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Chapter 1:

Introduction
In this chapter...


DesignPro Form Editor Overview



What’s New in DesignPro Form Editor?



Associated DesignPro Applications



About This Guide



Conventions



Getting the Answers You Need

This guide provides both background and procedural information for using DesignPro
Form Editor. Because business requirements and user preferences can vary for each
company, the material contained herein should be viewed as a general guide only.
As you step through the material, please remember that your specific business needs will
govern selection of the options and preferences described. Similarly, certain selections
will require that some tasks be repeated, while other selections will allow you to omit
tasks entirely.

DesignPro Form Editor Overview
Form Editor creates static forms containing objects such as lines, boxes, text, images, and
barcodes. These static forms are then merged with variable data for printing on high-speed
Xerox laser printers.
Using Form Editor, you can see each static form object as it is created, and generate proofs
using an optional desktop printer. You can then compile the forms on your PC, thus
freeing your printer from these tasks.
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Variable data from a credit card application becomes far more meaningful when merged
with a static form created by using Form Editor:

The image above shows variable data merged with a static form. The Account # and
Account Balance are the variable data in this example.

What’s New in DesignPro Form Editor?
Form Editor 3.00 introduces new and advanced features that help you create your
resources and provides different options for creating forms. The sections below briefly
explain the features:
Unicode Support
Form Editor 3.00 provides support for adding Chinese, Japanese, and Korean CJK texts.
User Interface
Improved object handling and movement in the Design Area. You can move objects using
the arrow keys on the keyboard, and view multiple forms opened in the workspace using
tabs in the Design Area.
Fonts and Font Lists
Multiple fonts can now be added to the font list in one step. The font list is also easier to
read with font names indicating their orientation.
Auto Refresh Manage Window
Manage window automatically refreshes so that only active resources display in the
Manage window.
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Associated DesignPro Applications
DesignPro Tools for Xerox employs the following four integrated applications to provide
advanced functionality for designing forms. Each application helps you create or modify
one or more of these necessary resources in a simple environment.
Following are the DesignPro Tools for Xerox applications:


DesignPro Manager: a Windows-based desktop program for managing and
converting resources to multiple supported formats. You can also open other
DesignPro Tools applications using the Manager.



DesignPro Form Editor: an advanced form design tool used to create and edit
forms for Xerox printers.



DesignPro Font Editor: a complete font design application used for creating and
editing Xerox raster fonts, as well as Elixir and PCL fonts. You can also open True
Type fonts in this editor.



DesignPro Graphics Editor: a full service bitmap editor providing various
transformations and commands for tiling graphics into raster fonts.

About This Guide
The DesignPro Tools Form Editor for Xerox User Guide provides definitions and step-bystep instructions to help you create forms and use the various tools and commands for
creating various objects.
The guide is organized to mimic the form creation process. From the basic form creation
to editing forms, each chapter describes tasks in the same order you can use when
planning your forms:
Chapter 1: Introduction
Introduces Form Editor. Also introduces this manual and identifies resources for finding
answers and contacting Customer Support.
Chapter 2: The Form Editor Environment
Describes the Form Editor workspace. Included are instructions for customizing Form
Editor menus and toolbars.
Chapter 3: Form Basics
Explains basic operations of Form Editor, including creating, opening, and merging form
groups. Instructions on how to use the Form Template feature are also provided in this
chapter.

Chapter 1: Introduction

15

Chapter 4: Resources and Formats
Provides information about assembling, managing, and converting resources required by
forms, and specifying file format settings. Included are instructions for selecting profiles,
specifying application-level and document-level settings for Form Editor resources.
Chapter 5: Drawing Tools
Explains how to use drawing tools in Form Editor and perform associated operations.
Chapter 6: Colors and Patterns
Describes how to apply colors and patterns to enhance the appearance of objects.
Chapter 7: Using Text
Explains how to enter text and modify text properties. Also describes the associated
operations for editing, importing, joining, splitting, finding, replacing text, and changing
the text color.
Chapter 8: Fonts and Font Lists
Provides information on how to select, add, and replace fonts and font lists. Included are
instructions on adding special characters.
Chapter 9: Using Elixir PrintDriver Pro
Explains how to use Elixir PrintDriver Pro to generate print files. Information on how to
transfer files to a Xerox printer is also provided.
Chapter 10: Active Objects
Provides information on active objects, their properties and how to create a PDF file in the
Form Editor.
Chapter 11: Data Tagging
Introduces the data tagging feature. Included are instructions for adding tags to form and
merging tags with data. Information on DAT files and associated functions and features is
also provided.
Chapter 12: Editing Forms
Describes the basic operations for editing/modifying forms and objects.
Appendix A: Workspace Quick Reference
Provides information on Form Editor workspace environment menus, toolbars and
keyboard shortcuts.
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Appendix B: Sample Forms
Gives a sample set of steps you can follow to create a form. Links to user guide tasks are
provided for more detailed information.
Appendix C: Glossary
Alphabetical listing of product-specific or unique terms and abbreviations used in this
guide.

Who Should Use this Guide?
This guide assumes you are already familiar with Microsoft Windows operations, printer
and font management operations and PC peripherals. You should also have access to
reference manuals for PC software and hardware, including any printers you are using for
the design and print process.

Related Guides
If you require further information about a specific topic or wish to obtain product
background information, reference the following resources, all of these resources are part
of the DesignPro Tools for Xerox documentation package:

DesignPro Tools for Xerox Getting Started Guide



DesignPro Tools Manager for Xerox User Guide



DesignPro Tools Font Editor for Xerox User Guide



DesignPro Tools Graphics Editor for Xerox User Guide



DesignPro Tools for Xerox Migration User Guide

Chapter 1: Introduction
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Conventions
Elixir products adhere to Microsoft Windows conventions for using menus, menu
commands, dialogs, command buttons, icons and mouse. See your Windows manual for
more information.
This guide uses the following typographic and symbolic conventions to identify special
information.


Typographic Conventions



Symbolic Conventions

Typographic Conventions
Following typographic conventions are used in this guide:

Convention

Information Type/Example

Bold type

Text for you to enter.
Field names, windows, toolbars, buttons and workspace
areas within a task step.
Example: select an item from the List of Used Fonts.
Example: click the Options tab.
Example: enter LPT1 for the following option.
Example: select the Text tool.
Example: click OK to save settings.

Italic type

References to other documents and books.
Example: refer to the DesignPro Tools Manager for
Xerox User Guide.
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Symbolic Conventions
Look for the following symbols as you read through this guide to identify special
information.

The Note symbol calls your attention to additional information.

The Tip symbol highlights a helpful tip.

The Shortcut symbol calls your attention to an easier way of accomplishing a
task.

The Warning symbol warns you of problems you might encounter.

The Migrating Users symbol provides notes and tips for anyone migrating from
a previous version of Opus.

Chapter 1: Introduction
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The Question symbol refers you to the Online Help for more information.
To open Online Help:


From the Help menu, select Contents, or



Click

in an open dialog.

Getting the Answers You Need
Elixir Technologies provides the following resources to help you learn and use Form
Editor:


Customer Support (page 20)



Elixir Web Site Support (page 21)



Elixir Training (page 21)



Product Help (page 22)



Release Notes (page 22)

Customer Support
If you purchased this product directly from Elixir Technologies, you can contact the
Customer Support Center for your region at the number or e mail address listed below.
If you have purchased this product from some other source, please contact the
authorized support representative from that source. Elixir provides customer
support for products purchased directly from Elixir.

North and South America:
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+1 805 641 5900 ext. 3
Monday - Friday, 7:00 am to 4:00 pm Pacific Standard Time; if closed, press 2 to
reach Elixir’s extended Support coverage.



ELX_support@elixir.com

DesignPro Tools Form Editor® for Xerox User Guide

Asia Pacific:


Asia_support@elixir.com

Europe:


+44 (0) 207 993-4811
Monday - Friday, 6:00 am to 4:00 pm Central European Time



+1 805 641 5900 ext. 3
Monday - Friday, 4:00 pm to 2:00 am Central European Time



Europe_support@elixir.com

An Elixir product specialist will take your call and ask for the following information:


Your name, organization, telephone number, and address.



Elixir product name and version number.



A complete description of the problem, including any error messages displayed on
your monitor or printed.

Elixir Web Site Support
You can obtain product support from the Elixir web page at www.elixir.com.
Select Support to:


Ask a question of Elixir Support.



Download the latest Product Releases and Patches.



View the latest product Release Notes.



Sign up for an Elixir Learning Program.



Renew your license product license.

Elixir Training
Elixir Technologies offers training for its full range of Windows-based products. For more
information, contact Elixir Learning at +1 805 641 5900 ext. 4.

Chapter 1: Introduction
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Product Help
Elixir software provides Online Help for all product functions and contains step-by-step
procedures that you can follow as you work:


Context-Sensitive Help can be activated from within the software for certain
dialogs by clicking



in the top right corner of a dialog.

Online Help can be opened from the Help menu by selecting Contents. You can
also open the Online Help contents by clicking
pressing F1 from the keyboard.

on the Standard toolbar, or by

Release Notes
Release Notes display at the start of product installation so you can review them before
beginning the installation process. Once installation completes, you can access Release
Notes from the product CD at drive:\Relnotes. There are two formats of the Release Notes
file: Relnotes.pdf and Relnotes.txt. The TXT file can be viewed using either Notepad or
WordPad. The PDF file can be viewed using Acrobat Reader. The TXT file can be viewed
using either Notepad or WordPad.
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Chapter 2:

The Form Editor
Environment
In this chapter...


Opening Form Editor



What’s in the Workspace?



Workspace Tools



Basic Workspace Functions



Opening Other DesignPro Applications from Form Editor

Opening Form Editor
To open Form Editor, from the Start menu, select All Programs, Elixir Applications,
DesignPro Tools, DesignPro Form Editor.

What’s in the Workspace?
The workspace is where the application objects are created and maintained. The Form
Editor workspace contains the following windows depending on which objects you want
to have open:


Design Area (page 24)



Manage window (page 25)



Messages window (page 29)



Toolbox (page 34)

When you start Form Editor, the blank workspace and the Messages window displays.
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The following illustration identifies each part of the Form Editor workspace when all
components are open:
Title bar

Menu

Toolbars

Design Area provides visual
display of application objects.

Manage window
provides Resource
Manager and other
object views.

Design Area tabs to switch
between different views.
Messages window
Status bar

The Form Editor Workspace.
You can customize the position and size of the windows per your requirements. The
workspace windows can be displayed as either floating or docked, and can also be hidden
from view.

Design Area
The Design Area provides a visual representation of the active form. You can use the
Design Area to add the drawing objects, images, and fonts and specify their properties.
You can scroll through the Design Area vertically and horizontally using the scroll bars.
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Manage window
Manage window provides quick access to all resources and objects used on your form.
You can also review and modify an object or associated properties using the Manage
window.
The Manage window is located on the right of the Design Area. You can view/hide the
Manage window by selecting from View, Manage window. You can also drag and drop
the Manage window at any position in the Design Area.
The Manage window consists of various tabs, where each tab represents a resource or an
object type (such as radio buttons). You can select the required tab to review or edit a
resource or object. For more information on managing resource objects using the Manage
window, see “Managing Resource Objects” on page 84 in Chapter 4: Resources and
Formats.

Changes made to the objects in the Manage window will also be reflected in the
Design Area.

The Manage window includes the following tabs:
Tag Structure tab
The Tag Structure tab is used by DocuTag users for creating and managing forms using
tags. The Tag Structure tab displays the document Tag Structure. Tags can be either
embedded or linked.

Manage window displaying the Tag Structure tab.

Chapter 2: The Form Editor Environment
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Tags display as child nodes under the Tag Structure root node. Right-clicking the root
node lets you create and/or delete a tag. You can create a tag by right-clicking the required
tag node. Once created, you can copy or move a tag to the other tag. You can also delete a
tag and access tag property dialogs.
Object Type View tab
The Object Type View tab displays all of the objects added to the form in the Design Area.
Objects are grouped together according to type. You can select an object in the Design
Area by clicking its respective node. This allows easy access to the required object when
there are several objects in the Design Area. You can also right-click an object node to edit
associated properties and/or delete the object.

Manage window displaying the Object Type View tab.
Resource Manager tab
The Resource Manager tab displays a tree structure of the various types of fonts, palettes,
images, and barcodes used within the application, as well as the number of times each of
these resources is used. This number is referred to as the usage of a resource. You can also
reload, embed, export, and remove unused resources. If you delete one instance of a
resource usage, the Manage window will automatically refresh to display the new usage
value of the resource. However, if a resource usage reaches zero, the resource is deleted
from the Resource Manager tab. This is true for all resources with the exception of fonts,
in which case the usage will display as ‘0’.
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For more information on managing resources using the Manage window, refer to the
“Managing Resource Objects” on page 84 in Chapter 4: Resources and Formats.

Manage window displaying the Resource Manager tab.
Radio Buttons tab
The Radio Buttons tab displays the tree structure for radio buttons that are inserted in a
form. In this tab, you can view the radio buttons in a group. Right-clicking the selected
radio button enables you to edit associated properties and/or delete the button.

Manage window displaying the Radio Buttons tab.
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DAT File tab
The DAT File tab displays the DAT file tree structure. A DAT file is an ASCII text file
containing form references and additional script commands for composing data streams.
You can also insert commands, and open and delete forms from the DAT file using the
DAT File tab. For more information on working with DAT files, see Chapter 11: “Data
Tagging” on page 239.
DAT file conversion provides an output data stream for proofing and printing. Forms
referenced in the DAT file are converted to the selected output format and embedded in
the data stream file. You can convert a DAT file into the required format using Manager.
For more information on conversions, refer to the DesignPro Tools Manager for Xerox
User Guide.

Manage window displaying the DAT File tab.
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Messages window
The Messages window is located at the bottom of the workspace by default. It displays the
processing/compilation errors, warnings, and informational messages generated by the
application in red, blue, and black text respectively. You can close the Messages window
from the menu by selecting View, Messages to allow more space to work.
You can also press Ctrl + Shift + M to view or hide the Messages window.
However, the Messages window will automatically re-display whenever a
message is generated by the application.

To view messages in the Messages window, select Properties from the File
menu. The Options dialog displays. From the Application node, select the
General category and check Send All Messages to Window.

Clearing Messages
To clear the messages generated by the application, right click in the Messages window
and select Clear from the pop-up menu.

You can also clear messages in this window by pressing Ctrl + D on the
keyboard.

To close the Messages window, from the View menu, select Messages. You can
also click at the upper-right corner of the Messages window. However, the
window will automatically re-display whenever a message is generated by the
application.
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Copying Messages
To copy the messages generated by the application:

1

Select the required messages in the Messages window.

2

Right-click the selected messages and select Copy Messages from the pop-up menu.
The selected messages copy to the clipboard and you can paste them wherever
required.

You can also copy messages from this window by selecting the required messages
and pressing Ctrl + C on the keyboard.

Logging Messages
Logging options allow you to save the information displayed in the Messages window in a
text file.
To log the generated messages:

1

From the Tools menu, select Options.
The Options dialog displays.

You can also open the same Options dialog by selecting File, Properties from
the menu.

2

From the Application node, select the Messages category, and check Log to File.
This writes messages to the log file.

Options set at the application level are applicable globally for all forms created in
the application.
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3

In the entry box adjacent to Log to File, enter the destination path for the log file.

The default value of “.\” saves the log file in the same directory as the resource
file.

4

Enter the name of the log file in the next entry box, as shown below.

The default log file name is “MSG.log”. You can also change the file name and then
save it.

5

Check Unicode to create the log file using the Unicode character set.

6

Specify the settings of your choice:
 Overwrite: overwrites any existing log file messages.
 Append: appends messages to the existing log file.
 Append by Date: appends messages to the log file by date.
You can view the log file at any time by clicking View Log File. The contents of
the log file (with the name and location entered in the Log to File entry boxes)
display in a Notepad window.

7

Click Apply, and then click OK.
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Displaying Message Time and Date
You can also display the time and date when a message was generated in the Messages
window.
To display message time:

1

From the Tools menu, select Options.
The Options dialog displays.

2

From the Application node, select the Messages category.

3

Under the Messages to View area, check Information to display informational
messages in the Messages window.

4

Under the Show area, check Message Time to display the message generation time
in the Messages window.

5

Under the Show area, check Message Date in order to display the message
generation time in the Messages window.

6

Click Apply and then click OK.

Color Coding Messages
Messages can also be color coded according to the nature of the message. Color coding is
added using colored boxes before the messages. Error messages display red boxes,
warnings display blue boxes, and informational messages display neither. With color
coding, critical messages can be located quickly.
To color code messages:
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1

From the Tools menu, select Options.
The Options dialog displays.

2

From the Application node, select the Messages category.

3

Under the Messages to View area, check Information to display informational
messages in the Messages window.
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4

In the Show area, check Use Color to display colored boxes in the Messages
window.
Message Generation Date
Message Generation Time

Color identifying
message type

Message Text

The Messages window showing the color-coded messages.

5

Click Apply and then click OK.
You can also set the number of maximum lines displaying in the Messages
window by entering the number in the Lines Maximum entry box, provided in
the Show area.
If the number of messages generated exceeds the value specified in the Lines
Maximum entry box, the new messages overwrite the existing ones from the
top in the Messages window. If Log to File is checked, messages are
overwritten from the top of the log file.
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Toolbox
The toolbox displays options associated with the tools available in the Tools toolbar.
When a tool is selected from the Tools toolbar, the toolbox directly above the Design Area
updates with options related to the selected tool.
The toolbox lets you copy and move objects in the Design Area. It provides options for
moving and making multiple copies of objects. For more information on copying and
moving objects, see Chapter 12: “Editing Forms” on page 263.
In addition, the toolbox provides options for drawing and adding various objects such as
lines, boxes, active objects and barcodes to enhance the appearance of the forms.


For information on drawing objects, see Chapter 5: “Drawing Tools” on page 103.



For information on text objects, see Chapter 7: “Using Text” on page 145.



For information on active objects, see Chapter 10: “Active Objects” on page 217.

Workspace Tools
Form Editor provides toolbars for easy access to the most commonly used application
commands. You can perform standard Windows operations to hide or display a toolbar, or
dock a toolbar at the edge of the workspace.

Menus
A menu with drop-down menus displays directly below the application title bar. These
drop-down menus provide both standard MS-Windows and application-specific options.
Selecting a menu performs an associated action or displays a submenu or a dialog. For a
complete list of all menu commands, see “Menu ” on page 289.
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Toolbars
Directly below the menu are the toolbars with buttons that provide access to the most
commonly used commands and tools. You can hide or display toolbars from the View
menu by selecting Toolbars, required toolbar.

To add or remove more buttons on a toolbar, see “Adding Buttons to

Toolbars” on page 39.

To view or hide a toolbar, see “Customizing Toolbar Display” on page 37.

Tools Toolbar
The Tools toolbar lets you add drawing objects, images, barcodes and images to the form.
When you click a tool on the Tools toolbar, a corresponding toolbox opens above the
Design Area. The toolbox displays options specific to the tool selected. Click another tool,
and a new toolbox replaces the previous selection. For details, refer to “Form Design
Tools” on page 303.

Standard Toolbar
The Standard toolbar provides one-click access to the basic File and Edit menu
commands such as saving or printing a file. For details, refer to “Standard Toolbar” on
page 298.
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Zoom Toolbar
The Zoom toolbar provides shortcuts to workspace viewing commands (basic viewing
commands are also available in the View menu). For details, refer to “Zoom Toolbar” on
page 299.

Position and Dimension Toolbar
The Position and Dimension toolbar is used for editing the start co-ordinates and
dimension operations for an object. For details, refer to “Position and Dimension Toolbar”
on page 300.

You cannot add or remove buttons from the Position and Dimension toolbar.

Common Attributes Toolbar
The Common Attributes toolbar is used for setting common object properties such as
color, line style and thickness. For more information on common object properties, see
Chapter 12: “Editing Forms” on page 263. For details on the toolbar, refer to “Common
Attributes Toolbar” on page 300.
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Filter Toolbar
The Filter toolbar provides quick access to the filter options provided in Form Editor. You
can use the Filter toolbar commands to exclude specified objects in the Design Area from
editing functions, such as moving or deleting. For details, refer to “Filter Toolbar” on page
301

Form Template Toolbar
The Form Template toolbar provides quick access to commands related to opening and
removing form templates. For more information on using form templates, see the “Form
Templates” on page 71 in Chapter 3: Form Basics. For details on the toolbar, refer to
“Form Template Toolbar” on page 302

Customizing Toolbar Display
You can also specify the toolbars that display in the workspace.
To customize Form Editor toolbars:

1

From the View menu, select Toolbars, Customize to display the Customize dialog.

2

Click the Toolbars tab.

3

Check the toolbars you want to display in the workspace from the list of available
toolbars.
The selected toolbar name displays in the Toolbar Name entry box.

You cannot uncheck Menu Bar from the list of toolbars.
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4

To set the appearance of the displayed toolbars, specify the following:
 Show Tooltips: displays the tool tips associated with the toolbar buttons.
 Cool Look: displays the toolbar buttons in the smooth look mode.
 Large Buttons: displays the toolbar buttons in the enlarged mode.
 Reset/Delete: resets a default toolbar to the default settings. This button toggles
to Delete to delete a custom toolbar.

5

Click OK and return to the application window.

You can also display a toolbar from the View menu by selecting Toolbars,
Toolbar name.

Creating a New Toolbar
You can also create a new toolbar for your Form Editor workspace with command buttons
of your own choice.
To create a new toolbar:

1

From the View menu, select Toolbars, Customize to display the Customize dialog.

2

Click the Toolbars tab.

3

Click New to display the New Toolbar dialog.

4

In the Toolbar Name entry box, enter the name of the new toolbar.
You can modify this name later in the Toolbars tab.

The names of the default toolbars are not editable.

5
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Click OK.
The new toolbar displays in the workspace. The new toolbar is currently empty. To
add buttons to this toolbar, see “Adding Buttons to Toolbars” on page 39.
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Adding Buttons to Toolbars
To add buttons to a toolbar:

1

From the View menu, select Toolbars, Customize to display the Customize dialog.

2

Click the Command tab.
The list of available command groups displays in the Categories list. When a
command group is selected in the Categories list, the buttons for each command in
the group display in the Buttons area.

3

Click and drag the required button to any target toolbar displaying in the Design
Area, then release the mouse.
While dragging the required button, the mouse cursor changes from
to
.
The selected button is then added to the required toolbar at the specified place.
If you drag the required button and drop it anywhere in the application window
other than the target toolbar, Form Editor automatically creates a new toolbar
with the specified button and displays it in the application window. If you then
click the Toolbars tab, the newly created toolbar name (default is Toolbar 1)
displays in the Toolbars list.

4

Click Apply and OK.
The added buttons display in the selected toolbars.

Status Bar
The Status bar displays along the lower edge of the Design Area. When you move the
mouse pointer over the Design Area, Status bar shows information corresponding to the
mouse location.

Status bar displaying the coordinates of the mouse pointer.
You can read tool tips for menu commands and toolbar buttons by moving the mouse
pointer on the required item. These are shown in the left side pane of the Status bar.

Status bar displaying Tooltip of the Print button.
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When an object is being drawn in the Design Area, the Status bar displays the tooltip of
the object being drawn along with the height, width, and coordinates of the mouse pointer.
The unit of measurement used for coordinates is the same as the ruler unit.These
coordinates help you draw objects within a specific range in the Design Area. The object
type and position are also displayed in the Status bar when the mouse pointer is placed
over it.

Status bar displays the object type, height, and width.

Ruler
Form Editor provides horizontal and vertical rulers which help place an object accurately
in the Design Area. Rulers display along the top and left sides of the Design Area. When
you move an object or cursor in the Design Area, lines indicating the object or cursor
position appear on the rulers. You can show or hide the rulers and change the unit of
measurement used in the rulers.

Displaying and Hiding the Ruler
To view/hide the ruler: From the View menu, select Ruler.

You can also activate the ruler by clicking
pressing F2 on the keyboard.

on the Zoom toolbar or

Changing the Ruler Position
The horizontal and vertical graphical rulers are placed at the top and left sides of the
Design Area by default. Form Editor lets reposition the horizontal and the vertical rulers
individually.

1

Select Tools, Options from the menu to open the Options dialog.

You can also open the same Options dialog by selecting File, Properties from
the menu.

2
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In the Options dialog, select the Ruler category under the Page node.
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3

Under the Horizontal area, check Position on Bottom to reposition the horizontal
ruler to the bottom of the Design Area.

4

Under the Vertical area, check Position on Right to reposition the vertical ruler to
the right of the Design Area.

5

Click Apply, and then OK to return to the workspace.

Changing a rulers position can only be activated at the page level. When a new
form is opened, the ruler settings will be reset to default.

Changing the Unit of Measurement
You can also change the unit of measurement used for the horizontal and vertical rulers.
This change is applied to both the horizontal and the vertical rulers, and to the digital ruler
as well.
To specify the required unit of measurement:

1

From the Tools menu, select Options.
The Options dialog displays.

2

From the Application node, select the Ruler category.

3

From the Units drop-down list, select the required unit and click OK.
The Design Area updates the rulers with the specified unit.

You can also set the unit of measurement at the page level only. To do this, select
the Ruler category under the Page node.

You can also select the required unit of measurement for the application from the
drop-down list for units available in the Zoom toolbar.
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Using Grid Settings for Ruler
The structure of the grid tool is determined by the values specified for sub-divisions and
the spacing between them. In order to keep the grid sub-divisions synchronous with the
ruler measurements, you can use the grid settings for the graphical and/or the digital ruler.
To use the grid settings for rulers:

1

Select Tools, Options from the menu to open the Options dialog.

2

Under the Application node, select the Ruler category.

3

Check the required option from the following:
 Use Grid Settings for Graphic Ruler: uses the grid units for both the horizontal
and vertical graphic rulers.
 Use Grid Settings for Digital Ruler: uses the grid units for the digital ruler.

4

Click OK.
The Design Area displays the rulers according to the grid settings. Refer to
“Specifying Grid Spacing” on page 46 for information on grid settings.

Changing the Zero Position of Rulers
The zero value on the horizontal graphic ruler is located at the left side of the Design Area,
with all of the positive measurement values incrementing towards the right side. Similarly,
on the vertical ruler, the zero is located at the top, with all of the positive measurement
values incrementing towards the bottom of the Design Area. If required, you can alter this
default arrangement of the zero position on either of the rulers.
To change the default position of zero on the rulers:
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1

Select Tools, Options from the menu to open the Options dialog.

2

In the Options dialog, select the Ruler category under the Page node.

3

Specify the following:
 Under the Horizontal area, select Right as the Zero Position to reposition the
zero on the horizontal ruler to the right side of the page.
 Under the Vertical area, select Bottom as the Zero Position to reposition the
zero on the vertical ruler at the bottom.

4

Click Apply, and then OK to return to the application window.
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Changing the Position of Measurement Values
To change the position of measurement values on a graphic ruler:

1

Select Tools, Options from the menu to display the Options dialog.

2

Select the Ruler category under the Page node.

3

Specify the following:
 Under the Horizontal area, check Positive Values to Left to display the positive
measurement values on the left of the zero.
 Under the Vertical area, check Positive Values to Top to display the positive
measurement values on the top of the zero.

4

Click Apply, and then OK to return to the application window.
The zero of the horizontal ruler is set to be
positioned on the right-side of the ruler.

The vertical ruler is set to be positioned
on the right side of the Design Area.

Both the rulers display negative values in the Design
Area. The positive values are towards the left and top
of the horizontal and vertical rulers zero values.

The image above illustrates the different arrangements of graphical rulers.
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You can also shift the zero on a ruler by specifying the required shift value in the
Zero offset entry box. For the horizontal ruler, a negative value will shift the
zero towards left and a positive value will shift it towards right. Similarly, for a
vertical ruler, a negative value causes the zero to shift up and a positive value
shifts it down.

Grid
The grid feature provides a network of intersecting lines that help in aligning and placing
objects in the Design Area. These lines help in the design process, but are not part of the
design. Using Form Editor, you can specify major grid spacing, as well as the number of
subdivisions within each major grid division in both vertical and horizontal directions.
Also, objects can be set to automatically align with grid coordinates for rapid document
design.

Displaying and Hiding the Grid
To display/hide the grid in the Design Area:

1

From the Tools menu, select Options.
The Options dialog displays.

You can also open the same Options dialog by selecting File, Properties from
the menu.

2

From the Application node, select the Grid category.

Displaying and hiding the grid can only be set at the application level. Once
activated, the grid will display every time a form is opened.
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3

Check Show Grid to display the grid.
You can also activate the grid by using one of the following methods:


Selecting View, Grid from the menu.



Clicking
on the Zoom toolbar
Pressing F4 on the keyboard.



4

Check the required options from the following:
 Hide Major Spacing (+): hides the appearance of the major spacing symbol (+)
in the Design Area.
 Hide Subdivisions (.): hides the appearance of the subdivision symbol (.) in the
Design Area.

5

Click Apply, and then OK to return to the application window.

Automatically Aligning Objects to the Grid
Form Editor lets you automatically align objects to the grid by providing the snap to gird
feature. Snapping offers a way of precisely placing an object on the Design Area by
having the object attach itself to the intersection of grid lines.
To turn on the snap to grid feature:

1

From the Tools menu, select Options.
The Options dialog displays.

2

From the Application node, select the Grid category.

This feature can only be activated at the application level. Options set at the
application level are applicable globally for all forms created in the application.

3

Check Snap to Grid and click OK.
The snapping feature will be activated.
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4

According to your required precision for placing an object, select one of the
following:
 Full Grid: snaps an object to the next nearest subdivision.
 Half Grid: snaps an object to a point at half of the next nearest subdivision.

5

Click Apply, and then OK to return to the application window.

You can also turn snap to the grid on or off by clicking
on the Zoom
toolbar. You can use the same method to turn snap to grid off.

Specifying Grid Spacing
Form Editor lets you customize the spacing between the grid points as per the specified
unit of measurement. Setting the grid spacing helps place the objects in accordance with
the grid lines. For example, if you want to place text objects vertically at a distance of 0.5
inches with each other, you can set the spacing to 0.5 inches.
To specify the grid spacing:

1

From the Tools menu, select Options.
The Options dialog displays.

2

From the Page node, select the Grid category.

Options set at the page level are activated for the active form only; Page level
settings applied to active form override the application level settings.

3

46

In both the Horizontal and Vertical areas, specify Major Spacing.
This option specifies the space between the horizontal or vertical grid lines, per
specified unit of measurement (default is 1 inch). It is represented by the symbol (+)
in the Design Area.

DesignPro Tools Form Editor® for Xerox User Guide

4

In both the Horizontal and Vertical areas, specify the Number of Subdivisions.
This specifies the number of divisions that are displayed between the horizontal or
vertical grid lines. The divisions are represented by dots in the Design Area.
Form Editor successfully handles forms (ELX and EFR) that have invalid grid
spacing values i.e., if you specify a 0 grid value in a form, the following message is
displayed "<filename>.elx contains an invalid grid spacing value 0. Changed to 1."

5

Click Apply, and then OK to return to the application window.
The grid displays, as per the specified spacing value.

Setting the grid spacing helps place the objects in accordance with the grid lines. For
example, if you want to place text objects vertically at a distance of 0.5 inches with each
other, you can set the spacing to 0.5 inches.
Similarly, you can specify default grid spacing by selecting the Grid category from
the Application node in step 2. This sets the grid spacing at the application
level which will be applicable to all forms.

Guides
Guides are horizontal and vertical lines that you can drag from the rulers onto the Design
Area. You can display, hide, and remove the guides. You can also set a radius for the
guides, and snap objects to the guides. These are used as visual aids when placing objects
and do not display while previewing or printing the form.
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Turning the Guides On and Off
To display/hide guides in the Design Area:

1

From the Tools menu, select Options.
The Options dialog displays.

You can also open the same Options dialog by selecting File, Properties from
the menu.

2

From the Application node, select the Guidelines category.

3

Check or uncheck Show Guidelines.

4

Click OK.
The Guides will appear in the Design Area.
You can also activate guides by using one of the following methods:


Selecting Guidelines from the View menu.

or


Clicking

on the Zoom toolbar

or


Pressing F6 on the keyboard.

Moving Guides to the Design Area
When you turn on the guides feature, the guides do not display in the Design Area like the
ruler or the grids do. To view the horizontal guide, click at any point on the horizontal
ruler and drag the line to the required position in the Design Area. Similarly, to view the
Vertical guide, drag the line from any point on the vertical ruler to the required location in
the Design Area. You can drag as many horizontal and vertical guides as needed.

If the rulers are not displaying in the Design Area, you will have to turn them on
before using the guides feature.
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The image below illustrates the process of viewing guides in the Design Area.

2. Drag the guide to
the Design Area.

3. Drop the guide at
the required location.

1. Click on
the Ruler.

Viewing guides in the Design Area.
For placing a guide more precisely at a required location:

1

Open the Options dialog by selecting Tools, Options from the menu.

2

Under the Page node, select the Guidelines category.

3

From the Direction area, select either Horizontal or Vertical to specify the guide
direction.
The box underneath Guideline Position will display all guides with the specified
direction.

4

In the Guideline Position entry box, specify the required location for placing the
guide. Enter or select a value in inches.

5

Click Set to add the guide in the box underneath Guideline Position.
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6

Click Apply, and then OK to return to the application window.

Guides drawn on a form are only applicable to that form.

Removing Guides from the Design Area
To remove a guide from the Design Area:

1

From the File menu, select Properties.
The Options dialog displays.

2

From the Page node, select the Guidelines category.

3

From the Direction area, select either Horizontal or Vertical to specify the guide
direction.
The box underneath Guideline Position will display all guides with the specified
direction.

4

Select the required guide from the box underneath Guideline Position.
The Guideline Position entry box displays the position of the selected guide.

5

Click Clear.
The selected guide will be removed from the text area

To remove all guides with the specified direction, click Clear All.
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6

Click Clear.
The selected guide will be removed from the text area

7

Click OK.
The selected guide(s) will be removed from the Design Area.
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Aligning Objects to the Guides
Form Editor also provides a snap to guides feature for automatically aligning objects to
the guides. This allows you to place objects precisely in the Design Area.
To activate/deactivate the snap to guides feature every time you open an application:

1

From the Tools menu, select Options.
The Options dialog displays.

2

From the Application node, select the Guidelines category.

3

Check or uncheck Snap to Guidelines and click OK.

You can also activate/deactivate the snap to guides feature by clicking
the Zoom toolbar.

on

Snapping to guides takes precedence over snapping to the grid in places where
guides fall between the grid lines.

You can also set the distance up to which an object will snap to any guide.This
value is called the Magnetic Snap Radius and can be set in the Options
dialog. Under the Application node, select the Guidelines category and
specify a value in the Magnetic Snap Radius entry box.
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Crosshair
The Crosshair tool displays as a pair of lines intersecting at the cursor. These lines move
with the cursor and help in placing objects relative to each other in the Design Area. You
can also use the crosshair to assist in aligning objects visually, as shown below:

Using crosshair to verify the
alignment of objects visually.

The image above illustrates the use of Crosshair.

Displaying and Hiding the Crosshair
To display or hide the crosshair, select View, Crosshair from the menu.
You can also turn the crosshair on or off either by:


Clicking

on the Zoom toolbar.

or
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Pressing F8 on the keyboard.
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Basic Workspace Functions
The Form Editor workspace also has some basic functions to help you design your forms.

Moving Objects Using the Keyboard
Once an object is placed in the Design Area, you can move it anywhere within the Design
Area. To precisely place objects in the Design Area, you can also make use of the arrow
keys on the keyboard. To move an object using the keyboard:

1

Select the required object in the Design Area.

2

Press the appropriate arrow key to move the object in the required direction.

Zooming within the Design Area
To view the entire form on the screen, or to view just a particular area of your form at
higher magnification, you can use the zoom feature. Form Editor provides various options
for setting the magnification level.
To change the magnification level, from the View menu, select Zoom and then the
required option. The options are:


Zoom In: magnifies the entire Design Area view. You can also magnify the view by
on the Zoom toolbar.

clicking


Zoom Out: reduces the entire Design Area view. You can also zoom out of the view
by clicking

on the Zoom toolbar.



Zoom Page Width: scales the design view to fit the page width.



Zoom Whole Page: scales the design view to fit the entire page.

The Zoom sub-menu also provides options to zoom in or out using predefined values:
10%, 25%, 50%, 75%, 100%, 200%, 400% or 1000%.
You can also zoom in by selecting an object and then pressing plus (+) from the
number pad on the keyboard. To zoom out, press minus (-) from the number
pad.
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Specifying Custom Zoom Value
To zoom in or out of the Design Area to a specified custom value:

1

From the View menu, select Zoom, Custom.
The Zoom dialog displays.

2

In the Enter Zoom entry box, specify the required zoom percentage value.
You can either select the values available in the drop-down list or type a new value.

3

Click Zoom.

You can also specify a custom zoom value in the text box provided in the Zoom
Toolbar.

Using the Full Screen View
To display as much of your design as possible on the screen, you can switch to the fullscreen view. In this view, Form Editor removes most of the screen elements, such as the
menu, toolbars, and scroll bars. It only displays the Design Area, the Messages window,
and the Manage window.
To switch to the full screen view, from the View menu, select Full Screen.
To turn off the full-screen mode and switch to the previous view, click
on the Full
Screen toolbar, or press Esc on the keyboard. The Full Screen toolbar displays only in the
full-screen mode.

Using the Right-Click Menu
The right-click menu provides access to the most commonly used functions in Form
Editor. To use the right-click menu, position the cursor in the workspace and right-click
your mouse. A pop-up menu displays. This menu is context-sensitive and displays a list of
options depending on the object selected in the workspace. Select the required option from
the menu.
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Choosing Commands
A command instructs Form Editor to perform a specific action. You can choose a
command by either:


Clicking a toolbar button.



Selecting a menu option.



Using a hot key.



Using a shortcut key.

In the chapters that follow, command selection is described using the most common
method for the described task. However, any related command selection can be used to
accomplish the same instruction.

Working with Property Dialogs
You can review or edit the properties associated with a Form Editor object using its
respective property dialog. Object property dialogs behave as modal by default. The
changes you make in the properties of an object are applied to it only by clicking the
Apply or OK buttons on a modal dialog. Also, you cannot switch to another application
area unless you close a modal dialog. Form Editor lets you change the modal behavior of
dialogs to modeless. You can also customize the use of buttons in the property dialogs.
You can also set to open the property dialog for a object whenever it is created.
This helps in rapid form designing. To do so, open the Options dialog from the
Tools menu, and select Show Page Properties from the General category.

Chapter 2: The Form Editor Environment

55

Setting the Property Dialog Mode
To customize the behavior of the property dialog:
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1

From the File menu, select Properties.
The Options dialog displays.

2

From the Application node, select the General category.

3

Specify the following in the Property Dialog Mode area:
 Modal: displays all of the object properties dialogs as modal. With modal
dialogs, you cannot switch to another application area unless you close the
dialog. To view another dialog, close the current dialog, and then open another
dialog.
 Modeless: displays all of the object properties dialogs as modeless. With
modeless dialogs, you can switch to other application areas even if the dialog is
active. Switching from one object to another in the Design Area automatically
updates the properties dialog. The specified changes are applied only if the
Apply or the OK button is clicked, otherwise the object remains unchanged.
 Modeless without buttons: displays all of the object properties dialogs as
modeless and without the Apply, OK, and Cancel buttons. In modeless dialogs,
changes specified in the dialog are instantly applied to the selected object when
you switch to another application area. Switching from one object to another in
the Design Area also automatically updates the properties dialog.

4

Click Apply and OK to save the settings.
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Opening Other DesignPro Applications from
Form Editor
You can also open other applications from the Form Editor workspace whenever required.
To open an application, select the required application name from the Tools menu. The
options available are:


Resource Map
Elixir Resource Map provides an interactive and central location for defining,
editing, and deleting profile mappings of resources like fonts and characters for
separate profiles. These mappings generally depend on the specific architecture used
by the client. For more information, refer to Elixir Resource Map Online Help.



Resource Librarian
Elixir Resource Librarian lets you store and organize resources. The resources that
are to be used in forms must be added from the Elixir Resource Library to a central
For detailed information, refer to Elixir Resource Librarian Online Help.



Profile Editor
Profile is a system file used to save important file locations and information about
Elixir applications. Using the Elixir Profile Editor, you can customize the Elixir
applications to suit a particular user, workgroup, or enterprise by creating, selecting,
and modifying unique user profiles. For more information, refer to Profile Editor
Online Help.
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Chapter 3:

Form Basics
In this chapter...


Supported File Formats



Basic Form Operations



Form Groups



Form Templates

Supported File Formats
Form Editor opens and saves forms in the following input and output formats:
Input Formats (Open)


Elixir Form (EFR)



Elixir Legacy Form (ELX)



Elixir PrintDriver Form (EP)



Windows EMF (EMF)



Xerox Form Object (FRM)



Xerox Form Source (FSL)

Output Formats (Save As):


Elixir Form (EFR)



Elixir Legacy Form (ELX)



Image File (TIF; LP3; IMG; SEG)



PCL Page (PCL)



PDF Page (PDF)
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PostScript (PS)



VIPP Forms (VIP)



Xerox Form Object (FRM)



Xerox Form Source (FSL)

Basic Form Operations
You can open, create, and edit forms in the Design Area. Refer to the following tasks for
more information on:


Creating a Form (page 60)



Opening a Form (page 61)



Saving a Form (page 64)



Customizing the Form (page 66)

Creating a Form
To create a form, from the File menu, select New. A new blank form displays in the
Design Area. The form is separated from the horizontal and vertical rulers by a gray area.
When the Manage and Messages windows are open, the gray area is reduced to give
maximum form view in the Design Area.
You can add the following objects in the form to meet your specific requirements.


To add drawing objects, refer to Chapter 5: “Drawing Tools” (page 103).



To add text objects, refer to Chapter 7: “Using Text” (page 145).



To add active objects, see Chapter 10: “Active Objects” (page 217).

You can also create a form by clicking
pressing Ctrl + N.

on the Standard toolbar or by

If Show page properties is checked in the Application - General category
from the Options dialog, the Options dialog automatically displays whenever a
form is created.
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Opening a Form
To open an existing form:

1

From the File menu, select Open.
The Open dialog displays.

You can also click
form.

2

on the Standard toolbar or press Ctrl + O to open a

Select the required form and click Open.
A new blank form displays in the Design Area. If multiple forms are opened in Form
Editor, you can access them by clicking their respective tabs at the bottom of the
Design Area. The tabs are available in workbook mode only. Most tools and options
are only enabled if a form is open in the Design Area. For more information on the
available form types, refer to “Supported File Formats” on page 59.
When working with more than one forms at a time, you can set to display forms
in the workbook mode. To set the workbook mode, select Options from the
Tools menu. The Options dialog displays. From the Application node, select
the General category and check Workbook Mode.

Refer to the following tasks for more information on:


Opening an Elixir Form (page 62)



Opening Forms of an External Format (page 62)



Opening a Recently Used Form (page 63)
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Opening an Elixir Form
To open an Elixir form (EFR) file:

1

From the File menu, select Open.
The Open dialog displays.

2

From the Files of Type drop-down list, select Elixir Form (*.efr).
Only Elixir format files will display in the main window. Selecting Elixir in the left
pane of the dialog automatically updates the path to drive:\Elixir\Forms\Elixir, the
default profile’s directory for Elixir forms. For more information on the available
form types, refer to “Supported File Formats” on page 59.

3

Select the required form and click Open.
The selected form displays in the Design Area.

When opening Elixir Legacy (ELX) forms, the name and path of the file should
not exceed 65 characters.

Opening Forms of an External Format
To open a form of an external format:

1

From the File menu, select Open.
The Open dialog displays.

2

From the Files of Type drop-down list, select the required file type.
Only files of the specified format will display in the main window. Selecting Elixir in
the left pane of the dialog automatically updates the path to
drive:\Elixir\Forms\Form format, the default profile’s directory for the selected form
format. For more information on the available form types, refer to “Supported File
Formats” on page 59.

You can edit the required property settings by clicking either
or Edit
Property Settings in the Open dialog. You can also restore the default
settings by clicking either

or Restore Property Settings.

These options are only activated when a format other than Elixir Legacy
Form (*.efr) is selected from the Files of Type.
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For information on all the options available in the input (parser) property
dialog(s), refer to the Online Help. To open the Online Help, click
on the top right of an open dialog.

3

available

Select the required file and click Open.
The selected form displays in the Design Area.

\

A user with insufficient rights may receive a warning message on opening a file
that contains references to the mapping database. For more information, refer
to “Appendix A: Error and Warning Message” in DesignPro Tools Manager for
Xerox User Guide.

Opening a Recently Used Form
Form Editor maintains a list of recently created or used forms to help you keep track of the
frequently used files.
To open a recently used form, you can use one of the following methods:


From the File menu, select the required form.
The most recently used forms are displayed at the lower end of the File menu.

or


From the File menu, select Open. Select the required form from the History folder
in the left pane of the Open dialog and click OK.

The selected form displays.
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Saving a Form
Form Editor lets you save forms in different file formats (see “Supported File Formats” on
page 59). To save the form, select either Save or Save as from the File menu and specify
the required file type in the dialog that displays.

You can also click
form.

on the Standard toolbar or press Ctrl + S to save a

Refer to the following tasks for more information on:


Saving a Form to Elixir Format (page 64)



Saving Forms to External Format (page 65)

Saving a Form to Elixir Format
To save a form to the Elixir (EFR) format:

1

From the File menu, select Save or Save as.
The Save or Save as dialog displays.

2

In the File Name entry box, enter the file name.

3

From the Save as drop-down list, select Elixir Form (*.efr) and click Save.
The form is saved. Selecting Elixir in the left pane of the Save dialog automatically
updates the path to drive:\Elixir\Forms\Elixir, the default profile’s directory for
Elixir forms. For more information on the available form types, refer to “Supported
File Formats” on page 59.

When saving Elixir Legacy (ELX) forms, the name and path of the file should not
exceed 65 characters.

64

DesignPro Tools Form Editor® for Xerox User Guide

Saving Forms to External Format
To save a form to the external format:

1

From the File menu, select Save or Save as.
The Save as dialog displays.

2

Select the required file type from the Save as drop-down list.
For more information on the available form types, refer to “Supported File Formats”
on page 59. Selecting Elixir in the left pane of the dialog automatically updates the
path to drive:\Elixir\Forms\Form Format, the default profile’s directory for the
selected form format.

You can edit the required property settings by clicking either
or Edit
Property Settings in the Open dialog. You can also restore the default
settings by clicking either

or Restore Property Settings.

These options are only activated when a format other than Elixir Legacy
Form (*.efr) is selected from the Files of Type.

For information on all the options available in the output (converter) property
dialog(s), refer to the Online Help. To open the Online Help, click
on the top right of an open dialog.

3

available

Enter the file name in the File Name entry box and then click Save to return to the
Design Area.

When saving a form to Xerox Form Object (FRM), or Xerox Form Source (FSL),
make sure that all of the objects are placed within the boundaries of the page,
since the data outside the form boundaries will be lost.
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PostScript Language Level 1 does not support the Substitute Solid Color for
Shades option. When saving in PS format, if you set the Postscript language to
Level 1, the object will always print in solid color. However, the Substitute Solid
Color for Shades option is available in the Postscript Language Levels 2 and 3.
This option can be set by selecting Yes in the Color options of the Printer
properties category in the PostScript dialog; Selecting No will print the object in
the specified pattern.

Customizing the Form
Form properties define attributes for your form, such as its dimensions and orientation,
when designing a form. Refer to the following tasks for more information on:


Setting Form Dimensions (page 66)



Setting Form Orientation (page 67)



Applying Form Identification Settings (page 67)



Adding Comments (page 68)



Setting Form Offsets (page 69)



Adding Page Border (page 69)

Setting Form Dimensions
To set the dimensions of a form:

1

From the File menu, select Properties.
The Options dialog displays.

2

Under the Page node, select the Dimensions category.

3

In the Width and Height entry boxes, enter the required width and height of the
form, respectively.
To use a standard size, select the required size from the Size list.
Selecting a standard form size will reset values in the Width and Height entry
boxes. Similarly, Custom will be automatically selected from the Size list if the
values in either Width or Height entry boxes are changed.

4
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Click OK.
The dimensions of the form change to reflect the new settings.
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Setting Form Orientation
Form orientation defines the layout position of a form.
To set the orientation of a form:

1

From the Tools menu, select Options.
The Options dialog displays.

2

Under the Page node, select the Dimensions category.

3

In the Orientation area, select either Portrait or Landscape.

PORTRAIT

LANDSCAPE

The form on the left is using the portrait orientation, whereas the form on the right is
using the landscape orientation.

4

Click OK.

The orientation of the form changes to the selected one.

Applying Form Identification Settings
You can specify the identification details for every resource, such as the author, company
name, version number, revision number, ID, etc. You can also specify the document
creation date and time.
To set or view these options:

1

From the File menu, select Properties.
The Options dialog displays.

2

Under the Page node, select the General category.
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3

Specify the following:
 Page Author: specifies a unique name identifying the author.
 Made for: specifies a unique name identifying whom the form was made for.
 Page Version: specifies a form version identifier.
 Page Revision: specifies a form revision identifier.
 Local ID: specifies a unique code identifying the form.
 Time Stamp: specifies the form creation date and time.

4

Click OK.

The form identification settings are saved and can be viewed later.

Adding Comments
You can add comments to describe any form item or feature.
To add a comment:

1

From the File menu, select Properties.
The Options dialog displays.

2

Under the Page node, select the Comment category.

3

Enter comments in the Comment entry box.

4

Click OK.
The comment is saved.

To view comments, follow steps1and 2 above.
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Setting Form Offsets
You can also specify the horizontal and vertical offsets of the form. Offsets specify the
distance from a starting point where an object is placed. These internal offsets assist in
object placement on the form.
To set the offset in either horizontal or vertical directions:

1

From the Tools menu, select Options.
The Options dialog displays.

2

Under the Page node, select the Offset category.

3

In the Horizontal Offset and Vertical Offset entry boxes, specify the horizontal and
vertical Offsets, per specified unit of measurement.

4

Click OK.
The form offsets are saved.

Adding Page Border
Using Form Editor, you can also add a border to your form. Refer to the following image
for more information:
2. Check Show Page Border and
select the border color from the
drop-down list below.
1. From the
Application
node, select the
General
category.

3. Click OK. A Border of
the selected color is added
to the form.

The image above explains the steps involved in adding a border to the form.
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Form Groups
Form Editor lets you merge a form and several associated objects into the current form.
You can only merge objects that fit within the boundaries of the current form. Before using
this feature, make sure that there is sufficient space in the Design Area to prevent the
objects from overlapping or falling outside the boundaries of the form.
You can merge forms that are saved in the following formats:


Elixir Form (EFR)



Elixir Legacy Form (ELX)



Elixir PrintDriver Form (EP)



Windows EMF (EMF)



Xerox Form Object (FRM)



Xerox Form Source (FSL)

Merging a Form Group
To merge a form group:
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1

From the File menu, select Merge Form Group.
The Merge dialog displays.

2

Search for the required target folder.

3

Select the required form, and then click Open to open the selected form in the
application window.
The selected form and associated objects are merged with the current form.
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Saving a Form Group
You can save a form group as a form in the Elixir (EFR) format similar to saving
individual forms. For more information, see “Saving a Form” on page 64.

While saving the forms using the Save Form Group option, the default font is
not added to the forms.

Forms containing tags can be saved using the Save Form Group option.

Form Templates
A form template is a file that is used as a visual guide for designing a new form. The
template does not become part of the new form; only the new form elements are saved.
You can load more than one form template into the Design Area, which are saved in the
following formats:


Elixir Form (EFR)



Elixir Legacy Form (ELX)



Elixir PrintDriver Form (EP)



Windows EMF (EMF)



Xerox Form Object (FRM)



Xerox Form Source (FSL)
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Loading a Form Template
To load a form template:

1

From the File menu, select Load Form Template.
The Template Form dialog displays.

2

Search for the required target folder.

3

Select the required form template, and then click Open.
The selected template displays in the Design Area.

You can add multiple form templates to a single form.

Removing a Form Template
To remove a form template from the Design Area, select Remove Form Template from
the File menu. All form templates are removed from the Design Area.

Changing the Color of Template Objects
You can also change the color of template objects to help distinguish them from the form
objects.
From the Form Template
toolbar, select the required
color for the template objects.

The template objects change color
as specified.

The image above illustrates the steps involved in changing the color of template objects.
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Chapter 4:

Resources and
Formats
In this chapter...


Resources



Gathering Resources



Converting Form, Font and Image files to Xerox Format



Using the Resource Library



About User Profiles



File Formats

Resources
Form Editor supports the import and export functions, and the use of forms, fonts, images,
and barcodes in all Xerox formats, common PC font and image formats, and Elixir Legacy
formats.
You can convert resources in the Xerox format to the Elixir format using built-in parsers.
Before importing, you can specify appropriate conversion settings for resources. Once
imported, you can modify these resources and save them in Elixir or Xerox format using
appropriate converters. You can also change converter properties when saving your form
depending on the required results and printer settings.
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Gathering Resources
When creating forms, it is important to understand the formats supported by the
application. While creating a form, make sure that all of the required resources (fonts, and
graphics) are available. These resources can reside either on the local machine or on a
network drive. Along with Elixir and legacy resources, Form Editor also supports Xerox
resources without the need of any pre-conversion.
For more information on the supported resource formats refer to the follow:


Forms (page 74)



Images (page 75)



Fonts (page 75)

Forms

Input Formats

Output Formats

Elixir Form (EFR)

Elixir Form (EFR)

Elixir Legacy Form (ELX)

Elixir Legacy Form (ELX)

Elixir PrintDriver Form (EP)

PCL Page (PDF)

Windows EMF Form (EMF)

PDF Page (PCL)

Xerox Form Object (FRM)

Postscript (PS)

Xerox Form Source (FSL)

VIPP Forms (VIP)
Xerox Form Object (FRM)
Xerox Form Source (FSL)
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Images

Input Formats

Output Formats

Bitmap Files (BMP)

Bitmap Files (BMP)

Elixir Legacy Graphic (LP3) includes
Legacy and DesignPro Tools images;
both use the same extension.

Elixir Legacy Graphic (LP3)
Elixir Form (EFR)
Joint Photography Experts Group File
(JPEG, JPG)

Joint Photography Experts Group File
(JPEG, JPG)

PC Paintbrush Bitmap File (PCX)

PC Paintbrush Bitmap File (PCX)
Portable Network Graphics File (PNG)
Tagged Image Format File (TIF)
Xerox IMG (IMG)
Xerox LGO (LGO)

Portable Network Graphics File (PNG)
Tagged Image Format File (TIF)
Xerox IMG (IMG)
Xerox LGO (LGO)

Fonts

Input Formats

Output Formats

ATM Type1

Elixir Legacy Font (HDR)

ATM Type 3

PCL Font (FLJ; PCL)

Elixir Legacy Font (HDR) includes
Legacy and DesignPro Tools fonts;
both use the same extension.

PostScript Font (PS)
Xerox Font (FNT)

PCL Font (PCL, FLJ)
True Type Font
Xerox Font (FNT)
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Understanding the Elixir Directory Structure
The Elixir directory structure contains resource folders that are organized by the resource
types, i.e., Documents, Fonts, Forms, Graphics and Jobs. Each resource folder has sub
folders for the different formats they support. For example, to locate an Elixir form, you
need to go to the Elixir Folder, select the Forms folder, and then select the Elixir folder.
For information on navigating between the directory folders, refer to the DesignPro Tools
Manager for Xerox User Guide.
DesignPro Tools provides a separate folder for all resource types, and all of the resources
are placed in their default folders, however, you can change the location of the resources.
For more information on saving and opening forms, refer to Chapter 3: “Form Basics” on
page 59.

Copying Resources to the Appropriate Directory
After preparing the resources required for your form, you must save them in the
appropriate input directories. All of the used resources need to be located and defined so
that Form Editor knows where to look for them. You can also specify a local or network
path for these resources.
DesignPro Tools creates a default directory structure for the resources. For example, the
default destination directory for saving an Elixir form is drive:\Elixir\Form\Elixir. You can
also specify a local or network path for these resources. For details, refer to the DesignPro
Tools Manager for Xerox User Guide.
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Setting up the Resource Searching Order
A resource searching order lets you specify which resources should be opened if you have
multiple resource types with the same name. For example, if you have a Xerox and an
Elixir image with the same name, you can specify that the Xerox image should be used
(although the default Elixir resource searching order would use the Elixir image).
To set up a resource searching order:

1

From the Tools menu, select Application Format Setting, Elixir Properties.
The Elixir dialog displays.

2

Select the Resources category and do the following:
Setting up a Resource Searching Order:
1. Select the
required
converter from
the list of
available
converters.

The list displays the
resource searching order.

2. Click
to move the
selected converter to the
Resource Searching Order
box.

3. To create a resource searching order,
select the required converter from the
Resource Searching Order box and move
it using

and

on the right.

The image above illustrates the process of setting up a Resource Searching Order.
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You can reset the properties of a resource converter by selecting it from either
the Available Resource Converters list or from the Resource Searching
Order list and clicking Set Selected Converter. The associated dialog
displays. To set converter properties, see “File Format Properties” on page
95.

You can replace any missing resources with the default resources by checking
Replace Missing Resources with Defaults in the Elixir dialog.

3

Click OK.
The specified settings are saved.

Setting Page Caching Options
You can specify the maximum size of the virtual memory used in caching the resource
pages. Caching document pages enables faster page switching, which provides you the
ability to design complex documents more efficiently.
To set the caching options:

78

1

From the Tools menu, select Application Format Setting, Elixir Properties.
The Elixir dialog displays.

2

Select the Caching category.

3

In the Caching area, specify the number of pages to be kept in the memory in the
Cache Size entry box.
The cache size set as 0 indicates that an unlimited number of pages can be kept in the
memory.

4

In the Caching area, specify the maximum limit (in megabytes) of the available
virtual memory in the Virtual Memory Usage Limit entry box. This feature is
currently not functional.

5

Click Apply and OK.
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Creating Backups
Form Editor provides options for creating backup files and saving your work at specified
intervals. Creating backup files helps in data recovery in case the original file becomes
corrupted. Saving your work at specified intervals ensures that your work is saved if the
application is closed prematurely or accidentally.
To set the filing and auto save options:

1

From the File menu, select Properties.
The Options dialog displays.

2

From the Application node, select the Editor category.

3

Check Make Backup Files in the Filing Options area.
This activates the backup file creation feature for creating file backups (BAK). Both
the file and its backup are stored at the same location every time you save the file.
The backup files help in data recovery in case the original file gets corrupted.

4

Check Autosave in the Filing Options area.
This activates the auto-save feature to automatically save the file after the specified
time interval. Selecting this option activates the Interval entry box. You can type or
select the required interval value in minutes.

5

Click OK.
The specified filing options are saved.

Setting File Filtering Options
By default, you can only view Xerox or Elixir formats when saving or opening resources.
If you want to view all files in the selected directories, you can remove the file filters in
these dialogs.
To set the file filtering options:

1

From the File menu, select Properties.
The Options dialog displays.

2

In the Filing Options area, check All Files in Main File Selector.
All file formats are displayed in the Files of Type list of the Open and Save dialogs.
Unchecking this option will restrict access to Elixir and Xerox formats only.
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3

Click OK.
The specified file filtering options are saved.

Converting Form, Font and Image files to
Xerox Format
Prior to using any resources on a Xerox printer, all Elixir or other resource types need to
be converted to Xerox format. When converting resources to another format, make sure
that the correct naming conventions are followed. Refer to the DesignPro Tools Manager
for Xerox User Guide for more information about converting form, font, and image files to
Xerox resources. For more information about converting Elixir format forms to Xerox
format, refer to “Saving a Form” on page 64 in Chapter 3: Form Basics.

Using the Resource Library
The Elixir Resource Library is a structured repository for storing Elixir resources, where
the structure similar to the Windows file folder structure. The Resource library is an
interactive and central location for storing resources such as fonts, forms, and images.
These resources are normally used while creating documents; the types of resources used
depend on your client’s requirements or specific needs.
You can store multiple resource types in the Elixir Resource Library such as:


Fonts (including Character Sets)



Forms



Images



Palettes

Since resources are frequently required and used while creating forms, the Resource
Library helps you to:
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Gather the resources at one location in the form of a library.



Add and/or delete resources as required.



Import and export required resources.



Edit and view forms containing the resources.
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Elixir provides an application called the Elixir Resource Librarian for storing and
organizing resources. The resources that are to be used in forms must be added from the
Elixir Resource Library to a central location on your computer.
Resource libraries are not mandatory for Form Editor users, and are used to
speed up conversions when converting large numbers of resources for jobs run
from the command line. For detailed information on the Resource Librarian,
refer to Elixir Resource Librarian Online Help.

Resource Library Structure
In the Elixir Resource Library, library root is the default root folder that displays in the
Resource Library window. You can create sub-folders under the root folder and designate
resources to specified folders as required; this facilitates organizing the sub-folders that
contain the same resource type. Each folder is assigned a unique, user-defined name.
Whenever you require a resource from the Resource Library, you can specify the name of
the appropriate folder, and then locate the required resource.
Elixir Resource
Library Root Folder
Resource Folders

The Elixir Resource Library Structure.

The resources are stored in the Resource Library in an internal Elixir format.
Resource Libraries are stored as individual files with an ERC extension.

Refer to the following tasks for more information:


Importing Resources to a Resource Library (page 82)



Exporting Resources from a Resource Library (page 83)
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Importing Resources to a Resource Library
Using the Resource Library, you can set rules for importing resources to the Elixir
Resource Library, while opening a form or inserting a resource (font, image, etc.)
To set options for importing resources:
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1

From the Tools menu, select Application Format Setting, Elixir Properties.
The Elixir dialog displays.

2

From the Resource Library category, specify the appropriate option in the Rules
for Importing Resources to Libraries area:
 Do Not Import Resources: specifies that no resources can be imported to the
Elixir Resource Library.
 Import Missing Resources Only: imports only those resources that are missing
in the Elixir Resource Library.
 All Resources, Overwrite Any Existing: imports all resources and overwrites
any existing resources in the Resource Library that have the same name.
 All Resources, Prompt Before Overwriting: imports all resources and prompts
you for confirmation before overwriting any existing resources in the Resource
Library.

3

Click Apply and OK.
The specified settings are saved.
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Exporting Resources from a Resource Library
You can export resources from a Resource Library and add them to your form. For
example, you can export an image from a Resource Library as follows:
1. From the Tools toolbox,
select the resource type to
insert. The Open Resource
File dialog displays.

2. From the Files
of Type of dropdown list, select
Resource Library
(*.erc32, *.erc).

3. Using the Look in drop-down
list, select the target folder.

4. Select the
required library.

5. Click Open. A
dialog displaying
the library
structure appears.

6. Select the
required resource.
7. Click OK.

8. In the Design Area, click
where you want to insert the
resource.

The image above illustrates the steps involved to export an image from a Resource
Library.
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Managing Resource Objects
You can easily manage and view all of the resources used in your form using the Manage
window. You can also view the reference as well as the number of resource references in
your form.
To view and/or manage resources used on your form:

1

From the View menu, select Manage window.
The Manage window displays in the Design Area.

2

Right-click the Resource Manager tab.

Manage window - Resource Manager tab.
The Resource Manager tab is used to monitor embedded resource usage. Referenced
resources can only be embedded in Elixir format documents. This feature is particularly
useful when sharing or moving documents between multiple machines.
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3

Right-clicking a node displays a pop-up menu, which lists options pertaining to the
current selection.
The menu options are explained below:
 Reload: refreshes the Resource Manager tree view. You should always refresh
this view before performing any actions in the Resource Manager tab.
 Go to First Resource Reference: shifts the focus of the workspace (or the
Design Area) to the first instance of the resource in the Design Area.
 Embed Resource: embeds the selected referenced resource in the form.
 The Export Resource and Export all Resources options let you export one or
all embedded resources in the form. Export option selections open the Export To
dialog for selecting the required Elixir Resource Library file for saving the
exported resources.
 Remove Unused Resources: removes unused resource references from the
Resource Manager tree view, thus enabling you to view only those resources
that are used in the form. Any unused form resources display a count of zero. For
example, AR12NP [0] System Arial represents a font that is not used within a
current form.

Exporting embedded resources creates copies of the resources in a destination
resource library, however, exported resources remain embedded in the form.



Embed all Resources: embeds all of the referenced resources in a document.
The Manage window monitors the usage of the embedded resources. The
referenced resources can only be embedded in Elixir format documents. This
feature is particularly useful in sharing or moving documents between multiple
machines.

Verifying Resources
When creating a form, you can verify referenced and embedded resources by closing and
reopening your form. The Messages window displays resource path information and
errors encountered while previewing or opening your form. These messages help you to
determine and troubleshoot incorrect paths and corrupt resources within a form.
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Exporting Resources
When saving Xerox and Elixir Legacy forms, you can export external resources (such as
fonts, images, etc.) used in your form.
To access the export path settings and properties for external resources, from the Tools
menu, select Application Format Setting, Output Formats and select an appropriate
output converter from the list.
You can choose to save all or specific external resource types used in your form, and
specify associated export properties. For more information on output properties options,
refer to the Online Help.

To open the Online Help, click

available on the top right of an open dialog.

The following image shows the Xerox LPS Resource Writer dialog with the Fonts
category selected, which contains options for setting export properties.

In the Fonts subcategory, specify font
exporting properties.

Setting Xerox font export properties.
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The Export Fonts option lets you specify the font handling settings. When checked, this
option generates font files based on your settings. From the Font Encoding drop-down
list you can select System Code Page to convert Unicode characters belonging to system
code page; or else this option replaces the Unicode characters with the user defined
character (default). The Used Unicode Subset option lets you substitute the basic subset
(subset 0 - ASCII) with Xerox font set.
The font format options specify either 5 WORD to create Xerox font format with 5 words
FST entry (default); or 9700 to create the Xerox font format with 4 words FST entry. In
addition, you can also specify the font orientation option when exporting fonts.
When exporting resources, you can also select the Destination Directory where you want
to export the selected resources. For example, the image below shows the Xerox LPS
Resource Writer dialog Resources category, which contains options for setting the
destination directory to export resources. The exported resources can be saved in either the
same directory as the output file or the default resource directory specified in the Profile
Server. You can also choose to overwrite any existing resource files in the specified
directory if any of the exported resources have the same filename as an existing resource.

Specify the Destination
directory when
exporting resources.

Xerox external resources export properties.
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External resources are not exported if resources with the same name already
exist in the Destination Directory, unless the Replace Existing Resources
option is selected.

Embedding Resources
Elixir format forms provide options for inserting fonts, images, and forms as embedded
resources in the form. This feature is especially useful if you need to move or change the
original resource.

Select Embedded from the Insert As
drop-down list. This tells Form Editor to
save the resource as part of the form itself
instead of referencing it.

Inserting a Xerox image as an embedded resource using the Open Resource File dialog.
You can also embed the existing resources used within a form using the Embed all
resources option (see “Managing Resource Objects” on page 84 for more information).
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Images resized while editing a form are correctly exported as segments only if
they are embedded in the form.

About User Profiles
You can customize Form Editor to fulfill the requirements of your specific working
environment by creating and maintaining unique user profiles. A profile is a system file
that stores important file locations and other related information for Elixir applications.
When an Elixir application is installed, a default profile is created and stored in the
SystemData.ini file, based on the information provided during installation. This file
establishes the basic operating environment for the specific application, and is located at
drive:\Documents and Settings\Current User\Application Data\Elixir
Technologies\Profiles. This default profile is created and loaded automatically when an
Elixir application is opened for the first time.
You can also create custom profiles using the Profile Editor. These custom profiles can be
subsequently selected using the Profile Selection command. Custom profiles selected for
various DesignPro Tools applications need to be specified separately. A profile selected
for one module does not apply to other modules and sessions.
Refer to the following tasks for more information:


Selecting a User Profile (page 90)



Creating a Custom User Profile (page 90)
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Selecting a User Profile
You can select an existing user profile and view its contents using the Profile Editor.
To select a profile and view its information:

1

From the Tools menu, select Profile Selection.
The Profile Selection dialog displays.

2

In the Current Profile area, select the required profile from the Profile Name dropdown list.
The INI file path entry box displays the path of the selected profile. The Description
entry box provides a brief narrative describing the selected profile.
You can view the list of pre-defined profile symbols used to identify various
application objects in the Symbols list. The Symbol Value entry box displays
the pre-defined symbol path of the selected profile specifying the location of
application objects. For details, refer to “Setting Symbol Properties” on page
91.

3

Click OK.
Any changes specified are saved.

Creating a Custom User Profile
You can also create custom profiles using the Elixir Profile Editor. A customized user
profile is based on the structure of the SystemData.ini file. This file contains the default
directories, Resource Maps, and Resource Libraries used by Elixir Applications, as well as
various system settings.
When you create a new profile, Profile Editor automatically creates a corresponding INI
file on the following path in the system drive:\Documents and
Settings\username\Application Data\Elixir Technologies\Profiles. Removing a profile
deletes the corresponding INI file from the hard disk.
To create a custom profile:
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1

From the Tools menu, select Profile Selection.
The Profile Selection dialog displays.

2

Click New.
The Register New Profile dialog displays.
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3

In the Profile Name entry box, specify a unique name to identify the new user
profile.

4

Click
next to the Profile INI File Path entry box.
The Open Profile Configuration File dialog displays.

5

Specify an appropriate path for the new profile and enter a unique profile name.
The Profile INI file Path entry box displays the profile name and file path.

6

Click Open to return to the Register New Profile dialog.
The Profile INI File Path entry box displays the specified path.

7

In the Description text area, enter a brief narrative about the new profile.

8

Check Only For Current User to make the created profile available only for the
local user on a machine.
If you uncheck this option, the profile will be created as shared/global) and will be
available to all the users on a machine

9

Click OK to create the custom profile.
To review additional information on profiles, refer to Chapter 9: Elixir Profile Editor
in the DesignPro Tools Manager for Xerox User Guide.

Setting Symbol Properties
You can set the default properties for items in the SystemData.ini file and also view the
predefined symbols along with the user-defined symbols. Each item represents a Key
(variable) and associated Value (path). Key and Value pairs indicate where to find certain
types of computer information. Keys identify application objects; Values indicate
associated object paths and types.
To set properties for symbols:

1

From the File menu, select Properties.
The Options dialog displays.

2

Under the Application node, select the Symbols category.
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The various options are illustrated in the figure below:
Displays objects
key string.

Displays objects
key path and type.

Displays selected
Key strings.

Browse to
select the path.

Set objects key
path and type.

Set real value for
selected objects key.

Set selected objects
key path and type.

The image above illustrates the various Xerox options.
Each item represents a Key (variable) and associated Value (path). Key and Value
pairs indicate where to find certain types of computer information. Keys identify
application objects. Values indicate associated object paths and types.

3

Review the options and set the object key path and type in the Value entry box. You
can click
to display the Browse for Folder dialog for selecting the required
path.
The value for the selected object key is displayed in the Real entry box.

4

Click Set to set the selected object key path and type.
The System Data category of the Options dialog is a subset of the Symbols
category. It includes information on the system symbols that are predefined by
Elixir, however, the list of information for System Data comes from the same file,
i.e., SystemData.ini file.
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You can define new symbols using Elixir Profile Editor and use them in the
Resource category input (parser) property pages. For more information on
user profiles, see “About User Profiles” on page 89.

File Formats
This section provides information about input parsers and output converter options and
their associated properties.
You can modify the input file format settings depending on your requirements. You can
also specify output file format settings while saving your form to the required format. The
output settings are influenced by the target printer properties.

Application Format Settings
Application format settings lets you specify input and output format options for Form
Editor. These settings are applied to all of the new documents, as well as to the documents
that do not have an associated Elixir parameter file. The application format settings are
applicable to all of the ongoing sessions in the application.

For information on Elixir parameter file, see “Elixir Parameter Files (EPM)”
on page 99.

Application Format Commands
Form Editor lets you perform application-level operations on all of the supported
converters and parsers, and lets you set the Elixir resource properties along with the setup
file loading and unloading operations. The application-level settings are applied to all of
the new resources created using Form Editor.
You can perform the following application-level operations:


Load the application format settings from an Elixir parameter file (EPM).



Clear the EPM file settings to the default values.



Save the application format settings to an EPM file.



Specify the input format settings.
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Specify the output format settings.



Specify the Elixir properties for application resource handling.

Document Format Settings
The Form Editor lets you set input format options at document-level, which override the
application-level settings for a specific document.
This feature is useful when working with multiple forms simultaneously. You may have
several forms open at the same time, each having unique input format settings; however,
document-level format settings are lost if the form is exported to another format.

Document Format Commands
Form Editor lets you perform document-level operations on all of the supported parsers
along with the setup file loading and unloading operations.
To specify document-level format settings, from the Tools menu, select Document
Format Settings and select the required option from the sub-menu.
You can perform the following document-level operations:


Load the document format settings from an Elixir parameter file (EPM).



Clear the EPM file settings to the default values.



Save the document format settings to an EPM file.



Specify the input format settings.

You can set the document format settings only when a form is open in the Design Area.
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File Format Properties
DesignPro Tool supports many industry standard formats. Form Editor provides you
design flexibility by providing options to convert other resources to Xerox formats. The
input and output format type dialogs associated with the Application Format Setting and
Document Format Setting options let you set and change the format type
conversion options.
The Input Formats and Output Formats options contain selections for the following file
types:


ElixirPDW: Elixir PrintDriver.



FRM: Xerox form.



FSL: Form Source Language.



GDF/Elixir Form: Elixir Generic Document Format.



Image: Generic Image Format.



PCL: Print Control Language.



PDF: Portable Document Format.



PostScript: PostScript Metafile format.



VIPP: Variable Data Intelligent PostScript Printware.



WindowsEMF: Enhanced Window Metafile.

Changing Input Format Properties
You can access the input format properties from either the Open or Save as dialogs or
directly from the Tools menu.
To change the input format properties:

1

Do one of the following:
 From the Tools menu, select Application Format Setting, Input Formats to
change the application-level input format settings.
or
 From the Tools menu, select Document Format Setting, Input Formats to
change the document-level input format settings.

2

Select the required input formats type from the list of available options (for example,
FRM).
The associated input format dialog displays a list of available categories. Categories
displaying in the input format dialogs depend on your selected file format type.
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3

Select the required category to view the associated properties.

4

Review the dialog selections and make your changes.
For information on all the options available in the input (parser) property
dialog(s), refer to the Online Help. To open the Online Help, click
on the top right of an open dialog.

5

available

Click Apply, and then click OK to save the settings.

Changing Output Format Properties
To change the output format properties:

1

From the Tools menu, Application Format Setting, Output Formats.

2

Select the required output format type from the list of available options.
The associated output format dialog displays a list of available categories. Categories
displaying in the output format dialogs depend on your selected file format
type.Select the required category icon to view the associated properties.

Categories displaying in the output format dialogs depend on the selected
format type.

For information on all the options available in the output (converter) property
dialog(s), refer to the Online Help. To open the Online Help, click
on the top right of an open dialog.
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3

Review the dialog selections and make your changes.

4

Click Apply, and then click OK to save the settings.
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Viewing Parser and Converter Properties
You can view properties for all available parsers and converters before deciding upon the
appropriate one to use.
To view the properties of a particular parser or converter:

1

From the File menu, select Properties.
The Options dialog displays.

2

Select the Info Server category.
The available options in the folder tree include:
 Input Parsers
 Output Converts
 Output Data Converters
Clicking adjacent to the required folder displays the associated components; each
associated component further contains sub folders that identify the resources such as
forms, images, fonts, etc.

3

Select the required resource folder to view the related information, as shown in the
image below:
Select the required tree
node in the tree view.
Information about the
selected component displays
in the associated fields.

Selecting a resource folder to view its related information.
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4

As appropriate, select or review the following options in the View area:
 Show All Components/Hide Unlicensed Components: displays all components
or only licensed components in the tree. The button alternates between Show All
Components and Hide Unlicensed Components options.
 Refresh: saves any changes and refreshes the folder tree.

5

Review the following options in the Component area:
 Name: displays a unique name identifying the selected converter or parser.
 ID: displays a unique code identifying the selected converter or parser.
 Presentation: displays the text that appears in the file filters of the Open and
Save dialogs corresponding to the selected converter or parser.

6

Click OK.
The specified settings, if any, will be saved.

Registering New File Extensions
DesignPro Tools lets you register new file extensions for any selected resource in a
converter or parser. For example, the file extension for an Elixir form is ELX. You can
change and register the extension of the Elixir form by changing it in the Extensions entry
box. This will change the input or output Files of Type filter in the Open or Save as
dialogs.
To register new file extensions:
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1

From the File menu, select Properties.
The Options dialog displays.

2

From the Info Server category, select a resource type from the tree view to set
associated file extensions.
The Presentation entry box specifies a unique name identifying the selected resource
node of the specified component (parser or converter). All existing file extensions
associated with the selected component display in the Extensions entry box.
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3

Add the new extension to the Extensions entry box.
These changes are added and registered as supported file format extensions in the
input or output Files of type filter available in the Open or Save dialogs.
You can add multiple extensions for a selected component. Each extension is
separated by a semi-colon. You can set an extension as the default extension for
a selected resource by clicking Default.

The Extensions setting applies to file extensions only and does not affect the
supported file formats.

4

Click Apply and OK.
To view the applied changes, you need to reopen the application.

Elixir Parameter Files (EPM)
You can save your input and output file format settings in an Elixir Parameter File (EPM)
so that the settings are not lost or forgotten between sessions. You can use EPM files to
transfer setting information to other PCs in your workgroup.
Although an EPM file can hold settings for both input and output files, it is recommended
to save separate EPM files for the input and output so that they can be used for different
conversion combinations.
Refer to the following for more information:


Saving an EPM File (page 100)



Clearing an EPM File (page 100)



Opening an EPM File (page 101)
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Saving an EPM File
You can save your input and output file format settings to an EPM file at the applicationlevel, or document-level. EPM files are also known as setup files. The application-level
settings apply to the whole application, while the document-level settings are specific to
the open document.
To save an EPM file:

1

Do one of the following:
 From the Tools menu, select Application Format Setting, Save to save an
application-level EPM file.
or
 From the Tools menu, select Document Format Setting, Save to save a
document-level EPM file.
The Export Setup File dialog displays.

2

Use the Save in drop-down list to search for the required target folder.

3

Select Setup Files (*.epm) from the Save as Type drop-down list.

4

In the File Name entry box, enter a file name.

5

Click Save to save the setup file.

Clearing an EPM File
You can unload an EPM file and restore the default file format settings at the application
level or document-level.
To clear an EPM file, do one of the following:
Do one of the following:


From the Tools menu, select Application Format Setting, Clear to save an
application-level EPM file.

or


From the Tools menu, select Document Format Setting, Clear to save a documentlevel EPM file.

An informational message is displayed. Click Yes to restore the default settings for the
setup file.
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Opening an EPM File
You can load input and output file format settings from an EPM file at the applicationlevel or document-level. The default Elixir Parameter files are located at
drive:\Documents and Settings\Current User\Application Data\Elixir Technologies.
To open an EPM file:

1

Do one of the following:
 From the Tools menu by selecting Application Format Setting, Load to load an
application-level EPM file.
or
 From the Tools menu by selecting Document Format Setting, Load to load an
document-level EPM.
The Load Setup File dialog displays.

2

Browse for the target file using the Look in drop-down list.

3

Select the required file and click Open to load the setup file.
To load the most recently used setup file by default, select Properties from the
File menu. The Options dialog displays. From the Application node, select
the General category and check Load Last Input Setup File at Startup.
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Chapter 5:

Drawing Tools
In this chapter...


Form Design Tools



Using the Line Tool



Using the Box Tool



Adding an Image



Using the Barcode Tool

Form Design Tools
Using the drawing toolbox in the Form Editor, you can draw several different objects such
as lines and boxes.
In addition, you can also add images and barcodes. When you click a drawing tool, the
toolbox changes accordingly and displays associated options for the selected tool. Click
another tool, and new tool options replace the previous selection.

Using the Line Tool
You can use the line tool to draw lines in the Design Area and set or change line properties
such as size, color, style, etc. See “Common Object Properties” on page 263 in Chapter
12: Editing Forms, which describes properties that apply to all of the drawing objects.
Use the following tasks to draw a line, view, and set line object properties:


Drawing a Line (page 104)



Setting Line Thickness (page 105)



Specifying the Length of a Line (page 106)



Setting Line Start/End Style (page 106)
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Drawing a Line
To draw a line in Form Editor:

1

Click

on the Tools toolbar.

The mouse pointer changes from
the Design Area.

2

3

to

and the Line toolbox displays above

In the Line toolbox, specify the line direction by clicking one of the following:


: sets the line direction to horizontal.



: sets the line direction to vertical.



: sets the line direction to either horizontal or vertical.



: sets the direction to freeform.

Click and drag the mouse pointer anywhere on the Design Area to draw the line.
The line is added to the Design Area and a corresponding node is added under the
Lines node in the Object Type View tab of the Manage window. To adjust the line
properties, right-click the corresponding node and select Properties from the pop-up
menu.
To view line properties, do one of the following:


Right-click the line and select Properties from the pop-up menu.

or


Press Alt + Enter.

The image above shows horizontal, vertical and freeform lines in the Design Area.
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You can also add a line in the Design Area by selecting Line from the Insert
menu.

Setting Line Thickness
To set line thickness:

1

Right-click the line and select Properties from the pop-up menu.
The Properties - Line dialog displays.

2

From the Style category, select the required thickness from the Thickness dropdown list.

3

Click OK.
The line thickness changes as specified.

Setting the line width in Form Editor.

You can also use the Common Attributes toolbar to adjust line thickness.
Select the line and update the value in the Line Thickness entry box.
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Specifying the Length of a Line
To set line length:

1

Right-click the line and select Properties from the pop-up menu.
The Properties - Line dialog displays.

2

Select the Dimensions category and enter the required length, per specified unit of
measurement, in the Length entry box.

3

Click OK.
The length of the line changes as specified.

Setting Line Start/End Style
Lines drawn can have varying start and end styles. Depending upon your requirement, you
can use either the squared, rounded, or flat styles.
To set the start and end style of a line:

1

Select the line in the Design Area.

2

From the Common Attributes toolbar, select the required start and end style from
the Line start/end drop-down list.
The line updates to the selected style.
Squared
Rounded
Flat

Line start/end styles in Form Editor.
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Using the Box Tool
The drawing toolbox lets you draw box objects in the Design Area. Once a box is added to
a form, you can view and set box properties, including size, style, background and
foreground color, etc. See “Common Object Properties” on page 263 in Chapter 12:
Editing Forms, which describes properties that apply to all of the drawing objects.
Use the following tasks to draw a box, view, and set box specific properties:


Drawing a Box (page 107)



Drawing a Square (page 108)



Setting Box Line Width (page 108)



Setting Box Border Properties (page 109)



Splitting a Box (page 109)

Drawing a Box
To draw a box in the Design Area:

1

In the Tools toolbar, click
.
The toolbox above the Design Area updates and displays box-specific options. The
mouse pointer changes from

2

to

.

Click and drag the mouse pointer anywhere on the Design Area to draw the box.
The box is added to the Design Area and a corresponding box node is added under
the Boxes node in the Object Type View tab of the Manage window. To adjust the
box properties, right-click the corresponding node and select Properties from the
pop-up menu.
To view box properties, do one of the following:


Right-click the box and select Properties from the pop-up menu.

or
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Drawing a Square
To draw a square in the Design Area:

1

Click
on the Tools toolbar.
The toolbox above the Design Area updates and displays box-specific options.

2

Click
in the Box toolbox.
The square lock is activated. This ensures that the box drawn will have equal width
and height.

3

Click and drag the mouse pointer anywhere on the Design Area to draw the box.
The square is added to the Design Area and a corresponding box node is added under
the Boxes node in the Object Type View tab of the Manage window. To adjust box
properties, right-click the corresponding node and select Properties from the pop-up
menu.

Setting Box Line Width
To set the line width of a box:

1

Right-click the box and select Properties from the pop-up menu.
The Properties - Box dialog displays.

2

From the Style category, select the required width from the Thickness drop-down
list.

3

Click OK.
The box line width changes as specified.

Box line thickness.

You can also adjust box line width by selecting the required width from the Line
Thickness entry box on the Common Attributes toolbar.
To adjust line width before drawing the box, select the required line width from
the Line Thickness drop-down list in the Box toolbox.
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Setting Box Border Properties
Form Editor lets you specify options to position the border of a box.
To specify box border properties:

1

Right-click the box and select Properties from the pop-up menu.
The Properties - Box dialog displays.

2

From the Position category, select either of the following:
 Center: positions the box’s border to share the same center point as the box’s
boundary.
 Top Positioning: positions the box’s border such that the top left corner of the
border is aligned with the top left corner of the box’s boundary.

3

Click OK.
The border of the box repositions as specified.

Splitting a Box
You can split a box object horizontally and vertically. Associated options lets you set the
line style and thickness properties for the selected box object.
To split a box object:

1

Right-click the box and select Properties from the pop-up menu.
The Properties - Box dialog displays.

2

Select the Splits category and specify the number of horizontal and vertical split
lines in the Horizontal Split Lines and Vertical Split Lines control boxes
respectively.

3

Specify the line styles for horizontal and vertical split lines in the corresponding
Line Style drop-down lists.

4

Select the thickness for the horizontal and/or vertical split lines from the Thickness
drop-down lists.

5

Click OK.
The box will change to reflect the specified changes.
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To set the split options before drawing a box, select the Box tool from the
Tools toolbar. The toolbox will update to display only box-specific options.
Click
or
for splitting the box horizontally or vertically. In the adjacent
entry box, specify the number of split lines.

1. Right-click the box
and select Properties
from the pop-up menu.
2. Select the Splits
category from the
Properties - Box dialog.
3. Specify the number of
horizontal split lines, the
split line style, and split
line thickness.
4. Specify the number of
vertical split lines, the
split line style, and split
line thickness.

5. Click OK. The box
splits as specified.

The image above illustrates the process of splitting a box.
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Adding an Image
Images can be logos, signatures, or bar charts. You can use Xerox or other vendor products
to create images and add them to your form. Once added to a form, you can view images
in the Design Area and set image properties.
Refer to the following tasks for information on adding and replacing an image:


Inserting an Image (page 111)



Replacing an Image (page 112)

Inserting an Image
To insert an image in the Design Area:

1

From the Tools toolbar, click
.
The Open Resource File dialog displays.

2

Select the required file format from the Files of type drop-down list.
You can also add an image stored in the Elixir Resource Library by selecting
Resource Library (*.erc32; *.erc) from the Files of Type drop-down list.
For more information, refer “Importing Resources to a Resource Library”
on page 82 in Chapter 4: Resources and Formats.

3

Browse to select the required image and then click OK.
The mouse pointer changes from

4

to

.

Position the mouse pointer in the Design Area and click at the required location to
insert the image.
The image is added under the Images node in the Object Type View tab of the
Manage window. To adjust image properties, right-click the associated node and
select Properties from the pop-up menu.
To view image properties, do one of the following:


Right-click the image and select Properties from the pop-up menu.

or
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Press Alt + Enter.
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Replacing an Image
To replace an existing image in a form:

1

Right-click the image and select Properties from the drop-down menu.
The Properties - Image dialog displays.

2

Select the General category, which lets you insert an image from the required
directory.

3

Click

4

Browse to select the required image, and then click Open.
The selected image name and path is displayed in the File entry box.

5

Click Apply, and then click OK to replace the image in the Design Area.

to open the Open Resource File dialog.

Using the Barcode Tool
Barcodes are an array of parallel rectangular bars and spaces that together represent data
elements or characters. Bars and spaces are arranged in predetermined patterns following
predefined rules. Barcode objects are read optically by transverse scanning. You can add
different barcode types to your form. Once added to a form, a corresponding Bar Codes
node displays in the Object Type View and Resource Manager tabs of the Manage
window.

You can also view barcodes in the Design Area and set barcode properties. Refer to
“Common Object Properties” on page 263 in Chapter 12: Editing Forms for more
information on properties that apply to all of the drawing objects.
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Inserting a Barcode
To insert a barcode in the form:

1

From the Tools toolbar, click
.
The toolbox updates and displays barcode-specific options. The mouse pointer
changes from

2

to

.

Position the cursor in the Design Area and drag and drop the barcode at the required
location.
The barcode is added under the Bar Codes node in the Object Type View tab of the
Manage window. To adjust barcode properties, right-click the associated node and
select Properties from the pop-up menu.
To view barcode properties, do one of the following:


Right-click the barcode and select Properties from the pop-up menu.

or


Press Alt + Enter.

Adding Barcode Text
Form Editor lets you view and add text to the current barcode object.
To add text to a barcode:

1

Right-click the barcode and select Properties from the pop-up menu.
The Properties - Barcode dialog displays.

2

Select the Text category and, in the Text entry area, enter the default text for the
selected barcode object or edit the existing text.
The set of valid characters and the minimum and maximum character count
values for the text entered can vary depending on the barcode type selected.
The following information below the Text entry area can help guide you when
entering text for a barcode:
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Description: displays the valid characters required for the selected barcode
type.
Comment: displays the minimum and maximum character count for the
selected barcode type.
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3

Click OK.
The text is saved.

Selecting the Barcode Type
Form Editor supports a variety of different barcode types, which you can add to your form.
To select the required barcode type:

1

Right-click the barcode and select Properties.
The Properties - Barcode dialog displays.

2

Select the required barcode type from the Barcode Type drop-down list.
You can choose from the following:
Code 39 (3 of 9)
Code 39 is an alpha-numeric code. This symbology includes 43 characters: A-Z, 0-9,
and characters for a dash (-), period (.), dollar sign ($), slash (/), plus sign (+),
percent (%), and a space. Each character in Code 39 is made up of five bars and four
spaces. Of these nine bars and spaces, six are always narrow and three are always
wide. There is also a start and stop character to initiate and to stop the reading. The
bar code shown is a typical Code 39. Code 39 is a bi-directional bar code implying
that a stop can be read first and the number read backwards, and it can still be
recognized in its proper sequence.

Code 3 of 9 barcode.
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MSI (Modified Plessey Code)
MSI Data Corporation introduced MSI from the original Plessey Code; therefore,
MSI is also known as Modified Plessey. It is mainly used in retail business. MSI/
Plessey is a fixed-length, non-self-checking symbology. Most applications still
support MSI only for backward compatibility, because MSI/ Plessey is based on
Pulse-Width Modulation technology and is inefficient in space usage. MSI requires
start/stop characters and is used to encode numeric data. A check digit is required at
the end of the data.

MSI barcode.
UPC Version A (Universal Product Code - A)
UPC is the most popular and most frequently used of all barcodes. It is mostly used
in the grocery industry and price product. UPC is designed to match the number of
the product with information such as the manufacturer, product, and price. It
provides a high read rate even as the product moves rapidly past the scanner. Some
other considerations for the scan ability of UPC lie in the fact that the codes must be
on products that are to be frozen, wet, or shrink wrapped, etc. A-4 line width
barcode; used for retail in the US; composed of 12 digits. UPC is a fixed-length,
numeric-only code.

UPCA barcode.
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UPC Version E (Universal Product Code - E)
UPC version E is composed of six digits. UP C-E is popular for applications in
which space is limited for the placement of the code.

UPCE barcode.
UPC (2-Digit Supplemental)
2-digit supplemental barcodes are used with magazines, newspapers, and
periodicals. For more information on 2-digit supplemental barcodes, see “EAN (2Digit Supplemental)” on page 117.

UPC 2-digit supplemental barcode.
UPC (5-Digit Supplemental)
5-digit supplemental barcodes are used on books to indicate a suggested retail price.
For more information on 5-digit supplemental barcodes, see “EAN (5-Digit
Supplemental)” on page 118.

UPC 5-digit supplemental barcode.
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EAN8 (European Article Number)
EAN8 (European Article Number) represents a 4 line width barcode used for retail
world-wide, except for the US. It is composed of only 8 digits to fit on smaller
packaging.

EAN8 barcode.
EAN13
EAN13 represents the most commonly used 4 line width barcode, composed of 13
digits and used for retail world-wide, except for the US.

EAN13 barcode.
EAN (2-Digit Supplemental)
EAN 2-digit supplemental barcodes are used with magazines, newspapers and
periodicals. The 2-digit supplement represents the issue number of the magazine and
can be used to track which issue of the magazine is being sold, for restocking
purposes. In reality, this is an internal issue number. The 2-digit extension is not
always the same as the issue number that is printed somewhere on the cover. The
encoded issue number can be the number of the month of the year, or the week
number, depending on the frequency with which the periodical is published.
Since the 2-digit supplement is mostly used in conjunction with a UPC-A, UPC-E,
EAN-13, or EAN-8 barcode, it makes the barcode longer and requires wider
scanners. The use of the extension is limited to the publication industry.

EAN 2-digit supplemental barcode.
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EAN (5-Digit Supplemental)
5-digit supplemental barcodes are used on books to indicate a suggested retail price.
The first digit of the supplement indicates the currency in which the price is
expressed. A "0" represents a price expressed in British Pounds, whereas a "5"
represents a price expressed in U.S. dollars. The remaining 4 digits of the
supplement indicate the price. For example, "51195" indicates a suggested retail
price of US $11.95.

EAN 5-digit supplemental barcode.
Industrial 2 of 5
This is also known as Code 25 Industrial or Code 2 of 5. This code is not often used
because of the amount of space required. The symbology consists of the numbers 0-9
and the start character and the stop character (parentheses). For example, to scan the
numbers 1234, you need to type and print (1234).

Industrial 2 of 5 barcode.
Matrix 2 of 5
Matrix 2 of 5 represents a special type of Code 2 of 5 Industrial.

Matrix 2 of 5 barcode.
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Interleaved 2 of 5
This is also known as Code 25 Interleaved or Code 2 of 5 Interleaved;a special type
of Code 25 Industrial that is very compact. Code 2 of 5 Interleaved is a high-density,
bi-directional code that encodes characters as well as spaces. Each character is made
up of five bars or five spaces (not both). Each character has two elements that are
wide and three elements that are narrow. Since this code is a variable-length code, it
must be printed with a frame around the code to ensure an accurate read. The frame
serves as a block to guard against a short diagonal read. This barcode is only valid if
there is an even number of digits. To display an odd number of digits, you have to
add a zero to the beginning.

Interleaved 2 of 5 barcode.
Codabar (2 of 7)
This is also known as Coderbar (NW-7). Codabar is used primarily for medical and
inventory purposes, as it is numeric only. It is commonly used on log tags, lumber
tally tags, and asset labels. The code is bi-directional and occupies less space than
Code 39.

Codabar (2 of 7) barcode.
Code 128
This represents a non-retail 4 line width barcode, used for the full ASCII character
set.

Code 128 barcode.
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PostNet (Postal Numeric Encoding Technique)
This represents a 4 line width barcode, specific to mail delivery in the US. It is
composed of a start and end character (asterisk) and 12 other digits: 5-digit zip code,
4-digit zip+4 code, 2 delivery point digits and 1 check digit.

Postnet barcode.
RM 4SCC
The Royal Mail 4-State Customer Code (RM4SCC) was created for automated mail
sorting processes and is normally used to print the postcode and Delivery Point
Suffix (DPS) on letters in machine readable format. The contents of the code may
vary in different countries. The Royal Mail 4-State Customer Code (RM4SCC) is
based on 36 barcodes representing alphanumeric characters (0-9, AZ), as well as
start and stop bar characters which are represented by ( and ).

RM4SCC barcode.
Japan
Data consists of a 7-digit postal code, after which home/building information can be
placed (optional).

Japan barcode.
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Apostal
This represents the Australian post symbology. Apostal is another implementation of
the 4-State Customer Code (see RM 4SCC, Royal Mail) and uses Reed Solomon
error checking instead of a single check digit.

Apostal barcode.
PDF 417 (Portable Data File 417)
This represents a stacked barcode symbology capable of encoding over a kilobyte of
data in a symbol; therefore, large amounts of text and data can be stored securely and
inexpensively when using the PDF 417 symbology. Using Reed Solomon error
correction, the printed PDF 417 symbol can withstand damage without causing loss
of data. This high level of error correction is far more advanced than onedimensional barcodes with check digits. The Reed Solomon error correction adds
significantly to the size of the PDF 417 barcode, but this is usually not a problem
because the barcode is two-dimensional, multi-row, and can be printed at very small
x dimensions.

PDF 417 barcode.
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Maxi Code
Maxi Code is a fixed size 2D matrix style symbology (originally called UPS Code),
which is made up of offset rows of hexagonal modules arranged around a unique
bulls-eye finder pattern. Hexagonal elements allow dense packing, and provide fixed
center-to-center spacing of all elements. The central finder pattern and fixed symbol
size allow for easy scanning on high-speed conveyors. Each Maxi Code symbol has
884 hexagonal modules arranged in 33 rows with each row containing up to 30
modules. The maximum data capacity for a Maxi Code symbol is 93 alphanumeric
characters or 138 numeric characters. Intended primarily for encoding addresses for
postal and delivery applications, it has a relatively low information content.
It does have a fixed physical size (width: 25.5 mm, height: 24.4 mm, tolerance
1.5mm), which simplifies the facilities required for printing and scanning symbols.

Maxi code barcode.
Data Matrix
Data Matrix is a very area-efficient 2D (two dimensional) barcode symbology that
uses a unique square module perimeter pattern that helps the barcode scanner
determine the cell locations. Because it can encode letters, numbers, text, and actual
bytes of data, it can also encode extended characters, Unicode characters, and
photos. Data Matrix barcodes can encode large amounts of data; however, encoding
over 800 characters is often difficult to scan.

Data Matrix barcode.

3
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Click OK.
The barcode type changes as specified.
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Setting Barcode Dimensions
You can adjust the dimensions of your barcode by setting various options. The options
applicable will differ depending upon the barcode type used.
To set barcode dimensions:

1

Right-click the barcode and select Properties from the pop-up menu.
The Properties - Barcode dialog displays.

2

From the Barcode category, specify any of the following dimension options that are
applicable to the selected barcode:

Option Name

Description

Barcode Type

Modifier

Specifies the horizontal width of the
barcode image.

Applicable to all barcodes
with the exception of PDF
417, Maxi Code and Data
Matrix.

Resolution

Specifies the resolution of the
barcode image, per specified unit of
measurement.

Applicable to all barcodes.

ModWidth

Specifies the narrowest bar width,
per specified unit of measurement.

Applicable to all barcodes
with the exception of PDF
417, Maxi Code and Data
Matrix.

Height

Specifies the vertical width of the
barcode image, per specified unit of
measurement.

Applicable to all barcodes
with the exception of PDF
417, Maxi Code and Data
Matrix.

Ratio

Specifies the ratio between the
narrowest and the widest bar.

Applicable to all barcodes
with the exception of:
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Code 128



PostNet



RM 4SCC



Japan



Apostal



PDF 417



Maxi Code



Data Matrix
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Option Name

Description

Barcode Type

Aspect Ratio X

Specifies the proportion between
the width and the height of the PDF
symbol.

Applicable to PDF 417
only.

Aspect Ratio Y

Specifies the proportion between
the width and the height of the PDF
symbol.

Applicable to PDF 417
only.

Width of X bar
module

Specifies the elementary bar module
width, per specified unit of
measurement.

Applicable to PDF 417
only.

Width of X space
module

Specifies the space module width,
per specified unit of measurement.

Applicable to PDF 417
only.

Delta width

Specifies the delta width, per
specified unit of measurement.

Applicable to PDF 417
only.

Number of Rows

Specifies the number of rows in the
barcode, per specified unit of
measurement.

Applicable to PDF 417
only.

Number of Columns

Specifies the number of columns in
the barcode, per specified unit of
measurement.

Applicable to PDF 417
only.

Height of the module

Specifies height of the bar module,
per specified unit of measurement.

Applicable to PDF 417
only

Truncate PDF

Omits the right row indicator and
simplifies the stop pattern into a
single module width bar.

Applicable to PDF 417
only.

Elementary barcode
module width

Specifies the barcode module width,
per specified unit of measurement.

Applicable to Data Matrix
only.

Elementary barcode
module height

Specifies the barcode module
height, per specified unit of
measurement.

Applicable to Data Matrix
only.

Size of barcode

Specifies the proportion between
the width and the height of the PDF
symbol.

Applicable to Data Matrix
only.

Width of code

Specifies the width of code, per
specified unit of measurement.

Applicable to Maxi Code
only.

Height of code

Specifies the height of code, per
specified unit of measurement.

Applicable to Maxi Code
only.
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Option Name

Description

Barcode Type

Maxicode Mode

The various modes available differ
in the barcode data structure. You
can choose between modes 2 - 6.

Applicable to Maxi Code
only.

Global dimension of
code

Specifies the global dimension of
code, per specified unit of
measurement.

Applicable to Maxi Code
only.

Click OK.
The dimensions of the selected barcode update as specified.

Setting Human Readable Information
You can also specify the settings for a barcodes human readable information. This refers to
the text associated with a barcode. Settings include its visibility, position, font name and
presentation.

Human Readable Information is not applicable to all barcode types.

To customize HRI (Human Readable Information) settings for a barcode:

1

Right-click the barcode and select Properties from the pop-up menu.
The Properties - Barcode dialog displays.

2

From the Barcode category, specify the appropriate HRI settings.
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The available options are:

Option Name

Description

Barcode Type

Display Human
Readable
Information (HRI)

Specifies the HRI associated with
the barcode. You can also specify
this setting by selecting the required

Applicable to all barcodes
with the exception of:


PostNet

barcode and clicking
Barcode toolbox.



RM4SCC



Japan



Apostal



PDF 417



Maxi Code



Data Matrix

HRI Presentation

in the

Specifies the row placement of the
barcode’s HRI. You can select either
of the following:


All in One (Barcode
includes HRI): displays text
within the barcode. You can
also select this option by
clicking
from the
Barcode toolbox.



One and One (2 Rows):
displays text either above or
below the barcode depending
upon the selection made
from HRI position. You can
also select this option by

Applicable to all barcodes
with the exception of:


PostNet



RM4SCC



Japan



Apostal



PDF 417



Maxi Code



Data Matrix

clicking
from the
Barcode toolbox.
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Option Name

Description

Barcode Type

HRI Position

Specifies the position of the HRI as
either above or below the associated
barcode. Activated only if One and
One (2 Rows) is selected from HRI
Presentation. You can also specify
the HRI position of a selected

Applicable to all barcodes
with the exception of:

barcode by clicking
or
from the Barcode toolbox.

Font Name

Present Asterisks in
HRI

3

Unique name identifying the font
used for the HRI. You can select the
font from the list of available
options.

Displays the barcode HRI with
asterisks.



PostNet



RM4SCC



Japan



Apostal



PDF 417



Maxi Code



Data Matrix

Applicable to all barcodes
with the exception of:


PostNet



RM4SCC



Japan



Apostal



PDF 417



Maxi Code



Data Matrix

Applicable to Code 39 (3
of 9) only.

Click OK.
The HRI on the selected barcode is updated as specified.
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Specifying Error Correction and Tolerance Settings
Barcode data can be electronically transferred, often resulting in data loss or corrupt data.
You can specify various error correction settings to recover any lost data.
To specify error correction settings for a barcode:
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1

Right-click the barcode and select Properties from the pop-up menu.
The Properties - Barcode dialog displays.

2

From the Barcode category, specify the error correction and tolerance settings.
The available options are:

Option Name

Description

Barcode Type

Error Correction
Level

Specifies the error correction level
here. PDF 417 supports correction
of lost or missing data. Each PDF
417 symbol requires two error
correction code words for error
detection. More error correction
creates a larger symbol that can
withstand more damage.

Applicable to PDF 417
only.

Percentage use of
EC

Specifies the error correction level
here. PDF 417 supports correction
of lost or missing data. Each PDF
417 symbol requires two error
correction code words for error
detection.

Applicable to PDF 417
only.

Error Correction
Code

Specifies an error correction code
that enables error-free reading even
when a symbol has been partially
lost or destroyed.

Applicable to Data Matrix
only.

Width dm. (hexagon
tolerance)

Specifies allowed deviation from
ideal horizontal spacing between
hexagons. MaxiCode symbols are
sensitive to the gap between
hexagons.

Applicable to Maxi Code
only.

Height dm. (hexagon
tolerance)

Specifies allowed deviation from
ideal vertical spacing between
hexagons. MaxiCode symbols are
sensitive to the gap between
hexagons.

Applicable to Maxi Code
only.

DesignPro Tools Form Editor® for Xerox User Guide

3

Click OK.
The error correction settings will update as specified.

Setting Barcode Encoding Properties
You can specify certain data encoding properties associated with the Data Matrix barcode.
For example, you can specify the set of characters allowed in the input string. You can also
specify whether or not to allow extended channel interpretation.
To specify the encoding properties of a Data Matrix barcode:

1

Right-Click the barcode and select Properties from the pop-up menu.
The Properties - Barcode dialog displays.

2

In the Barcode category, select one of the following from the Alphabet Base dropdown list:
 0: auto sets alphabet from input string.
 11: encodes 0-9 and space only.
 27: encodes A-Z and space only.
 37: encodes A-Z, 0-9 and space only.
 41: encodes A-Z, 0-9, space, . (period), , (coma) and - (minus or hyphen) only.
 128: encodes / (forward slash or solidus) only.
 256: encodes the full ASCII set.

To allow the representation of characters from other character sets and data
interpretations, check Extended Channel Interpretation.

3

Click OK.
The specified settings are saved.
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Chapter 6:

Colors and Patterns
In this chapter...


Using Colors



Working with the Color Palette



Working with the Palette List



Filling Objects with Patterns



Substituting Shades with Solid Colors



Working with Shade Lists

Introduction to Color
Form Editor provides a variety of ways to create and/or modify colors. Using the available
color models, you can choose colors to apply to the foreground/border or background/
interior of an object in the Design Area. Colors can be applied on drawing objects, tables,
charts, and text. Form Editor supports colors from the following four extensively used
color architectures: CIELAB, CMYK, HSB and RGBOCA. In order for you to manage the
colors in a design with more ease, Form Editor also lets you maintain a color list.
You can also fill objects using the available patterns. You can either add a pattern to an
object or replace existing patterns. In addition, you can specify whether to use shading or
solid colors on your form. Shading displays the fill patterns of objects, whereas coloring
them evens out the pattern giving a solid color.
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Using Colors
Form Editor lets you apply foreground and background colors to an object. Applying a
foreground color to an object fills the outline of the object with the selected color.
Applying a background color to an object fills the interior space of the object with the
selected color.
You can customize the existing color palette(s) and create new colors. You can either
replace the current palette or insert a color to an existing palette. For more information on
color palettes, see “Working with the Color Palette” on page 134.

Applying Color to Form Objects
To set or change an object color:

1

Click from
on the Common Attributes toolbar.
The Color Picker dialog displays.

2

To set the interior (foreground) and/or border (background) color of an object, select
from the following:


: sets the border color of an object.



: sets the interior color of an object.

Before setting the border/interior color of an object, select the required object.

3

Choose the required color from the palette.
The selected color fills and/or outlines the object in the form.
You can also change or apply color to an object using the properties dialog
associated with the selected object. For more information, refer to Chapter 12:
“Editing Forms” on page 263.
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Selecting a Color Catalog
Xerox toolset allows you to create forms using either highlight or full colors. Forms
utilizing full color can use color palettes consisting of a variety of different colors,
whereas forms using highlight color can only use a color palette consisting of black, white
and any third color. You can select the third color from the Color Catalog or the Color
Selector dialog, provided you follow Xerox naming conventions. For more on selecting
colors from the Color Selector dialog, see “Adding a New Color to the Color Palette” on
page 136.
The use of either highlight or full color for your form depends on the type of printer being
used. Certain Xerox printers can only print using three colors making Highlight forms a
more suitable choice. And other Xerox printers are capable of printing full color forms.

If your form utilizes a highlight color, adding more colors to the color palette will
enable you to use full colors for you form.

To add the required highlight color to the color palette:

1

From the File menu, select Properties.
The Options dialog displays.

2

From the Application node, select General.

3

In the Choose Catalog area, uncheck Full Color Palette and select the required
catalog from the drop-down list.
The selected color will be inserted in the color palette.

4

Click OK.
The selected color displays in the Color Picker dialog.
Selecting a color catalog does not replace the active color palette. The selected
color is only appended to the active color palette (This is applicable only if the
active palette is a full color palette.) The color appearance of the objects in the
Design Area is not affected.
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Working with the Color Palette
In Form Editor, you can quickly adjust the palette colors to meet the needs of your form
color presentations or remove colors that are no longer used. You can select from a variety
of palettes provided with the application, from which you can create and append custom
colors and save as a customized palette. You can also duplicate colors, delete colors from
the palette, edit colors in the palette, or reload the default palette if you have replaced it.
Form Editor supports Elixir Palette (PLF) and XML files (XML) formats for creating or
opening color palettes.
Refer to the following tasks for more information on the color palette:


Selecting a Color Palette (page 134)



Opening a Color Palette (page 135)



Adding a New Color to the Color Palette (page 136)



Editing a Color (page 138)



Deleting a Color (page 139)



Saving a Color Palette (page 139)

Selecting a Color Palette
The color catalog is applicable for Xerox printers using 3-color highlighting. In addition to
black and white, you can add a third highlight color to the color palette using the color
catalog. In Form Editor, you can also specify the application default color catalog that is
active when a new form is created.
You can choose from a variety of Xerox and Default colors, which are available as part of
the standard software installation. For printers that don’t use 3-color highlighting, see the
“Opening a Color Palette” on page 135.
To select a color palette:
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1

From the File menu, select Properties.
The Options dialog displays.

2

From the Application node, select the General sub-category.
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Check Full Color Palette to load a full color palette by default when Form Editor is
opened.
The full color palette used depends on the following two options:
 Default Color Palette: loads the default Form Editor color palette specified in
the System Data.ini file.
 User Specified Full Color Palette: loads a user specified color palette. Clicking
displays the Open dialog, where you can browse for the required file. You
can only select files with the XML extension. Select the required file and return
to the previous dialog. The specified color palette and path are displayed in the
User Specified Full Color Palette entry box.

4

Click OK.
The color palette will be updated when a new form is opened in Form Editor.

If the specified color palette is missing or damaged, a warning message will be
generated and a full color palette will be created and loaded by the application.

Opening a Color Palette
To open a color palette:

1

Click from
on the Common Attributes toolbar.
The Color Picker dialog displays.

2

In the Color Picker dialog toolbar, select one of the following:


Click

to open a color palette.

or
 Click
to add colors from another palette to the current palette.
The Open Resource File dialog displays.

3

Select the required palette file from the Open Resource File dialog and click Open.
The specified palette colors are then added to the existing palette.
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Adding a New Color to the Color Palette
To create a new color and add it to an existing palette:

1

Click from
on the Common Attributes toolbar.
The Color Picker dialog displays.

2

Click
on the Color Picker dialog.
The Color Selector dialog displays.

3

You can set the Spectrum and Model area settings as follows:
Use the slider to set
the required shade of
the selected color.

Use this drop-down list to
select the color model of
your choice from CIELAB,
CMYK, HSB and RGB

Click on the
required color.

You can set various
colors by moving
the sliders for each
value.

Gray scale displays
the current gray
color component.
The values lie
between 0 and 255.

Displays color
name. You can also
edit the color name
using this entry

The image above explains how to set the Spectrum and Model areas to select the
required color.
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The Initial color box displays the original color. The color shade selected by
adjusting the slider adjacent to the shades bar reflects the chosen color/shade in
the Current color box.

4

From the Model area, use the drop-down to select the color model from the
following:
CIELAB
 L: sets the color lightness; the value ranges between 0 - 100.
 A: sets the color chromatic component A (red to green); the value ranges
between - 127 to + 127.
 B: sets the color chromatic component B (blue to yellow); the value ranges
between - 127 to + 127.
CMYK
 C: sets the cyan component value; the value ranges between 0 - 100.
 M: sets the magenta component value; the value ranges between 0 - 100.
 Y: sets the yellow component value; the value ranges between 0 - 100.
 K: sets the black component value; the value ranges between 0 - 200.
HSB
 H: sets the color hue; the value ranges between 0 - 359.
 S: sets the color saturation; the value ranges between 0 - 100.
 B: sets the color brightness; the value ranges between 0 - 100.
RGB
 R: sets the red component value; the value ranges between 0 - 255.
 G: sets the green component value; the value ranges between 0 - 255.
 B: sets the blue component value; the value ranges between 0 - 255.
Depending on the chosen model, you can select the required color by either
adjusting the sliders available, or by specifying a numeric value in the adjacent
boxes for various modes. Adjustments that you make using the sliders or entry
boxes are also reflected in the Spectrum area.

5

Select the color of your choice and edit the name in the Color Name, if required.

6

Click OK to return to the Color Picker dialog.
The new color is added to the color palette.
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7

Click
in the Color Picker dialog to save the palette or click anywhere in the
form to close the dialog and load the current palette settings without saving the
changes.

For information on saving a color palette, see “Saving a Color Palette” on
page 139.

Editing a Color
You can also edit custom/user-defined colors in the color palette.
To change color:

1

Click from
on the Common Attributes toolbar.
The Color Picker dialog displays.

2

Select the required color from the Color Picker dialog.

3

Click

4

Choose the required color and set the properties specific to the selected color model.
For more on selecting a new color, see “Adding a New Color to the Color Palette” on
page 136.

to open the Color Selector dialog.

When editing colors, the Initial color box displays the original color and the
Current color box shows the modified color.
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5

Click OK.
The modified color replaces the selected color.

6

Click

in the Color Picker dialog to save the palette.
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Deleting a Color
You can delete a selected custom color from the palette. To delete a color, click

from

on the Common Attributes toolbar to open the Color Picker dialog, then click
in the palette.

Saving a Color Palette
To save changes to the color palette:

1

Click
dialog,

2

In the Color Picker dialog, click

3

Select the required file type from the Save as drop-down list.

4

Enter a name and click Save to save the palette file at the required location and
return to the Color Picker dialog.

from

on the Common Attributes toolbar to open the Color Picker

to open the Save Resource File dialog.

You can either overwrite the existing palette or save the existing palette as a
new palette; Color Picker dialog does not append the changes made to the
palette.
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Working with the Palette List
A palette list is an XML file containing different palettes. Form Editor provides options
for creating customized palette lists within a form. Once customized palettes for a
particular form are complete, they can be exported as a palette list in the external XML file
format. Similarly, an existing palette list can be imported for use with a new or an existing
form.

Importing a Palette List
To import a palette list in a form:

1

From the File menu, select Import, Palette List.
The Open dialog displays.

2

Use the Look in drop-down list to search for the required file.

3

Select the required XML file for the palette list, and then click Open.
The specified palette list is loaded in the form.

Exporting a Palette List
To export a palette list:

1

From the File menu, select Export, Palette List.
The Save as dialog displays.

2

Use the Save in drop-down list to search for the required target folder.
The palette list will be saved at this location.

3

Specify the palette list name in the File Name entry box, and then click Save.
The palette list is saved at the specified location.
You can also export a palette list into a resource library using the Resource
Manager tab in the Manage window. From the Palettes node, right-click the
selected palette list and select Export Resources from the pop-up menu. The
Export To dialog displays. Use the Save in drop-down list to select the target
folder and select the required resource library. Click Save to export the shade
list to the selected resource library.
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Filling Objects with Patterns
In Form Editor, you can add visual interest to drawing objects using the Pattern Selector
feature. You can either add a pattern to an object or you can replace an existing pattern
with another pattern.
Form Editor provides a number of pre-defined black and white shading patterns to meet
most design needs. When creating a full-color image, you can also select patterns based on
the color selected. For more on selecting colors, see “Adding a New Color to the Color
Palette” on page 136.

Adding a Pattern to an Object
To add/edit an objects fill pattern:

1

Select the required object in the Design Area.

2

Click from
on the Common Attributes toolbar.
The Pattern Selector dialog displays.

3

Clicking in the dialog displays a drop-down list containing different Xerox and
default color pattern types.
You can also add colored patterns to the form objects. To apply a colored pattern to
an object, specify a color before applying a pattern to the object. For more on
specifying the object color, see “Applying Color to Form Objects” on page 132.

4

Select the required pattern type from the drop-down list.
The patterns associated with the selected palette type are displayed in the Pattern
Selector dialog.

To view all available patterns in a color palette, move your cursor to the bottom
right corner of the pattern palette and click and drag to enlarge.

5

Select the required pattern.
The specified pattern is added to the selected object. If you draw the object after
selecting a pattern, the pattern will be added to the object once it is drawn in the
Design Area.
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For information on changing or adding patterns to an object using the associated
object Properties dialog, refer to Chapter 5: “Drawing Tools” on page 103.

Substituting Shades with Solid Colors
You can either fill an objects interior with a shade or a solid color. Specifying shading will
display the fill pattern of the object. However, specifying solid colors will even out the fill
pattern giving a solid interior finish. The interior color of the object depends on the pattern
applied to it. For example, selecting a condensed pattern for an object will result in a
darker shade of the specified color. Similarly, selecting a sparser pattern for the same
object will result in a lighter shade of the same color. For more on selecting patterns, see
“Adding a Pattern to an Object” on page 141.
To reset the shading option:

1

From the File menu, select Properties.
The Options dialog displays.

2

From the Application node, select the General category.

3

In the Preferences area, check/uncheck Substitute Shades with Solid Color as
required.

4

Click OK.
Objects in the Design Area will be either shaded or colored depending upon the
specified settings.

1.Object with a solid interior color. 2. Object with a shaded interior.
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Working with Shade Lists
A shade list is an XML file containing different shades. Form Editor provides options for
creating customized shade lists within a form. Once customized shades for a particular
form are complete, they can be exported as a shade list in the external XML file format.
Similarly, an existing shade list can be imported for use with a new or an existing form.

Importing a Shade List
To import a shade list:

1

From the File menu, select Import, Shade List.
The Open dialog displays. You can only select XML files from the Files of Type
drop-down list.

2

Use the Look in drop-down list to search for the required folder.

3

Select the required shade list, and then click Open.
The specified shade list is loaded in the form.

Exporting a Shade List
To export a shade list:

1

From the File menu, select Export, Shade List.
The Save as dialog displays with Save as Type set to XML.

2

Use the Save in drop-down list to search for the required folder.

3

Specify the shade list name in the File name entry box, and then click Save.
The shade list is saved at the specified location.
You can also export a shade list into a resource library using the Resource
Manager tab in the Manage window. From the Brushes node, right-click the
selected palette list and select Export Resources from the pop-up menu. The
Export To dialog displays. Use the Save in drop-down list to select the target
folder and select the required resource library. Click Save to export the shade
list to the selected resource library.
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Chapter 7:

Using Text
In this chapter...


Enhancing Forms using Text



Special Characters



CJK Support

Enhancing Forms using Text
In Form Editor, text entered in the Design Area is treated as a text object. You can create
multiple text objects in a single form and position each as required. You can customize the
text used by applying various text format settings, such as underlining the text or changing
text direction.
You can manipulate text layout and appearance for a specific text object only. For
example, you can specify colors for the text and background of a text object. Similarly,
you can also activate or deactivate word wrapping, specify line spacing, as well as indent
the text in a text object.

Text Basics
The following tasks define the steps necessary to carry out basic text operations such as
inserting, editing, or positioning text.


Inserting Text (page 146)



Editing Text (page 147)



Positioning Text (page 147)
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Inserting Text
Once a form is opened in the Design Area, you can insert text objects of any specified
size.
To insert a text object in the form:

1

Click
on the Tools toolbar.
The toolbox above the Design Area updates and displays text-specific options. The
mouse pointer changes from

to

.

2

Using the mouse, draw a text object of the required dimensions at the appropriate
location in the Design Area.

3

Enter the required text in the text object.
The text will remain within the specified boundaries.
You can also insert a text object in the Design Area by clicking
from the
Tools toolbar. The toolbox above the Design Area updates to display textspecific options. Click at an appropriate place in the Design Area and enter the
required text. The dimensions of the text box are determined by the dimensions
of the most recently entered text object.

The bounding box for boxed text object displays according to the dimensions of
the text object. This feature is compatible with Elixir Application Suite.

For tasks related to entering CJK text using the keyboard, see “Entering CJK

Text” on page 175.
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Editing Text
To edit text that has already been entered:

1

Click

from the Tools toolbar.

The mouse pointer changes from

2

.

Double-click the required text box.
The mouse pointer changes from

3

to

to

.

Edit the text in the text object, as required.
The text in the text object updates as specified.

Positioning Text
To accurately place a text object in the Design Area:

1

Right-click the text object and select Properties from the pop-up menu.
The Properties - Text dialog displays.

2

From the Position category, specify the x and y coordinates of the top left corner of
the text object in the X and Y entry boxes.

3

Click OK.
The text object moves to the specified position.
You can also move a selected text object using one of the following methods:


Select and drag the text object to the required position.

or


Specify the x and y coordinates in the X and Y entry boxes in the
Common Attributes toolbar.

or


Move the text object using the arrow keys on the keyboard.

For increased accuracy, Form Editor lets you move object in either the horizontal or
vertical direction. For more on moving objects, see “Repositioning Objects” on page 271
in Chapter 12: Editing Forms.
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Text-Specific Properties
You can set and change various text properties in Form Editor. You can strike out text, use
different underline styles, reset text background and foreground color, and also perform
various text transformations such changing the direct of the text and scaling text.
The following sections describe each text-specific settings in detail.


Setting Font Properties (page 148)



Underlining Text (page 149)



Striking Out Text (page 150)



Setting Text Object Foreground and Background Color (page 151)



Setting Text Direction (page 152)

Options that are common to all objects are described in “Common Object Properties” on
page 263 in Chapter 12: Editing Forms.

Setting Font Properties
You can use different fonts within a single text object.
To edit the font properties of a text object:

1

Right-click the text object and select Properties from the pop-up menu.
The Properties - Text dialog displays.
To view text properties, do one of the following:


Right-click the text object and select Properties from the pop-up menu.

or
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Press Alt + Enter on the keyboard.

2

From the Font category, click Font List.
The Font List dialog displays. You can add, edit, or delete Windows and Elixir fonts
from the current font list available in this dialog. You can also review the selected
font properties, such as User Name, Name, Size, and Style of the font. For more
information on the Font List dialog, refer to “Fonts” on page 187 in Chapter 8: Fonts
and Font Lists.

3

Click OK.
Any changes made to the font list are saved.
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To use multiple fonts in a single text object, double-click the text object and
select the characters whose font needs to be modified. Select the required font
type from the Font Style drop-down list in the Text Attributes toolbox. The
font style of the selected text will update to the specified style.

Underlining Text
You can underline text objects using various line styles available in Form Editor.
To underline text:

1

Right-click the text object and select Properties from the pop-up menu.
The Properties - Text dialog displays.
If you want to underline only a few characters in the text object, double-click
the text object and select the required characters. Right-click the selected text
and select Properties from the pop-up menu to display the Properties - Text
dialog.

2

Select the Effects category.
The Effects category contains a predefined list of underline styles and thickness
settings that you can apply to the selected text object. Associated options enable you
to add a line through the selected text object and/or apply underline styles and
thickness to the selected characters or words within a text object.

3

Select an underline style from the Style drop-down list.

4

Select the required line thickness from the Thickness drop-down list.

5

If you want to underline only the words in a text object and exclude spaces, check
Only Words.

6

Click OK.
The text in the selected text object is underlined.

Underlined text object.
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You can also activate the underlining feature before adding the text to the
Design Area. Click
toolbox, click

from the Tools toolbar and in the Text Attributes
.

Striking Out Text
You can strike out all or some of the text characters in a text object.
To strike out text:

1

Right-click the text object and select Properties from the pop-up menu.
The Properties - Text dialog displays.
If you want to strike out only a few characters in the text object, double-click
the text object and select the required characters. Right-click the selected text
and select Properties from the pop-up menu to display the Properties - Text
dialog.

2

From the Effects category, check Strikethrough.

3

Click OK.
The text in the selected text object will update.

Applying strikethrough to a text object.

You can also activate the strikethrough feature before adding the text to the
Design Area. Click
Attributes toolbox.
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in the Text
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Setting Text Object Foreground and Background Color
You can apply predefined foreground and background colors to the characters inside a text
object. You can also review the selected color properties.
To set the text (foreground) and background color:

1

Right-click the text object and select Properties from the pop-up menu.
The Properties - Text dialog displays.

2

From the Color category, click Fg/Border.
The list of all available colors and associated properties display.
 Name: displays a list of available colors and associated names for selection.
 Model: displays the color model. You can choose a model as per your
requirements.
 1st Value: first color component saturation for the selected Model; value
between 0 - 255.
 2nd Value: second color component saturation for the selected Model; value
between 0 - 255.
 3rd Value: third color component saturation for the selected Model; value
between 0 - 255.
 4th Value: fourth color component saturation for the selected Model; value
between 0 - 255.

3

Select the required text color from the list.

4

Click Bg/Interior and select the required background color for the text object.

5

Click OK.
The color of the text object is changed to the selected color.
The list of available colors can vary depending on the color palette selected. You
can add colors to the existing color palette or you can use a different color
palette of your choice. For more information on colors, see Chapter 6: “Colors
and Patterns” on page 131.
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Setting Text Direction
To change the direction of text:

1

Right-click the text object and select Properties from the pop-up menu.
The Properties - Text dialog displays.

2

Select the Direction category and specify the required direction by selecting either
Across, Down, Back, or Up.

Down

Across

Back

Up

The image above illustrates the various text directions available.

3

Click OK.
The direction of the text object changes as specified.
You can also specify the text direction before adding the text to the Design
Area. From the Tools toolbar, click

and specify the required direction from

in the Text Attributes toolbox.
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Text Operations
You can perform various text operations such as importing text from RTF and TXT files,
join multiple text objects, split a text object and find and replace text in the Design Area.
The following tasks define the required steps.


Setting Text Import Options (page 153)



Importing Text (page 154)



Joining Text (page 155)



Splitting Text (page 157)



Reformatting Text (page 158)

Setting Text Import Options
Form Editor lets you preserve the RTF formatting of the original text at the time of pasting
and place the data at the required location using the mouse pointer. You can also specify
whether you want to import text as a single text object, or as multiple text objects where
each text object is a paragraph from the original text.
To set the text paste options:

1

From the File menu, click Properties.
The Options dialog displays.

2

From the Editor category, click Paste RTF to preserve the format of the RTF text.

3

Check Separate Paragraphs to import the text as separate paragraphs.
The Separate Paragraphs option is valid for TXT files only.

4

Check Lock Position to lock the position of the imported paragraph in the form.

You can also activate the locking option by selecting the required text object and
pressing F11.

5

Click OK to save the specified text format settings.
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Importing Text
Form Editor lets you import text from any file saved in the RTF or TXT format. Once the
text has been imported, you can change the attributes within the Design Area.
RTF files can contain font references. True Type or Adobe fonts can be saved to
Xerox format when the form is saved. Xerox fonts can also be substituted in the
Form Editor. All fonts must be in Xerox format before printing the form on an
Xerox printer.

To import a text file to Form Editor:

1

From the Edit menu, select Import Text.
The Text Import dialog displays.

For more information on importing CJK text, refer to “Importing Files” on
page 173.

2

Select the required file type from Files of Type drop-down list.

3

Browse for the required file, and then click Open.

4

Click at the required place in the Design Area to insert the text.
When inserting text as separate paragraphs, each click in the Design Area will import
a new paragraph until all paragraphs in the text file have been imported. In addition,
properties specified in the Text Attributes toolbar automatically apply to the plain
text that you import in Form Editor.
You can use the shortcuts listed below to perform the following tasks:
F3: imports previous paragraph.
F4: imports the next paragraph.
 Esc: cancels the process of importing text.
Separate Paragraphs must be selected from the Options dialog for the first
two methods to work. For more information, refer to “Setting Text Import
Options” on page 153.
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The text from the specified file is added to the Design Area, as shown below:

The text file is imported into the Design Area.

Bulleted text can be added to a form by either directly importing an RTF file with
bullets or by pasting them from Microsoft Word. The bullets are editable and
can be copied and pasted or deleted in Form Editor.

You also copy the editable text from Form Editor workspace and paste it in MS
Word. The text is pasted in MS Word with font ‘Times New Roman’ and point
size ‘12’.

Joining Text
Form Editor provides options for joining text objects in the Design Area. These options
help you in joining text that was broken when converting a form to the Elixir format.
When objects are converted, the text is positioned with absolute placement to maintain the
exact dot-to-dot correspondence with the original document. Although this conversion
enables exact character placement, editing the converted text is very tiring. Joining objects
makes the document easier to edit, and makes it possible to run the spell check properly.
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Broken text objects are also common in forms. This is because the forms place
phrases or lines individually to achieve greater quality. When editing text in a
form, you can also use the join text options, as explained in subsequent sections.

Using Join By Spaces Option
To join text objects, select the required text objects and, from the Tools menu, select Join
Text, Join By Spaces. This option joins the selected text objects by placing each text
object under the previous text object. The following conditions apply when using this
option:


If two objects are placed adjacently with a distance of less than 0.1 inches between
them, then joining the two objects using the Join by Spaces option will result in the
objects being joined and placed within the same line.



If two objects are combined together, where the first object is word wrapped, then
the next object may or may not appear under the first object depending on the width
of the first text object.

If the width of the joined text object is increased, then the text will appear within the same
line.

The text objects are
joined together using the
Join by Spaces option.

The two objects
are joined.

The text appears in
the same line after
increasing the width
of the joined text.

Also note that if the width of the first text object is increased before joining, then the
joined text object will appear in the same line.

The text objects are joined
together using the Join by Spaces
option. The width of the first text
object is increased before joining.
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The joined text object
appears in the same line.
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You can also join multiple text objects by clicking
from the Select
toolbox and selecting Join By Spaces from the pop-up menu.

Using Join By Justify Option
To join text objects by justification, select the required text objects and, from the Tools
menu, select Join Text, Join By Justify. This option joins the selected text objects into
one continuous paragraph. The width of the paragraph is determined by the position of the
left and the right most text character.

You can also join multiple text objects by clicking
from the Select
toolbox and selecting Join By Justify from the pop-up menu.

Using Join By Relative Option
From the Tools menu, select Join, Join by Relative. This option joins the selected text
objects by retaining the original position of the text objects.

You can also join multiple text objects by clicking
from the Select
toolbox and selecting Join By Relative from the pop-up menu.

Splitting Text
You can split a single text object into two objects. Double-click the text object and place
the cursor at the location where you want to split the text. From the Tools menu, select
Split Text. The text splits into two objects at the specified place.

You can also split text by double-clicking within the text and clicking
in the
Text Attributes toolbox. The text object will split at the cursor position.
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Reformatting Text
When Elixir PrintDriver Pro creates a document identical to the original source,
sometimes the text appears to be overwriting itself in the form. For more information,
refer to Chapter 9: “Using Elixir PrintDriver Pro” on page 201.
To reformat the text objects to the default settings:

1

Select the required text object.

Notice that “This interpretation” (first line) seems to be formatted incorrectly.

2

From the Tools menu, select Reformat Text.
The text object reformats and the fonts now read correctly.

The text is now formatted correctly.

158

DesignPro Tools Form Editor® for Xerox User Guide

Finding Text
Form Editor lets you search for every occurrence of a specific word or phrase in the form.
To find text within a form:

1

From the Edit menu, select Find.
The Find dialog displays.

2

In the Find What entry box, specify the text to search.
You can specify whether or not to search for whole word occurrences of the
specified string by checking/unchecking Match Whole Word Only. You can
also specify your search to be case-sensitive by checking Match Case.

3

In the Direction area, specify one of the following:
 Up: sets the search direction upward.
 Down: sets the search direction downward.

4

Click Find Next to find the next occurrence of the specified text in the form.
If the current occurrence is the last occurrence in the specified direction, a message
box will pop-up to inform you that Form Editor has finished searching.

You can also search for the next occurrence of the most recently specified text
string in the form by selecting Find Next from the Edit menu.

Replacing Text
You can use the Form Editor to automatically replace selected text in the form with
another specified text string.
To replace selected text in the form:

1

From the Edit menu, select Replace.
The Replace dialog displays.

2

In the Find What entry box, specify the text to find and, consequently, replace.
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3

In the Replace With entry box, specify the text string that will replace selected
occurrences of the specified search string.
You can specify whether or not to search for whole word occurrences of the
specified string by checking/unchecking Match Whole Word Only. You can
also specify your search to be case-sensitive by checking Match Case.

4

Click one of the following:
 Find Next: displays the next text string occurrence.
 Replace: replaces only the current occurrence of the specified text.
 Replace All: replaces all occurrences of the specified text on the form.
Form Editor will find and/or replace all instances of the specified text string on the
form.

Text Layout
Form Editor lets you create multiple text objects in a single form. Each text object has
certain associated properties that are used to set the text layout. For example, you can
specify text justification, both horizontally and vertically, for a selected text object. You
can also activate or deactivate word wrapping, specify tab and indentation values, as well
as set line spacing for a specified text object.
The following tasks define steps that allow you to modify the layout of a text object:
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Setting Text Tabs Option (page 161)



Setting Text Indents Option (page 163)



Using Word Wrap (page 164)



Setting Text Justifications Options (page 164)



Setting Text Spacing (page 166)



Setting Line Spacing (page 167)



Removing Redundant Spaces (page 168)
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Setting Text Tabs Option
You can set the default spacing between the tab stops in the Design Area. You can also
define tab stop positions and alignment relative to the tab stop. You can also set the default
spacing between tab stops, extend text to the right or left from the tab stop, align a decimal
point at the tab stop, and add or remove solid, dotted, or dashed leader lines.
To specify tab settings:

1

Right-click the text object and select Properties from the pop-up menu.
The Properties - Text dialog displays.

2

Select the Tabs category and specify a tab spacing value for the selected text object,
in the Tab Stop Position entry box.
The value you enter in the Tab Stop Position entry box, will be specific to the
selected text object only. You can also select a default tab spacing value for all
text objects on the form by specifying a value in the Default Tab Stop entry
box and clicking Clear All to remove all tab spacing values previously entered, if
any.

3

Specify the text alignment with respect to the tab stop in the Alignment area by
selecting one of the following:
 Left: aligns the text to the left of the tab stop.
 Right: aligns the text to the right of the tab stop.
 Center: aligns the text to the center of the tab stop.
 Decimal: aligns the decimal point at the tab stop.

4

In the Leader area, specify whether to leave tab spaces blank or to fill them with
either periods, dashes, or a line by selecting one of the following:
 1 none: does not fill space.
 2……: fills space with leading periods.
 3------: fills space with leading dashes.
 4____: fills space with a leading underline.
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5

Click Set to add the specified tab position to the list.
You can add multiple tab positions to the list by repeating this task. This lets you use
multiple tab positions within a single text object as you can select the required tab
position from the list.
To remove any unnecessary tab stop position values from the list, select the
required tab stop position value and click Clear. You can also remove all
previously entered tab stop positions by clicking Clear All.

6

Click OK when you have set the Tab Stop Position list as required.
The specified tab stop position is saved in the Tab Stop Position list.
0.5
0.75
1.0

The image above displays the effects of setting tab position at 0.5, 0.75 and 1.0.

You can also specify default tab spacing for text objects at both the application
level and page level. Select Properties from the File menu to display the
Options dialog. Select the Tabs category from either the Application node
t(o specify application level settings), or the Page node (to specify page level
settings) and repeat steps 2 and 6.
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Setting Text Indents Option
Form Editor provides options for setting indentation values for text in a text object.
To set the indentation options:

1

Right-click the text object and select Properties from the pop-up menu.
The Properties - Text dialog displays.

2

Select the Indents category and enter a value specifying the spacing between the left
boundary of the text object and the associated text in the Left entry box.

3

In the Right entry box, specify the spacing between the right boundary of the text
object and the associated text.
You can apply special indentation options to the text inside a text object. In the
Special drop-down list, specify one of the following:
None: no indentation is applied.
First Line: indents the first line of text only.
 Hanging: indents all but the first line of text.
After selecting the required indentation option above, specify the indentation
value in the By entry box.



4

Click OK.
The specified indentation settings are saved.
Left 0.5

Right 1.0

The image above displays the effect of setting left indentation to 0.5 and right
indentation to 1.0.

You can also specify indentation settings for text objects at both the application
level and page level. Select Properties from the File menu to display the
Options dialog. Select the Indents category from either the Application
node, or the Page node and repeat steps 2 to 4.
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Using Word Wrap
Form Editor provides the word wrap feature that lets you wrap the text overflow in a text
object to the next line. This maintains the original dimensions of the text object.
To use word wrap:

1

Click
in the Tools toolbar.
The Text Attributes toolbox displays above the Design Area.

2

Click

3

Draw a text object in the Design Area.
Any text entered in the text object is word wrapped and its original dimensions are
maintained.

in the Text Attributes toolbox to activate the word wrap feature.

To activate/de-activate the word wrap option after drawing a text object, rightclick the text object and select Properties from the pop-up menu to display the
Properties - Text dialog. From the Justification category, check or uncheck
Word Wrap and click OK.

Setting Text Justifications Options
You can justify text inside a text object both horizontally and vertically.
To set text justification options:
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1

Right-click the required text object and select Properties from the pop-up menu.
The Properties - Text dialog displays.

2

From the Justification category, select one of the following from the Horizontal
Justification drop-down list:
 Left: justifies the text towards the left boundary of the text object.
 Right: justifies the text towards the right boundary of the text object.
 Center: justifies each line of text so that the spacing between the text and the left
and right boundaries of the text object are equal.
 Full: justifies text so that spacing between the text and both the left and right
boundaries of the text object is minimized. This is achieved by adding extra
spaces between some words or by adding extra spaces after all characters. For
more information, see “Setting Text Spacing” on page 166.
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Justification example:

Horizontal Justification.

You can also set the horizontal justification of a selected text object to left,
center, right or full by clicking
Attributes toolbox.

3

,

,

or

from the Text

Select one of the following from the Vertical Justification drop-down list:
 Linebase: sets the dimensions of the text object such that spacing between the
text and the upper and lower boundaries of the text object is minimized.
 Top: aligns the text towards the upper boundary of the text object.
 Center: aligns the text towards the center of the text object resulting in equal
spacing between the upper and lower boundaries of the text object.
 Bottom: aligns the text towards the lower boundary of the text object.

Vertical Justification.

You can also set the vertical justification of a selected text object to linebase,
top, center, or bottom by clicking
Attributes toolbox.
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,

,

or

from the Text
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4

Click OK.
The specified settings are saved.
Setting the vertical justification of a text object to either top, center or bottom
activates the boxed text mode. In boxed text mode, the boundaries of the text
objects are displayed as the text is being entered.

Setting Text Spacing
Form Editor uses text spacing to add extra spaces between words or characters in a text
object. When Horizontal Justification is set to Full, the spacing between the text inside a
text object and the left and right boundaries is minimized. This is accomplished by using
text spacing to even out the extra spaces between the text and the text object boundary.
You can either add spacing between words or characters, depending on what is more
suitable for your form.
To specify text spacing:

1

Right-click the required text object and select Properties.
The Properties - Text dialog displays.

2

From the Justification category, specify one of the following in the Additional
Spacing drop-down list:
 Inter-word Spacing: modifies the spaces between words within a specified text
object to adjust the layout of text.
 Inter-character Spacing: modifies the spaces between characters within a
specified word in the selected text object to adjust the layout of text.
 Automatic Select: modifies the spaces by using the default settings for this
option.

1) Inter-word spacing.
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2) Inter-character spacing.
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3

Click OK.
The specified settings are saved.
You can also specify either inter-word spacing or inter-character spacing for a
selected text object by clicking

or

on the Text Attributes toolbox.

Setting Line Spacing
You can set the line spacing for a text object, which determines the amount of vertical
space between lines of text.
To set line spacing:

1

Right-click the text object and select Properties from the pop-up menu.
The Properties - Text dialog displays.

2

From the Justification category, check Line spacing and enter the required value in
the entry box below it.

1) No line spacing applied.

2) Line spacing is 6 Lines per inch (LPI).

You can also specify line spacing for a selected text object by clicking
from
the Text Attributes toolbox and specifying an appropriate spacing value in
.

3

Click OK.
The specified line spacing is applied to the text object.
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Removing Redundant Spaces
Form Editor provides the facility of removing all redundant spaces within a selected text
object.
To remove all redundant spaces:

1

Double-click the required text object.
The mouse pointer changes from

2

to

.

In the Text Attributes toolbox, click
.
All redundant spaces are removed from the selected text object.

Special Characters
Form Editor lets you add characters that do not appear on your keyboard such as “.” or “®
”. These characters are referred to as special characters and can be added to your form by
either of the following methods:


Adding Special Characters Using the Soft Keyboard (page 168)



Adding Special Characters Using the Character Map (page 170)

Adding Special Characters Using the Soft Keyboard
To add special characters to a form using the soft keyboard:
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1

Insert a text object in the form and specify the required font from the Font Style
drop-down list in the Text Attributes toolbox.
For more information on inserting text objects on a form, see “Inserting Text” on
page 173.

2

On the Text Attributes toolbox, click
.
The Soft Keyboard dialog displays. The Font Name entry box in the Soft Keyboard
dialog displays the name of the selected font type. Each font type has its own set of
associated special characters that also display in the Soft Keyboard dialog.

3

From the Subrange drop-down list, select the required language to view associated
special characters.
Selecting All Unicode from the Subrange drop-down list will enable you to select
character sets associated with specific languages in the Character Set drop-down list.
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4

Click in the Design Area where you want to place your text, and then double-click
the required character in the Soft Keyboard dialog.

You can view the characters from close up by checking Zoom on the Soft
Keyboard dialog.

The character adds to the form at the specified place. Repeat this step to add more
special characters.

Selecting the “@” character from the Soft Keyboard adds it to the form.

5

Click OK when you are done adding all of the required special characters to your
form.
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Adding Special Characters Using the Character Map
You can use the Character Map dialog to copy and paste special characters in the form.
This dialog provides options for viewing characters that are available for a selected font.
The Character Map dialog displays the following character sets:


Windows



DOC



Unicode

To add special characters to a form using the Character Map dialog:

1

From the Start menu, select Programs, Accessories, System Tools, Character
Map.
The Character Map dialog displays.

2

As appropriate, review the dialog selections and make your changes.

3

Double-click the required character(s) from the Character Map dialog, and then
click Select to return to the Form Editor.
Refer to the Windows manual for more information on this dialog.

4

Right-click in the target location in the Design Area, and then select Paste from the
pop-up menu.
All selected special characters are added to the form.

Setting Character Mapping Options
Character Maps specify all characters available for a specified font type. You can
customize the Character Maps by replacing individual or groups of characters by
characters of your choice.
Mapping Characters using the Keyboard
To map characters using the keyboard:
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1

From the File menu, select Properties.
The Options dialog displays.

2

From the Character Mapping category, check Use KMP in the Keyboard Input
area to activate all associated fields.
This informs Form Editor to translate keystrokes using tables from the KMP files.
The KMP files used contain the character set maps and output maps.
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3

Select the required character map file for the current keyboard layout from the
Source drop-down list.

4

Select the required character map file for the target keyboard layout map file from
the Target drop-down list.

5

Select the required font character set in the Charset drop-down list.
This specifies the required Windows encoding needed to convert from Unicode to
ASCII and vice versa.

6

Click OK.
The specified character mapping settings are saved.

Mapping Characters from an Imported File
To map characters from an imported file:

1

From the File menu, select Properties.
The Options dialog displays.

2

From the Character Mapping category, check Use KMP in the Text Import area to
activate all associated fields.
This informs Editor to use the custom translation tables to map the characters. The
KMP files used contain the character set maps and output maps. This option is used
when text is imported into Form Editor.

3

Select the required character map file for the current keyboard layout from the
Source drop-down list.

4

Select the required character map file for the target keyboard layout map file from
the Target drop-down list.

5

Select the required font character set in the Charset drop-down list.
This specifies the required Windows encoding needed to convert from Unicode to
ASCII and vice versa.

6

Click OK.
The specified character mapping settings are saved.
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Mapping Characters Copied from an External File
To map characters copied from an external file:
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1

From the File menu, select Properties.
The Options dialog displays.

2

From the Character Mapping category, check Use KMP in the Text Paste area to
activate all associated fields.
This informs Form Editor to use the translation tables to map characters. The KMP
files used contain the character set maps and output maps. This option is used when
text is pasted in the specified area in Form Editor.

3

Select the required character map file for the current keyboard layout from the
Source drop-down list.

4

Select the required character map file for the target keyboard layout map file from
the Target drop-down list.

5

Select the required font character set in the Charset drop-down list.
This specifies the required Windows encoding needed to convert from Unicode to
ASCII and vice versa.

6

Click OK.
The specified character mapping settings are saved.
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CJK Support
Form Editor provides support for Chinese, Japanese, or Korean (CJK) texts. You can add
CJK text to forms and save these forms in different output formats.
The following tasks define the steps involved to insert CJK text, specify the wordwrapping feature, or to save the forms in a different output format.

Inserting Text
Form Editor provides support for inserting Chinese, Japanese, and Korean (CJK) text in
your form. The sections below explain the three different ways to insert CJK text in a
form:


Inserting Text (page 173)



Importing Files (page 173)



Pasting Text from Other Applications (page 175)



Entering CJK Text (page 175)

Inserting Text
For information on inserting a text object, refer to “Inserting Text” on page 146.

Importing Files
Form Editor lets you import CJK files in various encoding formats to a form design. These
files are added to the design as text objects. You can import Unicode RTF (Rich Text
Format) files, UTF-8, UTF-16 encoded text files and DBCS encoded Text (TXT) files.
RTF files are imported with their inherent encoding. Text formatting in an RTF file is also
retained on import (for example, red-colored text in the RTF file will be imported to the
Form Editor in the same red color). However, for encoded text files, you can select the
appropriate encoding standard.

Chapter 7: Using Text

173

Importing the Unicode and DBCS Encoded Text Files
To import the UTF-8, UTF-16 encoded text files and DBCS encoded Text (TXT) files:

1

From the Edit menu, select Import Text.
The Text Import dialog displays.

2

Browse to the required file and select it.

3

Click Open to import the text in the selected file.
The File Conversion dialog displays.

4

Select the applicable encoding standard from the Text Encoding drop-down list.
The Preview box shows how the imported text will look with the currently selected
encoding.

For tasks related to entering CJK text using the keyboard, see “Entering CJK

Text” on page 175.

5

Click OK.
The mouse pointer changes from

6

to

.

Move the pointer to the required position in the Design Area and click to insert the
imported text.

Importing Unicode RTF Files
To import the Unicode RTF (Rich Text Format) files:

1

From the Edit menu, select Import Text.
The Text Import dialog displays.

2

Browse to the required file and select it.

3

Click Open to import the text in the selected file.
The mouse pointer changes from

4
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to

.

Move the pointer to the required position in the Design Area and click to insert the
imported text.
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Pasting Text from Other Applications
You can copy CJK text from MS-Notepad or MS-Word and paste it in Form Editor. The
copied text is pasted as a text object in the form.
To paste CJK text in a form:

1

Open the required form in the Form Editor.

2

Open the file (containing the required text) in MS-Word or MS-Notepad (whichever
applicable).

3

Select the required text from the file.

4

From the Edit menu of the (Word/Notepad) file, click Copy.

5

Open the Form Editor window and paste the copied text in the Design Area by
selecting Edit, Paste from the main menu.
You can also paste the text in a form using one of the following methods:


Right-clicking in the Design Area, and selecting Paste from the pop-up
menu.

or


Pressing Ctrl + V on the keyboard.

Entering CJK Text
If you are running the Form Editor on a Chinese version of Windows, entering Chinese
text will be the same as entering the text normally. Similarly, Japanese and Korean text can
be entered in a form in the typical manner if you are using the respective language
versions of Microsoft Windows.
Form Editor also allows the users of English (or other) versions of Windows to type
Chinese, Japanese, or Korean text in a form design. This is accomplished by the use of
Input Method Editors (IMEs) for these languages. Microsoft has devised these IMEs for
different languages to enable users to input East Asian characters using a regular English
keyboard. Windows XP comes with the standard IMEs that are based on the most popular
input methods used in each of these languages.
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Once you have more than one language installed on your operating system, a Language
Bar displays, allowing you to shift between the different languages. Using the Language
Bar, you can compose the required text in any of the available ways (i.e., by radical, by
stroke count, by phonetic representation, or by entering in the character's numeric
encoding index).
You can customize the Language Bar display settings from the Regional and
Language Options dialog. Refer to the relevant Microsoft documentation for
more assistance.

The following tasks explain the basic steps involved in entering the CJK text for the users
of the English version of Microsoft Windows:


Entering Chinese Text (page 176)



Entering Japanese Text (page 179)



Entering Korean Text (page 181)

For more detailed information regarding the use of the IME Language Bar for entering the
Chinese, Japanese, or Korean text, refer to the relevant documentation by Microsoft.
Entering Chinese Text
Microsoft Windows offer various scripts for Chinese languages. Entering methods and
other settings for different scripts vary. The following example guides you through a
method used for entering Simplified Chinese. Form Editor lets you use other scripts
(namely GB18030, GB2312, and GBK).
To enter Chinese (Simplified) text on an English version of Windows:

1
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On the Language Bar, select Chinese (PRC) as the input language from the dropdown-list of installed languages.
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The associated options display in the Language Bar.
Chinese/English input(Shift)

Input Language

2

Select Chinese from the Chinese/English Input (Shift) toggle button on the
Language Bar.

3

Insert a text object in the Design Area using the Tools toolbar.
For inserting a text object, see “Inserting Text” on page 173.

4

Enter the required Chinese character.
The Input Method Editor makes up a Chinese character using a combination of 2-3
English characters. Enter the first character of the combination from the keyboard.
Two text bars displays in the Design Area. The smaller text bar shows the
combination of English characters before they make up a Chinese character. Once
composed, the Chinese character is displayed in the longer bar. The longer text bar,
therefore, shows the entered Chinese characters before you enter them on to the
form.

Design Area displaying the first character entered on the text bar.

In order to use Chinese text in your design, you also need to apply a font that
contains Chinese characters (for example, SimSun, Sim Hei, Arial Unicode MS,
MingLiu) to the text object.

Chapter 7: Using Text

177

5

Enter the remaining characters in the combination.

Text bar displaying the combination of three English characters.

6

Press Space to complete the combination and generate the Chinese character as
shown in the image below:

A Chinese character may also be generated before you press Space, if the IME
finds an appropriate combination.
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7

Similarly, add the remaining combinations of English characters to make up a word
of Chinese characters.

8

Press Enter to insert the text in the Design Area.
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The entered text displays at the position where the mouse pointer was placed for the
inserted text object.

Before you press Enter, make sure that the word is complete and the smaller
text bar is not displaying in the Design Area. To cancel the smaller text bar, press
Esc on the keyboard.

Entering Japanese Text
To enter Japanese text on an English version of Windows:

1

On the Language Bar, select Japanese as the input language from the drop-downlist of installed languages.

The associated options display in the Language Bar.
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2

Select Hiragana from the Input Mode drop-down list on the Language Bar.

3

Insert a text object in the Design Area using the Tools toolbar.
For inserting a text object, see “Inserting Text” on page 146.

4

Enter the required text.
A text bar appears in the Design Area to display the entered text.

Design Area displaying Japanese text entered on the text bar.

In order to use Japanese text in your design, you also need to apply a font that
contains Japanese characters (for example, MS Gothic) to the text object.
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5

Press Enter to insert the text in the Design Area.

The entered text displays at the position where the cursor was placed for the inserted
text object.
Entering Korean Text
To enter Korean text on an English version of Windows:

1

On the Language Bar, select Korean as the input language from the drop-down-list
of installed languages.

The associated options display in the Language Bar.
Han/Eng toggle

Input Language

2

Press the Han/Eng toggle button on the Language Bar to display as
for entering Hanja characters.

Chapter 7: Using Text

181

3

Insert a text object in the Design Area using the Tools toolbar, and then enter the
required Korean text.
For inserting a text object, see “Inserting Text” on page 173.

The entered text displays at the position where the cursor was placed for the inserted
text object.

In order to use Korean text in your design, you also need to apply a font that
contains Korean characters (for example, Tahoma) to the text object.

Setting Text Properties
Once the required CJK text has been inserted in a form design using any of the abovementioned ways, you can apply different fonts to it. You can also add the required
underline styles and foreground or background colors, and specify the horizontal and
vertical justification for the text. Additional let you set word, character, and line spacing.
You can set the direction, rotation, indentation, and tab properties of the text for its precise
placement on a form. For detailed information regarding the use of text objects in Form
Editor, see “Text-Specific Properties” on page 148.

Word Wrapping
Most CJK text requires special handling for the beginning and ends of lines, which is
commonly called word wrapping or hyphenation. There are some characters, usually
punctuation and enclosing characters, that should not begin a new line, and like-wise,
there are characters that should not terminate a line. There are similar rules in English, but
they are much more important for CJK text because there are no spaces between words
(punctuation marks are treated like any other character).
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To apply word wrapping:

1

Select the required text object in the Design Area.

2

From the Tools menu, select Word Wrap and then any of the following options:
 Wrap Up: applies the wrap-up line breaking rule on the selected text object. The
following images show the effect of this option:

1) A text object with two lines beginning with a question-mark, 2) The questionmarks wrapped-up to the previous line.


Wrap Down: applies the wrap-down line breaking rule on the selected text
object. The following images show the effect of this option:

1) A text object with the first two lines ending with a closing bracket, 2) The two
brackets wrapped-down to the next lines.


Dangling Punctuation: applies the line breaking rule of dangling punctuation on
the selected text object.
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The text object layout modifies according to the options specified.

You can apply more than one of these rules on a single text object, if required.

The following are the three fundamental methods used to line-break or word wrap
CJK text:
Wrap Down
Wrap-down line breaking works by forcing characters (that are not allowed to
terminate a line) to shift down to the next line.
The following is a list of characters that are wrapped down in CJK text:
“ ‘ ”, “ @ ”,““ ”,“ ”, “ §”,“ ( ”,“ ”,“”, “ ”,“ ”,“ # ”,“[”,“¥”,“{”, “$”,“<”,“£”.
Wrap Up
Wrap-up line breaking works by moving characters (that are not allowed to begin a
line) to shift up to the end of the previous line.
Dangling Punctuation
In a CJK text, if a certain character (such as punctuation such as a period or a
comma) is left hanging on the right margin, it is wrapped up to the previous line.
Dangling punctuation can be considered as a special case of the wrap-up rule.
The following is a list of wrap-up characters and characters that are handled as
dangling punctuation in CJK text:
“ " ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ °”, “ — ”, “ – ”, “ ‰”, “ ¤ ”, “
?”, “”, “”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “ ”, “”, “ ”, “”, “”, “”, “”, “ ”, “”,
“”, “”, “”.
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Saving Forms
Form Editor has been enhanced to provide font conversion and CJK support in the
following formats:


Elixir Form (EFR)



Elixir Legacy Form (ELX)
For information, refer to “Saving a Form to Elixir Format” on page 64 in Chapter 3:
Form Basics.



PDF Page (PDF)



PostScript (PS)

Saving in PDF and PS Formats
In order to save a form resource in Printable Document Format (PDF) or PostScript (PS)
format, Form Editor has been enhanced for handling CJK text and font conversion.
When a form is saved as a PDF Page or PostScript (PS), the True Type fonts used in the
form are converted automatically to the CID Outline format.

True Type fonts with selective scripts (namely GB2312, Shift-JIS, Hangul, BIG5,
and Unicode) are currently supported.
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Chapter 8:

Fonts and Font Lists
In this chapter...


Fonts



Working with a Font List

Fonts
Form Editor lets you apply different fonts for the text used in a form. You can select the
required fonts from the different font types supported in Form Editor. Required fonts are
first added to the font list, and then applied to text object. You can add, edit, and delete
fonts and set or change their properties.
You can use multiple fonts on a single form. Each form has its own unique font list to
which you can add or remove fonts. The following tasks define steps to add or edit font
lists.


Specifying a Default Font List (page 188)



Viewing Font Properties (page 189)



Adding Fonts to a Font List (page 192)



Making Changes to a Font List (page 197)



Importing a Font List (page 199)



Exporting a Font List (page 200)
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Font Types Supported in Form Editor
Form Editor supports Windows and External fonts that you can use while composing
forms. The available font types are:


Windows Fonts: includes both True Type and Adobe Type Manager (ATM) fonts.



External Fonts: Elixir and Elixir legacy, Xerox and PCL fonts.

Working with a Font List
A font list can be saved as either an XML or LST file containing different fonts. A font list
is included by default in every form created in Form. It enables you to manage all of the
fonts required in a form with more ease. You can add fonts with different specifications
(size, style, width, etc.) and assign meaningful names to them. Later on, you can apply
these to text by selecting the appropriate name. At any time during the design process, you
can also add more fonts, edit/delete the existing fonts, and re-arrange the list. You can also
import and export font lists.

Specifying a Default Font List
A font list can be saved as either an XML or LST file containing different fonts. In Form
Editor you can specify a default font list for forms. You can also create your own font list
or import an existing font list. Similarly, you can also export a font list to allow other
forms to use existing font lists.
To specify a default font list:
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1

From the File menu, select Properties.
The Options dialog displays.

2

From the Editor category, check Set Font List at New Doc/Form.

3

Click
from the Font List area.
The Open dialog displays.

DesignPro Tools Form Editor® for Xerox User Guide

4

Select the required font list and click Open.
The path associated with the specified font list is added to the entry box adjacent to
.

5

Click OK.
The specified font list is set as the default font list.

Viewing Font Properties
A font list consists of fonts and their associated properties that are available to a specific
form. You can view these properties in the Font List dialog. You can also customize the
Font List dialog to view/hide font properties.
To view font properties:

1

Click
from the Tools toolbar.
The Text Attributes toolbox displays above the Design Area.

2

Click
from the Text Attributes toolbox to display the Font List dialog.
The Font List dialog consists of the font list, an associated toolbar to manage the list,
and a Preview area to view sample text using any font selected from the font list. The
font list displays the fonts available for use in the active form along with their
respective properties.
You can sort the font list according to a font property by clicking on that specific
font heading. If the font list is already sorted according to that property, then the
sorting order will reverse.
You can also specify the order of the fonts in the font list by clicking either
,
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, or

,

.
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Refer to the following image:

Font list toolbar.

Font list for the
active document.

Sample text using
the selected font.

The Font List dialog.
The Font List dialog consists of the font list, an associated toolbar to manage the list,
and a Preview area to view sample text using any font selected from the font list. The
font list displays the fonts available for use in the active form along with their
respective properties.
You can customize the Font List dialog to display only columns of your choice.
Click
in the Font List dialog to open the Customize Columns dialog.
Select the required column name from the list and click Show/hide to specify
whether or not to view the property column in the Font List dialog. You can
specify column order by using the Up, Down, To Top, or To Bottom buttons.
To resort to the default settings, click Reset.
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Font Properties


User Name: displays the user-assigned name for the font.



Name: displays the actual name of the font.



Size: displays the font size.



Script: displays the scripts for selection.









Usage: system-generated value indicating the number of times the font is
used in the current form.
Coded Name: alphanumeric font name generated for Elixir, True Type, or
ATM fonts used in the form.
SBCS/DBCS: displays the character set options. You can either select
SBCS (uses a Single Byte character set) or DBCS (uses a Double Byte
character set).



Encoding: displays the font encoding options. Either:



EBCDIC: sets to Enhanced Binary-Coded Decimal Interchange Code.



ASCII: sets to the American Standard Code for Information Interchange.



UNICODE: sets to UNICODE.





3

Style: lists available font styles for selection; displays R for regular, I for
Italic, B for Bold, and BI for Bold Italic font.

Rotation: displays the font character rotation options. You can select 0,
90, 180, or 270 degrees counter-clockwise font rotation.
Met Tech: displays the Raster Font Metric Technology settings. You can
set it to either None or Fixed.



Ratio: specifies the ratio of scaling width relative to the height in a font.



Width: displays the font width.



DPI: displays the font resolution.

Click OK.
Any changes made to the font list or its format will be saved.
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Adding Fonts to a Font List
Forms created in Form Editor have an associated font list. A font list is a set of fonts used
in creating a form overlay. A font list may contain one or many fonts, and is specific to
one form. You can add or edit fonts in a font list as required.
Refer to the following tasks for more information:


Adding a Windows Font (page 192)



Adding an External Font (page 194)

For more on font lists and their properties, see “Making Changes to a Font List” on page
197.

Adding a Windows Font
Form Editor provides options for adding True Type and ATM fonts to a font list. True
Type fonts are Windows-based outline fonts technology used by Microsoft. Adobe Type
Manager (ATM) fonts are PostScript Adobe Type 1 fonts.
To add a Windows font to the font list:

1

Click
on the Tools toolbar.
The Text Attributes toolbox displays above the Design Area.

2

Click
on the Text Attributes toolbox.
The Font List dialog displays.

Press F9 on the keyboard to open the Font List dialog for changing a font.

3

Click
in the Font List dialog and select Windows Font from the pop-up menu.
The Font dialog displays.

You can also right-click a font in the Font list area of the Font List dialog and
select Add, Windows Font to open the Font dialog.
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4

Select the required font from the Font list.
The name of the specified font is added to the Font entry box. The Script drop-down
list displays the available scripts for the selected font.

5

Select the required script from the Script drop-down list.
The Font list will update to show all fonts available for the specified script.

6

Select a font style from the Font Style list.

You can use a font with a unicode character set by checking Use Unicode
Script. This will disable the Script drop-down list.

The selected style will be entered into the Font Style entry box.

7

Select the font size from the Size list.
The specified size will be added to the Font Size entry box. You can view text using
specified font settings in the Sample area.
You can also specify the font size in pels by selecting Use Fixed Width. Enter
the font width in Width (pels) and resolution in DP1 entry boxes. These two
options are activated only if Use Fixed Width is selected.

8

Select the required font orientation from the Default Orientation area.
You can specify the default orientation for a selected font only if you have
activated True Type font default orientation. To do so, from the File menu,
select Properties. The Options dialog displays. From the Editor category,
check Enable True Type Font Default Orientation and click OK.

9

Click Add.
To add multiple Windows fonts, repeat steps 4 to 9.
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10 Click End to return to the Font List dialog.
The selected font(s) are added to the font list. You can view the font type selected in
the Preview area of the Font List dialog.
To select the required font from the font list, use the Up/Down arrow keys, and
then press Enter to apply the selected font. To change the font name, doubleclick the User Name column of the required font and enter the new font name
in the entry box. Press Enter to apply the change. Press Esc to cancel the font
change.

11 Click OK.
The font is saved in the font list.
User names for True Type fonts are preserved in Elixir Legacy Forms (ELX) forms while
saving or converting them. A maximum of 6 character user names are allowed.
You can edit the font properties of any Windows font in the font list. For more information
on editing Windows font properties, see “Changing the Properties of a Windows Font” on
page 198.

Adding an External Font
Form Editor lets you use external fonts on your form. External fonts, also referred to as
ASCII fonts, consist of only a character set and no code page. Examples of external fonts
include all Xerox, PCL and ASCII versions of Elixir fonts.
To add an external font to the font list:

194

1

Click
on the Tools toolbar.
The Text Attributes toolbox displays above the Design Area.

2

Click
on the Text Attributes toolbox.
The Font List dialog displays.
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3

Click
in the Font List dialog and select External Font from the pop-up menu.
The Open Resource File dialog displays.

You can also right-click a font in the font list area of the Font List dialog and
select Add, External Font to open the Open Resource File dialog.

4

Select the required font type from Files of Type drop-down list.
You can select PCL Font (FLJ; PCL), Xerox font (FNT), or Elixir Legacy Coded
Font files (X0*.cdf, X1*.cdf, X2*.cdf, X3*.cdf, X4*.cdf).
You can also add a font stored in the Elixir Resource Library by selecting
Resource Library (*.erc32; *.erc) from the Files of Type drop-down list.
For more information, refer “Importing Resources to a Resource Library”
on page 82 in Chapter 4: Resources and Formats.

5

Select the required font, and then click Add to add the selected font to the font list.

To add multiple fonts from the Open Resource File dialog, press Ctrl and
select the required fonts. Click Add to add the specified fonts to the font list.

6

Click End to return to the Font List dialog.
The selected font is added to the font list. You can view the font selected in the
Preview area of the Font List dialog.
You can edit the font’s user name by selecting the font and double-clicking in the
User Name column. Enter the required name in the entry box that displays
and press Enter.
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7

Click OK.
The font is saved in the font list.

Windows fonts are displayed
with the symbol

.

External fonts are displayed
with the symbol

.

Coded fonts are displayed
with the symbol
.
Font pairs are displayed
with the symbol

.

The image above explains the symbols used for different types of fonts.

Xerox toolset supports only Windows and External fonts.

The symbols attached to the fonts names in the User Name column of the
Font List dialog indicate font orientation.
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Making Changes to a Font List
After creating a font list, you can make several changes to it, such as editing font
properties, replacing fonts, or deleting fonts. Review the following sections for more
information on making changes to the font list.

Deleting a Font
To delete a font from the font list:

1

Click
on the Tools toolbar.
The Text Attributes toolbox displays above the Design Area.

2

Click
on the Text Attributes toolbox.
The Font List dialog displays.

3

Right-click the required font and select Delete from the pop-up menu.
The selected font is removed from the font list.

You can also delete a font from the font list by selecting the font and clicking
in the Font List dialog.

Replacing a Font
You can replace an existing font in the font list with a new font in the Font List dialog.
To replace an existing font:

1

Click
on the Tools toolbar.
The Text Attributes toolbox displays above the Design Area.

2

Click
on the Text Attributes toolbox.
The Font List dialog displays.

3

Select the required font from the font list.
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4

Right-click an existing font in the Font List dialog and select Replace, Font Type
from the pop-up menu.

You can also replace a font in the font list by clicking
in the Font List
dialog and selecting the required font type from the pop-up menu.

5

Select the required font and return to the Font List dialog.
Replacing a font with any font type follows the same set of steps as adding the font.
For more information on adding a font, see “Adding Fonts to a Font List” on page
192.

6

Click OK.
Any updates made to the font list will be saved.
When you replace one font with another in the font list, the associated User
Name of the font also changes in the Font List dialog. You can specify settings
to preserve the existing user name of a font. To do so, from the File menu,
select Properties to display the Options dialog. From the Editor category,
check Preserve User Name on Font Replacement and click OK.

Changing the Properties of a Windows Font
In Form Editor, you can only apply edits to Windows fonts. All other font types can only
be either replaced or deleted from the font list.
To change the properties of a Windows font:
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1

Click
on the Tools toolbar.
The Text Attributes toolbox displays above the Design Area.

2

Click
on the Text Attributes toolbox.
The Font List dialog displays.

3

Select the required font in the Font List dialog.
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4

Click
on the Font List dialog.
The Font dialog displays where you can view or change the properties of the selected
font. For more information on setting Windows font properties, see “Adding a
Windows Font” on page 192.
You can edit the User Name, Size, or Style of a font in the font list by doubleclicking in the required property column of the selected font in the Font List
dialog.

5

Click OK to save your changes and return to the Font List dialog.

Importing a Font List
To import a font list:

1

From the File menu, select Import, Font List.
The Open dialog displays.

2

Use the Look in drop-down list to search for the required folder.

3

Select the required font list.
Font lists use the extension LST and XML.

4

Click Open to import the specified font list and return to the Design Area.
If fonts have already been added to the Font List dialog in the current form, the
imported font list will display with the existing fonts. The existing fonts do not
actually become part of the imported font list.
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Exporting a Font List
To export a font list:

1

From the File menu, select Export, Font List.
The Save as dialog displays.

2

Use the Save in drop-down list to search for the required folder.

3

Specify the font list name in the File Name entry box.
Font lists can be exported using the XML extension only.

4

Click Save to save the font list and return to the Design Area.
Font lists can also be exported from the Resource Manager tab of the
Manage window. Right-click the Fonts node and select Export Fonts from
the pop-up menu. In the Export To dialog, specify the required file and click
OK.
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Chapter 9:

Using Elixir
PrintDriver Pro
In this chapter…


Elixir PrintDriver Pro Overview



Supported Applications



Print File Types



Using the PrintDriver Wizard



Using PrintDriver with Elixir Scout Manager

Elixir PrintDriver Pro Overview
Elixir PrintDriver Pro uses the Windows print function to convert Windows-based
documents to Elixir or target printer format forms. It also provides several options for
handling fonts and images. TrueType and Adobe fonts can be converted to Xerox fonts
and Elixir; document images can be converted to Elixir format images or page segments.
Font and image conversions can be performed simultaneously during the overlay
conversion.

Supported Applications
PrintDriver supports the following applications:


Microsoft Word



Microsoft Excel



Microsoft Notepad



Microsoft WordPad



Adobe Acrobat
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PrintDriver can also be used with other applications; however, the above list has been
tested for compatibility.

Print File Types
Windows documents can be converted to two print file types:


Forms (page 202)



Documents (page 202)

These two types of print files can be converted to different output formats.

Forms
Windows documents can be converted to Elixir, Xerox and other format forms. Form is a
collection of constant data, such as lines, shading, text, boxes, or images that can be
merged with the variable data during printing. A list of the available form output formats
is provided below:

File Format

Extensions

Elixir

ELX

ElixirDoc

EFR

FRM

FRM

FSL

FSL

Image

TIF

PCL

PCL

PDF

PDF

PostScript

PS

Documents
Windows documents can be converted to Elixir, Xerox and other format documents. The
documents consists of one or more objects that represent a collection of data and often
contain multiple pages with forms, images, and variable data. A list of the available
document output formats is provided below:
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File Format

Extension

Elixir

ELX

ElixirDoc

EDF

DesignPro Tools Form Editor® for Xerox User Guide

File Format

Extension

Metacode

MET

Image

TIF

PCL

PCL

PDF

PDF

PostScript

PS

Using the PrintDriver Wizard
The supported Windows documents are converted to the required document and form
formats by opening the PrintDriver Wizard from an open document. In the PrintDriver
Wizard dialog, you can set up single or multiple print jobs, and select the required output
file type, format, destination path, and setup file. You can also add and delete the output
list entries.
Document conversion process can also be automated without opening the file
first using Elixir Scout Manager. For details, refer to “Using PrintDriver with
Elixir Scout Manager” on page 210.

When setting up a print job, each form or document output file displays as an individual
conversion entry (such as converting a single file to EFR and FRM will result in two
conversion entries). Each entry row contains the conversion parameters for the respective
form or document.
The PrintDriver usually generates an automatic filename for each file created. Each new
filename increments alphabetically to avoid overwriting the previous files. The first form
file created is Daa.efr. Subsequent files are automatically incremented and named Dab.efr,
Dac.efr, etc. The system will continue to increment through the alphabet indefinitely.
When converting a multiple page file, filenames created by PrintDriver are incremented
with a numeric sequence, one for each page. You can also name the output file in the
PrintDriver Wizard.
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Changing PrintDriver Pro Default Options
You can change the PrintDriver default options by using the PrintDriverOptionsAppU.exe
utility, located at drive:\Program Files\Elixir Technologies\Bin.
To set or review the default options for PrintDriver:

1

From the Start menu, select Run.
The Run dialog displays.

2

Enter drive:\Program Files\Elixir Technologies\Bin and click OK.
Replace drive with the letter of your CD-ROM drive.

3

Double-click PrintDriverOptionsAppU.exe to display the PrintDriver Options
dialog.

4

Check the Options tab to display the PrintDriver Options - Options dialog.

5

To display the PrintDriver Wizard dialog when converting files, select from the
following options:
 Autorun (No Windows, Messages to Log File): when checked this option does
not display the PrintDriver Wizard dialog while converting files, the conversion
is run automatically. Default settings are used for conversion. This option is
checking by default.
Selecting this option disables the options Show ‘File and Format’ Setup At
Start and Show Result Dialog Always. To activate these options, deselect
Autorun.

• Show ‘File and Format’ Setup At Start: displays the PrintDriver Wizard File and Format Setup dialog when PrintDriver is opened.

• Show Result Dialog Always: displays the Print Driver Wizard - Conversion
Result dialog only when PrintDriver completes the conversion.

204

DesignPro Tools Form Editor® for Xerox User Guide

6

Check Append Autonaming Counter Starting From First Page to append a ‘1’at
the end of the first output file created (such as daa1.efr) and increment for every
other output file (daa2.efr and so on).
Deselecting this option will name the first file as daa.efr, and the next file as daa1.efr
and so on. By default this option is not checked.

7

To remove the Setup file entry list from the PrintDriver Wizard - File and Format
Setup dialog, check Simple ‘File and Format’ Setup.
On selecting this option the default setup file is used.

8

Select Play Sound After Conversion to play a sound after PrintDriver completes
the conversion.
You can select the required sound file by clicking the Browse button in front of
Sound File entry box. By default no sound is played upon completion of conversion.

9

Select the required configuration file by clicking the button in front of the Config
File entry box.
Configuration file specified here is used for setting the input properties for
converting the file. If no file is specified here then the default file is used for
conversion.

10 You can select the required profile from the Profile Selection dialog by clicking the
Profile Selection button.
For information on profile selections, refer to Chapter 9: Elixir Profile Editor in the
DesignPro Tools Manager for Xerox User Guide.

You can click the Restore Config button to restore the default configuration for
PrintDriver.
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Setting up and Converting the Print Job
PrintDriver option is available in all your Windows application Print dialogs.The
PrintDriver Wizard dialog contains command buttons that enable you to insert new
conversion entries and change file format properties.
The image on the next page displays the sequence involved in the converting a Windows
supported document to Elixir format file using PrintDriver. The conversion process is
shown in the image below:
Opening the document in the
supported Windows applications.

Selecting Elixir PrintDriver
Pro from the Print dialog.

Specifying the
input and output
settings for printing
the Word document
to an Elixir format
form.

The document is converted
to the selected format.

Viewing the converted
file in Form Editor.

Converting a Windows supported document to Elixir format file using PrintDriver.
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To setup and convert the print job:

1

Open the required document in its supported Windows application.

2

From the File menu, select Print.
The Print dialog displays.

3

Choose Elixir PrintDriver Pro from the Printer Name drop-down list and click
OK.
The PrintDriver Wizard - File and Format Setup dialog displays. This dialog lets you
convert your Windows based documents into one or many output formats.

4

Click Properties.
The input properties dialog for the selected file displays. In this dialog you can edit
the input property settings for the conversion.

5

Make the required changes and click OK to close the WindowsEMF dialog.

For more information on the WindowsEMF dialog, refer to the Online Help. To
open the Online Help, click

6

available on the top right of the dialog.

Specify the required output document type from Document Type.
You can select either Form or Document. Selecting either one will display the
associated output format types in the Format drop-down list.
You can add another entry to the output list by clicking Insert. This converts the
same file to another output format. By default, one row for the conversion entry
displays. You can also remove an existing entry by clicking Delete.

7

Select the appropriate output format from the Format drop-down list.
The list is updated based on the selection of the Document Type. For more
information on the available output formats refer to “Forms” on page 202 and
“Documents” on page 202.
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8

Specify the path and name of the output file in the Output File entry list.
The default path for the selected output format is already displayed in the entry list.
To change the default path, click
to open the Save as dialog. Enter the new name
for the output file in the File name entry box and select the required output format
from the Save as type list. The saved file name displays in the Output File path.

The PrintDriver generates automatic names for the output files if no output name
is specified.

If you print a document multiple times with the same filename, the existing file is
overwritten with the new file.

9

Click Edit (located in front of the selected entry) to open the property settings for
selected output format.
To view the output properties of multiple entries at the same time, click Edit
located in front of the Delete button. Output Converter Properties dialog
displays. The output settings for all the checked entries are displayed. You can
access them by clicking their respective tabs at the top of the dialog.

10 Make the required changes and click OK to close the dialog.
These properties define how the output format file is created.
You can create a list of the resources used by specifying the resource list file.
To create a resource list file, select Resource List File from the dialog, check
Create Resource List File from the dialog that displays. Specify a location for
saving the file using the Browse button. Once the location has been specified click
OK and return to the previous dialog. The list file (LST) created will be placed at the
specified location during conversion.
The next step is to define the setup file. A setup file helps the system read the resource
settings before and during the conversion process.
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11 Specify the path and name of the setup file in the Setup File entry list.
The default setup file is already displayed in the entry list. To change the default
setup file, click
to open the Open dialog. Select the required setup file and return
to the previous dialog. The setup file name displays in the Setup File entry list.

For information on setup files, refer to Chapter 5: Using Converters in the
DesignPro Tools Manager for Xerox User Guide.

12 To achieve Elixir Application Suite Print Driver behavior of naming graphic files
using the same name as the file name, set an appropriate job ID without mentioning
the output file name in the Job ID entry box.
To print the file Append Autonaming Counter Starting From First Page must be
selected from in the Print Driver Wizard Options dialog. For details, refer to
“Changing PrintDriver Pro Default Options” on page 204.

13 Click Convert to save the entry settings and to convert the Windows document.
The PrintDriver Wizard - Conversion Result dialog displays the conversion result.
You can select more than one entry for conversion. Messages regarding the resource
list file are also displayed.

14 Click the link in the Output Files list to view the converted file.
The converted file opens in the in the associated DesignPro Tools editor.
You can view the conversion progress details by clicking Progress. You can also
return to the PrintDriver Wizard - File and Format Setup dialog by clicking
Setup in the PrintDriver Wizard - Conversion Progress dialog.

15 Click Close to exit the PrintDriver Wizard dialog.
16 Click OK to save the settings.
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Using PrintDriver with Elixir Scout Manager
In this section, you will be guided through setting up an automatic file conversion using
PrintDriver with Elixir Scout Manager. Elixir Scout Manager is a system service that
watches directories for a file or an event. When the specified file is present or the event
occurs, Scout can perform any number of actions. These actions can include opening an
executable (EXE or COM), running a batch file (BAT or CMD), or selecting a process
(DLL).
Scout runs in the background as a Windows service, providing event-triggered directory
"watch" capabilities. It is used to configure Scout and provide a UI window for operations.
Steps involved in the automating the conversion process using Scout are listed below:


Setting up a Watched Directory (page 210)



Creating an Event (page 215)

Setting up a Watched Directory
The first step in setting up the automation process is defining a watch directory. A watch
directory is a folder where Scout watches for an event to happen; where an event can be
defined as the arrival of a file in the watched directory.
In this example a Windows document format file is converted to an Elixir format file.
Settings required for this example only are explained in this section, for more information
refer to the Elixir Scout Manager User Guide.
To begin, you need first specify the input and output settings in the PrintDriver Wizard
dialog, for more information refer to “Setting up and Converting the Print Job” on page
206. You also have to add a new source, or a new watch directory. You must create the
directories/folders prior to setting up Scout; folders are not automatically created for you.
In this example the following two folders need to be created:


Drive:\Elixir\Scout



Drive:\Elixir\Scout\Working

Once the watch directories have been created the next step is to setup a new watch
directory. After which the Scout automatically starts the service, and displays the watch
directory. For information on the procedure refer to the steps in this task.
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The process of automating the conversion process is shown in the image below:
Specifying the watch
directory path and name.

Specifying the
Source Settings.

Specifying the
Action settings.

Scout displays the
watch directory.
Automating the conversion process using Scout.
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To add a new source, or a new watch directory:

1

Open the Elixir Scout Manager from Start, Program, Elixir Applications, Scout
Manager.
The Elixir Scout Manager window displays.

2

Click Add New URL Source on the toolbar.
The Add new URL source dialog displays. Here you will enter the watch directory
path and name.

3

Enter the watch directory path and name drive:\Elixir\Scout in the URL Source
Name entry box and click OK.
The drive:\Elixir\Scout dialog displays.

You will now specify the type of file(s) to watch for, what actions are to be taken on the
watched file(s), where to process them and what to do with these files once the processing
completes.

4

Check the Source Settings tab and select URL Directory as the input source type
from the Source type drop-down list.

5

Enter drive:\Elixir\Scout in the Checking URL Directory entry box.
The URL directory is placed in this directory.

6

Check Move the Directory to the Temporary Directory and specify the temporary
directory drive:\Elixir\Scout\Working in the entry box right below the Move
option.
This option moves the file from the watched directory to the temporary directory.

7

Enter *.doc in the File Filters entry box as the type of file to watch for in the watch
directory.
In this example you are converting a Windows document format file to Elixir format.

Now that you have set up the Source Settings, you will specify what action to take when
the DOC file arrives in the watch directory.
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8

Click the Action tab and check the DDE Server tab.
Dynamic Data Exchange (DDE) is a communication protocol. DDE enables all the
applications running in the Windows environment to send, receive data, and
exchange instructions. Scout lets you exchange data on file detection in the watched
directory by defining a DDE action.

9

Enter the full path of Microsoft Word program in the File Name entry box.
Click Browse in front of the File Name entry box to open the Open dialog. Locate
and select the required file. You can select files with EXE extension only. Click
Open to select the file.

10 Enter the command line arguments in the Arguments entry box, which will be used
for processing the selected executable file.
In this example, the Word file will be printed to Elixir Format file using PrintDriver.
The command line argument(s) specified here will be passed to the executable
application in the File Name entry box. The parameters are specified to provide
complete automation commands to run the executable application.The command
specified is Microsoft Word specific, for more information refer to the Microsoft
Word and Windows help.
The command specified in the Arguments entry box is Windows specific, To
find out which command to use open the Windows Explore. From the Tools,
menu select Folder Options. Check the File Types tab, select DOC from the
Registered File Types list and click Advanced. Select Print from the Actions
list and click Edit. Select the required command from the Action entry box.

Once the executable file has been selected, the next step is to define the executable action.

11 Specify the Dynamic Data Exchange (DDE) application string in the DDE Server
for initiating communication with the application specified in the File Name entry
box above.
The command specified is Microsoft Word specific, for more information refer to the
Microsoft Word and Windows help.
The command specified in the DDE Server entry box is Windows specific, To
find out which command to use open the Windows Explore. From the Tools
menu select Folder Options. Check the File Types tab, select DOC from the
Registered File Types list and click Advanced. Select Print from the
Actions list and click Edit. Select the required command from the Application
entry box.
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12 Specify the topic string for initiating Dynamic Data Exchange (DDE) conversation
with the application specified above in the Topic entry box
The command specified is Microsoft Word specific, for more information refer to the
Microsoft Word and Windows help.
The command specified in the Topic entry box is Windows specific, To find out
which command to use open the Windows Explore. From the Tools menu select
Folder Options. Check the File Types tab, select DOC from the Registered
File Types list and click Advanced. Select Print from the Actions list and click
Edit. Select the required command from the Topic entry box.

13 Enter the Dynamic Data Exchange (DDE) command for specific action when the
server application is running, in the DDE Message for the Running Server entry
box.
You need to specify PrintDriver as the printer to be used for printing. The commands
specified are Microsoft Word specific, for more information refer to the Microsoft
Word and Windows help.
The command specified in the DDE Message for the Running Server entry
box is Windows specific, To find out which command to use open the Windows
Explore. From the Tools menu select Folder Options. Check the File Types
tab, select DOC from the Registered File Types list and click Advanced.
Select Print from the Actions list and click Edit. Select the required command
from the DDE Message entry box.

14 Enter the Dynamic Data Exchange (DDE) command for specific action when the
server application is not running in DDE Message for the Non-Running server
entry box.
You need to specify PrintDriver as the printer to be used for printing. The command
specified is Microsoft Word specific, for more information refer to the Microsoft
Word and Windows help.
The command specified in the DDE Message for the Non-Running Server
entry box is Windows specific, To find out which command to use open the
Windows Explore. From the Tools menu, select Folder Options. Click the File
Types tab, select DOC from the Registered File Types list and click
Advanced. Select Print from the Actions list and click Edit. Select the
required command from the DDE Application Not Running entry box.
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15 Click Apply and OK.
Scout automatically starts the service, and displays the watch directory. The process
of automating the conversion process using Scout is complete.
The next step is to create an event to start the conversion process. For more information
refer to “Creating an Event” on page 215.

Creating an Event
An event is defined as the arrival of the input source file in the specified watched
directory. To create the event in this example, you will manually drop an input file into the
drive:\Elixir\Scout watch directory. Scout will then open PrintDriver to convert the file to
Elixir form format, and deliver the output file to the drive:\Elixir\Scout\Working directory.
To create the event:

1

Open the Windows Explore.

2

Browse to the location of the required file and copy the Word document.

3

Browse to drive:\Elixir\Scout and paste the copied file.
Scout automatically begins the process of converting; PrintDriver prints the
document to the pre-selected format using the pre-defined property settings. The
Elixir format file can be viewed by browsing to the location of the converted (output)
file and opening the file.
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Chapter 10:

Active Objects
In this chapter…


About Active Objects



Working with Active Objects



Creating a PDF File

About Active Objects
Active objects are accessed from the Tools toolbar they are used to create PDF form fields,
such as buttons, text entry boxes, etc. in a form. PDF files using these entry fields can be
presented on the Internet for online data entry. The data can then be sent to a web page
using HTML or the entire PDF file can be processed by a data scraping application.
There are six active objects available in the Form Editor:

Tools

Purpose
Inserts an Active Button: buttons are
interactive controls that can be manipulated
with a mouse to perform a specified action.
Inserts an Active Checkbox: checkboxes are
interactive controls having a maximum of two
values: On (Checked/selected) or Off
(Unchecked/deselected).
Inserts an Active Combobox: adds either a
combobox or a drop-down list. Each control
contains a list of text items, accessed using a
drop-down arrow.
Inserts an Active Editbox: enables text entry
from the keyboard.
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Tools

Purpose
Inserts an Active Radio Button: radio buttons
are grouped interactive controls, which require
one selection from the group.
Inserts a Signature: adds digital signatures to
PDF documents.

Working with Active Objects
To create a PDF file with form fields using active objects, you need to perform the
following task sequence:


Add active object(s) to an existing or new form.



Set the active object properties.



Set the PDF output properties.



Save the form to PDF.

For information on performing other operations on active objects, refer to
Chapter 11: “Data Tagging” on page 239.
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Adding Active Objects
To add an active object to an existing or new form:

1

Click the required active object on the Tools toolbar.
The mouse cursor changes from
to
. Selecting the required active object
displays the associated toolbox above the Design Area.

You can also add an active object by selecting the required active object from the
Tools menu.

2

Click and drag the mouse pointer anywhere on the Design Area to draw the active
object.
The specified active object is added to the form. A corresponding node is also added
in the Object Type View tab of Manage window.

Viewing Active Objects
Once the active object has been added to a form, a corresponding node is added under the
Objects tree node available in the Object Type View tab of the Manage window, as
shown below:

Object Type View displays the active objects.
You can delete, review, and/or edit the properties of the active objects.
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Common Active Object Properties
Most active objects available in the Form Editor share common properties. To set
properties that apply to all of the objects, refer to Chapter 12: “Editing Forms” on page
263.
To set or change properties for active objects inserted in a form:

1

Right-click the active object in the form and select Properties from the pop-up
menu.
The Properties dialog displays.
You can also view the active object properties by using one of the following
methods:


From the View menu, select Properties.

or


Press Alt + Enter.

or


Right-click the active object in the Manage window and select Properties
from the pop-up menu.

2

Select the required Category.

3

Review the dialog selections and make your changes.

4

Click Apply, and then click OK to save the changes.

Refer to the following tasks for more information on properties that are common to all of
the active objects:
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Setting the Active Object Name (page 221)



Adding an Active Object Border (page 221)



Setting the Active Object Border Color (page 222)



Setting the Active Object Foreground and Background Color (page 223)



Adding Text to the Active Object (page 224)



Selecting Active Object Fonts (page 224)
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Setting the Active Object Name
You can view and change the active object identification name and tool tip using the
Properties dialog.
To change the active object name and tool tip, specify the following:

1

Right-click the active object in the form and select Properties from the pop-up
menu.
The Properties dialog displays.

2

Select the Name category.

3

Enter the unique name identifying the object in the Active Control Name entry box.

4

Click Apply, and then click OK to save the changes.
The name of the active object is changed. When you move the mouse pointer over
the object in the Design Area, the Status bar displays the name of the active object
specified in the Properties dialog.
You can also add a tool tip identifying the active object. To add a tool tip; From
the Properties dialog, select Name category, enter the tool tip for the selected
object in the Tooltip entry box. The specified tool tip is only displayed when the
mouse pointer is placed over the object in the final PDF file.

Adding an Active Object Border
You can change the active object border line style and thickness in Form Editor. You can
select from the available border line weights or specify a custom value.
To add/change border to an active object:

1

Right-click the object and select Properties from the pop-up menu.

2

Select the Border category from the Properties dialog.

3

Check the Use Border to add a border around the selected active object.
Border line style and Thickness are activated only if Use Border is checked.

4

Select the line style from the Border Line Style drop-down list.
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5

Select the line thickness from the Thickness drop-down list.

6

Click Apply and OK to save the changes
The selected border is added to the object.
You can also specify a customized value (0-999) by selecting the Custom
thickness option from the Thickness drop-down list and specifying the custom
thickness in the associated entry box.

Setting the Active Object Border Color
You can apply predefined foreground, background, and border colors to the selected active
object. In addition, you can also review the selected color properties.The default
foreground is black, and the default background color is white. The border color is set to
black by default.
To set the text foreground (text), background (interior), and border color, specify the
following:

1

Right-click the active object in the form and select Properties from the pop-up
menu.
The Properties dialog displays.

2

Select the Color category and select Border.
Selecting Border changes the object’s border color. You can also view the color
models of the available colors, and their first, second, third and fourth saturation
components in the dialog.

3

Select the required color from the list of available colors under Name.

4

Click Apply and OK to save the changes
The selected color is added to the object.

Changing the active object border color.
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Setting the Active Object Foreground and Background Color
You can apply predefined foreground and background colors to the selected active object.
In addition, you can also review the selected color properties.The default foreground is
black, and the default background color is white. The border color is set to black by
default.
To set the text foreground (text), and background (interior) color, specify the following:

1

Right-click the active object in the form and select Properties from the pop-up
menu.
The Properties dialog displays.

2

Select the Color category and select Fg and/or Bg/Interior.
Selecting Fg changes the object’s foreground and text color. Selecting Bg/Interior
changes the object’s interior color. You can also view the color models of the
available colors, and their first, second, third and fourth saturation components in the
dialog.

3

Select the required color from the list of available colors under Name.

4

Click Apply and OK to save the changes
The selected color is added to the object:

Changing the active object foreground, text and background color.
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Adding Text to the Active Object
Form Editor provides options for changing the active object text (label).
To add text to the active object, specify the following:

1

Right-click the active object in the form and select Properties from the pop-up
menu.
The Properties dialog displays.

2

Select the Text category and enter the text in the Text entry box.

3

Click Apply, and then click OK.
The text is added as the active object label:

Adding text to the active object.

Selecting Active Object Fonts
You can add, remove, replace and delete different types of fonts to the active objects.
To set the font(s) for the selected active object:
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1

Right-click the active object in the form and select Properties from the pop-up
menu.
The Properties dialog displays.

2

Select the Font category and click Font List dialog.
The Font List dialog displays. You can add, edit, or delete Windows, Xerox and
Elixir fonts from the current font list. In addition, you can review and set font
properties using this dialog. For more information on the Font List dialog, refer to
“Enhancing Forms using Text” on page 145 in Chapter 7: Using Text.

3

After making the necessary changes click Apply and OK to save the changes.
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Active Button Properties
The active button feature is used to draw a button on the form. Once the active button is
added to a form, you can view and set the button properties, including position,
dimension, border, text, font, and color. For setting properties common to active objects
only, refer to “Common Object Properties” on page 263. To set properties that apply to all
of the objects, refer to Chapter 12: Editing Forms.
Refer to the following tasks to set the active button specific properties.


Adding an Image to the Active Button (page 225)



Adding a URL to the Active Button (page 226)

Adding an Image to the Active Button
To add an image to the active button, specify the following:

1

Right-click the active button in the form and select Properties from the pop-up
menu.
The Properties dialog displays.

2

Select the Action category.

3

From the Type drop-down list select Image.
Selecting Image activates the Image and Action drop-down lists.
Selecting Normal from the Type drop-down list specifies a normal button with
a label as defined in the Text category of the selected object. For more
information, refer to “Adding Text to the Active Object” on page 224.
No label or an image is added to the active object when None is selected from
the Type drop-down list.

4

Click
in front of Image drop-down list to open the Open Resource File dialog.
You can also select images already placed on the form from the Image drop-down
list.
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5

Select the required image, click Apply, and then click OK.
The image is added to the active button, as shown below:

1) Active button without image. 2) Active button with image added.

Adding a URL to the Active Button
Using Form Editor, you can open a web site by clicking on an active object. The URL
(Uniform Resource Locator) added to the active object opens the web site only if the file is
in PDF format.
To add a URL to the active button:

1

Right-click the active object in the form and select Properties from the pop-up
menu.
The Properties dialog displays.

2

Select the Action category.

3

From the Action drop-down list select Submit.
The name and values specified for the selected active object are submitted to the user
specified URL. Selecting Submit from the Action drop-down list activates the URL
and Objects options.

No action is performed when None is selected from the Action drop-down list.

4
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Enter the address of the web site in the URL entry box for submitting the name and
values of the selected active object(s).
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5

Specify which active objects to submit to the web site specified in the URL entry
box.
You can select from the following options:
 Include: includes the selected objects from the Select dialog.
 Exclude: excludes the selected objects from the Select dialog.
 All: includes all objects; no selection is necessary from the Select dialog.
Refer to the next step of this task for information on opening and selecting objects
from the Select dialog

6

Click Select to the open the Select Objects dialog and select the active object(s)
form the list of available objects.
Only active objects already added to the form are available for selection. You can
check the required objects in this dialog.

7

Click OK.
You return to the previous dialog. The names of the selected objects are displayed in
Preview.

8

Click Apply and OK to submit the specified URL to the selected active object(s).

Active Checkbox Properties
The active checkbox feature is used to draw a checkbox on the form. Once the active
checkbox is added to a form, you can view and set the properties, including position,
dimension, border, text, font, state, and color. For setting properties common to active
objects only, refer to “Common Object Properties” on page 263. To set properties that
apply to all of the objects, refer to Chapter 12: Editing Forms.
For more information on active checkbox specific properties, refer to “Setting the State of
Active Checkbox” on page 227.

Setting the State of Active Checkbox
Form Editor provides options for setting the default state of the active checkbox. You can
also choose to set the text label position for the active checkbox.
To set the state of the active checkbox:

1

Right-click the active checkbox in the form and select Properties from the pop-up
menu.
The Properties dialog displays.

2

Select the State category.
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3

Select either Left or Right to set the active checkbox label position in relation to the
actual checkbox.
The images below display the left and right text alignments as specified above:

4

To set the default state of the active checkbox either check or uncheck the Check/
Uncheck option.
If checked, the default state of the active checkbox displays a check mark. If
unchecked, the default state of the active checkbox does not display the check mark.

5

Enter the value that will be written to the PDF file when the active checkbox is
selected in the On Check Value entry box.
The recommended value for the on state is Yes. If no value is entered, Yes is used as
default when the PDF is created and the following warning message is generated in
the Messages window: PDF output converter: Checkbox doesn't have set name of On
state. Replacing with “Yes”.

6

Click Apply and OK to save the changes.

Active Combobox Properties
The active combobox feature is used to draw a combobox on the form. Once the active
combobox is added to a form, you can view and set the properties, including position,
dimension, border, text, font, value, and color. For setting properties common to active
objects only, refer to “Common Object Properties” on page 263. To set properties that
apply to all of the objects, Chapter 12: Editing Forms.
For more information on active combobox object specific properties, refer to “Setting the
Value List for Combobox” on page 229.
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Setting the Value List for Combobox
You can create an active combobox or a drop-down list using the Form Editor. Options for
defining a number of text items (values) for the active combobox and the drop-down list
are also provided.
To add values to the active combobox or the drop-down list, specify the following:

1

Right-click the active combobox in the form and select Properties from the pop-up
menu.
The Properties dialog displays.

2

Select the State category.

3

Select either Combobox or Drop-down list from the Type list as the type of
combobox for the selected active object.
 Combobox: creates a combobox, which includes both a drop-down list and
offers the users the options to enter a unique item name.
 Drop-down list: creates a drop-down list, where users must choose from one of
the available selections.

4

Click Add to add values to the Value list.
The value for Combobox or Drop-down list is added in the Value list. You can add
multiple values. Each item in the list is preceded by a check box; a checked item
represents default selection. To specify a value name, click once to select an item,
and then click again to edit the value. The selected values may be used as the field
values in the PDF.

5

Once you have finished adding the required values to the list, click Apply and OK.
You can view only one value in the active combobox inserted in the Design Area; to
view all of the items, you need to convert the form to the PDF format.

To delete a value from the Value list, select the value form the list and click
Remove in the Properties - Combobox dialog.
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Active Editbox Properties
The active editbox feature is used to draw a editbox on the form. Once the active editbox
is added to a form, you can view and set the properties, including position, dimension,
border, text, font, action, and color. For setting properties common to active objects only,
refer to “Common Object Properties” on page 263. To set properties that apply to all of the
objects, refer to Chapter 12: Editing Forms.
Use the following steps to view and set the active editbox specific properties.


Setting the Editbox Format (page 230)



Customizing the Active Editbox (page 232)

Setting the Editbox Format
An active editbox lets you enter text using the keyboard. You can enter or select text in the
active objects in the PDF file only.
You can add text, passwords, and numbers to the active editbox. Associated options let
you specify formulas and custom text properties, which can be applied to all or to the
selected active editbox objects in the current form.
To add actions to the active editbox:
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1

Right-click the active editbox in the form and select Properties from the pop-up
menu.
The Properties dialog displays.

2

Select the Action category.

3

Select the active editbox format from the Format ID drop-down list.
You can select from the following options:
• Text: enables text entry, including alphabetic and numeric characters.
• Number: allows numeric character entry only.
• Password: enables text entry, including alphabetic and numeric characters;
passwords display as replacement characters (such as *,@, !, #, or ") in the
password field to protect password entries.
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4

From the Action drop-down list select Formula to add formula for the active
editbox.
The formula must be entered in the Formula entry box.

No action is performed when None is selected from Action drop-down list.

5

Enter the required formula in the Formula entry box.
This option is only valid when Action is set to Formula. Formula operators may
include +, -, *, or /.

6

Click Insert to the open the Select Objects dialog and check the active editbox(s)
from the list of available objects.
Only active editboxes already added to the form are available for selection.

7

Click OK.
You return to the previous dialog. The names of the selected active editboxes are
displayed in Formula entry box.

8

Select the text alignment for the active editbox from the Alignment drop-down list.
You can select from the following option:
• Left: aligns text to the left.
• Center: aligns text at the center.
• Right: aligns text to the right.

9

Specify the maximum number of characters allowed for entry in the active editbox in
the Length entry box.
The characters can only be added if the file is in PDF format.

10 Check Multiline to allow multiple lines of text to for the selected active editbox.
If not checked, the active editbox is restricted to a single line of text.

11 Click Edit to open the Format Editor dialog for customizing the active editbox.
For more information on customizing the active editbox, refer to “Customizing the
Active Editbox” on page 232.
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12 After making the necessary changes click Apply and OK.
The image below describes the process involved in setting the active editbox format:
1. Specify the active editbox format
and the required formula s settings.

2. Select the active editbox
objects on which to apply the
specified formula settings.

3. Specify the display settings in
the Format Editor dialog.
A sample of the selections is
displayed in Sample entry box.

Customizing the Active Editbox
You can also customize how the characters display in the active editbox in Form Editor.
To customize the appearance of characters in the active editbox:
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1

Right-click the active editbox object in the form and select Properties from the popup menu.
The Properties dialog displays.

2

Select the Action category.

3

Specify the active editbox format and formula settings.
Form more information refer to “Setting the Editbox Format” on page 230 .
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The next step is to customize the active editbox.

4

Click Edit to open the Format Editor dialog.

5

Enter the group separator for separating the characters in the active editbox in the
Group separator entry box.
You can specify the number of digits separated by the group separator in the
Grouping list. For example, a value of ‘2’ results the value 1000000 being written as
1,00,00,00.

6

Specify whether or not to use a leading zero by selecting either 0.1 or .1 respectively.
• 0.1: uses leading zero.
• .1: no leading zero is used.

7

Enter the symbol to be used in the text string in the editbox in the Symbol entry box.
Select the required position of the symbol in the text string from the Symbol
placement list. You can select from the four available options.

8

Enter the customized decimal separator to be used in a text string in the Decimal
Separator entry box.
You can also enter the customized decimal digits to be used in the text string in the
Decimal digits entry box.

9

Enter the customized negative sign symbol to be used in a text string in the Negative
Sign Symbol entry box.
You can select the position of the negative sign from the Negative value list. A
sample of the numeric strings that are created using the selected options is displayed
in Sample entrybox.

10 Click OK to return to the Properties dialog.
The number format for entering numbers in the active editbox is displayed in the
Sample.
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Signature Properties
The signature feature lets you insert signatures in the form. Select this tool from either the
Tools toolbar or the Insert menu. Once the signature is added to a form, you can view and
set the signature properties, including position, dimension, border, text, font, action, and
color. For setting properties common to active objects only, refer to “Editing Forms” on
page 263. To set properties that apply to all of the objects, refer to Chapter 12: Editing
Forms.
For more information on signature specific properties, refer to “Locking the Signature
Object” on page 234.

Locking the Signature Object
Signatures are electronic “signatures” that authenticate the identity of the user. Signature
objects let you prohibit changes being made to the object. Once a document is signed by a
valid user, the form can lock the signature object.
To lock the signature object:

1

Right-click the signature object in the form and select Properties from the pop-up
menu.
The Properties dialog displays.

2

Select the Action category.
The image below displays the basic process involved in locking signature objects.
For more information, refer to the steps below.
1. Enter the required
action and Objects
settings. Click Select to
specify the required
objects.

2. Select the required objects. The
selected objects are displayed in Preview.
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3

Select Lock from the Action drop-down list to lock the selected signature object
when the signature field is signed.

4

Specify which active objects to lock by selecting one of the following options from
Objects drop-down list:
You can select from the following options:
 Include: includes the selected objects from the Select dialog.
 Exclude: excludes the selected objects from the Select dialog.
 All: includes all objects; no selection is necessary from the Select dialog.
Refer to the next step for information on opening and selecting objects from the
Select dialog.

5

Click Select to the open the Select Objects dialog and select the signature object(s)
form the list of available objects.
Only signature objects already added to the form are available for selection. You can
check the required objects in this dialog.

6

Click OK.
You return to the previous dialog. The names of the selected objects are displayed in
Preview entry box.

7

Click Apply and OK to lock the selected signature object(s).

Creating a PDF File
Once the active objects have been added to the form, you can specify the required PDF
output property settings and save the form as a PDF file.

Tag references are written to the PDF file as editboxes.
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Setting PDF Output Properties
To set the PDF file properties:

1

From the Tools menu, select Application Format Setting, Output Formats, PDF.
The PDF dialog displays.

2

Select the Active Objects category.

For more information on Main and Encryption categories, refer to the Online
Help. To open the Online Help, click

available on the top right of the dialog.

3

Review the dialog selections and make your changes.
 Process Text for Active Objects: when selected, active objects and tag
references are turned into PDF interactive objects. If the option is not selected,
active objects and tag references are ignored.
 Use 3D Border: allows the use of 3 dimensional borders on active objects.
 Border Color: lists available border colors for selection.
 Text Color: sets a text color of the active objects.

4

Click Apply, and then click OK to save the settings.

Saving a Form to PDF Format with Active Objects
To save a form to PDF format:
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1

From the File menu, select Save as.
The Save as dialog displays.

2

In the Save as drop-down list, select PDF Page (*.pdf).
If the Elixir button is selected in the left pane, the default profile path for PDF files
displays.
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3

Use the Save in drop-down list to search for the required folder.

4

Click Save to save the file.
You can click Edit Property Settings or
properties.

to review or change the PDF file

The Edit Property Settings option is activated only if a file format type other
than an Elixir form (*.efr) is selected from the Save as drop-down list.
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Chapter 11:

Data Tagging
In this chapter...


Understanding Data Tags



Tagging in DesignPro Tools



About Tag References



Using Elixir PrintDriver Pro for Data Tagging



DAT Files

Understanding Data Tags
The tagging feature adds data tags to forms. These tags can later be merged with data to
make meaningful applications. Data tagging is a way to mark text objects in a form that
enables the receiving of variable data from external data source during a print job process.
Form Editor supports two types of data tags:


Tag References: Tag references are text objects that use a specific syntax:
%%fieldname. Tag references reside in a form, and each tag references a section of
the actual data.
Tag References are used by DocuMerge for merging data with forms for printing.
The tagged forms are converted to Normalized Metacode. The Normalized
datastream merges with data to create meaningful documents. These normalized files
are used by DocuMerge as templates for merging data during document composition.



Active Objects: Forms using active objects are converted to the PDF format.
PDF files using the active objects can be presented on the Internet for online data
entry and/or combined with a system for data extraction. PDF entry requires the free
Acrobat Reader (version 5+), available at www.adobe.com/products/acrobat.

For more information on active objects and creating a PDF file, refer to Chapter 10:
“Active Objects” on page 217.
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Tagging in DesignPro Tools
Two of the DesignPro applications are useful for tagging forms:


Form Editor tags forms, and can save those forms directly to PDF. Forms can also be
saved to ELX or EFR and added to a DAT file. DAT files for Normalized
datastreams are created and exported in the Form Editor.
While defining and using tags, the following Form Editor workspace tools will be
required:
• Design Area: enables adding data tags to the forms in the design area.
• Active Object and Tag Reference tools on the Tools toolbar: lets you place
data tags in the Design Area.
• Manage window: defines and manages data tags using the Manage window.
Tag references display in the Tag Structure tab, and active objects display in the
Object Type View tab. Active radio button objects display under the Radio
Buttons tab, where grouping is viewed and managed.



Manager uses Converters to convert DAT files into Normalized Metacode. The
Converters utility is located on the Applications tab.

Tagging Limitations
DesignPro Tools 3.00 has a few limitations regarding tagging:
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Mixing active objects and tag references.
Active objects and tag references may be placed on the same form.



Saving to the ELX format.
Forms with active objects cannot be saved to the ELX format (only tag references
are preserved). All tag types are recognized when saving to the EFR format.
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About Tag References
Tag references are text objects on a form containing the data tag syntax. Each data tag
references a section of actual data. Once complete, tagged forms are added to a DAT file.
Creating a tag reference is a two-step process:


First, the tags are defined and their associated attributes are set in the Tag Structure
tab of the Manage window. You can create two types of tags:
• Embedded Tags: refers to tags that are embedded within a form.
• Linked Tags: refers to tags imported from an external tag definition list in a
form. If the tag definition list is not imported, then the default tag information is
used. For more information on creating tag definitions, refer to “Creating a Tag
Definition in the Manage Window” on page 242.
The tags are displayed as a list. The attributes of each tag describe the data that is
merged with the form and also describes how to format the data in the tag.



The next step is to add the tags to the form using from the Tools toolbar. Tags are
added as text objects or as tag reference objects in a form. Both object types use
specific tag syntax to reference a tag definition. See “Adding Tag References” on
page 245 in this chapter for more information on adding tag references to a form.

You can also add a tag reference to a Windows based document (such as MS
Word) using the ElixiTag toolbar provided with Form Editor.

Tags can also be added using the Insert menu or by entering the tag syntax
directly in a text object.

Before inserting tag references in a form, you may choose to set options that are applicable
globally every time you open a form and add the tag references. See “Setting Tag
Reference Default Properties (Options dialog)” on page 248 in this chapter for more
information on setting tag reference options.
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Creating a Tag Definition in the Manage Window
To create a tag definition:

1

Select the Tag Structure node available in the Tab Structure tab of the Manage
window.

2

Right-click the Embedded Tags or Linked Tags node and select Create New Tag
from the pop-up menu.
A new tag node is added under the Embedded Tags or Linked Tags node.

TAG_1_I (name: TAG1) represents a new tag added under the Embedded Tags node.
Once the tag has been defined the next step is to set the tag properties, refer to the next
task for more information.

Setting Tag Definitions Properties
To set tag definition properties:
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1

Add a tag definition in the Tag Structure tab of the Manage window.

2

Right-click the tag definition and select Properties from the pop-up menu to open
the Properties dialog.

3

Enter the sequential number of the tag in Field Number entry box.
As you insert tags, Form Editor automatically increments the field numbers for you.

4

Select either Mandatory or Optional.
If Mandatory is selected, then the document will produce an error flag if the data
field is empty when processing for print. No error flag is displayed if Optional is
selected.
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5

Enter the unique name identifying a tag in the Field Name entry box.
Tag names use upper case and cannot contain any spaces. If lower case is specified,
names are converted to uppercase during conversion. Use a “.” or a “_” to separate
words.

6

Enter the length of the field in the Field Length entry box.
If you intend to use the Field Gen option to format your data, include any additional
characters in the field length. For example, if you have a 9-digit field for a US social
security number (999999999) and wish to format it to include dashes (999-99-9999),
the Field Length should be 11 digits.

7

Specify the number of times you want to repeat fields in Tag Field Depth entry box.
The number will determine how many times the field will be repeated.

8

Enter the required replacement character in the Replacement Character entry box.
Replacement characters (such as *, @, !, #, or ") are used as placeholders to protect
real content used at design time (normally used for password entries).

9

Insert the character marking the end of a field in the Field End Character entry box.
The default value is $. For characters not available on your keyboard, use the Alt key
plus the decimal value of the character. If you need to look up a value, open the Start
menu and select Programs, Accessories, System Tools, and Character Map. The
Character Map provides the Keystroke required to type special characters.

10 Check Field Gen to format a data string using non-replacement characters in a string
of replacement characters.
You can enter non-replacement characters as you want them to display in relation to
the replacement characters in the entry box next to this option. For example, if your
replacement character is an @, and you wish to format a US social security number,
you would enter “@@@-@@-@@@@”.

11 Check or unckeck Delete After Use to delete a data field after it has been used.
Do not check this option if you require the same field again in the document. If you
need to use the same field name for a different data value, remember to check this
option.

12 Add carriage return/line feed after the tag is printed by checking Multi-data.
This is useful for aligning tags; for example, if you wanted to align data into
columns, you would check this option.
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13 To align tags with the same align number, enter the tag number in Tag Align entry
box.
All tags with the same align number will be grouped together.
You can add a brief narrative about the tag in the Comment entry box. You can
also specify the sample text to be used in the text object in the Sample Data
entry box. The specified sample text is displayed only if the Sample Data option
is selected from the Format drop-down list in the Tag Ref category of the
Options dialog.

14 Click Apply and OK to save the changes.
The tag is defined and the tag updates in the Manage window.
Once the tag properties have been set the next step is to add tag references. For more
information refer to “Adding Tag References” on page 245.

Changing Tag Definitions
Once the tag definitions are specified using the Tag Structure tab in the Manage window,
you can reorder, move, copy, or delete the definitions. These operations are described
below:
Reordering Tag Definitions
Click and drag a selected tag definition at the required new location within the Tag
Structure node; the field number of the selected tag updates to reflect the move.
Moving Tag Definitions
Click and drag a selected tag from the Embedded Tags node to the Linked Tags node, or
vice versa. You can also right-click a tag and select Move as Linked (if under the
Embedded Tags node) or Move as Embedded (if under the Linked Tags node) from the
pop-up menu. The tag definition moves to the specified node.
To move all embedded tags, right-click the Embedded Tags node and select Move all as
Linked from the pop-up menu; all embedded tags are moved as linked tags under the
Linked Tags node.
To move all linked tags, right-click the Linked Tags node and select Move all as
Embedded from the pop-up menu; all linked tags are moved as embedded tags under the
Embedded Tags node.
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Copying Tag Definitions
Right-click a tag and select Copy as Linked (if under the Embedded Tags node) or Copy
as Embedded (if under the Linked Tags node) from the pop-up menu. The tag definition
is copied to the specified node.
To copy all embedded tags, right-click the Embedded Tags node and select Copy all as
Linked from the pop-up menu; all embedded tags are copied as linked tags under the
Linked Tags node.
To copy all linked tags, right-click the Linked Tags node and select Copy all as
Embedded from the pop-up menu; all linked tags are copied as embedded tags under the
Embedded Tags node.
Deleting a Tag Definition
Right-click a tag definition in the Tag Structure node and select Delete from the pop-up
menu. The selected tag definition is deleted.
Deleting All Tag Definitions
Right-click the Tag Structure node and select Delete all from the pop-up menu. All tag
definitions are deleted.
To delete all of the embedded tags only, right-click the Embedded Tags node and select
Delete all Embedded from the pop-up menu.
To delete all of the linked tags only, right-click the Linked Tags node and select Delete all
Linked from the pop-up menu.

Adding Tag References
Once you have defined and created tags, the next step is to add the tag references in the
form.
Tags can be added to a form by either:


Using
from the Tools toolbar; this requires an existing tag definition to be
defined in the Manage window.



Entering the correct syntax in a text object. You need to have tags defined prior to
typing the syntax.
The syntax is typically %%x;, where x is a number referencing a specific field.

Because a tag reference is essentially a text object, text and tags can be merged in the same
text object. The following sections explain the tasks for adding tags in a form.
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Adding Tag References using the Tools Toolbar
To add a tag reference using the Tools toolbar:

1

Add a tag definition in the Tag Structure tab of the Manage window and set the
required properties.
For more information, refer to “Creating a Tag Definition in the Manage Window”
on page 242.

2

On the Tools toolbar, click
to open the Tag Selection dialog.
The Tag Selection dialog lists the defined tags and associated attributes under the ID,
Name, Comment, and Embedded columns.

3

Select a tag and view the associated read-only information.
You can click Advanced to expand the dialog to view the tag properties. If you want
to make changes, right-click the specified tag in the Manage window and select
Properties from the pop-up menu to open the Properties dialog.

4

Click OK, and then click on the form to place the specified tag reference.
Tag references are added as text objects with an arrow icon in the top right corner of
the text object. This icon designates the object as a tag reference.

Design Area showing the tag references added to a form.
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Adding Tag References using Tag Syntax
To add a tag reference to a form using a specified syntax:

1

Insert a text object in the form.

2

Enter the required syntax.
The tag reference syntax is %%x;, where the x is a number referencing a specific
field.

3

Right-click the text object, select Properties from the pop-up menu and select the
Tag Reference category.
For more information on this dialog, refer to “Creating a Tag Definition in the
Manage Window” on page 242.

4

Click Add to open the Tag Selection dialog.
You can also remove a tag from the list, Select the tag and click Remove to
delete the tag in this dialog. In addition you can also replace the selected tag with
the required tag by clicking Change.

5

Select the required tag and click OK to return to the previous dialog.
The options related to tag definitions are displayed in this dialog. For more
information on this dialog refer to “Setting Tag Definitions Properties” on page 242.
In addition you can also view the associated attributes under the ID, Name,
Comment, and Embedded columns.

6

Select the tag and click OK in the Text - Properties dialog.
The tag reference is added in the form.
For more information on remaining text object properties, refer to Chapter 7:
“Using Text” on page 145.
Tag references are changed in the same manner as other text objects. Refer to
Chapter 12: “Editing Forms” on page 263 for instructions on copying, pasting,
deleting, moving, resizing, and filtering text objects.
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If a form contains two or more identical tags and you view the properties of any
one tag, Form Editor prompts you whether to change all tags with the same field
number. Clicking No applies the properties of the selected tag and changes its
field number such that the selected tag does not remain identical.

If you merge two forms with identical tag field numbers, a message box prompts
you to either renumber tags in the source or target form, or overwrite tags in
the source or target form. To do this:


You can either check the Generate Unique Tag Field Number option
along with selecting the required form name to renumber the tags inserted
in the form.

or


You can uncheck the Generate Unique Tag Field Number option to
overwrite tags in one form with tags available in the other form, depending
on the form name that you have selected.

Setting Tag Reference Default Properties
(Options dialog)
Form Editor lets you specify how a tag reference is presented in the form. You can set
properties such as background color and the format in which the tag reference is presented
in the text object.

Setting Tag Reference Display Options
Using the Tag Ref category in the Options dialog, you can set the tag reference display and
tag recognition options for tag reference objects.
To set tag reference properties:

248

1

Select Options from the Tools menu to open the Options dialog.

2

Under the Application node, select the Tag Ref category.

3

Enter the required replacement character in the Replacement Character entry box.
Replacement characters (such as *, @, !, #, or ") are used as placeholders to protect
real content used at design time (normally used for password entries).
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4

Insert the character marking the end of a field in the Field End Character entry box.
The default value is $. For characters not available on your keyboard, use the Alt key
plus the decimal value of the character. If you need to look up a value, open the Start
menu and select Programs, Accessories, System Tools, and Character Map. The
Character Map provides the Keystroke required to type special characters.

5

Select the required background color from the Color List.
Background color is only used as a visual aid to help in locating all tag references
used within a form.

6

Select the required tag reference presentation format from the Format drop-down
list.
 Percent: displays (%%1) for tag presentation (default).
 Tag name: displays the field name as specified in the Field Name entry box
from the Tag Selection dialog.
 Replacement chars: displays tags using replacement characters.
 Sample data: displays text as specified in the Sample Data entry box from the
Tag Selection dialog.
The settings are used as a visual aid in the Design Area only

7

Check Autodetect from clipboard to automatically recognize strings in format
%%<number> as tag references, when text objects are copied from clipboard.
This option is useful when text is copied and pasted from a text editor such as
WordPad or MS Word.

8

Check Automatic Tag reference recognize to automatically recognize strings in
format %%<number> as tag references, when text objects are entered from
keyboard.
With this option selected, you need to manually type the tag syntax in text objects
instead of using the Insert Tag Reference tool.

9

Click Apply, and then click OK to save the settings.
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Working with Tag Definition Lists
A tag definition list is an ASCII file containing tag definitions. Once tag definitions are
complete for a form, they can be exported to a tag definition list. Similarly, if definitions
are already available in a tag definition list, the list can be imported for use with a new or
an existing form.
Tag definition lists are imported to or exported from the Linked Tags node in the Tag
Structure tab. Imported definitions do not save to the open form unless each definition is
copied to the Embedded Tags node. Exported lists do not include any tag definitions in
the Embedded Tags node.
If you intend to export tag definitions to a tag definition list, copies of all of
the tags must be listed under the Linked Tags node. Similarly, when
importing a tag definition list, all definitions display under the Linked Tags
node. To embed them in the open form, copy each tag definition to the
Embedded Tags node.

Importing a Tag Definition List
To import a tag definition list:

1

From the File menu, select Import, Tag Definition List. The Open dialog displays.

2

Use the Look in drop-down list to search for the required folder.

3

Select the required tag definition list, and then click Open to import the list.
Tag definition lists use the extension TAG.

If tag definitions already exist within the open form, the imported tag definition
list merges with the existing tag definitions.
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Exporting a Tag Definition List
To export a tag definition list:

1

Make sure that at least one tag definition is created under the Linked Tags node of
the Tag Structure tab.

2

From the File menu, select Export, Tag Definition List.
The Save as dialog displays.

3

Search for the required target folder.

4

Enter the tag definition list (TAG) name in the File name entry box, and then click
Save to export the list.

Using Elixir PrintDriver Pro for Data Tagging
PrintDriver provides options for creating forms from Windows applications, such as MS
Word for opening in Form Editor. For more information on using PrintDriver, refer to
Chapter 9: “Using Elixir PrintDriver Pro” on page 201.
You can insert tag references within a MS Word document and later on, use PrintDriver to
convert the document as a form (EFR). See “Adding Tags to a MS Word Document” on
page 251. The resulting form opens in Form Editor with the tag references intact.

Adding Tags to a MS Word Document
To add a tag to an MS Word document:

1

Open a document in MS Word.
If you selected the ElixiTag option during installation, the ElixiTag toolbar becomes
available in MS Word. This is an add-on to MS Word, and acts identically to all other
MS Word toolbars.

ElixiTag toolbar.
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2

Click
in the ElixiTag toolbar to display the Open dialog for selecting an
existing tag definition list.
You must install the ElixiTag option when installing DesignPro Tools in
order to use the MS Word add-on toolbar. This option is available in
Custom Install. For more information, refer to Chapter 2: Installation in the
DesignPro Tools for Xerox Getting Started Guide.

3

Use the Look in drop-down list to search for the required folder.

4

Select the required tag definition list (TAG), and then click Open.
All tags in the specified definition list are now available in the drop-down list in MS
Word.

5

Select the required tag from the drop-down list in the ElixiTag toolbar.
The tag adds to your MS Word document using typical tag script: %%x;, where x is
the field identifier:

The tags in the selected tag
definition list are displayed in
the ElixiTag drop-down list.

For more information on ElixiTag utility refer to Chapter 8: Stand-Alone Utilities of
DesignPro Tools Manager for Xerox User Guide.

6
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Save the document and then select Print from the File menu.
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7

From the Print dialog that displays, select Elixir PrintDriver Pro from the Name
drop-down list.

8

Click OK to open the PrintDriver Wizard dialog. Review the dialog selections and
make your required changes.
For more information on using the PrintDriver Wizard dialog, refer to Chapter 9:
“Using Elixir PrintDriver Pro” on page 201.

DAT Files
A DAT file is an ASCII file containing form references and additional script commands
for composing Normalized datastreams. Each DAT file must contain at least one form.
Script commands are not used with every printer, and are not required to complete a DAT
file. Following sections describe the operations that you can perform on a DAT file.

Basic Operations
You can create, add form references and script commands to DAT files in Form Editor.
Refer to the tasks below for more information.


Creating a DAT File (page 253)



Adding Form References to a DAT File (page 254)



Adding Script Commands to a DAT File (page 255)

Creating a DAT File
To create a DAT file in Form Editor:

1

Create a form in the Form Editor.

2

Select DAT File tab in the Manage window.

3

Add form references or script commands under the DAT File node.
For information on adding forms to a DAT file, refer to “Adding Form References to
a DAT File” on page 254. And for information on adding script commands, see
“Adding Script Commands to a DAT File” on page 255.

4

Export the DAT file.
For information on exporting the DAT file, refer to “Exporting a DAT File” on page
257.
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Adding Form References to a DAT File
To add a form reference to a DAT File:

1

In the Manage window, select the DAT File tab.

2

Right-click the DAT File node and select Insert Form from the pop-up menu.
The Open Resource File dialog displays.
You can also add another form by right-clicking an already form and selecting
Insert Form from the pop-up menu. You can select the required form from the
Open dialog that displays.

3

Search for the required target folder, select the required form, and then click Open.
The form reference displays as a child node of the DAT File node in the Manage
window.

The form reference adds to the DAT File.

You can open multiple forms by pressing Ctrl and clicking on the forms you want
to select in the Open dialog. Click Open, the form references are displayed as
child nodes of the DAT File node.
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Adding Script Commands to a DAT File
To add a script command to a DAT file:

1

In the Manage window, select the DAT File tab.

2

Right-click the DAT File node and select Insert Command from the pop-up menu.
A secondary pop-up menu displays.

DAT File tab in the Manage window.

3

Select the required script commands:
 Simplex: prints a form on single side; required for some Duplex-only printers.
 Input Tray: adds a form to the Input Tray. Once added, you can edit the tray
name and/or number as necessary to match your printer specifications.
 Output Tray: adds a form to the Output Tray. Once added, you can edit the tray
name and/or number as necessary to match your printer specifications.
 Copies: makes copies of a form. Once added, you can modify the number of
copies required.

The specified script command is added to the DAT file.
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Working with DAT Files
You can perform operations with DAT files such as opening referenced forms from a DAT
file, reordering form references and script commands, and deleting required form
references or script commands from a DAT file. Operations for exporting or importing
DAT files are also supported in the Form Editor. Refer to the following:


Opening a Form from a DAT File (page 256)



Reordering Form References or Script Commands in a DAT File (page 256)



Deleting Form References or Script Commands in a DAT File (page 256)



Exporting a DAT File (page 257)



Importing a DAT File (page 257)

Opening a Form from a DAT File
Referenced forms can be opened directly from the DAT File tab.
To open a referenced form:

1

Add the required forms under the DAT File node.

2

Right-click the form and select Open Form from the pop-up menu.
The selected form opens in the design area.

Reordering Form References or Script Commands in a DAT File
To reorder existing form references or script commands in a DAT file:

1

Add form reference and/or script command under the DAT File node.

2

Click and drag a selected form reference or script command to the required location
within the DAT File tree.
The selected form reference or script command moves up or down the DAT File tree
as placed.

Deleting Form References or Script Commands in a DAT File
To delete a form reference or script command added to a DAT file, right-click the required
form reference or scrip command node and select Delete from the pop-up menu. The
selected node is deleted.
You can delete all forms from the DAT file by right-clicking the DAT File node and
selecting Delete All from the pop-up menu.
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Exporting a DAT File
Once a DAT file is complete, you must export the file for conversion.
To export a DAT file:

1

From the File, select Export, DAT file.
The Save as dialog displays.

2

Use the Save in drop-down list to search for the required folder.

3

Specify the DAT file name in the File Name entry box, and then click Save.
The DAT file (DAT) is exported to the target location.
You can also export a tag definition file from the Manage window. Right-click the
DAT File node and select Export from the pop-up menu. Specify a location for
the file, save the file and return to Form Editor.

Importing a DAT File
DAT files can be imported into the Form Editor for viewing, editing, and exporting. An
imported DAT file does not merge with an open DAT file.

Export any changes to a DAT file in progress before importing a new DAT file.
Changes are only saved to the open DAT file when exported.

To import an existing DAT file:

1

From the File, select Import, DAT file.
The Open dialog displays.

2

Use the Look in drop-down list to search for the required folder.
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3

Select an existing DAT file, and then click Open.
The specified DAT file is imported in the design area.
You can also import a tag definition file from the Manage window. Right-click the
DAT File node and select Import from the pop-up menu. Select the required
file from the dialog that displays.

DAT Parser Properties
The DAT parser reads referenced forms and associated resources. Using the DAT, you can
view or set properties regarding the resources used in a form such as setting resources
paths, etc. To set the DAT parser properties, refer to “Setting DAT Parser Properties” on
page 258.

Setting DAT Parser Properties
To set DAT parser properties:

1

From the Tools menu, select Application Format Setting, Input Format, Dat
Parser menu.
The Dat Input Parser Properties dialog displays.

2

Review the dialog selections and make your changes.
For information on Dat Input Parser Properties dialog, refer to the Online Help.
To open the Online Help, click
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available on the top right of the dialog.
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Converting DAT Files to Normalized Metacode
Once the DAT file is complete, you will convert it to a print format. Normalized Metacode
is created in the Manager using the Converters utility.
Normalized Metacode is almost identical to Metacode, with the exception of BPSD Tags.
The BPSD Tags in Normalized Metacode are used by DocuMerge (a Document Sciences
product) to merge forms with live data during the print process.
To convert a DAT file to Normalized Metacode, refer to the following tasks:


Locating a DAT File in the DesignPro Manager (page 259)



Starting a Conversions Session (page 259)



Setting Input Properties (page 260)



Setting Output Properties (page 260)



Running the Conversion to Normalized Metacode (page 261)

Locating a DAT File in the DesignPro Manager
To locate a DAT file in the Manager:

1

Using the Elixir Resources pane in Manager, browse to Documents, Elixir, Elixir1.

2

On the top right of the application window, select Elixir Dat File (*.dat) from the
drop-down file filter list.
DAT files display in the Details window.

Starting a Conversions Session
To start a conversions session with a DAT file:

1

Locate a DAT file in the anager.

2

Click and drag a DAT file to
in the Applications tab.
The Conversions dialog opens. The DAT file is automatically recognized, and the
input area is filled in for you.
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Setting Input Properties
Input DAT file properties locate the forms and resources needed for creating the
Normalized Metacode file.
To set input DAT file properties:

1

Click
in the Inputs area of the Conversions dialog.
The Dat Input Parser Properties dialog displays.

2

Review dialog selections and make your changes.
For details on Dat Input Parser Properties dialog, refer to the DesignPro Tools
Online Help. To open the Online Help, click
open dialog.

3

available on the top right of an

Click Apply to save your settings and then click OK to close the Dat Input Parser
Properties dialog and return to the Conversions dialog.

Setting Output Properties
To set Normalized Metacode output properties:

1

Click
adjacent to the Xerox Metacode output format to set properties for
specified input Dat file in the Conversions dialog.
The Metacode dialog displays.

For details on the Metacode dialog, refer to the DesignPro Tools Online Help. To
open the Online Help, click

2
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available on the top right of an open dialog.

Click Apply to save your settings and then click OK to close the dialog.

DesignPro Tools Form Editor® for Xerox User Guide

Running the Conversion to Normalized Metacode
Default Metacode properties are set in the Manager. From the Tools menu,
select Application Format Setting, Output Formats, Metacode menu.

To run the conversion:

1

Specify the input properties for the DAT file.

2

Specify the output properties for the Normalized Metacode file.

3

Check Xerox Metacode format in the Output Formats view of the Conversions
dialog.
An output must be selected to create an output document.

4

Click OK to run the conversion.
The conversion status displays in the Messages window of Manager. Refer to
DesignPro Tools Manager for Xerox User Guide for more information.
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Chapter 12:

Editing Forms
In this chapter...


Modifying Forms



Common Object Properties



Setting Editing Options



Previewing and Printing Forms

Modifying Forms
You can modify forms and form objects using basic editing commands, including cut,
copy, paste, and delete. You can move form objects to different locations in the Design
Area, and specify fixed distances between multiple objects and object copies. You can also
apply color to form objects or change an existing color. In addition, you can also perform
detailed spell check.

Common Object Properties
Most objects available in the Form Editor share common properties.
To set or change properties for objects inserted in a form:

1

Right-click the object in the Design Area and select Properties from the pop-up
menu.
The associated Properties dialog of the selected object displays.
You can also view the object properties using one of the following methods:


From the View menu, select Properties.

or


Press Alt + Enter.
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2

Select the required Category option.

3

Review the dialog selections and make your changes

4

Click Apply, and then click OK to save your changes.
Once an object has been added to the form the associated toolbox is replaced
with the Select toolbox. To view the associated toolbox, select the object in the
Design Area, press Ctrl and right-click the object. The associated toolbox
replaces the Select toolbox. This feature is available for to line, box, barcode,
active button, active radio button, and signature objects.

The following topics detail those Category options that are common to all of the objects.

Selecting Design Area Objects
Use the mouse pointer to select the required object(s) in the Design Area. As illustrated in
the image below, the resize handles mark a selected object. Line objects have handles at
each end. All other objects have handles at each corner and each midpoint.

1) Bringing the mouse pointer over the object highlights it. 2) Clicking the object selects
it.
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Selecting Multiple Design Area Objects
There are three ways to select multiple objects in Form Editor:


Select All method
From the Edit menu, select Select All. All the objects on the form are selected. You
can also use the shortcut keys Ctrl + A to select all the form contents.

You can also invert the current selection by either selecting Invert Selection
from the Edit menu or by using the Ctrl + I shortcut key.



Marquee selection method
Click and drag the mouse pointer in the Design Area until the area you want to select
is enclosed by a rectangle. Release the mouse button. All objects inside the rectangle
are selected.



Shift + Click method
Press Shift and click on the objects you want to select. The objects on which you
clicked are selected only.

For more information on setting the object selection options available in Form Editor,
refer to the following task.
Setting Object Selection Options
Form Editor lets you specify the object selection options.
To set the object selection options, specify the following:

1

From the Tools menu, select the Options.
The options dialog displays

2

Select the Editor category from the Applications node.

3

Select either Enclose or Touch to set the object selection method.
 Enclose: form object can only be selected when the entire object is enclosed
within the selection box.
 Touch: form object can be selected when any part of the object is within the
selection box. You can also select the object by clicking on it using the mouse
pointer.

4

Click Apply and OK to save the changes
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Assigning Properties to Multiple Selected Objects
To set or change proprieties of multiple selected objects inserted in a form:

1

Use one of the methods mentioned above to select multiple objects in the Design
Area.

2

Right-click on one of the objects in the Design Area and select Properties from the
pop-up menu.
The associated Properties dialog displays.
You can also view the object properties by either:


Selecting Properties from the View menu.

or


Pressing Alt + Enter on the keyboard.

3

Select the required Category option.

4

Review the dialog selections and make your changes

5

Click Apply, and then click OK to save your changes.
The changes are applied to the multiple objects.

Copying Objects
Copying an object places a copy of the object on the clipboard. You can paste a copy of
the object in the same form or in a different form. The following methods are used for
copying objects:
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Select an object in the form, and from the Edit menu, select Copy.



Select the object in the form and select



Right-click an object in the form and select Copy from the pop-up menu.



Select an object in the form and press the Ctrl + C, the object is copied. Place the
copy of the object at the required location.

from the Standard toolbar.
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Creating Multiple Copies of Objects
Form Editor provides a feature for making multiple copies of objects. Multiple copies
have the same properties as the source object. Any change that you make in the source
object is not inherited by the object copies. You can also set horizontal and vertical offsets
to easily place the copies at different positions, relative to the original box.
To create multiple copies of the box object:

1

Select the object in the Design Area by clicking it once.

2

Select

3

Enter the number of copies you want to make in
toolbox.

4

Select a direction, you can select

5

Enter the vertical and horizontal offsets in the

on the Select toolbox.

,

, or

entry box on the Select

.
and

entry boxes respectively.
The first object copy will be placed relative to the original object based on the
specified horizontal and vertical offsets. The second object copy will be placed
relative to the first object copy and so on.

6

Drag the object to the required position.
The object copies.

7

Click

once more to turn the option off.

Chapter 12: Editing Forms

267

The image below shows an example of making multiple copies of a single object:

Select
to copy
the object.
Enter the number of
copies to make in
.
The direction
has been set to
.
The specified number
of copies are made.

You can also specify the number of copies using the up and down (spin control)
buttons next to the Copy# entry box.

If you do not turn
copied.
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off, any object you attempt to click and drag will be
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Pasting Objects
After copying and/or cutting objects, you can paste them in the form at the required
location. The paste command has no effect if the clipboard is empty. There are several
methods for pasting objects. You can select from the following methods:


Cut an object in the form, and then paste the object at the required location by
selecting Paste from the Edit menu.



Copy an object in the form, and then paste the object at the required location by
selecting Paste from the Edit menu
You can also paste an object using one of the following method:
Clicking



on the Standard toolbar.

or
Right-clicking an object and then selecting Paste from the pop-up menu.



or
Pressing Ctrl + V on the keyboard.



Setting the Paste Option
To set the object selection options, specify the following:

1

From the Tools menu, select the Options.
The options dialog displays

2

From the Applications node, select the Editor category.

3

Check Paste with Mouse to paste selection using the mouse.
After selecting and pasting the required object, the cursor displays an attached
rectangle (in this example) representing the selected object’s area. You can move the
mouse pointer to the required location and place the selected object.
The cursor displays a rectangle
representing the selected object’s
area.

4

Click Apply and OK to save the changes.
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Cutting Objects
Cutting an object removes it from the form and places it on the clipboard. You can cut an
object and then paste it to move it from one location to another in the form. There are
several methods for cutting objects. You can select from the following methods:


Select the object in the form and select Cut from the Edit menu.



Select the object in the form and select



Right-click an object in the form, and then select Cut from the pop-up menu.

from the Standard toolbar.

You can also cut an object using the Ctrl + X shortcut key.

Deleting Objects
You can delete objects within the Design Area in the Form Editor. There are several
methods for deleting objects. You can select from the following methods:
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Select an object in the form and press the Delete key on the keyboard.



Right-click an object in the form and select Delete from the pop-up menu.



Select an object in the form and select Delete from the Edit menu.



Right-click an object listed in the Object Type View tab of the Manage window and
select Delete from the pop-up menu. Only the selected object is deleted.



Right-click an object type listed in the Object Type View tab of the Manage
window and select Delete object name from the pop-up menu. All objects listed
under the object type are deleted.



Right-click the Objects node in the Object Type View tab of the Manage window
and select Delete all from the pop-up menu. All objects listed in the Object Type
View tab are deleted.
For deleting active radio buttons, you can also use the Radio Buttons tab of the
Manage window.
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Repositioning Objects
You can use one of the following methods for positioning objects in the Design Area:


Select and drag the object at the required place in the Design Area. The object is
moved to the new location.



Right-click the object and select Properties from the pop-up menu. From the
Properties dialog that displays, select the Transformation or Position category.
Specify the required horizontal and vertical position in the X and Y entry boxes. The
object is positioned at the new location.

Transformation category is only available for active objects in the Xerox
toolset.



Select the object and enter the coordinates in the X and Y entry boxes on the
Position and Dimension toolbar. The object is moved to the required location.



To move the copy of an object, select the object, press Ctrl, the object is copied.
Move the mouse pointer to the required location and place the object.

Form Editor provides a feature that lets you automatically move connecting perpendicular
lines. Line connected to form the sides of box also remain attached when you move the box.
For example, you can move the bottom horizontal line in a table, and all perpendicular lines
ending at the bottom line will automatically move (sticky lines). On de-selecting this feature,
only the selected line is affected by subsequent line moves.
To move objects using the sticky tool:
Draw lines that are perpendicular to each other or a line that is perpendicular to a box. Select
from the Select toolbar. Select the line, and move the line to the required location using
the mouse pointer. The other line or box also moves to the required location.
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Changing the Object Border and Interior Color
Form Editor provides options for specifying the border and interior color for the selected
object. You can pick any predefined color available in the palette. You can also review the
selected color properties.
To set the border and interior color of an object:

1

Right-click the object in the form and select Properties from the pop-up menu.
The associated Properties dialog displays.

2

Select the Color category and select Fg/Border and/or Bg/Interior.
Selecting Fg/Border changes the object’s border color and selecting Bg/Interior
changes the object’s interior color. You can also view the color models of the
available colors, and their first, second, third and fourth saturation components in
this dialog.

3

Select the required color from the list of available colors under Name.

4

Click Apply and OK to save the changes
The selected color is applied to the object:

1) The box border color is set to black. 2) The box interior color is set to blue.

Resizing Objects
You can use one of the following methods to change an object size:
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Select the object, the cursor changes to a + sign and then drag the object handles
either vertically, horizontally, or diagonally. Release the mouse button at the required
object length and/or width (scale). Proportions are maintained as you resize the
object. To resize the object either horizontally or vertically, drag the center handles.



Select the object and enter the coordinates in the W and H entry boxes on the
Position and Dimension toolbar. The object size changes to the required size.
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Resize the object using the object - Properties dialog:
• Right-click the object and select Properties from the pop-up menu. From the
Properties dialog that displays, select either the Transformation or Dimensions
category. Specify the required width and height of the object in the Width and
Height entry boxes. The object size changes to the required size.
• Right-click the object and select Properties from the pop-up menu. From the
Properties dialog that displays, select the Transformation category. Specify the
horizontal and vertical scaling percentage in the Scale – X and Y entry boxes.
The object is resized using the specified percentage. Only applicable for active
objects in the Xerox toolset.

To reduce the object size, enter a value less than 100; to increase the object size,
enter a value greater than 100.

Transformation category is only available for active objects in the Xerox
toolset.

Setting Object Rotation
To rotate an object in the Design Area:


Right-click the object and select Properties from the pop-up menu. From the
Properties dialog that displays, select the Transformation category. Specify the
rotation degrees in the Rotation entry box. The object is rotated by the specified
degrees. Only applicable for active objects in the Xerox toolset.



Select the object and enter the rotation degrees in the Rotation entry box on the
Position and Dimension toolbar. The object is rotated by the specified degrees.

0
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Changing an Object’s Line Style
Form Editor provides various options to change the object line style and thickness.
To set the object style:

1

Right-click the object in the form and select Properties from the pop-up menu.
The associated Properties dialog displays.

1

Select the Style category.
This category is only applicable for line, box, ellipse, and path objects.

2

Select the required style form the Line Style drop-down list.
Style examples:

You can also specify the required style using Line Style drop-down list in the
Common Attributes toolbar.

3

Specify the line thickness in the Line Thickness entry box.
You can select a predefined value from the available weights in the drop-down list.
Alternatively, you can also specify a customized value by selecting Custom from the
drop-down list and specifying the required thickness in the entry box next to this
option.
The thickness of a solid line drawn in Form Editor is automatically changed to
0.004 inches, if the thickness is less than 0.004 inches and the resolution is set to
240. This measure is adopted to make the lines visible on the print out.
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In Elixir Legacy Forms (ELX) if the border line style of a shaded box is set to
None and the Thickness is set to zero, then the box is displayed without any
border.

Skewing Objects
To distort an object in the Design Area:


Right-click the object and select Properties from the pop-up menu. From the
Properties dialog that displays, select the Transformation category. Specify the
skewing degrees in the Skew entry box. The object is skewed by the specified
degrees.

Transformation category is only available for active objects in the Xerox
toolset.



Select the object and enter the skewing degrees in the Skew entry box in the Position
and Dimension toolbar. The object is skewed by the specified degree.

Skewing an object.

To skew an object towards the left side, enter a positive value; to skew an object
towards the right side, enter a negative value.
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Setting the Object Interior
Form Editor provides options for filling objects with predefined patterns. You can also
select diagonals from the list of available options and fill each part of the object with a
different pattern.
To change or apply the object interior:

1

Right-click the object in the form and select Properties from the pop-up menu.
The associated Properties dialog displays.

2

Select the Interior category.
This category is applicable for box object only.

3

Select required pattern from the list of available patterns.

4

Click Apply and OK to save the changes.

Setting the Object Direction
To change the object direction:

1

Right-click the object in the form and select Properties from the pop-up menu.
The associated Properties dialog displays.

2

Select the Direction category and select the following:
 Across: places objects left to right in the form.
 Down: places objects top to bottom in the form.
 Back: places objects right to left in the form.
 Up: places objects bottom to top in the form.

Displaying the image in different directions: 1) Across 2) Down 3) Back 4) Up.

276

DesignPro Tools Form Editor® for Xerox User Guide

3

Click Apply and OK to save the changes.
The direction of the object changes as specified. This category is applicable for
image, text, and barcode objects only

Filtering Objects
You can use the filter tools located on the Filter toolbar to exclude objects in the from
from editing functions such as moving or deleting.

To filter an object in the form: select the associated filter tool on the Filter toolbar. This
action lets you edit all objects except the selected filter tool object; double clicking other
objects in the form changes the mouse pointer to the edit mode indicating that the object is
editable.
An example is shown below:
The text object becomes
un-editable when
is
selected from the Filter
toolbar.

All object in the form are editable except for the text object, since Text filter tool has been
selected from the Filter toolbar.

You can also select an object filter by selecting the required tool from the View,
Object Filters menu.
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Arranging Objects
Within the Design Area, you can arrange/stack objects based on the order in which they
are created, placing the most recently created object at the top of the stack. The
arrangement order of objects determines how they appear when they are overlapping.
Bring to Front
Right-click the object in the Design Area and select Bring to Front from the pop-menu to
bring the selected object to the front of overlapping objects.
Send to Back
Right-click the object in the Design Area and select Send to Back from the pop-menu to
send the selected object to the back of overlapping objects.
Bring Forward
Right-click the object in the Design Area and select Bring to Forward from the popmenu to bring the selected object up one step from the current position in the Design Area.
Send Backward
Right-click the object in the Design Area and select Send Backward from the pop-menu
to send the selected object down one step from the current position in the Design Area.

Undoing and Repeating Commands
Form Editor keeps track of your editing and formatting changes. If you want to undo a
change or command selection, you can usually reverse several previous actions.
To undo a change or redo a change:


Select
a change.

from the Standard toolbar to undo a change and select to



Press Ctrl + Z to undo a change and press Ctrl + Y to redo a change.

redo

You can also select the Undo and Redo options from the Edit menu.
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Setting Editing Options
Form Editor provides options for running spell checker and performing workspace cut,
paste, and save operations. In addition, you can also perform clipboard and filing
operations, as well as load the required font list for your form and you can preload a
required font from a font list. Paste options allow you to preserve RTF formatting at the
time of pasting and place data at a required location with/without a mouse click.

Using Spell Checker
Form Editor offers the spell check feature which employs a custom dictionary to check for
misspellings in a document. Spell checker displays a list of words that are similarly
spelled from the dictionary. When the spell check feature identifies a word not found in
the specified dictionary or dictionaries, you can select how to handle the word as
mentioned in the steps below.
To use the spell checker:

1

Insert text within a text box in the Design Area.

2

Select the text in the text box.

3

From the Tools menu, select Spell Check.
The Spelling dialog is displayed.

You can also open the Spelling dialog by clicking

4

on the Standard toolbar.

As appropriate, select either one of the following:
 Not in Dictionary: identifies the incorrectly spelled word; enter the correct
word.
or
 Suggestion: lists options for similarly spelled words from the dictionary; select
the correct word from the list.
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5

Do one of the following:
 Click Replace to use the suggested word displayed by the spell checker and
change the spelling of the incorrect word.
or
 Click Ignore to disregard the options displayed by the spell checker.
or
 Click Cancel to return to the Design Area without using the spell checker. Form
Editor displays a message confirming your selection of the above options.
Example of the Spell Check feature:
The Check Spelling
dialog displays when
the spell checker
feature is selected.

Once the spell check is complete,
a message box displays

For more information on the specifying the various spell check options refer, to
“Specifying Dictionary Files for Spell Checking” on page 282.

Setting Spell Checking Options
To set the spell checking options:
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1

From the Tools menu, select Options.
The Options dialog displays

2

From the Applications node, select the Editor category.

3

Select Spellcheck Typing to activate the spell check feature.
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4

To set the spelling options select Spell Options.
The Options dialog displays where you can set the spell checker properties. The
Options dialog displays only when a form is loaded in the Design Area.

5

In the Options dialog, specify the following options:
 Ignore Capitalized Words: ignores any words beginning with a capital letter
while spell checking.
 Ignore all-Caps Words: ignores any words containing all capital letters while
spell checking.
 Ignore Words with Numbers: ignores any words containing numbers while
spell checking.
 Ignore Words with Mixed Case: ignores any words containing both upper and
lower case letters while spell checking.
 Ignore Domain Names: ignores any words that are Internet domain names while
spell checking.
 Report Doubled Words: reports instances of words appearing twice in a row
while spell checking.
 Case Sensitive: performs case-sensitive spell check; this option is selected by
default.
 Phonetic Suggestions: displays phonetic suggestions for misspelled words while
spell checking.
 Typographical Suggestions: displays typographical suggestions for misspelled
words while spell checking.
 Suggest Split Words: displays split-word suggestions as a replacement for
misspelled words containing two joined words.
 Auto Correct: corrects commonly misspelled words automatically while spell
checking.

6

Select the primary dictionary language for spell checking from the Main Dictionary
drop-down list.

7

To set the speed of the spell checker, specify the following options:
 Fast but Less Accurate: performs fast but less accurate checking.
 Moderately Fast and Accurate: performs moderately fast and accurate
checking.
 Slow but Accurate: performs slow but accurate checking.

8

Click OK to return to the previous dialog.

9

Click Apply and OK to save the changes.
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Specifying Dictionary Files for Spell Checking
You can customize the way Form Editor checks the spelling of text within the text objects
by employing a custom dictionary. The dictionary used for referring to words for spell
checking is a third party component and is acquired and placed at drive:\Program
Files\Elixir Technologies\Common\Spell. You can also spell check text in different
languages by acquiring an off the shelf custom dictionary either for all languages or for a
specific language. Options for adding and removing the dictionary files are explained in
subsequent tasks.
Adding a Dictionary File
To add a dictionary file:

1

From the Tools menu, select Spell Check.
The Spelling dialog is displayed.

2

Click the Dictionaries button.
The Add Dictionary to File dialog displays

3

Browse to select the required file and click Open to add the dictionary file.
You return to the previous dialog.

Place the custom dictionary at the recommended location drive: \Program
Files\Elixir Technologies\Common\Spell.

4

Click Close to add the new dictionary file.

For more information on this dialog click Help.
Creating a Dictionary File
To create a dictionary file:
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1

From the Tools menu, select Spell Check.
The Spelling dialog is displayed.

2

Click the Dictionaries button.
The Add Dictionary to File dialog displays

3

Click New file.
The New Dictionary dialog displays.
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4

Enter the name of the new dictionary file in the File Name entry box.
You can enter a name or drowse for an existing dictionary files.

Clicking Browse displays the Create New Dictionary dialog. You can enter
the name of the new file or view the existing dictionary files in this dialog.

5

Select the required language from the Language drop-down list. If the required
language is not listed, you can select the Any option.

6

Click OK and return to the previous dialog.

7

Click Close to create the new dictionary file.

For more information on this dialog click Help.
Removing an Existing Dictionary File
To remove a dictionary file:

1

From the Tools menu, select Spell Check.
The Spelling dialog is displayed.

2

Click the Dictionaries button.
The Add Dictionary to File dialog displays

3

Select the required dictionary file from the File drop-down list and click Remove.
The selected file is removed.

4

Click Close to remove the selected dictionary file.

For more information on this dialog click Help.
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Adding Words to a Dictionary
To add a word to a dictionary file:

1

From the Tools menu, select Spell Check.
The Spelling dialog is displayed.

2

Click the Dictionaries button.
The Add Dictionary to File dialog displays

3

Select the required dictionary file from the File drop-down list.
This list displays the open dictionary files. On selecting the file from the list, the
contents of the dictionary are displayed in the Words list. Selecting this option
activates the Words and Add Word options.

4

Enter the new word in the Words entry box.
You can also select from the options available in the list right below the Words entry
box.

5

Click the Add Word to add word to the dictionary file.

For more information on this dialog click Help.
Deleting Words from a Dictionary
To delete a word from a dictionary file:

1

From the Tools menu, select Spell Check.
The Spelling dialog is displayed.

2

Click the Dictionaries button.
The Add Dictionary to File dialog displays

3

Select the required dictionary file from the File drop-down list.
This list displays the open dictionary files. On selecting the file from the list, the
contents of the dictionary are displayed in the Words list. Selecting this option
activates the Words and Delete Word options.

4

Select the required word from the list right below the Words entry box.

5

Click Delete Word to remove the word from the dictionary file.

For more information on this dialog click Help.
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Importing the Contents of a Dictionary
To import the contents of a dictionary file:

1

From the Tools menu, select Spell Check.
The Spelling dialog is displayed.

2

Click the Dictionaries button.
The Add Dictionary to File dialog displays

3

Select the required dictionary file from the File drop-down list.

4

Click Import to add words from the selected text file.

5

From the dialog that displays, select the required file and click Open.

6

Click Close, the contents of the file are added to the selected dictionary file.

For more information on this dialog click Help.
Exporting the Contents of a Dictionary
To export the contents of a dictionary file:

1

From the Tools menu, select Spell Check.
The Spelling dialog is displayed.

2

Click the Dictionaries button.
The Add Dictionary to File dialog displays

3

Select the required dictionary file from the File drop-down list.

4

Click Export to save the contents of the dictionary file to a text file.

5

From the dialog that displays, select the required file and click Save.

6

Click Close to save the contents to a selected file.

For more information on this dialog click Help.
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Previewing and Printing Forms
After creating a form, you can use the Form Editor Print Preview feature to review your
work and make changes before printing. You can also print the form directly from the
Form Editor.

Previewing a Form
To preview a form already open in the workspace:

1

From the File menu, select Print Preview to open the preview window.

2

Click Print to display the Print dialog for setting the print properties.
For more information on the Print dialog, refer to “Printing a Form” on page 287.

3

If your form consists of more than one page you can use the following buttons to
navigate between the pages:
 Next Page: displays the next page in a form. This option is activated only if the
form consists of more than one page.
 Prev Page: displays the previous page in a form. This option is activated only if
the form consists of more than one page.
One Page/Two Page is a toggle button. This option is available only in Elixir
Viewer. For Form Editor, this button remains disabled.
For more information on Elixir Viewer, refer to Chapter 10: Elixir Viewer in
DesignPro Tools Manager for Xerox User Guide.

4

To increase or decrease the magnification of the current page you can select either
Zoom In or Zoom Out respectively.
Zoom Out button is activated only if the Zoom In is previously selected.

5

Click Close to exit the Print Preview and return to the previous view of the form.
Forms are displayed with the selected paper size in the preview window as long
as the selected size is supported by the default printer installed on the system. If
the size is not supported by default printer or a custom paper size is used, then
the form is previewed using the letter paper size.
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Printing a Form
Once the form has been finalized you can print the form using a specified printer. Form
Editor lets you select the printer, and specify the printing range. You can also choose to
print multiple copies of the same form.
Setting the Print Properties
To set the print properties:

1

From the File menu, select Print.
The Print dialog displays.

2

Select the required printer from the Name drop-down list.
Information about the selected printer is displayed underneath this list.

3

Check Print to File to print a document to a file instead of routing it to a printer.

4

Check Print as Image to print the form as bitmap image.
Using a bitmap image preserves the graphics fidelity of the original form.

5

Click Properties to set different properties of the selected printer.

6

Click OK to print the form and return to the Design Area.

Setting a Print Range
In Form Editor you can print specific pages, one or more sections, or a range of pages in
more than one section. This helps save time and money.
To set the print range:

1

From the File menu, select Print.
The Print dialog displays.

2

Select the required print range option form the following:
 Select All to print all file pages.
This option is selected by default.
 Select Pages to specify the number of pages to be printed.
Enter the starting page number in from and end page number in to.
 Select the Selection option to print the current page only.

3

Click OK to print the form and return to the Design Area.
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Printing Multiple Copies
To print multiple copies:

1

From the File menu, select Print.
The Print dialog displays.

2

Enter the number of copies to be printed in the Number of Copies entry box.

3

Check the Collate option to print a complete copy of the file before the first page of
the next copy is printed.
This option activated only if a value greater than 1 is specified in Number of Copies
entry box above.

4

Click OK to print the form and return to the Design Area.

Using Bitmap Half Toning
Form Editor provides the bitmap halftoning feature, which creates the illusion of
continuous tones in an image when printed. At print time, images are broken into a series
of dots. You can vary the sizes of the dots in a halftone screen to create an optical illusion
of variations of gray or continuous color in the image.
To set the bitmap halftoning option:

1

From the Tools menu, select Options.
The Options dialog displays.

2

Select the General category and check User Bitmap Halftoning.

3

Click OK and Apply to save the changes.

Using Font Half Toning
Form Editor provides the font halftoning feature, which prints raster fonts in halftone. At
print time, images are broken into a series of dots. This feature alters the density and
pattern of the black-and-white dots to simulate different shades of gray.
To set the font halftoning option:
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1

From the Tools menu, select Options.
The Options dialog displays.

2

Select the General category and check Use Raster Fonts Halftoning.

3

Click OK and Apply to save the changes.
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Appendix A:

Workspace Quick
Reference
In this appendix...


Menu



Toolbars



Form Design Tools



Keyboard Shortcuts

Menu
Form Editor provides a horizontal menu located right below the title bar. The menu
provides access to standard Windows, as well as Form Editor-specific menu items. Each
menu item is associated with a drop-down menu. You can perform standard Windows
operations to hide or display the menu, or you can dock the menu at the edge of the Design
Area.
Form Editor provides the following menu items:


File Menu (page 290)



Edit Menu (page 291)



View Menu (page 292)



Insert Menu (page 293)



Tools Menu (page 294)



Window Menu (page 296)



Help Menu (page 297)
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File Menu
The File menu provides access to the following commands:

Icon

Menu Item

Purpose

Access Key

New

Creates a new file.

Ctrl + N

Open

Displays the Open dialog to
open the required file.

Ctrl + O

Close

Closes an active form.

Alt + F + C

Save

Saves an active form.

Ctrl + S

Save as

Displays the Save as dialog to
save an active form with a new
name.

Alt + F + A

Import

Displays the dialogs to import
the following lists:

Alt + F + M

Export
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Font List



Palette List



Shade List



Tag Definition List



DAT File



Merging Font Lists

Displays the dialogs to export
the following lists:


Font List



Palette List



Shade List



Tag Definition List



DAT File

Merge Form
Group

Displays the Merge dialog to
select the required form.

Alt + F + E

Save Form
Group

Displays the Save as dialog to
save a form.

Alt + F + G

Load Form
Template

Displays the Template Form
dialog to load the required form
template in the Design Area.

Alt + F + T
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Icon

Menu Item

Purpose

Access Key

Remove Form
Template

Removes the form template
from the Design Area.

Alt + F + F

Remove Tag File
Reference

Removes the tag file reference
from the Design Area.

Print Preview

Provides a view of the form as
it will print.

Print

Displays the Print dialog.

Alt + F + V

Print Setup

Displays the Print Setup
dialog.

Ctrl + P

Properties

Displays the Options dialog to
set the form properties.

Alt + F + R

Recent
Files

Displays a list of recently
opened files in Form Editor.
Exit

Quits the application.

Alt + F + I

Edit Menu
The Edit menu provides access to the following commands:

Icon

Menu Item

Purpose

Access Key

Undo

Reverses the last action.

Ctrl + Z

Redo

Cancels the last undo action.

Ctrl + Y

Cut

Cuts the selection.

Ctrl + X

Copy

Copies the selection to the
clipboard.

Ctrl + C

Paste

Pastes the previously copied
text onto the selected area in the
Design Area.

Ctrl + V

Delete

Deletes the selection.

Delete

Import Text

Displays the Import Text
dialog to select the required
file.

Alt + E + M

Select All

Selects the entire form in the
Design Area.

Ctrl + A
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Icon

Menu Item

Purpose

Access Key

Invert Selection

Cancels the previous selection.

Ctrl + I

Find

Displays the Find dialog.

Ctrl + F

Find Next

Searches for the next
occurrence of the specified
data.

Ctrl + F3

Replace

Displays the Replace dialog.

Ctrl + H

View Menu
The View menu provides access to the following commands:

Icon
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Menu Item

Purpose

Access Key

Full Screen

Switches the display of the
workspace from the Normal
view to the Full Screen view.

Alt + V + F

Zoom

Controls the magnification
level of the form in the Design
Area. Also displays the Zoom
sub-menu. For more
information, refer to the Zoom
Toolbar (page 299).

Alt + V + Z

Toolbars

Controls the display of the
toolbars; also displays the
Toolbars submenu.

Alt + V + T

Status bar

Shows or hides the Status bar.

Alt + V + S

Messages

Shows or hides the Messages
window.

Alt + V + M

Manage window

Shows or hides the Manage
window.

Alt + V + W

Ruler

Shows or hides the graphical
ruler in the Design Area.

F2

Grid

Shows or hides the grid in the
form.

F4

Guidelines

Shows or hides the guidelines
in the form.

Alt + V + U

Crosshair

Displays the crosshair in the
form.

F8
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Icon

Menu Item

Purpose

Access Key

Sticky Lines

Automatically resizes lines
when moving a connecting
perpendicular line. For
example, you can move the
bottom horizontal line in a
table, and all perpendicular
lines ending at the bottom line
will automatically resize.

Ctrl + L

Clear Messages

Clears all of the messages from
the Messages window.

Ctrl + D

Object Filter

Displays all of the filter tools.
Refer to the “Filter Toolbar”
on page 301 for more
information.

Alt + V + B

Form Template

Displays all of the form
template options. Refer to the

Alt + V + O

Form Template Toolbar
(page 302) for more
information.
Properties

Displays the Properties dialog
for the selected object.

Alt + Enter

Insert Menu
The Insert menu provides access to the tools located on the Tools toolbar. For more
information on the Tools toolbar, refer to “Form Design Tools” on page 303 in this
chapter.
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Tools Menu
The Tools menu provides access to the following commands:

Icon
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Menu Item

Purpose

Access Key

Layout

Displays the options to place
the objects in the Design Area.
You can select from the
following options:

Ctrl + L



Bring to Front



Send to Back



Bring Forward



Send Backward

Spell Checker

Displays the Check Spelling
dialog.

F7

Resource Map

Opens the Resource Map
application.

Alt + T + M

Resource
Library

Opens the Resource Library
application.

Alt + T + I

Profile Editor

Opens the Profile Editor
application.

Alt + T + E

Close Path

Closes the path drawn in the
Design Area.

Alt + T + P

Split Text

Splits the selected text object
into two objects.

Alt + T + X

Word Wrap

Wraps the text overflow in a
text object to the next line. You
can select from the following
options:


Wrap Up



Wrap Down



Dangling Punctuation
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Icon

Menu Item

Purpose

Access Key

Join Text

Displays options to join the
Text objects in the Design Area.
You can select from the
following options:

Alt + T + J



Join by Spaces



Join by Justify



Join by Relative

Reformat Text

Fixes the layout, indentation,
and alignment of the text
object.

Alt + T + F

Remove
redundant
spacing

Removes the extra spaces from
the selected text string.

AutoDetect Tag
Reference

Searches for the tag reference in
the Design Area.

Alt + T + G

Rulers and Grid

Displays the rulers and grid
options in the submenu.

Alt + R + S

Options

Displays the Options dialog.

Alt + T + T

Profile Selection

Displays the Profile Selection
dialog.

Alt + T + C

Toolset Selection

Lets you select the required
toolset. The available options
are: Xerox, AFP, or Hybrid.

Alt + T + O

Application
Format Setting

Displays the Application
Format Setting submenu for
setting the application
properties; also lets you Load,
Save, and Clear the setup file
at the application level.

Alt + T + A

Document
Format Setting

Displays the Document
Format Setting submenu to set
the document properties; also
lets you Load, Save, and Clear
the Setup file at the document
level.

Alt + T + D
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Window Menu
The Window menu provides access to the following commands:

Icon
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Menu Item

Purpose

Access Key

Default State

Returns the Design Area to the
default state.

Alt + W + S

Tile

Rearranges and resizes all of
the opened forms in the Form
Editor so that they do not
overlap each other

Alt + W + T

Arrange Icons

Arranges the minimized forms
in the Design Area.

Alt + W + A

Split

Splits the active form into four
areas.

Alt + W + P

Remove Split

Rejoins the form.

Alt + W + E

Dock to

Docks the current form window
to the selected location. You
can move the windows to: Top,
Left, Right, or to the Bottom
of the Design Area.

Alt + W + O

Switch to MDI

This feature is not currently
functional.

Alt + W + M

Windows

Displays the Windows dialog
containing the list of all of the
open forms. A form selected
from this dialog displays in the
Design Area.

Alt + W + W
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Help Menu
The Help menu provides access to the following commands:

Icon

Menu Item

Purpose

Access Key

Contents

Opens the DesignPro Tools for
Xerox Help file with the
Contents tab selected.

F1

Search

Opens the DesignPro Tools
Xerox Help file with the
Search tab selected.

Alt + H + S

Index

Opens the DesignPro Tools
Xerox Help file with the Index
tab selected.

Alt + H + I

Elixir on Web

Opens the Elixir web site.

Alt + H + E

About Form
Editor

Displays the Product Version,
Copyright, and Licensing
information.

Alt + H + A

Toolbars
Form Editor toolbars provide access to the most commonly used application commands.
You can perform standard Windows operations to hide or display a toolbar, dock a toolbar
at the edge of the Design Area, or display a toolbar as a palette window.
Form Editor provides the following toolbars:


Standard Toolbar (page 298)



Zoom Toolbar (page 299)



Position and Dimension Toolbar (page 300)



Common Attributes Toolbar (page 300)



Filter Toolbar (page 301)



Form Template Toolbar (page 302)
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Standard Toolbar
The Standard toolbar provides one-click access to the basic File and Edit menu
commands.

Button

Purpose
Creates a new file.
Opens the selected file.
Saves the active file in a specified format.
Prints the selection.
Provides a view of the form as it will print.
Displays the Check Spelling dialog.
Cuts the selection.
Copies the selection to the clipboard.
Pastes the selection onto the selected area in the
Design Area.
Reverses the last action.
Cancels the last undo action.
Searches for the first occurrence of the specified
data.
Searches for the next occurrence of the specified
data.
Displays the properties for the selected object in
the Design Area or tree window.
Opens the Form Editor for Xerox help file.
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Zoom Toolbar
The Zoom toolbar provides shortcuts to workspace viewing commands.

Button

Purpose
Increases the window object magnification.
Reduces the window object magnification.
Sets the window zoom percentage (window)
view size.
Sets the window display to a predefined
measurement.
Shows or hides the graphical ruler in the Design
Area.
Shows or hides the grid in the form.
Switches the snap to grid feature on or off.
Displays the crosshair in the form.
Shows or hides the guidelines in the form.
Switches the snap to guidelines feature on or off.
Switches the snap to objects feature on or off.
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Position and Dimension Toolbar
The Position and Dimension toolbar is used for editing the start coordinates and
dimension operations for an object.

Control Box

Purpose
Displays the horizontal and vertical coordinates
in the X and Y entry box on the toolbar for the
selected object. The red square represents the
coordinates of the selected object.
Sets the horizontal and vertical start coordinates
for a selected object.
Sets the width and height values for a selected
object.
Retains the original height and width proportion
during the resize operation for an object.
Rotates and skews the selected object.

Common Attributes Toolbar
The Common Attributes toolbar is used for setting common object properties, such as
color, line style, and thickness.

Button

Purpose
Sets the background and foreground color for a
selected object.
Sets the pattern for a selected object.
Displays the line thickness selections.
Specifies the custom value for the line thickness.
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Button

Purpose
Displays the predefined borderline styles for an
object.
Displays the predefined line cap styles for an
object.

Filter Toolbar
The Filter toolbar provides quick access to the filter options provided in Form Editor. You
can use the Filter toolbar commands to exclude specified objects in the Design Area from
editing functions, such as moving or deleting.

Button

Purpose
Switches the editing feature on and off for a line
object.
Switches the editing feature on and off for a box
object.
Switches the editing feature on and off for a text
object.
Switches the editing feature on and off for an
image object.
Switches the editing feature on and off for a
barcode object.
Switches the editing feature on and off for an
active button.
Switches the editing feature on and off for an
active checkbox.
Switches the editing feature on and off for an
active combobox.
Switches the editing feature on and off for an
active editbox.
Switches the editing feature on and off for a
active radio button.
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Button

Purpose
Switches the editing feature on and off for a
signature.
Switches the editing feature on and off for tag
definition.

Form Template Toolbar
The Form Template toolbar provides quick access to commands related to opening and
removing form templates.

Button

Purpose
Displays the Form Template dialog. Activated
only if a form template is not opened in the Form
Editor.
Removes the form template from the Design
Area.
Switches the editing feature on and off for a form
template.
Switches the editing feature on and off for a line
object.
Switches the editing feature on and off for a box
object.
Switches the editing feature on and off for a text
object.
Switches the editing feature on and off for an
image object.
Switches the editing feature on and off for a
barcode object.
Switches the editing feature on and off for an
active button.
Switches the object editing feature on and off for
an active checkbox.
Switches the object editing feature on and off for
an active combobox.
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Button

Purpose
Switches the object editing feature on and off for
an active editbox.
Switches the editing feature on and off for an
active radio button.
Switches the editing feature on and off for a
signature.
Switches the editing feature on and off for a tag
definition.
Sets the color for the selected form template.

Form Design Tools
Form design tools are design operation shortcuts located on the Tools toolbar. With oneclick access, you can open various toolboxes to perform specific design operations.
However, the Tools toolbar is only active when a form is open in the Design Area. You
can show or hide the toolbar and move it anywhere on the screen.
When you click a tool on the Tools toolbar, a corresponding toolbox opens above the
Design Area. Click another tool, and a new toolbox replaces the previous selection.

The tools are explained in the following table:

Item

Purpose
Displays the Select Toolbox (page 305).
Enables the insertion of a line object in the form
and displays the Line Toolbox (page 306).
Enables the insertion of a box object in the form
and displays the Box Toolbox (page 307).
Enables the insertion of a text object in the form
and displays the Text Attributes Toolbox (page
308).
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Item

Purpose
Enables the insertion of an image in the form and
displays the Image Toolbox (page 309).
Enables the insertion of a barcode object in the
form and displays the Barcode Toolbox (page
309).
Enables the insertion of an active button in the
form and displays the Active Button Toolbox
(page 310).
Enables the insertion of an active checkbox in the
form and displays the Active Checkbox toolbox.
Refer to the Active Button Toolbox (page
310).
Enables the insertion of an active combobox in
the form and displays the Active Combobox
toolbox. Refer to the Active Button Toolbox
(page 310).
Enables the insertion of an active editbox in the
form and displays the Active Editbox toolbox.
Refer to the Active Button Toolbox (page
310).
Enables the insertion of an active radio button in
the form and displays the Active Radio Button
toolbox. Refer to the Active Button Toolbox
(page 310).
Enables the insertion of a signature in the form
and displays the Signature toolbox. Refer to the
Active Button Toolbox (page 310).
Displays the Tag Selection dialog. For more
information, refer to Insert Tag Reference
(page 310).
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Select Toolbox
The Select toolbox provides options for selecting and copying objects and drawing
perpendicular lines.

Button

Purpose
Indicates the Select toolbox is open.
Copies the selected object in the Design Area.
Indicates the number of copies to be made.
Enables the horizontal movement of the copied
object.
Enables the vertical movement of the copied
object.
Enables unrestricted movement of the copied
object.
Creates single or multiple copies of the selected
object in the Design Area with a defined
horizontal offset from the selected object.
Specify a value by clicking on the up or down
arrows or by clicking in the numeric display box
and enter a number.
Creates single or multiple copies of the selected
object in the Design Area with a defined vertical
offset from the selected object. Specify a value
by clicking on the up or down arrows or by
clicking in the numeric display box and enter a
number.
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Button

Purpose
Automatically resizes lines when moving a
connecting perpendicular line. For example, you
can move the bottom horizontal line in a table,
and all perpendicular lines ending at the bottom
line will automatically resize.
Displays options to join the text objects in the
Design Area. You can select from the following
options:


Join By Spaces



Join By Justify



Join By Relative

Line Toolbox
The Line toolbox provides options for drawing horizontal, vertical, and free direction
lines.

Button

Purpose
Indicates the Line toolbox is open.
Draws a horizontal line only.
Draws a vertical line only.
Draws horizontal or vertical lines only.
Draws a line in any direction.
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Box Toolbox
The Box toolbox provides options for drawing boxes and specifying box properties.

Button

Purpose
Indicates the Box toolbox is open.
Limits the box shape to a square.
Draws the box within the confines of an invisible
boundary.
Sets the horizontal split line thickness and style
for a box.
Sets the vertical split line thickness and style for
a box.
Indicates the number of box shape horizontal
and/or vertical splits (activated only when Style
for Horizontal Splits or Style for Vertical
Splits is selected).
Displays the predefined line thickness values.
Sets the custom border line thickness, and box
shape horizontal or vertical splits value
(activated only when the Line Thickness
Custom option is activated).
Displays the predefined line styles for drawing
lines.
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Text Attributes Toolbox
The Text Attributes toolbox provides options for the specification of text object
preferences.

Button

Purpose
Indicates the Text Attributes toolbox is open.
Displays the Font List dialog for selecting,
adding, deleting, or editing the font list items.
Adds the font selected from the drop-down list to
the text.
Underlines the text.
Draws a line through the text.
Sets the text horizontal justification to the left.
Sets the text horizontal justification to the center.
Sets the text horizontal justification to the right.
Sets the text horizontal justification to both the
right and the left.
Sets the text vertical justification to the linebase.
Sets the text vertical justification to the top.
Sets the text vertical justification to the center.
Sets the text vertical justification to the bottom.
Sets the inter-word spacing.
Sets the inter-character spacing.
Sets the text block word continuation to the next
line.
Removes the extra spaces from the selected text
string.
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Button

Purpose
Turns the LPI (Lines Per Inch) setting on and off.
Displays the specified LPI setting.
Displays the direction options for the text flow.
Displays the Soft Keyboard dialog for adding
alphabets and special characters.

Image Toolbox
The Image toolbox provides options for adding Elixir format screen or printer images,
bitmaps, and logos to a form.

Button

Purpose
Indicates the Image toolbox is open.
Indicates the filename of the loaded image.
Displays the Open dialog for loading the
external image.

Barcode Toolbox
The Barcode toolbox provides options for adding barcodes to a form and specifying
barcode properties.

Button

Purpose
Indicates the Barcode toolbox is open.
Displays the available barcode types for
selection.
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Button

Purpose
Hides the barcode information.
Displays the HRI (Human Readable
Interpretation) above the barcode.
Displays the HRI (Human Readable
Interpretation) below the barcode.
Displays the HRI (Human Readable
Interpretation) type 1.
Displays the HRI (Human Readable
Interpretation) type 2.

Active Button Toolbox
The Active Button toolbox provides options for adding active buttons to a form and
specifying the active button properties.

Button

Purpose
Indicates the Active Button toolbox is open.
Draws a border around the active button.
Displays the selected border color.

The active checkbox, active combobox, active editbox, active radio button, and
signature toolbars all display the same toolbar commands as the active
button.

Insert Tag Reference
opens the Tag Selection dialog for viewing tags and associated properties. For more
information on the Tag Selection dialog, refer to Chapter 11: “Data Tagging” on page
239.
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Keyboard Shortcuts
You can use the shortcut keys (also called the accelerator keys or the fast keys) for quick
access to frequently used commands or operations. The following sections describe the
shortcut keys generally used in Form Editor:


Text Editing Keyboard Shortcuts (page 311)



Numeric Display Box Keyboard Shortcuts (page 312)



Zoom/Pan Control Keyboard Shortcuts (page 312)

Text Editing Keyboard Shortcuts
The following table outlines the available keyboard shortcuts for form text editing
operations:

Command

Keyboard Shortcut

Copies the selected text.

Ctrl + C

Cuts the selected text.

Ctrl + X

Deletes the left character.

Backspace

Deletes the right character.

Delete

Deletes the next word.

Ctrl + Delete

Deletes the previous word.

Ctrl + Bksp

Deletes to the end of the line.

Ctrl + K

Find

Ctrl + F

Find Next

F3

Find Previous

Shift + F3

Replace

Ctrl + H

Moves the cursor down one
line.

È

Moves the cursor to the left by
one character.

Å

Moves the cursor to the right by
one character.

Æ

Moves the cursor up one line.

Ç

Moves the cursor to the left by
one word.

Ctrl + Å
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Command

Keyboard Shortcut

Moves the cursor to the right by
one word.

Ctrl + Æ

Moves the cursor to the end of
the line.

End

Moves the cursor to the start of
the line.

Home

Moves the cursor to the end of
the text block.

Ctrl + End

Moves the cursor to the start of
the text block.

Ctrl + Home

Pastes the previously copied
text onto the selected area in the
Design Area.

Ctrl + V

Numeric Display Box Keyboard Shortcuts
The following fast keys can be used to edit numbers within numeric display boxes (such
as tool width option). Numbers are entered right to left, as on a calculator.

Command

Keyboard

Changes the decimal value.

Click on arrows (where
provided)

Changes the integer value.

Ctrl + Click on arrows

Deletes the number (set to 0).

Delete

Deletes the right digit.

Backspace

Finishes editing.

Enter

Zoom/Pan Control Keyboard Shortcuts
The following fast keys can be used to access the Zoom and Pan Control commands:
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Command

Keyboard Shortcut

Pans left.

Å

Pans up.

Ç

Pans right.

Æ

Pans down.

È
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Command

Keyboard Shortcut

Zooms in.

Numpad +

Zooms out.

Numpad -

Moves the cursor to the top left
side of the form.

Home

Moves the cursor to the top
right side of the form.

End

Moves the cursor to the top
right side of the form.

Ctrl + Page Up

Moves the cursor to the bottom
right side of the form.

Ctrl + Page Down

Scrolls up.

Page Up

Scrolls down.

Page Down

With Num Lock off, you can also use the numeric keypad functions as the Zoom/Pan
Control fast keys.
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Appendix B:

Sample Forms
This guide has provided you with both background and procedural information for using
Form Editor.
Form Editor lets you create: Bank statements, utility bills, marketing brochures, insurance
policies and more. You can create and edit the forms, fonts and images you need to meet
your business requirements. The interface allows a drag-n-drop approach to form designs
reducing design time and improving productivity. The Form Editor provides a visual
interface for creating and editing complex forms that can be saved in the appropriate
format for printing or viewing. Tables can easily be constructed, drawing objects can be
added, grouped and copied to improve design efficiency.
Existing resources can be opened in their native format and edited. Resources can be
saved in the required production print format and placed on the printer. No coding is
required.
Special characters can be added and character widths can be changed. Graphics, such as
company logos and scanned images of signatures can be added to forms.
In this appendix, two examples have been provided to showcase Form Editors capabilities:


Sample 1: Water Bill (page 316)



Sample 2: Promotional Letter (page 318)
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Sample 1: Water Bill
The following form has been created for a water company. A complete and thorough
design has been given using a predefined template. The static data is added to the form in
Form Editor. The variable data using a data file can be supplied later to the form for
printing.
In this example, the static data fields include the customer name, address and billing
information. The billing information includes descriptions of water usage charges,
previous record, consumption details, total amount and due date. In addition a payment
coupon is also included, which the customer has to detach along the perforated line and
send to the company. This data is not available in the data set, it has to be entered into
Form Editor. The static information also includes the company logo, address and a
promotional message.
Variable data will include the individual customer’s name, address and billing information
that will be placed later on for printing. The variable data is available in the data file.
To create this form, the following tasks were performed:
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1

Create and use company specific profile.
You can customize Form Editor to meet the requirements of your specific working
environment by creating and maintaining unique user profiles. For details, refer to
“About User Profiles” on page 89 in Chapter 4: Resources and Formats.

2

Specify the settings at either the application or page level.
Form Editor enables you to customize your work environment to meet your business
needs by controlling the operation and appearance of the application at the
application and the page level. You can also define how Form Editor reads the
resources added to a form. Refer to Chapter 4: “Resources and Formats” on page 73.

3

Setup application and/or document format settings.
These settings determine how Form Editor reads the resources added to a form.
Refer to “Managing Resource Objects” on page 84 for details in Chapter 4:
Resources and Formats.

4

Add a form template.
Template acts a a visual guide for placing the static data. You can use the template to
assist in accurate placement of objects. For more information, refer to “Form
Templates” on page 71 in Chapter 3: Form Basics.

5

Insert the company logo as an image.
Refer to “Adding an Image” on page 111 in Chapter 5: Drawing Tools.
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6

Add text objects.
You can insert text and set or change text properties. Form Editor also enables you to
edit, import, join, split, search, replace text and change the text color. For details,
refer to Chapter 7: “Using Text” on page 145.

7

Import text.
Many long passages of text intended for form originate in a text editor, such as
Microsoft Word. Instead of entering the text again in the Form Editor, you can
import the text from any file saved in RTF or TXT format. Refer to “Importing Text”
on page 154 in Chapter 7: Using Text.

8

Add fonts to the form.
Form Editor lets you add, edit, and delete different font types and set or change font
properties. You can also add special characters to a form. In addition, you can also
create a font list. A font list groups the fonts used in a form. You can reuse this list in
other forms. Refer to Chapter 7: “Using Text” on page 145.

9

Add lines and boxes.
You can add rectangle and rounded box objects. The box and line tools can be used
to create tables supporting the form requirements. Refer to Chapter 5: “Drawing
Tools” on page 103.

10 Create multiple copies of text and box objects.
Making multiple copies of objects and reusing them reduces time. Refer to “Creating
Multiple Copies of Objects” on page 267 in Chapter 12: Creating Multiple Copies of
Objects.

11 Add shades and patterns to the objects.
Shades and patterns can be applied to visually enhance the object. For details, refer
to Chapter 6: “Colors and Patterns” on page 131.

12 Place the objects in the Design Area using toolbar and the available guide and grid
options.
These options enable you to view and edit start and end coordinates and dimensions
of objects in the Design Area. Refer to following in tasks in Chapter 2: The Form
Editor Environment:
 Ruler (page 40)
 Grid (page 44)
 Guides (page 47)
 Crosshair (page 52)
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13 Save the form in the required format.
Refer to “Saving a Form” on page 64 in Chapter 3: Form Basics.
The image below provides a brief summary of the main tasks involved in creating the
design of the form:
(

)

g

Add images
using

Add text

.

using
Position objects
using the options
available in the
Position and
Dimension
toolbar.

.

Create tables
using
and

Add shading and

.

color using
and

.

Create multiple copies of boxes
and lines using

.

Sample 2: Promotional Letter
The following form has been created for a bank. A complete design of the letter has been
given.
In this example, the bank has to mail a promotional letter to the customers, detailing their
loan services. The letter has been written in Word format. A table listing their services has
to be created and the heading row requires a color that needs to be added to the default
palette. In addition, the bank logo and manager’s signature (scanned image) have to be
incorporated in the form.
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To create this form, the following tasks were performed:

1

Specify the settings at either the application or page level.
Form Editor enables you to customize your work environment to meet your business
needs by controlling the operation and appearance of the application at the
application and the page level. Refer to “Application Format Settings” on page 93
for details in Chapter 4: Resources and Formats.

2

Use PrintDriver to convert the Word document into the required format.
PrintDriver significantly reduces the time required to create overlays by allowing
you to create the form directly in a source application. It is an interactive tool that
uses the Windows Print function to create Elixir or target printer formats documents
and forms. PrintDriver creates documents using tools you are familiar with, such as
MS Word, and then prints them to Elixir forms. For details, refer to Chapter 9:
“Using Elixir PrintDriver Pro” on page 201.

3

Insert the company logo and the manager’s signature as images.
Refer to “Adding an Image” on page 111 in Chapter 5: Drawing Tools.

4

Add text objects.
You can insert text and set or change text properties. Form Editor also lets you edit,
import, join, split, search, replace text and change the text color. Many long passages
of text intended for form originate in a text editor, such as Microsoft Word. Instead
of entering the text again in the Form Editor, you can import the text from any file
saved in RTF or TXT format. For more information, refer to Chapter 7: “Using
Text” on page 145.

5

Add fonts to the form.
Refer to “Adding Special Characters Using the Soft Keyboard” on page 168 in
Chapter 7: Using Text.

6

Add lines and boxes.
You can add rectangle and rounded box objects. The box and line tools can be used
to create tables supporting the form requirements. For more information, refer to
Chapter 5: “Drawing Tools” on page 103.

7

Create multiple copies of text and box objects.
Making multiple copies of objects and reusing them reduces time. Refer to “Creating
Multiple Copies of Objects” on page 267 in Chapter 12: Creating Multiple Copies of
Objects.
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8

Place the objects in the Design Area using the toolbar and the available guide and
grid options.
These options enable you to view and edit start and end coordinates and dimensions
of objects in the Design Area. Refer to following in tasks Chapter 2: The Form
Editor Environment:
 Ruler (page 40)
 Grid (page 44)
 Guides (page 47)
 Crosshair (page 52)

9

Save the form in the required format.
Refer to “Saving a Form” on page 64 in Chapter 3: Form Basics.
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The image below provides a brief summary of the main tasks involved in creating the
design of the form:
Convert the Word format document to
Elixir (EFR) format using PrintDriver.
Add additional text
using

.

Create the
table using
and

Position objects
using the options
available in the
Position and
Dimension toolbar.

Create multiple
copies of text
and lines
using

Add the company logo
and signature using
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.

.

Save the form to the required
.

format using

.
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Appendix C:

Glossary
Following is an alphabetical listing of product-specific or unique terms and abbreviations
used in this guide.
BCOCA (Bar Code Content Architecture)
Composition of industry-standard bar codes, including draw rule commands and raster
data.
Bold
A darker version of a font or character formed using heavier strokes.
Boxed text
Form text bounded by a column of set height and width.
Cloned profile
Profile that is an exact replica of its parent profile. See also Profile.
Color Model
The method by which a color is specified. For example, the RGB color space specifies
color in terms of three intensities for red (R), green (G), and blue (B).
Common Attributes toolbar
This toolbar is used for setting common object properties, such as color, line style, and
thickness.
DBCS (Double-Byte Character Set)
Character set containing a maximum of 65536 characters.
Default profile
Profile that uses all system defined profile items to create a new profile. See also Profile.
Derived profile
Profile that inherits the missing profile item values from its parent profile. See also
Profile.
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Documents folder
A directory containing the fully composed multi-page documents for Xerox Form Objects
(FRM), Elixir (GDF), Enhanced Metafile (EMF), Print Control Language (PCL;PRN),
Portable Document Format (PDF), and PostScript formats.
ECS
Elixir Converter Settings File. Used to store all settings for a conversion session. These
settings include input and output options, pointers to input and output files, EPM files, and
file processing options.
EPM
An Elixir Parameter File that stores individual input and output property settings to
facilitate conversion.
ERC
Elixir Resource Container. Stores Elixir Resource Library.
Fast keys
See Keyboard shortcut.
FNT
Xerox LPS printer font format.
Font
Complete set of print characters of the same family, size, typeface, and orientation.
Fonts folder
A directory containing Xerox fonts (FNT), Elixir Legacy Coded Font (X0* .CDF;
X1*.CDF; X2*.CDF; X3*.CDF; X4*.CDF), and Windows font files.
Form
Single-page document used for background reproduction on each page of other
documents.
Form objects
The individual lines, shapes, images, and text that create a form. You can create, change,
move, copy, delete, import, or load a form object.
Form template
Form loaded as a visual guide for designing a new form. When the new form is saved, the
form template is not included.
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Forms folder
A directory containing Xerox Form Object (FRM), Xerox Form Source (FSL), Elixir,
Elixir Metafile, Print Control Language, Portable Document Format, and PostScript form
files.
Free text
Text on a form that is not bound by a column with a set height and width. The width of the
form is the only restriction.
FRM
Xerox LPS printer form format.
FSL
Forms source library. Uncompiled user-created forms containing FDL commands.
GOCA (Graphics Object Content Architecture)
Structure for describing a complex picture (such as bar chart or pie chart) using graphic
commands.
Graphics folder
A directory containing Xerox IMG and LGO (IMG, LGO) and Elixir Legacy Graphic files
(LP3).
Grid
Horizontal and vertical lines of pixels used for precise object placement.
Guidelines
Horizontal and/or vertical lines in the Design Area used to align objects.
Halftoning
Applying line or shading patterns to make images or characters appear either gray or
textured.
HDR
Font Header storing Elixir Legacy font.
Highlight Color
This refers to the third color used on a Xerox form (other than black and white) and can be
selected from either the Color Catalog or the Color Selector dialog.
Hot key
See Keyboard shortcut.
Image
Resolution-dependent migration image object that cannot be compressed or scaled.
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IMG
Xerox LPS printer image format.
Importing files
The process of copying non-Elixir format files from different storage media to the
appropriate Desktop input folder or to the Work area.
Inverse Landscape
The orientation of fonts, logos, or images on a page. See the definition for portrait for a
figure describing the orientation of fonts on pages.
Inverse Portrait
The orientation of fonts, logos, or images on a page. See the definition for portrait for a
figure describing the orientation of fonts on pages.
IOCA (Image Object Content Architecture)
Non-resolution dependent data structure in which image objects can be scaled and
compressed.
Jobs folder
A directory containing Xerox Form Object (FRM), Xerox Form Source (FSL), Elixir
FormDef (EFD) and Elixir PageDef (EPD) job folders.
Keyboard shortcut
A Special key or key combination for executing operation without using the mouse; also
called hot key(s).
Landscape
The orientation of a page or the fonts, logos, or images on a page. A landscape page is
narrower on the sides than on the top. See the definition of portrait for a figure describing
the orientation of fonts on pages.
LCDS
Line Conditioned Datastream. A print image data format used by Xerox printers.
LCDS Color Spectrum
This is a new Xerox feature that provides full color support.
LGO
File type of a Xerox logo file. Small illustration or design, usually simple, typically used
to identify a company.
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Line spacing
Distance between succeeding lines of text when printed on a page. In other words, the line
spacing is the distance from the top of the characters on one line to the top of the
characters on the next line.
LP3
File type storing Elixir Legacy Graphic.
Messages window
A window displaying informational, error and warning messages.
Metacode
The standard page description language for Xerox LPS printers. Used by a Xerox printer
to control imaging system’s internal functions and provide all-points-addressability.
Functions include character positioning and font and print orientation selection.
Page
Logical representation of a data page.
Paper
Physical attributes of a logical page, such as size, orientation, positioning, and
partitioning.
PCL
Printer Control Language. PCL fonts are binary files that are stored on your computer’s
hard drive.
Portrait
The orientation of a page, or the fonts, logos, or images on a page. A portrait page is
narrower on the top than on the side (like pages in this book).
Profile
A system file that stores important file locations for Elixir applications.
SBCS
Single-byte character set. A character set whose codes require a single byte of data. The
character set used for English is an example.
Setup (EPM) file
A file that stores individual input and output property settings to facilitate conversion.
Snap to
Product function that causes form elements to automatically align with the nearest
displayed grid point.
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Spacing character
A blank or all white character that is used for positioning characters on a line. These
characters do the same thing as a space key on a typewriter.
Style
A modified version of a typeface. Examples of a style are Bold, Italic, etc.
Symbol
A key representing application objects with associated paths and types.
TIFF
Tagged Image Format File. High-quality graphics format that supports color depths from 1
to 24-bit; designed to be a standard image format for storing high-quality color images on
multiple computer platforms.
Tools toolbar
This toolbar enables the opening of other object-specific toolbars.
Underline
Placement of a line under text, usually for emphasis (also called underscore).
Utilities
Service programs designed to perform everyday tasks such as verifying the validity of a
product license.
Virtual folder
Abstract representation of the physical file folder structure underlying DesignPro Tools.
Displayed as a tree structure in the DesignPro Manager, virtual folders are organized by
resource type, then resource format. At the lowest level of each branch, one or more
folders are listed, each representing a physical location on a mapped folder.
Zoom
Product feature used to enlarge a selected portion of a graphical image or document to fill
a window or the screen.
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Index
Numerics
3-color highlighting 134

A
about
active objects 217
tag references 241
this guide 15
accessing
resources 74
active button
image 225
properties 225
URL 226
active checkbox
properties 227
active combobox
properties 228
setting value 229
active editbox
customize 232
format 230
properties 230
active objects
adding 219
background color 223
border 221
fonts 224
foreground color 223
name 221
text 224
viewing 219
working 218
Active Radio Button toolbox 304
adding
active object name 221
active objects 219
barcode text 113
border 221
border color 222

Index

colors to color palette 136
fonts to a font list 192
foreground color 223
form references, DAT files 254
HDR fonts 194
image 111
images to active button 225
multiple fonts 193
page comments 68
pattern 141
PCL fonts 194
script commands, DAT files 255
shades 142
special characters using the character map 168,

170
special characters using the soft keyboard 168
tag references 245
tag references, Insert toolbar 246
tag references, Tag Syntax 247
tags, MS Word 251
text 146, 224
toolbar buttons 39
URL, active button 226
Windows font 192
Xerox fonts 194
adjusting
box line width 108
Adobe Acrobat 201
AFP
document file formats 203
aligning
objects to grid 45
objects to guides 51
text.See text justifying
Apostal 121, 123
application
format commands 93
settings 93
ASCII 171
Asia Pacific customer support 21
ATM fonts 192
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Australian post symbology 121
Autosave 79

120
ratio 123
resolution 123
RM 4SCC 120
RM4SCC 123
text 113
types 114
UPC (2-digit supplemental) 116
UPC (5-digit supplemental) 116
UPC version A (Universal Product Code - A)

B
background color
active objects 223
Backup Files 79
BAK 79
Barcode toolbox 304, 309
barcodes
adding 112
Apostal 121, 123
asterisks 127
bar width 123
Codabar (2 of 7) 119
Code 128 119, 123
Code 39 (3 of 9) 114, 127
Data Matrix 122
dimensions 123
displaying human readable information (HRI)

126
EAN (2-digit supplemental) 117
EAN (5-digit supplemental) 118
EAN13 117
EAN8 (European Article Number) 117
error correction 128
error tolerance 128
font name 127
height 123
HRI position 127
HRI presentation 126
human readable information 125
image resolution 123
image width 123
Industrial 2 of 5 118
inserting 113
Interleaved 2 of 5 119
Japan 120, 123
Matrix 2 of 5 118
Maxi Code 122
modifier 123
modwidth 123
MSI (Modified Plessey Code) 115
PDF 417 (Portable data file 417) 121
PostNet 123
PostNet (Postal Numeric Encoding Technique)
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115
UPC version E (Universal Product Code - E)

116
BMP 75
Box tool 107
Box toolbox 307
boxes
drawing 107
line width 108
positioning border 109
splitting 109
square 108

C
CDF 195
changing
color of template objects 72
color palette 134
font list 197
font list order 189
measurement unit of ruler 41
objects style 274
ruler position 40
ruler zero position 42
tag definitions 244
windows font properties 198
character
mapping 170, 172
setting mapping options 170
Character Map dialog 170
Check Spelling dialog 294, 298
Chinese text
setting properties 182
word wrapping 182
choosing commands 55
CIELAB 137
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CJK
Chinese text 173
Japanese text 173
Korean text 173
support 173
clearing
EPM files 100
messages in the Message window 29
closing
Messages window 29
CMYK 137
Codabar (2 of 7) 119
Code 128 119, 123
Code 2 of 5 118
Code 2 of 5 Interleaved 119
Code 25 Industrial 118
Code 25 Interleaved 119
Code 39 (3 of 9) 114, 127
Coderbar (NW-7) 119
color
about 131
catalog 133
default palette 135
deleting 139
editing 138
model 136
palette 134, 136
spectrum 136
user specified palette 135
color coding messages 32
color palette
adding color 136
opening 135
saving 139
Color Selector dialog 136, 138
coloring
objects 132
commands
repeating 278
undoing 278
Common Attributes toolbar 106, 108, 300
common properties
active objects 220
conventions
symbolic 19
typographic 18

Index

conversions, starting 259
converters
properties 97
converting
DAT files, Normalized Metacode 259
fonts 80
forms 80
images 80
print jobs 206
copying
messages 30
objects 266, 267
resources 76
tag definitions 245
creating
backups 79
custom profiles 90
DAT files 253
forms 60
PDF 235
profiles 316
tag definitions 242
toolbars 38
user profiles 90
crosshair
about 52
displaying/hiding 52
customer support
Asia Pacific 21
Europe 21
North America 20
South America 20
Customize Columns dialog 190
Customize dialog 38
customizing
font list, columns 189
guides 47
pages 66
zoom value 54
cutting
objects 270

D
DAT 28, 253, 257
DAT files
adding form references 254
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converting, Normalized Metacode 259
creating 253
exporting 257
importing 257
input properties, setting 260
Manager, locating 259
output properties, setting 260
script commands, adding 255
setting parser properties 258
understanding 253
working 256
Dat Input Parser Properties dialog 258, 260
Data Matrix
barcode type 122
elementary module height 124
elementary module width 124
error correction code 128
Size of Barcode 124
data tags
active objects 239
understanding 239
DBCS 173
default
font lists 188
deleting
color 139
fonts 197
form references 256
objects 270
script commands 256
tag definitions 245
Design Area 23
DesignPro Form Editor
tagging 240
dialogs
Browse for Folder 92
Character Map 170
Check Spelling 294, 298
Color Picker 132, 135, 139
Color Selector 136, 138
Customize 38
Customize Columns 190
Dat Input Parser Properties 258, 260
Elixir 77
Export To 200
Find 159, 292
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Font 192
Font List 148, 189, 190, 192, 195, 308
Form Template 302
Format Editor 231
Import Text 291
Merge 70, 290
Metacode 260
Open 250, 251, 252, 290, 309
Open Profile Configuration File 91
Open Resource File 111, 112, 195, 225, 254
Options 30, 50, 91, 170, 171, 172, 248,

281, 291, 293, 295, 316, 319
Pattern Selector 141
PDF 236
Print 253, 286, 291
Print Setup 291
PrintDriver Wizard 253
PrintDriver Wizard File Format and Setup 206
Profile Selection 295
Properties 220, 221, 222, 223, 224, 225,

226, 227, 229, 232, 234, 242, 263,
272, 274, 276
Properties - Barcode 113, 114, 128
Properties - Box 109
Properties - Image 112
Properties - Line 105
Properties - Text 150, 152, 161, 163, 166,
247
Register New Profile 90
Replace 159, 292
Save as 236, 257, 290
Select Objects 227, 231, 235
Soft Keyboard 168, 309
Tag Selection 246, 249, 304, 310
Template Form 72, 290
Text Import 154
Windows 296
Xerox LPS Resource Writer 86
digital ruler 42
dimensions
barcode 123
directory structure
Elixir 76
displaying
crosshair 52
grid 44
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message time in Messages window 32
ruler 40
DOC
character sets 170
document file formats
EDF 202
ELX 202
MET 203
PCL 203
PDF 203
PS 203
TIF 203
document level preferences 41
documents
format commands 94
format settings 94
print file types 202
drawing
box 107
freeform line 104
horizontal lines 104
horizontal or vertical lines 104
line 104
square 108
vertical lines 104

E
EAN
(2-digit supplemental) 117
(5-digit supplemental) 118
13 117
8 (European Article Number) 117
EDF 202
editing
color 138
font list 197
options 279
resource properties 84
spell checking 279
text 147
windows font properties 198

Index

EFR 59, 70, 71, 74, 202
Elixir
dialog 77
directory structure 76
document file formats 202
form 62, 95
Generic Document Format 95
Legacy Coded Font files 195
Legacy Forms 194
palette 134
parameter files 93, 99
PrintDriver Pro 95
Profile Editor 90
Resource Library 80
training 21
web site support 21
Elixir PrintDriver Pro
overview 201
supported applications 201
using Tag references 251
wizard, using 203
ElixirPDW 95
ElixiTag toolbar 241, 251
ELX 59, 70, 71, 74
embedding
resources 88
EMF 59, 70, 71, 95
Enhanced Window Metafile 95
entering
Chinese text 175, 176
Japanese text 175, 179
Korean text 175, 181
EP 59, 70, 71
EPM 93, 94, 99
error correction
code 128
level 128
specifying settings 128
error tolerance settings 128
Europe customer support 21
Export To dialog 200

333

exporting
DAT files 257
font lists 200
palette list 140
resources 86
shade list 143
tag definition list 251
extensions
BAK 79
BMP 75
CDF 195
creating new 98
DAT 28, 253, 257
EFR 59, 70, 71, 74
ELX 59, 70, 71, 74
EMF 59, 70, 71
EP 59, 70, 71
EPM 93, 94, 99
ERC 134
FLJ 75, 195
FNT 75, 195
FRM 59, 70, 71, 74, 95
FSL 59, 70, 71, 74, 95
GDF 95
HDR 75
IMG 59, 75
INI 90
JPEG 75
JPG 75
KMP 170
LGO 75
LP3 59, 75
LST 188, 199
PCL 59, 75, 95, 194, 195
PCX 75
PDF 59, 60, 74, 95, 185, 218, 235, 239
PLF 134
PNG 75
PS 74, 185
RTF 154, 173
SEG 59
TAG 250, 252
TIF 59, 75
TXT 154, 173
VIP 74
VIPP 95
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XML 134, 135, 188, 199

F
files
EPM 99
filtering 79
format properties 95
formats 59, 93
registering new extensions 98
selectors 79
Filter toolbar 277, 301
filtering
files 79
objects 277
Find dialog 159, 292
finding
text 159
FLJ 75, 195
FNT 75, 195
Font dialog 192
Font List dialog 148, 189, 190, 192, 195, 308
font lists
exporting 200
importing 199
order 189
specifying default 188
fonts
active objects 224
adding to font list 192
ATM Type 1 75
ATM Type 3 75
changing properties 198
DBCS 191
deleting 197
HDR 194
list 197
PCL 194, 195
properties 189, 191
replacing 197
SBCS 191
script 193
setting properties 148
size 193
style 193
Windows 192
Xerox 194, 195
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foreground color
active objects 223
Form Editor
opening 23
overview 13
toolbars 297
form formats
Elixir 202
ElixirDoc 202
Image 202
PCL 202
PDF 202
PostScript 202
form groups
about 70
merging 70
saving 71
form references
adding, DAT files 254
deleting, DAT files 256
reordering, DAT files 256
Form Template dialog 302
Form Template toolbar 302
form templates
about 71
changing color of template objects 72
loading 72
removing 72
Format Editor dialog 231
formats
ATM Type 1 75
ATM Type3 75
Bitmap Files (BMP) 75
Elixir Form (EFR) 74
Elixir Legacy Font (HDR) 75
Elixir Legacy Form (ELX) 74
Elixir Legacy Graphic (LP3) 75
files 93
images 95
Joint Photography Experts Group File (JPEG,
JPG) 75

Index

PC Paintbrush Bitmap File (PCX) 75
PCL Font (PCL, FLJ) 75
Portable Network Graphics File (PNG) 75
properties 95
Tagged Image Format File (TIF) 75
True Type Font 75
Xerox Font (FNT) 75
Xerox Form Object (FRM) 74
Xerox Form Source (FSL) 74
Xerox IMG (IMG) 75
Xerox LGO (LGO) 75
forms
creating 60
design tools 35, 103, 303
Full Color 133
Highlight 133
modifying 263
opening DAT files 256
operations 60
previewing 286
print file types 202
saving 64
saving to PDF 236
freeform
line 104
FRM 59, 70, 71, 74, 95
FSL 59, 70, 71, 74, 95
full color forms 133

G
GB18030 176
GB2312 176
GBK 176
GDF 95
Generic Image Format 95
getting the answers you need 20
graphic ruler 42
grid
about 44
aligning objects 45
displaying/hiding 44
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spacing 46
guides
about 47
aligning objects 51
moving 48
removing 50
turning on/off 48

H
HDR 75, 194
help
customer support 20
product 22
release notes 22
web site support 21
Help menu 20
hiding
font list property columns 190
grid 44
ruler 40
highlighting
forms 133
horizontal
line 104
split lines 109
splitting 109
HRI
displaying 126
presentation 126
row placement 126
using asterisks 127
HSB 137
human readable information 125

I
IBM 111
image
inserting 111
replacing 112
Image toolbar 304, 309
images
adding, URL 226
formats 95
IMG 59, 75
Import Text dialog 291
importing
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Chinese files 173
DAT files 257
font lists 199
fonts 199
Japanese files 173
Korean files 173
palette list 140
resources 82
shade list 143
tag definition list 250
text 154
text options 153
Industrial 2 of 5 118
INI 90
input
format properties 95
parsers 97
inserting
barcode 113
barcode text 113
Chinese text 173
image 111
Japanese text 173
Korean text 173
tag references 310
text 146
inter-character spacing 166
Interleaved 2 of 5 119
inter-word spacing 166

J
Japan 120, 123
Japanese text
setting properties 182
word wrapping 182
joining
text 155
text by justify option 157
text by relative position option 157
text by spaces option 156
JPEG 75
JPG 75

K
Key
about 92
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keyboard shortcuts
numeric display box 312
text editing 311
zoom/pan control 312
KMP 170
Korean text
setting properties 182
word wrapping 182

L
LGO 75
library root 81
limitations
tagging 240
Line tool 103
Line toolbox 104, 303, 306
lines
drawing 104
end style 106
flat 106
freeform 104
horizontal 104
rounded style 106
setting length 106
squared style 106
start style 106
style 106
thickness 105
vertical 104
width 108
loading
form templates 72
locking
signature object 234
logging
messages in the Messages window 30
LP3 59, 75
LST 188, 199

M
maintaining

Index

profiles 316
Manage window 25, 107, 112, 200, 292
Manager
locating DAT file 259
managing
creating tag definitions 242
DAT File tab 28
Object Type View tab 26, 104, 219, 240,

270
Radio Button tab 270
Radio Buttons tab 27, 240
Resource Manager tab 26, 84
Tag Structure tab 25, 240, 242
mapping
characters copied from an external file 172
characters from an imported file 171
characters using the keyboard 170
Matrix 2 of 5 118
Maxi Code
Height dm. 128
height of code 124
hexagon tolerance 128
mode 125
Width dm. 128
width of code 124
menus
Help 20
Merge dialog 70, 290
merging
form groups 70
messages
clearing messages 29
color coding 32
copying 30
displaying message time 32
logging 30
Messages window 29, 85, 292, 293
Metacode dialog 260
Microsoft
Excel 201
Notepad 201
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Word 201
WordPad 201
modifier 123
modifying
forms 263
modwidth 123
moving
guides 48
objects 53, 271
tag definitions 244
MSI (Modified Plessey Code) 115

format properties 96
PDF settings 236
overview
Elixir PrintDriver Pro 201
Form Editor 13

P

N
Normalized Metacode
DAT files, converting 259
North America customer support 20

O
Object Type View 107
objects
changing style 274
copying 266, 267
cutting 270
deleting 270
filtering 277
moving 53, 271
pasting 269
rotating 273
selecting 264
skewing 275
Open dialog 250, 251, 252, 290, 309
Open Profile Configuration File dialog 91
Open Resource File dialog 111, 112, 195, 225,

254
opening
color palette 135
DAT files 256
Elixir form 62
EPM file 101
Form Editor 23
forms with external formats 62
Options dialog 30, 50, 170, 171, 172, 248, 281,

291, 293, 295, 316, 319
output
converts 97
data converters 97
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pages
adding comments 68
dimensions 66
offsets 69
orientation 67
palette list 140
palettes 80
parsers
properties 97
pasting
Chinese text 175
Japanese text 175
Korean text 175
objects 269
pattern selector 141
PCL 59, 75, 95, 194, 195
PCL Font 75
PCX 75
PDF 59, 74, 95, 185, 218, 235, 239
PDF 417
aspect ratio X 124
aspect ratio Y 124
columns 124
delta width 124
error correction level 128
module height 124
percentage EC (error correction) 128
Portable data file 417 121
rows 124
symbol 124, 128
Truncate PDF 124
width of X bar module 124
width of X space module 124
PDF dialog 236
PDW 95
Percentage EC (Error Correction) 128
Plessey Code 115
PLF 134
PNG 75
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Portable Document Format 95
Position and Dimension toolbar 271, 272, 273,

275, 300
positioning
box border 109
text 147
PostNet
modifier 123
PostNet (Postal Numeric Encoding Technique) 120
PostScript 95, 202
prefixes
X0* 195
X1* 195
X2* 195
X3* 195
X4* 195
previewing
forms 286
Print dialog 253, 286, 291
print file types
documents 202
forms 202
print jobs
converting 206
setting 206
Print Setup dialog 291
PrintDriver Pro
Adobe Acrobat 201
supported applications 201
PrintDriver Wizard dialog 253
PrintDriver Wizard File Format and Setup dialog

206, 210
Profile Selection dialog 295
profiles
about 89
creating 316
custom 90
maintaining 316
user 90
viewing 90
Properties - Barcode dialog 113, 114, 128

Index

Properties - Box dialog 109
Properties - Image dialog 112
Properties - Line dialog 105
Properties - Text dialog 150, 152, 161, 163, 166,

247
Properties dialog 220, 221, 222, 223, 224, 225,

226, 227, 229, 232, 234, 242, 263, 272,
274, 276
PS 60, 74, 185

R
Raster Font Metric Technology settings 191
recovering data
creating backups 79
reformatting
text 158
refreshing
reloading resources 85
resources 85
Register New Profile dialog 90
registering new file extensions 98
related guides 17
release notes 22
reloading
resources 85
removing
form templates 72
guides 50
redundant spaces 168
reordering
form references 256
script commands 256
tag definitions 244
repeating commands 278
Replace dialog 159, 292
replacing
fonts 197
image 112
text 159
resolution 123
resources
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copying 76
embedding 88
exporting 86
gathering 74
importing 82
library 80
reloading 85
searching order 77
setting searching order 77
view properties 85
restoring
clearing EPM file 100
default file format settings 100
RGB 137
right-click menu 54
RM 4SCC 120, 123
rotating
objects 273
RTF 154, 173
ruler
about 40
changing position 40
changing unit of measurement 41
changing zero position 42
displaying/hiding 40
options 42
running
Normalized Metacode conversions 261

S
Save as dialog 236, 257, 290
saving
color palette 139
EPM file 100
form groups 71
forms 64
forms to Elixir format 64
forms using Chinese text 185
forms using Japanese text 185
forms using Korean text 185
forms, Elixir format 65
PDF 236
PDF output formats 185
PS output formats 185
script commands
adding, DAT files 255
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deleting, DAT files 256
reordering, DAT files 256
SEG 59
Select Objects dialog 227, 231, 235
Select toolbox 303, 305
selecting
barcode type 114
color catalog 133
color palette 134
font 224
objects 264
setting
active editbox format 230, 232
active object properties 220
application format properties 93
barcode dimensions 123
barcode human readable information 125
character mapping options 170
Chinese text properties 182
DAT parser properties 258
document format 94
editing options 279
file filtering options 79
filing options 79
font list order 189
font properties 148
grid spacing 46
Japanese text properties 182
Korean text properties 182
line spacing 167
output properties 260
page caching properties 78
page dimensions 66
page offsets 69
page orientation 67
paste options 265, 269
print jobs 206
ruler options 42
selection options 265, 269
spell checking 279
symbol properties 91
tag definition properties 242
tag references display options 248
tag references properties 248
text color 151
text direction 152
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text indent option 163
text justification 164
text properties 148
text spacing 166
text tabs 161
setting properties
input 260
shade lists 143
shades 142
signature
locking 234
properties 234
signature object
locking 234
skewing
objects 275
Snap to Grid 45
Soft Keyboard dialog 168, 309
South America customer support 20
spacing
inter-character 166
inter-word 166
special characters 168
spell checking
options 280
splitting
box 109
text 157
squares
lock 108
Standard toolbar 270, 298
starting conversions 259
Status bar 39, 292
striking out text 150
substitute shades with solid color 142
symbols
about 90, 91
system
code page 87

Index

T
tabs
DAT File 28
Object Type View 26
Radio Buttons 27
Resource Manager 26
Tag Structure 25
TAG 250, 252
tag definitions
copying 245
creating 242
deleting 245
exporting list 251
importing list 250
moving 244
reordering 244
setting properties 242
tag references
adding 245, 247
adding, Insert toolbar 246
adding,tag syntax 247
display options 248
Elixir PrintDriver, using 251
inserting 310
properties 248
Tag Selection dialog 246, 249, 304, 310
tagging
Form Editor 240
limitations 240
tags
MS Word, adding 251
Template Form dialog 72, 290
text
active object 224
adding 146
aligning.See text justifying
background color 151
barcode 113
bottom justification 165
center justification 165
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color 151
direction 152
editing 147
entering Chinese 175, 176
entering Japanese 175, 179
entering Korean 175, 181
finding 159
importing 154
importing options 153
indent 163
inserting 146
inserting Chinese 173
inserting Japanese 173
inserting Korean 173
joining 155
joining by justifying 157
joining by relative position 157
joining by spaces 156
justification option 164
justifying center 164
justifying full 164
justifying left 164
justifying right 164
layout 160
line spacing 167
linebase justification 165
operations 153
positioning 147
reformatting 158
replacing 159
setting properties 148
spacing 166
special characters 168
splitting 157
striking out 150
tabs option 161
top justification 165
underlining 149
word wrapping 164
Text Attributes toolbox 152, 164, 189, 192, 194,

197, 198, 308
Text Import dialog 154
thickness
line 105
TIF 59, 75
toolbars
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about 35
adding buttons 39
Common Attributes 36, 106, 108, 300
creating new 38
customizing display 37
ElixiTag 241, 251
Filter 277, 301
Form Editor 297
Form Template 37, 302
Position and Dimension 36, 271, 272, 273,

275, 300
Standard 35, 270, 298
Tools 146, 217, 219, 241, 246, 293, 303
Zoom 36, 299
toolboxes
about 34
Active Radio Button 304
Barcode 304, 309
Box 307
Image 304, 309
Line 104, 303, 306
Select 303, 305
Text Attributes 189, 192, 194, 197, 198,

308
tools
about 34
active checkbox 217
active combobox 217
active editbox 217
active radio button 218
barcode 112
box 107
color picker 132
form design 35, 303
line 103
menus 34
signature 218
toolbars 35
Tools toolbar 104, 146, 217, 219, 241, 246,

293, 303
training 21
True Type fonts 192
TXT 154, 173
typographic conventions 18
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U

W

underlining
text 149
understanding
DAT file 253
data tags 239
undoing commands 278
Unicode
character sets 170
mapping 171
UPC
(2-digit supplemental) 116
(5-digit supplemental) 116
version A (Universal Product Code - A) 115
version E (Universal Product Code - E) 116
user profiles
about 89
custom 90
default 90
using
Elixir PrintDriver Wizard 203
tag references, Elixir PrintDriver 251
UTF-16 173
UTF-8 173

web site support 21
Who Should Use this Guide? 17
windows
character sets 170
encoding 171, 172
Manage 25, 84, 107, 112, 200, 219, 240,

V
verifying
resources 85
vertical
line 104
split lines 109
splitting 109
viewing
active objects 219
font list property columns 190
font properties 189
full screen 54
profiles 90
VIP 74
VIPP forms 95

Index

270, 292
Messages 29, 85, 292, 293
Windows dialog 296
Windows fonts 192
WindowsEMF 95
word wrapping
about 182
dangling punctuation 184
using 164
wrap down 184
wrap up 184
workbook mode 61
working
DAT files 256
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