
DesignPro Tools

Visual PPFA
User Guide



2 DesignPro Visual PPFA User Guide

Elixir Technologies Corporation
721 East Main Street
Ventura, CA  93003

Copyright ©2006 by Elixir Technologies Corporation.
All rights reserved. 
DP200608V200

To report any errors you might find, please send a note to errata@elixir.com. Please note: emails 
are used to correct future versions of this guide and may not receive an individual reply. For 
technical support, please see "Customer Support" on page 18.

mailto:errata@elixir.com


Contents
Chapter 1: Introduction 11

Visual PPFA Overview........................................................................11
Understanding AFP format .................................................................12
Associated DesignPro Modules ...........................................................13
About this User Guide .........................................................................13

Who Should Use this Guide?..................................................................... 15
Related Guides........................................................................................... 15

Conventions .........................................................................................16
Typographic Conventions.......................................................................... 16
Symbolic Conventions............................................................................... 17

Getting the Answers You Need ...........................................................18
Customer Support ...................................................................................... 18
Elixir Web Site Support............................................................................. 19
Elixir Training ........................................................................................... 19
Product Help .............................................................................................. 19

Chapter 2: Visual PPFA Environment 21
Starting Visual PPFA...........................................................................21

Exiting Visual PPFA.........................................................................................22
What’s in the Workspace?......................................................................... 22
Understanding Workspace Windows ........................................................ 23

Design Area ......................................................................................................23
PageDef Tree ....................................................................................................25
FormDef Tree ...................................................................................................27
Template ..........................................................................................................27
Messages Window............................................................................................28

Using Workspace Tools............................................................................. 28
Menu Bar and Toolbars ....................................................................................29
Status Bar..........................................................................................................29
Grid...................................................................................................................29
Ruler .................................................................................................................29
Contents 1



Guidelines ........................................................................................................ 30
Crosshair .......................................................................................................... 30

Navigating the Workspace ........................................................................ 30
Choosing Commands................................................................................. 31
Undoing and Repeating Commands.......................................................... 32

Chapter 3: Customizing Visual PPFA 33
About User Profiles .............................................................................33

Selecting a User Profile.................................................................................... 34
Changing the Application Default Options ............................................... 35

Setting the Application Loading Defaults........................................................ 36
Applying the Display Settings ......................................................................... 37
Setting the Spell Checking Options ................................................................. 37
Setting the Filing Options ................................................................................ 38
Setting the Clipboard Options.......................................................................... 39
Setting the Record and Field Display Options................................................. 39
Setting the Border Colors and Line Styles....................................................... 40
Selecting the Paper and Printer Options .......................................................... 41
Setting the Sample Data Options ..................................................................... 42
Customizing the Sample Data Grid ................................................................. 43
Setting the Grid Options .................................................................................. 44
Setting the Guidelines Options ........................................................................ 46
Setting the Ruler Options................................................................................. 47
Setting the Symbols Properties ........................................................................ 48
Setting the Message Preferences...................................................................... 48
Logging the Messages...................................................................................... 49
Viewing the Parser and Converter Properties .................................................. 50
Registering the New File Extensions ............................................................... 51

Changing the Document Default Options ................................................. 52
Applying the Document Identification Settings............................................... 52
Setting the Document Guidelines .................................................................... 53
Setting the Document Ruler Options ............................................................... 53

Customizing the Toolbars and Menus....................................................... 55
Customizing the Toolbar Display .................................................................... 56
Creating a New Toolbar ................................................................................... 57
Adding Buttons to the Toolbars and Menus..................................................... 57
2 DesignPro Visual PPFA User Guide



Chapter 4: Preparing to Work 59
About IBM Print Services Facility ......................................................59
Preparing Resources ............................................................................61

Setting Elixir Resource Handling Properties............................................. 61
Setting up a Resource Searching Order............................................................63
Importing Resources to a Resource Library .....................................................64
Setting Page Caching Options ..........................................................................65

Gathering Resources.................................................................................. 65
Copying Resources to Appropriate Directory ..................................................66

Managing Resource Objects...................................................................... 67
Verifying Resources..........................................................................................68
Exporting Resources.........................................................................................68
Embedding Resources ......................................................................................69

Converting Form, Font, and Image Files to AFP Resources..................... 69
Elixir Resources versus AFP Resources...........................................................69

Changing File Formats.........................................................................70
Applying Application Format Settings...................................................... 70

Application Format Commands .......................................................................70
Applying Document Format Settings ........................................................ 70

Document Format Commands..........................................................................71
Specifying File Format Settings ................................................................ 71

Changing Input File Format Settings ...............................................................71
Changing Output File Format Settings.............................................................73

Elixir Parameter File (.EPM) .................................................................... 74
Loading File Format Settings   ........................................................................74
Clearing File Format Settings   ........................................................................74
Saving File Format Settings  ...........................................................................75

Chapter 5: Designing Physical Pages 77
Working with Form Definitions ..........................................................77

Creating a FormDef ................................................................................... 79
Setting the FormDef Properties ................................................................. 80

Setting a Unique FormDef Name .....................................................................81
Setting the Physical Page Offsets .....................................................................81
Setting the Duplex Printing Options.................................................................84
Designing Constant Forms ...............................................................................85
Placing Multiple Logical Pages on a Sheet ......................................................86
Selecting a Paper Source ..................................................................................87
Contents 3



Applying Finishing Operations........................................................................ 88
Setting Print Quality and Control Parameters.................................................. 91
Adding Comments ........................................................................................... 92

Chapter 6: Working with FormDef Lists and Objects 95
About FormDef Lists...........................................................................95

Working with a Suppression List .............................................................. 95
Adding a Suppression List ............................................................................... 96
Adding Suppressions to a Suppression List..................................................... 96

About FormDef Objects ......................................................................97
Working with CopyGroups ....................................................................... 98

Adding a CopyGroup ....................................................................................... 98
Setting CopyGroup Properties ......................................................................... 99

Working with SubGroups........................................................................ 101
Adding a SubGroup ....................................................................................... 102
Setting SubGroup Properties.......................................................................... 102
Specifying the SubGroup Presentation Options............................................. 103
Defining Suppressions for a Page .................................................................. 104

Working with Overlays ........................................................................... 105
Adding Overlays ............................................................................................ 105
Setting Overlay Properties ............................................................................. 106
Setting Overlay Display Properties................................................................ 106

About NUP ........................................................................................107
Selecting NUP Type ................................................................................ 108
Working with Basic NUP........................................................................ 108

Setting Basic NUP Properties ........................................................................ 108
Working with Enhanced NUP ................................................................. 110

Setting Enhanced NUP Properties ................................................................. 110
Viewing Full Preview.............................................................................. 114

Chapter 7: Designing Logical Pages 115
About Page Definitions .....................................................................115

Creating a PageDef.................................................................................. 117
Setting PageDef Properties...................................................................... 118

Setting PageDef Name................................................................................... 119
Setting up Page Numbers............................................................................... 119
Setting the Logical Page Margins .................................................................. 120
Specifying Print Configurations..................................................................... 121
4 DesignPro Visual PPFA User Guide



Setting the Logical Page Dimensions.............................................................122
Setting the Print Direction ..............................................................................123
Adding Comments..........................................................................................124

Chapter 8: Working with PageDef Lists  125
About PageDef Lists ..........................................................................125

Working with a Font List......................................................................... 125
Adding Fonts to a Font List ..................................................................... 129

Adding a Windows Font.................................................................................129
Adding an External Font ................................................................................131
Adding a Coded Font to the Font List ............................................................131
Adding a Font Pair..........................................................................................132
Replacing a Font.............................................................................................132
Changing the Properties of a Windows font...................................................133

Managing the Font List............................................................................ 133
Customizing Columns ............................................................................. 134
Working with a Color List....................................................................... 135

Adding a Color List ........................................................................................135
Adding Colors to a Color List ........................................................................136
Selecting OCA Color......................................................................................137
Selecting RGB, CMYK or CIELAB Color ....................................................137
Selecting Highlight Color...............................................................................139

Working with an Object List ................................................................... 139
Adding an Object List ....................................................................................140
Adding Objects to an Object List ...................................................................140
Adding a Secondary Object............................................................................142

Working with an Overlay List ................................................................. 143
Adding an Overlay List ..................................................................................143
Adding Overlays to an Overlay List...............................................................144

Working with a Segment List .................................................................. 145
Adding a Segment List ...................................................................................145
Adding Segments to a Segment List .............................................................145

Working with a TRC Reference List ....................................................... 146
Adding a TRC Reference List ........................................................................146
Adding TRC References a TRC Reference List.............................................147
Using a TRC Reference List...........................................................................148

Suppressing Fonts.................................................................................... 148
Suppressing Fonts Using AFPDS Property Settings ......................................148
Suppressing Fonts Using PPFA Property Settings .........................................149

Adding Lists from the Insert Toolbar ...................................................... 150
Contents 5



Chapter 9: Working with PageDef Objects 151
About PageDef Object.......................................................................151
Working with PageFormat.................................................................152

Adding a PageFormat .............................................................................. 152
Setting PageFormat Properties ................................................................ 154

Setting the Display Offset for a PageFormat ................................................. 155
Working with Records.......................................................................156

Adding a Record...................................................................................... 156
Setting Record Properties ........................................................................ 157

Setting Name and Display Options for a Record in Traditional PageDef ..... 157
Setting Name and Display Options for a Record in Record Format

PageDef................................................................................................... 158
Setting Sample Text ....................................................................................... 160
Setting Record Position.................................................................................. 160
Setting Record Direction................................................................................ 162
Repeating a Record in Traditional PageFormat ............................................. 162
Setting Font .................................................................................................... 163
Setting Color .................................................................................................. 164
Adding Comments ......................................................................................... 164

Working with Fields ..........................................................................164
Adding a Field ......................................................................................... 164
Setting Field Properties ........................................................................... 165

Specifying the Name and Data Presentation Settings for a Field in
Traditional PageDef ................................................................................ 165

Specifying the Name and Data Presentation Settings for a Field in
Record Format PageDef.......................................................................... 167

Setting Field Position ..................................................................................... 167
Working with the Barcode Field .......................................................168

Adding a Barcode Field........................................................................... 168
Setting Barcode Field Properties ............................................................. 169

Specifying the Name and Data Mapping Options for a Barcode Field ......... 169
Setting the Standard Barcode Options ........................................................... 170
Setting Special Properties for a 2DMATRIX Barcode .................................. 171
Setting Special Properties for a 2DMAXI Barcode ....................................... 173
Setting Special Properties for a 2DPDF417 Barcode .................................... 174
Specifying the Text ........................................................................................ 175

Working with Conditions ..................................................................175
Adding a Condition ................................................................................. 175
Setting Condition Properties.................................................................... 176

Setting General Properties for Conditions ..................................................... 176
6 DesignPro Visual PPFA User Guide



Switching Pages Using Conditional Logic Statements ..................................177
Working with Floating Overlays .......................................................180

Adding a Floating Overlay ...................................................................... 180
Setting Floating Overlay Properties ........................................................ 181

Setting General Properties for Floating Overlay ............................................181
Setting the Position of the Floating Overlay ..................................................182
Setting Rotation of the Floating Overlay........................................................182
Setting Offsets for the Floating Overlay.........................................................182
Merging Variable Data with a Floating Overlay ............................................183
Positioning an Overlay Relative to a Record .................................................183

Loading an Overlay as a Template .......................................................... 184
Adding a Template Overlay............................................................................184

Working with Floating Segments ......................................................185
Adding a Floating Segment ..................................................................... 186

Working with External Objects .........................................................187
Adding an Object..................................................................................... 187
Setting Object Properties ......................................................................... 187

Setting Object Position ...................................................................................189
Setting Object Content Position .....................................................................189

Working with End Subpage...............................................................189
Adding an End SubPage .......................................................................... 189

Chapter 10: Working with DrawGraphic 191
About DrawGraphic...........................................................................191

Adding a DrawGraphic Object ................................................................ 192
Setting DrawGraphic Object Properties .................................................. 193

Setting Object Name and Graphic ID.............................................................193
Setting Object Position ...................................................................................194
Setting the Dimensions for Line and Box Objects .........................................195
Setting Object Style options ...........................................................................196
Setting the Copy options ................................................................................197
Setting Object Color .......................................................................................198
Setting the Fill options for a DrawGraphic object..........................................198
Setting the Radius for a Drawgraphic Circle..................................................199
Setting the Axis for a Drawgraphic Ellipse ....................................................199

About EndGraphic .............................................................................200
Adding an EndGraphic Object ................................................................ 201
Setting EndGraphic Object Properties..................................................... 201

Setting EndGraphic Name and Graph ID.......................................................202
Contents 7



Chapter 11: Performing Standard Operations on Visual 
PPFA Objects 205
Opening FormDefs and PageDefs .....................................................205

Opening a Recently Used FormDef or PageDef ..................................... 205
Opening an Elixir FormDef or PageDef.................................................. 207
Opening PPFA Source or AFP Object FormDef or PageDef.................. 208
Opening a Legacy Document .................................................................. 209

Editing FormDefs and PageDefs .......................................................210
Copying Objects ...................................................................................... 211
Deleting Objects ...................................................................................... 211
Moving Objects ....................................................................................... 212

Saving FormDefs and PageDefs........................................................212
Saving a FormDef or PageDef to Elixir Format...................................... 213
Saving a FormDef or PageDef to AFP Object or PPFA Source Format. 214

Chapter 12: Working with Overlays 217
Working with Overlays in Visual PPFA ...........................................217

Using Overlays in FormDef .................................................................... 218
Using Overlays in PageDef ..................................................................... 219
Using Overlays as Templates .................................................................. 219
Editing Overlays using Design Tools...................................................... 220

Chapter 13: Working in Project Mode 225
About Project Mode...........................................................................225

Viewing Document Design in Project Mode........................................... 225
Adding PageDef or FormDef in Project Mode........................................ 227

Loading a FormDef or PageDef in Project Mode .......................................... 228
Removing FormDef or PageDef from the Project Mode............................... 228

Chapter 14: Working with Data 229
Data Formats for Traditional and Record Format PageDefs.............229
Data File Formats ..............................................................................229

Traditional Line Data .............................................................................. 230
Record Format Line Data ........................................................................ 231

Data Encoding Formats .....................................................................231
ASCII....................................................................................................... 231
EBCDIC .................................................................................................. 232
Mixed-Mode Data ................................................................................... 232
8 DesignPro Visual PPFA User Guide



Working with Sample Data................................................................233
Loading/Unloading a Sample Data File .................................................. 233

Setting Data File Properties............................................................................234
Data Mapping .......................................................................................... 236

Mapping Records............................................................................................237
Mapping Fields ...............................................................................................237
Mapping Barcodes..........................................................................................238

Chapter 15: Proofing Designs 239
About Data Proofing..........................................................................239

Preparing for Data Proofing .................................................................... 239
Setting Data Proofing Properties ............................................................. 240

Setting the Data File and Associated Properties.............................................240
Specifying Font Settings.................................................................................242

Running Proofing .................................................................................... 243
Previewing and Printing the Design Area Contents ................................ 244

Appendix A: Workspace Glossary 247
Menu bar ............................................................................................247

File Menu........................................................................................................248
Edit Menu .......................................................................................................248
View Menu .....................................................................................................249
Insert Menu.....................................................................................................251
Project Menu ..................................................................................................252
Tools Menu .....................................................................................................252
Window Menu ................................................................................................254
Help Menu ......................................................................................................254

Toolbars .............................................................................................255
Standard Toolbar.............................................................................................255
View Toolbar ..................................................................................................256
Position & Dimension Toolbar .......................................................................257
Common Attributes Toolbar...........................................................................258
Filter Toolbar ..................................................................................................259
Project Toolbar ...............................................................................................260
Insert Toolbar..................................................................................................261

Form Design Tools ............................................................................262
Select Toolbar .................................................................................................264
Line Toolbar ...................................................................................................264
Box Toolbar ....................................................................................................265
Ellipse Toolbar................................................................................................266
Contents 9



Path Toolbar ................................................................................................... 267
Text Attributes Toolbar .................................................................................. 268
Image Toolbar ................................................................................................ 269
Barcode Toolbar ............................................................................................. 270
Active Button Toolbar.................................................................................... 270

Keyboard Shortcuts ...........................................................................271
Text Editing Keyboard Shortcuts ................................................................... 271
Numeric Display Box Keyboard Shortcuts.................................................... 272
Zoom/Pan Control Keyboard Shortcuts......................................................... 273

Appendix B: Glossary 275

Index 283
10 DesignPro Visual PPFA User Guide



Chapter 1:

Introduction
This guide provides both background and procedural information for using DesignPro 
Tools Visual PPFA. Because business requirements and user preferences can vary for 
each company, the material contained herein should be viewed as a general guide only.

As you step through the material, please remember that your specific business needs will 
govern selection of the options and preferences described. Similarly, certain selections 
will require that some tasks be repeated, while other selections will allow you to omit 
tasks entirely.

Visual PPFA Overview
DesignPro Visual PPFA provides an easy-to-use visual interface for creating and editing 
PageDefs and FormDefs. You can also modify the overlays that are part of the design 
using the embedded Form Editor module. DesignPro Visual PPFA facilitates the AFP 
print job process by providing the following set of features:

Creates applications in a user-friendly environment, without the need for hard coding 
or having complete knowledge of PPFA commands, which allows you to focus on 
the application design.
Provides a visual design environment allowing overlay insertion for ease of data 
placement on single or multiple logical pages. It also enables you to set the print 
direction, color, and font of individual data fields and records.
Supports traditional, as well as record format PageDefs.
Provides support for quick design through a sample data file using drag-and-drop 
data placement or input of coordinates.
Provides a WYSIWYG display for AFP proofing using samples of EBCDIC, ASCII, 
or Mixed-mode print data in the Elixir Viewer.
Enables setting page dimensions, print direction, font types, font rotation, and text 
line spacing. Also facilitates you to place page segments for inclusion in the final 
printed output.
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Provides support for printing multiple pages on a single sheet of paper (Multiple-Up 
and NUP) using sub pages.
Supports conditional processing to enable different data on different pages based on 
variable data triggers.
Provides design support for duplex printing.
Provides design support for basic and enhanced NUP printing, enabling you to place 
up to four pages on a single sheet of paper in simplex mode, and eight in duplex 
mode.
Enables you to position the logical page exactly on the physical sheet, and also 
provides the inclusion of overlays that substitute for the preprinted forms.
Provides import and export capabilities for PageDefs and FormDefs in industry 
standard formats.
Provides a real time display of the generated PPFA source.
Provides design support for the required number of copies for any page of data. Also 
supports quality selection and post-processing controls such as perforation, cutting, 
etc.

With the help of these features you can get simplified procedures for generating and 
modifying PageDefs and FormDefs for document production.

Understanding AFP format 
A job is a print operation that merges variable data with fixed resources to produce a print 
run. The most common way to produce a print run is to use IBM’s Advanced Function 
Presentation (AFP) printers and the Print Services Facility (PSF) subsystem. Using this 
configuration, you can define and run a job as follows:

Create a FormDef source using Page Printer Formatting Aid (PPFA) form-definition 
commands to specify how the printer will handle the physical sheets of the paper.
Create a PageDef source using PPFA page-definition commands to specify how you 
want to position the data on the logical page. 
Compile the above definitions on a host computer to produce FormDef and PageDef 
object files.
Run the job, specifying the data file and the required resources (e.g., fonts, static 
overlays, page segments, etc.) that need to be printed.
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Generating source FormDef and PageDefs is a lengthy and costly process, requiring 
highly skilled data processing personnel or system programmers. In-depth knowledge of 
PPFA and print data streaming, as well as a trial-and-error method for calculating data 
print positions on forms, are therefore required.

Associated DesignPro Modules
DesignPro Tools for AFP employs five integrated modules to provide advanced 
functionality for designing forms.

Following are the DesignPro Tools for AFP modules:
DesignPro Manager – a Windows-based desktop program for launching and 
managing applications.  You can also convert resource files to and from multiple 
formats using the Converters application in the DesignPro Manager.
DesignPro Form Editor – an advanced forms design tool used to create and edit 
forms for AFP printers.
DesignPro Visual PPFA – a combined form editing and application building tool 
for creating IBM PPFA PageDefs and FormDefs.
DesignPro Font Editor – a complete font design application used for creating and 
editing AFP raster fonts as well as elixir and PCL fonts.  You can also open true type 
fonts in this editor.
DesignPro Graphics Editor – a full service bitmap editor providing various 
transformations and commands for tiling graphics into raster fonts.

About this User Guide
The DesignPro Visual PPFA User Guide provides definitions and step-by-step 
instructions to help you design variable-data documents. DesignPro Visual PPFA is used 
for visually creating physical and logical pages that make up a PPFA document. You can 
also edit existing PPFA source documents.

The guide is organized to mimic the entire document creation process. It explains the 
concepts and procedures involved in designing the variable data document. DesignPro 
Visual PPFA User Guide is organized as follows:

Chapter 1:  Introduction, provides an overview on the DesignPro Visual PPFA 
functions, and identifies resources for getting the technical support you need.

Chapter 2:  Visual PPFA Environment, describes the Visual PPFA operating 
environment, including the workspace and application start and exit procedures.
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Chapter 3:  Customizing Visual PPFA, provides information on selecting profiles, 
specifying application and document default settings, and customizing workspace menu 
bar and toolbars for Visual PPFA.

Chapter 4:  Preparing to Work, provides information about assembling, managing, and 
converting resources required by Visual PPFA, and specifying file format settings.

Chapter 5:  Designing Physical Pages, explains the basics, creation and setting of 
FormDefs. FormDef is short for Form Definition. Both of these terms will be used 
interchangeably throughout this guide.

Chapter 6: Working with FormDef Lists and Objects, describes the FormDef objects, 
lists and associated overlays, including their creation, modification, and property 
definition. It also provides detail on the basic and enhanced NUP.

Chapter 7: Designing Logical Pages, explains the basics, creation and settings of 
PageDefs. A PageDef is a short for page definition, and both of these terms can be used 
interchangeably.

Chapter 8:  Working with PageDef Lists, describes the resource lists used in designing a 
PageDef, and provides information on adding, maintaining and deleting these lists.

Chapter 9: Working with PageDef Objects, describes the procedures to work with 
PageDef objects such as page formats, records, fields and barcode fields, conditions, 
floating overlay, floating segments, external objects, and end subPages.

Chapter 10:  Working with DrawGraphic, describes procedures to add drawGraphic 
and endGraphic objects to your design, and set their properties. DesignPro Visual PPFA 
enables you to use graphic objects relative to the variable data while designing your 
PageDef. These objects, which can be added to a logical page, are referred to as 
drawGraphic objects in PPFA.

Chapter 11:  Performing Standard Operations on Visual PPFA Objects, describes 
procedures to perform standard operations on various Visual PPFA objects, such as 
copying, deleting and moving objects as well as opening and saving them in various 
formats.

Chapter 12:  Working with Overlays, describes how to work with an overlay in 
PageDef and FormDef, and the procedure to use it as a template. It also provides 
information on using the Visual PPFA form design tools for editing the overlays.

Chapter 13:  Working in Project Mode, describes how to work with documents in 
Visual PPFA Project Mode.
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Chapter 14: Working with Data, provides information about data file and data encoding 
formats, and describes procedure to work with sample data.

Chapter 15:  Proofing Designs, provides information about proofing designs, and 
previewing as well as printing the contents of the design area.

Appendix A: Workspace Glossary, provides information on DesignPro Visual PPFA 
workspace environment menu bars, toolbars, and keyboard shortcuts.

Appendix B: Glossary, provides product-specific or unique terms and abbreviations used 
in the DesignPro Visual PPFA User Guide.

Who Should Use this Guide?

This guide assumes you are already familiar with Microsoft Windows operations, printer 
and font management operations and PC peripherals. You should also have access to 
reference manuals for PC software and hardware, including any printers you are using for 
the design and print process. 

Related Guides

If you require further information about a specific topic or wish to obtain product 
background information, reference the following resources, all of which are part of the 
DesignPro Tools for AFP documentation package. 

DesignPro Tools for AFP Getting Started Guide.
DesignPro Manager for AFP User Guide.
DesignPro Form Editor for AFP User Guide.
DesignPro Font Editor for AFP User Guide.
DesignPro Graphics Editor for AFP User Guide.
Chapter 1: Introduction 15



Conventions
Elixir products adhere to Microsoft Windows conventions for using menus, menu 
commands, dialogs, command buttons, icons and mouse. See your Windows manual for 
more information.

This guide uses the following typographic and symbolic conventions to identify special 
information.

Typographic Conventions
This guide uses the following typographic conventions to identify special information.

Convention Information Type/Example

< > (angle brackets),

<Shift> + <F1>.

Keystrokes

Example:  <Enter>

Key combinations are denoted by a plus sign between keys.

Example: <Shift> + <F1>.

Bold type Field names within an explanation.
Example: Use rules set by selected Start on option.

Dialog areas referenced in tasks.
Example: Select an item from the List of used Fonts. Click the 
Options tab.

Tool names referenced in dialogs/windows.
Example: Make sure the Text tool is selected.

Button names with text written on them.
Example: Click OK to save settings.

Any text that you must type.
Example: Enter LPT1 for the following option.
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Symbolic Conventions
Look for the following symbols as you read through this guide to identify special 
information.

Italic type References to other guides.
Example: For more information, see “Chapter 6: File Format 
Dictionary” in DesignPro Manager for AFP User Guide.

References to other chapters.
Example: For more information, see "Managing Images" on page 
25 in Chapter 3: "Graphics Editor Basics"

Toolbar names.
Example: Click any tool on the Drawing toolbar.

Window names.
Example: Message window displays.

File paths and directories.
Example: drive:\Elixir\Fonts\Elixir.

Captions. 

Quotation marks References to tasks, activities, or concepts.
Example: For more information, see “Using Colors” in Chapter 5: 
“Editing Images”.

The Note symbol calls your attention to additional information.

The Tip symbol highlights a helpful tip.

The Shortcut symbol calls your attention to an easier way of accomplishing a 
task.

Convention Information Type/Example
Chapter 1: Introduction 17



Getting the Answers You Need
Elixir Technologies provides you with multiple ways to learn and use Opus:

"Customer Support" on page 18
"Elixir Web Site Support" on page 19
"Elixir Training" on page 19
"Product Help" on page 19

Customer Support
If you purchased this product directly from Elixir Technologies, you can contact the 
Customer Support Center for your region at the number listed below.

North and South America:

+1 805 641 5900 ext. 3 
Monday - Friday, 7:00 am to 4:00 pm Pacific Standard Time; if closed, press 2 to 
reach Elixir’s extended Support coverage.
Elx_support@elixir.com

Asia Pacific:

Asia_support@elixir.com

Europe:

+44 (0) 207 993-4811 
Monday - Friday, 6:00 am to 4:00 pm Central European Time
+1 805 641 5900 ext. 3
Monday - Friday, 4:00 pm to 2:00 am Central European Time
Europe_support@elixir.com

An Elixir Product Specialist will take your call and ask for the following information:
Your name, organization, telephone number and address.

The Warning symbol warns you of problems you might encounter.
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Elixir product name and version number.
A complete description of the problem, including any error messages printed or 
displayed on your monitor.

Elixir Web Site Support
You can obtain product support from the Elixir web page at www.elixir.com. 

Select Support to:
Ask a question of Elixir Support.
Find answers from a list of Frequently Asked Questions.
Review the latest Tips and Techniques for increasing productivity.
Download the latest Product Releases and Patches.
View the latest product Release Notes.
Access newsgroups to see how others are using Elixir products.
Sign up for an Elixir Learning Program.

Elixir Training
Elixir Technologies offers training for its full-range of Windows-based products. For 
more information, contact:

Elixir Learning 
+1 805 641 5900, ext. 4

Product Help
Elixir software uses the Microsoft Windows Help program to provide online help for all 
product functions.

This online tool includes step-by-step procedures that you can follow as you work. 
Context-Sensitive Help can be activated from within the software for dialogs by 
clicking  in the upper-right corner of a dialog. You can also get this information by 
right-clicking the control and selecting What’s This? from pop-up menu or selecting 
a dialog control such as an input field, radio button, or drop-down list, and then 
pressing Shift + F1.
Online Help can be opened by selecting Help>Contents from the menu.
Chapter 1: Introduction 19
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Chapter 2:

Visual PPFA 
Environment

This chapter describes the Visual PPFA operating environment, including the workspace 
and application start and exit procedures.

Starting Visual PPFA
To start a session, click Start on the Windows taskbar, and choose Programs>Elixir 
Applications>DesignPro Tools>DesignPro Visual PPFA.

In this chapter...

Starting Visual PPFA

What’s in the Workspace?

Understanding Workspace Windows

Using Workspace Tools

Navigating the Workspace

Choosing Commands
21



The DesignPro Visual PPFA application window launches.

Exiting Visual PPFA
To end a session, do one of the following:

Press <Alt> + <F4>.
From the menu bar, select File>Exit.

Click  at the top right corner of the application window.

What’s in the Workspace?
When you start working on the Visual PPFA, the workspace and all of the associated 
components display. The workspace is where application objects are created and 
maintained. The following illustration identifies each part of the Visual PPFA workspace:
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The Visual PPFA workspace.

Understanding Workspace Windows
The workspace contains the following windows:

Design area
PageDef tree window
FormDef tree window
Template tree window
Messages window

Design Area
The design area provides a visual representation of the active application. You can use the 
design area to create drawing objects, and map tree objects and data to the application. 
The design area can be vertically and horizontally scrolled.
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The design area displaying mapped objects.

The design area includes the following tabs:

Front Side
Displays the front side of the logical or physical page of the active application for review 
and/or design.

Back Side
This tab only displays when a FormDef is loaded in the design area and represents the 
backside of the physical page for review and/or design. The Backside tab is disabled in 
the simplex mode.

The design created in the design area translates to the PPFA source code at run time, and 
can be viewed using the PageDef Source and FormDef Source tabs.

PageDef Source tab
This tab is visible only when a PageDef is loaded in the design area. It displays the PPFA 
source code generated against the PageDef tree objects.

FormDef Source tab
The FormDef Source tab is visible only when a FormDef is loaded in the design area. It 
displays the PPFA source code generated against the FormDef tree objects.
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The PPFA source view displaying the PageDef source.

PageDef Tree
The PageDef Tree window is located at the left side of the design area, and provides a 
hierarchical representation of the PageDef PPFA objects that are part of the application.

The PageDef Tree displaying the default nodes.

New PageDef
The New PageDef node serves as the root node of the PageDef tree (located in the 
PageDef Tree window), and defines the general template for the logical page of the active 
application. A PageDef can contain multiple logical pages or layout formats. Right-
clicking this node and selecting the Properties option displays the Properties – PageDef 
dialog enabling you to set or change the logical page properties.
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Font List
The Font List node acts as a repository for fonts defined for the active application. Right-
clicking this node and selecting the Properties option displays the Properties – Font List 
dialog enabling you to add or delete fonts.

New PageFormat
The New PageFormat node defines the layout format for a single logical page in a design. 
You can place the conditional logic, records, and fields in a logical page. Right-clicking 
the New PageFormat node and selecting Properties displays the Properties – Page 
Format dialog enabling you to set or change the page format properties.

NewRecord
The NewRecord node represents variable data and can contain single or multiple field 
objects. Right-clicking this node and selecting the Properties optiondisplays the 
Properties – Record dialog enabling you to set or change record object properties.

The above-mentioned object nodes are added with the PageDef Tree, by default, and are 
the minimum requirement for any PageDef object. Other object nodes that can be added to 
a PageDef include the following:

Field
Barcode Field
Condition
Floating Segment
Floating Overlay
Object
End SubPage
DrawGraphic Line
DrawGraphic Box
DrawGraphic Ellipse
DrawGraphic Circle
EndGraphic
Color List
Object List
Overlay List
Segment List
TRC Reference List
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FormDef Tree
The FormDef Tree window is visible at the immediate left pane of the design area. It 
provides a hierarchical representation of the FormDef PPFA objects that are part of the 
current application. The FormDef Tree is displayed as a tabbed page when loaded with a 
PageDef in the application.

The FormDef Tree displaying the default nodes.

New FormDef
The New FormDef node serves as the FormDef tree root node, and defines the general 
template for the physical page of the active application. Right-clicking this node enables 
you to set or change the physical page properties.

New CopyGroup 
The New CopyGroup node defines one set of characteristics for the physical page. Right-
clicking this node enables you to set or change the CopyGroup object properties.

New SubGroup
The New SubGroup node defines a single set of characteristics for one side of the 
physical sheet. Right-clicking this node enables you to set or change the SubGroup object 
properties.

The above-mentioned object nodes are added with the FormDef tree, by default, and are 
the minimum requirements for any FormDef object. Other object nodes that can be added 
to a FormDef include the following:

Overlay
Suppression list

Template 
The Template window is located below the PageDef Tree window, and serves as a 
placeholder for the added template overlays. Although the template overlays are not a part 
of the design, they help in the design of the logical page by enabling accurate data 
placement. The Template window is only available with PageDef documents.
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The default Template window with the Template Overlays node.

Messages Window
The Messages window is located at the bottom of the workspace. This window displays 
processing and compilation errors, warnings, and informational messages generated by 
the application in red, blue, and black text. You can clear the displayed messages by 
pressing <Ctrl >+ <D> on the keyboard. In order to facilitate more working space, you can 
close the Messages window by selecting View>Messages from the menu bar, or by 

clicking  at the top of the Messages window. However, the window will automatically 
redisplay whenever a message is generated by the application.

The Messages window displaying an informational message.

You can customize the position and size of the windows according to your requirements. 
When required, you can also float, dock, or hide the workspace windows.

Using Workspace Tools
Visual PPFA toolbars provide quick access to the most commonly used application 
commands. You can perform standard Windows operations to hide, display, or dock a 
toolbar in the workspace. For detailed information, refer to "Customizing Visual PPFA" 
on page 33 and "Workspace Glossary" on page 247.
28 DesignPro Visual PPFA User Guide



Menu Bar and Toolbars
A menu bar with drop-down menu options is located directly below the application title 
bar. These menu options provide both the standard MS-Windows, as well as application-
specific options. Selecting a menu item performs an associated action or displays a 
submenu or dialog.

The toolbars are located immediately below the menu bar. They contain buttons that 
provide access to the most commonly used commands and tools. You can hide or display 
toolbars by selecting View>Toolbars >Required toolbar from the menu bar.

Status Bar
The status bar is located along the lower edge of the design area. When you move the 
mouse pointer over the design area, the status bar displays the coordinates of the mouse 
pointer with respect to the design area.

Status bar displaying the coordinates of the mouse pointer.

When an object is being drawn, or you move the mouse pointer over an object in the 
design area, the status bar displays the type, width, and height of the object, font used for 
the object, and the coordinates of the mouse pointer. The coordinates help you draw 
objects within the design area. Moreover, the status bar displays the tool tip when the 
mouse pointer is placed over an icon in the design area.

Status bar displays the object type, height, and width.

Grid

You can activate the Grid by clicking  on the View toolbar, by selecting View> Grid 
from the menu bar, or by pressing <F4> on the keyboard. The Grid tool enables you to 
position and align objects accurately in the design area.

Ruler

You can activate the Ruler by clicking  on the View toolbar, by selecting View> Ruler 
from the menu bar, or by pressing <F2> on the keyboard. The Ruler tool aids accurate 
object placement in the design area.
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Guidelines

You can activate the Guidelines by clicking  on the View toolbar, by selecting 
View>Guidelines from the menu bar, or by pressing <F6> on the keyboard. The 
Guidelines tool helps align multiple objects in the design area.

Crosshair

You can activate the Crosshair by clicking  on the View toolbar, by selecting 
View>Long Crosshair from the menu bar, or by pressing <F8> on the keyboard. The 
Crosshair tool enables you to visually align objects in the design area.

Visual PPFA design area displaying the Grid, Ruler, Guidelines, and Crosshair tools.

Navigating the Workspace
The workspace components are organized according to function and use. You can 
navigate to any workspace component by a simple mouse click.

To use the menu bar: 
Select appropriate menu, then select the required option from the drop-down list.
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To show the toolbar: 
Select View>Toolbars>toolbar name. Selection is indicated by a check mark next to 
the toolbar name.
To use the toolbar:
Click the button on the toolbar corresponding to the required option.
To use the pop-up menu:
Place cursor on the required object in any of the workspace windows, right-click the 
mouse and select the required option. The pop-up menu only lists commands 
pertaining to the current selection. 

Choosing Commands
A command instructs Visual PPFA to perform a specific action. You can choose a 
command by either:

Clicking a toolbar button.
Selecting a menu option.
Using the pop-up menu.
Using a shortcut key.

In the following chapters, command selection is described using the most commonly used 
approach for any task. However, any corresponding command selection can be used to 
accomplish the same instruction.
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Undoing and Repeating Commands
Visual PPFA keeps track of your editing and formatting changes. You can undo or redo 
any number of command selections.

The Standard toolbar.
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Chapter 3:

Customizing Visual 
PPFA

This chapter provides information about selecting profiles, specifying application and 
document default settings, and customizing workspace menu bar and toolbars for Visual 
PPFA.

About User Profiles
You can customize Visual PPFA to fulfill the requirements of your specific working 
environment by creating and maintaining unique user profiles. A profile is a system file 
that stores important file locations and other related information for Elixir applications. 
When an Elixir application is installed, a default profile is created and stored in the 
SystemData.ini file, based on the information provided during installation. This file 
establishes the basic operating environment for the specific application, and is located at 
drive:\Documents and Settings\current user\Application Data\Elixir 
Technologies\Profiles. This default profile is created and loaded automatically when an 
Elixir application is launched for the first time. 

You can also create custom profiles using the Profile Editor, which can be launched by 
selecting Tools>Profile Editor from the Visual PPFA application window. These custom 
profiles can be subsequently selected using the Tools>Profile Selection command. 
Custom profiles selected for various DesignPro modules need to be specified separately. 
A profile selected for one module does not apply to other modules and sessions.

In this chapter...

Selecting a User Profile

Changing the Application Default Options

Changing the Document Default Options

Customizing the Toolbars and Menus
33



Selecting a User Profile
To select a profile and view its contents, select Tools>Profile Selection to display the 
Profile Selection dialog.

As appropriate, review the following:

Current Profile

Profile name – lists the available user profiles.
INI file path – displays the complete path of the .INI file containing the selected 
profile. 
Description – displays a brief narrative describing the selected profile.

Pre-defined Symbols

Symbols – displays a list of the pre-defined symbols that identify various application 
objects.
Symbol value – displays the default path of the pre-defined symbols that are 
required by the current profile. This path specifies the location of the application 
object(s).

To select a user profile other than those listed in the Profile name, click New to display 
the Register New Profile dialog. Review the following dialog options:

Profile name – enter a unique name identifying the new user profile.
Profile INI file path – enter a unique profile name and file path in this text box. You 

can also click  to display the Open Profile Configuration File dialog for 
selecting the required .INI file.
Description – enter a brief narrative describing the new profile.

If the current user ID differs from the ID that you initially used to install the 
DesignPro Tools application, you can select a profile in the Profile Selection dialog. 
The dialog displays when any DesignPro module is launched for the first time, and 
prompts you to select a profile before using any DesignPro Tools module.
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Changing the Application Default Options
Visual PPFA facilitates you to customize your work, in terms of controlling the operation 
and appearance of the application environment in order to meet your business needs. You 
can use the Options dialog to review, enter, and change the default settings.

The Options dialog provides twelve category settings at the application level. You can 
choose to set your preferences from the various categories that are available in the dialog. 
These settings are applied the next time you open a document and remain in effect until 
they are changed.

Use the following steps to view and set preferences for the listed categories:

1 Select Tools>Options from the menu bar to display the Options dialog.

The Options dialog displaying the General Category options.

2 Select the required category from the Category list. 

3 Specify the required settings. For details on your required settings, refer to the 
relevant section below.

4 Click Apply and OK to save the settings.
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Setting the Application Loading Defaults
Loading defaults specify the application behavior at startup time. You can set display 
preferences for the message and property dialogs by using them. Loading defaults include 
the settings for object color, shade handling, and input setup file. The General category 
facilitates you to customize the application loading defaults.

To set the application loading defaults, review the following dialog options:

Preferences

Substitute shades with solid color – replaces the object shades with a solid color.

(1) Substitute shades with solid color option enabled. (2) Substitute shades with solid 
color option disabled.

Load last input setup file at startup – uses the setup file that was used (loaded/
saved) in the last application session for the next application startup. A setup file 
(.EPM) stores the input and output property settings for the different file formats. 
These settings facilitate the handling of user selected file format options during file 
conversion. For detailed information on setup files, refer to the DesignPro Manager 
for AFP User Guide.
Send all messages to window – displays all error, warning, and informational 
messages in the Messages window. If this option is unchecked, all of the generated 
messages display individually in the form of respective message boxes.

(1) Messages sent to the Messages window. (2) Messages displayed separately in 
their respective Message boxes.
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Show page properties – displays the Properties dialog for the selected object, by 
default, when creating a new document. This facilitates rapid document designing.
Workbook Mode – displays a tabbed view of the workspace, which enables you to 
switch between multiple open documents.

Applying the Display Settings
The display settings include options for customizing object specific property dialogs. The 
General category facilitates you to customize the display settings. To set the display 
settings, review the following dialog options:

Property Dialog Mode

Modal – sets the selected object Properties dialogs to modal, which prevents you 
from switching to another application area, unless you close the dialog.
Modeless – sets the selected object Properties dialogs to modeless, which enables 
you to switch to other application areas even if the dialog is active.
Modeless without buttons – sets the selected object Properties dialogs to modeless 
without buttons, where you can switch to other application areas even if the dialog is 
active. Changes specified in this dialog are immediately applied to the selected 
object.

Setting the Spell Checking Options
You can specify the spell checker options in the Editor category. To perform the spell 
checking function, review the following dialog options:

Spell Checking

Spellcheck typing – activates the spell checker.
Spell Options – displays a nested Options dialog for setting the spell checker 
properties. The Options dialog displays only when a document is loaded in the 
design area.

Specify the following in the Options dialog:
Ignore capitalized words – ignores any word that begins with a capital letter (e.g., 
Elixir) while performing the spell check. 
Ignore all-caps words – ignores any word that contains all capital letters (e.g., 
PPFA) while performing the spell check.
Ignore words with numbers – ignores any word that contains numbers (e.g., 
Barcode2of5) while performing the spell check.
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Ignore words with mixed case – ignores any word that contains both upper and 
lower case letters (e.g., PageDef) while spell checking.
Ignore domain names – ignores the URLs (Uniform Resource Locator, e.g., 
www.xyz.com) while performing the spell check.
Report doubled words – reports instances of words appearing twice in a row (e.g., 
account number number) while performing the spell check.
Case sensitive – performs case-sensitive spell check; this option is selected by 
default.
Phonetic suggestions – displays phonetic suggestions for misspelled words while 
performing the spell check.
Typographical suggestions – displays typographical suggestions for misspelled 
words while performing the spell check.
Suggest split words – displays split-word suggestions as a replacement for 
misspelled words containing two joined words.
Auto correct – performs the automatic correction of commonly misspelled words 
while performing spell check.
Main Dictionary language – specifies the primary dictionary language on the basis 
of which the spell checker works.

Suggestions

Fast but less accurate – performs fast but less accurate checking.
Moderately fast and accurate – performs moderately fast and accurate checking.
Slow but accurate – performs slow but very accurate checking.

Setting the Filing Options
The automation options for creating backup files and saving work at specified intervals 
can be specified using the Editor category. To set the filing and auto save features, review 
the following dialog options:

Filing Options

Make backup files – creates the backup (.bak) of the file. Every time you save the 
file, the file as well as its backup is stored at the same location. The backup files 
enable data recovery if the original file gets corrupted. 
Autosave – enables the auto-save feature that automatically saves the file after the 
specified time interval. On selecting this option the Interval box is enabled, where 
you can specify your required interval in minutes. 
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Allow all files in file selectors – displays all file formats specified in the file selector 
feature for the Open and Save dialogs.

Setting the Clipboard Options
You can specify the cut and paste operations for the workspace in the Editor category. 
Paste options enable you to preserve RTF formatting at the time of pasting, and places 
data at the required location with a mouse click.

To set the clipboard and object selection properties, review the following dialog options: 

Clipboard

Paste Rtf – preserves Rich Text Formatting (RTF) while pasting the clipboard 
content. 
Paste with mouse – pastes your selection using the mouse. When the Paste with 

mouse option is enabled, the mouse cursor changes from  to . 
You can move this cursor to the required location to paste the clipboard content.

Object selection

Enclose – selects the object when it is enclosed within the selection box. 
Touch – selects the whole object even if a part of that object lies within the selection 
box.

Setting the Record and Field Display Options
You can customize the display of mapped records and fields in the design area using the 
Editor category. The mapped fields can be viewed by their respective names, or by a 
string of replacement characters for accurate data placement.

To set the display properties for the records and fields, review the following dialog 
options:

PageDef Display

Name – displays the mapped records and fields in the design area by their respective 
names.
Replacement char – represents the mapped records and fields by a string of user-
specified replacement characters. On clicking this option, the associated text-box is 
enabled; enter a single replacement character in this box.
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(1) Records and fields displayed by their names in the design area. (2) Records and 
fields displayed by a string of replacement characters (X) in the design area.

Setting the Border Colors and Line Styles
In Visual PPFA, you can identify the logical pages, overlays, and NUP partitions using 
different colored borders. The Borders & Colors category, as the name indicates, 
provides options for setting the color and style of the border.

To set the border colors along with the line styles, review the following dialog options:

Border
Select the appropriate checkbox to activate the border color and line style lists for the 
following objects:

Logical Page
Page Overlay
Medium Overlay
Selected Overlay
NUP Overlay
NUP Partition

Select the required option from the Border list. Click Other to open the Color dialog to 
select a color other than the listed colors. 

You can also distinguish suppressed fields from printed fields by setting colors and line 
styles for suppression using the following options:

Suppression – activates the suppression color and line style lists.
Display form in one color – sets the loaded forms to display in a single (selected) 
color.
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Selecting the Paper and Printer Options
You can specify the required printer as well as the paper size in the Paper & Printer 
category. Other than the predefined options, you can also select media options and 
customize the size of the paper depending upon your printer type.

To set the required printer and paper size, review the following dialog options:

Paper options

Paper size – sets the paper size of the required document.

To select the size of the paper not mentioned in the Paper size list, select Custom to 
activate the Width and Height options.

Width – sets the width of the paper in the specified unit of measurement.
Height – sets the height of the paper in the specified unit of measurement.

Printer options - Changeable media origin

You can use a printer that facilitates the media origin to be shifted to any of the four 
corners of the paper. Select the required option from the following:

Cutsheet – specifies that the printing is to be done on a cut-sheet printer.
Continuous – specifies that the printing is to be done on a continuous form printer.

Similar presentation settings result in different page presentation on cut-sheet and 
continuous printers.
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Printer Options - Fixed media origin

Continuous 3800 – uses the IBM 3800 Continuous form printer for the required 
printing. The 3800 printers have fixed media origin; therefore, on selecting this 
option, the FormDef page presentation settings do not take effect.

Setting the Sample Data Options
You can specify the data file and sample data display options in the Sample Data 
category. This includes specification of the file length, its encoding, and record format. 
You can use the carriage control option for page ejection, and the TRC option for the font 
modification settings.

To set sample data properties, review the following dialog options:

Sample data file

Data File – specifies the name identifying the loaded data file. Click  to display 
the Open dialog for selecting the required data file.

File length

Starting line number – sets the line number in the file from where the data is 
loaded.
Number of lines to read – specifies the number of lines of data to be read.

File Encoding

ASCII – specifies that the loaded file is in ASCII (American Standard Code for 
Information Interchange) format. 
EBCDIC – specifies that the loaded file is in EBCDIC (Extended Binary Coded 
Decimal Interchange Code) format. 
Mixed-mode data – specifies that the loaded file is in mixed-mode data format.

The recommended length of a sample data file is 100 lines.
42 DesignPro Visual PPFA User Guide



File Record Format

File Format – specifies the required data format. The available options are:
• Stream Newline – each data record is delimited by a new line (linefeed) 

character. On selecting this option, the corresponding new line character displays 
in the New Line Char box.

• Record,n – each data record is delimited by record length instead of a new line 
character. On selecting this option, the Record Length box is enabled to specify 
the length of the input data records.

Control Characters

Carriage Control – skips carriage control characters in the data file. Carriage 
control characters manage line skipping, line spacing, and page ejection on line 
printers.
TRC – skips table-reference characters in the data file. Table-reference characters 
control font selection in line data.

Customizing the Sample Data Grid
The loaded sample data file displays in the Sample Data window in the workspace. The 
Sample Data category enables you to customize the display of the Sample Data window 
through the grid options.

A mixed-mode data file is a combination of both line data and structured fields 
(known as AFP data). Mixed-mode data files can specify the beginning and end of 
pages, as well as data controls for printing.

You can also set the Sample Data options using the Open sample data file dialog.  
To launch this dialog do one of the following:

Select Project>Load Sample Data File from the menu bar. 

Click  on the Project toolbar.
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To set the sample data grid specifications, review the following dialog options:

Sample Data Grid Settings

Grid options… – displays the Display options dialog for setting grid preferences for 
the Sample Data window. 

In the Display options dialog, specify the following:

Tiles and Guidelines

3D – Buttons – displays 3D-buttons in the sample data grid.
Vertical Lines – displays vertical lines in the sample data grid.
Horizontal Lines – displays horizontal lines in the sample data grid.

Line Style

Style – sets the required grid line style from the available options.

Color
Select the appropriate object from the list to display the corresponding color values that 
are available for selection. Click the required color from the available options. 

Preview

Preview – displays a preview of the Sample Data window with the current settings.
Set Defaults – sets the Display options fields to their default values.

Setting the Grid Options
The Grid feature provides a network of lines overlaying the design area. These lines help 
in the design process but are not part of the design. Using the Grid category options, you 
can specify major grid spacing, as well as the number of subdivisions within each major 
grid division in both vertical and horizontal directions. Also, objects can be set to 
automatically align with grid coordinates for rapid document design. To set the grid 
properties, review the following dialog options:

Horizontal/Vertical

Major spacing – sets the space between the horizontal or vertical grid lines, per 
specified unit of measurement (default is an inch). The major spacing is denoted by 
the symbol (+) in the design area. 
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Number of subdivisions – sets the number of divisions that are displayed between 
the horizontal or vertical grid lines. The divisions are denoted by dots in the design 
area.
Show grid – displays the grid in the design area.

Snap to grid – sets the alignment of the design area objects according to the grid 
points.

Hide major spacing (+) – hides the appearance of the major spacing symbol (+) in 
the design area.

1) Major spacing symbol (+) displaying in the design area. (2) Major spacing 
symbol disabled.

You can also view the grid by performing one of the following operations:

Select View>Grid from the menu bar. 

Click  on the View toolbar.
Press <F4> on the keyboard.

You can also snap objects to the grid by performing one of the following 
operations:

Select Tools>Rulers and Grid>Snap to Grid from the menu bar. 

Click  on the View toolbar.
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Setting the Guidelines Options
The guidelines facilitate you to place objects in the design area quickly by providing 
visual reference points. The Guidelines category provides options to display and align the 
objects. For more precise placement, you can also set a radius for the guidelines.

To set the guideline properties, review the following dialog options:

Snap

Magnetic snap radius – sets a value for the magnetic snap radius. Any object placed 
within the specified radius is snapped to the guideline.
Show guidelines – displays the guidelines in the design area.

Snap to guidelines – facilitates the snapping of objects to the guidelines.

You can also display the guidelines by performing one of the following operations:

Select View>Guidelines from the menu bar. 

Click  on the View toolbar.
Press <F6> on the keyboard.

You can also snap objects to guidelines by performing one of the following 
operations:

Select Tools>Rulers and Grid>Snap to Guidelines from the menu bar.

Click  on the View toolbar
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You can also drag and drop guidelines in the design area by clicking the graphic ruler, and 
then dragging the guideline to the required location.

Setting the Ruler Options
The Ruler category provides options for setting units of measurement for both graphical 
and digital rulers in the Visual PPFA workspace.

To set the ruler properties, review the following dialog options:
Units – specifies the unit of measurement for both graphic and digital rulers, as well 
as for the application.

Select the appropriate checkbox to apply the grid settings, specified in the Grid category, 
to the following:

Graphic ruler
Digital ruler

You can also specify the application units using the Units list in the View toolbar.
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You can also launch the Options dialog for setting the grid, guidelines and ruler settings 
by selecting the following: 

Tools>Rulers and Grid>Grid, for Grid Category.
Tools>Rulers and Grid>Guidelines, for Guidelines Category.
Tools>Rulers and Grid>Ruler for Ruler Category.

Setting the Symbols Properties
The Symbols category facilitates you to set the default properties for items in the System 
Data.ini file, and displays the pre-defined as well as the user-defined symbols. Each item 
represents a key (variable) with an associated value (path). The key and value pairs are 
used to locate the required type of computer information. In DesignPro Visual PPFA, the 
keys identify application objects, and values indicate the associated object paths and 
types.

To set the symbol specifications, review the following dialog options:
Key String – displays the selected key string.

Value – sets the type and path of the selected object. You can click  to display the 
Browse for Folder dialog for selecting the required path.
Real – displays a proper path for the selected key string.
Set – sets the Real value for the selected key string.

Setting the Message Preferences
Visual PPFA prompts you when informational, warning, and error messages are 
generated. In the Messages category, you can set the message type and display options. 
Specifying the message type economizes data logging by limiting the message display 
criteria. The display options for the time, date, and color of the messages can help identify 
the type and severity of a message.

The Symbols and System Data category features are currently inactive.

The SystemData category is a subset of the Symbols category. It includes 
information on the system symbols that are predefined by Elixir. The list of 
information for SystemData also comes from the same files i.e. SystemData.ini.
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To set the message preferences, review the following dialog options:

Messages to View

Information – displays informational messages in the Messages window.

Show

Message time – displays the time of the message in the Messages window.
Message date – display the date of the message in the Messages window.
Use color – displays the color of the messages in the Messages window.

You can also specify the maximum number of text lines displayed at one time in the 
Messages window by using the associated box. By default, the message length is 200 
lines.

Logging the Messages
You can archive the messages generated by Visual PPFA in a file for future use. Logging 
options provided in the Messages category facilitates you to save the information 
displayed in the Messages window.

To create a log for the generated messages, review the following dialog options:

Log Options

Log to File – enables writing of messages to the log file. On clicking the Log to File 
checkbox, all of the associated options are enabled. In the first associated text-box, 
type the destination path where the generated log file is to be saved. The default 
value of “.\” saves the log file in the same directory as the resource file. In the second 
associated text-box, type the name of the log file. The default file name is 
MSG.LOG. The file can have any name and can also be saved in formats other than 
LOG, e.g. .DOC. 
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Unicode – creates a log file using the Unicode character set.
Overwrite – overwrites any existing message in the selected log file.
Append – appends the newly generated messages to the specified log file.
Append by date – appends messages to the log file on the basis of date. 
View Log File – displays the log file contents using Notepad.

The Log file displaying the generated message; the system date is appended with the 
name of the file due to the Append by date option.

Viewing the Parser and Converter Properties
You can view the properties for all of the available parsers and converters using the Info 
Server category options.

The available Input Parsers, Output Converts, and Output Data Converters display in 
the form of a folder tree view. To view the properties of a particular parser or converter, 
click  on the relevant folder, and select the required option to display the information in 
the associated fields.
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View

Show all components/Hide unlicensed components –displays all components or 
only licensed components in the tree view. The button alternates between Show all 
components and Hide unlicensed components options.
Refresh –saves the changes, if any, and refreshes the folder tree view.

Component

Name – displays a unique name identifying the selected converter or parser.
ID – displays a unique code identifying the selected converter or parser.
Presentation – displays the text that appears in the file filters of the Open and Save 
dialogs corresponding to the selected converter or parser.

Registering the New File Extensions
You can register file extensions for a selected converter or parser using the Info Server 
category. For example, if an AFPDS input parser image category displays S1*.seg, and 
your .SEG files are saved with the extension .XYZ or .SEG123, you can add and register 
these variations as supported file format extensions. 

To register new extensions:

Resource

Presentation – displays the text that appears in the file filters of the Open and Save 
dialogs corresponding to the selected converter or parser.
Extensions – displays the extension(s) for the selected resource. Multiple extensions 
can be specified separated by semicolons.
Default – switches the selected resource extension back to the default.

The Extensions setting applies to file extensions only, and does not affect the 
supported file formats.
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Changing the Document Default Options
You can review the default appearance and settings for the document identification using 
Visual PPFA. The Options dialog provides four category settings at the document level. 
These display only when a document is loaded in the design area. New settings take effect 
if you click Apply or OK. These settings remain in effect until they are changed.

Use the following steps to view and set preferences for the listed categories:

1 Select Tools>Options from the menu bar to display the Options dialog.

The Options dialog displaying the General category options.

2 Select the required category from the Category list.

3 Enter the required settings. For details on your required settings, refer to the relevant 
section below.

4 Click Apply and OK.

Applying the Document Identification Settings
You can specify the document author, company, version number, revision number, and ID  
using the General category. You can also specify the document creation date and time.

Author – sets a unique name identifying the author.
Company – sets a unique name identifying the company.
Version – sets a document version identifier.
Revision – sets a document revision identifier.
Local ID – sets a unique code identifying the document.
Time Stamp – sets the document creation date and time.
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Setting the Document Guidelines
You can place guidelines in the horizontal or vertical directions using the Guidelines 
category. These options enable you to place objects in the design area quickly by 
providing visual reference points.

1 As appropriate, select one of the following options:
Horizontal – sets guidelines in the horizontal direction.
Vertical – sets guidelines in the vertical direction.

2 In the Guideline position box, specify the position of the guideline relative to the 
horizontal or vertical axis, per specified unit of measurement.

3 Click Set to add the guideline to the list.

4 To delete a specific guideline, select it from the list and click Clear. To clear all of 
the guidelines, click Clear All.

Setting the Document Ruler Options
The Ruler category provides options for setting the units of measurement for both the 
graphical, as well as the digital rulers.

To set the ruler properties, review the following dialog options:
Units – select the required unit of measurement for both graphic and digital rulers, as 
well as for the application.

Horizontal/Vertical
To specify the position of the zero digit on the horizontal ruler, click the appropriate Zero 
position option:

Left
Right

The Grid options provided at the application and document level are the same. 
However, the options set at the document level apply only to the current 
document, whereas the application level settings apply to the whole application 
and act as defaults for each newly created document. For details on grid options, 
refer to "Setting the Grid Options" on page 44.
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For the vertical ruler, click the appropriate Zero Position option from the following:
Top
Bottom

You can also customize the location of the ruler using the following options: 
Position on bottom – displays the horizontal ruler at the bottom of the design area.
Position values to left – displays the positive values on the left of the zero.
Position on right – displays the vertical ruler on the right side of design area.
Position values to top – displays the positive values on top of the zero.
Zero Offset – enter or select the page vertical offset, per specified unit of 
measurement.

The design area displays the ruler with (1) Default setting of top left, and (2) bottom 
right.
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Customizing the Toolbars and Menus
You can customize the Visual PPFA toolbars and menus to better serve your business and 
personal requirements. For this, you can add the frequently used commands to toolbars, 
and even remove the toolbars and toolbar items that you do not need.

To customize the Visual PPFA toolbars:

1 Select View>Toolbars>Customize from the menu bar, to display the Customize 
dialog.

2 Select the required tab.

3 Enter the appropriate settings. For details on your required settings, refer to the 
relevant section below.

4 Click Apply and OK.
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Customizing the Toolbar Display
You can review the toolbars that display in the workspace using the Toolbars tab. To 
display a toolbar in the workspace, review the following dialog options:

Toolbars – sets the toolbar you want to display in the workspace from the list of 
available options.

The selected toolbar name displays in the Toolbar name text box. You can also display a 
toolbar by selecting View>Toolbars>Toolbar name from the menu bar.

To set the appearance of the displayed toolbars:
Show Tooltips –displays the tool tips associated with the toolbar buttons.
Cool Look –displays the toolbar buttons in the smooth look mode.

The workspace toolbar with (1) Cool Look enabled and (2) Cool Look disabled.

Large Buttons – displays the toolbar buttons in the enlarged mode.

The workspace toolbar (1) without Large Buttons and (2) with Large Buttons.

Reset/Delete – resets a toolbar to the default settings. This button alternates to 
Delete when a user-defined toolbar is selected, hence can be used to delete a user-
defined toolbar only.

You cannot de-select the Menu bar option.
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Creating a New Toolbar
You can create a new toolbar using the Customize dialog. To create a new toolbar in the 
Toolbars tab:

1 Click New to display the New Toolbar dialog.

2 Enter the name of the new toolbar in Toolbar name.
The names of your created toolbars can be modified at any time using the Customize 
dialog, but the names of the default toolbars remain un-editable. On clicking OK, the 
new toolbar displays in the workspace without any buttons added. You can add 
buttons to the newly created toolbar later.

The Test toolbar displays in the workspace without any buttons.

Adding Buttons to the Toolbars and Menus
You can add buttons to the generally used toolbars using the Commands tab in the 
Customize dialog. A list of available toolbars display in the Categories option, whereas 
associated toolbar buttons display under the Buttons option. To add a command button to 
an existing toolbar, click and drag the required button to your target toolbar in the design 
area, then release the mouse. While dragging the required button, the mouse cursor 

changes from  to . The selected button is then appended to the required toolbar at 
the point where you dropped it.
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The following image illustrate the the process of appending buttons to a toolbar:

If you drag the required button and drop it anywhere in the application window other than 
the target toolbar, Visual PPFA automatically creates a new toolbar with the specified 
button and displays it in the application window. If you then select the Toolbars tab, the 
newly created toolbar name (default is Toolbar 1) displays in the Toolbars list.
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Chapter 4:

Preparing to Work

This chapter provides information about assembling, managing, and converting resources 
required by Visual PPFA, and specifying file format settings.

About IBM Print Services Facility
IBM Print Services Facility (PSF) is a print driver program that manages resources and 
jobs management for Advanced Function Printing (AFP) printers. PSF combines data 
streams with the resources and converts them into Intelligent Printer Data Streams (IPDS). 
IPDS contain data, as well as structured fields defining how the data is to be presented for 
the AFP printers.

PSF works only with AFP resources. It maintains a resource library for the following AFP 
resource types:

FormDefs
PageDefs
Overlays
Page segments
Fonts

In this chapter...

About IBM Print Services Facility

Preparing Resources

Gathering Resources

Managing Resource Objects

Converting Form, Font, and Image Files to AFP Resources

Changing File Formats

Elixir Parameter File (.EPM) 
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An overview of the AFP environment.

Visual PPFA enables the AFP print job process by providing the design support for all of 
the AFP resources such as fonts, overlays, PageDefs, etc. Visual PPFA also provides great 
flexibility as it facilitates resource conversion to a number of different formats. The 
resources that are created, saved, or exported in AFP formats using Visual PPFA and other 
DesignPro Tools components can be uploaded directly to the resource library of the 
specified printer. 

When saving resources to an AFP object format, Visual PPFA automatically appends the 
following prefixes to the resource file name:

F1 for FormDefs
P1 for PageDefs
O1 for overlays
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The following resource information must be provided when uploading resources to the 
printer resource library:

Name of the resource (1 to 8 characters long including prefixes).
Path of the resource.

At print time, PSF searches for these resources in the specified resource libraries and 
sends associated information to the printer with the print job.

Preparing Resources
Visual PPFA supports the import, export, and use of overlays, fonts, images, and barcodes 
in all the AFP object formats, common PC font and image formats, and Elixir legacy 
formats. You can also use the PageDef object files created in the Elixir Application Suite 
(EAS) as PageDef objects in Visual PPFA.

Visual PPFA uses built-in parsers to convert resources in the AFP object and PPFA source 
formats to the Elixir format. Before importing the resources, you can specify appropriate 
conversion settings for the resources. Once the resources are imported, you can modify 
and save them in Elixir formats, as well as AFP object and PPFA source formats using 
appropriate converters. You can also change converter properties when saving your 
documents, depending on your required results and printer settings.

Setting Elixir Resource Handling Properties
Elixir resource handling properties enable you to specify global settings for opening 
documents and copying resources to the Elixir resource library. You can also specify 
document page caching properties for optimized application performance. These settings 
can be very useful when working with large and complex documents.

The path and file names for the PSF host system are case-sensitive. When 
submitting a job, make sure that these names have correct uppercase and 
lowercase characters.
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To specify the Elixir resource handling properties:

1 From the menu bar, select Tools>Application Format Setting>Elixir Properties to 
display the Elixir dialog.

 

The Elixir dialog displaying the Resources category options. 

2 Select the required category from the Category list.

3 Enter the required settings. For details on your required settings, refer to the relevant 
section below.

4 Click Apply and OK.
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Setting up a Resource Searching Order
You can define a resource searching order for opening your document from a list of 
available converters, using Resources category options.

Resource Searching

Available resource converters – displays the resource converter formats that are 
available for selection.
Resource Searching Order – displays the searching order for the selected resource 
converters. The Input Parser is the built-in resource handler for input file resources, 
and hence it cannot be shifted to the Available resource converters list.

Click  and  to move items between the Available resource converters and 
the Resource Searching Order list.
The following image shows the steps involved in setting up a resource searching 
order:
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Set Selected Converter – displays the associated properties dialog for the selected 
item in the Resource Searching Order list. You can set custom settings for the 
parser, or simply view the default settings via this dialog. You cannot display or 
review the Input Parser properties. 

Resource Replacing

Replace Missing Resources with Defaults – replaces the missing resources with 
the default resources.

Importing Resources to a Resource Library
The Resource Library category facilitates you to set rules for importing resources to the 
Elixir resource library, while opening a document or inserting a resource (font, form, 
image, etc.) in the document.

You can use the following set of options to specify the rules for importing resources:

Rules for Importing Resources to Libraries

Do Not Import Resources – specifies that no resources are imported to the Elixir 
resource libraries.
Import Missing Resources Only – imports only those resources that are missing in 
the Elixir resource library.
All Resources, Overwrite any existing – imports all of the resources, and 
overwrites any existing resources with the same name in the resource library.
All Resources, prompt before overwriting – imports all of the resources, and 
prompts you for confirmation before overwriting any existing resources in the 
resource library.

For a detailed overview of the selected converter dialog options, see “Chapter 
6:File Format Dictionary” in the DesignPro Manager for AFP User Guide.
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Setting Page Caching Options
You can specify the maximum size of the virtual memory used in caching the document 
pages by using the Caching category options. Caching document pages enables faster 
page switching, which facilitates you to design complex documents more efficiently.
To set the caching options:

Caching

Cache Size – specifies the number of document pages to be kept in the memory. The 
cache size set as 0 indicates that an unlimited number of pages can be kept in the 
memory.
Virtual Memory Usage Limit – specifies the maximum limit (in megabytes) of the 
available virtual memory.

Gathering Resources
When creating a FormDef or a PageDef, make sure that all of the required resources 
(fonts, forms, and graphics) are available for your design. These resources can reside 
either on the local machine or on a network drive. Along with Elixir and legacy resources, 
Visual PPFA also supports AFP resources without the need of any pre-conversion.

Visual PPFA supports the following input and output formats:

Resource Types Supported Formats

Documents Elixir PageDef (*.epd) 

Elixir FormDef (*.efd) 

AFP PageDef Object (P1*.*, P1*.obj)

AFP FormDef Object (F1*.*, F1*.obj) 

AFP PPFA Source (*.src, *.pfa) 

Elixir AppBuilder 4.xx (Document.dbf) (.dbf documents are only 
supported as an input format).                                                                                                                                                                                                                                                                                                                                                

Overlays Elixir Form (*.efr)     

AFP Overlay Object (*.ove, *.ovl, O1*)    

AFP Overlay Source (OGL) (*.ogl)     

Elixir Legacy Form (*.elx)     

Resource Library (*.erc32, *.erc)         
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Copying Resources to Appropriate Directory
After preparing the resources required for your design, you need to save them in the 
appropriate input directories, keeping in view the specified Visual PPFA input settings. 
Visual PPFA searches these directories for the required resources when a document is 
opened or proofed.

DesignPro Tools for AFP creates a default directory structure for the resources. For 
example, the default destination directory for saving an Elixir PageDef is 
drive:\Elixir\Jobs\Elixir. You can also specify a local or network path for these resources. 
For details, refer to the DesignPro Manager for AFP User Guide.

Fonts True Type Font

Adobe Type Manager Font

Elixir Legacy Font (*.hdr) 

Resource Library (*.erc32, *.erc)

AFP Coded Font (X0*, X1*, X2*, X3*, X4*)

Elixir Legacy Coded Font (X0*.cdf, X1*.cdf, X2*.cdf) 

AFP Character Set (C0*, C1*, C2*, C3*, C4*)

Elixir Legacy Character Set (C0*.hdr, C1*.hdr, C2*.hdr)

AFP Code Page (T1*)

Elixir Legacy Code Page (*.cod) 

Images AFP Page Segment (S1*)

Elixir Legacy Graphic (*.lp3) 

Bitmap Files (*.bmp) 

Joint Photography Experts Group File (*.jpeg, *.jpg) 

Tagged Image Format File (*.tif) 

PC Paintbrush Bitmap File (*.pcx) 

Portable Network Graphics File (*.png)

Resource Library (*.erc32, *.erc)     

Resource Types Supported Formats
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Managing Resource Objects
You can manage and view the resources used in your FormDef and PageDefs using the 
Resource Manager window. You can also view the number of references of a resource, as 
well as their location in your document.

For managing the resource objects:

1 From the menu bar, select View>Resource Manager to display the Resource 
Manager window in the design area.

2 Right-clicking a Resource Manager tree node displays a pop-up menu, which 
options pertain to the current selection.

The Reload option refreshes the Resource Manager tree view. You are 
recommended to refresh this view before performing any action using the Resource 
Manager window.

The Go to first resource reference option shifts the focus of the application to the 
first instance of the resource in the design area.

The Export resource… and Export all Resources… options enable you to export 
one or all embedded resources in the document. Export option selections launch the 
Export To dialog for selecting the Elixir Resource Library file for saving the 
exported resources.

Exporting the embedded resources creates copies of the resources in a 
destination resource library. However, exported resources remain embedded in 
the document.
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The Remove unused resources option removes the unused resource references from 
the Resource Manager tree, thus enabling you to view only those resources used in 
the design. Any unused document resources display a count of zero in the Use Count 
column of the Resource Manager window.

The Embed all resources option embeds all of the referenced resources in a 
document. The Resource Manager monitors the usage of the embedded resources. 
The referenced resources can only be embedded in Elixir format documents. This 
feature is particularly useful in sharing or moving documents between multiple 
machines.

Verifying Resources
When creating the PageDefs and FormDefs, you can verify referenced and embedded 
resources by closing and reopening your document. You can also verify these resources 
later by proofing your document (for details, refer to  Chapter 15: "Proofing Designs" on 
page 239). The Messages window, while proofing or opening your document, displays 
information on the resource path and the encountered errors. These messages help 
determine and troubleshoot incorrect paths and corrupt resources.

Exporting Resources
When saving AFP and Elixir legacy PageDefs and FormDefs, you can export the external 
resources (e.g., forms, fonts, images, etc.) used in your layout. The export path settings 
and properties can be accessed by selecting an appropriate output converter from 
Tools>Application Format Settings>Output Formats options.

You can choose to save all or some specified external resource types used in your design, 
and specify the associated export properties. For more information about the output 
properties options, refer to “Chapter 6: File Format Dictionary” in the DesignPro 
Manager for AFP User Guide.

Selecting Never prevents the export of the specified resource type, whereas selecting To 
External Resource File exports that resource file to the specified location. When 
exporting resources, the exported resources can be saved to either the destination directory 
as the output file, or to the default resource directory specified in the Profile Server. You 
can also choose to overwrite any existing resource file in the specified directory if any of 
the exported resources have the same filename as an existing resource.

External resources are not exported if resources with the same name already 
exist in the Destination Directory, unless the Replace Existing Resources option 
is selected. 
68 DesignPro Visual PPFA User Guide



Embedding Resources
Elixir formats enable you to insert fonts, images, objects, and overlays as embedded 
resources in your design overlay. This feature is especially useful if you need to move or 
change the original resource.

Converting Form, Font, and Image Files to AFP 
Resources

Prior to performing the proofing operations, you need to convert all of the Elixir resources 
including the FormDefs and PageDefs to AFP format. When converting resources to the 
AFP format, ensure that the naming conventions are followed. Refer to the DesignPro 
Manager User Guide for more information about converting form, font, and image files to 
AFP resources. For more information about converting PageDefs and FormDefs to the 
AFP formats, refer to Chapter 11: "Performing Standard Operations on Visual PPFA 
Objects" on page 205.

Elixir Resources versus AFP Resources
Although Visual PPFA supports its own, as well as the native and legacy resource 
formats, it is advisable that you keep a copy of all the source files in the Elixir format. 
Visual PPFA PageDefs and FormDefs support many features that are not available in 
PPFA:

Elixir format facilitates you to use aliases and names up to 32 characters long for 
record, field, and other objects, hence providing ease of design; theses names are not 
saved in the AFP format. 
Internal comments and environmental settings, such as template overlays, are only 
supported in the Elixir format.

The images that are resized while editing an overlay are exported in the form of 
segments, provided they are embedded in the overlay.
Chapter 4: Preparing to Work 69



Changing File Formats
This section provides information about the input parsers and the output converters along 
with their associated properties.

You can modify the input file format settings depending on the properties of your source 
document. You can also specify the output file format settings while saving your 
document to the Elixir, AFP object, or PPFA source formats. The output settings are 
influenced by the target printer properties.

Applying Application Format Settings
Application format settings enable you to specify the input and output format options for 
Visual PPFA. These settings are applied to all of the new documents, as well as to the 
documents that do not have an associated Elixir parameter file. The application format 
settings are applicable to all of the ongoing sessions in the application.

Application Format Commands
You can perform the following application-level operations from the menu bar by 
selecting Tools>Application Format Setting options:

Load the application format settings from an Elixir parameter file (.EPM). 
Reset the .EPM file settings to the default values.
Save the application format settings to an .EPM file.
Specify the input format settings.
Specify the output format settings.
Specify the Elixir properties for application resource handling.

Applying Document Format Settings
Visual PPFA enables you to set input format options at document-level, which override 
the application-level settings.

This feature is useful especially when you are working with multiple documents 
simultaneously. You can have several forms open at the same time, each having its own 
unique input format settings. However, document format settings lose their effect if the 
document is exported to another format.
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Document Format Commands
From the menu bar, select Tools>Document Format Setting to perform the following 
document level operations:

Load the document format settings from an Elixir parameter file (.EPM).
Clear the .EPM file settings to the default values.
Save the document format settings to an .EPM file. 
Specify the input format settings.

Specifying File Format Settings
AFP printers support only AFP format resources. Visual PPFA provides you design 
flexibility by providing options to convert other resource types to AFP formats. The input 
and output format type dialogs associated with the Application Format Setting and 
Document Format Setting options enable you to set and change the format type 
conversion options.

The Input Formats and Output Formats options contain selections for the following file 
types:

AFPDS – Advanced Function Printing Data Streams 
GDF/Elixir Form – Elixir Generic Document Format 
OGL – IBM Overlay Generation Language 
PPFA – IBM Page Printer Formatting Aid 

Changing Input File Format Settings
To change input format settings:

1 Do one of the following:
From the menu bar, select Tools>Application Format Setting>Input Formats to 
change the application-level input file format settings.
Or
From the menu bar, select Tools>Document Format Setting>Input Formats to 
change the document-level input file format settings.

You can set the document format settings and commands only when a document 
is open in the design area.
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2 Select the required Input Formats type.
The associated input format dialog displays with the following category selections:

3 Select the required category from the list.

4 Enter the required settings.

5 Click Apply and OK to save the changes.

Category Name

Error Handling

Font(s)

General

Main

PageDef

Prefix

Resources

Resources - Fonts

Resources - Forms

Resources - Images

Synthesizer

Tags

Encoding
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Changing Output File Format Settings
To change the output format settings:

1 From the menu bar, select Tools>Application Format Setting>Output Formats.

2 Select the required Output Formats type.

3 The associated output format dialog displays with the following category selections:

4 Select the required category from the list.

5 Enter the required settings.

Category Name

Code Pages

Color(s)

Environment

Font(s)

Form(s)

FormDef

General

Images

Main

Page Objects

PageDef

Encoding
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6 Click Apply and OK to save the settings.

Elixir Parameter File (.EPM) 
You can save your input and output file format settings in an Elixir Parameter File (.EPM) 
so that the settings are not lost or forgotten between sessions. You can also transfer your 
.EPM files to other PCs in your workgroup.

Although an .EPM file can hold settings for both input and output files, it is recommended 
to save separate .EPM files for the input and output so that they can be used for different 
conversion combinations.

Loading File Format Settings   
You can load input and output file format settings from an .EPM file at the application 
level by selecting Tools>Application Format Setting>Load from the menu bar. You can 
also load input and output file format settings from an .EPM file at the document level by 
selecting Tools>Document Format Setting>Load from the menu bar. This displays the 
Load Setup File dialog. Browse for the required .EPM file in this dialog. The default Elixir 
parameter files are located at drive:\Documents and Settings\current user\Application 
Data\Elixir Technologies.

Clearing File Format Settings   
You can unload an .EPM file and restore the default file format settings at the application-
level by selecting Tools>Application Format Setting>Clear from the menu bar.

You can also restore the document-level file format settings by selecting Tools>Document 
Format Setting>Clear from the menu bar.

Categories displaying in the input and output format dialogs depend on your 
selected file format type.

Property field definitions for each category are provided in “Chapter 6: File 
Format Dictionary” of the DesignPro Manager for AFP User Guide.
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Saving File Format Settings  
You can save your input and output file format settings to an .EPM file at the application 
level by selecting Tools>Application Format Setting>Save from the menu bar.

You can also save input and output file format settings to an .EPM file at the document 
level by selecting Tools>Document Format Setting>Save from the menu bar. This 
displays the Export Setup File dialog. Browse to the required target folder where you need 
to save the exported file. 
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Chapter 5:

Designing Physical 
Pages

DesignPro Visual PPFA facilitates you to design documents containing variable data. 
Through the use of variable data printing, you can customize your printing material by 
merging the recurring contents with variable data. In the case of PPFA, the recurring 
content is made part of the physical page, and the variable data is specified in the logical 
page. The first step in creating the documents containing variable data involves the 
designing of the physical page. A FormDef object specifies the attributes of the physical 
page. 

This chapter explains the basics, creation and setting of FormDefs. FormDef is short for 
form definition. Both of these terms will be used interchangeably throughout this guide.

Working with Form Definitions
Form definitions (FormDefs) are the resources that specify how the printer controls the 
processing of the physical sheets of paper. FormDefs specify the attributes of the physical 
sheet, such as the paper source, number of copies, required overlay, and simplex/duplex 
settings. FormDefs feature the modifications that distinguish between formatting of 
different print jobs when they are derived from the same data, and can be used for all print 
server files regardless of the data type. Form definitions are always required for printing 
with IBM Print Services Facility (PSF).

In this chapter...

Working with Form Definitions

Creating a FormDef

Setting the FormDef Properties
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DesignPro Visual PPFA provides design support for all of the FormDef features, and 
facilitates you to do the following:

Position a logical page on a physical sheet.
Design simplex or duplex pages, with or without variable data.
Specify print offsets for the front and back sides of a paper.
Specify the print orientation to be either portrait or landscape.
Insert and edit overlays, which substitute for the preprinted forms.
Select the number of copies for any page.
Specify field suppression, which enables you to exclude the selected fields from the 
printed pages.
Design and place up to four logical pages on a single side of the sheet. 
Select from multiple paper sources.
Select the level of the print quality.
Specify the post processing controls such as perforation and cutting, etc.

Visual PPFA facilitates you to create and edit FormDefs that are, by default, saved in the 
Elixir FormDef (*.efd) format. You can open your existing PPFA code directly in Visual 
PPFA, and can even save it in the AFP FormDef object (F1*.obj) or AFP PPFA source 
(*.src) formats without a separate PPFA compiler. Visual PPFA also enables you to load 
FormDefs created in Elixir Application Suite as linked resources.

A single FormDef can contain a multiple set of formatting rules called CopyGroups. A 
CopyGroup defines every physical page in the file. Each CopyGroup can contain up to 
127 SubGroups, each of which creates a different set of modifications for the same page of 
data. CopyGroups specify the same set of properties as FormDefs. Properties specified in 
a CopyGroup override the values specified in the FormDef. 

Property settings at the FormDef level are used as defaults for the CopyGroup 
and SubGroup level, and are applied to each newly created CopyGroup or 
SubGroup.
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Creating a FormDef
Use the following steps to create a new FormDef:

1 From the menu bar select File>New to display the New Resource dialog.

2 Select the FormDef icon, and click OK to create a new FormDef.
The newly created FormDef displays in the design area.

The tree displays the default nodes that highlight the structure of a FormDef object.

Visual PPFA facilitates you to create, open, and edit FormDefs. Once created, you can 
define the FormDef properties and add objects such as CopyGroups, SubGroups, and 
overlays to the FormDef. You can also add, copy, save, and delete the FormDef objects.

You can also display the New Resource dialog to create a new FormDef by clicking 

 on the Standard toolbar.
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Setting the FormDef Properties
The FormDef properties are used to specify the attributes of a physical page. The 
properties are organized into nine categories. Use the following steps to view and set the 
FormDef properties:

1 Right-click the FormDef node in the tree window and select Properties from the 
pop-up menu.
The Properties – FormDef dialog displays.

The Properties – FormDef dialog displaying the General Category options.

2 Select the required category from the Category list.

3 Enter the required settings. For details on your required settings, refer to the relevant 
section below.

4 Click Apply and OK to save the settings.

To launch the Properties – FormDef dialog, select the New FormDef node in the 
tree view and do one of the following:

Select View>Properties from the menu bar 

Click  on the Standard toolbar.
Press <Alt> + Enter from the keyboard.
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Setting a Unique FormDef Name
Assigning meaningful names to FormDefs helps in referencing the resources for later use. 
Visual PPFA assigns a default name and alias to every newly created FormDef. You can 
change the default values in the General category, and specify a unique name and alias for 
the FormDef. This category also displays the date and time the FormDef was created and 
last accessed. The date and time attributes are automatically set by the system and cannot 
be modified.

To set a unique name for a FormDef:

General

Name – sets a unique name to identify the FormDef object with a maximum of six 
characters. 
Alias – sets a unique alternate name identifying the FormDef, which is displayed in 
the tree view.

The FormDef Source tab and the FormDef tree reflect the settings. The FormDef 
tree displays the Alias, whereas in the source tab, the Name is displayed and the 
Alias appears in the form of a comment.

Setting the Physical Page Offsets
The logical page determines the area where you want to place the variable data on the 
physical page. The offset parameters establish the position of the logical page relative to 
the physical sheet of the paper. In the Offset category, you can specify the horizontal and 
vertical attributes of the FormDef front and back offsets.
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The physical sheet front side offset is set to 1 inch to the right and 1 inch down from the 
sheet origin. The logical page boundary displays in the design area to reflect the settings.

To set the physical page offsets:

Front, Back offset

Horizontal, Vertical – sets the horizontal or vertical offset values of the front or 
back side of the FormDef, as per specified unit of measurement.
None – sets the default unit of measurement (for information on specifying the 
default unit of measurement, refer to "Setting the Ruler Options" on page 47. You 
can click the associated arrow to display a drop-down list of other units of 
measurement available for selection. These are inches, centimeters, millimeters, 
points, and pels. 

The Back offset option is only available for duplex printing mode.
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Setting the Page Presentation

Page presentation specifies how printed data is positioned on the physical sheet. A 
FormDef specifies the page presentation using the Presentation and Direction options 
that are provided in the Presentation category of the Properties – FormDef dialog.

To set the page presentation:

Presentation

Presentation – describes the layout of the page. Either:
• Portrait – sets to vertical presentation (page height is greater than the width).
• Landscape – sets to horizontal presentation (page width is greater than the 

height).
Direction – sets the direction of the print. Either:
• Across – prints the logical page from left to right.
• Down – prints the logical page from top to bottom.

The design area reflects the page presentation set to (1) Default setting of Portrait, 
Across and (2) Landscape, Down.

The page Presentation settings only take effect when any of the changeable 
media origin options are selected from the Paper & Printer category in the 
Options dialog.
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Setting the Duplex Printing Options
Visual PPFA enables you to design pages for duplex printing. In the duplex mode, 
printing is done on both sides of the sheet. Duplex printing can be performed in four ways, 
which are specified in the Duplex Printing option of the Presentation category.

To set the duplex printing options:

Presentation

Duplex Printing – sets the required option for duplex printing. Either:
• Simplex – duplex printing is not performed and the printer only prints on one 

side of the paper.

• Normal – prints in normal duplex mode with both sides of the paper having the 
same orientation for side binding.

• RNormal – prints in rotated normal duplex mode with the tops of both sides of 
the paper printed along the same edge. Use this option with landscape 
presentation pages.

• Tumble – prints in tumble duplex mode with the top of one paper side and the 
bottom of the other side along the same sheet edge for top binding.

• RTumble – printing is done in rotated tumble duplex mode with the top of one 
side of the paper printed along the same edge of the sheet as the bottom of the 
other. Use this option with landscape presentation pages.
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The following image illustrates the Normal, Rotated Normal, Tumble and Rotated Tumble 
printing options:

Designing Constant Forms
Constants forms, as the name indicates, do not contain any variable data. Visual PPFA 
provides design support for printing constant forms. In the Presentation category, you 
can specify whether a page prints with or without variable data using the Constant Form 
option.

To design the constant forms: 

Presentation

Constant Form – sets the required option for printing fixed (constant) or variable 
data. Either:
• No – turns off the constant form function, and variable data is printed.
• Front – prints a constant form on the front side of the sheet (i.e., no variable data 

is printed on the front side of the sheet).
• Back – prints a constant form on the back side of the sheet (i.e., no variable data 

is printed on the back side of the sheet).
• Both – prints a constant form on both sides of the sheet (i.e., no variable data is 

printed on either side).
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Placing Multiple Logical Pages on a Sheet
You can place multiple logical pages on a single sheet of paper using the NUP (Number 
UP) feature. You can divide a page into equal-sized partitions, each having its own 
CopyGroup and PageFormat.

The NUP partitions are generally set prior to the Invoke options in a typical workflow for 
using the NUP Type and Invoke options. 

To place multiple logical pages on a single sheet:
NUP Type – sets the required Number Up option for the print layout:
• None – does not use the NUP feature.
• Basic – enables up to four partitions per physical page side. The pages are placed 

in the partition in sequential order. If you select the Basic option and click 

Apply,  is enabled. Click  to display the Basic NUP dialog, which 
specifies the basic NUP settings.

• Enhanced – enables data placement in the specified partitions. If you select the 

Enhanced option and click Apply,  is enabled. Click  to display the 
Enhanced NUP dialog, which specifies the enhanced NUP settings.

You can also use the Invoke feature to specify the placement of the next page in the 
NUP partitions, or the next physical sheet.

Invoke – controls the action when a new CopyGroup is invoked. Either:
• Sheet (Default) – places the subsequent page on a new sheet.
• Next – places the subsequent page in the next selected partition on the same 

sheet.
• Front – places the subsequent page in the next selected front partition on the 

same sheet.
• Back – places the subsequent page in the next selected back partition on the same 

sheet.

For more information on designing NUP layouts, refer to "About NUP" on page 
107.
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Selecting a Paper Source
When working with printers that support multiple paper sources, the decision about the 
paper source can be made at design time. In the Bin category, you can specify the paper 
source to be used. Options provided in the Properties - FormDef dialog include the 
selection of the paper source type, media name, component ID, output bin, and bin error 
settings.

To set a paper source:

Source Bin

Source Bin – sets the required paper source. Either:
• Default – sets the default paper source.
• Envelope – sets the envelope paper source.
• Manual – sets the manual paper feed as the paper source.
• Other – sets any available paper source.

The associated box displays the bin number of the paper source corresponding to 
the option selected in the Source bin list. The Default, Envelope, and Manual 
options have fixed bin numbers. To enter a bin number value other than the 
predefined value, select Other, and then type the value in the box. Set the value 
in the range 1-255.

Media Name – specifies an agreed upon media name for the source bin. In case of a 
number of printers, the media name is already set, whereas you can also add the 
name in other printers. Selecting the Media Name check box enables the associated 
list that displays the available media names.
Comp ID – selects a paper source bin based on the component ID. Selecting the 
Comp ID check box enables the associated list that displays the available 
component IDs. 

Output Bin

Out bin – sets the destination bin number. Set the value in the range 1-255.
Jog – offsets the printout stack parts in the destination bin.

If no partitions are specified for Next, Front, and Back options, the data is 
placed on the next sheet.
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Bin Error
Specifies the printer behavior when any error is encountered. Either:

Stop – stops and holds the print job if the specified bin is not found.
Continue – continues the print job using the default bin if the specified bin is not 
found.

Applying Finishing Operations
You can use the FormDef object to request various operations with printers that support 
finishing operations. The finishing options are organized in three categories in the 
Properties – FormDef dialog. The Finishing category specifies the print job staple, fold, 
cut, and perforate options. 

Setting the finishing operations at the FormDef level applies the operations to all the print 
files and documents. The finishing options are device dependent; therefore, you are 
recommended to check your selections for compatibility with your printing device.

Click  to add a finishing operation to the selected operations list. Click  to delete 
options from the list. You can specify the following finishing operation options:

Scope – specifies the page limit up to which the finishing operations are applied. 
Select the required option from the following:
• Printfile – applies the finishing operation to the print file, excluding the header, 

trailer, and message pages.
• All – applies the finishing operation to the entire print file, including header, 

trailer, and message pages.
Type – specifies the type of finishing operation. Select the required option from the 
following:
• AFP – applies the Advanced Function Presentation (AFP)-specific operations.
• UP3I – passes the operations to the printer using the Universal Printer Pre- and 

Post-Processing finishing Interface (UP3I). 

Operation – sets the finishing options to be displayed depending upon your 
selection of the Type option (above). The following options are available if you 
select AFP in Type:

UP3I is an open standard intelligent interface intended for printers, pre-
processors, post-processors, and other related applications. 
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• CFoldIn – the center fold in; folds the sheet inwards along the center line 
parallel to the finishing operation axis.

• Corner – applies a staple into the media at the specified reference corner.
• Cut – applies a separation cut to the media along the finishing operation axis.
• Edge – applies one or more staples into the media along the finishing operation 

axis.
• Fold – folds the media along the finishing operation axis.
• Perforate – applies a perforation cut to the media along the finishing operation 

axis.
• Punch – inserts one or more holes into the media along the finishing operation 

axis.
• Saddle – applies one or more staples into the media along the finishing operation 

axis, and the media is folded outwards at the axis.
• SaddleIn – applies one or more staples into the media along the finishing 

operation axis, and the media is folded inwards at the axis.
X Operation – sets the required device-specific finishing option from the available 
list. These options are only applicable to the UP3I operations.

Reference – specifies the reference corner for the finishing operations. Either:
• Default – sets the default edge as the reference edge.
• Top Left – places the reference corner at the top left of the medium.
• Top Right – places the reference corner at the top right of the medium. 
• BotRight – places the reference corner at the bottom right of the medium.
• BotLeft – places the reference corner at the bottom left of the medium.
Offset Value – specifies the offset of the axis of the finishing operation from the 
reference edge. Set the value in the range 0 - 32767. This option is activated when 
AFP CFoldIn, Cut, Edge, Punch options, or any of the UP3I options are selected 
(above).

For more information on the UP3I finishing operations, refer to the 
complete UP3I specification document which can be viewed at the UP3I 
website homepage http://www.up3i.org.
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Count value – specifies the number (count) of the selected finishing operations. Set 
the value in the associated box within the range 1-122. This option is only activated 
when AFP Edge, Fold, Perforate, Punch, Saddle, SaddleIn options, or any of the 
UP3I options are selected (above).
Position value – specifies the offset as well as the axis of the finishing operation. Set 
the value in the range 0 - 32767. This field is only activated when AFP Edge, Punch, 
Saddle, SaddleIn options, or any of the UP3I options are selected (above).

You can create a finishing offset list by selecting a position value and then using  

and  to add or remove offsets from the list.

If a printer does not support the finishing operations specified in the Finishing category, 
an error is encountered. You can use the Finishing Error category options to select the 
job continuation and error reporting options. An error may be encountered when a 
finishing operation is not available to the printer.

To set the job continuation options:

Finishing Error

Stop – terminates the print job if a finishing error is detected.
Continue – continues the print job without the unavailable finishing operation.
Error Report – creates an error report for the finishing operation.

You can also specify additional post-processing capabilities for some selected printers by 
using the Processing category options. The processing capabilities can be applied to 
single or multiple pages.

To specify the processing options:

Type of cut
Sets one of the following cuts for the required printing devices at one or more fixed sheet 
locations:

Perforation cut
Separation cut
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Select fixed medium

Select fixed medium – activates the fixed media ID list. To apply a printing device 
fixed media to the physical page, select the corresponding ID in the fixed media ID 
list. You can select multiple IDs using this option.
Use all of the current medium – applies all of the fixed media to the physical page.

Setting Print Quality and Control Parameters
For printers that support multiple levels of print quality, you can specify the print quality 
at design time. In the Print Control category, you can specify the quality and control 
parameters for the selected AFP printers.

To set the print quality:
Pels per inch – specifies the print resolution value in pixels per inch. 
Quality – specifies the level of the print quality. Set the value in the range 1-10.
Cut Sheet – provides the information on the orientation of the medium, specified in 
the Presentation category, to the cut-sheet printers.
Font Fidelity – sets the font fidelity. If a raster font is not found on a printer, it is 
replaced by an outline font. This type of font substitution can cause the text to either 
overflow or underflow in the intended space on the page.

3800 Printer Only

Adjust – specifies the range of the horizontal adjustment of the print area on the 
sheet for an IBM 3800 printer. Set the value in the range 1-20; the default value is 0.

Color Value Error

Stop – terminates the print job and issues an error if the FormDef contains color 
values that the printer cannot render.
Continue – ignores the color exception and continues the current job by substituting 
colors for those FormDefs which cannot be rendered.
Error Report – prints the color error report; this field is only activated when 
Continue is selected.
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4000 Printer Only
You can also specify different levels of print quality with a unique, four-digit identifier for 
an IBM 4000 printer.

Verification ID – sets a unique, four-digit setup verification ID in hexadecimal 
format. The ID is propagated to all of the CopyGroups in the FormDef.

Click  to add the Verification ID to the control list for future use. To remove the 

identifier from the list, click  .

Toner Saver

Device Settings – activates the device-specific toner settings.
On – activates the toner saver mode.
Off – deactivates the toner saver mode.

Adding Comments
In the Comment category, you can add comments to the FormDef object. These 
comments can be viewed with the application source code in the Visual PPFA source 
view.

Comments

Comment Sub-command – sets special descriptive comments for the FormDef or 
PageDef object. 

Setting the toner saver feature can affect the quality as well as the performance of 
the printer.

Comments are converted with the application to (.OBJ) format. Therefore, they 
can be viewed both with the compiled PageDef, as well as the FormDef object 
code in an AFP environment.
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Programmer Comments – sets descriptive comments for the application objects.

Programmer Comments and Comment Sub-command displaying in the Source view. 

The specified Name, Alias, and Comments are retained in the object format 
and can be viewed when the FormDef is loaded again.
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Chapter 6:

Working with 
FormDef Lists and 
Objects

This chapter describes the FormDef objects, lists, and associated overlays, including their 
creation, modification, and property definition. It also provides detail on the basic and 
enhanced NUP.

About FormDef Lists
You can set up a number of lists that DesignPro Visual PPFA offers before starting the 
actual design process. This enables you to design your documents easily and more 
efficiently. A FormDef object can only contain one list, called a suppression list, which 
facilitates you to define the suppressed fields for storage and reuse.

Working with a Suppression List
You can customize your document by preventing (suppressing) some selected data from 
being printed on a page. The suppressions are created in a PageDef and are used in a 
FormDef. To suppress fields for a SubGroup, choose a unique name identifying the 
suppression, and add it both to the field that needs to be suppressed, and to the SubGroup 
that prints when the fields are suppressed. 

In this chapter...

About FormDef Lists

About FormDef Objects

About NUP

Viewing Full Preview
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The unique suppression names are added to the suppression list. The names that are 
included in the list appear in the Available Suppressions list for the SubGroup, thereby 
making it easy for you to specify SubGroup suppressions. You can specify a maximum of 
127 suppressions in the suppression list, and 8 suppressions for a SubGroup.

Adding a Suppression List
To add a suppression list, right-click the New FormDef node and select Insert, 
Suppression List from the pop-up menu. A Suppression List node is added in the 
FormDef tree.

The FormDef Tree with the newly added Suppression List..  

Adding Suppressions to a Suppression List
You can add suppressions to the newly created suppression list using the following 
procedure:

1 In the FormDef tree, right-click the Suppression List node. 

You can also add a suppression list by selecting the New FormDef node and 
performing one of the following functions:

From the Insert menu, select Lists, Suppression List.

Click  on the Insert toolbar, and then click .
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2 Select Properties from the pop-up menu to display the Properties – Suppression List 
dialog.

 

3 Enter a unique name identifying the field to be suppressed in the Suppression 
textbox. 
The name can only contain alphanumeric characters with a maximum length of eight 
characters.

4 Click  to add the suppression name to the Suppression list; click  to delete 
the selected suppression from the list.

5 Click Apply and OK to save the settings.

About FormDef Objects
A FormDef comprises a number of objects that include CopyGroup, SubGroup, and 
overlays. The CopyGroup and SubGroup objects are always needed with a FormDef, and 
every time you create a FormDef, the CopyGroups and SubGroups are, by default, added 
in it. The overlay object is optional and needs to be added explicitly. You can, however, 
specify additional CopyGroups, SubGroups, and overlays for a FormDef, as per your 
requirements. You can also view objects in the design area, and set or modify their 
properties.
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Working with CopyGroups
A FormDef can contain multiple sets of attributes defining the physical page called 
CopyGroups. A CopyGroup defines one set of attributes for a physical page in the 
document. This includes:

Position of the logical page.
Selection of simplex or duplex printing.
Selection of cut-sheet paper type among multiple paper sources.
Offset stacking or copy marking of discrete print job parts in an output stacker.
Printing multiple logical pages on a single side of a physical page.
A number of post-processing operations for a print job.
Level of the print quality.

Multiple CopyGroups can be used depending on the printing requirements, as well as the 
data. A single page of data can be printed using different layouts, requiring multiple 
CopyGroups. Similarly, you can also print multiple pages of data using the same layout 
utilizing a single CopyGroup. Each FormDef can comprise a maximum of 255 
CopyGroups. The CopyGroups are placed within a FormDef in the order they are 
generated. When working with multiple CopyGroups, switching between the CopyGroups 
is done using conditional processing.

For duplex mode, when data is printed on both sides of the physical sheet, a CopyGroup 
specifies attributes for both of the sides. Each CopyGroup can contain up to 127 
SubGroups, each of which creates a different set of modifications for the same page of 
data.

Adding a CopyGroup
To add a CopyGroup, right-click a node in the FormDef tree, and select Insert> 
CopyGroup from the pop-up menu. A New CopyGroup node displays in the FormDef 
tree.

The Form Def Tree displaying the added CopyGroup. 
98 DesignPro Visual PPFA User Guide



Setting CopyGroup Properties
To set the CopyGroup properties:

1 Right-click the New CopyGroup node in the FormDef tree window and select 
Properties from the pop-up menu to display the Properties – CopyGroup dialog.

 

2 Select the required category from the Category list.

3 As appropriate, enter or review the dialog options.

4 Click Apply and OK to save the settings.

The CopyGroup object supports the same set of properties as the FormDef object does, 
with a few exceptions. You need to replicate the FormDef settings at the CopyGroup level 
for the first CopyGroup to achieve the required results; but each newly created 
CopyGroup inherits the specified FormDef settings.

The procedure for setting a unique CopyGroup name, along with the physical page offsets, 
page presentation, duplex printing options, designing constant forms, and placing multiple 
logical pages on a sheet for a CopyGroup object is the same as those defined at the 
FormDef level.

You can also add a CopyGroup by selecting any node in the FormDef tree and 
performing one of the following functions:

From the Insert menu, select CopyGroup. 

On the Insert toolbar, click .
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Similarly, the procedure for selecting a paper source at the CopyGroup level is not 
different than that defined at the FormDef level; the only difference being the Bin Error 
settings. The Bin Error settings are provided at the FormDef level, and not at the 
CopyGroup or SubGroup levels. 

The finishing operations specified at the FormDef level are applied to the entire document. 
To apply finishing operations to individual sheets or a collection of pages, the operations 
need to be specified at the CopyGroup level. The finishing options available at the 
FormDef and CopyGroup levels are similar to each other; the only difference is the Scope 
at which the operations are applied.

To specify Scope at the CopyGroup level, review the dialog options:
Scope – Specifies the pages on which the finishing operations need to be applied:

• Sheet – finishing operation is applied to a single sheet. ZFold causes the sheet to 
be folded half inwards along a line parallel to the reference edge. The half of the 
sheet that is originally farther from the reference edge is again folded half 
outwards along a line parallel to the reference edge. The Offset, Count, and 
Position fields are disabled for this option.
You can also nest the finishing operations. To nest the finishing operations with a 
CopyGroup, you can define the BegColl (begin collection) and ContColl 
(continue collection) parameters. As a result, the continuing finishing operation 
is not stopped when another one is started.

• BegColl – causes a sheet eject and starts the CopyGroup media collection for the 
specified level. If a collection for the same finishing operation is already in 
progress from a previous CopyGroup, that collection is ended and its specified 
finishing operation is applied. The media collection that started with BegColl 
continues until either the end of the document is reached, or a CopyGroup is 
invoked, which does not specify ContColl for the same operation. When a 
finishing collection is ended, the specified finishing operation is applied.

• ContColl – continues with the CopyGroup media collection that started earlier 
for the same finishing operation by a previous CopyGroup. The media collection 
started with ContColl continues until either the end of the document is reached or 
a CopyGroup, which does not specify ContColl with the same operation, is 
invoked. When a finishing collection is ended, the specified finishing operation is 
applied.

When a finishing operation is not available to the printer, the job continuation and error 
reporting options can only be specified at the FormDef level. The procedure used to 
specify the additional post-processing capabilities for selected printers for the CopyGroup 
object is the same as the one defined for the FormDef object.
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At the CopyGroup level, you can only specify the print quality parameters of Pels per 
inch, Quality, and the Adjust parameter. These parameters are for the IBM 3800 printer, 
and are in the Print Control category. You can also specify the Cut Sheet option to pass 
medium orientation information to cut sheet printers. You can also specify the 
Programmer Comments in the Comment category for the CopyGroup object.

Working with SubGroups
A SubGroup, which is the subset of a CopyGroup,defines a single side of a physical paper. 
You can also use a SubGroup to print varying data on each side of the paper. For example, 
you can use one type of data or overlay on one side, and another type on the other side of 
the paper.

You can also use a SubGroup to print a single page in multiple ways. For example, you 
can print both an invoice and its associated packing list from the same data file by 
applying different sets of suppression and/or conditional processing modifications.

Each CopyGroup can comprise a maximum of 255 SubGroups. By using a SubGroup, you 
can perform the following functions:

Specify suppressions for the page.
Specify the overlays to be used. 
Select an input bin.
Specify the number of copies of the SubGroup to be printed.
Select the forms flash feature for IBM 3800 printers.

For more details, refer to the corresponding tasks in Chapter 5: "Designing Physical 
Pages" on page 77.
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Adding a SubGroup
To add a SubGroup, right-click either the CopyGroup or the SubGroup node in the 
FormDef tree, and from the pop-up menu select Insert, SubGroup. A new SubGroup 
node displays in the FormDef tree. 

 

The FormDef Tree with the newly added SubGroup.

Setting SubGroup Properties

To set the SubGroup properties:

1 Right-click the SubGroup node in the FormDef tree, and select Properties from the 
pop-up menu to display the Properties – SubGroup dialog.

You can also add a SubGroup by selecting either the CopyGroup or the 
SubGroup node in the FormDef tree, and performing one of the following 
operations:

From the Insert menu, select SubGroup.

On the Insert toolbar, click .
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2 Select the required category from the Category list.

3 Enter the required settings.

4 Click Apply and OK to save the settings.

Many of the options available at the SubGroup level are also specified at the FormDef, as 
well as the CopyGroup levels. However, you need to define these options at the SubGroup 
level in order to achieve the required result.

The procedure to set up a unique SubGroup name is the same as the one defined for the 
FormDef object. For more details, refer to Chapter 5: "Designing Physical Pages" on 
page 77.

A paper source is selected at the SubGroup level using the Bin category options. This is 
the same procedure as defined at the CopyGroup level; the only difference is with regard 
to the Jog settings that are not provided at the SubGroup level.

The procedure for adding Programmer Comments for a SubGroup object is also the same 
as that defined for the CopyGroup object.

Specifying the SubGroup Presentation Options
You can specify the SubGroup print presentation settings, including the number of copies 
of each page, the sheet side on which the SubGroup is to be printed, and the optional form 
flashing features for IBM 3800 printers, using the Presentation category options.

To set the print presentation settings: 

Presentation

Copies – specifies the number of copies of the SubGroup that needs to be printed. 
Set the value in the range 1-255.

Sheet Side

Both – prints the SubGroup on both (front and back) paper sides.
Front – prints the SubGroup only on the front side of the paper.
Back – prints the SubGroup only on the back side of the paper.

Form Flash, 3800 Printer

Flash – uses Form Flash to print the user-prepared images.
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Defining Suppressions for a Page
You can create several variations of the same document in a single print job by preventing 
the selected application data from being printed on a page. The fields to be suppressed are 
assigned a unique label in the PageDef. The labels are then added to the SubGroup that 
represents the page on which the fields are to be suppressed.

You can add unique suppression names to the suppression list. The names that are 
included in the list appear in the Available Suppressions list for the SubGroup, thereby 
making it easy for you to specify the SubGroup suppressions. 

To define suppressions for a page:

1 From the Suppression category, select a suppression from the Available 
Suppressions list. 

2 Click  to add the selected suppression to the Used Suppressions list.
You can also add suppressions to the list by entering a unique suppression name, not 

more than 8 characters in length in the associated text box, and clicking . The 
suppression is added to both the Available Suppressions and Used Suppressions lists.

Click  to remove the selected suppression from the Used Suppressions list, and 

put it back to the Available Suppressions list. Click  to delete the selected 
suppression from the list. However, the suppressions that are added to the Used 
Suppressions list cannot be deleted. The changes are also reflected in the suppression 
list. A suppression list is created by default if it is not already defined prior to 
specifying the suppressions for a SubGroup.

Colored borders identify the suppressed fields in the design area.
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Working with Overlays
An overlay is a static form comprising predefined, constant data such as lines, shading, 
text, boxes and logos. You can use an overlay to add a constant form to a FormDef, which 
is then printed on each physical page. Using an overlay eliminates the need for pre-printed 
forms.

Overlays can be merged with variable data to produce variable data documents during 
print operations. You can map and print logical page records and fields on these static 
forms.

Overlays are added to the SubGroup node of the FormDef tree. Each SubGroup can 
comprise a maximum of 255 overlays. Once created and added to the tree, you can view 
the overlays in the design area, and set or modify the overlay properties. You can also 
position an overlay on a page by setting horizontal and vertical offsets.

Adding Overlays
To add an overlay to the FormDef tree:

1 Right-click a SubGroup node in the FormDef tree, and from the pop-up menu select 
Insert, Overlay. 
The Overlay dialog displays.

2 Browse for the required overlay in the dialog.

3 Click Open to open the selected overlay, and return to the design area. 
The overlay node is added to the FormDef tree, and the overlay displays in the 
design area.

The FormDef Tree with the added overlays.
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Setting Overlay Properties
To set the overlay properties:

1 In the FormDef tree, right-click the overlay node and select Properties from the 
pop-up menu to display the Properties – Form dialog.

2 Select the required category from the Category list.

3 Enter the required settings.

4 Click Apply and OK to save the settings.

Setting Overlay Display Properties
You can select an overlay other than the one inserted in the FormDef tree using the 
General category options. You can also choose to hide or display the overlay in the design 
area.

You can also add an overlay by selecting the NewSubGroup node in the FormDef 
tree, and performing the following functions:

From the Insert menu, select Overlay.

On the Insert toolbar, click .
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To set the display options for the overlay: 

General

Name – displays the unique name identifying the selected overlay. You can change 

the overlay by clicking , which displays the Open Resource File dialog. In the 
dialog, browse and select the required overlay. The new overlay replaces the old one 
in the design area, and the Name is also updated to reflect the change.
Include in Presentation – displays the selected overlay in the design area.

The procedure to set the overlay offsets is the same as that for setting the FormDef offsets. 
For more details, refer to Chapter 5: "Designing Physical Pages" on page 77.

About NUP
The Number Up (NUP) printing option facilitates you to place multiple pages on a single 
sheet of paper. You can place up to four pages in the simplex mode, and eight pages in the 
duplex mode. The sheet is divided into equal sized areas called partitions where the pages 
are placed. NUP can be applied at two levels: 

Basic NUP – pages are placed in the partitions in sequential order. 
Enhanced NUP – pages are placed in the partitions in any sequence. 

The NUP options are available at the FormDef and CopyGroup levels. If NUP settings are 
applied at both the FormDef as well as the CopyGroup levels, the CopyGroup level 
settings are applied, as they have a much higher priority. The FormDef level settings act as 
defaults for the CopyGroups that do not have any defined NUP settings. For example, if 
you need to design two CopyGroups having the same NUP settings and pageFormat, but 
with one CopyGroup carrying some of the suppressed fields, the NUP settings need to be 
applied at the FormDef level to avoid any duplication. Visual PPFA provides design 
support for all of the NUP features.

When using the supporting resources (e.g., fonts, images, etc.) in an overlay, the 
overlay must be converted along with the associated PageDef or FormDef. For 
more information on converting overlays, refer to “Chapter 6: File Format 
Dictionary” in the DesignPro Manager for AFP User Guide.
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Selecting NUP Type
The NUP type selection depends upon the nature of the design. NUP Type options are 
provided in the Presentation category at both the FormDef, as well as the CopyGroup 
levels. At the FormDef level, the available options are:

NUP Type – specifies the required number up print layout options from the 
following:
• Default – applies the FormDef level settings to the CopyGroup.
• Basic – facilitates the use of up to four partitions per physical page side. The 

pages are placed in the partitions in sequential order. Selecting Basic as the NUP 

Type and clicking Apply enables , which displays the Basic NUP dialog. 
Use the dialog options to specify the Basic NUP settings.

• Enhanced – facilitates the data placement in the specified partitions. Selecting 

Enhanced as the NUP Type and clicking Apply enables , which displays 
the Enhanced NUP dialog. Use the dialog options to specify the Enhanced NUP 
settings. 

Working with Basic NUP
You can divide a sheet into equal sized partitions on each sheet side using the basic NUP. 
The data is placed sequentially from one partition to the next; the order in which data is 
placed into partitions cannot be otherwise specified or controlled. The basic NUP overlays 
are repeated in each partition.

Setting Basic NUP Properties
You can set the basic NUP properties in both the FormDef, as well as the CopyGroup 
objects using the Basic NUP dialog.
To set the basic NUP properties: 

1 In the CopyGroup Properties, select a Number Up partitioning option from NUP 
Type. You can create 1-Up, 2-Up, 3-Up, or 4-Up documents by choosing 1, 2, 3, or 
4 respectively from the list.
The FormDef or CopyGroup presentation options of Presentation, Direction, and 
Duplex Printing are reflected in the corresponding fields in the Basic NUP dialog. 
The settings also display in the Preview area in the dialog.

2 You can specify the overlays using NUP Properties options. 
In case of basic NUP, the added overlay displays in every partition on the sheet. 
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3 To add an overlay, click . 
A new row is added to the NUP Properties area.

4 Click  to open the Open Resource File dialog. 

5 Browse and select the appropriate overlay. 
The name of the overlay displays in the Overlay column. In a similar way, you can 
add multiple overlays. All of the added overlays display in each of the NUP 
partitions.

A 4-Up Basic NUP document with a single overlay added.
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6 You can accurately position the added overlay by specifying the following:
XOffset, YOffset – sets the horizontal and vertical offset values of the overlay.
Rotation – rotates the overlay to 0, 90, 180, or 270 degrees. 
Origin – sets the point of origin for the overlay:

• Page – measures the X and Y offsets relative to the origin of the page.
• Partition – measures the X and Y offsets relative to the origin of the partition.

7 Click OK to save the settings.

You can remove an overlay by selecting it in the NUP Properties area, and then clicking 

. The basic NUP node displays in the FormDef tree, along with the added overlays.

You can also specify the overlays to be used along with their associated properties in the 
Properties – NUP dialog. You can launch this dialog by right clicking the NUP Basic 
node and selecting Properties from the pop-up menu.

Working with Enhanced NUP
In addition to some new options, the enhanced NUP supports all of the basic NUP 
features. The enhanced NUP performs the partitions of simplex or duplex documents into 
equal sizes. By using a maximum of eight partitions, you can put pages in any sequence, 
specify unique overlays for each page, and rotate both the page as well as the overlays in 
the partitions. You can also place multiple pages in a single partition with no pages in the 
other partition. You can also extend pages across the partition boundaries; which is ideal 
for booklet layouts, as you can sequence paper partitions in a particular fill order.

Setting Enhanced NUP Properties
You can set the enhanced NUP properties in both the FormDef, as well as the CopyGroup 
objects using the Enhanced NUP dialog.

To set the enhanced NUP properties: 

1 In the CopyGroup Properties, select a Number Up partitioning option from NUP 
Type. You can create 1-Up, 2-Up, 3-Up, or 4-Up documents by choosing 1, 2, 3, or 
4 respectively from the list.
The FormDef or CopyGroup presentation options of Presentation, Direction, and 
Duplex Printing are reflected in the corresponding fields in the Enhanced NUP 
dialog. The settings also display in the Preview area of the dialog.
Depending on the number of partitions and the selected duplex printing option, rows 
are added to the NUP Properties area.
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2 You can specify the overlay for each partition by selecting the partition in the NUP 

Properties area and clicking  in the NUP Overlay area. 
This displays the Open Resource File dialog. 

3 Browse and select the appropriate overlay. 
The name of the overlay displays in the Name list. You can add multiple overlays 
using the same procedure, and all of the added overlays display in the specified NUP 
partition.
On adding an overlay, the associated options are enabled where you can accurately 
position the added overlay. This is achieved by selecting the overlay in Name and 
specifying the following:

Offset

Horizontal, Vertical – Sets the horizontal and vertical offset values of the overlay, 
per specified unit of measurement.
Origin – Sets the point of origin for the overlay. The available options are:

• Page – measures the X and Y offsets relative to the origin of the page.
• Partition – measures the X and Y offsets relative to the origin of the partition.

Rotation – rotates the overlay to 0, 90, 180, or 270 degrees.
Click Apply to save the settings. You can remove an overlay by selecting it in the 

Name list, and then clicking  .

4 Specify the order sequence in which data populates each of the partition, by clicking 

 to move up and  to move down through the partition list.
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5 You can set the properties of each partition by selecting the partition in the NUP 
Properties area and specifying the following:

Partition – specifies the partition in which you want to put the page. The 
available options depend on the Partition option selected in CopyGroup 
Properties.

Side – sets the paper side where you want the partition to print.
• Front – prints the partition on the front side of the sheet. 
• Back – prints the partition on the backside of the sheet. The Back option is 

available only with the duplex options.
XOffset, YOffset – sets the horizontal and vertical offset values of the partitions.
Rotation – rotates the overlay to 0, 90, 180, or 270 degrees.
Constant – restricts variable data from being printed in the selected partition.
View – enables viewing the partition overlays.

6 Click OK to save the settings.
The enhanced NUP nodes, one for each partition, display in the FormDef tree along 
with the added overlays.
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You can also specify the enhanced NUP options in the Properties – NUP dialog. You can 
launch this dialog by right clicking any of the enhanced NUP nodes and selecting 
Properties from the pop-up menu.

You can also change the overlays being used by right-clicking the respective overlay node 
and selecting Properties from the pop-up menu.
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Viewing Full Preview
The Visual PPFA Full Preview feature enables you to view the effect of the page 
presentation in the design area. You can disable the full preview feature to discard any 
page presentation settings that helps in the design process. To enable full preview, from 

the View menu select Full Preview, or click  on the View toolbar.

1) Full Preview Off and (2) Full Preview On.
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Chapter 7:

Designing Logical 
Pages

DesignPro Visual PPFA facilitates you to create variable data documents by dividing the 
design process into two parts. The recurring content is part of the physical page, which is 
defined by a FormDef object. Once the physical page is defined, the next step is to design 
the logical page that contains the variable data. A PageDef object specifies the attributes 
of the logical page.

This chapter explains the basics, creation, and settings of PageDefs. A PageDef is short for 
page definition, and both of these terms can be used interchangeably.

About Page Definitions
Page Definitions are control resources that manage the formatting and printing of logical 
pages. Designing the logical page deals with how you want to position the variable line 
data on a page. The logical page merges with the physical page to give the final print 
output.

DesignPro Visual PPFA supports two types of line data: 
Traditional line data comprised of fields and records for printing on a line printer. 
Record Format line data using a record ID to identify each record. 

You can design the PageDef as either Traditional or Record Format, depending on the type 
of line data being used.

In this chapter...

About Page Definitions

Creating a PageDef

Setting PageDef Properties
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DesignPro Visual PPFA provides design support for all of the PageDef features and 
facilitates you to perform the following functions:

Set the dimensions of the logical page.
Set the print direction of the logical page.
Set the text line and field print direction relative to the logical page.
Apply conditional processing to switch between pages.
Specify the spacing of the text line.
Specify options relating to individual text line and field positioning.
Specify the number of text lines per page.
Specify page segments for inclusion in the printed output.
Specify the floating overlays for inclusion in the printed output.
Specify the page ejection points.
Specify the page fonts, and set the font rotation.
Print more than one sub page on each paper side (Multiple up printing).
Specify the page colors (on printers that support colors).

Just as a FormDef object can contain multiple CopyGroup objects, a PageDef object can 
contain more than one pageFormats. The pageFormats specify the same set of properties 
as the PageDef does; however, the properties specified at the pageFormat level override 
the values specified at the PageDef level. Switching between multiple pageFormats can be 
handled by adding the related information to the data file, or by using conditional 
processing.

By default, the PageDefs are saved in Elixir PageDef (*.epd) format. DesignPro Visual 
PPFA also provides converter options for opening and saving PageDefs in AFP (*.obj), 
PPFA (*.src) and Elixir PageDef (.epd) formats. For Elixir Application Suite users, the 
existing AppBuilder FormDefs and PageDefs (*.dbf) can also be migrated to Visual 
PPFA. However, the legacy files opened in Visual PPFA cannot be saved to legacy format 
after modification.

The process of designing a PageDef in either Traditional or Record Format is the same, 
except for a few differences, which are explicitly covered later. 
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Creating a PageDef
To create a new PageDef:

1 From the menu bar, select File>New to display the New Resource dialog.

2 Select the PageDef Traditional icon to design the PageDef using Traditional data, or 
the PageDef Record Format icon to design the PageDef using the Record Format 
data.

3 Click OK to create a new PageDef.
The newly created PageDef displays in the design area.

The PageDef tree displays the default nodes that highlight the structure of a PageDef 
object. The Template Tree displays the template overlays used in the design process.

Visual PPFA facilitates you to create, open, and edit the PageDefs. Once created, you can 
specify the PageDef properties and add objects such as pageFormats, records, and fields, 
etc. to the PageDef. You can also add, copy, save, and delete the PageDef objects, as 
required.
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Setting PageDef Properties
The PageDef properties are used to specify the attributes of the logical page. To view and 
set the PageDef properties:

1 In the PageDef tree, right-click the New PageDef node and select Properties from 
the pop-up menu.
The Properties – PageDef dialog displays.

The Properties – PageDef dialog for Traditional PageDef displaying the General 
category options. 

You can also display the New Resource dialog to create a new PageDef by clicking 

 on the Standard toolbar.

The Properties – PageDef dialog displays the properties depending on the type of 
the PageDef (Traditional or Record Format).
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2 Select the required category from the Category list.

3 Enter the required settings.

4 Click Apply and OK to save the settings.

The property settings at the PageDef level are used as defaults for the pageFormat level, 
and are applied to each newly created pageFormat. However, these settings are not 
inherited by the default pageFormat created with the PageDef, and hence need to be 
explicitly defined.

Setting PageDef Name
Visual PPFA assigns a default name and alias to each newly created PageDef. You can 
change the default values to meaningful names for easy referencing of the PageDef 
resources. In the General category, you can specify a name and alias for the current 
PageDef. It also displays the creation and last accessed date and time of the PageDef 
object.

To set the name of the PageDef:

General

Name – identifies the PageDef object with a maximum of six characters. 
Alias – sets an alternate name identifying the selected item. The alias displays in the 
tree view.

Setting up Page Numbers
The page-numbering options can also be set at design time. You can choose to use 
different page counting schemes for pages defined by each PageDef. In the General 
category for Record Format PageDef, you can specify the Page Count options, as per 
your requirements. 

To launch the Properties – PageDef dialog, select the PageDef node in the PageDef 
tree, and perform one of the following operations:

From the menu bar, select View>Properties.

Click  on the Standard toolbar.
Press <Alt> + Enter from the keyboard. 
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To set up the page numbering option:

Page count

Page Count – specifies how the page numbering is to be handled when switching 
between pageFormats. Either:
• Stop – stops the current page count.
• Resume – resumes page count from the value attained the last time the 

pageFormat was called.
• Reset – resets to the Page Count start value.

In the associated box, type or select the Page Count start value. 
CMP – includes the embedded MO: DCA (Mixed Object Document Content 
Architecture) pages in the page counting.
CCP – includes the constant pages in page counting. 

Setting the Logical Page Margins
The logical page determines the area on the physical page where you want to place your 
variable data. Within the logical page, you can set the margins that define the area in 
which the data is placed. The page header and trailer data can only be placed in the 
margins. For Traditional PageDefs, you can specify the starting point for the first line of 
data inside the logical page using the Margins category.

To set the logical page margins for a Traditional PageDef:

Lineone 

Horizontal, Vertical – sets the horizontal and vertical offset values, per specified 
unit of measurement. 
None – displays a list of available units of measurement respective to the Horizontal 
and Vertical offsets. You can select inches, centimeters, millimeters, points, pels, or 
the default measurement unit, as per your requirement.

For Record Format PageDefs, left and right margins are also defined in addition to the top 
and bottom margins. These margins form a bounding box. 
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To set the margins for a Record Format PageDef:

Margins

Left, Right, Top, Bottom – sets the offset values that are available for selection for 
the left, right, top, and bottom margins, per specified unit of measurement. 
None –sets the unit of measurement respective to each of the Margins fields.

In a Record Format PageDef, if the text orientation is changed, the same bounding box 
defined by the margins applies to the new orientation, but the names of the margins 
change in the new orientation, as illustrated below. 

Displaying the impact of print direction on margins in a Record Format PageDef in (1) 
Across. (2) Down.

Specifying Print Configurations
For printers that support more than one print resolution level, you can specify the print 
resolution settings at design time. You can also get better printing results by controlling 
the data placement parameters. The print resolution and data placement options are 
located in the Margins category.

To set the print configurations:

Accuracy

Linespacing – specifies the distance between two printed lines, per specified unit of 
measurement.
LPI – displays a list of available units of measurement for Linespacing. You can 
select inches, centimeters, millimeters, points, pels, or Lines per Inch, according to 
your requirements.
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Pels Per Inch – sets the pixel resolution of your printer in order to accurately place 
your objects. You can either choose the predefined values of 240 or 300 pels per 
inch, or define a custom value. To set a custom value, select Custom from the Pels 
Per Inch list to enable the associated box where you can type your required value.

Setting the Logical Page Dimensions
You can specify the point of origin of a logical page on a physical sheet by specifying the 
logical page offsets in the FormDef. The width and height of the logical page relative to 
the point of origin is specified in the PageDef. You can specify the logical page 
dimensions in the Dimensions category.

To set the logical page dimensions:

Dimensions

Width, Height – sets the page dimensions, per specified unit of measurement, in the 
horizontal and vertical direction.
None –displays a list of available units of measurement for the horizontal and 
vertical directions.

Make sure that you have not defined a logical page larger than the physical sheet. 
Visual PPFA does not check the size of the physical sheet.

To view the placement of the logical page on the physical page, ensure that you 
have both the FormDef, as well as the PageDef loaded in the design area.
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Setting the Print Direction
A logical page can be printed in one of the four print directions that you can specify in the 
Direction category.

To set the print direction:

Direction

Across – prints the characters from left to right, in the top to bottom direction.
Down – prints the characters from top to bottom, in the right to left direction.
Back – prints the characters from right to left, in the bottom to top direction.
Up – prints the characters from the bottom to top, in the left to right direction.

The logical pages displaying different print directions.

The Across and Back options are used with portrait presentation, whereas Down and Up 
options are used with the landscape presentation.

Not all printers can print in all of the directions. For more information, refer to 
your printer guide.
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Adding Comments
In the Comment category, you can enter descriptive comments about the objects that are 
used in the application. These descriptions can be viewed with application source code in 
the DesignPro Visual PPFA source view. 

To add comments:

Comments

Comment Sub-command – sets special descriptive comments for the FormDef or 
PageDef object.

Programmer Comments – sets descriptive comments for the application objects.
 

Programmer Comments and Comment Sub-command displaying in the Source view.

Comments are converted with the application to (.OBJ) format. Therefore, they 
can be viewed both with the compiled PageDef or FormDef object code and in an 
AFP environment.

The specified Name, Alias, and Comments are retained in the object format and 
can be viewed when the FormDef is loaded again.
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Chapter 8:

Working with PageDef 
Lists   

This chapter describes the resource lists used in designing a PageDef, and provides 
information on adding, maintaining and deleting these lists. 

About PageDef Lists
Visual PPFA facilitates a design process by employing the use of six PageDef lists in a 
PageDef design. These lists are for the following objects:

Fonts, colors and objects at the PageDef level. 
Overlays, segments and Table Reference Characters (TRC) at the pageFormat level. 

The PageDef lists act as the repository for their respective items. Hence, you can define 
your customized resources beforehand, and later use these resources in the design process.

Working with a Font List
A font list stores the fonts that are defined for a PageDef. It enables you to define a font 
with your specified name, and configure its properties according to your requirements. 
Once the required fonts are added to the font list, the font is then selected for the text of the 
pageFormat. You can add the supported font types namely Elixir, TrueType, ATM and 
AFP fonts to the list. A font list can hold a maximum of 127 fonts.

In this chapter...

About PageDef Lists

Suppressing Fonts

Adding Lists from the Insert Toolbar  
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Whenever a new PageDef is created, a Font List node is created by default in the PageDef 
tree.

To work with a font list:

1 In the PageDef tree, right-click the Font List node and select Properties from the 
pop-up menu to display the Properties – Font List dialog.

Displaying the list of fonts and associated properties.

2 Click Add/Remove Fonts to display the Font List Dialog. 

A font that is not added in the font list cannot be applied to the text in a PageDef.
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The Font List dialog.

The Font List Dialog comprises a font list along with a toolbar to manage the list. 
The font list displays the already added fonts with their respective properties. You 
can edit certain properties of a font depending on its type.

As appropriate, review the following properties associated with a font:
User Name – specifies a user-assigned name uniquely identifying the font.
Name – displays the standard font name.
Size – specifies the font size in points (for a Windows font only). You can 
double-click the Size cell to change the font size.
Style – specifies the font style (for a Windows font only).

• Regular – sets regular as the style of the selected font.
• Bold – sets bold as the style of the selected font.
• Italic – sets italics as the style of the selected font.

The properties of a font constitute a column in the font list. You can customize 
the columns that are displaying in the Font List Dialog to suit your preferences. 
This is explained in"Customizing Columns" on page 134.
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• Bold, Italic – sets a combination of bold and italics as the style of the selected 
font.
Script – displays the Script associated with a Windows font to determine the 
language being used.
Usage – displays a system-generated value indicating the number of times the 
selected font is used in the PageDef.
Coded Name – displays an alphanumeric AFP font name generated only for the 
Windows fonts.
SBCS/DBCS – sets the character set associated with the selected font. 

• SBCS – sets the Single Byte Character Set.
• DBCS – sets the Double Byte Character Set.

Encoding – uses the specified encoding standard with the selected font. 
• EBCDIC – uses the Extended Binary Coded Decimal Interchange Code.
• ASCII – uses the American Standard Code for Information Interchange.
• UNICODE – uses UNICODE.

Rotation: specifies the rotation of the character box relative to the character 
baseline.

• 0 – rotates to 0 degrees.
• 90 – rotates to 90 degrees.
• 180 – rotates to 180 degrees.
• 270 – rotates to 270 degrees.

Met Tech – specifies the Metric Technology used in precisely defining the font 
characteristics.

• None – do not use the Metric Technology.
• Fixed – uses the fixed Metric Technology.
• Relative – uses relative Metric Technology.

Ratio – specifies the ratio of scaling the width relative to the height in the 
selected font.
Width – specifies the font width in pels (for a Windows font using the Japanese, 
Chinese simplified, Chinese traditional or Korean script). 
DPI – specifies the resolution in Dots Per Inch (DPI).

3 Click OK to save the settings and return to the Properties - Font List dialog.
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Adding Fonts to a Font List
You can add a Windows font, External font, Coded font, or a FontPair to the font list. To 
add a font:

1 On the Font List Dialog toolbar, click , and select your required font type from 
the pop-up menu.
An associated font type dialog displays with every selection.

2 As appropriate, review the respective dialog options. The procedure to add all the 
supported fonts is explicitly explained below.

Adding a Windows Font
Selecting Windows font from the pop-up menu displays the Font dialog, which enables 
you to add True Type, Open Type and Adobe Type Manager (ATM) fonts to the font list.

Font dialog for specifying the Windows fonts. 
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1 Select the required Font, Font style, and Size from their respective lists.
A sample of characters of the font with their applied properties display in the Sample 
box.

2 To use the font in any other language, you can change the script by selecting from 
the options available in Script.

3 Click Add to add the selected font along with its properties to the font list; click End 
to return to the Font List Dialog without saving the settings.

For a Windows font using the Japanese, Chinese simplified, Chinese traditional or 
Korean script, the Use fixed width check-box is enabled. You can select this 
option to specify the required width in the Width (pels) entry-box, and the 
required resolution in the DPI drop-down list. The specified width and 
resolution are used to calculate the font size. The Size field becomes disabled in 
this case.

With the resolution set to 240 DPI, you can specify a font width in the range of 
6 pels to 255 pels. Similarly, the width ranges for 300 DPI and 600 DPI are 6 
pels to 300 pels and 6 pels to 600 pels respectively.
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Adding an External Font
Selecting External font from the pop-up menu displays the Open Resource File dialog, 
which enables you to select a font resource from the files of type Elixir Legacy Font 
(*.hdr) or from the resource library (*.erc, *.erc32).     

Open Resource File dialog displaying a list of font resources you can select from. 

1 Browse and select the required font.

2 Click Add to add the selected font to the font list; click End to return to the Font List 
Dialog without saving the selection.

Adding a Coded Font to the Font List
Selecting Coded font from the pop-up menu displays the Open Resource File dialog, 
which enables you to select a font resource from the files of type AFP Coded Font (X0*, 
X1*, X2*, X3*, X4*) and Elixir Legacy Coded Font (X0*.cdf, X1*.cdf, X2*.cdf, 
X3*.cdf, X4*.cdf) or from the resource library (*.erc, *.erc32). 

The procedure to add a Coded Font is the same as that for an External Font. For details, 
refer to "Adding an External Font" on page 131 (above).
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Adding a Font Pair
Selecting FontPair from the pop-up menu displays the Font Pair dialog, which enables 
you to create a font pair by selecting the required character set and code page. A font pair 
comprises a character set and a code page.

1 To select a character set, click  adjacent to the Charset text box. 
This displays the Open Resource File dialog, which enables you to select an AFP 
Character Set (C0*, C1*, C2*, C3*, C4*) or an Elixir Legacy Character Set 
(C0*.hdr, C1*.hdr, C2*.hdr, C3*.hdr, C4*.hdr). You can also import a character set 
from the resource library (*.erc, *.erc32). 

2 Browse to the required file and select it.

3 Click Open to add the selected character set to the font pair. The Charset text box 
shows the file path of the selected character set.

4 To add a code page to the selected font pair, click  adjacent to the Codepage text 
box, which again displays the Open Resource File dialog. Select an AFP Code Page 
(T1*) or an Elixir Legacy Code Page (*.cod) from this dialog. You can also import a 
character set from the resource library (*.erc, *.erc32). 

5 Browse to the required file and select it.

6 Click Add to add the selected code page. The file path displays in Codepage. You 
can click End to return to the Font Pair dialog without saving any selection.

Replacing a Font
You can replace an existing font with a new font in the font list. To replace a font, select 

the font and click  on the Font List Dialog. From the pop-up menu, select the required 
type of font. Replacing a font with any of the font types follows the same steps as covered 
in "Adding Fonts to a Font List" on page 129.
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Changing the Properties of a Windows font
To view and change the properties of a selected Windows font:

1 On the Font List Dialog toolbar, click  to display the Font dialog.

2 Review and change the Font, Font style, Size, and Script options as per your 
requirement.

3 Click OK to save your changes and return to the Font List Dialog.

Managing the Font List
The Font List Dialog toolbar facilitates you to manage the font list to suit your 
preferences. You can re-arrange the sequence of fonts in a font list by selecting the font 

you want to move, and then clicking  to move the selected font up one position in the 

list,  to move the selected font to the top of the list,  to move the selected font 

down one position in the list, or  to move the selected font to the bottom of the list. To 

delete a font, select it and click  on the Font List Dialog toolbar.
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Customizing Columns
You can customize the columns that display in the Font List Dialog. To customize the 
columns:

1 On the Font List Dialog toolbar, click .
The Customize columns dialog displays. Each item in the displayed list represents a 
valid column name of the font list. The checked items represent the columns that are 
already displaying in the Font List Dialog.

2 Select the required column name and click one of the following buttons to perform 
your required function. 

To top – moves the selected column to the first position in the list.
Up – moves the selected column one position up in the font list.
Down – moves the selected column one position down in the font list.
To bottom – moves the selected column to the last position in the font list.
Show/hide – changes the visibility of the selected column in the font list. You 
can also double click a hidden column to make it visible or a visible column to 
hide it.
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3 Click Reset to position the columns according to the default arrangement.

4 Click OK to save your settings and return to the Font List Dialog.

Working with a Color List
A color list stores the colors that are defined for the active application. It is an optional list 
that is added at the PageDef level. It is recommended to make a list of the colors to be used 
in a PageDef design, with meaningful user-assigned names, to facilitate the design 
process.

Adding a Color List
To add a color list:

1 Select the required PageDef node in the PageDef tree.

2 From the Insert menu, select Lists, Color List to add the Color List node in the 
PageDef tree.

The PageDef tree with the added Color List node. 
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Adding Colors to a Color List
To add colors in a color list:

1 In the PageDef tree, right-click the Color List node, and select Properties from the 
pop-up menu.
The Properties – Color List dialog displays.

2 Click .
A row is added to the color list representing the new color item.

3 As appropriate, review the dialog options.

 – shows a sample of the added color.
Name – specifies a user-assigned name uniquely identifying the color.  is used 
to select the color.
Model – specifies the model of the selected color. 
Values – specifies the equivalent alphanumeric representation for the selected 
color as per the selected Model.
Usage – displays a system-generated value indicating the number of times the 
color is used in the PageDef.

You can delete a selected color from the color list by clicking .
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4 Click the Model cell of the new color, and select your required model. 
The steps to select a color vary with the color model selected.

Selecting OCA Color
To select an OCA color, make sure that you have selected OCA as the Model in the 
Properties - Color List dialog. To select an OCA color:

1 Click  in the Name cell.
A list of available OCA colors display.

2 Select the required color.
The selected OCA color displays in the new color row that is added to the color list.

Selecting RGB, CMYK or CIELAB Color
To select an RGB, CMYK, or CIELAB color, make sure that the Model selected for the 
new color item is RGB, CMYK, or CIELAB, as per your requirement. To select your 
required color:

1 Click  in the Name cell to display the Color Selector dialog.

The Color Selector dialog displaying the RGB Model. 
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The Model category displays the properties specific to the selected color model. A 
color model represents a color as a combination of other color pigments. These color 
pigments are specific to a model. For instance Red, Green and Blue pigments define 
a color in the RGB model. You can change the color model using the Selected Color 
Model drop-down list. The Spectrum category sets the spectrum of colors with their 
required shades using an adjacent shades bar.
The following image illustrates the different parts of the Spectrum category:

2 To select a color, click the required color area on the spectrum. The shades available 
for the selected color display in the shades bar.

3 Select a shade by adjusting the slider with the shades bar.

4 Equivalent values for the selected color display in the Model category.

5 You can also select the color by adjusting the sliders with each of the pigments in the 
Model category, or by typing a numbered value for each RGB color in the adjacent 
boxes. 

6 Click OK to add the selected color and return to the Properties – Color List dialog.

The Gray Scale value is read-only and adjusts automatically in correspondence 
with the selected color.
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Selecting Highlight Color
To select a Highlight color, make sure that you have selected HIGHLIGHT as the Model 
in the Properties - Color List dialog. To select the Highlight color:

1 Click  in the Name cell to display the Highlight Color dialog.

Highlight Color dialog displaying the fields that need to be specified for the required 
highlight color.

2 Specify the required values:
Highlight – specifies a value within the range 0 to 65,535. A value of 0 indicates 
that there is no value defined, and hence, the default color is used.
Coverage – specifies a value within the range 0 to 100, to indicate the amount of 
the highlight color to be used.
Black – specifies a value within the range 0 to 100, to indicate the percentage of 
black to be added to the highlight color.

3 Click OK to save the highlight color values and return to the Properties – Color List 
dialog.

Working with an Object List
An object list facilitates you to define and store external objects for an application. It is an 
optional list that is added at the PageDef level. You can add an AFP Page Segment (S1*), 
Elixir Legacy File (*.lp3) or an image file (*.bmp, *.jpg, *.jpeg, *.tif, *.pcx, *.png) to this 
list. 
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Adding an Object List

1 Select the PageDef node in the PageDef tree.

2 From the menu bar, select Insert>Lists>Object List to add the Object List node in 
the PageDef tree.

The PageDef tree with the added Object List node. 

Adding Objects to an Object List

1 In the PageDef tree, right-click the Object List node, and select Properties from the 
pop-up menu.
The Properties – Object List dialog displays.

 

2 Click .
A row is added to the object list representing the new object.

The objects added to the object list are also referred to as primary objects. 
Primary objects may contain references to secondary objects.
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3 As appropriate, review the dialog options.
User Name – displays the name of the added resource object.  displays the 
Open Resource File dialog to select the required resource.
Local Name – specifies the user-assigned name for the object.
Type – sets the type of the selected object. 

• PSEG – specifies that the selected object type is page segment. 
• IOCA – specifies that the selected object type is Image Object Content 

Architecture (IOCA). 
• BCOCA – specifies that the selected object type is Barcode Object Content 

Architecture (BCOCA). 
• GOCA – specifies that the selected object type is Graphic Object Content 

Architecture (GOCA). 
• TIFF-14 – specifies that the selected object type is Tagged Image File Format 

(TIFF). 
• WINDIB 17 – specifies that the selected object type is Windows Device 

Independent Bitmap.
• OS2DIB 18 – specifies that the selected object type is in the Operating System 2 

Device Independent Bitmap format.
• GIF-22 – specifies that the selected object type is in Graphic Interleaved Format 

(GIF). 
• JFIF-23 – specifies that the selected object type is in JPEG File Interchange 

Format. 
• PCX 19 – specifies that the selected object type is in PC Paintbrush file format. 

Usage – displays a system-generated value indicating the number of times the 
selected object is used in the PageDef.

 – displays the Object List dialog to add secondary objects. For details on the 
secondary objects, refer to "Adding a Secondary Object" on page 142.

You can delete a selected object from the object list by clicking  .
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4 As appropriate, select the following options.
Keep in Memory – saves the added objects in memory to avoid reloading them.
Preload – loads the objects before running a print job.
Color Profile – sets a color profile for the selected object. 

• NONE – do not use a color profile.
• CMYKEURO – uses a color profile of the European standard.
• CMYKSWOP – uses a color profile of the Web Offset Press standard.

5 Click Apply, and then OK to save the settings.

Adding a Secondary Object
If the object added to the Object List contains a reference to one or more secondary 
objects, you must identify them at this point. To add a secondary object reference for a 
primary object:

1 In the Properties – Object List dialog, click  adjacent to the Usage cell of the 
primary object to display the Object List dialog.

2 In the Object List dialog, click .
A row is added to the object list representing the new object item.
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3 As appropriate, review the dialog options:
User Name – displays the actual name of the added secondary resource.  
displays the Open Resource File dialog to select the required resource.
Local Name – specifies the user-assigned name for the object.
Type – sets the type of the selected object. 

• PDFRO-26 – specifies that the selected object type is a PDF resource object.
• RESCLRPRO-46 – specifies that the selected object type is a Resident Color 

Profile resource object
• IOCAFS45RO-47 – specifies that the selected object type is an Image Object 

Content Architecture FS45 resource object.
Preload – specifies the setting for loading the object.  

• Yes – loads the object before running a print job.
• No – do not load the object before running a print job.

4 Click OK to apply the settings and return to the Properties – Object List dialog.

Working with an Overlay List
An overlay list facilitates you to manage the overlays defined for a page format by 
itemizing them. You can use an overlay list to load multiple overlays to a printer prior to 
printing a page, thereby eliminating the processing overhead involved in loading an 
overlay every time it is required. The overlay list can contain a maximum of 127 overlays.

Adding an Overlay List

1 Select the PageFormat node in the PageDef tree.

2 From the Insert menu, select Lists, Overlay List to display the Overlay List node 
in the PageDef tree.

The PageDef tree with the added Overlay List. 
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Adding Overlays to an Overlay List
To add an overlay to an overlay list:

1 In the PageDef tree, right-click the Overlay List node and select Properties from 
the pop-up menu.
The Properties – Overlay List dialog displays.

 

2 Click .
A row is added to the overlay list representing the new overlay.

3 As appropriate, review the dialog options.
User Name – displays the name of the added overlay . displays the Open 
Resource File dialog to select the required overlay.
Preload – specifies the loading settings. 

• PRELOAD – loads the resource prior to processing the page.
• NOPRELOAD – do not load the resource prior to processing the page.

4 Click Apply, and then OK to save the settings and return to the application window.
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Working with a Segment List
A segment list facilitates you to define page segments in an application prior to its 
designing. It is an optional list that is added at the PageDef level. You can add an AFP 
Page Segment, Elixir Legacy File or an image file to it. The segment list loads multiple 
segments that are used in a page to the printer before printing them, thereby eliminating 
the printer-processing overhead in loading a segment each time it is required. A segment 
list can hold a maximum of 127 segments.

Adding a Segment List

1 Select the PageFormat node in the PageDef tree.

2 From the Insert menu, select Lists, Segment List to display the Segment List node 
in the PageDef tree.

The PageDef tree with the added Segment List. 

Adding Segments to a Segment List 
To add a segment to a segment list:

1 In the PageDef tree, right-click the Segment List node, and select Properties from 
the pop-up menu.
The Properties – Segment List dialog displays.
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The Properties – Segment List dialog.

2 Click .
A row is added to the segment list representing the new segment.

3 Enter the following:
User Name – displays the name of the added segment . displays the Open 
Resource File dialog to select the required segment.

4 Click Apply, and then OK to save the settings and return to the application window.

Working with a TRC Reference List
A Table Reference Character (TRC) denotes the second byte on a line in the your data. 
This byte contains an integer value in the range 0 to 126, which refers to the font that will 
be used to print that line. You can add a TRC list only at the PageFormat level of a 
Traditional format PageDef tree. To this list, you can add the fonts defined for the active 
PageDef in the font list.

Adding a TRC Reference List

1 Select the PageFormat node in the Traditional PageDef tree.

2 From the Insert menu, select Lists, TRC Reference List to display the TRC List 
node in the PageDef tree.
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The PageDef tree with the added TRC List. 

Adding TRC References a TRC Reference List
To add a TRC Reference to a TRC Reference list:

1 In the PageDef tree, right-click the TRC List node and select Properties from the 
pop-up menu.
The Properties – TRC List dialog displays.

 

2 As appropriate, change the name of the TRC list in TRC Table.

3 To add a TRC Reference item in the list, click .
A row representing the new item is added to the list.

4 As appropriate, review the following TRC table options:
TRC – sets a TRC integer value in the range 0 to 126.
Font Name – sets the font you need to associate with the TRC value.
Direction – sets the print direction for a font; the available options are Across, 
Down, Back, and Up.
Rotation – rotates the font to 0, 90, 180, or 270 degrees. 
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5 Click Apply, and then OK to save the settings and return to the application window.

Using a TRC Reference List
To control the fonts that are applied in a PageFormat using a TRC list, you must suppress 
the font references at record and field levels. 

Suppressing Fonts
To suppress a font, define it in the font list with the User Name "NOFONT". Use this font 
for each mapped record and field. The converter suppresses all the occurrences of 
"NOFONT" to prevent writing the font calls to records and fields. This suppression 
enables the use of fonts referenced by the TRC characters in the data file.

Suppressing Fonts Using AFPDS Property Settings
To suppress fonts using the AFPDS property settings:

1 From the Tools menu, select Application Format Setting, Output Formats, 
AFPDS.
The AFPDS dialog displays.

 

2 Select the PageDef category.
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3 Select the Suppress Font option to suppress the fonts applied at the record and field 
levels.

4 Click Apply, and then OK to save the settings and return to the application window.

Suppressing Fonts Using PPFA Property Settings
To suppress fonts using the PPFA property settings:

1 From the Tools menu, select Application Format Setting, Output Formats, 
PPFA.
The PPFA dialog displays.

 

2 Select the Font category.

3 Select the Suppress Font References option to suppress the fonts used at the record 
and field levels.

4 Click Apply, and then OK to save the settings and return to the application window.

You can also edit the AFPDS property settings when saving the PageDef as an 
AFP PageDef object using the Edit Property Settings button in the PageDef 
Save as dialog.
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Adding Lists from the Insert Toolbar

You can add a number of different lists to a PageDef or a page format. For this, click  
on the Insert toolbar. From the pop-up menu, select the required list (Color List, Object 
List, Overlay List, Segment List, TRC Reference List, or Suppression List) to add to the 
required PageDef or page format node.
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Chapter 9:

Working with PageDef 
Objects

This chapter describes the procedures to work with PageDef objects, such as page formats, 
records, fields and barcode fields, conditions, floating overlays, floating segments, 
external objects, and end subpages.

About PageDef Object
Visual PPFA facilitates you to add a variety of objects to a PageDef. These objects include 
PageFormats, records, fields, conditions, etc. The PageFormat and record are essentially 
required in a PageDef. This is the reason why both the objects are present by default each 
time you create a PageDef. The rest of the objects are optional, and Visual PPFA enables 
you to specify additional PageFormats, records, and other objects for a PageDef as 
required. You can view the objects added to a PageDef in the PageDef tree, as well as in 
the design area. Each of the objects has an associated set of properties that determines its 
contribution to the design.

In this chapter...

Working with PageFormat

Working with Records

Working with Fields

Working with Conditions

Working with Floating Overlays

Working with External Objects
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Working with PageFormat
A PageFormat is a logical page template within a PageDef. A single PageDef may have 
multiple PageFormats. Each of the PageFormats specifies a different set of configurations 
defining a different logical page for a print job. A PageFormat contains the same controls 
for formatting a print output as the PageDef. The settings specified for the PageDef are 
inherited by each of the newly created PageFormats, thus removing the need to specify the 
same settings individually for each PageFormat.

The first PageFormat in a PageDef is, by default, active when a file begins its processing. 
To change the active PageFormat, you can choose one of the following procedures:

Use conditional processing.
Add the Invoke Data Map structured field to the data file each time you want to 
change the PageFormats.

A PageFormat is used in both the Traditional PageDef, as well as the Record Format 
PageDef, but properties vary slightly between the two types.

Adding a PageFormat
A PageFormat is present by default in the PageDef tree. However, when different pages in 
a file need to be formatted differently, you may need to specify more than one PageFormat 
in your PageDef.

The PageFormat settings take precedence over the PageDef settings. Note that 
the PageDef settings are not automatically applied to the already created 
PageFormats.
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To add a new PageFormat:

1 In the PageDef tree, select the PageDef node.

2 From the menu bar, select Insert>PageFormat to add a New PageFormat node in the 
PageDef tree.

PageDef tree displaying the newly added PageFormat. 

The tasks included in this section explain various settings associated with the PageFormat 
objects. 

You can also add a PageFormat by performing one of the following functions:

Right-click any node in the PageDef tree, and select Insert>PageFormat from 
the pop-up menu.

Select any node in the PageDef tree and click  on the Insert toolbar.
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Setting PageFormat Properties
To set the PageFormat properties:

1 In the PageDef tree, right-click the required New PageFormat node, and select 
Properties from the pop-up menu.
The Properties – Page Format dialog displays the Traditional or Record Format 
PageDef, depending upon your selection of type on the time of creating a new 
PageDef.

The Properties – Page Format dialog for the Traditional PageDef. 

2 Select your required Category, and enter the appropriate settings.

3 Click Apply and OK to save your settings and return to the application window.

You can also launch the Properties – Page Format dialog by selecting the New 
PageFormat node in the PageDef tree and performing one of the following 
functions:

On the Standard toolbar, click .
From the menu bar, select View>Properties.
Press <Alt> + Enter from the keyboard.
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All of the categories available for the PageFormat have the same options as the analogous 
category in the PageDef. Hence, the settings for these options in a newly created 
PageFormat are all inherited from the PageDef. You can change the inherited settings by 
following the steps explained in Chapter 7: "Designing Logical Pages" on page 115. 
There is an additional Display category available in the Properties –Page Format dialog, 
which is explained below.

Setting the Display Offset for a PageFormat
In order to align your PageDef design with that of the FormDef, Visual PPFA facilitates 
you to set the display offsets. The display offsets illustrate the position of the logical page 
on the physical page in the design area. You can specify the display offsets of a 
PageFormat as long as you do not have a FormDef loaded in your design. Once a FormDef 
is loaded, the Display category automatically updates its values in order to synchronize 
with the Offset category, and becomes unavailable for any modification. In such cases, 
you can make changes in the Offset category of the FormDef, if required.

To specify the display offsets, select the Display category in the Properties – Page 
Format dialog, and review the following dialog options:

Display offset

Horizontal, Vertical – sets the required horizontal and vertical offset values, per 
specified unit of measurement.
None – displays a list of available units of measurement respective to the Horizontal 
and Vertical offsets.

Display offset for a PageFormat changed from (1) Horizontal: 0.100”, Vertical: 
0.100” to (2) Horizontal: 0.500”, Vertical: 0.500”.
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Working with Records
A PageFormat can contain multiple records, which specify the layout of a data record in 
the design area. An apparent purpose of the record objects is to hold the variable data 
coming from the data file, but it may or may not be associated with some data from the 
data file depending upon the design requirements.

Adding a Record
When a PageFormat is created, a record is added to the PageDef tree by default. To add 
another record to the PageFormat:

1 Right-click the PageFormat node to which you need to add a record object, and 
select Insert>Record from the pop-up menu.
A NewRecord node is added to the selected PageFormat in the PageDef tree.

The PageDef tree displaying the added record. 

The actual placement of a logical page on the physical page for the print output is 
determined by the values specified in the Offset category for the associated 
FormDef.

You can also add a new record by selecting the required PageFormat node and 
performing one of the following functions:

From the menu bar, select Insert>Record.

On the Insert toolbar, click .
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Setting Record Properties
To view and set the properties of a record object:

1 In the PageDef tree, right-click the required record node and select Properties from 
the pop-up menu. The Properties – Record dialog displays.

2 Select the required category from the Category list.

3 As appropriate, review, enter, or select the dialog options.

4 Click Apply and OK to save the settings.

Setting Name and Display Options for a Record in Traditional 
PageDef
Visual PPFA assigns a default name to every newly inserted record. You can change the 
default name in the General category of the Properties - Record dialog for a Traditional 
PageDef. To change the name options:

Name – specifies a meaningful name for the selected record. A user-assigned name 
makes future referencing to the record object easy.

The General category also enables you to set the following options:
Print Data – prints the data referenced by the selected record in the final output.
Include In Presentation – indicates that the selected record is contributing 
(mapped) to the design. A mapped record is shown with  icon in the PageDef tree. 
Although an un-mapped record node is located in the PageDef tree, it does not 
contribute to the PageDef design.

The PageDef tree displaying the mapped records. 
Chapter 9: Working with PageDef Objects 157



In the example illustrated below, (1) shows NewRecord 2 with Print Data option disabled 
so the data is not printed, but the Include In Presentation option is enabled meaning the 
record is mapped to the design and therefore holds its position. Example (2) shows 
NewRecord 2 with the Include In Presentation option disabled so the record is not 
mapped to the design.

(1) NewRecord 2 is not visible in the design, but holds its position between the two 
records. (2) NewRecord 2 has no participation in the design.

Setting Name and Display Options for a Record in Record 
Format PageDef
You can specify the Name, Print Data, and Include In Presentation settings for a record 
via the General category of the Properties - Record dialog for a Record Format PageDef, 
as explained in "Setting Name and Display Options for a Record in Traditional PageDef" 
on page 157. In addition to the specified options, there are some other options that are as 
follows:

Start New Page using this layout – starts printing the current record from a new 
page.
Type – specifies the type of layout to be used for the selected record. Either:

• Body – prints the data line by line. This option is used for a majority of data in 
the data file that is printed as normal text. For Body selected as the layout type, 
the Default option is not available. Select the Group option to specify if the 
existing group header should be saved and used for subsequent pages. If this 
option is not selected when processing starts on a Body type, the active group 
header record is discarded and not reprinted on subsequent pages.

• Page Header – prints the data as a header on each new page. For Page Header 
selected as the layout type, the Default option is enabled.

• Page Trailer – prints the data as a trailer (footer) on each new page. For Page 
Trailer selected as the layout type, the Default option is enabled.

• Group Header – prints the data as a header that is to be printed at the beginning 
of a group of data. For Group Header selected as the layout type, the Group and 
Default options are disabled.
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RecordID – specifies the ID of the record mapped to the current record. The 
associated drop-down list enables you to select a format in which you need to specify 
the record ID. Either:

• Char – specifies the RecordID in alphanumeric characters.
• Hex – specifies the RecordID as a Hexadecimal value.
• ASCII – specifies the RecordID as an ASCII value.
• EBCDIC – specifies the RecordID as an EBCDIC value.
As Visual PPFA does not translate the RecordID values, make sure to specify the 
value in the correct format as used in the data file.
Delimiter – specifies the delimiting character that is used to separate the fields in the 
data file. You can specify a one or two byte value as appropriate, consistent with 
your data file. The associated drop-down list enables you to select a format in which 
you want to specify the record ID.

End Space – specifies the location, as per the selected unit of measurement, where a 
page eject is performed. If the remaining space on the page (before the bottom 
margin) is less than the specified End Space value, the logical page is ejected before 
the record data is processed. This parameter is useful to ensure that a table heading is 
not printed at the end of a page without having space for additional data records, or 
to ensure that a table entry is not printed at the bottom of a page without having 
space for a record.
X Space – indicates the amount of extra space from the position of the record to the 
bottom of the group header area, per specified unit of measurement. This enables 
you to identify the amount of X (eXtra) space in excess of one text line being used by 
the header so that the baseline moves down and the following group data is not 
placed on top of the header area. You need to explicitly define the X space value, as 
Visual PPFA does not calculate it.

Illustrating the use of X Space parameter.

A delimiter specified in this category affects the Field Num attribute of the 
fields in the record. This is explained later in this chapter.
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Setting Sample Text
By default, a record is represented in the design area by its name, as specified in the 
General category. The Sample Text category of the Properties – Record dialog facilitates 
you to specify a sample text for the selected record. Hence, the sample text displays in the 
design area replacing the name of the record.

Design area displaying the usage of Sample Text option.

Setting Record Position
Visual PPFA facilitates you to place the records in your design, as per your requirement, 
using the Position category. It enables you to specify the horizontal and vertical position 
coordinates relative to a specified origin. You can also use custom settings, if required. To 
set the position of a record, specify the following in the Position category of the 
Properties – Record dialog:

Horizontal

Offset – sets the horizontal coordinate for positioning the record. Either:
• Custom – customizes the offset by specifying your required horizontal values in 

the associated text box. The specified value is used as an absolute value for the 
horizontal positioning of the record.

• Margin – specifies that the selected record starts at the position corresponding to 
the horizontal value specified in the Margins category of the current 
PageFormat.

• Same – specifies that the selected record starts at the same horizontal offset 
position as the previously defined record. If applied to the first record of a logical 
page, the horizontal position is 0, which is the default offset value.
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None – displays a list of available units of measurement for the selected horizontal 
offset.

Vertical

Offset – sets the vertical coordinate for positioning the record. Either:
• Custom – customizes the offset by specifying your required vertical values in the 

associated text box. The specified value is used as an absolute value for the 
vertical positioning of the record.

• Top – specifies that the selected record is placed corresponding to the vertical 
value that is specified in the Margins category of the current PageFormat.

• Same – specifies that the selected record starts at the same vertical position as the 
previous record.

• Next – specifies that the selected record is to be positioned down one line from 
the previous field. For the first record of a logical page, the starting position of 
the record is one line down from the top of the logical page, as defined in the 
Margins category of the current PageFormat.

None – displays a list of available units of measurement for the selected vertical 
offset.

Illustrating the placement of a record using the Custom option.
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Setting Record Direction
The print direction determines the appearance of the record text in the design. To set the 
print direction of a record, select the Direction category in the Properties – Record dialog 
and select any of the options explained below:

Direction

Across – prints the characters from left to right.
Down – prints the characters from top to bottom.
Back – prints the characters from right to left in an upside-down direction.
Up – prints the characters from bottom to top.

Displaying records in different directions: (1) Across (2) Down (3) Back (4) Up. 

Repeating a Record in Traditional PageFormat
You can specify the number of times a record needs to be printed on a logical page. If the 
printed record contains fields, then the fields will also be repeated. The repeated instances 
can be printed using the settings specified either for contained fields or the first record.

To set the option for repeating the records, specify the required settings in the Repeat 
category of the Properties – Record dialog:

Record repeat

Repeat – sets the number of times you need to repeat the record.
Repeat type – specifies the type of repeat operation you need to perform. Either:

• Field – specifies the field associated with the repetition of the selected record is 
to be positioned based on the first instance of the same field. 
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• Line – specifies that fields associated with repetitions of the selected record are 
to be positioned based on the repetition of the record itself.

Displaying the use of the Repeat option. 

Setting Font
Visual PPFA facilitates you to select a font that you need to use for the text of the selected 
record. You can select your required font from the font list displayed in the Font category 
of the Properties – Record dialog.

The fonts in the font list can be categorized as either SBCS (Single Byte Character Set) 
fonts or DBCS (Double Byte Character Set) fonts, depending upon the character set of the 
font. You can select a font for a record by specifying the following options:

SBCS font

User name – displays the SBCS font names that are already added in the font list. 
The properties associated with the selected font display in Name, Code Page, and 
Rotation. 
Use DBCS font – enables the User name, Name, Code Page, and Rotation options 
for the selected DBCS font. The font is selected in the User name option, and the 
properties associated with the selected font display in Name, Code Page, and 
Rotation.

For details on font lists, refer to "Working with a Font List" on page 125. 
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Setting Color
You can also specify the color of text for a record in Visual PPFA. In the Color category of 
the Properties – Record dialog, you can either select a new color or defined one in the 
color list. To set a color:

Use this color – sets a color from the list of available color models. Select a color 
model in the Model field, and click  to select the required color or shade from the 
selected model.

Use defined color – uses a color that is defined in the PageDef color list.

Click Apply and then OK to save the settings.

Adding Comments
The Comment category enables you to enter a description for the records that are used in 
the application. This description can be viewed with application source code in the 
DesignPro Visual PPFA source view.

Working with Fields
The field object is used to identify a field in a data record, which is to be formatted and 
placed on the page. A field must essentially be nested within a record. The parameters that 
are not specified for a field are inherited from its parent record.

Adding a Field
To add a field to a record:

1 In the PageDef tree, select the record node to which you need to add a field object.

2 From the menu bar, select Insert>Field to add a new field node to the selected record 
node.

For information on selecting colors from different color models, refer to 
"Working with a Color List" on page 135. 
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You cannot insert a field to a mapped record (for which the Include In Presentation 
option is enabled).

The PageDef tree displaying the added field node. 

Setting Field Properties
To set the field properties:

1 In the PageDef tree, right-click the required field node and select Properties from 
the pop-up menu. The Properties – Field dialog displays.

2 Select the required category from the Category list.

3 As appropriate, review, enter, or select the dialog options.

4 Click Apply and OK to save the settings.

Specifying the Name and Data Presentation Settings for a Field 
in Traditional PageDef
Visual PPFA assigns a default name to every newly inserted field. You can change the 
default name of a Traditional PageDef field via the General category of the Properties - 
Field dialog.

You can also add a field by performing one of the following functions:

Right-click the required record node and select Insert>Field from the pop-up 
menu.

Select the required record node or any of its child nodes and click  on 
the Insert toolbar.
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As appropriate, review the following dialog options:
Name – specifies a meaningful name for the selected field that displays in the 
PageDef tree. A user-assigned name makes future referencing to the field object 
easy.

The General category also enables you to set the following options:
Type – specifies the type of layout to be used for the selected field. Either:
• Data – prints variable data from the input data file.
• Fixed Text – prints static text (explained below) for the current field.
Suppression – suppresses the selected text field if the specified name is identified by 
a suppression attribute from the FormDef. The same name can be used in one or 
more fields to suppress the fields as a group.

Start – specifies the position of the starting byte for the selected field.
Length – specifies the length of the field in bytes.
Text – displays the text that is printed in the design area as the default static text for 
the selected field. Click Edit to set the required text in the Fixed Text dialog.

To set a fixed text for a field, specify the following options in the Fixed Text dialog:
Duplication – sets a decimal value that specifies the number of times the field text 
needs to be repeated. The maximum duplication value depends on the size of the 
text.
Format – specifies the type of text used in the selected field. Either:

• Char – indicates that the text contains single-byte code characters, which include 
all Roman alphabetic characters including blanks.

• Hex - indicates that the text contains hexadecimal codes that specify values from 
X'00' to X'FE.'

• DBCS – indicates that the text contains double-byte code characters. The valid 
double-byte character set (DBCS) codes are from X'41' to X'FE' for each byte.

• Kanji – indicates that the text contains Kanji numbers enclosed in apostrophes. 
The Kanji numbers are separated by commas; e.g., K’321,400.’

For more information on suppressing fields, refer to Chapter 6: "Working with 
FormDef Lists and Objects" on page 95.
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Specifying the Name and Data Presentation Settings for a Field 
in Record Format PageDef
The General category in the Properties – Field dialog of a field in Record Format 
PageDef facilitates you to specify the settings explained above for a Traditional PageDef. 
There are a few more settings available, specific to the Record Format type of PageDef. 
These are explained below.

The following options are also available for selection in the Type drop-down list 
besides Data and Fixed Text (above).
• FieldNum – uses the data associated with the field number specified in the Field 

Num entry-box. Fields are characterized by delimiters in a record data. The 
FieldNum option is available for selection in the Type drop-down list only if a 
delimiter is specified in the properties of the parent record object.

• Record ID – prints the Record ID (bytes 1-10) of the input data.
• PageNum – specifies whether the page number should print or not, and whether 

you want it reset to a specific value rather than using the current value (from the 
page count settings in the PageDef/PageFormat properties).
Select the Print check-box in order to print the page number. Select Reset and 
specify the required value in the associated entry-box to reset the page number.

 In addition to the specified options, you can also align the field data by setting the 
following option:

Align Data – sets the text alignment of the selected field. Either:

• RIGHT – aligns data to the right edge of the field area. 
• LEFT – aligns data to the left edge of the field area.

Setting Field Position
You can place your required fields in the design via the Position category of the 
Properties – Field dialog. It enables you to specify the horizontal and vertical position 
coordinates relative to the specified origin. You can also specify your custom settings.

Horizontal

Offset – sets the horizontal coordinate for positioning the field. Either:

• Custom – customizes the offset by specifying your required horizontal values in 
the associated text box. The specified value is used as an absolute value for the 
horizontal positioning of the field.

• Current – specifies that the inline offset (relative to the direction of the field) is 
the end of the previous field. The record offset is used in case of the first field.
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None – displays a list of available units of measurement for the selected horizontal 
offset.

Vertical

Offset – sets the vertical coordinate for positioning the field. Either:

• Custom – customizes the offset by specifying your required vertical values in the 
associated text box. The specified value is used as an absolute value for the 
vertical positioning of the field.

• Current – indicates that the baseline offset (relative to the direction of the field) 
is the same as the previous field; that is; the baseline position is not changed. The 
record offset is used in case of the first field.

• Next – positions the field one line down in the baseline direction from the 
previous field.

None – displays a list of available units of measurement for the selected vertical 
offset.

Setting the Direction, Font, and Color options for a field is similar to that of a record. For 
details, refer to "Setting Record Properties" on page 157.

Working with the Barcode Field
The barcode field sets a bar code in the PageFormat. A bar code is a collection of lines and 
spaces that are affixed to retail store items, identification cards, postal mail, etc. to identify 
a particular product number, person, or location. The code uses a sequence of vertical bars 
and spaces to represent numbers and other symbols. Visual PPFA facilitates you to use the 
standard bar code features for the identification of your documents.

Adding a Barcode Field
To add a barcode field to a record:

1 In the PageDef tree, select the record node to which you need to add a barcode field.

2 From the menu bar, select Insert>Barcode Field. A NewBarcode field node is added 
to the selected record node in the PageDef tree.

In case of a Record Format PageDef, the Direction options available for a field 
depend upon the position specified for the selected field.
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You cannot add a barcode field to a mapped record (for which Include In Presentation 
option is enabled).

The PageDef tree displaying the added barcode field node. 

Setting Barcode Field Properties
To view and set the properties of a barcode field:

1 In the PageDef tree, right-click the required barcode field node and select Properties 
from the pop-up menu. The Properties – Field, Barcode dialog displays.

2 Select the required category from the Category list.

3 As appropriate, review, enter, or select the dialog options.

4 Click Apply and OK to save the settings.

Specifying the Name and Data Mapping Options for a Barcode 
Field
Visual PPFA assigns a default name to every inserted barcode field. You can change the 
default name in the General category of the Properties – Field, Barcode dialog. 

Name – specifies a meaningful name for the selected barcode field. A user-assigned 
name makes future referencing to the field object easy. This name displays in the 
PageDef tree.
Short Name – sets a short name to be used to refer to the barcode object in the 
application source; make sure that the barcode short name is unique.

You can also add a barcode field by performing one of the following operations:

Right-click the required record node and select Insert>Barcode Field from 
the pop-up menu.

Select the required record node or any of its child nodes and click  on 
the Insert toolbar,
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 The General category also enables you set the following dialog options:
Type – specifies the type of layout to be used for the selected barcode field. Either:

• Data – prints variable data from the input data file.
• Fixed Text – prints static text (explained below) for the current field.
• FieldNum – uses the data associated with the field number specified in the Field 

Num entry-box. Fields are characterized by delimiters in a record data. The 
FieldNum option is available for selection in the Type drop-down list only if a 
delimiter is specified in the record properties.

• Record ID – prints the Record ID (bytes 1-10) of the input data as a barcode.
Start – specifies the position of the starting byte for the selected field.
Length – specifies the length of the field in bytes.
The Start and Length attributes are in reference to the variable data coming from the 
input data file. These options are therefore only available for Data selected as the 
Type.
Include In Presentation – indicates that the selected barcode field is contributing 
(mapped) to the design. A mapped field is shown with  icon in the PageDef tree. 
Although an un-mapped field node is located in the PageDef tree, it does not 
contribute to the PageDef design.

Setting the Standard Barcode Options
Visual PPFA facilitates you to specify certain standard barcode properties as per the 
requirement of your design. Review the following dialog options in the Barcode category 
of the Properties –Field, Barcode dialog:

Type – sets the required barcode type from a list of available barcode standards.

As per your selection of the Type option, you may have certain options enabled that are 
explained below:

Special Properties – displays the Special Properties dialog for your selected 
barcode Type.
Suppress Blanks – suppresses the trailing blanks in the data field used to generate 
the barcode.
SSASTERISKS – specifies whether an asterisk is to be generated as the HRI 
(Human Readable Interpretation) for bar code start and stop characters. 
Mod – sets some additional processing information about the barcode symbol to be 
generated. Different options are available to select from, based upon the selection of 
Type.
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Mod Width – sets the width of the smallest defined barcode element using mils 
(thousandths of an inch). This option is ignored for the barcode types that explicitly 
specify the module width. Set the value in the range 1-254.
Height – sets the height of the barcode element, as per the specified unit of 
measurement.
Ratio – sets the required ratio of the barcode element.
HRI Position – specifies the placement position of the Human Readable 
Interpretation (HRI). Either:

• ON – generates the HRI at the default location for the barcode Type.
• ABOVE – places the HRI above the barcode symbol.
• BELOW – places the HRI below the barcode symbol.
• OFF – does not generate the HRI.
• ONLY – prints the HRI only; the barcode symbol is not generated. 
HRI Font – prints the HRI using the selected font for the barcode.
Color – specifies the color to print the barcode symbol and HRI.

Setting Special Properties for a 2DMATRIX Barcode
In the Properties –Field, Barcode dialog, select 2DMATRIX as the Type and click 
Special Properties to display the Data Matrix Special Properties dialog.

As appropriate, review the available dialog options for the 2DMATRIX barcode and make 
your changes.
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Row Size – sets the size of the row for the required data characters.
Header/Trailer – specifies a special function to be used with a Data Matrix barcode 
symbol. Either:

• FNC1UCC – sets the UCC/EAN1 alternate data type identifier. An FNC1 is 
added in the first data position (or fifth position of a structured append symbol) to 
indicate that the selected barcode symbol conforms to the USS/EAC application 
identifier standard format.

• FNC1IND – specifies the Industry (IND) FNC1 alternate data type identifier. An 
FNC1 is added in the second data position (or sixth data position of a structured 
append symbol) to indicate that the selected barcode symbol conforms to a 
particular industry standard format.

• RDRPROG – specifies that the symbol contains a message used to program the 
barcode reader. 

• MAC5 – provides instructions to the barcode reader in order to insert an industry 
specific header and trailer around the symbol data. The barcode symbol contains 
a 05 Macro codeword. 

• MAC6 – provides instructions to the barcode reader in order to insert an industry 
specific header and trailer around the symbol data. The barcode symbol contains 
a 06 Macro codeword. 

• USERDEF – does not use the special defined functions. This is a user-defined 
data symbol with no header or trailer instructions to the reader.

File ID 1 – sets a low order byte of unique file identification for a set of structured 
append symbols.
File ID 2 – sets a high order byte of unique file identification for a set of structured 
append symbols.

Each of these IDs is a unique number between 1 and 254. The actual File ID is computed 
by multiplying 256 with the sum of File ID 1 and File ID 2.

Process Escape Sequences – specifies that each backslash character within the 
barcode data needs to be treated as a normal data character.
Ebcdic to Ascii Conversion Required – specifies that each byte of data is translated 
from EBCDIC codepage 500 to ASCII codepage 819.
Use sequence command – indicates a structured append sequence. Some two-
dimensional barcodes can be logically linked together to encode large amounts of 
data. The logically linked symbols can be presented on the same or different media 
and are logically recombined after they are scanned. Visual PPFA checks the 
numbers for obvious errors as well as the proper number range. Specify the 
following two fields if you have selected the Use sequence command option:
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Sequence Indicator – sets an integer value in the range 1-16, specifying the 
structured-append sequence indicator.
Total symbols – sets an integer value in the range 2-16, specifying the total number 
of structured-append symbols.

Setting Special Properties for a 2DMAXI Barcode
In the Properties –Field, Barcode dialog, select 2DMAXI as the Type and click Special 
Properties to display the Maxicode Special Properties dialog.

As appropriate, review the available dialog options for the 2DMAXI barcode and make 
your changes.

Use sequence command – indicates a structured append sequence. Some two-
dimensional barcodes can be logically linked together to encode large amounts of 
data. The logically linked symbols can be presented on the same or different media 
and are logically recombined after they are scanned. Visual PPFA checks the 
numbers for obvious errors as well as the proper number range. Specify the 
following two fields if you have selected the Use sequence command option:
Sequence Indicator – sets an integer value in the range 1 to 16, specifying the 
structured-append sequence indicator.
Total symbols – sets an integer value in the range 2-16, specifying the total number 
of structured-append symbols.
Symbol Mode – sets an integer value in the range 2-6. Each number assumes a 
setting given below:
• 2 – sets the Structured Carrier Message as numeric postal code.
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• 3 – sets the Structured Carrier Message as alphanumeric postal code.
• 4 – sets the standard symbol (default).
• 5 – does not support the symbol mode.
• 6 – uses the barcode data to program the bar code reader system. 
Process Escape Sequences – specifies that each backslash character within the 
barcode data needs to be treated as a normal data character.
Ebcdic to Ascii Conversion Required – specifies that each byte of data is translated 
from EBCDIC codepage 500 to ASCII codepage 819.
Use Vertical Zipper Pattern On Right – prints a vertical zipper pattern on the right 
side of the printed 2DMAXI barcode.

Setting Special Properties for a 2DPDF417 Barcode
In the Properties –Field, Barcode dialog, select 2DPDF417 as the Type and click Special 
Properties to display the PDF417 Special Properties dialog.

As appropriate, review the available dialog options for the 2DPDF417 barcode and make 
your changes. 

Data Symbols Per Row – specifies the number of data characters in a row. Set the 
value in the range 1-30. 
Total Rows – specifies the total number of rows. Set the value in the range 3-90. 

The Data Symbols Per Row and Total Rows options determine the size of the two-
dimensional barcode.
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Security Level – sets your required security level from a list of available values. A 
higher security level means more error correction code words to be added to the 
symbol.
Process Escape Sequences – specifies that each backslash character within the 
barcode data needs to be treated as a normal data character.
Ebcdic to Ascii Conversion Required – specifies that each byte of data is translated 
from EBCDIC codepage 500 to ASCII codepage 819.
Use as Macro PDF417 – uses a PDF417 macro for the selected barcode field.
Control Block Data – sets the text of the PDF417 macro for the selected field. This 
option is enabled when you select the Use as Macro PDF417 option.

Specifying the Text
The Text category of the Properties – Field, Barcode dialog sets a fixed text, which is 
required to generate the barcode symbol, provided that Fixed Text is selected in the Type 
option of the General category.

The Position, Direction, Font, and Color options for a barcode field are similar to that of 
a record, and are discussed earlier in this chapter.

Working with Conditions
Conditions are control objects that are added to the PageDef tree and are processed in the 
order of their placement. Condition objects consist of a test statement and an action 
statement. The result obtained after processing the test determines the action to be 
performed. Tasks in this section explain how to use condition objects in a PageDef design.

Adding a Condition
To add a condition object to a record:

1 In the PageDef tree, select the record node to which you want to add a condition 
object.

2 From the menu bar, select Insert>Condition to add a new condition node to the 
selected record.
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The PageDef tree displaying the added condition node. 

Setting Condition Properties
To view and set the properties of a condition object:

1 In the PageDef tree, right-click the required condition node and select Properties 
from the pop-up menu. The Properties – Condition dialog displays.

2 Select the required category from the Category list.

3 As appropriate, review, enter, or select the dialog options.

4 Click Apply and OK to save the settings.

Setting General Properties for Conditions
Visual PPFA assigns a default name to each of the newly inserted condition objects. You 
can change the default name via the General category of the Properties – Condition 
dialog. As appropriate, review the following dialog options:

Condition – specifies a meaningful name for the selected condition that displays in 
the PageDef tree. A user-assigned name makes future referencing to the condition 
object easy.
Short Name – sets a short name to be used to refer to the condition in the application 
source; make sure that the condition short name is unique.

You can also add a condition by performing one of the following functions:

Right-click the required record node and select Insert>Condition from the 
pop-up menu.

Select the required record node or any of its child nodes, and click  on 
the Insert toolbar.
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Field Num – sets the field number to be used in comparison. This option is available 
in Traditional PageDef when the parent record of the selected condition uses 
Delimiter. Fields cannot be counted without delimiters being specified in the 
database.
ANSI CC – prints the subsequent record, if enabled. If this option is disabled, the 
subsequent record is skipped, and the record following the skipped record is printed. 
This option is only available in the Traditional PageDef.

Switching Pages Using Conditional Logic Statements
By using the conditional logic, Visual PPFA enables you to switch from the current 
physical or logical page to any other physical or logical page in the active application. The 
Condition category displays the conditional logic that is applied in your current design. 

To edit any of the conditions, select the required condition and click Edit to display the 
Condition dialog. As appropriate, review the following dialog options to check the input 
data to decide any further action:

Condition
The following two parameters execute to extract a piece of data required for this test from 
the input data file. 

Start – specifies the starting byte of the comparison field within the data record 
where the comparison is to be done.

Length – specifies the length of the comparison field.

The following parameters are used to check the data:
This is – specifies the type of condition used. Either:

• When – starts the comparison parameters of the selected condition. A condition 
should have at least one When situation.

• Otherwise – performs the specified action without any further comparison. If a 
true condition is not detected when an Otherwise statement is encountered, the 
Otherwise statement always results in a true condition.

The carriage-control characters and the table-reference characters are not 
considered as data.
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Operator – specifies a comparison operator for the selected condition. The selected 
operator specifies the type of comparison that needs to be performed between the 
data in the comparison field (portion of the record specified by Start and Length) 
and the constant text defined in the Value parameter. The available options are:

• = – refers to “equal to.”
• != – refers to “not equal to.”
• > – refers to “greater than.”
• >= – refers to “greater than or equal to.”
• < – refers to “lesser than.”
• <= – refers to “lesser than or equal to.”

Value – specifies some constant text for comparison with the text in the comparison 
field. The length of the constant text must be the same as the value for the Length 
parameter, with a maximum length of 8000 bytes.
Duplicate – specifies the number of times the text entered in Value needs to be 
duplicated.
Length – displays the total computed length of the Value string multiplied by the 
Duplicate value. 
Type – specifies the type of the text used in the selected condition. Either:

• Char – specifies that the text contains single-byte code characters consisting of 
all Roman alphabetic characters including blanks.

• Hex – specifies that the text contains hexadecimal codes that specify values from 
X'00' to X'FE.'

• DB Char – specifies that the text contains double-byte code characters. The valid 
Double-Byte Character Set (DBCS) codes are from X'41' to X'FE' for each byte.

• Kanji – specifies that the text contains Kanji numbers that are enclosed in 
apostrophes. The Kanji numbers are separated by commas, e.g., K’321,400.’

The Condition dialog options.
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Action

Process – sets the processing time of the selected condition. Either:

• Before – specifies that the conditional processing begins prior to the processing 
of the current record or sub page.

• After – specifies that the conditional processing begins after the processing of 
the current record or sub page.

Current – specifies the processing action of the selected condition. Either:

• Page – specifies that the conditional processing begins before or after the current 
sub page is processed.

• Line – specifies that the conditional processing begins before or after the current 
record is processed.

Change – specifies the type of action that needs to be taken for the selected 
condition. Either:

• Custom – enables the Copy Group and Page Format options so that you can 
customize your condition settings.

• New Form – invokes a new CopyGroup by ejecting to the new sheet.
• New Side – invokes a new PageFormat by ejecting to the next side of the sheet or 

to the next partition (in case of NUP). 
Copy Group – displays a list of the CopyGroups used in the current application. The 
list also shows the following generic options to switch to any of the CopyGroups:

• Current – invokes the current CopyGroup.
• First – invokes the first CopyGroup in the current FormDef.
• Next – invokes the next CopyGroup in the current FormDef.
• Null – does not perform any action.
Page Format – displays a list of PageFormats for the current application. The list 
also shows the following generic options to switch to any of the PageFormats:

• Current – invokes the current PageFormat.
• First – invokes the first PageFormat in the current PageDef.
• Next – invokes the next PageFormat in the current PageDef.
• Null – does not perform any action.

Once you have specified your required conditional logic, click  to add this logic to the 
condition object. You can replace an existing conditional logic by selecting the condition, 

making the required changes in its options, and then clicking  to replace it with the 

modified condition. To delete a conditional logic from the list, select it and click .
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Working with Floating Overlays
Overlays are static forms comprised of constant data such as lines, boxes, text, and logos. 
An AFP overlay can be used as a floating overlay (page overlay) or as a medium overlay. 
Different actions are performed on these two different types of overlays. Floating overlays 
apply to the page and are placed relative to the page origin. Medium overlays always 
apply to the entire medium and are placed at the medium origin. When used with NUP, the 
medium overlay still applies to the entire sheet of paper, not to the individual partitions. 

The same overlay can either be a page overlay or a medium overlay, depending on the 
method used to invoke it for printing. An overlay invoked by a page definition is always a 
floating overlay. An overlay invoked by a form definition without NUP is always a 
medium overlay. When NUP is specified in the form definition, you can specify 
commands to invoke a floating overlay. 

Adding a Floating Overlay
To add a floating overlay to a record:

1 In the PageDef tree, select the record node to which you need to add a floating 
overlay.

2 From the menu bar, select Insert>Floating Overlay to display the Floating Overlay 
dialog.

3 Select your required overlay and click Open to add it in the PageDef tree.

4 The selected floating overlay node displays under the record node in the PageDef 
tree.

The PageDef tree displaying the added floating overlay node. 
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Setting Floating Overlay Properties
To view and set the properties of a floating overlay:

1 In the PageDef tree, right-click the required floating overlay node and select 
Properties from the pop-up menu. The Properties – Form dialog displays.

2 Select the required category from the Category list.

3 As appropriate, review, enter, or select the dialog options.

4 Click Apply and OK to save the settings.

Setting General Properties for Floating Overlay

You can use a floating overlay in your design by using the resource name either from the 
data file or mentioning it explicitly in the properties associated with the floating overlay 
object. In the General category of the Properties – Form dialog, review the following 
options:

General

Name – displays the name of the resource added as the floating overlay. Click  if 
you need to change the selected overlay resource in the Open Resource File dialog.
Use quoted name – enables you to set a valid overlay name in the Name textbox.
Use variable name – extracts the overlay name from the record data coming from 
the data file. Selecting this option enables the Start and Length options.
Start – specifies the starting byte of the overlay field in the data record.
Length – specifies the number of bytes to process from the data record, beginning 
with the position specified in Start.

You can also add a floating overlay by performing one of the following functions:

Right-click the record node and select Insert>Floating Overlay from the pop-
up menu.

Select the required record node or any of its child nodes and click  on 
the Insert toolbar.
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Include In Presentation – indicates that the floating overlay is contributing 
(mapped) to the design. This option is enabled only if the parent record of the 
selected floating overlay is mapped. A mapped record is shown with  icon in the 
PageDef tree. Although an un-mapped overlay node is located in the PageDef tree, it 
does not contribute to the PageDef design.

Setting the Position of the Floating Overlay
You can specify the parameters for positioning your floating overlay via the Position 
category of the Properties – Form dialog. As appropriate, review the dialog options:

Horizontal, Vertical – sets the required horizontal and vertical offset values, per 
specified unit of measurement.
None – displays a list of available units of measurement respective to the Horizontal 
and Vertical offsets.

Setting Rotation of the Floating Overlay
You can also specify the orientation of your floating overlay via the Rotation category of 
the Properties – Form dialog. As appropriate, review and select the following option:

Rotation – sets the rotation of the selected floating overlay with respect to the x-
axis. Either:
• 0 degrees – rotates the selected overlay to 0 degrees.
• 90 degrees – rotates the selected overlay to 90 degrees.
• 180 degrees – rotates the selected overlay to 180 degrees.
• 270 degrees – rotates the selected overlay to 270 degrees.

Setting Offsets for the Floating Overlay
You can position a floating overlay in the design area by specifying its offsets in the 
Properties –Form dialog. The offset parameters initially take values from the settings 
specified in the overlay resource. You can modify the settings in the Offset category by 
specifying the Horizontal and Vertical offsets along with their respective units of 
measurement.
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Merging Variable Data with a Floating Overlay
To merge variable data with a floating overlay, ensure that the required overlay is added to 
the record and the Include in Presentation option is enabled for both the record as well as 
the overlay. Add another data record and drag and drop the record node onto the required 
overlay location in the design area. The record is mapped to the selected overlay location.

Mapping data to a static overlay in the PageDef.

Positioning an Overlay Relative to a Record
An overlay is always positioned relative to the record to which it is added. Right-click the 
added overlay node and select Properties from the pop-up menu. Specify your required 
horizontal and vertical coordinates setting in the Position category of the Properties – 
Form dialog. For details on the dialog options, refer to "Setting the Position of the 
Floating Overlay" on page 182. The overlay is successfully placed at the specified 
position relative to the record.
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Positioning the overlay relative to the record.

Loading an Overlay as a Template
The template overlay feature of Visual PPFA enables you to place and preview the 
overlays that are being used in the PageDef. Any overlay that can be loaded in the design 
area can also be used as a template; however, this does not hold true for Elixir native 
format (*.epd) overlays. Templates are not a part of the design and are not saved with the 
document. 

Visual PPFA provides a separate Template window to display a tree view of the template 
overlays added for a PageDef. Each overlay displays as a separate node in the tree.

Adding a Template Overlay
To add a template overlay:

1 In the Template window, select Template Overlays.

2 From the menu bar, select Insert>Template Overlay to display the Overlay dialog.

3 Select your required overlay and click Open to add the template overlay node to the 
Template tree.
184 DesignPro Visual PPFA User Guide



The Template tree displaying the added template overlay node.

The properties of the template overlay are set in the same manner as that of the floating 
overlay. For details, refer to "Setting Floating Overlay Properties" on page 181.

Working with Floating Segments
Segments are defined data groups that can be printed at a selected page location, and 
repeated at the same location on every printed page; such as logos, signatures, or bar 
charts. The segments do not have any specific, defined environment parameters, but 
instead inherit parameters defined for their associated PageFormat, record, or overlay. The 
segments are added as child nodes of a record in the Visual PPFA PageDef tree. A 
maximum of 127 segments can be inserted for each PageFormat, but each segment must 
have a unique name. Once added to a PageDef, you can view segments in the design area 
and set their properties.

Adding and setting the properties of the floating segments are done in the same manner as 
that of the floating overlay. For details, refer to "Adding a Floating Overlay" on page 180 
and "Setting Floating Overlay Properties" on page 181. However, floating Segments do 
not have Rotation and Offset categories.

You can also add a template overlay by performing one of the following functions:

In the Template tree, right-click the Template Overlays node and select 
Insert>Template Overlay from the pop-up menu.
Select the Template Overlays node in the Template tree or any of its child 

nodes, and click  on the Insert toolbar.
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Adding a Floating Segment
To add a floating segment to a record:

1 In the PageDef tree, select the record node to which you need to add a floating 
segment.

2 From the menu bar, select Insert>Floating Segment to display the Floating Segment 
dialog.

3 Select your required segment (*.seg) and click Open to add it in the PageDef tree.
The selected floating segment node displays under the record node in the 
PageDef tree.

The PageDef tree displaying the added floating segment node.

You can add a floating segment by performing one of the following functions:

Right-click the required record node and select Insert>Floating Segment from 
the pop-up menu.

Select the required record node or any of its child nodes and click  on 
the Insert toolbar.
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Working with External Objects
Visual PPFA facilitates you to add external objects such as text, graphics, images, and 
barcodes in a PageDef. These objects can contain environment information for 
determining the location and orientation of the data on a page.

Adding an Object
To add an object to your PageDef design:

1 In the PageDef tree, select the record node to which you want to add an object.

2 From the menu bar, select Insert>Object to add an object node to the PageDef tree.

The PageDef tree displaying the added object node. 

Setting Object Properties
To view and set the properties of an object:

1 In the PageDef tree, right-click the required object node and select Properties from 
the pop-up menu. The Properties – Object dialog displays.

2 Select the required category from the Category list.

3 As appropriate, review, enter, or select the dialog options.

4 Click Apply and OK to save the settings.

You can also add an external object by performing one of the following functions:

Right-click the required record node and select Insert>Object from the pop-
up menu.

Select the required record node or any of its child nodes, and click  on 
the Insert toolbar.
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Setting General Properties of an Object
Visual PPFA facilitates you to specify the object resources that you require for your 
design. You can select an object from the object list or get the resource name from the 
input data file, and then use it as an object resource.

Make sure that you have already added an object list along with the required object(s) for 
your PageDef. For details on object lists, refer to "Working with an Object List" on page 
139 . To set the properties for the objects, review the following options in the General 
category of the Properties – Object dialog:

Resource name – specifies your required resource from a list of defined objects 
from the added object list. This option is only enabled when Use variable name is 
selected.
External name – displays the external name of the resource object, which indicates 
where the object is located.
Use variable name – enables the Resource name and External name options to 
specify your required object.
Start – specifies the starting byte of the object field in the data record.
Length – specifies the number of bytes to process from the data record, beginning 
with the position specified in Start.
Object Type – specifies the type of object used. Either:
• PSEG – uses page segment.
• IOCA – uses the Image Object Content Architecture (IOCA). 
• BCOCA – uses Barcode Object Content Architecture (BCOCA). 
• GOCA – uses Graphic Object Content Architecture (GOCA). 
• TIFF-14 – uses Tagged Image File Format (TIFF). 
• WINDIB 17 – uses Windows Device Independent Bitmap.
• OS2DIB 18 – uses Operating System 2 Device Independent Bitmap.
• GIF-22 – uses Graphic Interchange Format (GIF). 
• JFIF-23 – uses JPEG File Interchange Format. 
• PCX 19 – uses PC Paintbrush file format.
Object Color – specifies a color to be used as the default color for placing the 
object.
Include In Presentation – indicates that the selected object is contributing (mapped) 
to the design. A mapped object is shown with  icon in the PageDef tree. Although 
an un-mapped object node is located in the PageDef tree, it does not contribute to the 
PageDef design.
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Setting Object Position
You can place your objects anywhere in the design by setting their offsets via the Position 
category of the Properties – Object dialog. To position the objects, review the following 
dialog options:

Object offset

Horizontal, Vertical – sets the required horizontal and vertical offset values, per 
specified unit of measurement.
None – displays a list of available units of measurement respective to the Horizontal 
and Vertical offsets.

Setting Object Content Position
Visual PPFA enables you to specify the placement positions of the object contents. You 
can type or select the required horizontal and vertical offsets for the object contents along 
with their respective units of measurement. For this, select the USEOBJ option of the 
Position category to activate the object content offsets.

Working with End Subpage
A PageFormat consists of one or more subpages. A subpage consists of a group of 
PageDef objects followed by an end subpage object. If an end subpage is not defined, then 
the entire PageFormat is considered to be a single subpage. The end subpage objects can 
only be used with Traditional PageDefs.

Adding an End SubPage
To add an end subpage object:

1 In the PageDef tree, select the record node next to which you need to add the end 
subpage object.

2 From the menu bar, select Insert>End SubPage to add an End SubPage node.
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PageDef tree displaying the End Subpage node added next to a record node. 

You do not need to set any properties with an end subpage object. The occurrence of an 
end subpage is used to mark the boundaries between multiple subpages. Subpages are only 
required with conditional processing. Multiple-up printing can be done with or without 
defining the subpages. However, in order to change the PageFormat or CopyGroup at the 
level of any multiple-up pages, the multiple-up pages need to be defined as subpages.

You can also add the end subpage by performing one of the following functions:

Right-click the required record node and select Insert>End Subpage from the 
pop-up menu.

Select the required record node or any of its child nodes, and click  on 
the Insert toolbar.
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Chapter 10:

Working with 
DrawGraphic

This chapter describes how to add DrawGraphic and EndGraphic objects to your design, 
and how to set their properties. DesignPro Visual PPFA enables you to use graphic objects 
relative to the variable data while designing your PageDef. These objects, which can be 
added to a logical page, are referred to as DrawGraphic objects in PPFA. 

About DrawGraphic
The DrawGraphic objects include all of the shapes typically used in a design namely lines, 
boxes, circles, and ellipses. In addition to this, EndGraphic objects are used in conjunction 
with the DrawGraphic objects. The EndGraphic object signals the end of an active 
DrawGraphic object. Unlike the graphic objects created at design time and stored as 
overlays, the DrawGraphic objects are generated at t print time, as is the case with variable 
data placed on a PageDef.

In this chapter...

Adding a DrawGraphic Object

Setting DrawGraphic Object Properties

Adding an EndGraphic Object

Setting EndGraphic Object Properties

The DrawGraphic support is available for designing the Record Format PageDefs 
only, and cannot be used with Traditional PageDefs.
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Adding a DrawGraphic Object
To add a DrawGraphic object: 

1 In the PageDef tree, select a record node.

2 On the Insert toolbar, click any one of the following as required:

 – adds a DrawGraphic line node to the PageDef tree.

 – adds a DrawGraphic box node to the PageDef tree.

 – adds a DrawGraphic circle node to the PageDef tree.

 – adds a DrawGraphic ellipse node to the PageDef tree.

PageDef tree with the added DrawGraphic objects. 

You can also add a DrawGraphic object by performing one of the following 
functions:

Right-click a record node and select Insert>Required DrawGraphic object from 
the pop-up menu.
Select a record node in the PageDef tree. From the menu bar select 
Insert>Draw Graphics>Required DrawGraphic object.
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Setting DrawGraphic Object Properties
Visual PPFA facilitates you to specify custom attributes for the DrawGraphic objects that 
are added to a PageDef. To view and set the properties of a DrawGraphic object:

1 In the PageDef tree, right-click a DrawGraphic object node and select Properties 
from the pop-up menu. The Properties dialog for the object displays.

2 Select your required Category, and enter the appropriate settings.

3 Click Apply and OK to save your settings and return to the application window.

Setting Object Name and Graphic ID
Visual PPFA assigns a default name and graphic ID (Graph ID) to every newly added 
DrawGraphic object. The EndGraphic object uses the Graph ID to indicate the end of the 
active DrawGraphic object. You can change the default values in the General category of 
the Properties dialog.

To set a new name and Graph ID for the selected object, review the following dialog 
options:

General

Name – specifies a meaningful name for the selected DrawGraphic object. A user-
assigned name makes future referencing to the object easy.
Graph ID – sets the identification mark for EndGraphics to end all of the active 
graphics with a matching graphic ID. An active graphic is one that is started but not 
ended, for example, a vertical line or a box with no vertical size. Set an integer value 
in the range 0-65534.

You can also launch the Properties dialog by selecting the node of the required 
object in the PageDef tree, and performing one of the following functions:

From the menu bar, select View>Properties.

Click  on the Standard toolbar.
Press <Alt> + Enter from the keyboard.

The Graph ID is specified for the line and box objects only.
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Include In Presentation – indicates that the selected object is contributing 
(mapped) to the design. A mapped object is shown with  icon in the PageDef tree. 
Although an un-mapped object node is located in the PageDef tree, it does not 
contribute to the PageDef design. This option is enabled when its parent record is 
mapped (i.e., the Include In Presentation option of the record node is selected).

Setting Object Position
Visual PPFA facilitates you to set horizontal, as well as vertical offsets for DrawGraphic 
objects. You can set the offset values along with their reference positions in the Position 
category of the Properties dialog. These offsets collectively determine the placement of 
the object in the final print output.

Horizontal

Offset – sets the horizontal coordinate for positioning the object. Either:
• Custom – customizes the offset by specifying your required horizontal values in 

the associated text box. The specified value is used as an absolute value for the 
horizontal positioning of the object.

• LPos – sets the layout position (LP) of the parent record as the reference position 
for the horizontal offset value.

None – displays a list of available units of measurement for the selected horizontal 
offset.

Vertical

Offset – sets the vertical coordinate for positioning the object. Either:
• Custom – customizes the offset by specifying your required vertical values in the 

associated text box. The specified value is used as an absolute value for the 
vertical positioning of the object.

• LPos – sets the layout position (LP) of the parent record as the reference position 
for the vertical offset value.

• CPos – sets the current position (CP) of the previous field or DrawGraphic object 
as the reference position for the vertical offset value.

• Next – specifies that the selected object is to be positioned down one line from 
the previous field, as defined in the Margins category of the current PageFormat.

None – displays a list of available units of measurement for the selected vertical 
offset.
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Setting the Dimensions for Line and Box Objects
You can set the dimension and direction of the selected line or box via the Dimension 
category of the Properties dialog. As appropriate, review and set the following options:

Dimension

Width – sets the length of a horizontal or diagonal line or width of a box object, as 
applicable.

None – displays a list of available units of measurement for specifying the Width of 
the selected object.
Height – sets the length of a vertical or diagonal line or height of a box object, as 
applicable.
None – displays a list of available units of measurement for specifying the Height of 
the selected object.
Use Floating height – sets the length of a vertical line or height of a box using an 
EndGraphic object. 

Direction

Across – sets the line horizontally by enabling you to specify the width of the 
selected line.
Down – sets the line vertically by enabling you to specify the height of the selected 
line.
To – sets the line in a slanting (diagonal) position enabling you to specify both the 
width, as well as the height for the selected line.

You can only specify width for horizontal line and height for a vertical line.
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(1) Direction of the line set to ‘To,” Width set to 2.000 in and Height set to 1.000 in. 
(2) A slanting line drawn in the design area diagonal to a box of Width: 2.000 in and 
Height: 1.000 in.

Setting Object Style options
The Style category of the Properties dialog sets the line (borderline in case of box, circle, 
and ellipse) properties of the selected object. You can specify your required line style, as 
well as the thickness for your design. Review the following dialog options:

Style

Line style – displays a list of available line styles to select from.
Thickness – sets the thickness of the selected line or object border. Either: 
• Light – sets a thickness of 0.01 inches to the selected line/object borders.
• Medium – sets a thickness of 0.02 inches to the selected line/object borders.
• Bold – sets a thickness of 0.03 inches to the selected line/object borders.
• Custom – uses a custom integer value, via an associated box, for the width of the 

line/object borders. Set the value in the range 0-999. Specify 0 to have invisible 
borders (ignoring the style and color of the line).

Rounded
The Rounded option is only available in the Style category of a DrawGraphic box. You 
can also specify a style for the corners of a box. As required, select any one of the 
following:

None – uses sharp corners for the selected box.
Small – uses slightly rounded corners for the selected box.
Medium – uses medium-sized rounded corners for the selected box.
Large – uses large-sized rounded corners for the selected box.
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Max – uses the maximum possible rounded sized corners; in such cases, the object 
generally takes shape of a circle.

Design area displaying different rounded options for a DrawGraphic box.

Setting the Copy options
In Visual PPFA, you can copy a DrawGraphic object by specifying the required settings in 
the Copy category. Review the following options in the Properties dialog of the selected 
DrawGraphic object:

Copy

Number of copies – specifies the number of copies you require for the selected 
object. Set the value in the range 0-999. 
Spaced value – sets the distance between the object copies, per specified unit of 
measurement.
None – click this button to display the list of available units of measurement. In the 
list, select the required option for Spaced value.
None – displays a list of available units of measurement for Spaced value.
Diameter – sets the spacing between the copies of a DrawGraphic circle object to be 
equal to its diameter.

Direction

Across – places the object copies horizontally in the design area.
Down – places the object copies vertically in the design area.
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(1) The copies of DrawGraphic circle object placed vertically. (2) The copies of 
DrawGraphic circle object placed horizontally.

Setting Object Color
Visual PPFA enables you to specify the line/borderline color of an object in the Color 
category. You can select a new color from the OCA color list, or a defined color from the 
color list. To set a color, select one of the following options:

Use this color – sets a color from the OCA color list. Click  to display the list of 
available colors.
Use defined color – uses a color that is already defined in the PageDef color list. 
You can also add the required color to the color list and then apply it to the selected 
DrawGraphic object. For details, refer to "Adding Colors to a Color List" on page 
136.

Setting the Fill options for a DrawGraphic object
Visual PPFA facilitates you to fill a DrawGraphic object using a list of available patterns 
and colors. The Fill category is available in the Properties dialog for the DrawGraphic 
boxes, circles, and ellipses. You can also use different patterns and colors on different 
copies of the same object.
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To specify the fill options for a selected DrawGraphic object or any of its copies:

1 In the Fill category, click  to add a row of color, its pattern, and scope.

2 As appropriate, review and select the dialog options:
Scope – specifies the copy number of the object for which you are setting the fill 
options. Select ALL to apply the same specifications to all copies of the selected 
object.
Pattern – specifies the color pattern to fill in the object.
Color – specifies the color in which the Pattern is to be applied to the selected 
object.

Setting the Radius for a Drawgraphic Circle
To set the radius of a DrawGraphic circle, specify the following options in the Radius 
category of the Properties dialog:

Radius – sets a value specifying the radius of the selected circle.
None – displays a list of available units of measurement for the specified radius.

Setting the Axis for a Drawgraphic Ellipse
The major and minor axes of an ellipse determine the dimensions and angle of rotation for 
an ellipse. The Axis category of the Properties – Ellipse dialog is therefore used to specify 
the size and orientation of a DrawGraphic ellipse object on a logical page.

An ellipse displaying its Major and Minor axes. 

Since you cannot have copies for a DrawGraphic ellipse object, the Fill category 
of an ellipse does not have the Scope option.
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The major axis is the longer of the two lines with respect to which the ellipse is 
symmetrical. The minor axis is the length of the line formed by the two endpoints closest 
to the center of the ellipse (the shortest axis). The x and y movements are either in the 
positive or negative direction from the center point where both the axes meet.

Major axis/ Minor axis

X Position – sets the values of the x coordinate of the selected ellipse.
Y Position – sets the values of the y coordinate of the selected ellipse.
None – displays a list of available units of measurement respective to the X position 
and the Y position.

About EndGraphic
An EndGraphic object signals the end of a DrawGraphic object whose vertical size is not 
earlier specified. EndGraphic objects are used to limit the vertical size of a line or a box to 
some specific number of lines. A single EndGraphic object can be associated with one or 
more DrawGraphic objects.

The axes coordinates must be explicitly set following the standard ellipse 
mathematics to ensure the correct appearance of the ellipse.

The EndGraphic feature can only be used with the DrawGraphic line and box 
objects.
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Adding an EndGraphic Object
To add an EndGraphic object, right-click a record node in the PageDef tree, and select 
Insert>EndGraphic from the pop-up menu. The EndGraphic node displays in the 
PageDef tree.

PageDef tree with the added EndGraphic object. 

Setting EndGraphic Object Properties
The EndGraphic object enables you to end all of the active graphics with a matching 
Graph ID. An active graphic is one that has been started but not ended, for example a 
vertical line or a box with no vertical size. To view and set the properties of an 
EndGraphic object:

1 In the PageDef tree, right-click the required EndGraphic object node and select 
Properties from the pop-up menu. The Properties – End Graphic dialog displays.

2 Select the required category from the Category list.

3 Select your required Category, and enter the appropriate settings.

4 Click Apply and OK to save your settings and return to the application window.

You can also add an EndGraphic object by selecting a record node in the PageDef 
tree, and performing one of the following functions:

Click  on the Insert toolbar.
From the menu bar select Insert>Draw Graphics>End Graphic.
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Setting EndGraphic Name and Graph ID
Visual PPFA assigns a default name and Graph ID to every newly added EndGraphic 
object. The Graph ID specified for an EndGraphic object is used to end all of the active 
graphics with a matching Graph ID. You can change the default values in the General 
category of the Properties – End Graphic dialog. 

To specify a new name and Graph ID for the selected object, review the following options:

General

Name – specifies a meaningful name for the EndGraphic object. A user-assigned 
name makes future referencing to the selected object easy.
Graph ID – sets a value matching a previously defined Graph ID value for an active 
DrawGraphic object that you need to end.

Setting EndGraphic Object Position
Visual PPFA enables you to specify a vertical offset position for an EndGraphic object. 
You can set the offset values along with their reference positions in the Position category 
of the Properties- End Graphic dialog. These options collectively determine the 
placement of the object in the final print output. Review the following dialog options:

You can also launch the Properties – End Graphic dialog by selecting the 
EndGraphic node in the PageDef tree, and performing one of the following 
functions:

From the menu bar, select View>Properties. 

Click  on the Standard toolbar.
Press <Alt> + Enter from the keyboard.

If no Graph ID is specified, then all of the DrawGraphic objects that do not have 
a Graph ID are closed.
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Vertical

Offset – sets the vertical coordinate for positioning the EndGraphic object. Either:
• Custom – customizes the offset by specifying your required vertical values in the 

associated text box. The specified value is used as an absolute value for the 
vertical positioning of the object.

• LPos – sets the layout position (LP) of the parent record as the reference position 
for the vertical offset value.

• CPos – sets the current position (CP) of the previous field or DrawGraphic object 
as the reference position for the vertical offset value.

• Next – specifies the selected object is to be positioned down one line from the 
previous field, as defined in the Margins category of the current PageFormat.

None – displays a list of available units of measurement for the selected vertical 
offset.

Graph ID specified in an EndGraphic object must match the already defined value 
for the DrawGraphic object. If no Graph ID is specified, all of the DrawGraphic 
objects that have no associated Graph ID will be closed.
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Chapter 11:

Performing Standard 
Operations on Visual 
PPFA Objects

This chapter describes procedures to perform standard operations on various Visual PPFA 
objects, such as copying, deleting, and moving objects, as well as opening and saving 
them in various formats.

Opening FormDefs and PageDefs
Visual PPFA enables you to open the FormDefs and PageDefs originally saved in Elixir 
native, PPFA source, or AFP object formats. You can also specify the input parser settings 
for the FormDefs and PageDefs saved in either PPFA source or AFP object formats.

Opening a Recently Used FormDef or PageDef
Visual PPFA maintains a list of recently created or used FormDefs and PageDefs to help 
you keep track of the frequently used files.

In this chapter...

Opening FormDefs and PageDefs

Editing FormDefs and PageDefs

Saving FormDefs and PageDefs
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To open a recently used FormDef or PageDef, you can perform either of the following two 
functions:

1 From the main bar, select File>required PageDef or FormDef.
The most recently created/used file displays at the top of the list with sequence 
number 1.
Or
From the menu bar, select File>Open. The Open dialog displays. Select the History 
tab to view the recently used files. Select the required FormDef or PageDef from the 
dialog list, and click Open. The selected FormDef/PageDef displays.
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Opening an Elixir FormDef or PageDef
To open an Elixir FormDef (*.efd) or PageDef (*.epd) file: 

1 From the menu bar, select File>Open to display the Open dialog.

2 Select the required .EFD or .EPD file and click Open.
The selected Elixir FormDef/PageDef displays.

You can also launch the Open dialog to open an Elixir FormDef or PageDef by 
performing one of the following functions:

Click  on the Standard toolbar.
Press <Ctrl> + <O> from the keyboard.

A user with insufficient rights may receive a warning message on opening a file 
that contains references to the mapping database. For more information, refer to 
the “Appendix A: Error and Warning Messages” in the DesignPro Manager for AFP 
User Guide.
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Opening PPFA Source or AFP Object FormDef or 
PageDef

To open a PPFA Source or an AFP Object FormDef or PageDef:

1 From the menu bar, select File>Open to display the Open dialog.

2 Select your required PPFA Source of AFP Object FormDef/PageDef in the Files of 
type list. 

3 Click Edit property settings… to display the AFPDS or PPFA Property Settings 
dialog, depending on the Files of type selection. In the dialog, specify the 
appropriate input parser settings.
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4 Click Open to display the selected FormDef/PageDef.

Opening a Legacy Document
Apart from supporting its own formats, Visual PPFA also supports native and legacy 
resource formats. For users of Elixir Application Suite, existing AppBuilder FormDefs 
and PageDefs can be migrated to Visual PPFA. Elixir AppBuilder (Document.dbf) file 
can contain multiple FormDefs and PageDefs. You can open a file in Visual PPFA to 
select your required FormDefs and PageDefs.

To open a legacy document:

1 From the menu bar, select File>Open to display the Open dialog.

2 Select Elixir AppBuilder 4.xx (Document.dbf) from the Files of type list.

3 Click the Elixir tab. The legacy files display in the dialog.

For details on setting the input parser options, refer to the “Chapter 6: File 
Format Dictionary” in the DesignPro Manager for AFP User Guide. For details on 
converting files to different formats, refer to Chapter 4: "Preparing to Work" on 
page 59.

When opening a PPFA Source document, the font resolution is not preserved. 
You can set your required font resolution using the Resolution options in the 
Font category of PPFA Output Properties.

The resources that are created using AppBuilder version 4.10 or higher can be 
opened in the DesignPro Tools for AFP.
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4 Select the required legacy file and click Open to display the dialog listing the 
contents of the Document.dbf file.

5 Click OK to open the document.

Legacy files, once modified, cannot be saved to a legacy format when opened in Visual 
PPFA. You can save the file in Elixir, AFP object, or PPFA source formats. 

Editing FormDefs and PageDefs
Once created, you can edit a FormDef or a PageDef by a variety of options. You can add 
objects by selecting Insert>Required Object from the menu bar. You can set properties for 
the new objects and edit properties of the existing ones. You can also change the position 
of the objects in the PageDef or FormDef tree by dragging and dropping them to the 
required location in the tree window. Apart from all these functionalities, Visual PPFA 
also facilitates you to copy, move, and delete the objects when required.
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Copying Objects
To copy a FormDef or a PageDef object, right-click the object tree node and select Copy 
from the pop-up menu. To paste the copied node, right-click the required location in the 
FormDef or PageDef Tree window, and select Paste from the pop-up menu.

The copied object displays as a new node in the tree view; the design area and source 
view also reflect the changes. 

You can also copy/paste an object directly in the design area. Right-click the required 
object and select Copy from the pop-up menu. However, when you Paste the object, it is 
pasted exactly on the original object and you need to drag it to your required location in 
the design area.

Deleting Objects
To delete a FormDef or a PageDef object, right-click the required object node in the 
FormDef/PageDef tree and select Delete from the pop-up menu. However, you cannot 
delete certain requisite nodes. For example, in case of a PageDef, you cannot delete the 
PageDef or the Font List nodes. Furthermore, if a design has a single PageFormat or 
record node, then the node cannot be deleted. For a FormDef, in addition to the main 
FormDef node, the design should at least have a single instance of CopyGroup as well as 
SubGroup nodes.

You can also copy an object by selecting it in the tree view or the design area and 
performing one of the following functions:

From the menu bar, select Edit>Copy and Edit>Paste to Copy and paste the 
object.

Click  and  on the Standard toolbar to copy and paste the object.
Press <Ctrl> + <C> and <Ctrl> + <V> from the keyboard to copy and paste 
the object.
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Deleting an object from the design area will only un-map it and the object node will not be 
deleted from its tree.

Moving Objects
To move an object in the design area or in the PageDef or FormDef tree, select the object 
and drag it to your required location and then release the mouse button. The selected 
object displays in the new location. Note that changing the location of the object nodes 
does not bring any change to your design. In order to change the position of objects in the 
design area, you either need to change the position settings, or drag the actual object in the 
design area, as specified above.

Saving FormDefs and PageDefs
By default, Visual PPFA saves the FormDefs and PageDefs in Elixir FormDef (.efd) and 
Elixir PageDef (*.epd) formats. However, you can also save your FormDef /PageDef in 
AFP FormDef Object (.obj), AFP PageDef Object (.obj), or PPFA Source (.src) formats. 
The AFP FormDef and PageDef Object (.obj) formats are used for the IBM environment, 
whereas the PPFA Source format enables you to edit a FormDef or PageDef outside the 
Visual PPFA environment. To save the FormDef or PageDef in either OBJ or SRC 
formats, you can optionally use converter settings to customize file format properties. For 
example; if you need to print a FormDef or a PageDef saved at 240 pels resolution on a 
printer working at 300 pels resolution, you can save that FormDef/PageDef with the 
required settings via the output converter settings. 

You can also delete an object by selecting it in the tree view or in the design area, 
and performing one of the following functions:

From the menu bar, select Edit>Delete.
Press <Del> from the keyboard.

While designing your documents in DesignPro Visual PPFA, keep in notice that 
the size of any resource used in a design does not exceed 16.7 MB. Resources 
with a size greater than 16.7 MB do not convert to the DOS/VSE format.
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Saving a FormDef or PageDef to Elixir Format
To save an Elixir FormDef (*.efd) or PageDef (*.epd) file:

1 From the menu bar, select File>Save>FormDef to display the FormDef Save As 
dialog or select File>Save>PageDef to display the PageDef Save As dialog, 
whichever required.

Whenever a design is created or edited and is closed without saving, DesignPro 
Visual PPFA prompts the user to save the changes.
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2 Click Save to save your FormDef/PageDef.

Saving a FormDef or PageDef to AFP Object or PPFA 
Source Format

To save a PageDef or FormDef to PPFA Source or AFP Object format:

1 From the menu bar, select File>Save>FormDef to display the FormDef Save As 
dialog.
Or
From the menu bar, select File>Save>PageDef to display the PageDef Save As 
dialog.

You can also launch the PageDef Save As dialog to save an Elixir PageDef by 
performing one of the following functions:

From the menu bar, select File>Save As>PageDef.

Click , and then click  on the Standard toolbar.
Press <Ctrl> + <S> from the keyboard.

You can also launch the FormDef Save As dialog to save an Elixir FormDef by 
performing one of the following functions:

From the menu bar, select File>Save As>FormDef.

Click , and then click  on the Standard toolbar.
Press <Ctrl> + <M> from the keyboard.
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2 Click Edit property settings… to display the AFPDS or PPFA Property Settings 
dialog, depending on the Files of type selection. 

3 Specify the appropriate output converter settings in the dialog.
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4 Click Save to save your FormDef or PageDef in your required AFP Object or PPFA 
Source format.

For details on setting the output converter options, refer to “Chapter 6: File 
Format Dictionary” in the DesignPro Manager for AFP User Guide. For details on 
converting files to different formats, refer to Chapter 4: "Preparing to Work" on 
page 59.

When opening a PPFA Source document, the font resolution is not preserved. 
You can set your required font resolution in the Resolution options of the 
Font category of PPFA output properties.
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Chapter 12:

Working with Overlays

This chapter describes how to work with an overlay in PageDef and FormDef, and the 
procedure to use it as a template. It also provides information on using the Visual PPFA 
form design tools for editing overlays.

Working with Overlays in Visual PPFA
An overlay is a static form comprised of predefined constant data such as lines, shadings, 
text, boxes, and logos, etc. that are stored as AFP resources. The overlays are primarily 
used in place of preprinted forms. Using overlays instead of preprinted forms gives you 
greater flexibility; enables you to efficiently change the forms; eliminates storage space 
needed for the preprinted forms; and decreases the operator intervention that is needed to 
print the forms. DesignPro Form Editor enables you to design overlays and save them in 
various output formats. Visual PPFA merges these overlays with the variable data to 
produce variable data documents.

In Visual PPFA, an AFP overlay can be used either as a page overlay or a medium 
overlay. Page overlays apply to the page and are placed relative to the page origin. 
Medium overlays apply to the entire medium and are placed at the medium origin.

In this chapter...

Using Overlays in FormDef

Using Overlays in PageDef

Using Overlays as Templates

Editing Overlays using Design Tools
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Using Overlays in FormDef
You can use an overlay to add a constant form to a FormDef, which is then printed on each 
physical page. Overlays are added to the FormDef tree SubGroup node. Each SubGroup 
can comprise a maximum of 255 overlays. Once created and added to the tree, you can 
view the overlays in the design area and set or modify their properties. You can position 
an overlay on a page by specifying the horizontal and vertical offsets.

You can also specify overlays with basic and enhanced NUP options. In case of basic 
NUP, the same overlay is repeated in each of the partitions, whereas in enhanced NUP, 
each partition can contain a separate overlay. 

An overlay invoked by a FormDef without NUP is referred to as a medium overlay. When 
NUP is specified in the form definition, you can specify both page and medium overlays. 

A FormDef with overlays added to SubGroups and NUP partitions. 

For more information on using overlays in a FormDef, refer to "Working with 
Overlays" on page 105.
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Using Overlays in PageDef
Visual PPFA supports the use of overlays in a PageDef design enabling you to 
dynamically place different overlays in correspondence with the data placed on a logical 
page. An overlay invoked by a PageDef is referred to as a page overlay, or the floating 
overlay. The floating overlay is added to the record object.

A PageDef with floating overlays. 

Using Overlays as Templates
For variable data to accurately display on the medium overlay, you need to have a proper 
coordination amongst the overlay, FormDef, and PageDef. Visual PPFA provides a 
template overlay feature to place and preview the overlays that are being used in a 
PageDef. Any overlay that can be loaded into the design area can be used as a template. 
However, templates are not part of the design and are not saved with the document.

Visual PPFA provides a separate Template window to display a tree view of the template 
overlays that are added for a PageDef. Each overlay displays as a node in the tree. When 
designing a PageDef, the overlay that is used as a template is usually the one being used in 
the corresponding FormDef.

For more information on using overlays in a PageDef, refer to "Working with 
Floating Overlays" on page 180
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The Template tree with the added Template Overlays. 

Editing Overlays using Design Tools
Design Pro Tools provides a Form Editor module for creating and editing overlays. These 
overlays are then used in Visual PPFA as templates, or as a part of the FormDef and 
PageDef objects. Once loaded in Visual PPFA, you can edit the overlays using the form 
designing tools.

To edit a loaded overlay, right-click the overlay node and select Open form for edit from 
the pop-up menu.
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The design area with an overlay for editing.

Once opened for editing, you can modify the existing objects that constitute the overlay. 
You can also add new objects using the Tools toolbar. You can add lines, boxes, ellipses, 
paths, text, images, signatures, and all active objects. You can also modify the properties 
of these objects using the associated toolbar that displays on selecting an object from the 
Tools toolbar.
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You can use object filters to help in the design process, by selecting the required filter 
from the Filter toolbar. On applying a filter for an object type, the occurrences of the 
object in the design cannot be selected. You can set object filters for lines, boxes, ellipses, 
paths, text, images, and barcodes.

You can also select a tool by selecting Insert>Form Design Tools>Required Tool 
from the menu bar.
222 DesignPro Visual PPFA User Guide



After making all of the required changes, right-click the overlay node, and select Close 
edited form from the pop-up menu. You can also close the form for editing by clicking 
any of the tree nodes. Visual PPFA prompts a confirmation message to ensure that you 
save your changes. You can choose to save or discard the changes. If you select the Insert 
As option of Filename Only, Relative Path To Profile Server Root, or Absolute Path 
when loading the overlay, the changes are incorporated in the original overlay. To prevent 
any type of modification in the original file, select the Embedded option when loading the 
overlay.

You can also select an object filter by selecting View>Object Filters>Required 
Filter from the menu bar.

Visual PPFA also facilitates you to launch the Form Editor separately to edit or 
create overlays by selecting Tools>Form Editor from the menu bar. For more 
information on editing overlays, refer to DesignPro Form Editor User Guide.
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Chapter 13:

Working in Project 
Mode

This chapter describes how to work with documents in Visual PPFA Project Mode.

About Project Mode
Visual PPFA provides a display-based method for proofing pageDefs and formDefs using 
samples of EBCDIC, ASCII, and mixed-mode print data.  This accurately generates an 
output that would be produced using InfoPrint (PSF) and an IPDS-capable printer (cut-
sheet or continuous form) in the Elixir Viewer.

Visual PPFA needs to run in the Project Mode in order to proof the documents.  Project 
Mode requires opening both the pageDef, as well as the formDef in the design area with at 
least one mapped pageDef object.

Viewing Document Design in Project Mode
Project Mode enables you to review a document design by displaying the formDef and 
pageDef tree structures.  You can also add pageDef and formDef objects and perform 
editing functions in the Project Mode.

You can either open a new pageDef/formDef and add the associated controls in the design 
area, or open an existing pageDef or formDef.  To enable the editing function, select 
View>Object Filters>PageDef Editable for a pageDef, and View>Object Filters>FormDef 
Editable for a formDef.  If these options are not selected, then the loaded formDef or 
pageDef objects cannot be modified.

In this chapter...

About Project Mode

Viewing Document Design in Project Mode

Adding PageDef or FormDef in Project Mode
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You can also select to view or hide the loaded formDef or pageDef.  To view the formDef, 
select View>Object Filters>FormDef Visible from the menu bar.  To view the pageDef, 
select View>Object Filters>PageDef Visible from the menu bar.

Application with the pageDef Visible option set to off.  The records do not display in the 
design area, though they are included in the presentation (i.e. are mapped).

To enable editing, you can also: 

Click   on the Filter toolbar for a formDef object.

Click  on the Filter toolbar for a pageDef object.

To make a formDef or a pageDef visible, you can perform the following functions:

For a formDef, click  on the Filter toolbar. 

For a pageDef, click  on the Filter toolbar.
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Adding PageDef or FormDef in Project Mode
You can add a formDef object to a design when a pageDef object is opened in the design 
area.  For this, select Project>Add New FormDef from the menu bar.  In case of a formDef 
being opened in the design area, you can perform either of the following functions:

From the menu bar, select Project>Add New Traditional PageDef to add a Traditional 
pageDef to your design.  To add a Record Format pageDef, select Project>Add New 
Record Format PageDef from the menu bar.

The pageDef and formDef controls displaying in their respective trees.

Select the appropriate option on the Project  toolbar to perform your required 
function: 

Click  to add a formDef.

Click  to add a Traditional pageDef.

Click  to add a Record Format pageDef.
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Loading a FormDef or PageDef in Project Mode
To load an already designed formDef (*.efd) or pageDef (*.epd) to an active page or form 
definition: 

1 From the menu bar, select Project>Load FormDef or PageDef to display the Open 
dialog.

2 Select the appropriate option from the Files of type list to display the available 
pageDefs or formDefs in the dialog.

3 Select the required file, and click Open.

The Project Mode can only consist of a single pageDef and formDef.  If you try to load a 
formDef or pageDef when one is already loaded in the application, a confirmation 
message displays.  As appropriate, replace or continue working on the existing pageDef or 
formDef.

Removing FormDef or PageDef from the Project Mode
To remove a formDef or a pageDef from the Project Mode, do the following:

From the menu bar, select Project>Remove PageDef to remove the loaded pageDef from 
the design.

Or 

From the menu bar, select Project>Remove FormDef to remove the loaded formDef from 
the design.

If your formDef/pageDef is not saved, Visual PPFA prompts you to save it before 
removing it from the design.

You can also launch the Open dialog to load a FormDef or PageDef by clicking 

 on the Project toolbar. 

To remove a formDef or pageDef from the Project  toolbar: 

Click  to remove the formDef.

Click   to remove the pageDef
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Chapter 14:

Working with Data

This chapter provides information about data file and data encoding formats, and 
describes procedure to work with sample data.

Data Formats for Traditional and Record 
Format PageDefs

Visual VPPFA supports line data with both Traditional, as well as Record Format 
PageDefs. Line data is ASCII or EBCDIC data that is formatted for printing on line 
printers. It is the text-only data and is stored as records or lines of data. The data file is 
selected on the basis of the following two criteria: 

The design requirements.
The storage and transmission requirements. 

Data File Formats
A data file is comprised of variable data required for a print job. This data is specifically 
arranged in a particular format for printing on line printers, and is commonly referred to as 
line data. Each line of data in line data is regarded as a record. Any part of a record is a 
field. The data records in a data file may contain control characters such as carriage 
control (CC), table-reference characters (TRC), or simply data. A Visual PPFA PageDef 
resource is used to arrange the records and fields of line data for the final print output.

In this chapter...

Data File Formats

Data Encoding Formats

Working with Sample Data

Data Mapping
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The arrangement of data within a data file depends on the design requirements, based on 
which the line data is categorized as the following:

Traditional line data.
Record Format line data.

Traditional Line Data
Traditional line data is data formatted for printing on a line printer. Fully formatted line 
data can be printed on a line printer without a page definition, however, all line data needs 
a page definition to be printed on a page printer.

A traditional line data record can contain a 1-byte carriage control character and a 1-byte 
table reference character followed by the data to be printed. 

Traditional data file displaying the variable data arranged in line. This type of format is 
useful when designing the reports in which the arrangement of data will not vary much 
from one instance to the other.

With a line printer, the maximum number of data bytes in a single input record is 
208. With a page printer, the maximum number is 32,768 bytes.
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Record Format Line Data
The record formatting function enables an application to specify a format identifier 
(record ID) with each set of data fields (data record). The format identifier references a 
specific layout format in a Page Definition (PageDef). At print time, each layout format 
(referenced by a record id in a data record) is retrieved from the PageDef and used to 
position and format the associated data records/fields on the output page. The PageDef can 
contain any number of layout formats. The application can use a PageDef layout format to 
either insert an end of page when a specified last line point is exceeded on the output page 
or to force an end of page.

A Record Format data file. 

Data Encoding Formats
The data encoding formats use a code that links a set of characters with a set of numbers, 
electrical pulses, or some other entity, in order to store and transmit text in computers. The 
most commonly used encoding standards that Visual PPFA supports are as follows:

American Standard Code for Information Interchange.
Extended Binary Coded Decimal Interchange Code.
Mixed-mode data.

ASCII
ASCII (American Standard Code for Information Interchange) encodes letters, numerals, 
and other symbols as integers, as well as 7-bit binary version of those integers. It is a 
character set and a character encoding format based on the Roman alphabet used in 
modern English and other Western European languages. It is most commonly used by 
computers and other communication equipment to represent text, and by control devices 
that work with text. ASCII encoded files use the *.txt extension. 
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EBCDIC
EBCDIC (Extended Binary Coded Decimal Interchange Code) is a binary code for 
alphabetic and numeric characters that IBM developed for its operating systems. EBCDIC 
is extensively used for text files and at times, also for certain legacy applications and 
databases. In an EBCDIC file, each alphabetic or numeric character is represented with an 
8-bit binary number. EBCDIC encoded files use the *.ebc extension.

Mixed-Mode Data
Visual PPFA enables you to use structured fields embedded with typical line data in a data 
file. These structured fields carry PPFA commands for invoking a certain PageDef or a 
FormDef object. Using this feature, you can add information regarding the design along 
with its relevant set of data records in the data file. This enables you to load PageDef and 
FormDef objects dynamically based on the data. The design object is initially invoked on 
processing and then the data is positioned. Note that you can also load variable overlays, 
segments and objects (images, graphics, and resource libraries) dynamically in a 
document design by referring to their respective names in a data file. However, this is 
accomplished through the use of floating overlays, floating segments and external objects 
inserted in a PageDef object. For more information, refer to Chapter 9: "Working with 
PageDef Objects" on page 151.

To view or edit an EBCDIC data file, use a text editor that supports the EBCDIC 
format.
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Working with Sample Data
A sample data file is used to map variable data in order to set up the PageDef design. The 
arrangement of data using the sample file is used as a template for all of the documents to 
be printed in the same format.

Loading/Unloading a Sample Data File
The data file first needs to be loaded in the design area in order to map the variable data on 
a PageDef. 

To load a data file:

1 From the main menu, select Project>Load Sample Data File to display the Open 
sample data file dialog.

2 As appropriate, review the dialog options and make your changes.

3 Click OK to save the settings and return to the application window.

Structured fields cannot be mapped to the PageDef design.

You can also load a sample data file by clicking  on the Project toolbar. 

You can load sample data files with record length up to 32,767 characters at 
maximum.
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Setting Data File Properties
To specify the data file properties, review the following dialog options:

Sample data file

Data File – displays the name and path of the data file that you need to load as a 

sample. Clicking  displays the Open dialog, where you can select the required 
data file.

File length

Starting line number – sets the starting line number of the record in the data file. To 
load the complete file, specify 1.
Number of lines to read – sets the number of lines of data you need to load. Specify 
the total number of lines in order to load the complete file.

You can also reload the sample data file by setting the specifications in the text boxes next 

to the  (Start Line) and the  (File Length) icons on the Project toolbar. Press 
<Enter> or <Tab> on the keyboard to reload the sample data file with the new 
specifications.

File Encoding

ASCII – sets the ASCII encoding standard for the loaded data file. 
EBCDIC – sets the EBCDIC encoding standard for the loaded data file. 
Mixed-mode data – specifies that the required file contains mixed-mode data. 

File Record Format

File Format – sets the pattern followed by a data file to signify the occurrence of a 
new record. Either:
• Stream NewLine – indicates a new line of record at the occurrence of the 

specified New Line Char (explained below).
• Record,n – indicates that a line of record is of the specified Record Length.

For details on file encoding options, refer to the "Data Encoding Formats" on 
page 231.
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New Line Char – displays the character signifying the start of a new line of record. 
This is a read-only field having a default value of 0D0A. 0D0A is the ASCII value 
for Carriage Return – Line Feed.
Record Length – sets the size of a record (bytes) in the data file. This option is 
enabled only when Record,n is selected from the File Format list. 

Control Characters

Carriage Control – specifies that each record in the data file carries a carriage 
control character. The first byte of a record is reserved for carriage control 
characters.
TRC – specifies that each record in the data file carries a Table Reference Character 
(TRC). If a record already contains the carriage control character, its second byte 
will hold the TRC. If there is no carriage control character, then the first byte will 
hold the TRC.

To unload a data file, click  on the Project toolbar. 
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Data Mapping
On loading a sample data file, the contents display in a dockable Sample Data window in 
the application workspace. The Sample Data window displays the sample data on the 
basis of the settings specified in the Open sample data file dialog. For details, refer to the 
"Loading/Unloading a Sample Data File" on page 233.

A Traditional data file containing the carriage control and table reference characters 
loaded to the Sample Data window is displayed in the following image:

Similarly, a Record Format data file with no control characters loaded to the Sample Data 
window is displayed below:

Visual PPFA enables you to map sample data to your design by setting separate properties 
for records and fields. It also facilitates you to map traditional data by using the drag and 
drop features.
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Mapping Records
To map a line of record from the data file to a record object in the PageDef design, select 
the Include In Presentation option from the General category of the selected record. On 
selecting this option, the record is mapped to the design and becomes visible in the design 
area.

To map a record visually using the drag and drop features:

In the case of Record Format data, you cannot map records using the drag and drop 
feature. To map a record in the Record Format PageDefs, open the General category of 
the Properties – Record dialog. Specify the value identical to the record ID for the record 
in the data file. This maps the record with the specified record ID to the required record 
object.

Mapping Fields
To map a field from the data file to the PageDef design, select the Include In 
Presentation option for the field object. This option is available in the General category 
of the selected field. On selecting this option, the field is mapped to the design and 
becomes visible in the design area. You can specify the following parameters for a field in 
the General category:

Start – specifies the starting byte to position the field in the record.
Length – specifies the length of the selected field in bytes.
Chapter 14: Working with Data 237



You can also map a field visually by using the drag and drop feature, as illustrated below:

Mapping Barcodes
Mapping a barcode field follows the same steps as mapping a normal field. While 
mapping a barcode field using the drag and drop feature, press the <Shift> key from the 
keyboard.  For details on mapping a normal field, refer to "Mapping Fields" on page 237.

In case of Record Format data, you cannot map fields using the drag and drop 
feature. Fields cannot be added to the records that are already mapped to the 
PageDef design..
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Chapter 15:

Proofing Designs

This chapter provides information about proofing designs and previewing, as well as 
printing the contents of the design area.

About Data Proofing
Visual PPFA facilitates you to preview your print output once the FormDef and PageDef 
are designed. The display-based proofing process, referred to as data proofing, merges the 
FormDef and the PageDef resources with the selected data file to generate a preview of 
the output. Data proofing is performed in the Project Mode. Project Mode provides a joint 
display of the PageDef and FormDef in the design area, thus enabling you to 
simultaneously view all of the objects. 

Preparing for Data Proofing
The AFPProofing.ini file saves the data proofing options, except for data file selection, for 
all application sessions. For this reason, you need to specify a data file after the initial 
install and before executing a proofing action for the first application run. This can be 
done either by using the AFP Proofing dialog or loading a sample data file. If a sample 
data file is loaded, the data file name in Proofing.ini file will be overwritten with the name 
of the sample data file. The name of this file also displays in the AFP Proofing dialog in 
read-only mode.

In this chapter...

Setting Data Proofing Properties

Running Proofing

Previewing and Printing the Design Area Contents
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After loading a document design in Project Mode, specify a sample input data file along 
with the data proofing properties. Before proofing, you can view the PageDef and 
FormDef resources in the Resource Manager window.

Setting Data Proofing Properties
To successfully proof your design, specify the required data proofing settings prior to 
running the proofing process. For setting the data proofing properties:

1 From the menu bar, select Project>Proofing Settings to display the AFP Proofing 
dialog.

2 Select your required Category, and enter the appropriate settings.

3 Click Apply and OK to save your settings.

Setting the Data File and Associated Properties
The proofing process merges the PageDef, FormDef, and an associated data file to 
generate a preview of the print output. You can specify the data file along with other 
relevant settings in the General category of the AFP Proofing dialog. To specify the 
proofing settings, review the following options:

Sample Data File
This parameter lets you indicate the data file you intend to use for the proofing operation. 
Select the sample data file you have used for the design.

Data File – specifies the name and path of the data file for your proofing operation. 
Clicking  displays the Open dialog to select your required data file.

Visual PPFA enables you to proof your design at any time during the designing 
process, provided that the application is running in Project Mode. You can, 
however, specify the data proofing settings even when the application is not in 
Project Mode.
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File Encoding

ASCII – specifies the ASCII encoding standard for the loaded data file. 
EBCDIC – specifies the EBCDIC encoding standard for the loaded data file. 

File Record Format

File Format – sets the pattern followed by the selected data file to signify the 
occurrence of a new record. Either:
• Stream – considers one line of data as one record.
• Stream NewLine – indicates a new line of record at the occurrence of the 

specified New Line Char (explained below).
• Record – indicates that the first two bytes of each line specify the length of the 

record.
• Record,n – indicates that a line of record is of the specified Record Length.
New Line Char – displays the character signifying the start of a new line of record. 
This option is enabled only when Stream NewLine is selected from the File Format 
options. Either:
• 0D0A – refers to the ASCII value for Carriage Return – Line Feed (CRLF). It 

indicates the start of a new record whenever a CRLF character is met in the 
datastream.

• 0D – refers to the ASCII value for Carriage Return (CR). It indicates the start of a 
new record whenever a CR character is met in the datastream.

• 0A – refers to the ASCII value for Line Feed (LF). It indicates the start of a new 
record whenever an LF character is met in the datastream.

Record Length – specifies the size of a record (in bytes) in the data file. This option 
is enabled only when Record,n is selected from the File Format list. Set the value in 
the range 1-32767.

Control Characters

Carriage Control – specifies that each record in the data file carries a carriage 
control character. The first byte of a record is reserved for carriage control 
characters.
TRC – specifies that each record in the data file carries a Table Reference Character 
(TRC). If a record already contains the carriage control character, its second byte 
will hold the TRC. If there is no carriage control character, then the first byte will 
hold the TRC.
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Carriage Control Type – specifies the encoding type for the carriage control 
characters that are being used in the selected data file. This option is enabled only 
when Carriage Control is selected. Either:
• NONE – does not specify any carriage control type.
• ANSI…ASCII – encodes the ANSI carriage control characters in ASCII.
• ANSI…EBCDIC – encodes the ANSI carriage control characters in EBCDIC.
• IBM MACHINE – encodes the machine code carriage control characters in 

Hexadecimal format.

Specifying Font Settings
Before running the data proofing, you can specify some general settings for the fonts that 
are used in the design. To specify the font settings, review the following options in the 
Miscellaneous category of the AFP Proofing dialog:

Font Reference
This parameter lets you specify an option on how you want to refer to the fonts used in 
your design. Font references are used in picking up the fonts utilized in an application to 
apply them for actual printing. Select one of the following options, whichever is 
applicable:

CharSet CodePage Name – uses the character set and the code page name to refer 
to fonts that are used in the design.
Coded Font Name – uses the coded font name to refer to fonts that are used in the 
design.

Processing Mode

PRMODE – sets the SOSI (Shift-Out, Shift-In) data processing mode. Either:
• SOSI1 – specifies that each shift-out, shift-in code can be converted to a blank 

and a Set Coded Font Local text control.
• SOSI2 – specifies that each shift-out, shift-in code can be converted to a Set 

Coded Font Local text control only.

Make sure that you specify the same font references as you did in the Fonts 
category of the AFPDS dialog (select Tools>Application Format Settings>Output 
Formats>AFPDS… from the menu bar). For more information on AFPDS 
property settings, refer to “Chapter 6: File Format Dictionary” in the DesignPro 
Manager For AFP User Guide. 
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• SOSI3 – specifies that each shift-out character can be converted to a Set Coded 
Font Local Text Control field and two blanks. Each shift-in character is 
converted to a Set Coded Font Local Text Control followed by two blanks.

• NONE – specifies not to perform SOSI data processing.

CHARS

Name – specifies TRC references to the fonts that you require for printing the 

document. You can give a list of four TRC items. Click  to add an item in the 
associated list. TRC fonts used in the PageDef will be overridden during proofing 
with the fonts (if any) specified here.

Running Proofing
After specifying the AFP proofing settings for the active PageDef /FormDef, you can now 
proof the application design by clicking Project>Run Proofing from the menu bar. 
Informational and error messages (if any) display in the Messages window. After the 
proofing is successfully run, the document opens in the Elixir Viewer. You can view the 
result and confirm your design.

For proper functionality of the SOSI process modes, the first font specified in 
CHARS parameter (or in the PageDef font list) must be an SBCS font, and the 
second font must be a DBCS font.

You can also run proofing by clicking  on the Project toolbar. 
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Previewing and Printing the Design Area Contents
To preview the design area contents before merging the resources:

1 From the menu bar, select File>Print Preview, or click  on the Standard toolbar. 
The DesignPro Visual PPFA displays the active document in Print Preview mode.

2 As appropriate, Zoom In or Zoom Out the document, or Print it using the available 
options.
244 DesignPro Visual PPFA User Guide



To print the design area contents:

1 From the menu bar, select File>Print; or click  on the Standard toolbar to display 
the Print dialog. 

2 Review the dialog and make your changes.

3 Click OK to print the contents and return to the design area.

Printer

Name – specifies the installed printer name with its path. 
Properties – displays a properties dialog for the selected printer.
Status – displays the operating state of the printer.
Type – displays the name of the selected printer.
Where – displays the network location of the selected printer.
Comment – displays a brief narrative describing the printer.

Print Range

All – prints the entire page.
Selection – prints the selected contents of the page only.

Copies

Number of copies – specifies the required number of copies to be printed.

Page Shift (in DPI)

X Shift – specifies the horizontal page shift, in dots per inch.
Y Shift – specifies the vertical page shift, in dots per inch.

It is recommended to preview the document before printing it.
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Appendix A:

Workspace Glossary

This appendix provides information on DesignPro Visual PPFA workspace environment 
menu bars, toolbars, and keyboard shortcuts.

Menu bar
DesignPro Visual PPFA provides a horizontal menu bar located right below the title bar. 
The menu bar provides access to standard Windows, as well as DesignPro Visual PPFA-
specific menu items. Each menu item in the menu bar is associated with a drop-down 
menu. You can perform standard Windows operations to hide or display a menu bar, or 
you can dock a menu bar at the edge of the design area.

Visual PPFA provides the following menu items:
File
Edit
View
Insert
Project
Tools
Window
Help

In this appendix...

Menu bar

Toolbars

Form Design Tools

Keyboard Shortcuts
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File Menu
The File menu provides access to the following commands:

Edit Menu
The Edit menu provides access to the following commands:

Icon Menu Item Purpose Hot Keys

New Creates a new file. <Ctrl> + <N>

Open Displays the Open dialog to 
open a required resource file.

<Ctrl> + <O>

Close Closes the active PageDef or 
FormDef.

<Alt> + <F> + <C>

Close All Closes all of the PageDef and 
FormDef resources.

Save Saves the active FormDef or 
PageDef.

<Ctrl> + <S>

Save As Displays the Save As dialog to 
save an active FormDef or 
PageDef with a new name.

Save All Saves all of the open 
PageDefs and FormDefs.

<Ctrl> + <Shift> + <S>

Print Setup Displays the Print Setup 
dialog.

Print Preview Provides a view of the 
PageDef as it will print.

<Alt> + <F> + <V>

Print Displays the Print dialog. <Ctrl> + <P>

Exit Quits the application. <Alt> + <F4>

Icon Menu Item Purpose Hot Keys

Undo Reverses the last action. <Ctrl> + <Z>

Redo Cancels the last undo action. <Ctrl> + <Y>

Cut Cuts the selection. <Ctrl> + <X>
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View Menu
The View menu provides access to the following commands:

Copy Copies the selection to the 
clipboard.

<Ctrl> + <C>

Paste Pastes the previously copied 
text onto the selected area in 
the design area.

<Ctrl> + <V>

Delete Deletes the selection. Delete

Select All Selects the entire PageDef or 
FormDef resources in the 
design area.

<Ctrl> + <A> 

Invert Selection Cancels the previous 
selection.

Find Displays the Find dialog. <Ctrl> + <F>

Find Next Searches for the next 
occurrence of the specified 
data.

F3

Replace Displays the Replace dialog. <Ctrl> + <H>

Icon Menu Item Purpose Hot Keys

Full Screen Switches the display of the 
workspace from Normal 
view to the Full Screen view.

Zoom Controls the magnification 
level of the design area. Also 
displays the Zoom sub-
menu. For more information 
on Zoom, refer to the Zoom 
toolbar section below.

Toolbars Controls the display of the 
toolbars; also displays the 
Toolbars submenu.

Status Bar Shows or hides the Status 
bar.

Icon Menu Item Purpose Hot Keys
Appendix A: Workspace Glossary 249



PageDef Tree Shows or hides the PageDef 
Tree window. 

<Ctrl> + <Shift> + <P>

Template Tree Shows or hides the Template 
Tree window. 

<Ctrl> + <Shift> + <T>

FormDef Tree Shows or hides the FormDef 
Tree window. 

<Ctrl> + <Shift> + <F>

Messages Shows or hides the Messages 
window. 

<Ctrl> + <Shift> + <M>

Resource 
Manager

Shows or hides the Resource 
Manager window. 

<Ctrl> + <Shift> + <R>

Sample Data Shows or hides the Sample 
Data window. 

<Ctrl> + <Shift> + <D>

Ruler Shows or hides the graphical 
ruler in the design area.

F2

Grid Shows or hides the grid. F4

Guidelines Shows or hides the 
guidelines.

F6

Long Crosshair Shows or hides the crosshair. F8

Full Preview Displays the page 
presentation settings.

Swap Sheet 
Dimensions

Switches paper orientation 
from portrait to landscape 
and vice-versa.

Clear Messages Clears all of the messages 
from the Messages window.

<Ctrl> + <D>

Refresh Reloads the design area 
contents.

F5

Object Filters Displays all of the Filter 
tools. Refer to the “Filter 
Toolbar” section below for 
more information.

Properties Displays the Properties 
dialog for the selected object. 

<Alt> + <Enter>

Icon Menu Item Purpose Hot Keys
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Insert Menu
The Insert menu provides access to the following menu commands:

Icon Menu Item Purpose

PageFormat Adds a PageFormat object to the PageDef tree.

Record Adds a record object to the PageFormat node of the 
PageDef tree.

Field Adds a field object to the record node of the 
PageDef tree.

Barcode Field Adds a barcode field object to the record node of the 
PageDef tree.

Condition Adds a condition object to the record node of the 
PageDef tree.

Floating Segment Adds a floating segment object to the record node of 
the PageDef tree.

Floating Overlay Adds a floating overlay object to the selected record 
node of the PageDef tree.

Object Adds an object to the record node of the PageDef 
tree.

End Subpage Adds an End Subpage object to the selected 
PageDef tree record node.

Draw Graphics Displays a sub menu to add the drawGraphic objects 
in a record node.

CopyGroup Adds a CopyGroup object to the FormDef tree.

SubGroup Adds a SubGroup object to the CopyGroup node of 
the FormDef tree.

Overlay Adds an overlay object to the SubGroup node of the 
FormDef tree.

Template Overlay Adds a template overlay object to the Template tree.

Lists Displays the available PageDef and FormDef lists.

Form Design Tools Displays the form design tools. For more 
information, see “Form Design Tools” section 
below.
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Project Menu
The Project menu provides access to the commands used in Visual PPFA Project Mode.

Tools Menu
The Tools menu provides access to the following commands: 

Icon Menu Item Purpose Hot Keys

Add New 
FormDef

Adds a FormDef to the 
design area.

Add New 
Traditional 
PageDef

Adds a Traditional PageDef 
to the design area.

Add New 
Record Format 

PageDef

Adds a Record Format 
PageDef to the design area.

Load FormDef 
or PageDef

Loads a PageDef or 
FormDef in the design area.

Remove 
FormDef

Removes a FormDef from 
the design area.

Remove 
PageDef

Removes a PageDef from the 
design area.

Load Sample 
Data File

Loads a data file in the 
design area.

Unload Sample 
Data File

Removes the data file from 
the design area.

Proofing 
Settings

Displays the AFP Proofing 
dialog.

Run Proofing Runs data proofing and 
displays the result in the 
Elixir Viewer.

<Ctrl> + F5

Icon Menu Item Purpose Hot Keys

Spell Checker Displays the Check Spelling 
dialog. 

F7

Form Editor Launches the DesignPro 
Form Editor.

Resource Map Launches the Elixir 
Resource Map.
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Profile Editor Launches the Elixir Profile 
Editor.

Layout Displays options to place the 
objects in the design area.  
Either: Bring to front, Send 
to back, Bring Forward, or 
Send Backward.

Split Text Splits the selected text object 
into two objects. 

Join Text Displays options to join the 
text objects in the design 
area. Either Join By Spaces, 
Join By Justify, or Join By 
Relative.

Reformat Text Enables you to fix the layout, 
indentation, and alignment of 
the text object.

Rulers and Grid Displays the rulers and grid 
options in the submenu. 

Options Displays the Options dialog. 

Profile 
Selection

Displays the Profile 
Selection dialog. 

Application 
Format Settings

Displays the Application 
Format Settings submenu for 
setting the application 
properties; also enables you 
to Load, Save, and Clear the 
Setup file at the Application 
level.

Document 
Format Settings

Displays the Document 
Format Settings submenu to 
set the document properties; 
also enables you to Load, 
Save, and Clear the Setup 
file at the Document level.

Icon Menu Item Purpose Hot Keys
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Window Menu
The Windows menu provides access to the following commands:

Help Menu
The Help menu provides access to the following commands:

Icon Menu Item Purpose

Cascade Rearranges and resizes all of the open design 
resources so that they overlap each other.

Tile Rearranges and resizes all of the open design 
resources so that they do not overlap each other.

Arrange All Arranges the documents that are open in the design 
area.

Split Splits the design area into four partitions, each 
displaying the active design.

Icon Menu Item Purpose Hot Keys

Contents Launches the DesignPro 
Tools for AFP Help file with 
the Contents tab selected.

F1

Search Launches the DesignPro 
Tools for AFP Help file with 
the Search tab selected

<Alt> + <H> + <I>

Index Launches the DesignPro 
Tools for AFP Help file with 
the Index tab selected.

<Alt> + <H> + <I>

Elixir on Web Launches the Elixir website. <Alt> + <H> + <E>

About Visual 
PPFA

Displays the Product 
Version, Copyright, and 
Licensing information.

<Alt> + <H> + <A>
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Toolbars
Visual PPFA toolbars provide access to the most commonly used application commands. 
You can perform standard Windows operations to hide or display a toolbar, dock a toolbar 
at the edge of the design area, or display a toolbar as a palette window.

Visual PPFA provides the following toolbars:
Standard toolbar
View toolbar
Position & Dimension toolbar
Common Attributes toolbar
Filter toolbar
Project toolbar
Insert toolbar
Tools toolbar.

Standard Toolbar
The Standard toolbar provides one-click access to the basic File and Edit menu 
commands.

Button Purpose

Creates a new file.

Opens the selected file.

Saves the active file in the specified format 
(PageDef or FormDef).

Saves the PageDef object.

Saves the FormDef object.

Displays the Print dialog for printing the document.
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View Toolbar
The View toolbar provides shortcuts to workspace viewing commands.

Displays the print preview of the design.

Cuts the selection.

Copies the selection to the clipboard.

Pastes the selection. 

Reverses the last action.

Cancels the last Undo action.

Searches for the first occurrence of the specified 
data.

Searches for the next occurrence of the specified 
data.

Displays the properties dialog for the selected item.

Launches the DesignPro Visual PPFA for AFP help 
file.

Button/Control Box Purpose

Increases the window object magnification.

Reduces the window object magnification.

Sets the window zoom percentage (window) view 
size.

Sets the window display to a predefined 
measurement.

Button Purpose
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Position & Dimension Toolbar
The Position and Dimension toolbar is used for editing the start coordinates and 
dimension operations for an object.

Shows or hides the graphical ruler in the design 
area.

Shows or hides the grid.

Switches Snap to Grid feature on or off.

Displays the Crosshair.

Shows or hides the Guidelines.

Switches the Snap to Guidelines feature on or off.

Switches the Snap to Objects feature on or off.

Displays the page presentation settings in the design 
area. 

Switches the paper orientation from portrait to 
landscape and vice-versa.

Button/Control Box Purpose

Displays the horizontal and vertical coordinates in 
the X and Y entry box on the toolbar for the selected 
object. The red square represents the coordinates of 
the selected object.

Sets the horizontal and vertical start coordinates for 
a selected object.

Button/Control Box Purpose
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Common Attributes Toolbar
The Common Attributes toolbar is used for setting common object properties such as 
color, line style, and thickness.

Sets the width and height values for a selected 
object.

Retains the original height and width proportion 
during the resize operation for an object.

Button/Control Box Purpose

Sets the background and foreground color for a 
selected object.

Sets the pattern for a selected object.

Displays the line thickness selections.

Specifies the custom value for the line thickness.

Displays the predefined borderline styles for an 
object.

Displays the predefined line cap styles for an object.

Button/Control Box Purpose
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Filter Toolbar
The Filter toolbar provides quick access to the filter options provided in DesignPro Visual 
PPFA. You can use the Filter toolbar commands to exclude specified objects in the design 
area from editing functions, such as moving or deleting.

Button Purpose

Shows or hides the PageDef objects.

Shows or hides the FormDef objects.

Switches the editing feature on and off for a 
PageDef object.

Switches the editing feature on and off for a 
FormDef object.

Switches the editing feature on and off for a Line 
object.

Switches the editing feature on and off for a Box 
object.

Switches the editing feature on and off for an Ellipse 
object.

Switches the editing feature on and off for a Path 
object.

Switches the editing feature on and off for a Text 
object.

Switches the editing feature on and off for an Image 
object.

Switches the editing feature on and off for a 
Barcode object.
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Project Toolbar
The Project toolbar provides quick access to the Project menu commands.

Button Purpose

Adds a FormDef to the design area.

Adds a Traditional PageDef to the design area.

Adds a Record Format PageDef to the design area.

Loads a PageDef or FormDef in the design area.

Removes a FormDef from the design area.

Removes a PageDef from the design area.

Loads a data file in the design area.

Removes the data file from the design area.

Specifies the start line of the data file in the adjacent 
text box.

Specifies the length of the data file in the adjacent 
text box.

Runs document proofing and displays the result in 
the Elixir Viewer.
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Insert Toolbar
The Insert toolbar provides one-click access to the Insert and Insert Draw Graphic menu 
commands.

Button Purpose

Adds a PageFormat object to the PageDef tree.

Adds a record object to the selected PageFormat 
node of the PageDef tree.

Adds a field object to the selected record node of the 
PageDef tree.

Adds a barcode field object to the selected record 
node of the PageDef tree.

Adds a condition object to the selected record node 
of the PageDef tree.

Adds an image object to the selected record node of 
the PageDef tree.

Adds a floating overlay object to the selected record 
node of the PageDef tree.

Adds an object to the selected record node of the 
PageDef tree.

Adds an end subPage object to the selected record 
node of the PageDef tree.

Adds a drawGraphic line object to the selected 
record node of the PageDef tree.

Adds a drawGraphic box object to the selected 
record node of the PageDef tree.

Adds a drawGraphic circle object to the selected 
record node of the PageDef tree.

Adds a drawGraphic ellipse object to the selected 
record node of the PageDef tree.

Adds an endGraphic object to the selected record 
node of the PageDef tree.
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Form Design Tools
Form design tools are design operation shortcuts located on the Tools toolbar. This toolbar 
only displays when a loaded form is opened for editing in Visual PPFA. With one-click 
access, you can open various toolbars to perform your required design operations.

When you click a tool on the Tools toolbar, a corresponding toolbar opens above the 
design area. Click another tool, and a new toolbar replaces the previous selection.

Adds a CopyGroup object to the FormDef tree.

Adds a SubGroup object to the selected CopyGroup 
node of the FormDef tree.

Adds an overlay object to the SubGroup node of the 
FormDef tree.

Adds a template overlay object to the Template tree.

Displays the available object lists.

Adds a color list to the active PageDef.

Adds an object list to the active PageDef. 

Adds an overlay list to the active PageDef. 

Adds a segment list to the active PageDef.

Adds a TRC list to the active PageDef.

Adds a suppression list to the active FormDef.

Button Purpose
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The Tools toolbar enables the launching of the following form design toolbars:

Button Purpose

Launches the Select toolbar.

Enables the insertion of a line object in the form and 
launches the Line toolbar.

Enables the insertion of a box object in the form and 
launches the Box toolbar.

Enables the insertion of an ellipse object in the form 
and launches the Ellipse toolbar.

Enables the insertion of a path object in the form 
and launches the Path toolbar.

Enables the insertion of a text object in the form and 
launches the Text Attributes toolbar.

Enables the insertion of an image in the form and 
launches the Image toolbar.

Enables the insertion of a barcode object in the form 
and launches the Barcode toolbar.

Enables the insertion of an Active Button in the 
form and launches the Active Button toolbar.

Enables the insertion of an Active Checkbox in the 
form and launches the Active Checkbox toolbar.

Enables the insertion of an Active Combobox in the 
form and launches the Active Combobox toolbar.

Enables the insertion of an Active Editbox in the 
form and launches the Active Editbox toolbar.

Enables the insertion of an Active Radio Button in 
the form and launches the Active Radio Button 
toolbar.

Enables the insertion of a signature in the form and 
launches the Signature toolbar.
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Select Toolbar
The Select toolbar provides options for selecting and copying objects and drawing 
perpendicular lines.

Line Toolbar
The Line toolbar provides options for drawing horizontal, vertical, and free direction lines.

Button Purpose

Indicates the Select toolbar is open.

Copies the selected object in the design area.

Indicates the number of copies to be made.

Enables the horizontal movement of the copied 
object.

Enables the vertical movement of the copied object.

Enables unrestricted movement of the copied object.

Draws perpendicular lines only.

Button Purpose

Indicates the Line toolbar is open. 

Draws a horizontal line only.

Draws a vertical line only.
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Box Toolbar
The Box toolbar provides options for drawing boxes and specifying box properties.

Draws horizontal or vertical lines only.

Draws a line in any direction.

Button Purpose

Indicates the Box toolbar is open. 

Limits the box shape to a square.

Displays the predefined box corner styles.

Displays the predefined box corner radius styles.

Sets the custom corner radius value.

Draws the box within the confines of an invisible 
boundary.

Sets the horizontal split line thickness and style for a 
box.

Sets the vertical split line thickness and style for a 
box.

Indicates the number of box shape horizontal and/or 
vertical splits (enabled only when Style for 
Horizontal Splits or Style for Vertical Splits is 
selected).

Displays the predefined line thickness values.

Button Purpose
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Ellipse Toolbar
The Ellipse toolbar provides options for drawing ellipses and specifying ellipse properties.

Sets the custom border line thickness, and box shape 
horizontal or vertical splits value (enabled only 
when the Line Thickness Custom option is 
activated).

Displays the predefined line styles for drawing 
lines.

Draws the diagonal inside the box from the top left 
corner to the bottom right corner.

Draws the diagonal inside the box from the top right 
corner to the bottom left corner.

Button/Control Box Purpose

Indicates the Ellipse toolbar is open. 

Draws the ellipse outward from the center.

Draws the ellipse within the confines of an invisible 
boundary.

Displays the predefined shapes for drawing the 
ellipse.

Indicates the angle at which the drawing of the 
ellipse begins.

Indicates the angle at which the drawing of the 
ellipse ends.

Draws the diagonal inside the ellipse from the top 
left to the bottom right.

Draws the diagonal inside the ellipse from the top 
right to the bottom left.

Button Purpose
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Path Toolbar
The Path toolbar provides options for drawing paths and specifying path properties.

Button/Control Box Purpose

Indicates the Path toolbar is open.

Automatically closes the path lines to form a shape.

Leaves all path lines open.

Snaps the path segments to vertical and horizontal 
angles.

Draws the path segments in any direction.

Draws the path segments according to the Line 
Curve formula.

Draws the path segments according to the Bezier 
Curve formula.

Draws the path segments according to the 
Tangential Curve formula.

Completes the path shape drawing.
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Text Attributes Toolbar
The Text Attributes toolbar provides options for the specification of text object 
preferences.

Button/Control Box Purpose

Indicates the Text Attributes toolbar is open. 

Displays the Font List dialog for selecting, adding, 
deleting, or editing the font list items.

Adds the font selected from the drop-down list to 
the text.

Underlines the text.

Draws a line through the text.

Sets the text horizontal justification to the left.

Sets the text horizontal justification to the center.

Sets the text horizontal justification to the right.

Sets the text horizontal justification to both the right 
and the left.

Sets the text vertical justification to the linebase.

Sets the text vertical justification to the top.

Sets the text vertical justification to the center.

Sets the text vertical justification to the bottom.

Sets the inter-word spacing.

Sets the inter-character spacing.
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Image Toolbar
The Image toolbar provides options for adding Elixir format screen or printer images, 
bitmaps, and logos to a form.

On selecting the Image tool from the Tools toolbar, the Open Resource File dialog 
displays. In this dialog, browse and select the required image resource. The selected image 
name displays in the Image toolbar textbox and the image can be placed at any location in 
the design area.

Sets the text block word continuation to the next 
line.

Displays the direction options for the text flow.

Displays the direction options for the text character 
flow.

Displays the Soft Keyboard dialog for adding 
alphabets and special characters.

Button/Control Box Purpose

Indicates the Image toolbar is open.

Indicates the filename of the loaded image.

Displays the Open dialog for loading the external 
image.

Button/Control Box Purpose
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Barcode Toolbar
The Barcode toolbar provides options for adding barcodes to a form and specifying the 
barcode properties.

Active Button Toolbar
The Active Button toolbar provides options for adding active buttons to a form and 
specifying the active button properties.

Button/Control Box Purpose

Indicates the Barcode toolbar is open.

Displays the available barcode types for selection.

Hides the barcode information.

Displays the HRI (Human Readable Interpretation) 
above the barcode.

Displays the HRI (Human Readable Interpretation) 
below the barcode.

Displays the HRI (Human Readable Interpretation) 
type 1.

Displays the HRI (Human Readable Interpretation) 
type 2.

Button/Control Box Purpose

Indicates the Active Button toolbar is open.

Draws a border around the active button.

Displays the selected border color.
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Keyboard Shortcuts
You can use the shortcut keys (also called the accelerator keys or the fast keys) for quick 
access to frequently used commands or operations. The tables below describe shortcut 
keys generally used in DesignPro Visual PPFA.

Text Editing Keyboard Shortcuts
The following table outlines the available keyboard shortcuts for form text editing 
operations:

The Active Checkbox, Active Combobox, Active Editbox, Active Radio Button, and 
Signature toolbars all display the same toolbar commands as the Active Button.

Selecting a tool from the Tools toolbar enables you to place a single object in the 
design area. To place multiple objects of the same type in the design area, double-
click the required tool on the Tools toolbar.

Command Keyboard Shortcut

Copies the selected text. <Ctrl> + <C>

Cuts the selected text. <Ctrl> + <X>

Deletes the left character. <Backspace>

Deletes the right character. <Del>

Deletes the next word. <Ctrl> + <Del>

Deletes the previous word. <Ctrl> + <Bksp>

Deletes to the end of the line. <Ctrl> + <K>

Deletes to the end of the text block. <Ctrl> + <E>

Find <Ctrl> + <F>

Find Next <F3>

Find Previous <Shift> + <F3>

Replace <Ctrl> + <H>

Moves the cursor down one line. < >
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Numeric Display Box Keyboard Shortcuts
The following fast keys can be used to edit numbers within numeric display boxes (e.g., 
tool width option). Numbers are entered right to left, as on a calculator.

Moves the cursor to the left by one 
character.

< >

Moves the cursor to the right by one 
character.

< >

Moves the cursor up one line. < >

Moves the cursor to the left by one word. <Ctrl> + < >

Moves the cursor to the right by one word. <Ctrl> + < >

Moves the cursor to the end of the line. <End>

Moves the cursor to the start of the line. <Home>

Moves the cursor to the end of the text 
block.

<Ctrl> + <End>

Moves the cursor to the start of the text 
block.

<Ctrl> + <Home>

Pastes the previously copied text onto the 
selected area in the design area.

<Ctrl> + <V>

Command Keyboard Shortcut

Changes the decimal value. Click on arrows (where provided)

Changes the integer value. <Ctrl> + click on arrows

Deletes the number (set to 0). <Del>

Deletes the right digit. <Backspace>

Finishes editing. <Enter>

Command Keyboard Shortcut
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Zoom/Pan Control Keyboard Shortcuts
The following fast keys can be used to access the Zoom and Pan Control commands:

With Num Lock off, you can also use the numeric keypad functions as the Zoom/Pan 
control fast keys.

Command Keyboard Shortcut

Pans left < >

Pans up < >

Pans right < >

Pans down < >

Zooms in Numpad + 

Zooms out Numpad - 

Moves the cursor to the top left side of the 
form.

<Home>

Moves the cursor to the bottom left side of 
the form.

<End>

Moves the cursor to the top right side of 
the form.

<Ctrl> + <Page Up>

Moves the cursor to the bottom right side 
of the form.

<Ctrl> + <Page Down>

Scrolls up. <Page Up>

Scrolls down. <Page Down>
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Appendix B:

Glossary
The following is an alphabetical listing of product-specific or unique terms and 
abbreviations used in this guide.

AFP
Advanced function printing.

ANSI (American National Standards Institute)
An organization consisting of producers, consumers, and general interest groups. ANSI 
establishes the procedures which accredited organizations create and maintain voluntary 
industry standards.

Barcode
An array of parallel rectangular bars and spaces that together represent data elements or 
characters of a particular type. 

Baseline
A conceptual line with respect to which successive characters are aligned.

Baseline Direction
The direction in which successive lines of text appear on a logical page.

BCOCA (Bar Code Object Content Architecture)
An architected collection of constructs used to interchange and present barcode data.

Carriage Control Character (CC)
The first character of an output record (line) that is to be printed or spaced.

Character Set
A group of alphabetic, numeric, and other characters that have some relationship in 
common. For example, the standard ASCII character set includes letters, numbers, 
symbols, and control codes that make up the ASCII coding scheme.

Code Page
Text file that maps character hexadecimal value to associated graphic character identifier.

Condition
Standard logical test (e.g., IF, ELSE, ELSEIF, etc.) for making processing decisions.
275



CopyGroup
A subset of a form definition (FormDef) containing a set of controls for the physical pages 
of a printout. Such functions as the selection of either of two paper sources on the page 
printer, the use of duplex printing, or the positioning of the reference point for all printing 
on the sheet are available in the CopyGroup.

Datastream
A continuous stream of data that has a defined format.

DBCS (Double-Byte Character Set)
Character set containing a maximum of 65536 characters where each character is 
represented by two bytes.

Design Area
Application window used to create, view, and edit design objects.

DesignPro Manager
Windows-based operating environment for launching and using Elixir applications such 
as Visual PPFA, Form Editor, Graphics Editor, Font Editor, and DPT Converter.

Direction
The print position of data in a logical page, line, or field. 

Document
A machine-readable collection of one or more objects that represent a composition, work, 
or collection of data.

Duplex Printing
Printing on both sides of a sheet.

Elixir Resource Map
A utility used for mapping fonts and characters between the supported display and print 
formats.

Ellipse
A plane curve; especially a conic section whose plane is not parallel to the axis, base, or 
generatrix of the intersected cone. 

Fast Keys
See Keyboard Shortcut.

Fidelity
Degree of required visual exactness for processing AFP print file input data.

Field
A specified area in a record used for a particular class of data.
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File
A named set of records stored or processed as a unit.

Font
Complete set of print characters of the same family, size, typeface, and orientation.

Form
Single-page document used for background reproduction on each page of other 
documents.

Form Definition (FormDef)
Resource object defining form or print media characteristics, including overlays, paper 
source, duplex printing, post processing controls, perforating, cutting, text suppression, 
position of composed–text data on form, page number, and modification notation.

Format
The arrangement or layout of data on a physical medium or in a presentation space.

GOCA (Graphics Object Content Architecture)
Structure for describing a complex picture (e.g., bar chart or pie chart) using graphic 
commands.

Grid
Horizontal and vertical lines of pixels used for precise object placement.

Guidelines
Horizontal and/or vertical lines in design area used to align objects.

Hexadecimal
A number system with a base of sixteen. The decimal digits 0 through 9 and characters A 
through F are used to represent hexadecimal digits. The hexadecimal digits A through F 
correspond to the decimal numbers 10 through 15, respectively. An example of a 
hexadecimal number is X'1B', which is equal to the decimal number 27.

In
Inches.

IOCA (Image Object Content Architecture)
Non-resolution dependent data structure in which image objects can be scaled and 
compressed.

Kanji
A graphic character set consisting of symbols used in Japanese ideographic alphabets. 
Each character is represented by 2 bytes.
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Keyword
A two-part self-defining parameter consisting of a one-byte identifier and a one-byte 
value.

Keyboard Shortcut
Special key or two-key combination for executing an operation without using the mouse; 
also called fast key(s) or hot key(s).

Line Printer
A device that prints a line of characters as a unit.

Logical Page
A collection of data that can be printed on one side of a sheet of paper.

Medium
The physical material (for example, paper) on which data is printed. 

Messages Window
A window displaying informational, error, and warning messages.

MO:DCA (Mixed Object Document Content Architecture)
Structure of device-independent data stream used for interchanging documents.

Multiple Up
The printing of more than one page on a single side of a sheet of paper.

NUP
The printing of more than one logical page on a single side of a medium.

Object
A collection of data referred to by a single name.

Orientation
Direction of the type in reference to the upper left corner of a portrait page.

Overlay
A collection of static data such as lines, shading, text, boxes, bar codes, or logos that can 
be merged with variable data on a page during printing.

Overlay Generation Language (OGL)
A programming language used to produce electronic overlays.

Page
Logical representation of a data page.
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Page Definition (PageDef)
Resource containing format controls for printing logical pages; can include controls for 
number of lines, font selection, print direction, dimension, conditional processing, 
overlays, color, multiple up printing, and field mapping.

PPFA (Page Printer Formatting Aid)
IBM utility used to create and store form and page definition resource objects for 
formatting printed output.

Page Segment
Page resource comprising of text and/or images composed before formatting, but included 
in printing.

Paper
Physical attributes of a logical page, such as size, orientation, positioning, and 
partitioning.

Pel
See Pixel.

Pixel
Contraction of “picture element;” smallest displayable or printable unit on a physical 
medium. A pixel is sometimes referred to as a dot. Character bitmaps are made up of dots 
or pixels. A pixel can contain additional information, such as color, and can be larger than 
one bit while still representing one dot.

Preprinted Form
A sheet of paper containing a preprinted design of constant data. Variable data can be 
merged with the constant data on such a form. 

Print Data Stream
Datastream created by Print Services Facility (PSF) for transmission to the printer.

PSF (Print Services Facility)
IBM utility for managing input and output data streams; combines print data (from system 
spool), printing controls, and other resources to produce data stream for AFP printers.

Raster Font
Series of pels arranged in scan lines to form font.

Record
A set of one or more related data items grouped for processing.
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Resolution
Measure of image sharpness, expressed either as number of lines and columns, or pels per 
unit of area.

Resource Map Editor
Product component used to display, define, and edit font input to output format mappings, 
and provide instructions for storing information in the Elixir Resource Map.

Rotation
The orientation of the characters of a font with respect to the baseline.

SBCS (Single-Byte Character Set)
Character set in which each character is represented by a 1-byte code (256 characters).

Sheet
A single piece of paper.

Snap to Grid
Product function that causes form elements to automatically align with nearest displayed 
grid point.

SOSI (Shift-Out, Shift-In)
Special EBCDIC datastream codes used to control switch between double- and single-
byte fonts.

SubGroup
A subset of a form definition used to reprint the same page of data more than once. 
SubGroups provide for variations in the same page of data within one print job.

Subpage
A part of the logical page on which line data may be placed. In the page definition, 
multiple subpages can be placed on a physical page based on changes in the print data.

Style
A modified version of a typeface. Examples of a style are Bold, Italic, etc.

TRC (Table Reference Character)
Optional print data set control character used for selecting font during printing.

Typeface
All characters of single type family, each having same style, weight, and width, regardless 
of size.

Unformatted Print Data
Data having no formatting used for print output.
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Viewer
Provides on-screen viewing of documents created for production printing. File formats, 
including Elixir Document, Elixir GDF, Windows EMF, PCL, Elixir PDW, Elixir Form, 
Elixir Legacy FormAFP Overlay Object, and PostScript can be proof printed in the 
Viewer.

Zoom
Product feature enabling magnification changes for display of the design area objects.
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Index
A
about

data proofing 239
DrawGraphic objects 191
EndGraphics 200
FormDef lists 95
FormDef objects 97
NUP 107
page definitions 115
PageDef lists 125
PageDef objects 151
project mode 225

Active Button toolbar 263
Active Checkbox toolbar 263
Active Combobox toolbar 263
Active Editbox toolbar 263
Active Radio Button toolbar 263
adding

barcode fields 168
buttons to menus 57
buttons to toolbars 57
color lists 135
colors to a color list 136
comments 92, 124, 164
conditions 175
CopyGroups 98
DrawGraphic object 192
end subpages 189
EndGraphic object 201
External fonts 131
fields 164
floating overlays 180
floating segments 186
Font Pair 132
fonts to a font list 129

External fonts 131
Font Pair 132
Windows fonts 129

FormDefs
project mode 227

lists from Insert toolbar 150
object lists 140, 142
objects 187
objects to an object list 140
overlay lists 143
overlays 105
overlays to an overlay list 144
PageDefs

project mode 227
PageFormats 152
project mode

FormDefs 227
PageDefs 227

records 156
segment lists 145
segments to a segment list 145
SubGroups 102
suppression lists 96
suppressions to suppression list 96
template overlays 184
TRC reference lists 146
TRC references to a TRC reference list 147
Windows fonts 129

AFP 61, 71, 88
resources 69

AFP format
understanding 12

AFP formdef objects
opening 208

AFP pagedef objects
opening 208

AFPDS dialog 148
application default options

changing 35
application format

commands 70
settings 70

applying 70
application loading default options

setting 36
applying
Index 283



application format settings 70
document format settings 70
file format settings 71
finishing operations 88

ASCII 42, 229, 231, 234, 241

B
back side tab 24
barcode fields 26

adding 168
mapping data 169
setting name 169
setting options 170
setting properties 169
specifying text 175
standard options 170
working 168

Barcode toolbar 263, 270
barcodes

mapping 238
basic NUP 107, 108, 218

setting properties 108
working 108

BCOCA 141, 188
BMP 66, 139
border colors

setting 40
Box toolbar 263, 265

C
caching 65
CDF 66, 131
changing

application default options 35
document default options

 52
file format settings

input 71
output 73

file formats 70
Windows font properties 133

Check Spelling dialog 252
choosing

commands 31
CIELAB colors

selecting 137

clearing
Elixir Parameter file 74
file format settings 74

clipboard options
setting 39

CMYK colors
selecting 137

COD 66, 132
color lists 26

adding 135
adding colors 136
working 135

Color Selector dialog 137
colors

setting 164
columns

customizing 134
commands

application format 70
choosing 31
document format 71
repeat 32
undo 32

comments
adding 92, 124, 164

Common Attributes toolbar 258
condition 26
conditions

adding 175
setting properties 176
working 175

constant forms
designing 85

content position, setting
objects 189

control parameters
setting 91

conventions 16
symbolic 17
typographic 16

converter properties
viewing 50

converting
fonts to AFP resources 69
forms to AFP resources 69
image files to AFP resources 69
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CopyGroups 78, 79, 86, 97
adding 98
setting properties 99
working 98

copying
objects 211
resources to appropriate directory 66

creating
FormDefs 79
PageDefs 117
toolbar 57

crosshair 30
customer support 18
customizing

columns 134
menus 55
sample data grid 43
toolbars 55, 56

D
data

loading, sample data file 233
mapping 236
unloading, sample data file 233
working 233

data encoding formats 231
ASCII 231
EBCDIC 232
mixed mode 232

data file
properties, setting 234, 240

data file formats 229
record format line data 231
traditional line data 230

data formats
for record format PageDefs 229
for traditional PageDefs 229

data mapping options
barcode fields 169

Data Matrix Special Properties dialog 171
data proofing

about 239
preparing 239
properties, setting 240

DBF 65, 116
defining

page suppressions 104
deleting

objects 211
design area 23

previewing contents 244
printing contents 244

designing
constant forms 85

DesignPro modules 13
DesignPro Visual PPFA

toolbars 255
designs

proofing
about 239

dialogs
AFPDS 148
Check Spelling 252
Color Selector 137
Data Matrix Special Properties 171
Elixir 62
Find 249
Font 129
Font List 268
Font List Dialog 126
Highlight Color 139
Open 269
Open Resource File 131
Options 253
PPFA 149
Print 248
Print Setup 248
Profile Selection 253
Properties 250
Properties – CopyGroup 99
Properties – Font List 126
Properties - Object List 140
Properties - Overlay List 144
Properties – Page Format 154
Properties – PageDefs 118
Properties - Segment List 146
Properties – SubGroup 102
Properties – Suppression List 97
Properties - TRC List 147
Replace 249
Save As 248
Soft Keyboard 269
Index 285



digital ruler 47
display offsets, PageFormat settings 155
DOC 49
document default options

changing
 52

document design
project mode 225

document format
commands 71
setting 70

document format settings
applying 70

document guidelines
setting 53

document identification
setting 52

document ruler
setting 53

document, legacy
opening 209

DrawGraphic objects
about 191
adding object 192
box 26
circle 26
ellipse 26
line 26
setting properties 193

DrawGraphic objects, setting
axis for ellipse 199
color 198
copy options 197
dimensions 195
fill color 198
graphic ID 193
object name 193
object style 196
positions 194
radius 199

duplex printing
setting 84

E
EBCDIC 42, 229, 232, 234, 241
editing

FormDefs 210
overlays, using design tools 220
PageDefs 210

EFD 65, 78, 207, 212, 228
EFR 65
Elixir

resources 69
Elixir dialog 62
Elixir FormDefs

opening 207
Elixir PageDefs

opening 207
Elixir Parameter File

clearing 74
loading 74
saving 75

Elixir Parameter File See EPM
Elixir resource handling properties

setting 61
Ellipse toolbar 263, 266
ELX 61, 65
embedding

resources 69
end subpage 26
end subpages

adding 189
working 189

EndGraphic objects 26
about 200
adding 201
setting properties 201

graphic ID 202
object name 202
positions 202

enhanced NUP 107, 108, 218
setting properties 110
working 110

EPD 65, 116, 184, 207, 212, 228
EPM 36, 70, 71
ERC 65, 66, 131, 132
ERC32 65, 66, 131, 132
exiting

Visual PPFA 22
exporting

resources 68
extensions
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.AFP 61, 71, 88

.BMP 66, 139

.CDF 66, 131

.COD 66, 132

.DBF 65, 116

.EFD 65, 78, 207, 212, 228

.EFR 65

.ELX 61, 65

.EPD 65, 116, 184, 207, 212, 228

.EPM 70, 71, 74, 75

.ERC 65, 66, 131, 132

.ERC32 65, 66, 131, 132

.GDF 71

.GIF 141, 188

.HDR 66, 131, 132

.INI 239

.JPEG 66, 139, 188

.JPG 66, 139

.LP3 66, 139

.OBJ 65, 78, 116, 124, 212

.OGL 65, 71

.OVE 65

.OVL 65

.PCX 66, 139, 141

.PFA 65

.PNG 66, 139

.SEG 186

.SRC 65, 78, 116, 212

.TIF 66, 139

.TIFF 188

.TXT 231
External fonts

adding 131
external objects

working 187

F
field display options

setting 39
fields 26

adding 164
barcode

adding 168
setting properties 169
working 168

mapping 237

setting position 167
setting properties 165
working 164

file format settings 71, 74, 75
applying 71
changing

input 71
output 73

clearing 74
loading 74
saving 75

file formats
changing 70
DOC 49
Elixir Parameter file 74
EPM 36
INI 34
LOG 49
RTF 39
SEG 51

filing options
setting 38

Filter toolbar 259
Find dialog 249
finishing operations

applying 88
floating overlay 26
floating overlays

adding 180
general properties, selecting 181
loading as template 184
merging variable data 183
setting offsets 182
setting position 182

relative to record 183
setting properties 181
setting rotation 182
working 180

floating segment 26
floating segments

adding 186
working 185

Font dialog 129
Font List dialog 126, 268
font lists

adding a Font Pair 132
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adding External fonts 131
adding fonts 129
adding Window fonts 129
managing 133
setting

colors 164
fonts 163

working 125
Font Pair

adding 132
font settings

data proofing, specifying 242
fonts 59

converting 69
replacing 132
setting 163
suppressing 148

using AFPDS property settings 148
using PPFA property settings 149

form definitions See FormDefs 14, 77
form design tools 262
FormDef lists

about 95
FormDef objects

about 97
FormDef tab 24
FormDef tree window 23, 27, 96, 98, 102, 218, 250

new CopyGroup node 27
new FormDef node 27
new SubGroup node 27

FormDefs 59, 60, 77
AFP object

opening 208
creating 79
editing 210
Elixir format

opening 207
objects 97

copying 211
deleting 211
moving 212

opening 205
PPFA source

opening 208
project mode

adding 227

loading 228
removing 228

saving 212
AFP object format 214
Elixir format 213
PPFA source format 214

setting a unique name 81
setting properties 80
using overlays 218

forms
converting 69

front side tab 24

G
gathering

resources 65
GDF 71
general properties

conditions, setting 176
floating overlays, setting 181
objects, setting 188

GIF 141, 188
GOCA 141, 188
graphic ID

DrawGraphic objects, setting 193
EndGraphic objects, setting 202

graphic ruler 47
Graphics Editor

Overview 11
overview 11

grid 29
setting 44

guidelines 30
setting 46, 53

H
HDR 66, 131, 132
Help

context-sensitive 19
customer support 18
opening Online Help 19

help 15
Highlight Color dialog 139
highlight colors

selecting 139
288 DesignPro Visual PPFA User Guide



I
IBM print services 59
image files

converting 69
Image toolbar 263, 269
importing

resources 64
INI 34, 239
IOCA 141, 188

J
JFIF 141
JPEG 66, 139, 188
JPG 66, 139

K
keyboard shortcuts 271

numeric display box 272
text editing 271
zoom/pan control 273

L
legacy document

opening 209
line data 115

record format 115, 231
traditional 115, 230

line styles
setting 40

Line toolbar 263, 264
lists from Insert toolbar

adding 150
loading

Elixir Parameter file 74
file format settings 74
floating overlays as templates 184
FormDefs

project mode 228
PageDefs

project mode 228
project mode

FormDefs 228
PageDefs 228

sample data file 233
LOG 49
logging 49

logical page dimensions,setting 122
logical page margins,setting 120
logical pages 40

setting dimensions 122
setting margins 120

logical pages, multiple
placing 86

LP3 66, 139

M
managing

font lists 133
resource objects 67

mapping
barcodes 238
data 236
fields 237
records 237

medium overlay 40
menu bar 29, 30, 247
menus

adding buttons 57
customizing 55

merging
variable data, floating overlays 183

message logs 49
message preferences

setting 48
Messages window 250
messages window 23, 28
mixed mode data 232, 234
moving

objects 212
multiple logical pages

placing 86

N
navigating

workspace 30
new file extensions

registering 51
NUP 180

about 107
basic 107, 108, 218
enhanced 107, 108, 110, 218
overlays 218
Index 289



selecting types 108
NUP overlay 40
NUP partition 40
NUP type 86

O
OBJ 65, 78, 116, 124, 212
object 26
object list 26
object lists

adding 140, 142
adding objects 140
working 139

objects
adding 187
copying 211
deleting 211
DrawGraphics

adding 192
setting properties 193

EndGraphics
adding 201
setting properties 201

external
working 187

general properties,setting 188
moving 212
setting

content position 189
general properties 188
position 189
properties 187

standard operations, performing 205
OCA colors

selecting 137
offsets, setting

floating overlays 182
OGL 65
Open dialog 269
Open Resource File dialog 131
opening

AFP FormDef objects 208
AFP PageDef objects 208
Elixir FormDefs 207
Elixir PageDefs 207
FormDefs 205

legacy document 209
PageDefs 205
PPFA source FormDefs 208
PPFA source PageDefs 208

Options dialog 253
OVE 65
overlay 27
overlay list 26
overlay lists

adding 143
adding overlays 144
working 143

overlay properties
setting 106

overlays 59, 60, 97, 101, 105, 106, 125
adding 105
editing, using design tools 220
floating 180, 219

adding 180
loading as templates 184
merging variable data 183
setting general properties 181
setting offsets 182
setting position 182
setting position, relative to record 183
setting properties 181
setting rotation 182
working 180

medium 180, 218, 219
NUP 218
page 180, 219
setting properties

display 106
template

adding 184
using

FormDef 218
PageDef 219

working 105, 217
overlays as templates 219
overview

Graphics Editor 11
OVL 65

P
page caching options
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setting 65
page definitions

about 115
page numbers

setting 119
page overlay 40
page presentation

setting 83
page segments 59
page suppressions

defining 104
PageDef 39
PageDef lists

about 125
PageDef objects

about 151
PageDef tab 24
PageDef Tree window 135, 140, 143, 145, 147, 

153, 156, 157, 165, 169, 176, 180, 187, 190, 
192, 201, 211, 219, 250

PageDef tree window 23, 25
font list node 26
new PageDef node 25
new PageFormat node 26
new record node 26

PageDefs 59, 60, 125
about 115
AFP object

opening 208
creating 117
editing 210
objects

copying 211
deleting 211
moving 212

opening 205
PPFA source

opening 208
project mode

adding 227
loading 228
removing 228

saving 212
AFP object format 214
Elixir Format 213
PPFA source format 214

setting name 119
setting properties 118
using overlays 219

pagedefs
Elixir format

opening 207
PageFormats

adding 152
setting properties 154
working 152

pages
switching 177

paper options
setting 41

paper source
selecting 87

parser properties
viewing 50

Path toolbar 263, 267
PCX 66, 139, 141
performing

standard operations 205
PFA 65
physical page offsets

setting 81
placing

multiple logical pages 86
PNG 66, 139
Position and Dimension toolbar 257
position, setting

floating overlays 182
floating overlays, relative to record 183
objects 189

positioning
overlay, relative to record 183

PPFA 71
PPFA dialog 149
PPFA source formdefs

opening 208
PPFA source pagedefs

opening 208
preparing

for data proofing 239
resources 61

preview
viewing 114
Index 291



previewing
design area contents 244

print configurations
specifying 121

Print dialog 248
print directions

setting 123
print quality parameters

setting 91
print services 59
Print Setup dialog 248
printer options

setting 41
printing

design area contents 244
profile

selecting 34
Profile Selection dialog 253
profiles 33, 34
project mode

about 225
data proofing 239
document design, viewing 225
working 225

Project toolbar 260
project toolbar 233, 234, 235, 243
proofing

about 239
properties 240
running 243

Properties – CopyGroup dialog 99
Properties – Font List dialog 126
Properties - Object List dialog 140
Properties - Overlay List dialog 144
Properties – Page Format dialog 154
Properties – PageDefs dialog 118
Properties - Segment List dialog 146
Properties – SubGroup dialog 102
Properties – Suppression List dialog 97
Properties - TRC List dialog 147
Properties dialog 250
properties, changing

Windows fonts 133
properties, setting

2DMATRIX barcode 171
2DMAXI barcode 173

2DPDF417 barcode 174
barcode fields 165, 169
conditions 176
data file 234, 240
data proofing 240
DrawGraphics 193
EndGraphics 201
field 165
floating overlays 181
objects 187, 188
PageFormat 154
records 157

properties,setting
basic NUP 108
CopyGroups 99
enhanced NUP 110
overlay display 106
overlays 106
PageDefs 118
SubGroups 102

PSEG 141

R
record direction

setting 162
record display options

setting 39
record format line data 231
Record Format PageDef

setting
data presentation options 167
display options 158
field name options 167
name options 158

record position
setting 160

records
adding 156
mapping 237
repeating

Traditional PageFormat 162
setting properties 157
working 156

registering
new file extensions 51

Related 15
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Related guides 15
removing

FormDefs
project mode 228

PageDefs
project mode 228

project mode
FormDefs 228
PageDefs 228

repeating
Traditional PageFormat record 162

Replace dialog 249
replacing

fonts 132
resource library 64
Resource Manager window 67, 250
resource objects

managing 67
resource searching order

setting 63
resources

AFP 69
copying 66
Elixir 69
embedding 69
exporting 68
gathering 65
importing 64
preparing 61
verifying 68

RGB colors
selecting 137

rotation, setting
floating overlays 182

RTF 39
ruler 29

setting 47
running

proofing 243

S
sample data

working 233
sample data grid

customizing 43
Sample Data window 250

sample text
setting 160

Save As dialog 248
saving

Elixir Parameter file 75
file format settings 75
FormDefs 212
FormDefs to AFP object format 214
FormDefs to Elixir format 213
FormDefs to PPFA source format 214
PageDefs 212
PageDefs to AFP object format 214
PageDefs to Elixir format 213
PageDefs to PPFA source format 214

SEG 51, 186
segment list 26
segment lists

adding 145
adding segments 145
working 145

segments
floating

working 185
Select toolbar 263, 264
selected overlay 40
selecting

CIELAB colors 137
CMYK colors 137
highlight colors 139
NUP types 108
OCA colors 137
paper source 87
profiles 34
RGB colors 137

setting
2DMATRIX barcode properties 171
2DMAXI barcode properties 173
2DPDF417 barcode properties 174
application format 70
application loading defaults 36
barcode field properties 169
barcode options 170
basic NUP properties 108
border colors 40
clipboard options 39
colors 164
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condition properties 176
control parameters 91
CopyGroup properties 99
data file properties 234, 240
data mapping options

barcode fields 169
data presentation options

Record Format PageDef fields 167
Traditional PageDef fields 165

data proofing properties 240
display offset for PageFormat 155
display options

Record Format PageDef 158
Traditional PageDef 157

document format 70
document guidelines 53
document identification 52
document ruler 53
DrawGraphics

axis for ellipse 199
color 198
copy 197
fill options 198
object name 193
object position 194
object style 196
radius 199

drawGraphics
graphic ID 193
object dimensions 195

duplex printing options 84
Elixir resource handling properties 61
EndGraphics

graphic ID 202
object name 202
object position 202

enhanced NUP properties 110
field display options 39
field positions 167
field properties 165
file format 71, 73
filing options 38
floating overlays

general properties 181
offsets 182
position 182

position, relative to record 183
properties 181
rotation 182

fonts 163
data proofing 242

FormDef name 81
FormDef properties 80
general properties

conditions 176
floating overlay 181
object 188

grid options 44
guidelines 46
line styles 40
logical page dimensions 122
logical page margins 120
message logs 49
message preferences 48
name

barcode fields 169
Record Format PageDef 158
Record Format PageDef fields 167
Traditional PageDef 157
Traditional PageDef fields 165

object properties 187
objects

content position 189
general properties 188
position 189

overlay display properties 106
overlay properties 106
page caching options 65
page numbers 119
page presentation 83
PageDef name 119
PageDef properties 118
PageFormat properties 154
paper options 41
physical page offsets 81
print directions 123
print quality parameters 91
printer options 41
record direction 162
record display options 39
Record Format PageDefs options

data presentation 167
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display 158
name 158

record position 160
record properties 157
resource searching order 63
ruler 47
sample text 160
spell check 37
SubGroup properties 102
symbol properties 48
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