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Introduction
The FreeFlow Makeready Installation Guide provides the information and procedures needed
to perform the installation of a FreeFlow Makeready system.
For important information regarding system requirements and known issues and limitations for
the current software release, refer to the Xerox® FreeFlow Makeready Release Notes. You can
download the release notes from the Support and Drivers section on www.xerox.com.

Xerox® FreeFlow®
9.0 Makeready® Installation Guide

3

Makeready Software
System Configuration
and Installation
This chapter contains the procedures required to install and configure the FreeFlow software.

Before You Begin
Your FreeFlow product is supported on platforms that meet or exceed the system requirements
defined by Xerox in the FreeFlow Makeready Release Notes. For more information, visit the
Support and Drivers section on www.xerox.com. The customer installs and configures an
appropriately licensed version of the operating system on the server, then installs the software.
Before the installation of the FreeFlow software starts, the Installer checks the system
prerequisites and displays any prerequisites that are required before the installation can
continue.
To obtain a license for the FreeFlow software, contact a Xerox Sales Representative or Agent.
The license .dat file determines the options that are enabled during installation.

Guidelines
Ensure that you follow these guidelines when you use the FreeFlow Installer application:
•
•
•

4

To load the required software, follow the onscreen instructions.
When you install third-party applications, always accept the default or typical installation
settings.
If an Open File-Security Warning dialog appears, run the file referenced.
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Prerequisite System Specifications
Before you install the FreeFlow software, ensure that the following third-party software is
installed:

•
•

Microsoft .Net Framework 3.5
Adobe Acrobat Pro

To install the Adobe Acrobat Pro software with the default or typical settings, refer to Xerox®
FreeFlow Makeready Release Notes for the current supported versions.
To download the Makeready installer software from the Supports and Drivers section, visit
www.xerox.com.
If installation of the Copyright Management Service is required, configure the required IIS
settings. For details, refer to the appropriate section in Appendix B: Inspection.
Note: If you have not obtained a copy of the FreeFlow Makeready Copyright Management
Services User Guide, download the document from the Support and Drivers section on
www.xerox.com.

FreeFlow Software Installation
To install the FreeFlow Makeready software, perform the following:
Note: Before you install the FreeFlow software, ensure that the platform meets or exceeds the
minimum system requirements.
1.
2.
3.

4.
5.
6.

Ensure that you are logged in to the system as the Windows Administrator and that no
other applications are running. If DPAdmin is the Administrator account, continue to use
this account.
To run the FreeFlow Makeready installer, double-click the Makeready-9.0.xx.x-MN.exe,
where xx.x is the version of the file. If prompted to confirm running the file, select Run.
The FreeFlow Makeready Installer application launches, then checks for prerequisites. If
the installer detects that required applications are not installed on the system, it displays
the applications in a list, or a warning appears.
Note: If all prerequisites are met, the Welcome screen appears. If a warning appears,
before you continue, verify that all settings are configured properly.
Click Next. The FreeFlow Makeready Installer Welcome screen appears.
Click Next. The Licensing screen appears.
To upload the license .dat file, complete the following steps:
Click Add license.
Browse to the location of the .dat file, then click Open.
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7.

8.
9.

10.

11.
12.
13.
14.
15.
16.
17.
18.
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If installation of the Copyright Management Service (CMS) is required, this software
requires the installation of Internet Information Services (IIS). Before the installation of
the FreeFlow software, install and configure IIS. Refer to Appendix B: Inspection.
If required, select the check boxes for the Copyright Management Service
applications needed. Choose from the following list of options:
• CMS Server with Client license required
• CMS Client Only
• None
If you select CMS Client Only, enter the IP Address of the CMS Server.
Note: If the IP Address of the CMS Server is not known, enter 127.0.0.1.
Click Next.
Proceed accordingly:
− If the Copyright Management Service screen appears, proceed to step 11.
− If the Destination screen appears, continue with step 13.
At the Copyright Management Service screen, enter the following information:
CAUTION: Ensure that the account password information is entered on the Copyright
Management Service screen. The installer uses this information to configure the
underlying MSDE database during the installation. Once the system is installed, you
cannot change this information unless you reinstall the FreeFlow software.
− CMS Database Administrator Password.
Note: A complex password is required. Do not enter special characters.
− Proxy server IP Address or URL with port number, if required.
Note: Enter the IP Address and port number in the following format:
− IPAddress:PortNumber or ProxyServerName:PortNumber.
Note: If the proxy server settings are not known, leave them blank. If needed, you can
change the proxy server information later from the CMS configuration screen.
− Proxy Server account user name, if required.
− Proxy Server user password, if required.
Click Next. The Destination screen appears.
Click Next. The Ready to Install screen appears.
Review the list of options to install. If a required option is not listed, click Back, then make
required configuration changes.
Click Install.
When the Installation completes, a FreeFlow Installation Completed Successfully dialog or
warning appears.
Read the dialog, then click Finish. If a warning appears, resolve the issue listed.
Read the dialog, then click OK. The system automatically shuts down, then restarts.
When the system is ready, to complete the installation process, ensure that you log in as
the current Administrator. If DPAdmin is the Administrator account, continue to use this
account.
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Copyright Management Service Account
Configuration
Complete this section only if the optional Copyright Management Service (CMS) was installed.
If you have not yet obtained a copy of the FreeFlow Makeready Copyright Management
Services User Guide, download the document from the Support and Drivers section on
www.xerox.com.
Note: The customer is responsible for signing up for an account with the Copyright Clearance
Center (CCC) prior to the installation of the Copyright Management Service. You can access the
CCC website at www.copyright.com.
Completion of the following procedures requires the CCC account information. If this
information is not available, skip this procedure and continue with the steps in Register
Production Printers. The Copyright Management Service can be configured after the user has
registered for an account with the CCC. If the CCC account information is not available, the
customer can configure CMS later.
1.
2.
3.
4.
5.

6.
7.
8.
9.

Launch Internet Explorer.
In the Explorer Address bar, enter: https://localhost:8090/CMS/CMSAdmin.aspx, then press
Enter. The CMS Administration page appears.
Click the Configuration link.
In the Section Names menu, select CMS Configuration.
In the Key Value column, enter the following customer CMS database user account
information:
− User Name
− Password.
To test the connection, click Test Configuration.
To save the information, click the Update link.
Close all open screens.
For new installations, proceed to Register Production Printers.

Register Production Printers
For the list of supported Xerox production printers and Controllers, refer to the FreeFlow Printer
Support Guide. You can download this document from the Support and Drivers section on
www.xerox.com.
To set up production printers, complete the following steps:
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Note: The following steps represent a generic procedure that is designed to facilitate the
installation of a typical production printer.
1.
2.

3.

4.
5.
6.
7.

8.
9.
10.

11.

12.

13.
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To start the application, select Start>All Apps>Xerox>FreeFlow>Printer Registration.
The Printer Registration application launches, and the Installed Products dialog appears.
Note: If a Windows Security Alert dialog appears, to enable all features of the program,
click Unblock. If the User Account Control dialog appears, click Continue.
From the list of installed products, clear all the check boxes except for Makeready.
Note: To turn off the display of the Installed Products window, you can select Do not show
this dialog again when launching application. To set the software to display the
Installed Products window, from Printer Registration, select Options>Install Products.
To close the dialog, click OK. The Printer Registration screen appears.
At the bottom of the screen, click Add. The Add Printer Wizard screen appears.
In the Printer Name or IP Address text box, type the IP Address or host name of the print
server as it is known on the network.
Proceed accordingly:
− For automatic detection of the printer model and controller or server type, click
Identify Configuration. After the printer is identified, proceed to step 9.
− To enter the printer information manually, continue with step 8.
From the Printer model drop-down list box, select the appropriate printer.
Ensure that the appropriate controller or server is selected in the Controller/Server type
menu.
If you are installing a printer that supports the High Security feature, and want to
configure the feature, ensure that the High Security check box is selected.
Note: If the printer is not set up for High Security and High Security is selected, printing is
disabled.
Click Next, then proceed accordingly:
− If the printer supports automatic registration, an Automatic Printer Registration
screen appears. Proceed to step 12.
− If the printer does not support automatic registration, a screen appears prompting for
queue information. Proceed to step 13.
At the Automatic Printer Registration screen, make the appropriate selection:
− To register all the print queues automatically, select the check box for Automatically
register all queues at printer, then click Next. Proceed to step 13.
− To register only specific print queues, leave the Automatically register all queues at
printer check box blank and click Next. A screen appears prompting for queue
information. Proceed to step 14.
At the print queue information screen, make the following selections:
Select the print queue from the menu, or manually enter the queue name.
Note: If High Security is selected and the printer is not set up for High Security,
printing is disabled.
Enter a descriptive custom name for the printer and queue combination.
Click Next, then proceed to step 14.
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14. Select the printer/queue pairs that you want to register, then click Next. The FreeFlow
printer settings screen appears.
15. At the FreeFlow printer settings screen, complete the following steps to finish
configuration of the printer:
Select the required Print Path and Job Handling options.
If the screen indicates an FTP user name and password box, enter the appropriate
information. Some printers do not use this method and the FTP login boxes are
grayed out.
Click Finish. The printer is registered.
16. To configure additional printers, repeat steps 5-15.
17. To close the Printer Registration application, select File>Exit.
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Post-Installation
Procedure
This section contains additional post-installation procedures to ensure a fully functional
FreeFlow system.
This chapter includes:
•
•
•
•

Adding Licensed Features After Installation
Test the Print Paths
Install a Xerox® DocuMate Scanner
Ensure that the System is Backed Up

Adding Licensed Features After Installation
Note: If the installation of optional software is required, perform the procedures in this section.
The License Manager is used to enable additional licensed features after the installation of the
FreeFlow software. All licensed components are installed during the installation of FreeFlow but
require a valid license to function. To obtain the required licensing information, contact your
Xerox Sales Representative or Agent.
You can install the following optional software:
•
•

Set Labeling
Copyright Management Service.

Note: Copyright Management Service and Set Labeling are typically enabled during the
installation of FreeFlow software. Other features are displayed in the license tool, however only
the software previously listed is valid for the installed configuration.
1.

2.
3.
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To run the FreeFlow License Tool application, complete the following steps:
From the Windows Start menu, select Run. The Run window appears.
In the Open drop-down text box, enter FreeFlow installation
drive>\freeflow\licensetool.exe, then click OK. The License Manager screen appears.
Click Next. A Warning dialog appears.
To dismiss the dialog, click OK.
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4.

5.

Complete the following steps to upload a license .dat file:
Click Add license.
Browse to the location of the updated .dat file and open it.
Note: Loading a license from a .dat file does not remove existing FreeFlow licenses, it only
appends or updates existing license information.
To follow the onscreen instructions to complete the licensing change, click OK.

When the system is ready, log in and verify that the required features are enabled.

Test the Print Paths
Use this section to test print paths for all installed printers.

Test the Printers
To test the available print paths, complete the following steps:
1.
2.
3.

From the Windows Taskbar, select Start>All Apps>Xerox FreeFlow>File Manager.
The File Manager application opens.
Under All Folders, double-click the icon and browse to the FreeFlow installation folder
(install drive:\Xerox\FreeFlow).
To test the production print path, complete the following steps:
In the details portion of the FreeFlow folder, locate and select the file PpTest.rdo.
From the menu bar, choose File>Print. When the Print dialog appears, click OK.
Another Print dialog appears.
Ensure that Production Print is selected, then click OK. The Job Setup screen appears.
Note: If a Windows Security Alert dialog appears, to allow use of all program features,
click Unblock. If the User Account Control dialog appears, click Continue.
Note: If you are submitting the file to a printer using TCP/IP and the FTP User
account designated when registering the printer has not been created on the print
server, a dialog box appears that prompts you to enter a user name and password for
the print server.
Ensure that the required printer is selected, then click Submit All. A status dialog
displays the percentage of completion.
Note: If a Windows Security Alert dialog appears, to allow use of all program features,
click Unblock. If the User Account Control dialog appears, click Continue.
Verify the document printed at the production printer.
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4.

5.

To test the PostScript print path, complete the following steps:
In the \FreeFlow directory, select PsTest.rdo.
From the menu bar, choose File>Print. When the Print dialog appears, click OK.
Another Print dialog appears.
Ensure Production Print is selected, then click OK. The Job Setup screen appears.
Ensure that the required printer is selected, then click Submit All. A status dialog
appears showing the percentage of completion.
Verify the document printed at the production printer.
Close the FreeFlow File Manager application.

Install a Xerox® DocuMate Scanner
This section contains the procedures for installing a Xerox DocuMate scanner, TWAIN 1.9 or
later. Refer to the Xerox® FreeFlow Makeready Release Notes for the current supported
scanners. You can download this document from the Support and Drivers section on
www.xerox.com.
1.
2.
3.
4.
5.
6.
7.

Using a USB cable, connect the scanner to the FreeFlow Makeready system.
Download the appropriate DocuMate driver for your scanner. You can find the certified
TWAIN and WIA drivers, along with additional installation and configuration guides, at:
http://www.xeroxscanners.com/en/us/support/DriversAndManuals.asp.
Install the DocuMate Scanner Driver.
Ensure that the DocuMate Scanner is powered on and running. If the scanner is not
powered on and running, the drivers do not install correctly.
Reboot the Makeready system.
Launch the Makeready application.
Select File>Insert>Scan>Images.

The DocuMate Scanner dialog opens successfully.

Ensure that the System is Backed Up
CAUTION: It is the responsibility of the customer to back up the FreeFlow system after the
installation completes.
Perform a complete backup of the local system to use for purposes of disaster recovery.
CAUTION: Perform a complete backup of any external storage devices, such as RAIDs, and so
on. If a system failure or a data corruption occurs, failure to complete these procedures can
result in an unrecoverable system.
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Appendices
This section includes the following information:
•
•

Appendix A: Managing FreeFlow Software After the Installation
Appendix B: Inspection
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Appendix A: Managing
FreeFlow Software
After the Installation
Installing Patches and Service Packs
You can update the FreeFlow software periodically using Service Packs and SPAR patches.
Install patches on an as needed basis only to solve a specific issue. Service Packs are approved
for all installations. Install the Service Packs to keep the system current.
Note: The following instructions are generic. Service Pack and Patch instructions are provided
with each software update. Always follow the instructions provided when installing the Service
Pack or Patch.
To install a FreeFlow patch, complete the following steps:
1.
2.
3.

Download the latest Makeready software from the Support and Drivers section on
Xerox.com. The FreeFlow Makeready software has a full installer, which you can use for
new installations or for patching.
Double-click Makeready-9.0.xx.xx.MN.exe, then follow the steps on screen.
When the installation completes, open the FreeFlow application and verify that the patch
revision is listed on the splash screen.

Post-upgrade Confirmation and Configuration
Procedures
Verify the Registered Printer List
To verify that the registered production printer list was retained, complete the following steps:

14
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1.
2.
3.
4.
5.

From the Windows Taskbar, select Start>Programs>Xerox FreeFlow>Printer
Administration>Printer Registration. The Printer Registration application launches, and
the Installed Products dialog appears.
From the list of installed products, clear all the check boxes except for Makeready.
Click OK to close the dialog. The Printer Registration screen updates and displays the same
list of registered printers.
Verify that the list of registered printers is populated with the printer list that was present
on the previous system.
Close the Printer Registration application.

Reinstalling FreeFlow Software
If required, to reinstall the FreeFlow software, complete the following procedure:
Note: This procedure assumes that all FreeFlow software has been uninstalled using the
Windows Add or Remove Programs utility.
1.
2.
3.

To run the FreeFlow Makeready installer, double-click the Makeready-9.0.xx.xx- MN.exe. If
prompted to run the file, select Run.
Click Next. The Licensing screen appears.
If required, edit the license or add a license from a .dat file.

Note: It is not required to add or edit the license for a basic reinstallation. The Installer detects
the existing license.
CAUTION: In the next step, you are instructed to navigate through the Installer screens. Unless
you are required change the password, if the password text box contains asterisks for existing
accounts, do not enter a password.
4.
5.

Navigate through the remaining screens and accept the default values. Only enter a
system password if the password text box is empty. If asterisks are present, the installer
has detected an existing password for the account.
After the reinstallation process is complete and the system restarts, ensure that the system
is operating normally.
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Uninstalling FreeFlow Software
To uninstall the FreeFlow software completely when a complete uninstall is required, follow and
complete these procedures:
Note: Completing this procedure does not remove licensing information and other Xerox
program information stored in the C:\Progam Files\Xerox folder.
There are two Common Printer applications: The Common Printer Status Tool and FreeFlow
Printer Registration. These applications are installed as part of the FreeFlow application bundle
but must be removed separately.
1.
2.
3.

From the Windows Taskbar, select Start>Control Panel.
Select Programs and Features. The Uninstall or change a program window appears.
Locate the Common Printer Status Tool application, then click Uninstall.
The application is uninstalled.

Note: If a User Account Control dialog appears, click Continue.
4.

Locate the FreeFlow Printer Registration application and click Uninstall. The application
is uninstalled.

Note: If a User Account Control dialog appears, click Continue.
Note: Uninstalling Printer Registration does not remove the list of registered printers. This list is
maintained in c:\Windows\System32.
5.
6.

From the list of programs, select FreeFlow Makeready.
Click Uninstall. An Installer screen appears.

Note: If a User Account Control dialog appears, click Continue. Click Next, then proceed
accordingly:
− If an Add or Remove Programs dialog appears, proceed to step 11.
− If a database removal screen appears, continue with step 8.
CAUTION: The next step uninstalls the Copyright Management Database. Before you proceed,
ensure that the uninstall is required. In some situations, it is desirable to leave the database
applications intact.
7.
8.
9.
10.
11.
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To uninstall the Copyright Management Database, select the check box.
Click Next. A warning dialog appears.
To confirm the database removal, click Yes. An Add or Remove Programs dialog appears.
Click Yes. The software is uninstalled. A Remove Completed Successfully screen appears.
Click Finish The system shuts down, then restarts.
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Appendix B: Inspection
The required system settings for Makeready are listed as follows. Ensure that the FreeFlow
settings are configured, as applicable, before you begin the installation of the FreeFlow
software.

System Settings
The following are the required system settings for the FreeFlow software:
Note: To enable and configure the recommended security settings, refer to the Xerox FreeFlow
Security Document. You can download this document from the Xerox Security website on
www.xerox.com.

Disable Hyper-threading in the PC BIOS
If this option exists, disable hyper-threading in the PC BIOS. Consult your IT Department for
more information, if necessary.

Verify the Memory (RAM)
1.
2.
3.

Ensure that you are logged in to the Operating System as an administrative user.
Right-click Start, then select System.
Verify the amount of Installed Memory (RAM) meets or exceeds minimum specifications
listed in the FreeFlow Makeready Release Notes and exit System screen.

Disable User Account Control
1.
2.

In the control panel, click User Accounts twice, then select Change User Account Control
Settings.
To confirm the new settings, slide the bar to Never Notify, then select OK. If the message
Do you want to allow the following program to make changes to this computer? appears,
select Yes, then from the left pane, select Control Panel Home.
Note: Some customers do not allow user account control to be disabled or Never Notify to
be selected. Verify this setting with the customer. If required, after the installation of
FreeFlow completes, enable the setting again.
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Verify the Necessary OS Components
If installation of the Copyright Management Service is required, configure the required IIS
settings.
Note: Ensure that you have access to the Microsoft Windows installation disk.
Note: In the following section, do not remove or disable any of the customer applications. Only
add the following applications, if needed.
1.
2.
3.

4.

5.
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From the control panel, select Programs. Select Programs and Features. Select Turn
Windows features on or off.
Expand the Windows Features window.
Expand Internet Information Services, then expand the FTP Server. Verify that the
following is active:
− FTP Service
Expand Web Management Tools and verify that the following are active:
− Expand IIS 6 Management Compatibility
• IIS 6 Management Console
• IIS 6 Scripting Tools
• IIS 6 WMI Compatibility
• IIS Metabase and IIS 6 configuration compatibility
− IIS Management Console
Expand World Wide Web Services and verify that the following are active:
− Expand Application Development
• .NET Extensibility 3.5
• ASP
• ASP.NET 3.5
• ISAPI Extensions
• ISAPI Filters
• Server Side Includes
− Expand Common HTTP Features
• Default Document
• Directory Browsing
• HTTP Errors
• Static Content
− Expand Health and Diagnostics
• HTTP Logging
• Request Monitor
− Expand Performance Features
• Static Content Compression
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6.
7.
8.

− Expand Security
• Basic Authentication
• Request Filtering
• Windows Authentication
Verify that the Microsoft .NET Framework 3.5 is active, which is indicated by a shaded box.
To ensure that the necessary components are installed, click OK.
Select Restart Now.
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