This software is based in part on the work of Graeme W. Gill.
© Press-sense Ltd. 2002-2007. All rights reserved
Includes Adobe® PDF Libraries and Adobe Normalizer technology
The Graphics Interchange Format® is the Copyright property of CompuServe Incorporated.
GIF™ is a Service Mark of CompuServe Incorporated.
Portions contain an implementation of the LZW algorithm licensed under U.S. Patent 4,558,302
Parts of this software Copyright © 2004-2006 Enterprise Distributed Technologies Ltd. All Rights Reserved.
Parts of this software Copyright ©1995-2003, The Cryptic Foundation Limited. All Rights Reserved.
Parts of this software are a SSLv3/TLS implementation written by Eric Rescorla by Claymore Systems, Inc. All Rights Reserved.
Parts of this software Copyright © 2002, Lee David Painter and Contributors. Contributions made by Brett Smith, Richard Pernavas, Erwin Bolwidt.
Parts of this software Copyright © 1995-2005, Jean-loup Gailly and Mark Adler.
# Table of Contents

1 About this guide .................................................................1-1
   Audience ..................................................................................1-1
   How to recognize important information .............................................1-1
   Conventions ................................................................................1-1
   Indicators ...................................................................................1-2
   Related information ............................................................................1-2
   FreeFlow Process Manager documentation ........................................1-2
   Windows related information .............................................................1-3
   Using FreeFlow Process Manager Online Help ..................................1-3
   Obtaining additional support ..............................................................1-3

2 About FreeFlow Process Manager ...........................................2-1
   FreeFlow Process Manager applications .................................................2-1
   The Workflow Builder application .........................................................2-1
   The Workflow Submission Client application ........................................2-2
   The Workflow Job Manager application ................................................2-2
   Post-installation setup ...........................................................................2-2
   Logging in to the FreeFlow Process Manager applications ...................2-5
   Authorization error message ..................................................................2-6
   Group membership and authorization ......................................................2-6
   Managing production printers ................................................................2-6
   Xerox FreeFlow Common Printer Administrators group .......................2-6
   Registering and adding a production printer ...........................................2-7

3 Workflow Builder .................................................................3-1
   Workflow process icons .......................................................................3-1
   Building workflows ...............................................................................3-4
   Rules for building workflows ..................................................................3-4
   Building a new workflow .........................................................................3-5
   Creating fail branches ...........................................................................3-5
   Exporting workflows ...............................................................................3-5
   Importing workflows ...............................................................................3-6
   Configuring process settings .................................................................3-6
   About Input .......................................................................................3-6
   Configuring Image Enhancement settings ..............................................3-6
   Configuring Convert Settings ..................................................................3-7
   About Join ..........................................................................................3-10
   Configuring Optimize Settings ..............................................................3-11
   Configuring Preflight settings ...............................................................3-15
   Upgrading legacy workflows that contain Job Level Edit nodes ............3-15
   About Watermarks ...............................................................................3-16
   About Bates numbers ............................................................................3-16
   Adding page numbers ............................................................................3-16
   Adding a Barcode ..................................................................................3-16
   Configuring Imposition settings ...........................................................3-19
   Configuring Preps settings .....................................................................3-25
   About Review .....................................................................................3-25
Configuring Notify settings .................................................................3-26
Setting up a watermark in an email attachment ..........................3-27
Configuring Print settings .................................................................3-27
Configuring Save settings .................................................................3-28
Configuring JDF Export settings .....................................................3-29
Limitations when creating JDF Tickets in Adobe Acrobat Professional .................................................................3-31
Creating conditional branches .........................................................3-32
Guidelines for successful conditional branching .........................3-32
About external process settings .......................................................3-36
About the Copy Count Divisor ..........................................................3-36
About the Copy Count Divisor and Review nodes .........................3-37
To enable the Copy Count Divisor ....................................................3-37
Setting up repository credentials .....................................................3-37
Advanced administration .................................................................3-38
Checking the status of a process .......................................................3-38
Setting the number of concurrent processes and the copy count divisor .................................................................3-38
About hot folders ................................................................................3-38
Hot folders and Join ...........................................................................3-38
To manage hot folders ........................................................................3-41
Managing hot folders .........................................................................3-41
Setting up or modifying a hot folder ...............................................3-42
Deleting a hot folder ...........................................................................3-43
Pausing and resuming hot folder monitoring ....................................3-43
Configuring the hot folder system settings .......................................3-43
Submitting a job to a hot folder ........................................................3-43
Submitting an RDO to a hot folder ....................................................3-44
Submitting a job ticket file (*.xpf) to a hot folder for reprinting ..........3-44
Submitting .xml workflow files to a hot folder .................................3-46
Submitting .vpc files to a hot folder ....................................................3-47
Using third party external processes .................................................3-47
Setting up external processes ..........................................................3-48
Guidelines for using third party external processes .........................3-48
Setting up the SMTP Server .............................................................3-51
Setting up the proxy server ..............................................................3-51
Automatic Job and Job History Deletion ...........................................3-52
Archive Job History Records Setup ..................................................3-52
Optimizing system performance with hot folder and job deletion options .................................................................3-52
4 Workflow Submission Client .........................................................4-1
Workflow Submission Client main window ......................................4-1
Job submission ..................................................................................4-1
Limitations for Save File List ...........................................................4-2
Submitting Zip files ...........................................................................4-2
Submitting VI Containers (.vpc) .......................................................4-2
Submitting a file with saved job ticket information for reprinting .................................................................4-2
About RDOs ......................................................................................4-2
# Table of Contents

## 5 Workflow Job Manager
- About Workflow Job Manager ......................................................................... 5-1
- Logging into Workflow Job Manager .................................................................. 5-2
- The Workflow Job Manager main window ......................................................... 5-2
- The Status area ..................................................................................................... 5-3
- The Jobs area ....................................................................................................... 5-3
- The Jobs area columns ......................................................................................... 5-3
- Managing Jobs ..................................................................................................... 5-4
  - About the status of a job ................................................................................. 5-4
  - About purging report data .............................................................................. 5-4
  - About documents in Adobe Acrobat .............................................................. 5-4
  - Viewing preflight results ................................................................................. 5-5
  - Viewing print results ........................................................................................ 5-5
  - Modifying workflow settings .......................................................................... 5-5
  - Pause a job ....................................................................................................... 5-6
  - Approve a job at a Review step ..................................................................... 5-6
  - Fail a job ........................................................................................................... 5-6
  - Modifying the copy count ................................................................................ 5-7
  - Printing a hardcopy proof .............................................................................. 5-7
  - Adding a recipient to a Notify step with no recipient address specified .......... 5-8
- Creating reports .................................................................................................. 5-8
- Viewing Web Services Job Instructions .............................................................. 5-9
- Remote Workflow Job Manager Client ............................................................. 5-10
- Managing jobs from third party management information system (MIS) .......... 5-10
  - Assigning and configuring a workflow for an incoming third party job ........ 5-11
  - Selecting files for an incoming third party job .............................................. 5-11
  - Viewing the JDF file for an incoming third party job .................................... 5-11
  - Viewing the job instructions for an incoming third party job ..................... 5-12

## 6 MAX Submission Client
- MAX Submission Client ..................................................................................... 6-1
- MAX Submission Client Interface ...................................................................... 6-2
- Configure Hot Folders and Custom Field Labels .............................................. 6-3
- Shop Order ......................................................................................................... 6-3
- Add Order Item .................................................................................................. 6-3
- Address Book ..................................................................................................... 6-4
- Order Items Files and Folders .......................................................................... 6-4

## A Setting up Preps
- Starting Preps Automation Server ................................................................... A-1
- To configure the Preps default workflow ......................................................... A-2
- Creating and saving Preps Job files .................................................................. A-2
- Selecting a device type for Preps versions prior to 5.3.1 ................................ A-3
- Missing hardware key error .............................................................................. A-3
- Using Preps with Adobe Acrobat ................................................................. A-3
1

About this guide

This guide provides information and procedures for using the FreeFlow Process Manager application.

This chapter explains the information found in this guide and how the information is organized, including:

• Identifying the audience and the basic skills required to use this guide effectively
• Explaining the standard conventions and cues that highlight important information
• Listing related documentation you might find helpful
• Listing available online FreeFlow Process Manager Help systems
• Providing information on obtaining additional information

NOTE
If you are using Process Manager for the first time, it is recommended that you read About Process Manager, in this guide.

Audience

This guide is intended for administrators and operators.

How to recognize important information

The following sections provide the conventions and indicators that are used in this guide.

Conventions

This guide uses the conventions listed in the table below to help you recognize information.

<table>
<thead>
<tr>
<th>Convention</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Angle brackets&gt;</td>
<td>Variable information is enclosed in angle brackets (for example, select &lt;filename&gt;).</td>
</tr>
</tbody>
</table>
**Convention** | **Description**
--- | ---
**Bold**  | • Names of options you select, including toolbar buttons and buttons in dialog boxes, are enclosed in square brackets (for example, select Close).
          | Menu commands are also displayed in square brackets, with the menu name appearing first, then a colon, followed by the option name (for example, select File > Close).
          | • Text you should enter exactly as it appears is displayed in bold (for example, enter test1.rdo).
          | • Within procedures, the names of keys to press are displayed in capital letters and enclosed in angle brackets (for example, press ESCAPE). Keyboard combinations are represented by the plus sign (+) between names of keys (for example, press CONTROL+C to copy).

**Italics** | Titles of documents and manuals that provide additional information on the current topic are displayed in italics (for example, the *Production Printing Setup Guide*).

**Indicators**

This guide uses the following indicators to help you recognize important information:

<table>
<thead>
<tr>
<th>Indicator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NOTE</td>
<td>A NOTE indicate important or supplemental information for a task or procedure.</td>
</tr>
<tr>
<td>CAUTION</td>
<td>A CAUTION indicate that you may lose data or damage equipment if care is not taken when performing the task or procedure following the caution.</td>
</tr>
<tr>
<td>WARNING</td>
<td>A WARNING indicates that you may cause personal injury or death if care is not taken when performing the task or procedure following the warning.</td>
</tr>
</tbody>
</table>

**Related information**

This section lists additional materials you may need, or find helpful, when using your FreeFlow Process Manager system.

To order the Xerox documentation listed below, contact your Xerox Representative.

**FreeFlow Process Manager documentation**

For more information on FreeFlow Process Manager, refer to the following publications:

- Xerox FreeFlow System Administrator
- Xerox FreeFlow Security Document
Windows related information

Microsoft provides user and administrators with several different resources to support the operating system environment.

- **Windows Online Help** - Windows includes extensive online Help for all aspects of the operating system.
- **Windows Microsoft Web site** - Microsoft has a World Wide Web site that contains the latest operating system news and information about upgrades. The URL for this site is: http://www.microsoft.com/

Using FreeFlow Process Manager Online Help

This section provides a brief overview of the type of Help available online from the FreeFlow Process Manager software.

You can access the Process Manager Online Help system by selecting Help in the Help menu. You can also access Help by selecting the Help button, when available, in dialog boxes.

Obtaining additional support

For additional information about the following topics, contact your Xerox Representative.

- X-PRESS FAX
- FreeFlow FAQ Xerox web site
- Xerox Welcome Center
About FreeFlow Process Manager

This section provides information about Xerox FreeFlow Process Manager applications, hardware and software components, preparatory steps for workflow building and job management, user and group access, the log in process, adding and removing printers, and backup and restore functions.

FreeFlow Process Manager applications

FreeFlow Process Manager consists of three applications that allow you to process jobs using automated workflows:

- **Workflow Builder** - allows you to create and manage workflows
- **Workflow Submission Client** - allows you to submit jobs to workflows
- **Workflow Job Manager** - allows you to manage submitted jobs
- **MAX** (Manifest Automation from Xerox) - automates job submission by processing order jacket files from upstream systems
- **MAX Submission Client** - allows you to submit order jacket files for MAX processing

The Workflow Builder application

Use Workflow Builder to:

- Create workflows
  - Use graphical tools to assemble customized workflows from workflow process steps.
  - Configure the settings for workflow process steps.
  - Enable workflows to receive jobs.
  - Disable workflows to modify them or to prevent job submission.
  - Import and export workflows and their associated hot folders.
- Set up and manage hot folders.
- Add external PDF processes to support third party software.
- Set up Notify attributes on the SMTP server; set up the Proxy server.
- Set up repository credentials.
- Configure the remote conversion workstation
The Workflow Submission Client application

Use Workflow Submission Client to:
- Select files for submission from Windows or from a document repository.
- Select an optional job ticket for submission with the files.
- Submit the files to one of the automated workflows.
- Modify the workflow process settings.
- View the job ticket and resolve job ticket conflicts.
- Launch Workflow Builder
- Submit files remotely from a workstation or server with Remote Workflow Submission Client installed.
- Save and load a file list.

The Workflow Job Manager application

Use Workflow Job Manager to:
- View job details and status.
- Review and edit jobs in Adobe Acrobat.
- Edit process settings.
- Resubmit jobs.
- Approve, fail, pause, or delete jobs.
- Generate, view, and export reports.
- Perform selected tasks remotely from a workstation or server with Remote Workflow Job Manager Client installed.

Post-installation setup

The table below provides a post-installation checklist you must complete after your FreeFlow Process Manager system has been installed.

NOTE
This checklist assumes that a Xerox Representative has installed all hardware and software necessary to run the FreeFlow Process Manager system.

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Overview</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure document repository connections</td>
<td>Use the FreeFlow Administration Tool to configure the connection between FreeFlow Process Manager and the supported document repositories. For detailed procedures on configuring repository connections, refer to the FreeFlow Administration Tool online Help system.</td>
</tr>
<tr>
<td>Procedure</td>
<td>Overview</td>
</tr>
<tr>
<td>-----------</td>
<td>----------</td>
</tr>
</tbody>
</table>
| Create user accounts; add or edit user contact information; change XDL Admin account password | Creating User Accounts  
Process Manager user accounts are created and managed using the Windows Local Users and Groups functionality in the Computer Management application. Users that are created and added to the appropriate Process Manager group accounts using Windows appear in the FreeFlow Administration Tool list of users.  
Storing User contact information  
The FreeFlow Administration Tool is used to view user accounts that have been created in Windows, and to add or edit user contact information.  
Changing the XDL Admin account password  
The FreeFlow Administration Tool allows you to change the password for the XDL Admin account. This password is set during the installation of the software.  
For detailed procedures on creating user accounts, refer to the Windows online help. For detailed procedures on adding or editing user contact information or changing the XDL Admin account password, refer to the FreeFlow Administration Tool online Help system. |
| Manage production printers for workflows | Production printers must be added to FreeFlow Process Manager before you attempt to drag a Print process into a workflow during the workflow building process.  
A common printer interface enables all FreeFlow applications to maintain a single database of configured printers and to have a common job setup GUI interface across FreeFlow applications. The common printer interface includes the following utilities:  
- Registered Printer List Locator  
  Allows you to set whether the registered printer list in use by a FreeFlow application is located on a local computer or on a remote computer.  
- Printer Registration  
  Allows you to register and manage supported production printers and queues for use by FreeFlow software applications. To configure the Print process step in a workflow, production printers must first be added via the FreeFlow Printer Registration application.  
- Printer Status/Job Status Tool  
  Allows you to status jobs, queues, and printers.  
For additional information, refer to the online Help for the Registered Printer List Locator, Printer Registration, or the Printer Status/Job Status Tool. |
<table>
<thead>
<tr>
<th>Procedure</th>
<th>Overview</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure the SMTP server</td>
<td>The Simple Mail Transport Protocol (SMTP) Server is used for e-mail notification. The SMTP Setup dialog, accessed via the Workflow Builder application, allows you to identify the mail server for outgoing mail or notifications, define authentication parameters, and establish the maximum size for e-mail attachments. For details, refer to the following procedure in the online help: “Setting up the SMTP Server.”</td>
</tr>
<tr>
<td>Set up workflows</td>
<td>Three default workflows are provided with the software: Simple, Main, and Reprint. Modify these workflows or create your own, based on the needs of your organization. For details, refer to the following procedure in the online help: “Configuring process settings;” or “Building a new workflow.”</td>
</tr>
<tr>
<td>Generate the preflight profile repository on a clean install.</td>
<td>Preflight profiles do not exist on a clean install. You will need to generate the profile repository. For details, refer to the following procedure in the online help: “Configuring preflight settings.”</td>
</tr>
<tr>
<td>Create or modify preflight profiles.</td>
<td>You may want to modify the preflight profiles that are provided with FreeFlow Process Manager. For details, refer to the following procedure in the online help: “Creating preflight profiles.”</td>
</tr>
<tr>
<td>Set the default job option in Adobe Acrobat</td>
<td>For the Convert process, you can select from various job options, or create custom job options, to generate optimal PDFs in Process Manager. The default job option that is displayed in Process Manager is selected in Adobe Acrobat Distiller. You can ensure that Process Manager displays the desired Adobe Acrobat Distiller default job option by selecting a profile from the Default Settings drop box in Acrobat Distiller. For details, refer to the following procedure in the online help: “Configuring Convert settings.”</td>
</tr>
<tr>
<td>Upgrade legacy workflows that contain the Job Level Edit process.</td>
<td>In previous versions, 6.0 and below, of FreeFlow Process Manager, all job level edit functions (for example, watermarks, page numbering, page rotation) were available via a single Job Level Edit dialog. Legacy workflows that contain Job Level Edit processes will perform as they did in earlier versions, but you will not be able to edit them. To use previous versions (6.0 and below) job level edit functions, save the existing Job Level Edit workflow, and it will be converted into a series of individual, Watermark, Bates Numbering, Page Numbering, Flip and Rotate nodes, as appropriate. For details, refer to the following procedure in the online help: “Upgrading legacy workflows that contain the Job Level Edit process.”</td>
</tr>
</tbody>
</table>
## Procedure

<table>
<thead>
<tr>
<th>Procedure</th>
<th>Overview</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ensure Color Manage workflow consistency between the server and a remote client. Importing legacy (version 5.0 and below) workflows with a Color Manage node.</td>
<td>Workflows that include color management can become inconsistent between the Process Manager server and the remote client when profiles are uninstalled on the server. Color profiles are now managed in the Optimize node Color tab. If you import a legacy workflow with a Color Manage node into FreeFlow Process Manager, the legacy Color Manage icon is converted to an Optimize icon and the settings transfer automatically to the Optimize settings Color tab. For information, refer to the Ensuring Color Manager workflow consistency between the server and a remote client procedure.</td>
</tr>
<tr>
<td>Import ICC profiles ICC profile rights</td>
<td>Import any required ICC profiles. You must own the rights to use the ICC profiles accessed by FreeFlow Process Manager. For details, refer to the following procedure in the online help: “To import an ICC profile.”</td>
</tr>
<tr>
<td>Set up hot folders</td>
<td>You can open a common browse folder dialog and select or create a folder in the system via the Hot Folders dialog in Workflow Builder. You can: • Pause/resume all hot folders or individual hot folders. • Enable file clustering on a per hot folder basis. For details, refer to the following procedure in the online help: “Setting up a hot folder.”</td>
</tr>
<tr>
<td>Set up external processes</td>
<td>You may want to add external processes to support third party software, or to set up third party scripts. For details, refer to the following procedure in the online help: “Using third party external processes.”</td>
</tr>
<tr>
<td>Set up Preps</td>
<td>To use Preps, you will need to install it, configure the default Preps workflow, and create and save Preps job files. For details, refer to the following procedure in the online help: “Setting up Preps.”</td>
</tr>
</tbody>
</table>

## Logging in to the FreeFlow Process Manager applications

Process Manager user accounts are created and managed using the Windows Local Users and Groups functionality in the Computer Management application. During install, Xerox FreeFlow Process Manager Administrators and Xerox FreeFlow Process Manager Operators groups are created. Your administrator then populates these groups with users. Permissions to launch applications are based on group membership. For more information, see *Group membership and authorization* on page 2-6.
Authorization error message

The Windows operating system caches a user’s group membership information. If you add yourself to an authorization group (e.g., Xerox FreeFlow Process Manager Administrators) and then try to launch an application, you will receive an error message indicating you do not have permission to launch FreeFlow Process Manager applications. To rectify this issue, log off and then log back on.

Group membership and authorization

The following table shows authorization based on membership in FreeFlow Process Manager Administrators or FreeFlow Process Manager Operators groups.

<table>
<thead>
<tr>
<th>Administrator</th>
<th>Operator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Can launch Workflow Job Manager, Workflow Submission Client, Manifest Automation from Xerox (MAX) and MAX Submission Client</td>
<td>Can launch Workflow Job Manager, Workflow Submission Client, Manifest Automation from Xerox (MAX) and MAX Submission Client</td>
</tr>
<tr>
<td>Can launch Workflow Builder</td>
<td>Cannot launch Workflow Builder</td>
</tr>
<tr>
<td>Can launch FreeFlow Administrator Tool and perform all administrative tasks</td>
<td>Can launch FreeFlow Administrator Tool and edit repository connection information</td>
</tr>
</tbody>
</table>

**NOTE**

Printer Registration also supports user authentication through the operating system and application-level authorization through membership in operating system groups.

Managing production printers

A common printer interface enables all FreeFlow applications to maintain a single database of configured printers and to have a common job setup GUI interface across FreeFlow applications. The common printer interface includes the following utilities:

- **Registered Printer List Locator**: Allows you to set whether the registered printer list in use by a FreeFlow application is located on a local computer or a remote computer.
- **Printer Registration**: Allows you to register and manage supported production printers and queues for use by FreeFlow software applications. To configure the Print process step in a workflow, production printers must first be added via the FreeFlow Printer Registration application.
- **Printer Status/Job Status Tool**: Allows you to status jobs, queues, and printers.

**NOTE**

When building a workflow containing the Print node, you must register the printer associated with the Print node.

Xerox FreeFlow Common Printer Administrators group

In order to make changes to registered printers with the Printer Registration tool, a user must be a member of the Xerox FreeFlow Common Printer Administrators group.
Registering and adding a production printer

1. Select Start > Programs > Xerox FreeFlow Software > Printer Registration, or in Workflow Job Manager, select Launch > Printer Registration. The Installed Products dialog displays.
2. Ensure the radio button for Process Manager is marked.
3. Select OK.
4. In the Printer Registration dialog, select the desired task: Add, View/Edit, or Delete.
5. For additional information about registering and managing printers, select Help in the Printer Registration dialog to open the online Help.
   For additional information about Production Printing, refer to the online Help for the Registered Printer List Locator, Printer Registration, or the Printer Status/Job Status Tool.
With Xerox FreeFlow Workflow Builder you can create workflows by dragging and dropping processes into a sequence. You can also choose system configuration options. Optionally, you can configure and add third party software workflow components to a workflow to enhance the flexibility and capabilities of the Process Manager system.

Workflow process icons

The Workflow Builder Insert menu allows you to insert processes into a displayed workflow. To insert a process, select a process in a workflow, and select Insert > item. The new process is inserted to the right of the selected process.

Workflow processes are also available as icons in the Workflow Process Options area. The icons can be dragged and dropped into the workspace to assemble a workflow.

<table>
<thead>
<tr>
<th>Process Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input</td>
<td>Displays automatically as the first workflow node when you select Enter during new workflow creation.</td>
</tr>
<tr>
<td>Image Enhancement</td>
<td>Automatic Image Enhancement (AIE) optimizes sharpness, color balance, saturation, exposure, noise reduction and contrast of TIFF, JPEG, and BMP images, whether standalone or embedded in a PDF. AIE also supports redeye removal for humans and shadow detail enhancement. The AIE feature works only for color and grayscale images.</td>
</tr>
<tr>
<td>Convert</td>
<td>Converts documents submitted to the workflow to PDF. Converts the following formats: MS Word, MS PowerPoint, MS Excel (includes Microsoft Office 2007), MS Publisher, Adobe Photoshop, Adobe InDesign, Adobe Illustrator, JPG, JPEG, TIFF, TIFF-IT, TIF, BMP, PS, RDO, Quark Xpress (QXD and QXP), VPC, and EPS. Allows you to flatten PDFs by converting them to Postscript and back to PDF again. Uses Acrobat Preflight Fixups to automatically correct job problems. You can select an Adobe Acrobat Distiller job option to generate optimal PDFs.</td>
</tr>
<tr>
<td>Join</td>
<td>Combines multiple PDF files into a single PDF file.</td>
</tr>
<tr>
<td>Process Icon</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Optimize</td>
<td>The Optimize process allows you to automatically correct common problems with PDF files. You can embed missing fonts, define PDF boxes and flatten document transparencies and overprints. The transparency and overprint flattening render the document objects to ensure that optimized documents RIP with the expected appearance. The Optimize process node can also perform ICC-based color conversion and spot color suffix normalization. You can also create a PDF/X-1a compliant PDF.</td>
</tr>
<tr>
<td>Preflight</td>
<td>Uses an Adobe Acrobat preflight profile to validate and check formatting, verify the image, fonts, and verify references to OPI image server images. Fixups in Acrobat Preflight profiles can be used to automatically correct many PDF problems including PDF box manipulation, resizing to PDF contents and dealing with non-printing content and PDF Layers.</td>
</tr>
<tr>
<td>Watermarks</td>
<td>Allows you to add a text or image watermark to selected pages of an input PDF file. You can specify a combination of images or text, in various alignments, that can appear either underneath or on top of the page content. Selected pages may be specified as all pages, odd or even pages, landscape or portrait pages, specific document pages, or as a page range (for example, pages 1-5, 8).</td>
</tr>
<tr>
<td>Bates Numbering</td>
<td>Allows you to add bate stamps to selected pages of an input PDF file. Bate stamps consist of a page number with optional leading zeros and an optional fixed text prefix. An optional extra line of fixed text can appear either above or below the page number. Selected pages may be specified as all pages, odd or even pages, landscape or portrait pages, specific document pages, or as a page range (for example, pages 1-5, 8).</td>
</tr>
<tr>
<td>Page Numbering</td>
<td>Allows you to add page numbers to selected pages of an input PDF file. Selected pages may be specified as all pages, odd or even pages, landscape or portrait pages, specific document pages, or as a page range (for example, pages 1-5, 8).</td>
</tr>
<tr>
<td>Barcodes</td>
<td>Allows you to add a barcode to your workflow. You can specify the barcode type or symbology, symbology-specific options, width, height, padding, inclusion of human-readable text, placement, alignment, rotation, frequency, size and other options. Selected pages may be specified as all pages, odd or even pages, landscape or portrait pages, specific document pages, or as a page range (for example, pages 1-5, 8).</td>
</tr>
<tr>
<td>Rotate Pages</td>
<td>Allows you to rotate selected pages in the PDF file 90 degrees right or left, or 180 degrees. Selected pages may be specified as all pages, odd or even pages, landscape or portrait pages, specific document pages, or as a page range (for example, pages 1-5, 8).</td>
</tr>
<tr>
<td>Flip Pages</td>
<td>Allows you to flip selected pages in the PDF file horizontally or vertically to create a mirror image. Selected pages may be specified as all pages, odd or even pages, landscape or portrait pages, specific document pages, or as a page range (for example, pages 1-5, 8).</td>
</tr>
<tr>
<td>Resize</td>
<td>Allows you to select a specific size, or a size based on a percentage of the original image size. For TIFFs, JPGs, or BMPs, the image is resized; for PDFs, the page is resized. Selected pages may be specified as all pages, odd or even pages, landscape or portrait pages, specific document pages, or as a page range (for example, pages 1-5, 8).</td>
</tr>
<tr>
<td>Process Icon</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Impose</td>
<td>Allows you to select an imposition template to apply to the job. Supports repeated, sequential, alternating and cut &amp; stack multiup imposition. Supports saddle and perfect bound booklet and calendar imposition. Also allows the addition of crop marks to the imposed document. You can specify which face of the sheet to place marks on and the PDF boxes on which to place crop marks.</td>
</tr>
<tr>
<td>Crop</td>
<td>Allows you to automatically crop jobs consisting of one or more PDF pages and JPEG, TIFF, or BMP file images. For PDF documents, crops the pages; for JPEG, TIFF, or BMP files, crops the images. Selected pages may be specified as all pages, odd or even pages, landscape or portrait pages, specific document pages, or as a page range (for example, pages 1-5, 8).</td>
</tr>
<tr>
<td>Pressmarks</td>
<td>Allows you to add a pressmark image to selected pages of an input PDF file. You can specify the pressmark placement, rotation, frequency, and transparency. Selected pages may be specified as all pages, odd or even pages, landscape or portrait pages, specific document pages, or as a page range (for example, pages 1-5, 8).</td>
</tr>
<tr>
<td>Review</td>
<td>Can be used multiple times, at critical points in a workflow, to view, check and edit the PDF file using Adobe Acrobat. When stopped at the Review step, you can change process settings, resubmit the job to a previous step for additional processing, view a soft proof, or print a hardcopy proof. You can approve the job and allow it to move to the next step in the workflow, or you can fail the job. If you save the PDF after editing it in Acrobat, the edited PDF will be moved to the next step in the workflow. If there is a Print step after the Review step, you can select Copies to access the Copies dialog and change the number of copies to print.</td>
</tr>
<tr>
<td>Notify</td>
<td>Provides job status notification via e-mail. allows you to attach preflight results and job files up to a maximum size of 1 GB.</td>
</tr>
<tr>
<td>Print</td>
<td>Allows you to print PDF, VPC, or RDO (for reprint) files to a specified production printing queue using a specified job ticket. For information about reprinting RDOs, refer to the topic “About submitting RDOs.”</td>
</tr>
<tr>
<td>Save</td>
<td>Allows you to save all supported file types from the workflow to a specified location in a Windows file system or document repository. Also allows saving of an XPIF job ticket, if available, with the job.</td>
</tr>
<tr>
<td>JDF Export</td>
<td>The output file of a JDF export task can be re-imported and re-run by dropping it into a hot folder associated with an appropriate workflow. The files associated with the JDF must exist in the same location as the original job.</td>
</tr>
<tr>
<td>Conditional</td>
<td>Conditional branching provides an added level of logic to a workflow, allowing it to examine the properties of submitted jobs, and then act accordingly without human intervention. You can add one or more conditional branches to a workflow, each with one or more user-designated conditions that specify the desired attributes or properties of the submitted jobs.</td>
</tr>
</tbody>
</table>
### External Process

**Description**

External Process enables the integration of third party workflow components. Workflow components may be integrated via hot folders or via Command Line Interface.

### Building workflows

You can create new Workflows or duplicate an existing workflow. To build or modify a workflow, you perform the following basic steps:

- Drag and drop process icons into the workspace. Processes move from left to right in the workflow.
- Configure the process settings, as needed, to meet the requirements of the workflow.
- Save and enable the workflow.

**NOTE**

All workflows are disabled after an upgrade or migration. A pop-up message displays if you try to enable a workflow that requires additional configuration. Complete the configuration, and then enable the workflow.

### Rules for building workflows

Apply the following rules when you sequence workflow process steps in the workspace:

- Input is the first step in any workflow. **Input** is automatically displayed in the workspace when you begin a new workflow.
- If Convert exists in a workflow, it must precede the following processes:
  - Join
  - PDF Optimize
  - Preflight
  - Impose
  - Bates Numbering
  - Page Numbering
  - Watermarks
  - Rotate Pages
  - Flip Pages
  - Print
  - Barcodes
  - Pressmarks
Building a new workflow
To build a new workflow, drag and drop process icons into the workspace, configure the process settings to meet the workflow requirements, and then save and enable the workflow.
1. Launch Workflow Builder.
2. In the Workflows toolbar, select New. A new workflow is added to the list. A highlighted name cell is provided for editing.
3. Select the desired process from the Workflow Process Options area, and drag and drop the process into the workflow workspace into the desired position.
4. If necessary, configure the process settings.
5. Select Save and Enable.

NOTE
A Workflow must be enabled before it can accept new jobs for processing.

Creating fail branches
You may also add fail branches -- contingency workflow steps for fail conditions. For example, after a Preflight process, you might want to add a fail branch that contains the following:
- A Notify process that contains Preflight results.
- A Review process, to check or edit the document.

The workflow defaults to having no fail branches open. You can open a branch by clicking on the “plus” icon and collapse the branch by clicking on the “minus” icon.
1. Select the desired fail branch process and drag it downward, after the desired process in a workflow.
2. Drag the process into the gray space holder that appears after the red arrow.

NOTE
You can also place a fail branch after a process step as follows: Select, and then Copy a process, point to the desired position in the workflow, and select Paste as Fail Branch from the Edit menu.

Exporting workflows
The Process Manager export/import workflow function provides workflow portability and a method for backing up and restoring workflows and their associated hot folders and other resources.

NOTE
Custom preflight profiles must be exported from within Adobe Acrobat.

NOTE
A .wfc folder displays in the export save location, along the .xml file. It contains configuration files, hot folder, and other workflow information to enable workflow and hot folder restoration during import.
1. In Workflow Builder, select a workflow or multiple workflows.
2. Select File > Export and save the workflows to the desired location.
Importing workflows

Import any required custom preflight profiles before importing a workflow. To import a workflow, you must first generate an .xml workflow file by exporting a workflow. The .xml file can then be imported into Workflow Builder on the same Process Manager server or imported into Workflow Builder on a second Process Manager server.

NOTE
Only .xml files can be selected.

NOTE
If the .xml file is incorrectly formatted, an error message similar to this displays: “The file complete path does not contain readable workflow data.”

NOTE
If the .xml file contains workflows of the same names, the following message displays: Cannot import the following workflows [workflow names]. Existing workflows of the same name already exist. Please rename or delete the existing workflows first. “Names are not case-sensitive: “Newsletter Workflow” is the same as “newsletter workflow”.

1. In Workflow Builder, select File > Import.
2. In the Open window, browse to the desired workflow XML file.

The workflow is fully restored, including any referenced directories and hot folders that were deleted after the workflow was exported.

Ensuring imported workflow compatibility

Workflows can be successfully imported from one Process Manager server system to another Process Manager server if both servers have the same software version of Process Manager and if all the configurations on the second server are compatible.

The following items should be checked for compatibility:
- Preps jobs lists and custom templates
- Fonts used in Bates Numbering, Page Numbering, Watermarks
- ICC profiles used in Optimize
- Adobe Acrobat Preflight profiles used in Preflight

Configuring process settings

About Input
When you create and name a new workflow and select Enter. An Input node automatically displays at the beginning of the workflow.

In Workflow Builder, the Input node does not have a settings dialog. In Workflow Job Manager, you can open the Input settings dialog and view a list of the original input files, the file path, file size and date modified. Input files can also be viewed via the tool tip.

Configuring Image Enhancement settings
To access the Image Enhancement Settings, double-click the Image Enhancement step in a workflow.
Image Enhancement allows the application of a range of image processing operations that optimize the sharpness, color balance, saturation, exposure, noise reduction and contrast of TIFF, JPEG, and BMP images, whether standalone, or embedded in a PDF. Image Enhancement also supports red eye removal for humans and shadow detail enhancement. The Image Enhancement feature works for only color and grayscale images.

**Limitations for Image Enhancement**

- Image Enhancement can be applied only to raster image files such as TIFFs, JPEGs, and BMPs. It also supports those files if they are embedded in PDFs.
- The image quality improvement for BMPs may be minimal.
- Image Enhancement red eye reduction applies only to photographs of humans, and not to photographs of animals.
- The Exif data that is found in some JPEG files is not currently supported by Image Enhancement and will result in the loss of resolution information.
- If you include the Image Enhancement process in a FreeFlow Process Manager workflow and submit the job to a DocuSP 5.1 or a Xerox FreeFlow Print Server, ensure that you submit it to a queue for which Image Enhancement is not enabled.
- If you have the option of performing the Image Enhancement processing in either FreeFlow Process Manager or in the current DocuSP 5.1 or Xerox FreeFlow Print Server, for reasons of flexibility and performance, it is recommended that you do so in FreeFlow Process Manager, rather than in DocuSP 5.1 or Xerox FreeFlow Print Server.

### Configuring Convert Settings

Process Manager automates the processing of PDF documents. The Convert process step enables Microsoft Word, Microsoft Excel, Microsoft PowerPoint, Microsoft Publisher, Adobe InDesign, Adobe Illustrator, Adobe Photoshop, JPG, JPEG, BMP, TIFF, TIFF-IT, TIF, PS, VPC, QXD, QXP, RDO, and EPS document types to be converted to a PDF document for submission to Process Manager workflows.

You can select from various job options to generate optimal PDFs for Microsoft Office (including Microsoft Office 2007) or PS files. The job options include the basic Adobe Acrobat Distiller set with the addition of various Xerox-specific job options, including DocuColor iGen3. You can also create custom job options in Adobe Acrobat Distiller for use in Process Manager.

The default job option that displays in Process Manager is selected in Adobe Acrobat Distiller.

The Flatten submitted PDF files for printing option allows you to re-process PDF files with known printing problems. “Flattening” converts a PDF file to PostScript, and then converts it back to a PDF file. This feature may result in a loss of features and image degradation, including:

- Loss of transparency.
- Loss of some interactive features such as thumbnails, bookmarks, article threads, logical structure and trapping information.
- Loss of functionality of other interactive features such as forms, hyperlinks, JavaScript.
- Loss of some annotations such as comments, embedded files, embedded media such as video/audio, and references to external files or media.
Manual Conversion tab

Adobe Illustrator and QuarkXPress files must be manually converted to PDFs before they can be processed in a workflow. To do this:

- Set up a working directory via the Convert Settings dialog. Files are held in the directory until they are manually converted.
- Set up an email notification address via the Convert Settings dialog. This allows you to send an e-mail message to indicate that a Adobe Creative Suite or QuarkXPress document is waiting to be converted to PDF. A message will be sent for each document processed.

**NOTE**
The SMTP server must be configured to enable email notification.

- Manually convert the files to PDF via Adobe Creative Suite or QuarkXPress and save the converted files in the working directory to continue workflow processing.

Microsoft® Office conversion setup

1. Enable Microsoft Office conversion.
   a) Log in as XDL_ADMIN.
   b) Launch the Microsoft Office applications once.
   c) Log off.
2. If Process Manager is installed on Windows 2008 Server, configure DCOM.
   a) Log in as administrator.
   b) Open Control Panel > Administrative Tools > Component Services.
   c) In the left pane, open
      Control Root > Component Services > Computers > My Computer > DCOM Config.
   d) Select No for all warning dialog boxes that display.
   e) Close Component Services.

Restrictions on PDF conversion

Depending on the submission method, PDFs created by a Process Manager Convert node may have restrictions on their use. If you purchase a PDF conversion license, all PDFs are unrestricted. PDF conversion jobs submitted using the following methods have restrictions on e-mailed PDFs:

- Hot Folders
- MAX
- MAX Submission Client
- JDF
- JMF
- a remote Workflow Submission client without Adobe Acrobat installed

If the job is submitted using one of the listed methods, PDFs e-mailed by a Notify node have the following restrictions:

- low resolution proofs are watermarked
- high-resolution proofs are watermarked and cannot be edited or printed

PDFs from jobs submitted by the Workflow Submission Client running on the Process Manager system do not have restrictions.
Working with PDF files

- Adobe does not support PDF files larger than 2.25 GB on the Windows platform.
- PDF files containing more than 30,000 pages and are not supported.
- If the input PDF file requires a password to open the PDF file, most operations will fail.

Remote Creative Suite Conversion setup

The Remote Creative Suite Conversion Setup dialog is used to enable automatic conversion of Adobe InDesign and Adobe Illustrator files from a remote workstation.

1. In Workflow Builder, select **Options > Remote CS3 Conversion Setup**.
2. Mark the **Enable automatic conversion of Creative Suite files using a remote workstation** if you want to enable automatic conversion of Adobe InDesign and Adobe Illustrator files.
3. Enter the appropriate path for the Remote Conversion Share Path.
4. Select **OK**.
Setting up the Remote Conversion Client

1. Log in to the Remote Conversion Client as XDL_ADMIN.
2. Create a new shared folder on the drive where the Adobe Illustrator and Adobe InDesign applications are installed.
   a) Right-click the folder and select **Properties**.
   b) In the **Sharing** tab select **Share this folder**.
   c) Set the Share name.
   d) Select **Permissions**.
   e) Add XDL_ADMIN to the **Share Permissions** and allow **Full Control**.
3. For Windows XP, disable the system firewall.
   a) Select **Start > Settings > Control Panel > Windows Firewall**.
   b) In the **General** tab select **Off**.
4. Disable the **Remote Registry** service.
   a) Select **Start > Settings > Control Panel > Administrative Tools > Services**.
   b) If the **Remote Registry** service is not already **Started** and **Automatic**, make the changes in the properties of the service.
5. Configure the **Local Security Policy**.
   a) Select **Start > Settings > Control Panel > Administrative Tools > Local Security Policy**.
   b) In the tree view, select **Local Policies > Security Options**.
   c) Double-click **Network Access: Sharing and security model for local accounts**.
   d) Select **Classic - local users authenticate as themselves**.
6. Configure **Component Services**.
   a) Select **Start > Settings > Control Panel > Administrative Tools > Component Services**.
   b) In the tree view, select **Component Services > My Computer > DCOM Config**.
   c) If a warning The CILSID { } ... has the name value AppId but is not recorded under \HKEY_CLASSES_ROOT\AppID. Do you wish to record it? appears, select **No**.
   d) If CS2 is installed and the object **Illustrator InkInfo** is defined, select **The interactive user** in the **Identity** tab of the object properties.
   e) If CS3 is installed and the object **Illustrator LabColor** is defined, select **The interactive user** in the **Identity** tab of the object properties.
   f) If either CS2 or CS3 is installed and the object **Adobe InDesign Application** is defined, select **The interactive user** in the **Identity** tab of the object properties.

About Join

Join combines, or concatenates, multiple PDF files into a single PDF file. All the PDF files must exist before you attempt to use the Join process.

Files in a multiple-file job are processed separately until they reach the Join process.

- Once files are joined, only one set of parameters and one job ticket apply.
- The Join process may be placed anywhere in a workflow. However, only you can have only one Join process per workflow.
- Once files are joined, they job cannot be resubmitted to a point before the Join process.
Limitations for Join

Bookmarks, logical structure, internal hyperlinks, and article threads within PDF files might not be preserved by the PDF Join component.

Configuring Optimize Settings

The Optimize process allows you to modify a PDF file to be PDF/X compliant, specify how fonts should be embedded, define PDF Box settings, configure spot color settings, manage color profiles, and configure image quality settings for hairline correction and the removal of color trapping layers.

The Optimize Options dialog includes five tabs: General, PDF Boxes, Color, Spot Colors, and Image Quality. The availability of dialog options varies, depending on whether the Create a document that complies with PDF/X standards option is selected, for example:

• When compliance is selected, font embedding is automatically set to ON, and output compliance error handling is available.
• When compliance is not selected, font embedding is automatically set to OFF; Color Management is enabled, and independent use of the PDF Box is enabled.

To configure the General Optimize settings

The General tab allows you to select a Settings File, define compliance criteria, designate font embedding options, and optimize for fast web viewing.

1. In the Settings File area, select from the following to load a settings file:
   • pdfx-1a2001.xml (pre-installed settings file)
   • pdfx-1a2003.xml (pre-installed settings file)
   
   NOTE
   If created, other user-defined settings files are also displayed.

2. In the Compliance area, mark the check box for Create a document that complies with PDF/X standards and select from the following options:
   • PDFX-1a 2001
   • PDFX-1a 2003

3. In the Fonts area, select from the following:
   • Embed Fonts Selected by default and grayed out when compliance is selected.
   • Embed as subset to minimize the document file size.
   • Select Embed all fonts to enable future text editing. If a font has been previously subset embedded, it will be fully embedded. This option increases the file size.
   
   NOTE
   The font family must be loaded on the PC. Only fonts with the appropriate permission bits will be embedded.

4. In the Fast Web Viewing area, mark the check box for Optimize the document for fast web view to enable fast page-at-a-time downloading from web servers.

5. Select Show job submitter the settings file name only. Settings details will be hidden to display only the Settings File drop box to job submitters. All other dialog features are hidden.
About PDF Boxes settings

The PDF Boxes tab allows you to define PDF Box settings. The availability of dialog options varies, depending on whether the Create a document that complies with PDF/X standards option is selected in the General tab.

When the check box for Set crop box to media box is checked:
- If a PDF document has a crop box, it is replaced with one the size of the media box.
- If the PDF document does not have a crop box, one is generated and set to the size of the media box.

When the trim box and art box are missing, or when the bleed box is missing, you can choose how to handle the job.

About PDF Boxes

The following table describes the PDF media box, bleed box, trim box and art box.

<table>
<thead>
<tr>
<th>PDF Box</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media box</td>
<td>Page size; contains all the objects of a page, including text and images that appear on the page or that bleed or extend off the edge of the finished document. Media box dimensions are always greater than or equal to the trim box dimensions. Media box dimensions are always greater than or equal to the bleed box dimensions.</td>
</tr>
<tr>
<td>Crop Box</td>
<td>The crop box represents the region in which the page contents are trimmed when displayed or printed. It defines how the page contents are placed on the output medium. The crop box dimensions are always greater than or equal to the trim, art, and bleed box. The crop box dimensions are always smaller than or equal to the media box.</td>
</tr>
<tr>
<td>Bleed box</td>
<td>Represents an extended area around the trim box at which contains content that will be trimmed during finishing. A document that requires a bleed also requires a bleed box. The bleed box must be smaller than the media box, and can be the same or larger than the trim box.</td>
</tr>
<tr>
<td>Trim box</td>
<td>Represents the final finished size of the document after printing and finishing. A document intended for commercial printing requires a trim box. The trim box must be smaller than the media box, and can be the same as the bleed box. Trim marks are nominally placed around the trim box.</td>
</tr>
<tr>
<td>Art box</td>
<td>Represents an area of the page (for example, a piece of clip art) to be positioned when the PDF content is placed in an application, such as a page layout program. The art box must be smaller than the bleed box. Trim and art boxes may have the same dimensions.</td>
</tr>
</tbody>
</table>
About Color settings

The Optimize step settings Color tab allows you to select the output color space, source color space, define the appropriate action when an error occurs, and select the desired transparency. In the Output Color Space area, the Change all colors in document drop box allows you to define the desired output color space:
- Convert colors to gray (always available)
- Convert colors to CMYK (always available)

NOTE
The following options are available only if Create a document that complies with PDF/X standards is not selected on the General tab:
- Don’t change colors -- to gray out the Source Color Space options; prevent color changes in the document.
- Manage Color profiles -- to enable color management. This enables the Don’t change ICC profiles for [xx] option in the CMYK, RGB and Gray drop boxes in the Profiles to use section. Enables Treat managed [xx] as.
- Convert colors to RGB

NOTE
The Color Manage node from earlier versions of FreeFlow Process Manager is replaced by the Manage Colors profiles option.
- In the ICC profile drop box, select the desired profile.

NOTE
You must own the rights to use the ICC profiles accessed by FreeFlow Process Manager.

Selecting the Use Output Intent, if present, for Source Color Space check box allows the document’s output intent to override the designated source color space profile. In the Source Color Space area, the following information applies to the CMYK, RGB, and Gray drop box options:
- Treat untagged [CMYK, RGB, or Gray] as: Assigns the selected ICC profile to all non-profiled [CMYK, RGB, or Gray] objects.
- Treat managed [CMYK, RGB, or Gray] as: Available when “Manage Color Profiles” is selected in the “Change all colors in document” area. Assigns the selected ICC profile to all profiled [CMYK, RGB, or Gray] objects.
- Treat all [CMYK, RGB, or Gray] as: Assigns the selected ICC profile to both non-profiled and profiled [CMYK, RGB, or Gray] objects.
- Don’t change ICC profiles for [CMYK, RGB, or Gray]: Available with “Manage Color Profiles” selection. Grays out the [CMYK, RGB, or Gray] profile. Preserves the original profile of [CMYK, RGB, or Gray] objects within the document.

Importing a legacy workflow with a Color Manage node

If you import a legacy workflow with a Color Manage node into FreeFlow Process Manager, the Color Manage icon is converted to an Optimize icon and the settings transfer automatically to the Optimize settings Color tab.
About Spot Colors settings

The Spot Color tab allows you to keep spot colors, convert to common CMYK standard colors, or to convert to an alternative color space. It provides a normalization process with the ability to allow you to specify how to treat PANTONE® Color values with C, CV, U, CVC, and CVU suffixes.

**NOTE**

If no spot colors are defined in the exclusion list, then all spot colors in the document will be converted. Objects that contain multiple spot colors must have all of their spot colors defined in the exclusion list or the objects will be converted to the Output Color Space. The exclusion list appears below the text box.

To configure Image Quality settings

The **Hairline Correction** feature thickens stroke lines within a document that may be too thin for printing purposes.

The Remove color trapping layers option allows you to eliminate color trap layers from the PDF. Color trap layers are originally intended to provide fill between two objects that abut in a document but end up printing with white space along the abutting borders. Color trap layers solve the issue by printing an overlapping border between the abutting objects.

**NOTE**

Removal of trap layers is supported for traps created by Prinergy, Prinect and Esko Graphics.

Managing Color profiles

Color Manage allows you to:

- Add CMYK, RGB, or gray profiles to untagged CMYK content.
- Replace CMYK, RGB, or gray profiles for tagged content.

A CMYK, RGB or gray profile is added to untagged content when colors need to be transformed or accurately displayed or printed. Untagged color spaces (also known as "device" spaces) have an ambiguous interpretation; adding a profile resolves the ambiguity by providing a specific interpretation of the data.

CMYK, RGB or gray profiles are replaced for tagged content when the original profile—the original specification of how the color values should be interpreted—is wrong or has changed. This can occur when:

- The original profile is known to be incorrect—for example, because of a known error in prior processing.
- The color is being edited, and the output is desired in a different color space.

Only profiles installed on the Windows Operating System are visible.
Ensuring Color Manage workflow consistency between the server and a remote client

Workflows with color management enabled in the Optimize node can become inconsistent between a Process Manager server and remote client when profiles are uninstalled on the server. Use the following procedure to ensure workflow consistency.

1. Disable the Workflow.
2. Open the Optimize node.
3. Enable the workflow to reset the profile database.

Configuring Preflight settings

The preflight validation depends on the profile you select. The administrator defines preflight profiles using Adobe Acrobat Professional’s profile repository and Xerox custom profiles. The Xerox FreeFlow Recommended Preflight profile, provided with the FreeFlow Process Manager product, includes the following checks:

- Font is not embedded
- Image resolution is less than 250 ppi
- Bitmap (1bit monochrome) image resolution is less than 600 ppi
- Document is damaged and needs repairs
- PDF contains errors or is damaged

To generate the preflight profile repository on a clean install

Preflight profiles do not exist on a clean install. After a clean install, do the following to generate the profile repository:

1. Select Start > Programs > Adobe Acrobat Professional.
2. In the Advanced menu, select Preflight. This generates the profile repository from which you can select profiles in the Preflight Settings dialog.
3. Close Adobe Acrobat Professional.

To configure Preflight settings

1. In the Select Preflight profiles that submitters can choose from text box, select the desired profiles. The profiles will be listed in the Select the default profile drop box.
2. In the Select the default Preflight profile drop box, select a default profile.

Upgrading legacy workflows that contain Job Level Edit nodes

In previous versions of FreeFlow Process Manager (2.0 through 4.0), all job level edit functions (for example, watermarks, page numbering, page rotation) were available via a single Job Level Edit dialog. In this version, you must add an individual process step to the workflow for each function. Legacy workflows that contain Job Level Edit processes will perform as they did in earlier versions, but you will not be able to edit them. To use this version of job level edit functions, save the existing Job Level Edit workflow, and it will be converted into a series of individual, Watermark, Bates Numbering, Page Numbering, Rotate and Flip nodes, as appropriate.
About Watermarks

Up to 1000 user-configured text and image watermarks can be set up and applied to each page of an input PDF file. The List box shows watermarks that have been configured. The attributes for a selected watermark are displayed in the Description area. Image and text icons to the left of each watermark indicate the watermark type.

**NOTE**

All watermarks in the Watermarks list are applied to the job and are applied in the order in which they are listed.

Image watermarks can be transparent or opaque, scaled, rotated, variably positioned from the document edge and can appear either underneath or on top of the page content. Text watermarks can consist of multiple lines with hard line breaks. They can be created in a variety of font types, sizes and colors; can be transparent or opaque, rotated, or variably positioned from the document edge; and can appear either underneath or on top of the page content.

About Bates numbers

Bates numbering can be added to an input PDF file. Bates numbering consists of a page number with optional leading zeros and an optional fixed text prefix. An optional line of fixed text can appear either above or below the bates number.

Adding page numbers

Page numbers can be added to a PDF file. Page numbers are available in a selection of styles, including 1, 2, 3; I, II, III; or i, ii, iii. Options include adding a prefix and/or suffix, and selecting font, color, and position.

Adding a Barcode

The Barcode node allows you to add a variety of barcodes to your workflows. You can specify the barcode type or symbology, font, placement, alignment, rotation, frequency, and size. You can specify additional symbology-specific barcode options. For example:

- Two-digit or 5-digit supplements. The supplement is a second barcode, separate from the primary barcode and positioned to its right.
- A checksum, for barcode verification, which may be either optional or mandatory.
- Start and stop characters that bracket the bar code content.
To configure Barcode settings

1. To open the **Add Barcode** dialog, double-click the **Barcode** process in a workflow.
2. In the **Barcode** tab, specify the barcode symbology from the drop box.
3. In the **Options** area, select from the following:
   
   **NOTE**
   Options vary depending on the selected symbology.

   - **Include check digits** to enable barcode verification.
   - **Include start character** to include a start character in the barcode.
   - **Include stop character** to include a stop character in the barcode.

4. In the **Size** area, specify the following:

   - **Font Size**: Select or type the desired font size. This is an approximation of the width of the narrowest bar in the bar code in mils (one thousandths of an inch). The Bar Codes node does not require you to have bar code fonts installed on the FreeFlow system.
   - **Height**: Select or type the desired barcode height.

   **NOTE**
   The size of the human-readable text is not included in the requested bar code height. If you specify height = 1 inch, the total size of the graphic is one inch plus the height of the readable text extending above or below the bar code.

   **NOTE**
   Height can be specified in inches or millimeters, except for PostNet (Japan) and QR Code because the height for those types is determined uniquely to bar width or cell size.

   - **Horizontal padding**: Select or type the desired padding to control the amount of white space on either side of the barcode.
   - **Vertical padding**: Available for QR Code type only. Select or type the desired padding to control the amount of white space at the top or the bottom of the barcode.

5. Select the desired degree of rotation, in increments of 90 degrees. The icon changes to reflect the selected rotation.
6. Select or type the horizontal position from the PDF document box: **From left**, **Center**, or **From right**.
7. Select or type the vertical position from the PDF document box: **From top**, **Center**, or **From bottom**.
8. Select the position relative to **Crop Box**, **Media Box**, **Bleed Box**, **Trim Box** or **Art Box**.

   **NOTE**
   You can specify offset in inches or in millimeters either as positive (inward from the selected box), or negative (outward from the selected box) numbers. Default placement is Top-Left of the Crop Box, with horizontal and vertical offsets (0.0, 0.0).
9. **In the Apply to pages area, specify the pages upon which the barcode will appear.**

   - If **Page range** is selected, enter a text string using commas and hyphens. For example, select 1-3, 7, 12-14, 17 to print bar codes on pages 1 through 3, on page 7, on pages 12 through 14, and on page 17.

   **NOTE**
   Various order jacket file variables are supported by FreeFlow Process Manager MAX, Manifest Automation from Xerox. You can enter variable data syntax in the page range text box. For example, given an Order jacket file (OJF) with columns 1, 2, 3, 4 containing page range data 1-3, 7, 12-14, 17 respectively, you can enter text $CSV1$, $CSV2$, $CSV3$, $CSV4$ into the page range text box. If OJF column contains an invalid page range, the workflow will fail with an invalid page range error in Workflow Job Manager.

10. Select **Always use these settings** to prevent users from modifying the settings. The settings will appear in the Submission Client controls, but will be grayed out and unchangeable.

11. Select **OK** to accept the changes or select another tab to continue configuring.

   View the dynamic effect of your selections in the Preview window at the bottom of this dialog, or click the Preview button to preview the barcode placement in the document.

---

### To configure the barcode readable text

If the barcode symbology supports it, the Readable Text tab allows you to specify that the data encoded in the bar code prints in a human-readable format. The default is disabled.

   **NOTE**
   The size of the human-readable text is not included in the requested bar code height. If you specify height = 1 inch, the total size of the graphic is one inch plus the height of the readable text extending above or below the bar code.

---

### To configure barcode data

You can specify the data to be encoded as a bar code.

In the **When sheets are part of the barcode data** area, the selected count direction is applied to all three variables (SheetNumber, SignatureNumber, and SheetInSignature).

   **NOTE**
   If bar code frequency is set to Even Pages or Odd Pages, the Bar Codes node treats the document as duplex, and the Sheet Number variable increments for every bar code (i.e., not for every PDF page), while the TotalSheets variable is half the number of PDF pages. The document is also treated as duplex if any of the Signature variables are used.
Configuring Imposition settings

The Imposition process allows you to define the placement of page elements to increase production press efficiency and to create specific applications—for example, booklets.

If Preps is installed on the computer, the initial Imposition Settings dialog allows you to choose one of the following:

- **Specify imposition settings**: When you select OK, displays the FreeFlow Process Manager Imposition Settings dialog, in which you can establish the desired settings.
- **Use Preps job file**: When you select OK, displays the Preps Imposition Settings dialog, in which you can select Preps templates.

To configure Imposition settings - General tab

The General tab allows you to select a job type and establish settings—for example, orientation, stock, margins, and various signature options.

The following Pages on sheet side options are available:

- Repeated fills a multi-up sheet side with copies of a single page.
- Sequential places a single page in each cell of the multi-page up.
- Cut and Stack arranges the order that the images are printed on the sheets so the printed sheets can be cut and easily stacked into one copy of the final document.
- Alternating places the pages sequentially, but alternating the front side and the back side of a page.

By specifying cell-relative position for the PDF image (logical page) within an imposed sheet cell, you can use a single set of imposition parameters with jobs of different sizes within an overall size range.

The following signature options are available:

- Signature Shift to specify an incrementing offset for incoming PDF pages on the output paper stock for Book, Pamphlet, and Calendar job styles.
- Single signature when cleared, to specify the number of sheets per signature segment; when selected, to place all sheets in one signature.
- Sheets per signature to enter the number of sheets that will comprise a single segment of a multiple-segment signature document, from 1-999. Multiple-segment signatures are used for perfect bound books. Available when Single signature checkbox is unchecked.
- Fill last segment to fill the document with blank sheets to ensure the last segment in the job is filled to the value specified in Sheets per signature. Available when Single signature checkbox is not selected.

**NOTE**
The number of sheets in the final signature may not equal the requested value when Sheets per signature does not divide evenly into the number of sheets.

**NOTE**
For the PDF box options, the above options define the box relative to the size of the PDF page being imposed. The box is affected by and moved according to all transformations of the page such as Autofit, Margin, and Page Image Position/Alignment settings. The range is 0 to 60 inches and the metric equivalent. Use care with this option as it is possible to specify a box rectangle that exceeds the actual page size or that is clipped off by the sheet cell(s) during imposition.
Guidelines for Cell Clustering

A cell is the area on a sheet occupied by a multipage imposition scheme. Cell Clustering provides the option of pulling together cells on a sheet in a way that results in cell sizes that contain the imposed page images with no waste space between cells. The Cell Cluster is positioned and aligned as a single entity.

- Cell Clustering is not available for Standard and Signature job types. The cells in a signature job configuration are pulled together using the “Binding-edge” alignment option.
- With Autofit off it is possible to yield cell sizes that when clustered, produce a layout area that exceeds the dimensions of the paper stock. As a result, only a portion of the NxN cell matrix may appear on the cell with the rest of the cells partially or completely clipped by the defined paper stock size.
- With Cell Clustering OFF, the imposition entities being controlled are the individual page images with respect to position, alignment, and autofit. With Cell clustering ON, the entity being controlled is the entire cluster of cells.
About Job types

The following job types are available via the Imposition Settings dialog:

- **Standard**: The pages are printed in a sequential order with one page on one side of a sheet of defined paper stock. There is one Standard job type, for which you can specify the image orientation and sides imaged.

- **Signature**: Two separate pages are printed side-by-side on one side of a sheet of paper. All Signature documents are 2-Sided. The pages of the document are sequenced when printed to produce output that can be folded to create a booklet type of document. There are three signature job types, characterized by the fold (binding edge) of the document:
  - **Signature Booklet**: Landscape, fold (binding edge) is parallel to short edge of the stock
  - **Signature Calendar**: Head To Toe orientation, fold (binding edge) is parallel to short edge of the stock
  - **Signature Pamphlet**: Portrait orientation, fold (binding edge) is parallel to the long edge of the stock

- **N-Up**: The pages are printed in sequential order with each page of the document appearing a specified number of times (n) on the same side of a sheet of paper. (This is also known as multiple imposition or tiling.) Each copy of the page is called a cell. There are multiple N-Up job types:
  - **2-Up**: each page is imaged twice on one side of a sheet of paper.
  - **2-Up Flip Left**: each page is imaged twice on one side of a sheet of paper with the left most image rotated 180 degrees.
  - **2-Up Flip Right**: each page is imaged twice on one side of a sheet of paper with the right most image rotated 180 degrees.
  - **3-Up**: each page is imaged three times on one side of a sheet of paper.
  - **3-Up Flip Left**: each page is imaged three times on one side of a sheet of paper with the left most image rotated 180 degrees.
  - **3-Up Flip Right**: each page is imaged three times on one side of a sheet of paper with the right most image rotated 180 degrees.
  - **4-Up**: each page is imaged four times on one side of a sheet of paper. There is no flip option for 4-Up.
  - **8-Up**: each page is imaged eight times on one side of a sheet of paper. There is no flip option for 8-Up.
  - **16-Up**: each page is imaged sixteen times on one side of a sheet of paper. There is no flip option for 16-Up.

- **Custom N-Up**: Allows the user to specify rows and columns in combination with Orientation, Sides Imaged, Margins, Paper Stock, and Autofit options. If Custom N-Up is not selected, Rows (maximum of 16), Columns (maximum of 16), and Pages on Sheet Side; Repeated; Sequential; Cut and Stack; Alternating are grayed out.

- **Maximum N-Up**: Given an input page size, calculates how many of those pages can be fit onto the sheet.
To configure Imposition settings - Crop Marks tab

1. In the Imposition Settings dialog, select the **Crop Marks** tab.
2. In the Crop mark box window, select from the following:
   - **Media Sheet** to define the crop margin relative to the sheet regardless of imposition job type. Range is 0 to remaining width of paper stock for Left and Right controls, and 0 to remaining height of paper stock for Top and Bottom controls.
   - **Media Cell** to define the crop margin relative to each cell on the sheet. Range is 0 to remaining width of cell for Left and Right controls, and 0 to remaining height of cell for Top and Bottom controls.
   - **Cell Cluster** to define the crop margin relative to each cell cluster on the sheet.
   - **PDF Crop Box** to define the boundary for the contents of the page when it is displayed or printed.
   - **PDF Trim Box** to define the finished dimensions of the page after trimming.
   - **PDF Bleed Box** to define the amount of extra area to image outside of the final page size defined by the PDF Trim Box.
   - **PDF Art Box** to define the area of the page where PDF content is placed.

   **NOTE**
   Bleed, Trim, and Art boxes must be smaller than or equal to the defined PDF Crop Box.

3. In the crop marks offsets area, specify offsets from the edges of the selected crop mark box:
   - **Top**, **Bottom**, **Left**, and **Right** to set the desired offsets.
   - **Uniform** to define all offsets; defined by the Top offset.
   - **Inward offset** to place offsets inside the perimeter of the selected box.
   - **Outward offset** to specify offsets outside the perimeter of the selected box.

   **NOTE**
   The Outward offset option is disabled for media sheet crop marks.

   **NOTE**
   Offsets must be all inward or all outward. Negative offset values are not allowed.

4. Select from the following Sheet Face options:
   - **Mark both sides** to place crop marks on the front and back of sheets. This is the default selection when a duplex job is defined.
   - **Mark front side only** to place crop marks on the front side of sheets. This is the default selection when a simplex job is defined.
   - **Mark back side only** to place crop marks on the back of sheets.

5. Select from the following Interval options:
   - **Mark every sheet** to apply crop marks to all sheets in the output.
   - **Mark first sheet** to apply crop marks to the first sheet in the output.
   - **Mark last sheet** to apply crop marks to the last sheet in the output.
   - **Mark every** to apply crop marks to every “n” sheet as defined by the user via the sheets spin box. Range: 1 to 500.
   - **Starting with the first sheet** to start crop marks on the first sheet when selected, or on sheet(s) N when not selected.

6. Select from the following Size and Color options:
   - **Crop mark length**: Defines the length of the crop mark from corner offset outward to the edge of the cell, sheet, or page.
- **Crop mark color**: Defines the color of the crop mark.
- **Crop mark bleed**: Defines the distance between the crop marks and the corner of the rectangle the crop marks identify. For example, if the bleed length is set to "0," the horizontal and vertical crop mark lines that form a corner would meet. Larger values space the lines away from each other.

**PDF Page Box Considerations**

- The PDF Boxes allow you to perform an “automated crop” by using a box defined within the PDF, rather than tailoring a workflow specific to an input document type. You can use the PDF boxes to meet specific job requirements—for example, the PDF Art Box can represent document fold lines.
- The PDF Media box option is not supported in imposition, but you can create an equivalent during imposition via the Paper Stock setting. The PDF Media Box describes the whole area of the PDF document including gutters and trim areas. All other box definitions are sub-areas of the media box. It is not changeable by the user and is established when the PDF document is created.
- The Trim, Bleed and Art boxes must be smaller than the Crop Box. Box edges defined in the input document that are beyond the corresponding crop box edge are limited to the crop box edge during imposition.
- You can select which of the four supported PDF boxes to be used for positioning and autofit. Note that the PDF page is not clipped by the selected box unless margins are applied. Enabling autofit will cause the selected box to scale to fit the sheet cell it is being imposed into. PDF page data may bleed outside of the selected box into any sheet cell waste-space created during autofit scaling as long as it does not intrude into a neighboring imposition cell.
- Bleeds beyond the selected PDF box are disabled if any margins are applied.
- From the perspective of downstream workflow components, page size in the output document is the selected paper stock upon which the input document is imposed.
- You can make PDF box definitions unique on a page-by-page basis. Asymmetric imposition results occur if these definitions are not consistent throughout the document.
Maximum N-Up considerations

- Maximum N-up might benefit workflows where resource utilization is of a higher-priority than layout scheme.
- The N-up cell count is based on the size of the configured imposition reference box (PDF box) on the first page of the document only. If the selected reference box is not of consistent size throughout the input document, unusual clipping or seemingly asymmetric output will result.
- The application of gutters when this feature is used with imposition cell clustering will be accounted for in the layout computations and therefore, total N-up cells maybe be reduced as a result.
- The use of gutters in conjunction with imposition cell clustering may result in a reduction of total N-up cells.
- If the input page size reference is larger than the selected stock size, a Standard non-Autofit job style output results.
- If the number of pages in the input document cannot fill all the cells for the N-up, a partial N-up output results.
- Autofit functionality is not available with this configuration.
- The maximum number of rows and/or columns is limited to 16 in each direction.
- Maximum N-Up cannot be used to automatically configure the printed stock.

Automatic stock type considerations

The Automatic Paper Stock type option selects or creates a custom stock configuration that completely contains the cells of a specified job type. This option is useful for "intermediate" imposition steps in multi-imposition workflows.

**Imposition result vs. print result:** The automatic stock feature produces an imposition result - not a print result. The stock size defined by the code logic cannot be communicated to the print component logic.

**Stock dimensions based on reference box:** The stock dimensions are based on the resulting cell layout of the job type and the size of the configured imposition reference box (PDF box) on the first page of the input document only. If the reference box is inconsistent in size throughout the input document, unusual clipping or unexpected border-gutter space may result.

**Regional prioritization:** If you prioritize the automatic selection to one of the standard named stock configurations, you may further constrain the standard stock type used by regionality.

For each of the options, If no stock among the set is large enough to encompass the layout area, a Custom type is created.

- If a standard stock type is identified, orientation is dynamically configured to choose a stock orientation that minimizes post-imposition waste areas.
- If the subsequent layout exceeds the size of an identifiable standard stock type, a Custom stock type that encompasses the layout area is created.
- If you choose not to prioritize among standard stock types, a stock type that wholly encompasses the layout area is created. This might equate dimensionally to a standard named stock type.

**Maximum size:** The maximum size for an automatic stock is 60" in either direction.

**Both Maximum N-up and Automatic stock selected:** If you select both Maximum N-up and Automatic stock configurations, the result is a Standard, non-Autofit job style output as the maximum number of cells that can be fit onto a undefined area is always equal to one.
Configuring Preps settings

If Preps is installed on the computer, the initial Imposition Settings dialog allows you to choose one of the following:

- Specify imposition settings: Displays the Imposition Settings dialog, in which you can establish the desired imposition settings.
- Use Preps job file: Displays the Preps Imposition Settings dialog, in which you can select Preps job files.

In Preps, job files are layout masters used in conjunction with a set of pages to produce imposed jobs. The Administrator establishes the selectable job files from the Preps software. The Preps dialog settings allow you to select from a list of Preps imposition job files.

Limitations for Imposition and Preps

- If a workflow with branching contains an Impose node in more than one branch, the node in only one branch receives job ticket information. For Conditional branches, the top branch receives job ticket information. For Fail branches, the main branch receives job ticket information.
- JDF imposition parameters cannot be translated into Preps imposition.
- Non-printable content such as bookmarks, sounds, movies, logical structure, hyperlinks, and article threads will not be preserved by the Preps imposition component.
- When you submit a job to a Process Manager workflow that includes Imposition with Preps, ensure that the Preps application is not running if the license is only for one instance of Preps.

About Review

The Review process allows you to view the PDF file in its current state and approve or fail the document. When a workflow is stopped at a Review step, in Workflow Job Manager you can also perform the following functions, depending on the makeup of the workflow:

- View and edit the file using Adobe Acrobat Professional.
- Print a hardcopy proof.
- Modify the copy count.
- Change process settings and resubmit the job.
Configuring Notify settings

The Notify process provides job status notification via e-mail. Examples of uses include:
- Job start notification: Notifies the operator that the job is beginning.
- Preflight fail notification: Notifies the operator when preflight fails, which allows immediate intervention.
- Job finish notification: Notifies the operator that the job is completed.

Email attachments

If you choose to attach job files, the recipient will be able to remotely proof, validate, or repair the PDF file. Compound document types, such as RDOs, cannot be attached. The email notification will fail if the file exceeds the limitation.

You can add a watermark to the email attachment.

NOTE
Email notification requires configuration of the SMTP server via the Workflow Builder application.

1. To access the Notification Settings dialog, double-click the Notification step in a workflow.

NOTE
In the FreeFlow Administration Tool, the administrator can modify the user’s contact information and email address. When the user logs in to Process Manager, the To and From fields in the Notification Settings dialog are automatically set to that email address.

2. Select from the following:
   - Use the job submitter’s email address: Picks up the job submitter’s email address as configured in the FreeFlow Administration Tool and uses it as the sender address for the notification.
   - Use the following address: Allows you to enter an email address. By default, the text field displays the email address of the logged-in user. When submitting a job via a hot folder, the user set up in the hot folder dialog is the submitting user, and his/her email is used in the notification when that option is selected.

3. In the To text box, type the recipient(s) e-mail address(s). Be sure to separate multiple addresses with semicolons.

4. If desired, select Send copy of notification to sender to send a copy to the sender.

5. Select Enter recipient address during job processing to gray out and clear the “To:” field and hold the job when the Notify step is reached. You must then enter recipient addresses before continuing with the job.

6. Select Enable Custom Subject Line to enter a text string of your choice in the text box, or to select which of the following options to include in the subject line:
   - Append Job ID
   - Append Job Name
   - Append Job Status

7. Select which of the following options to include in the body of the mail note:
   - Job ID
   - Job Name
   - Job Status
   - Job Submit Date
   - Preflight Results
   - Job Files
   - Low Res version
8. To include a watermark on the job file, see Setting up a watermark in an email attachment.

   **NOTE**
   Job files will include the PDF files at this stage of the processing.

   **NOTE**
   Attached Job files can be viewed, but not printed or edited.

   **NOTE**
   All options, except Preflight Results and Job Files, are selected by default. When Job Files is selected, Send low resolution image is selected by default.

9. Type a message with a maximum of 256 characters.

10. Select **Allow job to continue even if no notification is sent** to ensure that the job does not fail if the email notification is not sent due to lack of recipient address or other failure.

   **NOTE**
   When selected, along with Enter recipient address during job processing, the job will stop at Notify, but it will continue as successfully completed when you select Resume, if you do not enter a recipient.

### Setting up a watermark in an email attachment

With the Unlimited User Conversion License you can add a fully customizable security watermark to email attachments.

If properly licensed, you can disable the security watermark by clearing the Specify the text to be applied as watermark on PDF email attachments check box.

Without the Unlimited User Conversion License, the attachment watermark defaults to PROOF. You can append customized text to PROOF. The Unlimited User Conversion restrictions apply when submitted via hot folders and not via Workflow Submission Client.

The watermark does not appear on the job document.

In Workflow Builder, select **Options > Email Attachment Watermark Setup** to change the watermark settings.

### Configuring Print settings

The Print settings dialog allows you to print PDF, VPC, or RDO (for reprint) files to a specified production print queue using a specified job ticket. A job ticket stores all your document information for printing to a production printer.

Using the Print settings dialog, you can:

- Open a job ticket from a Windows file or document repository.

  **NOTE**
  Job tickets can be applied only to workflows that contain the Print task.

- Access the Job Setup dialog for production printing and make the desired changes.

**If the printer is not available on a standalone client**

If you attempt to open the Print Settings dialog on a Workflow Job Manager or Workflow Submission Client standalone client and an error message states that the current printer is not available, you will need to obtain the list of registered printers.

On the standalone client, select **Start > Programs > Registered Print List Locator**. In the Registered Print List Locator dialog, select Remote and enter the computer address of the Printer Administration server.
To configure Print settings

1. To access the Print Settings dialog, double-click the Print step in a workflow.
2. In the Select printers that submitters can choose from text box, select the desired printers. The printers will populate the Select the default printer drop box.

   NOTE
   Printers are added to the list in the Select printers that submitters can choose from text box via the Printer Registration application.

3. In the Default printer drop box, select the appropriate default printer.
4. Select Job Setup to open the Job Setup dialog from production printing. Make the desired selections. Options vary depending on the selected printer. Refer to the job setup help for additional information.

Fault handling for Print

When printing fails in a workflow without a Fail node, Process Manager will retry printing. By default, the workflow will retry printing for up to 30 minutes before failing. Workflows waiting to retry printing are not counted in the number of active tasks.

Configuring Save settings

The Save process allows you to copy all supported file types to a specified location within a document repository or Windows File system. Dialog options include:

   Save job ticket information: Allows you to save the job ticket (XPIF) with the PDF file for reprinting purposes.
Saving a job ticket with the PDF file for reprinting

NOTE
To save the job ticket, a Print process must be included in the workflow prior to the Save process.

The Save the job ticket option in the Save Settings dialog allows you to save the job ticket (.xpf) information with the PDF file for reprinting purposes. An .xpf job ticket is automatically saved in the same folder as the PDF. The last settings that were used to successfully process the Print node are saved.

To associate the .xpf job ticket with the file to be processed, save an .xpf job ticket using the following naming convention:

- file name. file extension.xpf, for example:
  - PDF file name = brochure.pdf
  - .xpf file name = brochure.pdf.xpf

NOTE
.xpf job tickets must be in the same directory as the files to be processed. If you move or rename the job files, you must also move and rename the associated .xpf job ticket.

Using Workflow Submission Client to reprint
Submit only the saved PDF file to the reprint workflow. Process Manager automatically picks up the associated job ticket and applies it to all print nodes in the workflow.

Using a hot folder to reprint
You must submit the saved PDF file and the associated .xpf file to the reprint workflow. The files are dropped into the Waiting for Job Ticket folder inside the hot folder. Process Manager applies the saved job ticket to all print nodes in the workflow.

Configuring JDF Export settings
Job Definition Format (JDF) is a universal job ticket format. JDF capabilities enable Process Manager to use existing JDF job tickets and to create new JDF job tickets.

JDF job tickets are submitted via a hot folder. The hot folder is monitored by the Process Manager application, which looks for JDF tickets and submits them to the workflow.

JDF Export settings allow you to designate a JDF Export file destination. The filename cannot exceed 80 characters, and the directory path cannot exceed 160 characters.

The output file of a JDF export task can be reimported and rerun by dropping it into a hot folder associated with an appropriate workflow. The files associated with the JDF must be in the same location as the original job.

1. To access the JDF Export Settings dialog, double-click the JDF Export step in a workflow.
2. In the Export Options section, select from the following:

   - **Export the Process Manager workflow job as a new JDF** to export the supported workflow nodes as JDF.
   - **Export the JDF submitted with any modifications made by external processes** to export the submitted JDF. If external processes are present in the workflow, the exported JDF will contain the changes made by the external process nodes.
About JDF Export options

If you export the workflow JDF by selecting Export the Process Manager workflow job as a new JDF the JDF Export node functions as it always has.

If you submit a JDF file to a workflow that contains a JDF Export node:

- If the job does not encounter an External Process node, the JDF Export node exports a copy of the submitted JDF file.
- If the job encounters an External Process node, and you select the option to send the JDF and an XML file by selecting Export the JDF submitted with any modifications made by external processes, the JDF Export node exports a copy of the JDF file returned by the External Process node.
- If the job encounters an External Process node, and you do not select the option to send the JDF and an XML by selecting Export the Process Manager workflow job as a new JDF, the JDF Export node exports a copy of the submitted JDF file.
- If you select to export the submitted JDF file and a JDF file was not submitted to the workflow, the JDF Export node will fail.
- In all cases that a JDF file is exported, the exported JDF file is updated to reference the PDF file being exported.

When exporting a JDF file, the margin information is read from the JDF file. Therefore, if the left and right margin values are different in JDF export, the JDF adds the values and divides the total by two to make the values the same for import. The same applies for the top and bottom margin.

Fault handling for JDF Export

Errors are logged in the Windows Event log and display in the Job Manager status display area. The following errors cause the export operation to fail:

- The workflow contains a non-supported task.
- The workflow does not contain all the tasks it needs.

JDF and Color Manage

When submitting a JDF ticket to a workflow, only the color profile being used by the JDF ticket is visible in the Color settings in the Optimize node. Normally, when submitting jobs, all default options - the set of installed CMYK color profiles, and the srgb color space profile.icm - are visible.

**NOTE**

To enable color management, the Optimize node settings should be set as follows: in the General tab, de-select the check box for Create a document that complies with PDF/X standards. In the Color tab, in the Change all colors in document drop box, select Manage Color profiles.

**NOTE**

When the JDF ticket specifies a color profile, the color profile must be installed on the Process Manager Server or the job will fail.
Limitations when creating JDF Tickets in Adobe Acrobat Professional

To create a JDF ticket in Adobe Acrobat Professional for submission to FreeFlow Process Manager, for the JDF ticket to be handled properly, you must specify the number of pages in the document or the pages in the range.

To specify the number of pages

1. Select Start > Programs > Adobe Acrobat Professional.
2. In Adobe Acrobat Professional, select Advanced > Print Production > JDF Job Definitions.
4. In the Create New Job Definition dialog, browse to the desired selection and select Save. The file path displays in the Filename text box.
5. Select Create and Edit.
6. In the Edit JDF Job Definitions dialog, select Add Section.
7. In the Number of Pages section, enter the appropriate value.
8. Select OK.
9. Close the dialog.

To specify the pages in the range

1. Select Start > Programs > Adobe Acrobat Professional.
2. In Adobe Acrobat Professional, select Advanced > Print Production > JDF Job Definitions.
4. In the Create New Job Definition dialog, browse to the desired selection and select Save. The file path displays in the Filename text box.
5. Select Create and Edit.
6. In the Edit JDF Job Definitions dialog, select Add Section.
7. Select Add File.
8. In the Pages to use in Document section, enter a value for Pages in the Range.
9. Select OK.
10. Close the dialog.
Creating conditional branches

Conditional branching provides an added level of logic to a workflow, allowing it to examine the properties of submitted jobs, and then act accordingly without human intervention.

You can add one or more conditional branches to a workflow, each with one or more user-designated conditions that specify the desired attributes or properties of the submitted jobs. During execution, the condition(s) of each branch are compared with the information retrieved from the job. The first branch whose conditions or specifications “match” the properties retrieved from the job will be taken.

Each Conditional node can include up to 12 branches; each branch can include up to 12 conditions that must be satisfied.

You can specify two main categories of conditions:

• PDF-related conditions
• JDF ticket-related conditions

The branches of a Conditional node can be merged into a common workflow. Conditional branching provides an alternative to using Preflight as a means to filter and route jobs.

Guidelines for successful conditional branching

**Number of branches and conditions:** A Conditional node is limited to 12 outbound branches. Each branch can have up to 12 conditions.

**Nested branching:** Nesting occurs when a Conditional node directly follows a branch of another Conditional node. You can have up to two nested Conditional nodes.

**Execution sequence:** Branches are checked from the top branch to the bottom. The top branch conditions are checked first. If the conditions are satisfied, the top branch is taken. Otherwise, the second branch is checked, and so on. Branch order is defined in the Conditional Branch Settings dialog.

**Fail branches:** A Fail branch can be added to Conditional node. The Fail branch is not considered part of the Conditional Branch and is not displayed in the Conditional Branch Settings dialog.

**JDF Export:** Workflows with a Conditional Branch do not support JDF Export.

**Conditions from more than one category:** Different categories can be combined in one branch. For example, a branch can contain both PDF and JDF conditions.

**Modifying conditional branches in Workflow Submission Client:** You can add or remove conditions for a Conditional branch. You cannot do the following:

• Add or remove branches.
• Rearrange the order of the branches.
• Change branch names.

**Failed status:** A job will fail if:

• None of the conditional branches match the job and there is no pass-through branch.
• If the necessary information is not available to evaluate a condition. For example, if a PDF file is submitted to a branch with a PDF bleedbox condition and bleedbox is not defined in the PDF file, the job will fail.
Adding and configuring branch conditions

You can place a Conditional process anywhere in a workflow that a decision must be made. Node configuration is performed via the Branch Conditions Branch Name dialog, where you add branches and define or edit their conditions. Twelve branches are allowed per Conditional node, 12 conditions are allowed per Conditional branch.

1. In Workflow Builder, drag and drop a Conditional process into the workflow. The Conditional Branch Settings dialog automatically opens.

2. Select **New Branch**.

3. In the Branch Conditions dialog, enter a name in the **Branch** name text box. The name display in the dialog title later, when you open the dialog to view or edit conditions. The options in the **This branch will only accept** area ensure that only the desired file types are examined by the branch. For example, if you select PDF format files and you submit a .doc file to the workflow, the system does not attempt to apply PDF-only conditions to the file. The branch is skipped; no errors are generated.

4. In the **This branch will only accept** area, select from the following:
   - **PDF format files**: To enable the addition of PDF conditions.
   - **Documents submitted with JDF job tickets**: To enable the branch to accept only files submitted with JDF job tickets and to enable the addition of JDF-specific conditions.
   - Select both options.
   - Select neither option.

5. In the **Conditions that must be met** drop box, select from the following:
   - **Any**: To establish that one or more conditions must be met for the branch to be considered a match.
   - **All**: To establish that all conditions must be met for the branch to be considered a match.

6. In the **Conditions to add** area, select a condition.

   **NOTE**
   Refer to the *Conditional branch conditions* on page 3-34 table for a description of the conditions and their qualifiers. Qualifiers vary based on the selected condition, for example, “PDF format files.”

7. Select the desired qualifiers for the condition.

8. After all fields are configured, select **Add** to add the condition and display it in the Conditions List.

9. Add more conditions, if desired, up to 12 per branch.

A workflow process must follow a conditional branch or the workflow cannot be saved.
## Conditional branch conditions

<table>
<thead>
<tr>
<th>Available For</th>
<th>Condition</th>
<th>1st Qualifier</th>
<th>2nd Qualifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>PDF Only</td>
<td>Number of Impressions</td>
<td>Equal to</td>
<td>Make a numeric selection</td>
</tr>
<tr>
<td></td>
<td>*Number of Pages</td>
<td>Not equal to</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mediabox Width</td>
<td>Less than or equal to</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mediabox Height</td>
<td>Greater than</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Trimbox Width</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Trimbox Height</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bleedbox Height</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Bleedbox Width</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Artbox Height</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Artbox Width</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cropbox Height</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cropbox Width</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Maximum Bleed Size*</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Author</td>
<td>Contains</td>
<td></td>
<td>Enter text</td>
</tr>
<tr>
<td>Title</td>
<td>Does not contain</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Subject</td>
<td>Starts with</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Keyword</td>
<td>Ends with</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Creator</td>
<td>Is equal to</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Producer</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Color or B&amp;W</td>
<td>All B&amp;W</td>
<td></td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Containing any grayscale or color</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>images</td>
<td></td>
<td></td>
</tr>
<tr>
<td>First Page Orientation</td>
<td>Portrait</td>
<td></td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Landscape</td>
<td></td>
<td></td>
</tr>
<tr>
<td>All Page Orientations</td>
<td>Same</td>
<td></td>
<td>YesNo</td>
</tr>
<tr>
<td></td>
<td>All Page Sizes Equal</td>
<td></td>
<td></td>
</tr>
<tr>
<td>JDF Job Ticket Only</td>
<td>Customer Billing</td>
<td>Contains</td>
<td>Enter text</td>
</tr>
<tr>
<td></td>
<td>CodeCustomer ID</td>
<td>Does not contain</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Customer Job Name</td>
<td>Starts with</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Customer Order ID</td>
<td>Ends with</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Is equal to</td>
<td></td>
</tr>
<tr>
<td>Always</td>
<td>Job name File Extension</td>
<td>Contains</td>
<td>Enter text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Does not contain</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Starts with</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Ends with</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Is equal to</td>
<td></td>
</tr>
</tbody>
</table>
Condition Definitions

For a list of available conditions and their qualifiers, see Conditions to Add.

**Number of copies**
The value that a Conditional Branching node uses for the “number of copies” condition is the copy count value associated with the job at the time of Conditional branching execution.

A copy count value is associated with a job through the following ways:
- If an XPIF ticket was submitted with the Job (for example as part of an RDO) and it has a copy count value, that value will be considered the Job copy count value.
- If a JDF ticket was submitted with the job and it has a copy count value, that value will be considered the Job copy count value.
- If the user sets a value for the *Quantity* attribute in FreeFlow Process Manager MAX, Manifest Automation from Xerox, that value is considered the Job copy count value.
- If the user sets a copy count value during Review in Job Manager, that value is considered the Job Copy count value from that point on.
- If *Imposition affects copy count switch* is set in the WorkFlow Builder, and the copy count value has been modified by Imposition, once the job reaches the Conditional branching node, the modified value is considered the Job copy count value for Conditional Branching.
- If the job has no associated copy count value, Conditional branching fails when it examines the number of copies condition. A message saying no copy count value is available displays.

**NOTE**
Printer copy count value is not the same as Job copy count value. The *number of copies* condition of Conditional branching works independently of the Print nodes in a workflow and the copy count values, if any, set during workflow design.

**Number of impressions**
This is the number of copies multiplied by number of pages in PDF file.

**Maximum bleed size**
If a Trim Box and a Bleed Box are defined, and the Trim Box is contained within the Bleed Box, then the Bleed size is the four offsets from the four sides of the Bleed Box to the four sides of the Trim Box, and the Maximum Bleed size is the greatest of the four.
Linking conditional branches

The branches of a Conditional node can be merged into a common workflow once they have been processed. Follow these rules:

- If a link is used, all of the branches of a Conditional node must merge.
- The branches of one conditional node cannot merge with branches of another Conditional node.

1. Right-click the Conditional node to which you wish to add a link.
2. Select Create Common Links. Links display at the end of the branches for that node. Another link displays beneath the first workflow, creating a common workflow.
3. Drag and drop the necessary workflow processes into the common workflow to continue processing the job.

About external process settings

Process Manager allows you to configure up to 5 external processes to use as process options in Workflow Builder.

External Processes are indicated either by a plus symbol or, if you choose an existing process icon, by a plus symbol overlay.

1. Set up the profiles for each external process node defined in Workflow Builder.
2. In the Process Name Settings window choose which profiles can be selected.
3. Select the default profile.

About the Copy Count Divisor

You can enable the system to adjust the copy count to maintain the original quantity intent for workflows that contain multiple-up impositions. The value is changed to output the original quantity of the original document given that the imposition node has changed the PDF document to contain multiple instances of the original document.

In the Job Manager Copy Count and the Print node Job Setup dialogs, the quantity value is modified when you:

- Process the job through a Xerox imposition node (not Preps) that is multi-up repeated.
- Enable the Copy Count Divisor switch.
- Use Print nodes that do not have Always use these settings selected.

Example: If the original document is 1 page, the original quantity is 100 copies, and the imposition is 4-up repeated, then the post imposition copy count quantity will be 25, since each copy of the imposed document now contains 4 copies of the original document.

NOTE

Multiple imposition nodes will divide the copy count when each node executes.

If there is a JDF Export node in the workflow, the JDF ticket created through the JDF export node does not include the modified copy count.
About the Copy Count Divisor and Review nodes

Review nodes and the Copy Count Divisor in Imposition nodes interact as follows:

- Review nodes that follow an Imposition node that changes the copy count will have two values for quantity:
  - Quantity (original document)
  - Quantity (imposed document)
- Imposition nodes that follow a Review node will use the quantity defined in the Review node to calculate updated quantities using the Copy Count Divisor.
- If there is an Imposition node that uses the copy count between a Review node and a Print node the quantity defined within a Print node will not be used by the Review node.

To enable the Copy Count Divisor

1. In Workflow Builder, select Options > Processes to display the Processes dialog.
2. Select the Impose process, then select Settings to open the Impose Process Settings dialog.
3. Mark the check box for Imposition affects copy count.

Setting up repository credentials

Repository credentials are used in all transactions that require logging into a repository in FreeFlow Process Manager. This includes:

- Add Repository File in Workflow Submission Client.
- Browse Repository in the Save and JDF export nodes.
- Hot folders - When you create a hot folder, you must specify the “Submitting user” whose repository credentials are associated with the hot folder: either a member of the Process Manager Administrator group or a member of the Operators group. This informs the system whose repository credentials to use when a job must access a repository during hot folder submission.
- Resubmit operation in Workflow Job Manager.

Prior to performing operations that require repository access, you must set up and save your repository credentials in FreeFlow Process Manager. Credentials are set up and saved per user. Once a user has RMS credentials saved, all future repository transactions by that user through the Workflow Builder, Workflow Submission Client, or Workflow Job Manager use the same saved RMS credentials.

Before setting up repository credentials in FreeFlow Process Manager, you must have previously:

- Set up an account on the repository.
- Set up a link between the desired repository and FreeFlow Process Manager via the FreeFlow Administration Tool.
Advanced administration

Checking the status of a process

The Processes dialog lists information about each process, including:
- Name
- Status
- Concurrent count

**Take Offline/Set Online**: Allows you to change the offline or online status of a selected process; pauses jobs that reach the process. Available if no jobs are using the process. The option displays as a context menu option when you right-click a process.

**Settings**: Opens the Process Settings dialog.

1. In Workflow Builder, select **Options > Processes** to display the Processes dialog.
2. Select a process and select **Take Offline/Set Online** to change the status.
3. Close the Processes dialog.

Setting the number of concurrent processes and the copy count divisor

The Process Settings for the Process dialog allows you to:
- Select the number of concurrent processes. This sets the number of instances of a process that can be used to concurrently process jobs.
- Place the process online or offline.
- Turn the copy count divisor functionality on or off, available for Imposition only.

To set the number of concurrent processes

1. In Workflow Builder, select **Options > Processes** to display the Processes dialog.
2. Select a process, then select **Settings** to open the Process Settings for Process dialog.
3. Select the number of concurrent processes, from 1-4.
4. As appropriate, select or clear the check box to place the process online.
5. Select **OK** to accept the changes and close the Process Settings for Process dialog.

About hot folders

The hot folder function allows you to designate one or more folders on your system to be monitored, at set intervals, by the Process Manager application. When a file is detected in a hot folder, it is automatically submitted to the workflow associated with that hot folder.

Hot folders and Join

To process multiple files as a single joined file, you can:
- Use a Zip file to submit the jobs to a hot folder.
- Submit an .xml workflow with a folder to a dynamic workflow.
- Submit an .xml workflow with a Zip file to a dynamic workflow.

If you do not use these methods to submit multiple files to a hot folder, each file is processed as a separate job, even if the associated workflow contains a Join task.
Hot folders and Zip files

A hot folder can unzip a Zip file containing multiple PDFs or mixed file formats. The files are processed either as separate jobs or as a single job depending on the properties of the hot folder. Hot folders can process Zip files that contain all supported file types.

Hot folders support the following Zip file formats:
- Microsoft Windows Compressed (zipped) files packaged with Windows Server 2003
- WinZip 7.0 and 8.0 zipped files

Hot folders do not support:
- Folders inside a Zip file, except for .CON directories when a matching .rdo is present. Folders inside the Zip file are unzipped but are not submitted.
- Nested Zip files (a Zip file within a Zip file)
- Files for which, when unzipped, there is not enough room on the drive. If problems occur, the file is moved to the error folder.

The following limitations apply to InfoZip files:

<table>
<thead>
<tr>
<th>Item</th>
<th>Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of files</td>
<td>64 K</td>
</tr>
<tr>
<td>Uncompressed size of a single file</td>
<td>4 GB</td>
</tr>
<tr>
<td>Compressed size of a single file</td>
<td></td>
</tr>
<tr>
<td>Total size of archive</td>
<td>256 TB</td>
</tr>
<tr>
<td>Maximum path/filename length (characters)</td>
<td>DOS: 256</td>
</tr>
<tr>
<td></td>
<td>Unix: 1024</td>
</tr>
<tr>
<td></td>
<td>CD-ROM 8 level sub directory; depending on the type of file system</td>
</tr>
</tbody>
</table>
Hot folders and JDF

Job Definition Format (JDF) job tickets can be submitted via a hot folder. JDF is a universal job ticket format. JDF capabilities enable Process Manager to use existing JDF job tickets and to create new JDF job tickets. The JDF job ticket is created with a third party submission tool.

The following workflow processes support JDF:
- Optimize
- Convert
- Join
- Print
- Impose

The workflow processes currently supports the following types of JDF Intent:
- Business card
- Postcard
- Common paper sizes (letter, legal, A3, A4, tabloid, etc.)
- Saddle stitch, corner stitch, side stitch
- Soft cover

JDF files take precedence over other file types; they are processed first.

NOTE
By default, if the job has completed successfully, the JDF is placed in the hotfolder named “Output”. If the job fails, it will be placed in a hotfolder named “Error”.

Hot folders and error checking

Non-supported file types are moved to an Unsupported Files folder within the hot folder. It is the user’s responsibility to manually delete these files from the folder.

Hot folders: supported files

The hot folder supports the same files that are supported through the Workflow Submission Client: Adobe Illustrator CS, Adobe InDesign CS, Adobe Photoshop (currently supported version), Bitmap, JPG, JPEG, Microsoft Office 2007, Microsoft Publisher (Excel, PowerPoint, and Word), PDF, RDO, TIFF, TIFF-IT, VPC, QXD, EPS and PS.

Hot folders and read-only files

Read-only files are not picked up by the hot folder.

Hot folders on mapped or shared drives and resources

To work properly, full access for the hot folder must be granted to XDL_ADMIN, particularly if the hot folder is on a mapped drive. XDL_ADMIN passwords must match client and server.
Limitations when setting up directories as input/output hot folders for more than one feature

Within Process Manager, users can set up directories as input/output hot folders for Process Manager Hot Folders (for job submission), QuarkXPress file conversion, and Third party external processes. When setting up a directory as an input or output hot folder, make sure that it is not being used as a hot folder for either of the other two features, by visiting their corresponding dialogs.

The system does not currently perform conflict checking across these different features.

To manage hot folders

You can use the Hot Folders dialog to manage hot folders independently of workflows.

1. Select Options > Hot Folders, or right-click a workflow listed in the Workflows dialog.
2. Perform the necessary actions.
3. Close the Hot Folders dialog.

Managing hot folders

The Hot Folders dialog options include:

**New**: Opens the New Hot Folder dialog.

**Modify**: Opens the Hot Folder dialog for the selected hot folder.

**Delete**: Deletes the selected hot folder. Also available as a context menu by right-clicking an item listed in the Hot Folders window.

**Pause**: When selected, the hot folder mechanism processes all files currently in the selected hot folder. It stops scanning for new files after all current files are processed. The button toggles between the pause and resume states.

**Resume**: When selected, the hot folder mechanism resumes monitoring the selected hot folder at the defined interval. The button toggles between the pause and resume states.

**Settings**: Opens the Hot Folder System Settings dialog.

**Stop/Start**: Allows you to stop/start the hot folder services, effectively pausing/resuming all hot folders at once.

**Status line**: (bottom of screen) Lists the total number of hot folders, the Processing or Paused status, and the monitoring interval.
Setting up or modifying a hot folder

The New Hot Folder or Hot Folder (for modifying a hot folder) dialogs contain the following options:

**Hot folder location**: Lists the full file location path for the hot folder associated with the selected workflow.

**Browse**: Opens a common browse folder dialog and allows you to select or create a folder in the system.

**Target Workflow**: Lists all workflows in the system. The list reflects the sort order of the Workflows dialog.

Submitted with documents Target Workflow: This option, in the Target Workflow drop down menu, supports the hot folder submission of .xml workflows that have been exported from the Workflow Builder application as well as hot folder submission of MAX order jacket files.

**Submitting User**: Allows you to specify the user whose repository credentials will be associated with the hot folder: either a member of the Process Manager Administrator group or a member of the Operators group. This informs the system whose credentials to use when a job must access a repository during hot folder submission.

**NOTE**

If the submitting user does not have saved repository credentials, the job will fail if attempting to access a repository during hot folder submission.

**Submission Options**: Specifies whether to always submit multiple files as separate jobs, always as a single job, or as a single job only when the selected workflow contains a Join process.

The following options are available when Enable file clustering, Enable hot folder scheduling, and Set scheduled times for hot folders individually are selected in the Hot Folder System Settings dialog:

**Enable file clustering for this hot folder**: Enables the system to wait until the specified number of files are placed in the hot folder before processing them.

**Number of files**: Allows you to specify the minimum number of files before processing is initiated on the set. The default is 2; the maximum is 100.

**Enable scheduling for this hot folder**: Enables the scheduling functions:

- **Time of Day**: Allows you to specify the times during the day that you want the hot folder scanned. The default is 12:00 AM.
- **Add**: Available if **Enable scheduling for this hot folder** is selected. Adds the selected time of day to the list. If you try to add a time more than once, the Time Already Added message displays.
- **Scheduled times**: Available if **Enable scheduling for this hot folder** is selected. Lists the times during a day when the hot folder system scans the hot folder for files. A maximum of 10 polling times can be set.

**NOTE**

Interval between polling times cannot be smaller than the hot folder scan interval.

- **Remove**: Removes the select time from the list.

**OK**: Closes the dialog and saves the settings.

**Cancel**: Closes the dialog and does not save the settings.

**Waiting for Job Ticket folder**: Each hot folder contains a Waiting for Job Ticket folder. When submitting .xfp job tickets with a job file, both items must be placed into this folder.
Deleting a hot folder

This option is available when a hot folder is not paused.

1. Workflow Builder, select Options > Hot Folders.
2. Select a hot folder.
3. Select Delete, and then select Yes to confirm the deletion.
4. Close the Hot Folders window.

Pausing and resuming hot folder monitoring

The hot folder monitoring function can be paused in order to perform any necessary actions.

Configuring the hot folder system settings

The Hot Folder System Settings dialog allows you to set the scan interval, to enable file clustering, and to select between scheduling all hot folders for the same times of day or scheduling hot folders individually. It contains the following options:

Scan Interval: Sets the time between system scans of the hot folders for new files. The default interval is 10 seconds. The available range is 10 - 100 seconds. Workflows are submitted as files are found, unless clustering or scheduling is enabled.

Enable automatic file submission rate adjustment: Limits the submission of jobs from the hot folder when the processing capacity has been reached. Jobs may stay in the hot folder until previously submitted jobs have completed processing.

Enable file clustering: Enables the system to wait until the specified number of files are placed in the hot folder before processing them. The number is set on a per hot folder basis. If selected, the scan interval is set to 10 seconds and grayed out.

Enable hot folder scheduling: Enables the scheduling function.

NOTE
The clustering and scheduling options each have the ability to invoke the system to submit jobs independent of the other’s settings. If both clustering and scheduling are selected, then reaching either the clustering number of files or the scheduled time results in the submission of hot folder files as workflow jobs.

Set scheduled times for each hot folder individually: Allows you to specify times on a per hot folder basis.

Use the following scheduled times for all hot folders: Allows you to specify times for all hot folders.

Submitting a job to a hot folder

NOTE
Read-only files are not picked up by a hot folder.

1. Locate the desired file using Windows Explorer.
2. Use Windows Explorer to copy, move, paste, or drag and drop the file into the appropriate hot folder. The submission is automatically processed.

NOTE
If you move a file into a hot folder, you will not be able to retrieve it. The system automatically deletes the files from the hot folder. Copy the file if you need to retrieve it.
Submitting an RDO to a hot folder

**CAUTION**
If you are submitting an RDO to a hot folder, do not open, copy, move, delete, or rename an RDO document using Windows Explorer. You will corrupt the document.

To ensure better processing, when submitting RDOs to a hot folder, ensure that all contents inside the .CON are copied before copying the RDO file. If either the RDO or the .CON folder is missing from the hot folder, the file will not be processed. You must then manually delete the file from the hot folder.

**NOTE**
Successful submission of linked RDOs (an RDO containing a link to another RDO) and set labeling RDOs via Workflow Submission Client or hot folders cannot be assured.

1. Select **Start > Programs > Xerox FreeFlow Software > File**.
   
   **NOTE**
   To submit files to a hot folder, you can also use FreeFlow Web Services.

2. In File Manager, navigate to the appropriate RDO.
   
   **NOTE**
   In File Manager, the .CON file is not visible.

3. Right-click the file. In the context menu, select **Copy**.

4. In the Copy dialog, select **To**. Type the path to the desired hot folder, for example, `C:\Documents and Settings\Administrator\Desktop\RDO Hot Folder`.
   
   **NOTE**
   To display the path to the desired hot folder, select Options > Hot Folder and locate the hot folder path.

5. Select **OK**. The file is automatically submitted to the workflow associated with the hot folder.

Submitting a job ticket file (*.xpf) to a hot folder for reprinting

You can save an .xpf job ticket file with the PDF file for reprinting purposes by including a Save process in a workflow and selecting Save job ticket information in the Save Settings dialog.

**NOTE**
You can also create the job ticket with FreeFlow Print Manager Advanced Print Path.

To associate the .xpf job ticket file with the files to be picked up by the hot folder for processing, the .xpf job ticket file is automatically saved along with the PDF file, in the location designated in the Save settings, using the following naming conventions:

- File name: `<file name\>`<file ext\>.<file ext\>
- .xpf job ticket name: `<file name\>`<file ext\>xpfxpf.<file ext\>.xpf.xpf

When submitting files in a folder, the following naming conventions are used:

- Folder name: `<folder name\>`
- .xpf job ticket name: `<folder name\>`xpfxpf

**NOTE**
If you are not using a hot folder for submission, you can submit only the saved PDF to a reprint workflow. The .xpf associated with the file is automatically picked up and applied.
To submit an .xpf job ticket to a hot folder for reprinting

Waiting for Job Ticket folder: The job file and its associated .xpf must be placed in the Waiting for Job Ticket folder inside the hot folder.

When submitting subdirectories that contain job files associated with either .xpf files or .xml files, copy the directories first, and wait until all the files are copied before dropping the .xpf or .xml file into the hot folder.

When an .xpf job ticket is submitted to the hot folder’s Waiting for Job Ticket folder, with an associated job file, the job ticket is applied to all the print nodes in the workflow associated with the hot folder.

1. Locate the saved PDF. The PDF is in the location that was designated in the Save settings when the job was initially processed.

2. Locate the associated .xpf job ticket. The .xpf should be in the same location as the PDF, and the associated .xpf file name should match the PDF. For example:
   - File name = newsletter.pdf
   - Job ticket name = newsletter.pdf.xpf

3. Do one of the following:
   - For a file: Drag and drop or copy and paste the file to be processed and its associated .xpf into the Waiting for Job Ticket folder inside the hot folder.

   **NOTE**
   To reprint via Workflow Submission Client, submit only the saved PDF file to the reprint workflow. Process Manager automatically picks up the associated job ticket and applies it to all print nodes in the workflow.

   - For a folder: Drag and drop or copy and paste the folder to be processed and its associated .xpf into the Waiting for Job Ticket folder inside the hot folder. The .xpf file must be outside the folder to be processed. Each file in the folder is submitted separately as a single job with the job ticket.

4. The job prints using the job ticket.

   **NOTE**
   If the Print node has Always use these settings selected, the Print node setting overwrites the .xpf job ticket; otherwise, the .xpf job ticket overwrites the Print node settings.

Error conditions

- JDF is a “job ticket” and cannot be associated with an .xpf.
- Since RDO files already contain an internal job ticket, any associated .xpf file and the RDO are moved to the Unsupported Files folder.
- If the .xpf ticket is invalid, the .xpf file and the associated document are moved to the Unsupported Files folder.
- .xpf files without any associated document are ignored.
- .xpf files placed in the hot folder outside the Waiting for Job Ticket folder, are moved to the Unsupported Files folder.
Imposition handling with .xpf tickets

- If the .xpf ticket contains Imposition information and the workflow contains Imposition nodes, imposition information is applied to the first imposition node automatically.
- If the Imposition node has Always use these settings selected, the Imposition node settings overwrite the .xpf ticket; otherwise, the .xpf ticket overwrites the Imposition node settings.
- If the .xpf ticket contains any imposition information and the workflow does not contain any imposition node, the imposition information is ignored.

Submitting .xml workflow files to a hot folder

This feature allows you to submit exported workflow(s) in xml format, with either a file or a folder containing several files, to a hot folder.

The .xml file name must match the name of its associated file or folder to be picked up for hot folder processing.

**Dynamic workflows:** Files are submitted to a dynamically created “Submitted with documents” workflow, which is available in the target workflow drop box. Each time a new job is submitted to a dynamic workflow, a new workflow, with a unique workflow Id, is created. Dynamic workflows are not visible and are deleted from the Process Manager database when jobs using the workflows are deleted. Data from the dynamically created workflow is available for accounting information, but the “Submitted with documents” workflow does not contain any accounting info.

**Matching file names:** The .xml must be named `<filename>.<filename>.<file ext>.xml` to be associated with `<filename>.<file ext>`.

**Matching folder names:** The .xml must be named `<folder name>.xml` to be associated with `<folder name>`.

When submitting a folder to a hot folder, the .xml must be outside the submitted folder. Each file in the folder is submitted as a single job to each of the workflows in the .xml file.

To submit .xml workflow files to a hot folder

1. Create the desired workflow in Workflow Builder.
2. To create an .xml workflow file, export the workflow. Ensure that the .xml file name matches the name of the PDF file or the folder that you will be submitting to the workflow. If the workflow name does not match, rename it.

   **NOTE**
   - The workflow does not need to exist or be enabled in Workflow Builder to process the .xml.

3. In Workflow Builder, set up a hot folder using the target workflow **Submitted with documents**.
4. Using Windows Explorer, locate the .xml file and the matching file or folder you will be submitting.
5. Copy, move, paste, or drag and drop the .xml and its matching file or folder into the Submitted with documents hot folder.

   **NOTE**
   - If you are submitting a folder to a hot folder, ensure the .xml is outside the folder.
6. The submission is automatically processed.
Error conditions for dynamic workflows

- If a workflow contains a print node and a printer is not available, the job will fail.
- The following dynamic workflow file names are restricted; files will be moved to the Unsupported Files folder:
  - Unsupported Files folder.xml
  - Waiting for Job Ticket. xml
  - Manifest Status.xml

Submitting .vpc files to a hot folder

VPC files can be submitted only to workflows containing Review, Print, Save, Convert and Impose processes. Jobs submitted to workflows with processes other than these will fail.

VPC file limitations

- **Review**: Identification of the number of document sets within a VI Container is limited to database mode VIPP and PPML print files. Selection of a set, or a range of sets is limited to database mode VIPP print files. Viewing and editing VI containers via Adobe Acrobat requires conversion to PDF.
- **Convert**: Supports conversion of VI Containers with VIPP print files. Once the VI container is converted to PDF, the VI job remains as a PDF file throughout the remainder of the workflow.
- **Impose**: Supports VI containers converted to PDF
- **Preflight**: Supports VI containers converted to PDF. Validates that all required elements of the VI Container Job are contained in the VI Container and that the container is a valid VI container. If validation is successful the job will pass; otherwise, it will fail.
- **Print**: Limited to DocuSP DFEs.

Using third party external processes

Administrators can add up to 5 external processes from third party software. Select Options > External Processes to configure external processes. Each process can have a combined maximum of 10 folder-based and CLI profiles.

**Submitting to third party processes via hot folders**: Folder-based profiles allow the submission of jobs from third party processes via hot folders. During setup, each profile is assigned to a process input hot folder, a process output hot folder, and an optional errors hot folder.

For folder-based profiles, third party software must be installed and running on the Process Manager server or a third party machine in order to use external processes in a workflow. When the Process Manager workflow reaches the third party step, the job is retrieved by the third party application, processed, and then returned to the Process Manager workflow to complete any remaining workflow steps.

**Running third party scripts**: CLI profiles are available for input via command line interfaces and scripts. During setup, each profile is assigned a file name and location for the script, optional parameters, and locations for the input and output files.

Once an external process is set up, it displays in Workflow Process Options area, where the operator can drag it into a workflow and select the desired profile.
Setting up external processes

The External Processes Setup dialog allows you to set up or edit process icons, names, and profiles, or to delete a profile from the Process Profiles list. It includes the following options:

**Process icon:** Allows you to select an icon.

**Process name:** Allows you to enter a name for the external process.

**Process profiles:** Lists, by name, the existing profiles up to a maximum of 10. Listed profiles are selectable.

**Add folder profile:** Available if 9 or fewer profiles are configured. Opens the Folder Profile Setup dialog, which allows you to enter a new configuration. If there are ten profiles configured when Add is selected, the Maximum Allowed error dialog displays.

**Add CLI profile:** Opens the CLI Profile Setup dialog which allows you to enter a new configuration.

**Edit:** Opens the setup dialog for the selected profile.

**Delete:** Deletes the selected profile with a confirmation dialog.

Guidelines for using third party external processes

- For folder-based profiles, the third party software must support input and output via hot folders.
- In addition to PDFs, External Process nodes accommodate all supported file types, except RDOs.
- The third party application must accept and send out the same types of files. For example, PDF in must result in PDF out. The function of the third party software cannot be to convert PDF to JPEG.
- The third party application must accept and send out the same file name. For example, table.PDF in must result in, table.PDF out. The function of the third party software cannot be to convert, table.PDF to door.PDF.
- Users must supply a user name and password when a remote location is selected during setup.
- The folder-based, input, output, and error locations must reside on the same remote machine or the same local machine.
- The CLI profile Script full path, Working directory, and Output location (if used) must reside on the same remote machine or on the same local machine.
Setting up third party input and output hot folders

For folder-based profiles, to ensure the exchange of files between the Process Manager external process and the third party software, you must set up input and output hot folders for the third party software that match the input and output folders of the profile used to execute the external process.

**NOTE**

It is your responsibility to ensure that your third party software has the proper Windows write access to the folders (input folder, output folder, etc.) you create and/or set up during the External Process node configuration in Workflow Builder.

**Example**

**In Process Manager** - The following input and output folders are set up in Process Manager for an external process profile called Profile 1:

- Process input folder: C:\Profile1In
- Process output folder: C:\Profile1Out

**In the third party software** - The following input and output hot folder locations must be set up to match the above input and output folders for Profile 1:

- Third party input hot folder location is mapped to the Process input folder: C:\Profile1In
- Third party output hot folder location is mapped to the Process output folder: C:\Profile1In

**NOTE**

The third party software must be running for you to use the external process in a workflow.
Setting up folder-based profiles

The Folder Profile Setup dialog allows you to set up hot folders for input, output, and error files, and to define a timeout interval.

**NOTE**
Input, output, and error files must be assigned to unique locations.

The dialog includes the following options:

**Profile name:** Allows you to enter a name for the profile.

**Input location:** Allows you to select a hot folder on a local or remote drive for Process Manager to place the files and for the third party software to retrieve the files.

**Provide available job data to external process by XML file:** Allows you to request the system to provide additional information to the external process via an XML file written to the external process input folder. Information includes job name, job ID, date submitted, JDF and preflight results file path information, manifest order jacket file information.

**NOTE**
The third party application should also be configured to retrieve input at this location.

**Output location:** Allows you to select a hot folder on a local or remote drive for the third party software to store successfully processed files.

**NOTE**
The third party application should also be configured to store successfully processed files at this location.

**Error location:** Allows you to select a hot folder for the third party software to place error files. If error files are generated, the job will fail.

**NOTE**
Creating an error file location is optional.

**Timeout:** Allows you to enter a duration to wait for the external process to return processed files. If this time elapses with no returned files or errors, the job fails. Seconds and minutes values cannot both be zero.
Setting up CLI profiles

The CLI Profile Setup dialog allows you to select a script location and enter optional parameters, set up working directory and output locations, and define a timeout interval. The dialog includes the following options:

**Profile name:** Allows you to enter a name for the profile.

**Script full path:** Allows you to enter or select the location and file name of the script file to be used for the external process.

**Browse:** Opens a common file dialog that allows you to select a file.

**Parameters:** Allows you to enter optional script parameters. Default parameters are $\text{in}$ $\text{out}$.

**Provide available job data to external process by XML file:** Allows you to request the system to provide additional information to the external process via an XML file written to the external process input folder.

**Working directory:** Allows you to designate a location on a local or remote drive in which the external process node can place input files and from which the script can retrieve the files.

**Output location:** Optional; allows you to enter the location on a local or remote drive in which the script stores successfully processed files.

**Timeout:** Allows you to enter a duration to wait for the external process to return processed files. If this time elapses with no returned files or errors, the job fails. Seconds and minutes values cannot both be zero.

Adding or editing a CLI profile

Changing a name or a folder affects existing workflows.

You may add parameters before, after, or between the default parameters, but you should not delete the defaults. If a default is deleted, an error message displays when you click OK.

Setting up the SMTP Server

The Simple Mail Transport Protocol (SMTP) Server is used for email notification. To support the Notify process step, you must designate a mail server for outgoing mail or notifications. Incoming and outgoing mail cannot be directed without the SMTP address of your mail server.

1. In Workflow Builder, select **Options > SMTP Setup**.
2. In the **SMTP server** text box, enter the name of the mail server used for outgoing mail or notifications.
3. Select a maximum attachment size from 20 - 1024 MB.
4. Select **OK**.

Setting up the proxy server

Job submission using JMF/JDF might require communication via a proxy server. The Proxy Setup dialog is used to configure an address and port number on your proxy server.

In Workflow Builder, select **Options > Proxy Setup**.
Automatic Job and Job History Deletion

Automatic job deletion automatically removes completed jobs from the system on a schedule you select. By default, the system automatically deletes successfully completed jobs. You can choose the age of jobs to delete so that recent jobs are retained. You can also choose to delete job history records for the deleted jobs, and to archive the job history records before deleting them from the system.

In Workflow Builder, select Options > Automatic Job Deletion to choose deletion options.

Archive Job History Records Setup

You can configure the job history records that will be archived just prior to the removal of the jobs, including the file format, job attributes included, and the order in which the records in the archive are sorted.

Optimizing system performance with hot folder and job deletion options

Automatic job deletion is designed to work together with automatic file submission rate adjustment for hot folders. Using these two features together may improve system performance by managing the number of jobs in the system.
Workflow Submission Client

Xerox FreeFlow Workflow Submission Client allows you to perform major job submission tasks, from choosing files to enter in a designated workflow to selecting the best workflow for the job.

Workflow Submission Client main window

The Workflow Submission Client main window contains four areas that represent the main steps in the job submission process: Get Files, Select Workflow, Configure Settings, and Submit Job.

Job submission

Job submission involves a few basic steps.

- **Locate and sequence the files**: You can select files from local disks, DocuShare, or from the document repositories. If you are submitting multiple files for joining, list them in the desired sequence.
- **Select a workflow**: Only workflows that have been enabled in Workflow Builder display. Ensure the selected workflow includes the processes necessary to meet the job criteria.
- **Modify the process settings**: You can modify process settings to meet the needs of a job in the Configure Settings area; for example:
  - You can change page numbers or watermarks settings via the appropriate process settings dialogs.
  - You can change the job ticket settings (for example, the number of copies, the stock) using the Job Setup dialog in Print Settings.
- **Name and submit the job**: Use the default name or select a new name, and then submit the job. When submitting multiple files, you can choose to submit them as a single job.

**NOTE**
To automatically clear files from the Get Files list after submission, select Options > Remove Files after Submission.
Limitations for Save File List

Repository files that have been saved in a Xerox File List (.xfl) can be successfully loaded only if the Workflow Submission Client application has not been closed since the file list was first created. Once the Workflow Submission Client application is closed, the temporary repository files are removed. If you re-launch the application and load the file list, an error message will display for each of the removed repository files.

Submitting Zip files

Zip files can be submitted only via a hot folder.

Submitting VI Containers (.vpc)

VI Container files (.vpc) can be submitted via Workflow Submission Client only to workflows containing Review, Print, Save, Convert and Impose. Jobs submitted to workflows with processes other than these will fail.

Submitting a file with saved job ticket information for reprinting

The Save the job ticket option in the Save Settings dialog allows you to save the job ticket (XPIF) information with the PDF file for reprinting purposes. To reprint via Workflow Submission Client, submit only the saved PDF file to the reprint workflow. Process Manager automatically picks up the associated job ticket and applies it to all print nodes in the workflow.

About RDOs

The FreeFlow document type, RDO, stands for Raster Document Object. It is a compound object (an object having many parts), but FreeFlow sees an RDO as a single document. The two main parts of an RDO are the .RDO file and the .CON directory.

- The .RDO part of the file contains all the information about how to organize the images in the document to produce the desired output, or appearance.
- The .CON directory part of the file contains all the images of the document stored as individual files in the .CON directory. The images can be TIFF, JPEG, and Adobe PDF and can be black and white, grayscale, or color.

Working with RDOs in Windows Explorer and File Manager

When you open Windows Explorer and look for your documents, you see both parts of the RDO - the .RDO file and the .CON directory. For a document named Family, you see a file named Family.rdo and a directory named Family.con.

In File Manager, you can view only the RDO. FreeFlow treats the parts of the RDO as a single document.

Submitting RDOs

RDOs are submitted to a workflow via Workflow Submission Client, the same way that you submit any job to a workflow.
To submit an RDO and produce an RDO (RDO reprint)

RDOs previously set up with the necessary job parameters in Makeready can be submitted to Process Manager for reprinting. Minor changes can be made to the job ticket for example, the copy count.

You can submit an RDO reprint to a workflow that contains any combination of Save, Print, and Review. Review is available only to pause, approve, fail, change copy counts, and print a proof. You will not be able to view the RDO using View DocumentSettings; the RDO ticket can be viewed via Settings. This is possible only if you have a Print node.

RDO limitations

Successful submission of linked RDOs (an RDO containing a link to another RDO) and set labeling RDOs via Workflow Submission Client or hot folders cannot be assured.

If submitting RDOs to a workflow with a Convert node prior to the Print node connected to Continuous Feed production printer, mark the Use these settings always check box to retain the banner message information.

Remote Workflow Submission Client

Process Manager can support multiple remote instances of Workflow Submission Client. This allows you to submit files by logging in to any workstation or server in your print shop that has the Remote Workflow Submission Client software installed. The following file types are supported:

- If Adobe Acrobat is not installed on the client system, only PDF file types can be submitted remotely via the Add Windows File, Add Repository File, or Add Cabinet File (for legacy Document Library) options, regardless of whether Adobe Reader is installed.
- If Adobe Acrobat is installed on the client system, then all supported file types can be submitted.

Process Manager supports a maximum of 8 instances of Remote Workflow Submission Client, not including the client on the FreeFlow Process Manager server.

NOTE

Ensure that the Process Manager server is selected in the text box of the remote client login screen.
Workflow Job Manager

Xerox FreeFlow Workflow Job Manager allows you to view and manage active and completed jobs in the system.

About Workflow Job

Use Workflow Job Manager to perform tasks at the job level:
- View job details and status.
- Review and edit jobs in Adobe Acrobat.
- Edit process settings.
- Identify faulted jobs.
- Resubmit jobs.
- Approve, fail, pause, or delete jobs.
- Generate, view, and export reports.
- Set up repository credentials.
- Review and configure incoming third-party jobs from Management Information Systems (MIS).
- Perform selected tasks remotely from a workstation or server with Remote Workflow Job Manager Client installed.
Logging into Workflow Job Manager

Process Manager user accounts are created and managed using the Windows Local Users and Groups functionality in the Computer Management application. During install, Xerox FreeFlow Process Manager Administrators and Xerox FreeFlowProcess Manager Operators groups are created. Your administrator then populates these groups with users. Permissions to launch applications are based on group membership.

**NOTE**
If you are not a member of an authorizing group, contact your administrator. If you forget your username and password, notify your administrator.

A login screen may or may not display, depending on group membership and server location. If you enter the incorrect username or password, you receive an incorrect username or password error message. You can then enter your correct username and password.

2. In the User name text box, enter your user name.
3. In the Password text box, enter your password.
4. The Domain text box is populated with the domain of the currently logged in user, or the last domain entered in the login form. Confirm that the proper domain name appears.
5. Enter the appropriate Process Manager server name in the Server text box.
6. Select **OK**.
7. If during login to a remote client you enter the incorrect username or password, an incorrect username or password error message displays. Enter your correct username and password.

The Workflow Job Manager main window

The Workflow Job Manager window provides an overview of all jobs and their current status in the system. You can view all jobs in the system, including active and completed jobs. Two major areas comprise the Workflow Job Manager main window: the Status area and the Jobs area.
The Status area

The upper portion of the Workflow Job Manager window displays the detailed status of a job selected in the Jobs area.

The status area reflects the status of the selected job and the selected workflow node. The buttons that display vary, based on the selected workflow and node. The status area displays the name of the job and includes the following elements:

- **Process status text**: Displays the name and status of a selected workflow process—for example, Passed in Convert.” Includes an instructive statement—for example, You may edit settings and resubmit to this node.
- **Selected process arrow**: An arrow connects the currently selected process to the status area.
- **Process buttons**: The available buttons display for the selected process—for example View Document and Approve.
- **Progress bar**: Indicates the status of an in-progress automated process.

  **NOTE**
  
  When submitting multiple files for conversion, the progress bar shows the conversion progress on a per file basis. For each file, the progress bar moves to 50% to indicate that the file is processing, and then to 100% when processing is complete.

- **Workflow**: Graphically represents the workflow of the selected job.
  - **Active process**: A green highlight indicates the currently active process; green arrows link the processes.
  - **Completed process**: A blue check mark indicates a completed process.
  - **Selected process**: A blue background indicates a selected process; an arrow connects the selected node to the message area. Selecting a process displays the Settings button, if available, and allows you to access the settings dialog.
  - **Process Settings**: You can position the mouse cursor over a process to view the setting in a tool tip.
  - **Input settings**: In Workflow Job Manager, you can open the Input settings dialog and view a list of the original input files for the selected job. Input files can also be viewed via the tool tip.

  **NOTE**
  
  The workflow process steps cannot be dragged and dropped in this graphical view.

The Jobs area

The lower portion of the Workflow Job Manager window lists all jobs, active and completed, currently in the system.

- Each row lists a job and the job details.
- The toolbar allows you to launch Workflow Submission Client, or delete a job, or launch Workflow Builder.

The Jobs area columns

Each row in the Workflow Job Manager Jobs area contains information about a job. Sort the jobs list by the items in any column by selecting the column heading. For example, to sort the table alphabetically by workflow, select the Workflow column heading.
Managing Jobs

This section contains the activities available within Workflow Job Manager, including checking job, process, and workflow status; editing documents; editing workflow settings for specific jobs; approving or deleting jobs; viewing print results; or opening Workflow Submission Client to start a new job.

About the status of a job

When you choose to view the details of individual jobs, details are displayed in the status area at the top of the screen and include:

- **Graphical display**: Depicts the workflow process steps. A “+” in the workflow indicates a process branch that was created due to a failed process. Click “+” to open the branch; click “-” to close the branch.
- **Progress bar**: Shows the progress of the current process.

About purging report data

To help manage the database size, accounting data from deleted jobs can be removed from the database.

**NOTE**

Deleting jobs from the Workflow Job Manager window should not be confused with the Purge function.

Select Purge in the Reports dialog to display the Purge dialog, which includes the following options:

- **Never**: Never removes accounting data.
- **Now**: Removes data for deleted jobs upon clicking OK.
- **Older than**: Purges the records older than the specified value. If selected, the default is 365 days.

About documents in Adobe Acrobat

The View Document function is available whenever a PDF job is at a Review step or is paused. The View Document function allows you to open the PDF file in Adobe Acrobat, preview its current state and, if necessary, edit the document.

**NOTE**

You cannot change the file submission or the selected workflow, but you can access the other settings if you are allowed to change settings.

The following options are available:

- **Approve/Resume**: When selected, the job continues in the workflow.
- **Fail**: When selected, the job fails.

**NOTE**

If a document from an earlier step is edited, the changes do not affect the later document unless the job is resubmitted before the place where the document was edited.
Viewing preflight results

A Preflight process step must be completed for a job in order to select this option.

1. In Workflow Job Manager, select a job from the Jobs list.
2. Select a Preflight node, and then select from the following:
   - Right-click the node and select Preflight Results from the context menu.
   - Select Edit > Preflight Results.
   - Select Preflight Results.
3. Adobe Acrobat displays the results for the selected Preflight node.

Viewing print results

Use the Print Results dialog to obtain information about documents submitted to IPP printers. The dialog updates periodically to display up-to-date information about each instance of a production print process in a workflow, including printer name, queue name, job name, job status, job ID, time, print quantity, finishing type, collation, and output.

1. In Workflow Job Manager, select a job from the Jobs list.
2. Select a Print step, then select from the following:
   - Right-click the node, and select Print Results from the context menu.
   - Select Edit > Print Results.
   - Select a Print step, and then select Print Results.
3. Review the print results for the selected Print node.

Modifying workflow settings

**Settings**: Available if a job is at a Review step or paused and a configurable process step is selected in the workflow. It provides access to the workflow process settings.

**Resubmit**: Available if a job is paused at a Review step and a previous process step is selected. When selected, it reprocesses the workflow at the step that is currently selected.

**NOTE**

During the resubmit operation, if there is interaction with a repository, the RMS credentials of the current user (the user running Workflow Job Manager) are used. If the current user of Workflow Job Manager does not have proper RMS credentials saved, the job will fail during resubmit.

1. In Workflow Job Manager, select a job that is at a Review step or is paused.
2. Select a workflow process step.
3. Select **Settings**. If the process is not configurable, **Settings** is grayed out.
4. Make the desired changes.
Pause a job

You can pause a job if it is processing and not in a failed status.
The following options are available for a paused job:

View document: Opens the PDF file in Adobe Acrobat; allows you to review and edit the document.

Settings: Available if a job is at a Review step or paused and a configurable process step is selected in the workflow. Provides access to the workflow process settings.

Resume: The job continues in the workflow.

Fail: The job fails.

NOTE
The job pauses after the current process is done processing.

Approve a job at a Review step

A job can be approved if the job is at a Review step.
The following options are available for a job awaiting approval:

View document: Opens the PDF file in Adobe Acrobat; allows you to review and edit the document.

Settings: Available during the Review process step. Provides access to the workflow process settings.

Copies: Available when a selected job is at the Review step. If the job workflow contains a Print step after the Review step, the Copies dialog opens.

Print Proof: Available when a selected job is at a Review step only if the workflow contains a Print step following the Review step. Allows you to print a high resolution proof of the PDF file processed to that point on the next available Print step in the workflow.

Approve: Available during the Review process step. When selected, the job continues in the workflow.

Fail: When selected, the job fails.

Fail a job

You can fail a job if the job is paused or at a Review step. A failed job and all of the intermediate files can be deleted. The workflow is not deleted.
Modifying the copy count

The **Copies** option is available when a selected job is at the Review step. If the job workflow contains a Print step after the Review step, the Copies dialog opens in which the following options are available:

- **Quantity (original document)**: Allows you to change the number of copies to print, from 1-9999999, for all Print steps that follow the Review step in the workflow branch. Represents the quantity of the document as submitted via an XPIF, JDF or manifest value (order jacket file field for Quantity). If the copy count dialog is opened from a Review node prior to the copy count being modified by a multi-up repeated Imposition node, only this option displays.

- **Quantity (imposed document)**: Allows you to modify the imposed copy count. If the Copy Count dialog is opened from a Review node after the copy count is modified by a multi-up repeated Imposition node, this option is available and the **Quantity (original document)** cannot be modified. **Quantity (imposed document)** is available when you:
  - Process the job through a Xerox imposition node (not Preps) that is multi-up repeated.
  - Enable the Copy Count Divisor feature via Workflow Builder > Processes, right-click on Impose > Settings. This feature enables the system to adjust the copy count to maintain the original quantity intent for workflows that contain multiple-up impositions.
  - Submit a job with a job ticket quantity intent.

During the Review task, if both **Quantity (original document)** and **Quantity (imposed document)** are available for a Print node, the value displayed in the Print node Quantity setting is the **Quantity (imposed document)** value.

For more information about the copy count divisor, see the topic “To enable the copy count divisor.”

**NOTE**
The job must have a Print step following a Review step.

Printing a hardcopy proof

A hard copy allows you to review a hardcopy of the job before printing a full production run. The **Print Proof** option is available when a selected job is at a Review step. It uses the job ticket settings, with a copy count of one, to print a high resolution proof of the PDF file processed up to that point on the next available Print step in the workflow.

**NOTE**
**Print Proof** is only available if the workflow contains a Print step following the Review step.

Printer status and results for print proof jobs are not available in the Process Manager reports. However, you can obtain the job information in the production printer Job Manager.

1. In Workflow Job Manager, select a job from the Jobs list. The job must be stopped at the Review step.
2. Select **Print Proof** to print a single copy. Obtain and review the proof.

**NOTE**
A “Proof sent to printer” message displays when the “Print Proof” button is selected and the document is successfully sent to the printer.

A “Proof failed to print” message displays when you select[Print Proof] and the document is sent to the printer but fails to print.

3. If appropriate, select **Approve** to print the entire job.
Adding a recipient to a Notify step with no recipient address specified

If the **Enter recipient address during job processing** option is selected during configuration of the Notification Settings, the job runs until it reaches the Notify step then pauses and displays the following message:

Attention Required for Notify. Please add recipients to the notify settings and resume the job.

The following options are available for the job when you select a Notify step with no recipient addresses specified:

- **View Document**: Opens the PDF file in Adobe Acrobat and allows you to review and edit the document.
- **Settings**: Opens the Notification Settings dialog and allows you to enter recipient addresses.
- **Resume**: Continues processing the job. Resume is grayed out if no recipients are specified, and the submitter did not check the **Allow job to continue even if no notification is sent** check box.
- **Fail**: Fails the job.

Creating reports

The reports feature allows you to set up, generate, view and export various customized reports. The reports can include audit trail data, such as status and information about each job processed; as well as accounting data, such as processing time and number of impressions. You can also manage accounting data for past deleted jobs.

Reports can be viewed in Workflow Job Manager, or can be exported to the following formats:
- CSV comma delimited (*.csv)
- XML (*.xml)

The report function is also available via Remote Workflow Job Manager Client.

You can set up and generate the following reports:

<table>
<thead>
<tr>
<th>Report Category</th>
<th>Report Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job reports</td>
<td>Full job report</td>
</tr>
<tr>
<td></td>
<td>Job totals daily</td>
</tr>
<tr>
<td></td>
<td>Job totals monthly</td>
</tr>
<tr>
<td></td>
<td>Job totals yearly</td>
</tr>
<tr>
<td>Workflow reports</td>
<td>Full workflow report</td>
</tr>
<tr>
<td></td>
<td>Single workflow daily</td>
</tr>
<tr>
<td></td>
<td>Single workflow monthly</td>
</tr>
<tr>
<td></td>
<td>Single workflow yearly</td>
</tr>
<tr>
<td></td>
<td>all workflows daily</td>
</tr>
<tr>
<td></td>
<td>All workflows monthly</td>
</tr>
<tr>
<td></td>
<td>All workflows yearly</td>
</tr>
<tr>
<td>Process reports</td>
<td>Single job</td>
</tr>
<tr>
<td></td>
<td>All jobs</td>
</tr>
<tr>
<td></td>
<td>Process results daily</td>
</tr>
<tr>
<td></td>
<td>Process results monthly</td>
</tr>
<tr>
<td></td>
<td>Process results yearly</td>
</tr>
</tbody>
</table>
The Reports dialog allows you to select a report type and define the report parameters. It provides access to dialogs that allow you to view or export a report, and purge data for past jobs. Dialog options, which vary depending on the selected report, include:

**Workflow name:** Allows you to enter the workflow name.

**Workflow Id:** Allows you to enter the workflow Id.

**Job name:** Displays for reports that require an exact job name; allows you to enter the job name.

**Job Id:** Allows you to enter the job Id.

**Category:** Allows you to select a report category. Report options for the category are displayed in the Report type field.

**Type:** Options depend on the report category selection.

**Start date:** Allows you to select a start date for inclusion of data in a report.

**End date:** Allows you to select an end date for inclusion of data in a report.

**All dates:** Allows you select the use of all available data in terms of dates for report generation.

**Attributes to include:** Includes the appropriate data/column options for the selected report type.

**NOTE**
Processing time is displayed in seconds.

**NOTE**
“Impressions” refers to the number of sides of paper printed. Data is available only at the time of print. If an IPP connection is not available at the time the report is requested, the number of impressions is not reported.

**Sort attribute:** Available if at least one report attribute is selected. Allows you to sort a report by the selected attribute in ascending or descending order.

**Purge:** Opens the Purge dialog, which allows you to remove accounting data for deleted jobs.

**View:** Generates a report and displays a report for viewing.

**Export:** Opens the Export dialog.

1. In Workflow Job Manager, select **Options > Reports** to display the Reports dialog.
2. Select the report category and type.

---

**Viewing Web Services Job Instructions**

Web Services job instructions can be viewed via a URL link by selecting View Job Instructions. This option is available when a selected Web Services job is in a Review, paused, or Incomplete Notify Settings state.

1. In Workflow Job Manager, select a Web Services job from the Jobs list.
2. Select **View Job Instructions.** The system default web browser opens to the Web Services-supplied URL for the selected job.
Remote Workflow Job Manager Client

Process Manager can support multiple remote instances of Workflow Job Manager. This allows you to manage jobs by logging in to any workstation or server in your print shop that has the Remote Workflow Job Manager Client software installed.

Process Manager supports a maximum of 8 instances of Remote Workflow Job Manager Client, not including the client on the FreeFlow Process Manager server.

**NOTE**
Ensure that the Process Manager server is selected in the text box of the remote client login screen.

**Using the View Document function**
To use the View Document function when a job is stopped at the Review task, Adobe Acrobat or Adobe Reader must be installed. Otherwise, the function is disabled.

If Adobe Reader is installed:
- You can use the View Document function to view PDF files.
- You cannot edit PDF files.

If Adobe Acrobat is installed, you can use the View Document function to:
- Edit PDF files
- View PDF files

**Job In Use dialog**
When using Remote Workflow Job Manager Client, only one remote client at a time can modify a job. If another user attempts to edit or review documents associated with a job that is being edited or reviewed, the system locks the job and the Job in Use Dialog displays. This prevents other clients from accessing the job. Dialog options include:

**Unlock**: Available only on the server installation of Workflow Job Manager. Brings up the Unlock Confirmation dialog.

**Unlock Confirmation dialog**
The Unlock Confirmation dialog displays when a user selects Unlock in the Job in Use dialog.

**Managing jobs from third party management information system (MIS)**

Third party management information systems (MIS) can submit jobs directly to Process Manager. For incoming jobs that do not include all the necessary processing information, the operator might have to complete the job setup by assigning and configuring a workflow and/or selecting the workflow submission files.

Incoming third party jobs that require additional configuration display the following elements:
- A paused job icon in the Name column
- “Attention Required” in the Status column
- Instructional text, for example: “Please configure this job and select Approve to begin processing.”

The topics in the following sections cover the dialogs and procedures involved in configuring incoming third party MIS jobs:
Assigning and configuring a workflow for an incoming third party job

On occasion, incoming jobs do not have the information necessary for processing, and you will need to assign a workflow.

1. Select a workflow from the drop down box.
2. When a workflow is selected, the JDF job intents are matched as closely as possible to the workflow settings. If the settings are locked or not available, the workflow defaults are applied.
3. Continue configuring the job if files have not been selected, or select Approve to release the job for processing.

   **NOTE**
   Approve is available if a workflow has been assigned and files have been selected. If Approve is grayed out, you must complete the job configuration.

Selecting files for an incoming third party job

On occasion, incoming jobs do not have the information necessary for processing, and you need to select files for a workflow.

**Select Files**: This option opens a common file dialog for selecting input files. If files have been selected, they are listed beneath the button instead of the default statement No files are currently associated with this job.

1. In Workflow Job Manager, from the Jobs list, select a job with “Attention Required” in the Status column.
2. Select **Select Files**.

   **NOTE**
   If files have been selected previously, they are listed beneath the button.
3. Continue configuring the job if a workflow has not been assigned, or select Approve to release the job for processing.

   **NOTE**
   Approve is available if a workflow has been assigned and files have been selected. If Approve is grayed out, you must complete the job configuration.

Viewing the JDF file for an incoming third party job

On occasion, incoming third party jobs do not have the information necessary for processing, and you need to review the JDF file submitted with the job.

**View JDF**: This option is available if a JDF file was submitted with the job. It opens the JDF file in a separate window.

1. In Workflow Job Manager, from the Jobs list, select a job with “Attention Required” in the Status column.
2. Select **View JDF** to display the JDF file in a separate dialog.
Viewing the job instructions for an incoming third party job

On occasion, incoming third party jobs do not have the information necessary for processing, and you need to review the job instructions submitted with the job.

**View Job Instructions**: This option is available if a job instructions file was submitted with the job. The job instructions file opens with Adobe Reader in a separate window.

1. In Workflow Job Manager, from the Jobs list, select a job with "Attention Required" in the Status column.

2. Select **View Job Instructions** to display the job instructions in a separate dialog.
Xerox FreeFlow MAX Submission Client allows customers to utilize the power of Manifest Automation from Xerox or MAX to create and process short and ultra short run jobs cost effectively.
MAX Submission Client

MAX Submission Client provides an easy to use graphical interface to allow print providers to set up job orders. The following steps describe the process and the elements of a Shop Order:

- **Shop Order:**
  - Shop Orders include single or multiple customers’ jobs, such as multiple business cards, post cards, or photos. Multiple jobs must be of the same type and characteristics in a given shop order.
  - The details of the customer job is provided in the associated Order Item tab (see below).
  - Multiple jobs can be processed as separate jobs or grouped together for efficient utilization of paper, print charge, finishing, etc.
  - You have a choice to select the Bill of Material printing at the individual job or combined job level.
  - Multiple Shop Orders can be created and saved for later use. You can also edit and delete existing Shop Orders, edit the job and Bill of Material settings at the Order Item level.
  - Each Shop Order must be associated with one workflow.

- **Order Item:**
  - Order Item is associated with a given Shop Order. Order Item allows you to provide detailed information about customers and their jobs.
  - Order Item allows the input of multiple files as a part of a job. You need to join these files if you need to create one job such as a book, book cover file and the shell.
  - You can, optionally, input the customer information, such as purchase order number, customer name and address. This information will be printed on the Bill of Material associated with the Shop Order. Depending upon the associated workflow, this information or a subset of the information can be included in the printed document. For example the customer order number and name can be printed in the cropped area of the printed job.

- **Files in the Selected Order Item:**
  - Allows input and displays the folder and the file name or names associated with a customer order in the Order Item.
  - Up to 10 custom fields of information can be specified on a given customer order, assuming the associated workflow has been set-up accordingly. For example, a bar code can be specified for distribution routing or automating finishing information.

- **Job Settings:**
  - Job settings can be applied either at the Shop Order level or the Order Item level.

- **Bill of Materials (BOM):**
  - Bill of Materials settings can be applied either at a Shop Order level, for example, one consolidated report, or at the Order Entry level for an individual Bill of Materials for each job.

- **Submit Shop Order:**
  - Sends the Shop Order and all the associated files and printing properties to Process Manager.

MAX Submission Client Interface

The MAX Submission Client interface allows the submission of customer jobs and customer specific information for processing by Freeflow Process Manager.
Configure Hot Folders and Custom Field Labels

You must configure the behavior of the Hot Folder and specify a workflow for each Shop Order. Select Settings > Configure.

- **Hot Folder**: Enter the location of the Hot Folder.
- **When an error occurs while processing a shop order**: Select Continue or Stop processing the shop order.
- **When an error occurs while processing items within a Bill of Materials**: Select Continue or Stop processing the rest of the items.
- **Bill of Materials**: Select if you would like to generate a PDF format of the Bill of Materials and the workflow to process the Bill of Materials.
- **Custom field labels**: Use this area to customize file labels for variable data on the User Interface.

Shop Order

Setup and selection of Shop Orders are completed from the main screen Setup Shop Orders button.

- **Add Shop Order**:
  - **Shop Order Name**: Enter Shop Order name.
  - **Submission Options**: To submit multiple orders as one job or separate jobs. Optional selections include number of copies, named paper stock, and XPIF job ticket.
  - **Target workflow**: Select the appropriate workflow.
  - **Bill of Materials generation**: To generate a Bill of Materials for each order or one Bill of Materials for the entire order. Optional selections include due date and rush orders.
- **Shop Order Properties**: Verify or edit the settings of a selected Shop Order.
- **Duplicate Shop Order**: Duplicate the selected Shop Order, which can be modified with Shop Order Properties.
- **Delete Shop Order**: Delete the selected Shop Order.

  **NOTE**
  A Shop Order can include one or many Order Items. All Order Items included a Shop Order must use the same workflow.

Add Order Item

Order Items Setup, selection and edit are completed from the main screen under Order Items.

- **New Order Item**:
  - **Purchase order number**: Enter the purchase order number.
  - **Customer Information**: Select from the drop down arrow or from the address book button.

  **NOTE**
  If the customer does not exist in the address book, see the next section, Address Book, to add a new customer.

  - **Joining Files**: To submit multiple orders as one job or separate jobs. Optional selections include the number of copies, named paper stock, and XPIF job ticket.
  - **Bill of Materials generation**: To generate a Bill of Materials for each order or one Bill of Materials for the entire order. Optional selections include due date and rush orders.
- **Edit Order Item**: Verify or edit the settings of a selected Order Item.
- **Duplicate Order Item**: Duplicate the selected Order Item, which can be modified with Edit Order Item.
- **Delete Order Item**: Delete the selected Order Item.
Address Book
Address book setup, selection, and edit are completed from the Address Book button.
- **New Customer**: Last name, first name, and phone number must be entered.
- **Customer Properties**: Verify or edit the settings of a selected customer.
- **Delete Customer**: Delete the selected customer.

Order Items Files and Folders
Adding files and folders to the selected Order Item.
- **Add**:
  - **File or Folder name**: Input the file or folder to include in the Job.
  - **Custom fields**: Input information into Custom fields. Depending on workflow, information specified in custom fields can be applied to the printed document.
  - **Joining files**: Optional selections include the number of copies, named paper stock and XPIF job tickets.
- **Properties**: Verify the settings of a selected Order Item File or Folder.
- **Duplicate**: Duplicate the selected file, which can be modified with Properties.
- **Remove file**: Remove the selected file.
To use Preps, install Preps in the following way:

**NOTE**
This version of FreeFlow Process Manager supports Kodak Preps 5.3.3.

**NOTE**
When the Preps documentation uses the term Xerox DigiPath, it is referring to FreeFlow.

**NOTE**
Obtain a Preps Pro license from Kodak.

- For Setup Type, select the Custom Install.
- Select the following components during installation:
  - Preps Program
  - Languages
  - Xerox Digipath
  - Automation
  - Automation Server
  - iKey Hardware Key Driver or Sentinel Hardware Key Driver

You also have to physically install the appropriate hardware key.

Once Preps is installed, you need to perform the following:
- Configure Preps to use the Default workflow PDF to PDF.
- Create and save Preps Job files.

### Starting Preps Automation Server

Preps Automation Server does not automatically start up in Windows Server 2008. To use Preps on Windows Server 2008 start the Preps automation server (PrepsSrv.exe) manually as administrator.

1. Navigate to the Preps installation directory.
   The installation directory is usually `C:\Program Files\Kodak\Preps 5.3.3`.
2. Right-click PrepsSrv.exe and select **Run as administrator**.
To configure the Preps default workflow

1. Start Preps.
2. Select Edit > Preferences to display the Preferences dialog.
3. Select the General tab. In the Default workflow box, select PDF -> PDF.
4. Select Setup > Save Profile to display the Save Profile dialog.
5. In the Profile Name text box, ensure the “default” is entered, and select OK to save the profile.
6. If the message “Profile default already exists. Overwrite anyway.” displays, select Yes.
7. Exit Preps.
8. The Save current configuration dialog prompts “Do you want to save the current configuration into the profile,” select Yes. Preps closes.

NOTE
The profile must be manually edited in a text editor to allow output to a PDF file. After completing steps 9-1 above, do the following:

9. On the Process Manager server, locate the file “default.cfg” under <Preps Install dir>\>\Preps x.x\Profiles\Default.
10. Open the file with a text editor.
   a) Double-click “default.cfg”.
   b) In the Windows dialog, select Select the program from a list, and select OK.
   c) In the Open With dialog, select Notepad, and select OK.
11. Find and change the following entries:
   • Change -O:P to -O:D
   • Change -ADOBEPIFT:NO to -ADOBEPIFT:YES
   • Change -JDFOUTPUT:YES to -JDFOUTPUT:NO
   • Change -EXPORTPDF:NO to -EXPORTPDF:YES
   • Change SkipDeviceSizeWarning:NO to SkipDeviceSizeWarning:YES
12. Save and close the file.
13. If there is a .cfg file under >Preps Install dir>\>\Preps x.x\Profiles, make the same changes as in steps 11-13 to this file also.

Creating and saving Preps Job files

When you use Preps, the FreeFlow Workflow Builder system searches the Imposition Jobs directory for Preps files with a .job suffix. Since no default .job files are provided, you must create them.

1. In Preps, to create a new PDF job, select File > New Job > PDF->PDF
2. Add a template and signature to the job file.
3. Select select a device type for each signature
4. In the Choose Device window, select Press Sheet Size as the target device. You must select a device for each signature.
5. Select OK to close the Choose Device window.
6. Save the job file to the FreeFlow Install Directory \ImpositionJobs directory, typically, E:\FreeFlow\ImpositionJobs.

Repeat these steps to add more job file templates.
Selecting a device type for Preps versions prior to 5.3.1

You must select a device type for each signature in order to use old Preps job files.
1. Start Preps.
2. Select Setup > Device Setup.
4. Close the Preps application. You can now use the old job files.
   For more information about device setup, refer to your Preps documentation.

Missing hardware key error

If the “Preps Server error, check Preps Automation Front-End server” error message is displayed on your Preps UI or on the server that you are using to run Preps, do the following, even if the Preps hardware key is not missing:
1. Stop the Preps Automation Front-End server by performing one of the following:
   • If there is a yellow folder icon (with the tooltip “Waiting for Jobs”) in the systray, double-click the icon to open the Preps UI, then select File > Exit to close Preps.
   • If there is not a yellow folder icon (with the tooltip “Waiting for Jobs”) in the systray, in Windows Task Manager, end the PrepsSlv.exe process.
2. Reinsert the hardware key.
4. Open the FreeFlow Process Manager applications and resubmit the job. The Preps Automation Front-End server starts automatically.

Using Preps with Adobe Acrobat

When using Adobe Acrobat, after Preps installation, you must change the PDF Conversion Acrobat directory.
1. Start Preps.
2. Select Edit > Preferences to display the Preferences dialog.
3. Select the PDF tab.
4. Select Adobe Acrobat and select the directory in which you installed Adobe Acrobat, for example C:\Program Files\Adobe\Acrobat Directory\Acrobat.exe.
5. Select OK to close the Preferences dialog.
Index

.vpc files
submitting to a hot folder 3-47
.xml workflow files
errors 3-47
hot folders and
about 3-46
submitting to a hot folder 3-46
.xpf tickets
errors 3-45
imposition and 3-46

A
about 4-2
About the FreeFlow Process Manager
applications 2-1
Administrators group 2-6
Adobe Acrobat
viewing and editing a document 5-4
Adobe Acrobat Professional
limitations when creating JDF tickets
with 3-31
specifying number of pages for JDF
tickets 3-31
specifying the pages in the range for JDF
3-31
Adobe Creative Suite
remote conversion 3-9
approving a job 5-6
audience 1-1
Automatic Paper Stock type
considerations 3-24

B
barcode
about 3-16
configuring 3-17
configuring data
about 3-18
readable text 3-18

C
cautions 1-2
Cell Clustering 3-20
CLI profiles
adding or editing 3-51
setting up 3-51

Color Manage node
importing a legacy workflow 3-13
color profiles
consistency between server and client
3-15
color profiles, managing 3-14
color settings 3-13
conditional branches
about 3-32
conditions reference 3-34
definitions of conditions 3-35
linking 3-36
conditional branches
guidelines 3-32
conditions
configuring 3-33
creating 3-33
Convert settings
configuring 3-7
copy count
modifying 5-7
copy count divisor
enabling 3-37
credentials, repository
about 3-37

E
error
logging in 2-6
PREPS server A-3
error checking
hot folders and 3-40
errors
.xml workflow files 3-47
.xpf tickets 3-45
external process settings, configuring 3-36
external processes
about 3-47
guidelines 3-48
setting up 3-48
setting up with hot folders 3-49

F
fail branches, creating in a workflow 3-5
failing a job 5-6
files
   selecting for an incoming third party job 5-11
folder-based profiles
   about 3-50
FreeFlow FAQ (Xerox web site)
   additional information 1-3
FreeFlow Process Manager
   about 2-1
      applications 2-1
         Workflow Builder 2-1
         Workflow Job Manager 2-2
         Workflow Submission Client 2-2
   applications logging in 2-5
documentation 1-2
   post-installation setup 2-2
FreeFlow Process Manager Operator/
   Administrator Guide
   conventions 1-1
   overview 1-1
FreeFlow Process Manager Operator/
   Administrator Guideaudience 1-1
FreeFlowProcess Manager
   Online Help 1-3

G
   group membership 2-6
      administrators 2-6

H
   hardcopy proof
      printing 5-7
   Help
      accessing 1-3
   hot folder
      submitting .xml workflow files to 3-46
   hot folders
      .xml workflow files and
         about 3-46
      configuring
         about 3-43
deleting 3-43
   error checking and 3-40
   folder-based profiles
      about 3-50
JDF and 3-40
   limitations 3-41
   linked RDOs and 3-44
   managing 3-41
      about 3-41
   modifying
      about 3-42
   pausing and resuming monitoring 3-43
   RDOs and
      limitations 3-44
   read-only files and 3-40
   setting up
      about 3-42
   shared drives and 3-40
   submitting .vpc files
      about 3-47
   submitting a job ticket file (*.xpf) to
      3-45
      about 3-44
   submitting a job to 3-43
   submitting an RDO to 3-44
   supported files 3-40
   using with external processes 3-49
   Zip files and 3-38, 3-39

I
   icons, workflow process 3-1
   Image Quality settings 3-14
   imposition
      .xpf tickets and 3-46
      about 3-19
      configuring
         Crop Marks tab 3-22
         General tab 3-19
   job types 3-21
      Maximum N-up
      considerations 3-24
      PREPS and 3-25
      limitations 3-25
   Input node 3-6, 3-7
   installation
      generating a preflight profile 3-15

J
   JDF
      Adobe Acrobat Professional
      specifying the number of pages
         3-31
      specifying the pages in the
         range 3-31
      Color Manage 3-30
      hot folders and 3-40
limitations when creating tickets with Adobe Acrobat Professional 3-31

JDF Export
- about 3-30
- configuring 3-29
- fault handling 3-30

JDF file
- viewing for an incoming third party job 5-11

Job instructions
- viewing 5-9
- viewing for an incoming third party job 5-12

Job Level Edit nodes
- upgrading legacy workflows 3-15

job ticket
- saving with PDF 3-29

Join 3-10
- limitations 3-11

L

legacy workflows
- upgrading workflows that contain Job Level Edit nodes 3-15

linked RDOs
- hot folders and 3-44

logging in 2-5
- authorization 2-6
- error message 2-6
- Workflow Job Manager 5-2

M

management information system (MIS)
- managing jobs from 5-10
- managing jobs from a management information system (MIS) 5-10

Manual Conversion tab 3-8

MAX Submission Client 6-1
- about 6-2
- about the interface 6-2

Maximum bleed size, condition 3-35

Microsoft Windows 1-3

MOES
- Add Order Item 6-3
- Address Book 6-4
- configuring hot folders and custom field labels 6-3

Order Items files and folders 6-4
Shop Order 6-3

N

notes 1-2
Notify step
- adding a recipient 5-8
- configuring 3-26
- Number of copies, condition 3-35
- Number of impressions, condition 3-35

O

Online Help
- accessing 1-3
Optimize
- configuring settings 3-11
- general 3-11

P

page numbers 3-16

paper stock type
- automatic 3-24
- pausing a job 5-6

PDF
- Join 3-10
- limitations 3-11
- saving a job ticket 3-29
- working with 3-9

PDF Boxes
- considerations 3-23
- PDF Boxes, about 3-12
- PDF Boxes, configuring 3-12
- preflight
- viewing results 5-5

Preflight
- configuring 3-15
- preflight, about 3-15
- preflight, profile repository 3-15

PREPS
- Adobe Acrobat 8.1.1, using with A-3
- default workflow, configuring A-2
- device type, selecting A-3
- imposition
- limitations 3-25
- imposition settings 3-25
- job files, creating and saving A-2
- server error A-3
- setting up A-1
print
  viewing results 5-5
Print
  fault handling 3-28
Print settings
  about 3-27
  configuring 3-28
printer
  registering and adding 2-7
  Printer Registration 2-6
  Printer Status/Job Status Tool 2-6
process
  checking status 3-38
processes
  copy count divisor
    enabling 3-37
  number of concurrent 3-38
proof
  printing 5-7
proxy server
  setting up 3-51
R
RDOs
  hot folders and
    limitations 3-44
  limitations 4-3
    submitting 4-2
    about 4-2
read-only files
  hot folders and 3-40
Registered Printer List Locator 2-6
Remote Workflow Job Manager Client 5-10
Remote Workflow Submission Client 4-3
repository credentials, about 3-37
Review
  approving a job 5-6
  failing a job 5-6
Review, about 3-25
S
Save settings
  about 3-28
saving a file list
  limitations 4-2
shared drives
  hot folders and 3-40
SMTP server
  setting up 3-51
spot colors 3-14
submitting RDOs 4-2
U
Unlimited User Conversion 3-8
User Conversion, unlimited 3-8
V
VI containers (.vpc)
  submitting 4-2
vpc files
  limitations 3-47
  submitting to a hot folder 3-47
W
warnings 1-2
watermark, in an email attachment 3-27
watermarks
  about 3-16
  Bates numbering 3-16
Web Services
  job instructions
    viewing 5-9
Windows, Microsoft 1-3
workflow
  assigning and configuring 5-11
  importing a legacy workflow 3-13
Workflow Builder 2-1, 3-1
  General tab 3-7
  input 3-6, 3-7
  Manual Conversion tab 3-8
  menus
    Insert 3-1
Workflow Job Manager 2-2, 5-1
  about 5-1
  checking job status 5-4
  creating reports 5-8
    jobs area 5-3
    columns 5-3
  logging in 5-2
  main window 5-2
  managing jobs 5-4
  purging report data 5-4
  status area 5-3
workflow settings
  modifying 5-5
Workflow Submission Client 2-2, 4-2
  job submission 4-1
  main window 4-1
saving a file list
  limitations 4-2
submitting a file with saved job ticket
  4-2
submitting RDOs 4-2
submitting VI containers (.vpc) 4-2
workflows
  building
    new 3-5
    rules for 3-4
  creating fail branches 3-5
exporting 3-5
importing 3-6
  compatibility 3-6
workflows, building 3-4

X

X-PRESS FAX
  additional information 1-3
Xerox Welcome Center
  additional information 1-3
xml workflow files
  errors 3-47

Z

Zip files
  hot folders and 3-38, 3-39
  submitting 4-2