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Chapter 1:

Introduction
In this chapter...


Font Editor Overview



Associated DesignPro Applications



About this User Guide



Conventions



Getting the Answers You Need

This guide provides both background and procedural information for using DesignPro
Font Editor for Xerox. Because business requirements and user preferences can vary for
each company, the material contained herein should be viewed as a general guide only.
As you step through the material, please remember that your specific business needs will
govern selection of the options and preferences described. Similarly, certain selections
will require that some tasks be repeated, while other selections will allow you to omit
tasks entirely.

Font Editor Overview
DesignPro Font Editor is a character set editor that allows you to create and edit various
fonts in a What You See Is What You Get (WYSIWYG) environment.
DesignPro Font Editor enables you to perform the following operations:


Create character sets and legacy fonts through the use of convenient wizards.



Edit individual font characters using tools to manipulate each character bitmap.



Apply transformations to one, all, or a sequence of font characters to embolden,
italicize, underline, and apply other transformations.
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Display and change character or font properties such as kerning, baseline offset, and
orientation.



Convert character sets to Xerox format and Xerox format fonts to other supported
formats.

Working together with the DesignPro Manager and Converters, you can import and
convert fonts to the Elixir generic format, perform desired edits, and then reconvert to
original or other formats.

Associated DesignPro Applications
DesignPro Tools for Xerox employs integrated applications to provide advanced
functionality for creating resources such as documents, overlays, fonts and images for
Xerox jobs. Each application helps you create or modify one or more of these necessary
resources in a simple environment.
Following are the DesignPro Tools for Xerox applications:
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DesignPro Manager: a Windows-based desktop program for managing and
converting resources to multiple supported formats. You can also open other
DesignPro Tools applications using the DesignPro Manager.



DesignPro Form Editor: an advanced overlay design tool used to create and edit
forms for Xerox printers.



DesignPro Font Editor: a complete font design application used for creating and
editing Xerox fonts as well as Elixir and PCL fonts. You can also open True Type
fonts in this editor.



DesignPro Graphics Editor: a full service bitmap editor providing various
transformations and commands for tiling images into raster fonts and image
modifications, such as resizing and cleaning up scanned images.
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About this User Guide
The DesignPro Font Editor User Guide provides definitions and step-by-step instructions
to help you understand the different font types and their structure, and to create and edit
Xerox, Elixir, Legacy and PCL fonts.
The DesignPro Font Editor User Guide is organized to explain the font creation and
editing process. Each chapter describes tasks in the same order you can use for creating
and editing different font types and then transforming them to suit your needs.
Chapter 1: Introduction
Introduces DesignPro Font Editor and basic font functions. Also introduces this manual
and identifies resources for finding answers and contacting Customer Support.
Chapter 2: Font Editor Workspace
Provides an overview of DesignPro Font Editor for Xerox environment, including
workspace, menus and toolbars. It also provides instructions on customizing the Font
Editor workspace.
Chapter 3: Font Structure
Describes font structures and how DesignPro Font Editor handles fonts.
Chapter 4: Font Editor Basics
Provides information on opening, creating, and saving fonts in the supported formats of
DesignPro Font Editor. Also, included are instructions for specifying file format
properties.
Chapter 5: Editing Fonts
Describes how to modify fonts and set the font and character properties. Also describes
the use of drawing tools to perform associated operations.
Chapter 6: Transform Tools
Describes how to perform transform operations on single character or all characters in a
font or font character set.
Appendix A: Workspace Quick Reference
Provides information on DesignPro Font Editor workspace environment menus and
toolbars.
Appendix B: Glossary
Provides an alphabetical listing of product-specific or unique terms and abbreviations
used in the DesignPro Font Editor User Guide.

Chapter 1: Introduction
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Who Should Use this Guide?
This guide assumes you are already familiar with Microsoft Windows operations, printer
and font management operations and PC peripherals. You should also have access to
reference manuals for PC software and hardware, including any printers you are using for
the resource creation and print process.

Related Guides
If you require further information about a specific topic or wish to obtain product
background information, reference the following resources, all of which are part of the
DesignPro Tools for Xerox documentation package:
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DesignPro Tools for Xerox Getting Started Guide.



DesignPro Tools Manager for Xerox User Guide.



DesignPro Tools Form Editor for Xerox User Guide.



DesignPro Tools Graphics Editor for Xerox User Guide.



DesignPro Tools for Xerox Migration Guide.
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Conventions
Elixir products adhere to Microsoft Windows conventions for using menus, menu
commands, dialogs, command buttons, icons and mouse. See your Windows manual for
more information.
This guide uses the following typographic and symbolic conventions to identify special
information.

Typographic Conventions
This guide uses the following typographic conventions to identify special information.

Convention

Information Type/Example

Bold type

Text for you to enter.
Field names, windows, toolbars, buttons and workspace
areas within a task step.
Example: select the font character set from the
Script list.
Example: click the Font Properties tab.
Example: select the ACSII Font option to specify
the character set type as ASCII.
Example: select the Text tool.
Example: click OK to save settings.

Italic type

References to other documents and books.
Example: refer to the DesignPro Tools for Xerox
Getting Started Guide.

Chapter 1: Introduction
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Symbolic Conventions
Look for the following symbols as you read through this guide to identify special
information.

The Note symbol calls your attention to additional information.

The Tip symbol highlights a helpful tip.

The Shortcut symbol calls your attention to an easier way of accomplishing a
task.

The Warning symbol warns you of problems you might encounter.

The Question symbol refers you to the online help for more information.
To open online help:

14



From the Help menu, select Contents, or



Click

in an open dialog.
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Getting the Answers You Need
Elixir Technologies provides you with multiple ways to learn and use DesignPro Font
Editor:


Customer Support (page 15)



Elixir Web Site Support (page 16)



Elixir Training (page 16)



Product Help (page 16)



Release Notes (page 16)

Customer Support
If you purchased this product directly from Elixir Technologies, you can contact the
Customer Support Center for your region at the number listed below.
If you have purchased this product from some other source, please contact the
authorized support representative from that source. Elixir provides customer
support for products purchased directly from Elixir.

North and South America:


+1 805 641 5900 ext. 3
Monday - Friday, 7:00 am to 4:00 pm Pacific Standard Time; if closed, press 2 to
reach Elixir’s extended Support coverage.



Elx_support@elixir.com

Asia Pacific:


Asia_support@elixir.com

Europe:


+44 (0) 207 993-4811
Monday - Friday, 6:00 am to 4:00 pm Central European Time



+1 805 641 5900 ext. 3
Monday - Friday, 4:00 pm to 2:00 am Central European Time



Europe_support@elixir.com

Chapter 1: Introduction
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An Elixir Product Specialist will take your call and ask for the following information:


Your name, organization, telephone number and address.



Elixir product name and version number.



A complete description of the problem, including any error messages printed or
displayed on your monitor.

Elixir Web Site Support
You can obtain product support from the Elixir web page at www.elixir.com.
Select Support to:


Ask a question of Elixir Support.



Download the latest product releases and patches.



View the latest product Release Notes.



Sign up for Elixir Training.



Renew your product license.

Elixir Training
Elixir Technologies offers training for its full range of Windows-based products. For more
information, contact Elixir Learning at +1 805 641 5900, ext. 4.

Product Help
Elixir software provides Online Help for all product functions and contains step-by-step
procedures that you can follow as you work:


Context-Sensitive Help can be activated from within the software for certain
dialogs by clicking



in the upper-right corner of a dialog.

Online Help can be opened from the Help menu by selecting Contents.

Release Notes
Release Notes display at the start of product installation so you can review them before
beginning the installation process. Once installation completes, you can access Release
Notes from the product CD at drive:\Relnotes. There are two formats of the Release Notes
file, Relnotes.pdf and Relnotes.txt. The PDF file can be viewed using Adobe Reader. The
TXT file can be viewed using either Notepad or WordPad.
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Chapter 2:

Font Editor
Workspace
In this chapter...


Opening Font Editor



What’s in the Workspace?



Workspace Tools



Basic Workspace Functions



Arranging Workspace Windows

Opening Font Editor
To open DesignPro Font Editor, from the Start menu, select All Programs, Elixir
Applications, DesignPro Tools, DesignPro Font Editor.

What’s in the Workspace?
When you start Font Editor, the workspace displays where you can create and maintain
fonts. The Font Editor workspace contains the following main components, depending
upon which component you want to have open.


Character Set Window (page 18)



Toolbox (page 20)



Messages Window (page 21)
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The image illustrates each part of the Font Editor workspace, when all the components are
open.
DesignPro Font Editor Components.
Menu
Click buttons on the
toolbar to choose
commands quickly
Toolbox contains
the options for
each main tool
Character Set
window
Messages window
Status bar

You can customize the position and size of the windows to meet your requirements. The
workspace windows can be, displayed as either floating, docked, or can also be hidden
from view.

Character Set Window
The Character Set window displays immediately below the toolbar and contains the active
character set. The Character Set window is vertically scrollable only. You use the
Character Set window to create, edit and save character sets.
Double clicking a character in the Character Set window opens the editing pane to edit
the selected character.
You can also select a character in the Character Set window, and click
the Formatting toolbar to edit a character.

on

See Chapter 5: “Editing Fonts” on page 81 for details.
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In Edit mode, the Character Set window is split into three panes:


Character Set pane displays at the bottom of the screen.



Editing pane shows the selected character in magnified view for editing.



The right most pane displays the selected character in its original size. Magnifying or
reducing the view displays a locator box over the character allowing panning of the
character. Panning is a display method for scanning the selected character
horizontally or vertically. You can click and drag the locator box to bring an offscreen extension of the selected character smoothly into view in the editing pane.

Character Set window split into three panes in Edit mode.

Chapter 2: Font Editor Workspace
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Toolbox
Toolbox displays at the left of the Design Area by default. The Toolbox provides different
options associated with most toolbar items in the Drawing Toolbar (page 27) and
Transform Toolbar (page 28). Click on the toolbar item to view the associated options in
the Toolbox. The Toolbox updates each time you select a Drawing or Transform tool.

1. Select the required tool
from the toolbar to display the
associated options in the
Toolbox.
2. Select the required options
from the Toolbox.

3. Click Apply to apply the
changes.

The options available in the Toolbox change depending on the tool selected in the
Transform or Drawing toolbar.

20
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Messages Window
The Messages window is located at the bottom of the workspace by default and can be
docked to any other position. This window displays processing and compilation errors,
warnings and informational messages generated by the application. You can close the
Messages window from the menu by selecting View, Messages to allow more space to
work.
You can perform any of the following functions to view or hide the Messages
window:
Check/uncheck Messages from the View menu.
Press Ctrl+Shift+M on the keyboard.
However, the Messages window will automatically re-display whenever a
message is generated by the application.




You can view messages in pop-up message boxes alternatively.
Select Tools, Options. The Options dialog displays. From the General
category, uncheck Send All Messages To Window.

You can also click

at the top of the Messages window.

Clearing Messages
To clear the messages generated by the application, right-click in the Messages window
and select Clear Messages from the pop-up menu.

You can also clear messages in this window by pressing Control + D or by
selecting Clear Messages from the View menu.

Chapter 2: Font Editor Workspace
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Copying Messages
To copy the messages generated by the application:

1

Select the required messages in the Messages window.

2

Right-click the selected messages and select Copy Messages from the pop-up menu.
The selected messages copy to the clipboard and you can paste them wherever
required.

You can also copy messages from this window by selecting the required
messages and pressing Control + C on the keyboard.

Logging Messages
Logging options enable you to save the information displayed in the Messages window in
a text file.
To log the generated messages:

1

From the Tools menu, select Options.
The Options dialog displays.

2

Select the Messages category, and check Log to File.
This writes messages to the log file.

Options set at the application level apply to all projects created in the
application.

3

In the entry box adjacent to Log to File, enter the destination path for the log file.

The default value of “.\” saves the log file in the same directory as the resource
file.

22
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4

Enter the name of the log file in the next entry box, as shown below:

The default log file name is “MSG.LOG”, however, you can change the file name and
save it.

5

Check Unicode to create the log file using the Unicode character set.

6

Specify the settings of your choice:
 Overwrite: overwrites any existing log file messages.
 Append: appends messages to the existing log file.
 Append by date: appends messages to the log file by date.
You can view the log file at any time by clicking View Log File. The contents of
the log file (with the name and location entered in the Log to File entry boxes)
display in a Notepad window.
You can create a message log file in any format.

The Log file displaying the generated messages and the system date value is
appended to the name of the file due to the Append by date option.

7

Click Apply, and then click OK.
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Displaying Message Time and Date
You can also display the time and date when a message was generated in the Messages
window.
To display message time and date:

1

From the Tools menu, select Options.
The Options dialog displays.

2

Select the Messages category.

3

Under the Messages to View area, check Information to display informational
messages in the Messages window.

4

Under the Show area, check Message Time in order to display the message
generation time in the Messages window.

5

Under the Show area, check Message Date in order to display the message
generation time in the Messages window.

6

Click Apply and then click OK.

Color Coding Messages
Messages in the Messages window can also be color coded according to the nature of the
message. Color coding is added using colored boxes before the messages. Error messages
display red boxes, warnings display blue boxes, and informational messages display
neither. With color coding, critical messages can be located quickly.
To color code messages:
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1

From the Tools menu, select Options.
The Options dialog displays.

2

Select the Messages category.

3

Under the Messages to View area, make sure Information is checked to display
informational messages in the Messages window.
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4

In the Show area, check Use Color to display colored boxes in the Messages
window.

5

Click Apply and then click OK.

The Messages window.

You can also set the number of maximum lines displaying in the Messages
window by entering the number in the Lines Maximum entry box, provided in
the Show area.
If the number of messages generated exceeds the value specified in the Lines
Maximum entry box, the new messages overwrite the existing ones from the
top in the Messages window. If Log to File is checked, messages are
overwritten from the top of the log file.

Chapter 2: Font Editor Workspace
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Workspace Tools
Font Editor provides toolbars for easy access to the most commonly used application
commands. You can perform standard MS-Windows operations to hide or display a
toolbar, or dock a toolbar at the edge of the workspace.

Menus
A menu bar with drop-down menus displays directly below the application title bar by
default. These drop-down menus provide both standard MS-Windows and applicationspecific options. Selecting a menu item performs the associated action or displays a submenu or a dialog. See “Menu bar” on page 133 in Appendix A: “Workspace Quick
Reference” on page 133 for detailed information on all of the menus.

Toolbars
Directly below the menu bar are the toolbars with buttons that provide access to the most
commonly used commands and tools. You can hide or display toolbars from the View
menu by selecting Toolbars, required toolbar. See “Toolbars” on page 140 in Appendix A:
“Workspace Quick Reference” on page 133 for detailed information on all of the menus.
To add or remove more buttons on a toolbar, see the “Adding Buttons to
Toolbars” on page 31.
To view or hide a toolbar, see “Customizing Toolbar Display” on page 29.

Standard Toolbar
The Standard toolbar provides one-click access to the basic File and Edit menu
commands such as Saving Fonts (page 64) or Creating Fonts (page 57). For more
information, refer to “Standard Toolbar” on page 141 in Appendix A: “Workspace Quick
Reference” on page 133.
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Formatting Toolbar
The Formatting toolbar provides quick access to the formatting commands such as
Swapping Characters (page 89) or Replacing Non-Blank Characters with Blank
Characters (page 91). For more information, refer to “Formatting Toolbar” on page 142 in
Appendix A: “Workspace Quick Reference” on page 133.

Preview Toolbar
The Preview toolbar is used for previewing fonts in the Font Editor. For more
information, refer to “Preview Toolbar” on page 143 in Appendix A: “Workspace Quick
Reference” on page 133.

Drawing Toolbar
The Drawing toolbar provides drawing tools for editing font characters in the Character
Set window. For more information, refer to “Drawing Toolbar” on page 144 in Appendix
A: “Workspace Quick Reference” on page 133.

Chapter 2: Font Editor Workspace
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Transform Toolbar
The Transform toolbar provides tools for editing individual characters in the Font Editor.
For more information, refer to “Transform Toolbar” on page 145 in Appendix A:
“Workspace Quick Reference” on page 133.

See “Toolbox” on page 20.

View Toolbar
The View toolbar provides one-click access to the basic View commands. For more
information, refer to “View Toolbar” on page 146 in Appendix A: “Workspace Quick
Reference” on page 133.
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Customizing Toolbar Display
You can also specify the toolbars that display in the workspace.
To customize Font Editor toolbars:

1

From the View menu, select Toolbars, Customize.
The Customize dialog displays.

2

Click the Toolbars tab.
The Toolbar Options displays.

3

Check the toolbars you want to display in the workspace from the list of available
toolbars.
The selected toolbar name displays in the Toolbar Name entry box.

Chapter 2: Font Editor Workspace
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You cannot uncheck Menu bar from the list of toolbars.

You can also display a toolbar from the View menu by selecting Toolbars,
required toolbar.

4

To set the appearance of the displayed toolbars, specify the following:
 Show Tooltips: displays the tool tips associated with the toolbar buttons.
 Cool Look: displays the toolbar buttons in the smooth look mode.
 Large Buttons: displays the toolbar buttons in the enlarged mode.
 Reset/Delete: resets a default toolbar to the default settings. This button toggles
to Delete when a custom toolbar is selected; only custom toolbars can be deleted.

The Standard toolbar with Large Buttons and (1) Cool Look un-checked and (2)
Cool Look checked.

5

30

Click OK to return to the application window.
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Creating a New Toolbar
Using Font Editor, you can also create a new toolbar.
To create a new toolbar:

1

From the View menu, select Toolbars, Customize.
The Customize dialog displays.

2

Click the Toolbars tab.

3

Click New to display the New Toolbar dialog.

4

In the Toolbar Name entry box, enter the name of the new toolbar.
You can modify this name later in the Toolbars tab.

The names of the default toolbars are not editable.

5

Click OK.
The new toolbar displays in the workspace. The new toolbar is currently empty. To
add buttons to this toolbar, see “Adding Buttons to Toolbars” on page 31.

Adding Buttons to Toolbars
You can also add buttons to your toolbar.
To add buttons to a toolbar:

1

From the View menu, select Toolbars, Customize.
The Customize dialog displays.

Chapter 2: Font Editor Workspace
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2

Click the Command tab.
The list of available command groups displays in the Categories list. When a
command group is selected in the Categories list, the buttons for each command in
the group display in the Buttons area.

3

Click and drag the required button to any target toolbar displaying in the Design
Area, and then release the mouse.
While dragging the required button, the mouse cursor changes from
to
selected button is then added to the required toolbar at the specified place.

. The

If you drag a button and drop it anywhere in the application window other than
the target toolbar, Font Editor automatically creates a new toolbar with the
specified button and displays it in the application window. If you then click the
Toolbars tab, the newly created toolbar name (default is Toolbar 1) displays in
the Toolbars list.

4
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Click OK.
The added buttons display in the selected toolbars.
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Status Bar
The Status bar displays, by default, along the lower edge of the Font Editor workspace.
The Status bar displays a tooltip when the mouse pointer is placed over a command.
When you move the mouse pointer over a character, the Status bar displays the Character
ID in decimal and in hexadecimal format, character width in pels, and character type such
as blank, non-blank or spacing.

Type spacing specifies a blank bitmap used to provide space between characters
or words. All other characters containing bitmaps are non-blank characters.

Displays the Character ID
in decimal and hexadecimal
format.

Tooltip

Character type

Displays character
width in pels.

Status bar showing the tooltip, selected character width and type, and the Character ID.
In Edit mode, the Status bar displays additional information about the character; column
and row locations, zoom magnification and reduction sizes, and horizontal and vertical
coordinates. The coordinates help you in drawing objects within the editing pane.
Displays the column and row location
of the mouse pointer in the Character
Set pane.

Tooltip

Displays the horizontal and
vertical coordinates on left
click.

Displays the distance between
two points in the Character Set
pane using the ruler.

Status bar in the Edit mode.
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Grid
The grid feature in Font Editor provides a network of intersecting lines that help in
aligning and editing characters in the Character Set window. These lines help in the
character editing process, and are not a part of the finished character set.

The Character Set window with the Grid option enabled.

Displaying and Hiding the Grid
To activate the grid in the Character Set window, select View, Grid from the menu.

You can also view and hide the grid by clicking
pressing F4.

on the View toolbar or by

The grid is only active when the zoom is set to 3X or greater.

34

DesignPro Tools Font Editor® for Xerox User Guide

Basic Workspace Functions
The Font Editor workspace also has some basic functions to help you design your font(s)/
character sets.
Using the Right-Click Menu
The Right click menu provides access to the most commonly used functions in Font
Editor. To use the Right click menu, position the cursor in the Character Set window,
right-click the mouse and then select the required option.
Choosing Commands
A command instructs Font Editor to perform a specific action. You can choose a command
by either:


Clicking a toolbar button.



Selecting a menu option.



Using a hot key.



Using a shortcut key.

In the chapters that follow, command selection is described using the most common
method for the described task. However, any related command selection can be used to
accomplish the same instruction.
Undoing and Repeating Commands
Font Editor keeps track of your editing and formatting changes. If you want to undo a
change or command selection, you can reverse several previous actions.
Click Redo to repeat the
last reversed action

Click Undo to reverse
the last action

Using the Standard toolbar to Undo and Repeat commands.


You can use Control + Z and Control + Y shortcut keys to perform the undo and
redo actions respectively.



You can also select either Redo or Undo from the Edit menu.
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Arranging Workspace Windows
Font Editor lets you arrange the workspace windows in an orderly manner using the
Window menu options. When you first open a character set in the Font Editor, it opens in
the default state with windows docked to their specific locations. The default windows
include the Character Set window, Toolbox, and Messages window. You can open
different font files in the workspace and minimize or resize the default window state by
clicking

and

window by clicking

, as required. In minimized state, you can return to the maximum
on the title bar.

Cascading Windows
Cascade is an arrangement of windows in Font Editor such that they overlap one another.
Typically, the title bar of the window remains visible so that you can always see which
ones are open.
To cascade the windows opened in Font Editor, from the Window menu, select Cascade.

Cascading windows can overlap each other.
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Tiling Windows
Tiling is an arrangement of windows in Font Editor such that every window is completely
visible and does not overlap each other.
To tile the windows opened in Font Editor, from the Window menu, select Tile.

Tiled windows do not overlap each other.

Chapter 2: Font Editor Workspace

37

Arranging Windows
You can arrange windows that are in the minimized state in the Font Editor workspace
such that every window is completely visible and does not overlap each other.
To arrange the windows opened in Font Editor, from the Window menu, select Arrange
Icons. This option arranges the windows in the minimized state starting from the bottom
left corner of the workspace.
The windows arrange in the workspace
starting from the bottom-left corner.

Arranging windows in minimized state.
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Chapter 3:

Font Structure
In this chapter...


Font Structure



Xerox Font Components



Font Characteristics



Elixir Legacy Font Structure

This chapter describes font structures and how DesignPro Font Editor handles different
format fonts, including Xerox and Elixir format fonts.

Font Structure
A font is a set of graphic characters of a given typeface and other properties, such as size,
pitch, and style. There can be up to 256 characters in a font, consisting of numerals, letters,
punctuation marks, and symbols.
Font Editor uses a proprietary structure that enables you to display and edit characters in a
WYSIWYG format. In addition, you can also convert TrueType and ATM font formats to
Elixir format fonts using the DesignPro Manager, Converters. For more information on
Converters, refer to the DesignPro Manager for Xerox User Guide.
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The following sections describe components of a font type family, a term that
encompasses all characteristics of printed text.
Type Family
A type family is a group of typefaces that have a common basic design, but may vary in
size and style. Examples of type family are:


Sonoran Sans Serif



Courier



ITC Avant Garde Gothic

Typeface
A typeface is a collection of characters having the same style, weight, and width, as
described below:


Style is the inclination of characters with respect to the vertical axis (for example,
Roman (upright) or italic (top slant to the right)).



Weight is the degree of boldness of a typeface (for example, semi-light, light,
medium or bold).



Width is the degree of horizontal spacing of a character (for example, condensed or
normal).

Each typeface (Times New Roman, Arial, etc.) can have many fonts. Each font has a
specific set of properties defining all of the above characteristics. Most Windows
applications blur this definition by allowing you to choose a typeface and then set the
other options that define a specific font. The typeface examples include:


Sonoran Sans Serif Roman medium normal



Helvetica italic bold condensed



Times italic light normal

Type Font
A type font (also called a font) is a collection of characters that share the same type family,
typeface, and size. Font examples include:
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Sonoran Sans Serif 10-point Roman medium normal



Helvetica 8-point italic bold condensed



Times 12-point italic light normal
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Xerox Font Components
A Xerox font consists of a character set with a finite set of characters. The character set
corresponds to the type font (or font) described in “Type Font” on page 40. The character
set contains information about a single type family, typeface, bitmap, and point size, and
can also include information about the baseline positioning, rotation, ascenders,
descenders, etc. Each character within the character set is assigned a unique identifier
called a Graphic Character ID (GCID).

Font Characteristics
This section describes following font characteristics, particularly their appearance on a
printed page:


Character Baseline (page 41)



Character Rotation (page 42)



Character Orientation (page 43)



Toned Pel Box (page 43)



Printing Adjacent Characters (page 44)



Ascenders and Descenders (page 45)



Baseline Positioning (page 46)



Kerning (page 46)

Character Baseline
The character baseline is a reference to which characters align as they are added to the
page in the inline (print) direction. The character baseline is always parallel to the inline
(print) direction.

Character Baseline
Inline (Print) Direction

Character baseline.
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Character Rotation
Character rotation is the angle through which a printed character is rotated clockwise in
90o increments about the character baseline. The following figure shows the four character
rotations for the 0o inline (print) direction:

Character Baseline
0 Degree Rotation

90 Degree Rotation

Character Baseline

180 Degree Rotation

270 Degree Rotation

Character rotations for inline print direction.
As there are four inline print directions, there are a total of 16 combinations of inline
(print) directions and character rotations. Since Unbounded Box fonts do not support the
180o print directions, only 12 combinations apply for Unbounded Box fonts.
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Character Orientation
Character orientation is specified as portrait, landscape, inverse portrait, and inverse
landscape. Text printing depends on page orientation, which can be portrait or landscape.
The following figure illustrates the effect of printing text with different orientations on
portrait and landscape pages:

Portrait Page

Landscape Page

Character orientation.

Toned Pel Box
A toned pel box defines the boundaries of a character bitmap. Each character bitmap in a
character set comprises an ordered array of black dots (toned pels) and non-printing blank
dots (untoned pels). Toned-pels define the shape of the character; untoned-pels define the
white space in and about the character.
Width

Toned-Pel Box
Height

Toned-pel box.
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Printing Adjacent Characters
When printing side-by-side characters (as text in a word), each character is positioned
according to its character reference point and character escapement point. Character
reference point defines the current print position for the character.
Character escapement point marks the end of the space along the baseline allocated for the
character. When printing adjacent characters, the reference point of the next character is
placed at this point.
The distance from the character reference point to the near edge of the toned-pel box is the
character’s A-space; the toned-pel box width is the character’s B-space; and the distance
from the far edge of the toned-pel box to the escapement point is the character’s C-space.

Character
Reference
Point

Character
Escapement
Point

A + B + C = Character Increment

Character measurements.
A-space, B-space, and C-space are measured in pels (dots). The sum of the A-space, Bspace, and C-space is the character increment.
If a font's characters have the same increment (or uniform increment), the font is a
monospaced or fixed pitch font; if a font's character increments differ from each character,
the font is a proportional-spaced or typographic font.
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Ascenders and Descenders
The character ascender is the distance from the character baseline to the topmost tonedpel. The character descender is the distance from the character baseline to the lowest
toned-pel.

Ascender
Character
Baseline

Descender

Ascenders and descenders.

Ascenders and descenders are different for different rotations of a character.
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Baseline Positioning
The character baseline offset specifies the character placement relative to the character
baseline. The following figure shows the baseline offset (measured in pels) for different
character rotations.

Character Baseline
0 Degree Rotation

90 Degree Rotation

Character Baseline

180 Degree Rotation

270 Degree Rotation

Baseline offsets.
If the baseline offset is the same for all characters in a given rotation of a character set, it is
a Uniform Baseline Offset. If the baseline offset is different for characters in a given
rotation, the largest offset is the Maximum Baseline Offset.

Kerning
Kerning is a technique of printing characters so that they partially overlap. Kerning is
normally used to place italicized characters closer to each other for a more attractive
appearance.

Character
Baseline

Left kerning example.
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Kerning can be of two types:


A left-kerned character partially overlaps the preceding character, as in the letter “i”
in the figure above. A left-kerned character has a negative A-space.



A right-kerned character partially overlaps the next character, as in the letter “f” in
the following example. A right-kerned character has a negative C-space.

Character
Baseline

Right kerning example.

Elixir Legacy Font Structure
When converted to the Elixir format, a font can be edited and transformed in a number of
ways for example, a font can be resized, rotated, underlined, etc. The operations you can
perform on a font and individual font characters depend on the source font, i.e., whether
font was converted from a Xerox character set or from any other source fonts.

Elixir Font Converted from a Xerox Source
Each Elixir format font includes at least three components with different file extensions in
the drive:\Elixir\Fonts\Elixir directory. These are:


HDR component (file containing font header information).



GLH component (file containing header information for each character).



GLY component (file defines actual character bitmaps).
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Differences Between Character Set and Font
The differences described below assume you are familiar with editing Xerox and Elixirformat character sets, TrueType and ATM fonts.
Font Editor handles Xerox and Elixir-format character sets, TrueType and ATM fonts, as
follows:
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Xerox and Elixir format fonts are arranged in ASCII-sorted order in the displayed
character cells.



Xerox font names cannot exceed 6 characters. If the stem name of a font being
converted to Xerox production-printer format contains more than six characters, the
last (right side) characters are truncated.



Elixir format font names cannot exceed 8 characters.



Xerox and Elixir fonts are raster fonts; TrueType and ATM fonts are vector fonts.

DesignPro Tools Font Editor® for Xerox User Guide

Chapter 4:

Font Editor Basics
In this chapter...


Supported File Formats



Opening Fonts



Creating Fonts



Saving Fonts



Font Format Properties

Supported File Formats
DesignPro Font Editor can open, create, save, and edit fonts. It also provides options to
change the file type and attributes of fonts. You can open and save fonts in the following
input and output formats:
Input Formats (Open)


Adobe Type Manager Fonts



Elixir Legacy Fonts (HDR)



PCL Fonts (PCL, FLJ)



True Type Fonts



Xerox Fonts (FNT)

Windows applications use True Type or Postscript fonts. The True Type fonts are
Windows-based outline fonts technology used by Microsoft. Adobe Type Manager (ATM)
fonts are PostScript Adobe Type 1 fonts. ATM is a utility to render smooth characters on
PC screens from font outlines (Type 1 fonts) instead of using bitmap or raster fonts.
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Output Formats (Save As)


Elixir Fonts (HDR)



PCL Fonts (PCL, FLJ)



Xerox Fonts (FNT)

Opening Fonts
Font Editor enables you to open and edit Xerox, Elixir Legacy, PCL, or Windows fonts.
The font character bitmaps are arranged with a predefined left-to-right and top-to-bottom
order according to the predefined ASCII position of characters in the font.

Each character in a font has an ASCII number assigned to it denoting its position
in the font. This number is defined in the font header HDR file.

The maximum number of characters in a font is 256. You can set the range of the character
set using the ASCII numbers. For more information on setting the range of the character
set, see “Opening Windows Fonts” on page 55.
To open a font, click

on the Standard toolbar, or select Open from the File menu.

By default, you can select only font-specific file types from the Files of Type
drop-down list. However, you can also add the All Files (*.*) option to the Files
of Type drop-down list to select any file type. Select Options from the Tools
menu to display the Options dialog. Select the General category and check
Allow All Files in Fileselectors. Click OK to return to the Font Editor
workspace.
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Opening a Recently Used Font
Font Editor maintains a list of recently created or used fonts to help you keep track of the
frequently used font resources.
To open a recently used font, you can use one of the following methods:


From the File menu, select the required font.
The most recently created/used files display at the lower end of the File menu.



From the File menu, select Open to display the Open dialog. Select the required font
from the History folder in the left pane of the Open dialog and click Open.
The selected font displays in the Font Editor workspace. The Messages window
displays messages regarding the location of the font.

Opening Xerox Fonts
To open a Xerox font:

1

From the File menu, select Open.
The Open dialog displays.
You can also use one of the following methods to open a font:



Click
on the Standard toolbar.
Press Control + O on the keyboard.

2

Select Xerox Font (FNT) from the Files of Type drop-down list.

3

Click the Elixir folder to search for the required file at its default location.
You can also use the Look In drop-down list to search for the required target folder.
The path automatically updates to the specified profile directory for the selected
Files of Type if Elixir is selected from the left panel of the Open dialog. For
example, the default profile lists drive:\Elixir\Fonts\Xerox as the directory for
Xerox fonts.

4

Select the required font.

Chapter 4: Font Editor Basics

51

5

To set the input properties:
 Click Edit Property Settings to open the Xerox LPS Resource Parser dialog
for specifying the appropriate input settings.
Or
 Click Restore Default Settings to restore the default settings for Xerox LPS
Resource Parser dialog.
You can also click
to edit the required property settings or
to restore
the default input settings. For information on all the options available in the
parser dialogs, click

6

in an open dialog.

Click Open.
The selected font opens in Font Editor.

Opening Elixir Legacy Fonts
To open an Elixir Legacy font:

1

Select Open from the File menu.
The Open dialog displays.

2

Select Elixir Legacy Font (HDR) from the Files of Type drop-down list.

3

Click the Elixir folder to search for the required file at its default location.
You can also use the Look In drop-down list to search for the required target folder.
The path automatically updates to the specified profile directory for the selected
Files of Type if Elixir is selected from the left panel of the Open dialog. For
example, the default profile lists drive:\Elixir\Fonts\Elixir as the directory for
Elixir fonts.

4
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Select the required font and click Open.
The selected font opens in Font Editor. The Messages window displays messages
regarding the location of the font.

DesignPro Tools Font Editor® for Xerox User Guide

Opening PCL Fonts
To open a PCL font:

1

Select Open from the File menu.
The Open dialog displays.

2

Select PCL Font (FLJ, PCL) from the Files of Type drop-down list.

3

Click the Elixir folder to search for the required file at its default location.
You can also use the Look In drop-down list to search for the required target folder.
The path automatically updates to the specified profile directory for the selected
Files of Type if Elixir is selected from the left panel of the Open dialog. For
example, the default profile lists drive:\Elixir\Fonts\PCL as the directory for PCL
Fonts.

4

Select the required font.

5

To set the input properties:
 Click Edit Property Settings to open the PCL dialog for specifying the
appropriate input settings.
Or
 Click Restore Default Settings to restore the default settings for PCL dialog.
You can also click
to edit the required property settings or
to restore
the default input settings. For information on all the options available in the
parser dialogs, click

6

in an open dialog.

Click Open.
The select PCL font opens in the Font Editor workspace.
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Opening PC Mapped Fonts
A PC mapped font is a coded font saved in the ASCII format. The coded fonts cannot be
directly converted to other format fonts like Xerox or PCL fonts; however, we can create a
PC mapped (ASCII) font in order to convert fonts to any other ASCII font. The ASCII
font can also be used by indexes, without any code page.
To open a PC mapped font:

1

Select Open from the File menu.
The Open dialog displays.

2

Select Elixir Legacy Font (HDR) from the Files of Type drop-down list.

3

Click the Elixir folder to search for the required file at its default location.
You can also use the Look In drop-down list to search for the required target folder.
The path automatically updates to the specified profile directory for the selected
Files of Type if Elixir is selected from the left panel of the Open dialog. For
example, the default profile lists drive:\Elixir\Fonts\Elixir as the directory for
Elixir Legacy fonts.

4

Select the required font.
The PC mapped fonts are prefixed by X0, X1, X2, X3, or X4.

5

To set the input properties:
 Click Edit Property Settings to open the GDF/Elixir Form dialog for
specifying the appropriate input settings.
Or
 Click Restore Default Settings to restore the default settings for GDF/Elixir
Form dialog.
You can also click
to edit the required property settings or
to restore
the default input settings. For information on all the options available in the
parser dialogs, click

6
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in an open dialog.

Click Open.
The PC mapped font opens in the Font Editor workspace.
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Opening Windows Fonts
To open a Windows font:

1

Select Open Windows Font from the File menu.
The Font dialog displays.

Select the required
font, font style, and the
required size in this
area.

The Sample area
provides a preview
of the selected font
with its associated
properties.

Specify the orientation
and resolution of the
selected font.

Specify an output name
using the Custom option,
or select Auto to use the
system generated name.

You can use the
Script drop-down
list to select a
script for the
selected font.
Select an option for character set
range using these drop-down lists.

You can also press Control + Shift + O on the keyboard to open a Windows
font.

2

Specify the following in the Font dialog:
 Font: selects the required font from the list.
 Font Style: specifies the type for the selected font. Select an option from
Regular, Bold, Italic, Bold Italic.
 Size: specifies the size of the selected font.
You can view a sample of your selections in the Sample area.
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3

In the Orientation and Resolution area, select an option from the following:
 Portrait: sets to portrait.
 Landscape: sets to landscape.
 Inv Portrait: sets to inverse portrait.
 Inv Landscape: sets to inverse landscape.

4

In the Orientation and Resolution area, use the DPI drop-down list to specify a
DPI for the selected font. The default value is 300 for Windows font.

5

From the Script list, select the font character set.

6

In the Character Set Range area, select the character set range by specifying the
ASCII lower and upper values from the drop-down lists.

7

In the Output Name area, select one of the following options:
 Auto: uses the auto-generated name for the selected font.
 Custom: specifies a custom name for the select font. You can use 6 alphanumeric
characters with a maximum value of 6.

8

Click OK to select the required Windows (True Type) font.
The selected font opens in Font Editor workspace.
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Creating Fonts
Font Editor can create Xerox and ASCII type fonts. It also creates Xerox fonts and Elixir
Legacy fonts from Windows font sources.
To create either a Xerox or an ASCII type font, you can use the new or existing character
sets and code pages. Font Editor provides a wizard to walk you through the necessary
steps for creating a character set.

Creating an ASCII Font
To create an ASCII (PC Mapped) font:

1

From the File menu, select New to display the New Font dialog.

2

Select the ACSII Font option to specify the character set type as ASCII.

3

Enter a file name in the External Name entry box.
Font Editor assigns a default name to the new font. You can change the default name
and specify a custom name for the font.

4

In the Character Properties area, specify the following:
 Number of Characters: sets the number of null characters for the ASCII font.
The value can be between 1 and 256.
 Baseline from Bottom: sets the distance in pels from the character baseline to
the character box bottom edge. The value can be between 1 and 99 for ASCII
fonts.
The character type for ASCII font is NULL by default and can be reviewed from
All Type(s). Since all of the character cells are null, most of the settings do not
display any change.
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5

In the Character Box Dimensions area, specify the following:
 Width: sets the character raster pattern horizontal length in pels. For ASCII font,
the value of width is always 8 pels. The character cell width does not show for
null characters.
 Height: sets the character raster pattern vertical length in pels. The value can be
between 2 and 2000.

6

Click Next to set the font properties.
The Font Properties dialog displays. For more information on setting font
properties, see the “Setting Font Properties” on page 59.

7

Do either one of the following:
 Click Back to review or edit your selections made in the Font dialog.
Or
 Click Finish to create an ASCII font with a null character set and return to the
Font Editor workspace.
Most of the properties set during creation of fonts can be changed later using the
Font Properties dialog. For more information, see “Setting Font Properties” on
page 59.
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Setting Font Properties
To set font properties for an for an Xerox font or ASCII font, using the Font Properties
dialog:

1

In the Orientation area, the following options are available for specifying the font
orientation:
 Port: sets to portrait.
 IPort: sets to inverse portrait.
 Land: sets to landscape.
 ILand: sets to inverse landscape.

Font Editor displays the characters only in portrait style. The orientation results
are visible in printing.

2

The Resolution area displays the following font resolution information:
 Hor Resolution: displays the horizontal resolution of the glyph, in pels.
 Ver Resolution: displays the vertical glyph resolution, in pels. The values
depend on the resolution option selected.
The available resolutions for horizontal and vertical font resolution include 240, 300,
and 600. You cannot set the font orientation and resolution options when creating a
Xerox font.

3

In the Pitch area, select the required pitch (number of characters per linear inch)
from the following options:



Fixed: uses the same horizontal spacing for characters in the character set. Selecting
Fixed enables the following options:
 Enter Fixed Width: enters a fixed width in pels. The value can be between 0 and
2000 for ASCII fonts and between 0 and 32767 for Xerox fonts.
 Bitmap Placement: sets the font character bitmap alignment from the dropdown list.
The Bitmap Placement (character alignment) does not display any difference
for null characters. The alignment of characters in the character cells becomes
visible when cell width is greater than the character.



Proportional: uses variable horizontal spacing for characters in the character set.

Chapter 4: Font Editor Basics

59

4

In the Distance area, enter the required distance information in the following:
 Distance Above: sets the character distance above the baseline in pels.
 Below: sets the character distance below the baseline in pels.
 Leading: sets the leading space between two consecutive lines. The value can be
between -999 and 999.
The sum of Distance Above, Below, and Leading values gives the total space
between two consecutive lines. Total shows the total space calculated.

5

Review the following options:
 Enter the required value specifying the last character position in the character set
in Last Character At. The value can be between 0 and 255.
 In the Point Size entry box, you can view the point size initialized by 0 for ASCII
font and 1 for Xerox fonts. The point size is dependent on the pixel height, but
does not have any effect during font creation.
 In the Pixel Height entry box, you can view the pixel height of the font.

6

In the Change Cell Width area, enter the required value in Amount to change cell
width. The value can be between -512 and 512.

7

Click Finish to create the Xerox font.
The Xerox font displays in the Font Editor workspace.

You can click Back to go to the previous dialogs and change or review your
settings.
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Creating a Xerox Font
Creating a Xerox font involves going through two different dialogs via a wizard.

Creating a New Font
To create a new Xerox font:

1

From the File menu, select New.
The New Font dialog displays.
You can also use one of following methods to open the New Font dialog:



Click
on the Standard toolbar.
Press Control + N on the keyboard.

2

In the Type area, select Xerox Font.

3

In the External Name entry box, enter a file name.
The Font Editor assigns a default name to the new font. You can change the default
name and specify a custom name for the font. The name cannot be greater than 6
characters in length including the prefix.

4

In the Character Properties area, specify the following:
 Number of Characters: sets the number of spacing characters for Xerox fonts.
The value can be between 1 and 256.
 Baseline from Bottom: sets the distance in pels from the character baseline to
the character box bottom edge. The value can be between 0 and 511 for Xerox
fonts.

The character type for Xerox font is NULL by default and can be reviewed
from All Type(s).

5

In the Character Box Dimensions area, specify the following:
 Width: sets the character raster pattern horizontal length in pels. For ASCII font
the value of width is always 8 pels. The character cell width cannot be changed
for null characters.
 Height: sets the character raster pattern vertical length in pels. The value can be
between 2 and 127.
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6

Click Next to specify the Xerox font properties.
The Font Properties dialog displays. Refer to “Setting Font Properties” on page 59
for specifying appropriate properties in this dialog.

You can click Back to go to the previous dialogs and change or review your
settings.

Creating an Elixir Legacy Font from a Windows Font
To create an Elixir Legacy font from a Windows font:

1

Open a Windows font. For more information, see the “Opening Windows Fonts” on
page 55.

2

From the File menu, click Save.
The Save As dialog displays.
You can also use one of following methods to save an Elixir Legacy font:
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Click
on the Standard toolbar.
Press Control + S on the keyboard.

3

Select Elixir Legacy Font (HDR) from the Save As drop-down list.

4

Click the Elixir folder to save the required file at its default location.
You can also use the Save In drop-down list to search for the required target folder.

5

In the File Name entry box, enter a file name.
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6

To set the output properties:
 Click Edit Property Settings to display the ElixirForm dialog and specify the
appropriate output properties in the dialog. Specify or review the available
category options, and click OK to return to the Save As dialog.
Or
 Click Restore Default Settings to restore the default settings for ElixirForm
dialog.
You can also click
to edit the required property settings or
to restore
the default settings for the output converter. For information on all the options
available in the converter dialogs, click

7

in an open dialog.

Click Save to create an Elixir Legacy font from the selected Windows font.

Creating a Xerox Font from a Windows Font
To create a Xerox font from a Windows font:

1

Open a Windows font in the Font Editor. For more information, see “Opening
Windows Fonts” on page 55.

2

Select Save from the File menu.
The Save As dialog displays.

3

Select Xerox Font (FNT) from the Save As drop-down list.

4

Click the Elixir folder to save the required file at its default location.
You can also use the Save In drop-down list to search for the required target folder.

5

In the File Name entry box, enter a file name.
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6

To specify the output properties:
 Click Edit Property Settings to display the Xerox LPS Resource Writer dialog
and specify the appropriate output properties in the dialog. Specify or review the
available category options, and click OK to return to the Save As dialog.
Or
 Click Restore Default Settings to restore the default settings for Xerox LPS
Resource Writer dialog.
You can also click
to edit the required property settings or
to restore
the default settings for the output converter. For information on all the options
available in the converter dialogs, click

7

in an open dialog.

Click Save to create a Xerox font from the selected Windows font.

Saving Fonts
Font Editor enables you to save fonts to the Xerox format so they can be used on a Xerox
printer.

Saving a Font as an Elixir Legacy Font
To save a font as an Elixir Legacy font:

1

Select Save As from the File menu.
The Save As dialog displays.
You can also use one of following methods to create an Elixir Legacy font:
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Click
on the Standard toolbar.
Press Control + S on the keyboard.

2

Select Elixir Legacy Font (HDR) from the Save As drop-down list.

3

Click the Elixir folder to save the required file at its default location.
You can also use the Save In drop-down list to search for the required target folder.

4

In the File Name entry box, enter a file name.
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5

To set the output properties:
 Click Edit Property Settings to display the ElixirForm dialog and specify the
appropriate output properties in the dialog. Specify or review the available
category options, and click OK to return to the Save As dialog.
Or
 Click Restore Default Settings to restore the default settings for ElixirForm
dialog.
You can also click
to edit the required property settings or
to restore
the default settings for the output converter. For information on all the options
available in the converter dialogs, click

6

in an open dialog.

Click Save.
The font is saved as an Elixir Legacy font. The Messages window displays messages
regarding the location of the font.

The name of Elixir Legacy font is required to have a maximum length of 8
characters.
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Saving a Font as a PCL Font
Font Editor saves non-ASCII format fonts in the PCL format. You can also save Elixir
Legacy, Windows fonts, Xerox fonts as PCL fonts.
To save a font as a PCL font:

1

Open or create the required font.

2

From the File menu, select Save As.
The Save As dialog displays.

3

Select PCL Font (FLJ; PCL) from Save As drop-down list.

4

Click the Elixir folder to save the required file at its default location.
You can also use the Save In drop-down list to search for the required target folder.

5

In the File Name entry box, enter a file name.

6

To set the output properties:
 Click Edit Property Settings to display the PCL dialog and specify the
appropriate output properties in the dialog. Specify or review the available
category options, and click OK to return to the Save As dialog.
Or
 Click Restore Default Settings to restore the default settings for PCL dialog.
You can also click
to edit the required property settings or
to restore
the default settings for the output converter. For information on all the options
available in the converter dialogs, click

7
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in an open dialog.

Click Save.
The font is saved as a PCL font.
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Saving a Xerox Font
To save a font as Xerox font:

1

Open or create the required font.

2

From the File menu, select Save As.
The Save As dialog displays.

3

Select Xerox Font (FNT) from Save As drop-down list.

4

Click the Elixir folder to save the required file at its default location.
You can also use the Save In drop-down list to search for the required target folder.

5

In the File Name entry box, enter a file name.

6

To set the output properties:
 Click Edit Property Settings to display the Xerox LPS Resource Writer dialog
and specify the appropriate output properties in the dialog. Specify or review the
available category options, and click OK to return to the Save As dialog.
Or
 Click Restore Default Settings to restore the default settings for Xerox LPS
Resource Writer dialog.
You can also click
to edit the required property settings or
to restore
the default settings for the output converter. For information on all the options
available in the converter dialogs, click

7

in an open dialog.

Click Save.
The font is saved as a Xerox font (FNT).
When you save a character set using the Save or Save As options from the
File menu, the Font Editor automatically reloads the font to reflect changes
specified in the Converter settings.
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About User Profiles
You can customize Font Editor to meet the requirements of your specific working
environment by creating and maintaining unique user profiles. A profile is a system file
that stores important file locations and other related information for Elixir applications.

Default User Profile
When an Elixir application is installed, a default profile is created and stored in the System
Data.ini file based on the information provided during installation. This file establishes the
basic operating environment and is located at drive:\Documents and Settings\current
user\Application Data\Elixir Technolgies\Profiles. This default profile is created and
opened automatically when an Elixir application is opened for the first time. You can also
create custom profiles using the Profile Editor. These custom profiles can be subsequently
selected using the Profile Selection command. Custom profiles selected for various
DesignPro applications need to be specified separately. A profile selected for one
application does not apply to other applications and sessions.

Selecting a User Profile
To select a profile and view its information:

1

From the Tools menu, select Profile Selection.
The Profile Selection dialog displays.

2

In the Current Profile area, select the required profile from the Profile Name dropdown list.
The INI file path entry box displays the path of the selected profile. The Description
entry box provides a brief narrative describing the selected profile.
You can view the list of pre-defined profile symbols used to identify various
application objects in the Symbols list. The Symbol Value entry box displays
the pre-defined symbol path of the selected profile specifying the location of
application objects.
For more information, refer to “Setting the Symbols Properties” on page 70.

3

68

Click OK.
Any changes specified are saved.
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Custom User Profile
You can also create custom profiles using the Elixir Profile Editor. A customized user
profile is based on the structure of the SystemData.ini file. System Data.ini contains the
default directories, resource maps, and resource libraries used by Elixir applications, as
well as various system settings.
When you create a new profile, Profile Editor automatically creates a corresponding INI
file on the following path in the system: drive:\Documents and
Settings\username\Application Data\Elixir Technologies\Profiles.
Removing a profile deletes the corresponding INI file from the hard disk.
To create a custom profile:

1

From the Tools menu, select Profile Selection.
The Profile Selection dialog displays.

2

Click New.
The Register New Profile dialog displays.

3

In the Profile name entry box, specify a unique name to identify the new user
profile.

4

Click
next to the Profile INI File Path entry box.
The Open Profile Configuration File dialog displays.

5

Specify an appropriate path for the new profile and enter a unique profile name.

6

Click Open to return to the Register New Profile dialog.

7

In the Description text area, enter an optional brief narrative about the new profile.

8

Click OK to create the custom profile. To review additional information on profiles,
refer to the Profile Editor Online Help.
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Setting the Symbols Properties
You can set the default properties for items in the System Data.ini file and also view the
predefined symbols along with the user-defined symbols. Each item represents a Key
(variable) and associated Value (path). Key and Value pairs indicate where to find certain
types of computer information. Keys identify application objects; Values indicate
associated object paths and types.
To set the symbol properties:

1

From the Tools menu, select Options.

2

Select the Symbols category.
The various options are illustrated in the figure below:

Each item represents a Key (variable) and associated Value (path). Key and Value
pairs indicate where to find certain types of computer information.
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3

Review the options and set the object key path and type in the Value entry box. You
can click
to display the Browse for Folder dialog for selecting the required
path.
The value for the selected object key is displayed in the Real entry box.

4

Click Set to set the selected object key path and type.
You can define new symbols using Elixir Profile Editor and use them in the
Resource category in parsers property pages. For more information on user
profiles, refer to the task “About User Profiles” on page 68.

Font Format Properties
When creating fonts in Font Editor, it is important to understand the formats supported by
the application. While creating a font, make sure that all of the required resources
(Windows fonts, code pages, coded fonts and Legacy fonts) are already available. These
resources can reside either on the local machine or on a network drive. Along with Elixir
and Legacy resources, Font Editor also supports Xerox resources without the need of any
pre-conversion. Font Editor supports the following input and output formats:


PCL: Print Control Language.



GDF: Elixir Generic Document Format.



FRM: A compiled Xerox form resource file (Xerox LPS Resource Parser/Writer).

For information on all of the Input and Output Format options, click
available on top-right of the respective parser and converter dialog.

Application format settings enable you to specify the input and output format options for
opening and saving fonts using Font Editor. These settings are applied to all of the new
fonts, as well as to the fonts that do not have an associated Elixir Parameter File (EPM)
(page 78). The application format settings are applicable to all of the ongoing sessions in
the application, therefore, the application-level settings act as default settings for opening
and saving font files in the Font Editor. You can also customize input or output format
settings for opening or saving individual files using the Font Editor.
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Changing Input Format Properties
To change the input format properties:
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1

From the Tools menu, select Application Format Setting, Input Formats.

2

Select the required input formats type from the sub-menu.
The associated input formats dialog displays.

3

Select a Category to view the associated properties.

4

Review the dialog selections and make your changes.
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5

Click Apply and OK to save the settings.

You can also customize input format settings for opening individual files using the Edit
Property Settings button in the Open dialog, which displays the GDF/Elixir Form,
FRM, or PCL property dialog, depending on the file type selected in the Files of Type
drop-down list. You can also restore the default settings for the selected converter or
parser by clicking Restore Default Settings in the Open dialog.

You can also Edit Property Settings or Restore Default Settings using
or

respectively in the Open dialog.

Changing Output Format Properties
To change the output format properties:

1

From the Tools menu, select Application Format Setting, Output Formats.

2

Select the required output format type.
The associated output format dialog displays.

3

Select a Category to view the associated properties.
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4

Review the dialog selections and make your changes.

5

Click Apply and OK to save the settings.

You can also edit the output property settings for saving a font, by clicking Edit Property
Settings in the Save dialog, which displays the GDF/Elixir Form, FRM, or PCL
property dialog, depending on the file type selected in the Save As drop-down list. You
can also restore the default setting of the application by clicking Restore Default Settings
in the Save As dialog.

You can also Edit Property Settings or Restore Default Settings using
or

respectively in the Save As dialog.

Viewing Parser and Converter Properties
You can view properties for all available parsers and converters using Font Editor.
To view the properties of a particular parser or converter:
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1

Select Options from the Tools menu.
The Options dialog displays.

2

Select the Info Server category.
The available Input Parsers, Output Converters, and Output Data Converters display
as a folder tree view. The available options in the folder tree include:
 Input Parsers
 Output Converts
 Output Data Converters
Clicking adjacent to the required folder displays the associated components; each
associated component further contains sub folders that identify the resources such as
forms, images, fonts, etc.
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3

Select the required resource folder to view the related information.
Viewing Resource Folder Example.
Expand the required node
in the tree view.

Information about the
selected component displays
in the associated fields.

4

As appropriate, select or review the following options in the View area:
 Show All Components/Hide Unlicensed Components: displays all components
or only licensed components in the tree. The button alternates between Show All
Components and Hide Unlicensed Components options.
 Refresh: saves any changes and refreshes the folder tree.

5

Review the following options in the Component area:
 Name: displays a unique name identifying the selected converter or parser.
 ID: displays a unique code identifying the selected converter or parser.
 Presentation: displays the text that appears in the file filters of the Open and
Save dialogs corresponding to the selected converter or parser.

6

Click Apply and OK to save the settings.
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Registering New File Extensions
Font Editor lets you register new file extensions for any selected font resource in a
converter or parser. For example, the extension for an Elixir font is HDR. You can change
and register the extension of the Elixir font by changing it in the Extensions entry box.
This will change the input or output Files of Type/Save As filter in the Open or Save As
dialogs respectively.
To register new file extensions:

1

From the Tools menu, select Options to display the Options dialog.

2

From the Info Server category, select a resource type from the tree view to set
associated file extensions.
The Presentation entry box specifies a unique name identifying the selected resource
node of the specified component (parser or converter). All existing file extensions
are associated with the selected component display in the Extensions entry box.

3

Add the new extension to the Extensions entry box.
You can add multiple extensions for a selected component. Each extension is
separated by a semi-colon. You can set an extension as the default extension for
a selected resource by clicking Default.
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These changes are added and registered as supported file format extensions in the
input or output Files of Type filter available in the Open or Save dialogs.

The Extensions setting applies to file extensions only and does not affect the
supported file formats.

4

Click Apply and OK.
To view the applied changes, you need to reopen the application.

The image below shows the process of changing resource extensions in the Xerox toolset.

1. Select the required
node in the tree view.

2. Specify the new
extension in the
Extensions entry box.

Sets the extension to
its default value.
The modified extension displays
in the Files of Type/Save As
drop-down list in the Open or
Save As dialogs.

Changing resource extensions of an Elixir Legacy font.
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Elixir Parameter File (EPM)
You can save your input and output file format settings in an Elixir Parameter File (.EPM)
so that the settings are not lost or forgotten between sessions.You can use EPM files to
transfer setting information to other PCs in your workgroup.
Although an EPM file can hold settings for both input and output files, it is recommended
to save separate EPM files for the input and output so that they can be used for different
conversion combinations.

Saving an EPM File
You can save your input and output file format settings to an EPM file at the application
level. The application level settings apply to the whole application.
To save an EPM file:

1

From the Tools menu, select Application Format Setting, Save to save an
application level EPM file.
The Export Setup File dialog displays.

2

Use the Save In drop-down list to search for the required target folder.

3

Select Setup Files (EPM) from the Save As Type drop-down list.

4

In the File Name entry box, enter a file name.

5

Click Save to save the setup file.

Clearing an EPM File
You can unload an EPM file and restore the default file format settings at the application
level using Font Editor.
To clear or restore defaults for an EPM file:
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1

From the Tools menu, select Application Format Setting, Clear to restore defaults
for an application level setup file.
An information message is displayed.

2

Click Yes to restore the default settings for the setup file.
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Opening an EPM File
You can load input and output file format settings from an EPM file at the application
level using Font Editor. The default Elixir Parameter files are located at drive:\Documents
and Settings\current user\Application Data\Elixir Technologies.
To open an EPM file:

1

Do one of the following:
 From the Tools menu, select Application Format Setting, Load to load an
application level EPM file.
Or
 From the Tools menu, select Document Format Setting, Load to load a
document level EPM file.
The Load Setup File dialog displays.

2

Browse for the target file using the Look In drop-down list.

3

Select the required file and click Open to open the setup file.
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Chapter 5:

Editing Fonts
In this chapter...


Editing Fonts Overview



Working with Fonts



Formatting Fonts



Using Drawing Tools

Editing Fonts Overview
The DesignPro Font Editor provides tools for editing individual character bitmaps to
create customized fonts. Customized fonts are used to create company logos, corporate
fonts, and signature fonts without the surplus characters to manage the fonts more
efficiently. The fonts process and print faster than images making the print operation
efficient.
Directly below the menu bar are toolbars with buttons that provide access to various font
modification tools. See Appendix A: “Workspace Quick Reference” on page 133, for
information on menus and toolbars.
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Font Characteristics
Elixir fonts are placed in drive:\Elixir\Fonts\Elixir directory during installation. The font
stem name provides information about the font type. For example, HE07NP is a Helvetica
7-point, normal portrait font.
The figure illustrates characteristics of a character in a cell:

Above
Baseline

Below
Baseline

Cell Width

Character attributes.
The character attributes are explained as follows:
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Blanks Left: blank dots to the left of the characters.



Blanks Right: blank dots to the right of the characters.



Baseline Offset: characters in a font are aligned with an imaginary line called the
baseline The baseline is used to align characters horizontally. The character baseline
offset specifies where to place the character relative to the character baseline.
Baseline offset is the distance between the baseline and the character glyph bottom.
If the bitmap is above the baseline, the offset will be positive and if the bitmap is
below the baseline, the value will be negative.



Above Baseline: distance from the baseline to the top edge of the character cell. This
is equal to cell height - baseline.



Below Baseline: distance from the baseline to the bottom edge of the character cell.



Cell Width: width of the character box.
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The figure illustrating the character and line-spacing attributes on a printed page:

After Baseline

Line-spacing

Below Baseline
Leading

Character and line attributes.
Line spacing is defined as the space, expressed in points, between lines of text, measured
from the baseline (bottom) of one line to the baseline of the next.
The following formula is used to calculate line spacing:
Line Spacing = Above Baseline + Below Baseline + Leading
Leading is the additional space that can be inserted between rows of character raster
patterns to alter the line spacing value for the font.

For more information on the font properties, see the section “Font
Characteristics” on page 41 in Chapter 3: “Font Structure” on page 39.
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Working with Fonts
The Font Editor helps you to modify individual and multiple characters in a character set
using the standard operations like copying and pasting, adding characters to a character
set, and swapping characters in a character set.

Selecting and Deselecting Characters
The Font Editor provides the following three options for the selection of character(s) in
the Character Set window:


To select an individual character, click the required character in the Character Set
window. The character is selected.



To select multiple characters, press Control and click on the other required
characters in the Character Set window. The characters are selected.
To select a range of continuous characters, select the first character in the required
range, press Shift and select the last required character. All of the characters in the
range of the first and last characters are selected.



You can select all characters in a character set by selecting Select All from the Edit
menu.

You can click anywhere in the white area between the character cells or in the Character
Set window to cancel all selections made.

You can also press Control + A on the keyboard to select all of the characters in
the character set.
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Copying and Pasting Characters
The Font Editor can copy and paste individual and multiple characters within a character
set.

Copying and Pasting Individual Characters
To copy and paste a character in a character set:

1

Select the required character from the Character Set window.

2

From the Edit menu, select Copy.
You can also copy the selected character by one of the following methods:




Click
on the Standard toolbar.
Right-click the character and select Copy from the pop-up menu.
Press Control + C on the keyboard.

To make a copy of a character within the same character set, you can use the
copy/paste method.

3

Select the required target character from the character set.

4

From the Edit menu, select Paste.
The New GCID dialog displays. This dialog displays if a duplicate GCID already
exists in the character set.
You can also paste a character by selecting the target character, and performing
one of the following:




Click
on the Standard toolbar.
Right-click the character and select Paste from the pop-up menu.
Press Control + V on the keyboard.

The entry box displays a GCID value suggested by the Font Editor.
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5

Review the existing value or enter a new GCID value in the entry box.

6

Click OK.
The copied character is pasted to the target cell.

Cutting Individual Characters
To cut individual characters in a character set:

1

Select the required character in the Character Set window.

2

From the Edit menu, select Cut.
The selected character is removed from the character set.
You can also cut a character using one of the following methods:




Click
on the Standard toolbar.
Right-click the character and select Cut from the pop-up menu.
Press Control + X on the keyboard.

Copying and Pasting Multiple Characters
To copy and paste multiple characters in a character set:

1

To select non-adjacent characters, select a character in the Character Set window,
press Control, and click each additional character.
You can also select adjacent files by selecting the first file in the sequence, press
Shift and click the last file. See “Selecting and Deselecting Characters” on page
84 for more information.

2

From the Edit menu, select Copy.

3

Select the required target characters in the Character Set window.
If the number of target characters selected is less than the copied source
characters, the number of pasted characters will be the same as the selected
target characters.
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4

From the Edit menu, select Paste.
The selected characters are pasted on the target character cells as shown in the
following image:
1. Select multiple characters in the Character Set
window and press Control + C on the keyboard.

2. Select the target characters
in the Character Set window.

3. Press Control + V to
paste the selected

An example of copying and pasting multiple characters.
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Adding Characters to a Character Set
You can add characters from one character set to another by dragging the required
character onto the target character set.
To merge characters:

1

Open the required character sets in the Font Editor.
You will add the character from the source character set to the target character set.

You can select Tile from the Windows menu to arrange windows in the Font
Editor workspace.

2

Select required character in the Source character set.

3

Click and drag the required character from the source character set to the Target
character set.
The selected character is added to the Target character set.
Source character set

Target character set

Merging characters from the Source character set to the Target character set.
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Undoing a Change
The Font Editor keeps track of your editing and formatting changes. You can undo a
change or a command selection by reversing the previous actions. To undo a change,
select Undo from Edit menu.
You can also use the following methods to undo a change:



Click
on the Standard toolbar.
Press Control + Z on the keyboard.

Formatting Fonts
The character formatting tools helps to swap, kill, and modify individual characters. These
tools can also be used to set the properties of the character set. You can open multiple
fonts, and copy or replace font characters. The Formatting toolbar is active only when a
character set is opened in the Font Editor workspace.

Swapping Characters
You can switch the positions of two characters in a character set using the swap character
tool. Note that you can only swap characters in the same character set.
To swap characters in a character set:

1

Select a character in the Character Set window.

2

Right-click the selected character and select Swap Character from the pop-up
menu.

You can also click
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on the Formatting toolbar to swap a character.
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3

In the Character Set window, select another character for swapping with the
previously selected character.
The character positions are switched, as shown in the image below:
Select this character to switch
with the selected character.

Before swapping characters.

After swapping characters.
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Replacing Non-Blank Characters with Blank Characters
Font Editor replaces non-blank characters with spacing characters in the character set.
To replace non-blank characters with spacing characters:

1

Select a character in the Character Set window.

2

Right-click the selected character and select Blank Character from the pop-up
menu.
The selected character is replaced with a spacing character.

You can also click
on the Formatting toolbar and select Blank from the
pop-up menu to replace a character with a blank character.

An example of replacing a non-blank character.

You can also replace multiple characters in the Character Set window with
blank characters using the same method.
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Deleting Characters
The Font Editor provides the kill character tool to either delete the entire character or
remove the character glyph from the selected character.
The Delete option is enabled only for the AFP character sets. To delete
characters from a non-AFP character set, reformat the character set to an AFP
character set.

To delete a character from the character set:

1

Select a character in the Character Set window.

2

Right-click the selected character and select Kill Character, Delete from the pop-up
menu.
The selected character is deleted from the character set.

You can also click
on the Formatting toolbar and select Delete from the
drop-down menu to delete a character.

An example of deleting characters from the character set.
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Importing Images in a Font
You can import images in the selected character cell using the Import Image tool. The
supported image formats for importing images are:


Bitmap files (BMP)



Elixir Legacy graphics (LP3)



IMG files (IMG)



JPG files (JPG)



PC Paintbrush Bitmap Format files (PCX)



PCL files (PRN).



Tagged Image Format files (TIF)

Importing Images
To import images into a character cell:

1

Select the required character in the Character Set window.

2

From the Tools menu, select Import Image.
The Open dialog displays.

You can also click
on the Formatting toolbar to import an image to a
character in the Character Set window.

3

In the Open dialog, select the required file type from the Files of Type drop-down
list.
Selecting the Elixir icon in the left dialog pane automatically locates the target folder
based on the selected file type. For example, when you select Elixir Legacy Files
from Files of Type drop-down list, and then select Elixir from the side pane, the
default path for selecting the image is automatically set to drive:\Elixir\Pics\Elixir.

4

Select the required image and click Open.
The selected image is imported in the Font Editor workspace.
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Cell Resize Options
If the size of the imported image is larger than the size of the character, the Cell
Resize Option dialog displays. You can select one of the following resize options
for importing the image into the character set:
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E: extends the selected characters cell beyond its boundaries to fit the
imported image in the cell. The character cell cannot be extended beyond
the cell width limit for fonts.
S: skips the importing operation for the selected character.
A: aborts the importing operation for all of the selected characters and
returns to the application without importing.
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Character Properties
You can view and set individual character properties for font character sets and code
pages.

Setting Font Character Properties
To set the properties of font characters:

1

Select a character in the Character Set window.

2

Right-click the selected character and select Properties from the pop-up menu.
The Character Properties dialog displays.

You can also click
Properties dialog.

on the Formatting toolbar to view the Character

Specify the character
properties in this
area.

Select a character
type in this area.

Specify the
floating accent
options using
this area.

Specifying the font character properties.
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3

Enter or review the following options:
 Cell Width: sets the character cell width (character width or delta-X).
 Baseline Offset: sets the character baseline offset in pels It is measured from the
character bitmap bottom to the character baseline.
 Blanks Left: sets the distance between the character cell left edge and the
character bitmap start in pels.
 Blanks Right: displays the distance between the character bitmap right edge and
the right character cell edge in pels.
 Left Kerning: sets the character left kerning in pels 9700 family printers do not
support this option.
 Character Number: displays the font character ordinate position in decimal.
 Equiv ASCII Char: displays the font character ASCII character equivalent.
 Equiv Hex Char: displays the font character hexadecimal character equivalent.
 Bitmap Width: displays the character bitmap width in pels.
 Bitmap Height: displays the character bitmap height in pels.

4

In the Character Type area, select the required character type option from the
following:
 Nonblank: sets the character type to non-blank.
 Spacing: sets the character type to spacing.
 Null: sets the character type to null.

5

In the Floating Accent area, select one of the following options:
 High Accent: maps high accent position to the character.
 No Accent: accent position is not mapped to the character.
 Low Accent: maps low accent position to the character.

6

Click Prev to view the preceding character properties.

7

Click Next to view the next character properties.

When selecting the Next or Previous buttons, a confirmation message displays
if the character properties are changed. Click Yes to accept the changes.

8
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Click OK to save changes and return to the Font Editor workspace.
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Setting Null Character Properties
To set the properties of a null character:

1

Select a null character in the Character Set window.

2

Right-click the selected character and select Properties from the pop-up menu.
The Properties of Null Character dialog displays.

You can also click
on the Formatting toolbar to view the Properties of
Null Character dialog.

3

Review the following options:
Character Number: displays the font character coordinate position in decimal.
 Equiv ASCII Char: displays the font character ASCII character equivalent.
 (Hex): displays the font character hexadecimal character equivalent.


4

In the Character Type area, select a character type. The options include:
 Null: sets the selected character to null.
 Spacing: sets the selected character to spacing character.

5

Click Prev to view the preceding character properties.

6

Click Next to view the next character properties.

When selecting the Next or Previous buttons, a confirmation message displays
if the character properties are changed. Click Yes to accept the changes.

7

Click OK to save changes and return to the Font Editor workspace.
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Setting Spacing Character Properties
To set the spacing character properties:

1

Select a spacing character in the Character Set window.

2

Right-click the selected character and select Properties from the pop-up menu.
The Properties of Spacing Character dialog displays.

You can also click
on the Formatting toolbar to view the Properties of
Spacing Character dialog.

3

Review the following spacing character properties information:
 Character Number: displays the font character ordinate position in decimal.
 Equiv ASCII Char: displays the font character ASCII character equivalent.
 (Hex): displays the font character hexadecimal character equivalent.

4

Select the required character type option from the following:
 Spacing: sets the character type to spacing.
 Null: sets the character type to null.

5

Click Prev to view the preceding character properties.

6

Click Next to view the next character properties.

When selecting the Next or Previous buttons, a confirmation message displays
if the character properties are changed. Click Yes to accept the changes.

7
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Click OK to save changes and return to the Font Editor workspace.
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Font Properties
The Font Editor enables you to view and set the font properties for Xerox fonts.

Setting Character Set Properties
To set the font properties for a Xerox font:

1

Click
on the Formatting toolbar.
The Font Properties dialog displays.

2

Click the Font Properties tab.
For more information on this tab, see “Setting Font Properties” on page 59 in
Chapter 4: “Font Editor Basics”.

3

Click the HPPCL Properties tab to set the typeface properties.

4

Click the Xerox 9700/5Word Properties tab to specify the Xerox font properties.
Refer to “Setting Xerox 9700/5Word Properties” on page 100 for more information
on setting the Xerox font properties.

5

Click Apply, and then click OK to save the settings and return to the Font Editor
workspace.

Setting HPPCL Properties
The HPPCL Properties enables you to review and specify Xerox font typeface properties.
To set the properties, select the HPPCL tab in the Font Properties dialog:

1

Specify the following:
 Typeface Name: sets a unique name identifying the character set.
 Typeface: sets the character cell width (character width or delta-X).
 Symbol Set: sets the character cell width (character width or delta-X).

2

In the Style area, use the Stroke Weight drop-down list to select the required weight
style of a straight or curved line that is used to create character shape.

3

In the Style area, check Italic to italicize the font characters.

4

Click Apply, and then click OK to save the settings and return to the Font Editor
workspace.
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Setting Xerox 9700/5Word Properties
The Xerox 9700/5Word Properties tab enables you to review and specify Xerox font
properties. Refer to “Setting Character Set Properties” on page 99 for instructions on
setting font properties.
To set the Xerox 9700/5Word Properties:

1

In the Internal Name entry box, review the name assigned to the font by the Font
Editor.

2

In the Revision entry box, enter a unique name for the font. The maximum limit for
the length of the specified name is 2 characters.

3

In the Version entry box, specify a version name. The maximum limit for the length
of the specified version is 2 characters.

4

In Library entry box, enter a library name. The maximum limit for the length of
specified library name is 10 characters.

5

You can review the size of the memory from Memory Size.

6

Click Apply, and then click OK to save the settings and return to the Font Editor
workspace.

Using Drawing Tools
The Font Editor provides drawing tools for editing individual character bitmaps. The
drawing tools are located on the Drawing toolbar and are enabled only when a character is
open in the edit mode. To show or hide the Drawing toolbar, click the View menu and
select Toolbars, Drawing from the drop-down menu.

Editing Characters
You perform editing operations using the drawing tools in the Edit mode. To switch to the
Edit mode, double click a character in the Character Set window.

You can also edit a character by selecting the character in the Character Set
window and clicking
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on the Formatting toolbar.
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In the Edit mode, the Character Set window splits into three panes, as shown in the
image below:

The Character Set window splits into three panes in Edit mode.
The characters in a character set display in the Character Set pane at the lower end of the
Character Set window. The selected character displays in a magnified view in the Editing
pane.
The character bitmap displays as dots in the editing pane. A character initially displays at
8X magnification. Each dot in the bitmap displays as a black or white box that is 8 bits
high and 8 bits wide.
Font Editor enables you to perform the following functions in the Edit mode:


To view characters in the Editing pane at a larger magnification, click
View toolbar.



To Zoom out, click



To view grid in the Editing pane, click

in the View toolbar.



You can exit the edit mode by clicking

on the Formatting toolbar.
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in the

in the View toolbar.
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Selecting Areas
You can use the Select tool in Font Editor to copy and paste a rectangular area in a
character cell. The Select tool also enables you to define straight-edged areas that you can
move or make changes to in the character.
Copying Selected Area
To copy areas in a character cell:

1

Double-click the required character in the Character Set window.
The selected character opens in the Edit mode.

2

Click
on the Drawing toolbar.
The Toolbox displays the associated options.

3

To copy a part of the character glyph, click

4

Draw a marquee around the area that you want to copy.

5

Click and drag to place the selected area at the required location.

under the Select area in the Toolbox.

Example of moving the selected area.

6
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Click

on the Standard toolbar to apply changes to the selected character.
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Moving Selected Area
To move areas in a character cell:

1

Double-click the required character in the Character Set window.
The selected character opens in the Edit mode.

2

Click
on the Drawing toolbar.
The Toolbox displays the associated options.

3

To move a part of the character glyph, click

4

Draw a marquee around the area that you want to move.

5

Click and drag to place the selected area at the required location.

under the Select area in the Toolbox.

Example of copying the selected area.

6

Click
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on the Standard toolbar to apply changes to the selected character.
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Drawing Lines
You can use the line tool to draw lines in a character cell.
To draw a line:

1

Double-click the required character in the Character Set window.
The selected character opens in the Edit mode.

2

Click
on the Drawing toolbar.
The Toolbox displays the associated options.

3

Enter the required line width (in dots) in the Thickness entry box.

4

In the Color area, click one of the following buttons for specifying a line color:


sets the line color to white.



sets the line color to black.



5

sets the line color to inverse. The line is drawn in the color opposite to the
background color.

Click the required area in the character cell and drag the mouse to draw a line.

Examples of line thickness.

6
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Click

on the Standard toolbar to apply changes to the selected character.
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Drawing Boxes
You can use the box tool to draw hollow or filled boxes in a character cell.
To draw a box:

1

Double-click the required character in the Character Set window.
The selected character opens in the Edit mode.

2

Click
on the Drawing toolbar.
The Toolbox displays the associated options.

3

Enter the required border width in dots in the Thickness entry box.

4

In the Color area, click one of the following for specifying a box color:


: sets the box color to white.



: sets the box color to black.



5

6

: sets the box color to inverse. The box is drawn in the color opposite to the
background color.

In the Fill area, select one of the following box fill type options:


: sets the box type to hollow.



: sets the box type to filled.

Click the required area in the character cell and drag the mouse to draw a box.

A box is drawn over the character “a” with invert and fill options selected.

7

Click
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on the Standard toolbar to apply changes to the selected character.
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Using a Box as an Eraser
You can use the box tool to erase objects in a character cell.
To use the box tool as an eraser:

1

Double-click the required character in the Character Set window.
The selected character opens in the Edit mode.

2

Click
on the Drawing toolbar.
The Toolbox displays the associated options.

3

Set the box color similar to the background color of the character cell for erasing
objects.
For more information on drawing boxes, refer to “Drawing Boxes” on page 105.

The selected area is erased using the box tool.

4

Click

on the Standard toolbar to apply changes to the selected character.

Drawing Circles
You can use the circle tool to draw hollow or filled boxes in a character cell.
To draw a circle:
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1

Double-click the required character in the Character Set window.
The selected character opens in the Edit mode.

2

Click
on the Drawing toolbar.
The Toolbox displays the associated options.

3

Enter the required line thickness in dots in the Thickness entry box.
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4

In the Color area, click one of the following for specifying circle color:


: sets the circle color to white.



: sets the circle color to black.



5

6

: sets the circle color to inverse. The circle is drawn in the color opposite to
the background color.

In the Fill area, select the circle fill type option from the following:


: sets the circle type to hollow.



: sets the circle type to filled.

Click the required area in the character cell and drag the mouse to draw a circle.

Circle examples.

7

Click
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on the Standard toolbar to apply changes to the selected character.
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Drawing Dots
You can use the dot tool to draw dots in a character cell.
To draw a dot:

1

Double-click the required character in the Character Set window.
The selected character opens in the Edit mode.

2

Click
on the Drawing toolbar.
The Toolbox displays the associated options.

3

Enter the required dot thickness in dots in the Thickness entry box.

4

In the Color area, click one of the following for specifying the dot color option:


: sets the dot color to white.



: sets the dot color to black.



5

: sets the dot color to inverse. The dot is drawn in the color opposite to the
background color.

Click the required area in the character cell to draw a dot.

Dot thickness example.

6
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Click

on the Standard toolbar to apply changes to the selected character.
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Using the Brush Tool
You can use the brush tool to paint continuous strokes in black, white, or invert colors with
a specified thickness.
To paint using the brush tool:

1

Double-click the required character in the Character Set window.
The selected character opens in the Edit mode.

2

Click
on the Drawing toolbar.
The Toolbox displays the associated options.

3

Enter the required brush tip thickness in dots in the Thickness entry box.

4

In the Color area, click one of the following for specifying the painting color option:


: sets the brush color to white.



: sets the brush color to black.



5

: sets the brush color to inverse. The object is drawn in the color opposite to
the background color.

Click and drag the brush tip in the required area in a character cell to paint.

Brush Paint Example.

6

Click
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on the Standard toolbar to apply changes to the selected character.
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Using the Preview Tool
The preview tool displays a font-preview pad for viewing how text created with the
current font will display at print time. You can use the keyboard or alternatively click on
characters in the Character Set window to place characters on the sampling pad. You can
also proof-print the sampling pad (text prints as bitmaps). The preview tool also enables
tools for viewing character baseline, kerning effect, and for clearing the sampling area.

Sampling a Font
To sample a font:

1

Open the required font in the Font Editor.

2

Click
on the Preview toolbar.
The Preview pane displays and the preview tools are enabled.

3

Click the required characters to enter text for viewing in the Preview pane.

Preview pane

Sampling fonts.

4
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You can perform the following functions using the Preview toolbar:


Click
text.

on the Preview toolbar to display the baseline along with the entered



Click

on the Preview toolbar to see the kerning effect on character pairs.



Click
pane.

on the Preview toolbar to clear all of the text entered in the Preview



You can click

to exit the Preview pane.
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Chapter 6:

Transform Tools
In this chapter...


Using Character Transform Tools



Inverting Character Color



Positioning Characters



Blending Characters

Using Character Transform Tools
The DesignPro Font Editor can transform characters by selecting Transform toolbar
options such as resize, rotate, shift, slant, darken, lighten, slim, underline, reverse, filter,
outline, mirror, and halftone individual characters or fonts. The transformations are editing
functions used to change font character print characteristics. You can apply transform
operations for a single character, all characters in a font, or the font character set.

You can hide or display the Transform toolbar by selecting Toolbars,
Transform from the View menu.
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The Transform toolbar is active only when a character set is opened in the Character Set
window. Selecting a tool from the Transform toolbar displays the associated options in
the Toolbox. You can also use the transform tools to create and transform the character set
or selected characters. The figure below illustrates different transformations applied to a
single character:

Transformations example.
The following sections describe transform tools and the use of transform commands for
customizing fonts.

112



Inverting Character Color (page 113)



Resizing Characters (page 114)



Rotating Characters (page 116)



Flipping Characters (page 117)



Positioning Characters (page 118)



Distorting Characters (page 119)



Filtering Characters (page 120)



Applying Halftone to Characters (page 122)



Darkening Characters (page 125)



Lightening Characters (page 126)



Outlining Characters (page 127)



Slimming Characters (page 128)



Blending Characters (page 129)



Underlining Characters (page 130)
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Inverting Character Color
To invert/reverse black and white colors in single or multiple font characters:

1

Select the required character in the Character Set window.
You can also select multiple characters in the Character Set window for inverting
colors.

You can also double-click a character to open it in the Editing pane in the
Character Set window.

2

Click

3

Click
on the Toolbox to apply the settings.
The colors of the selected character(s) are inverted.

on the Transform toolbar.

Click
to invert colors for the selected
characters in the character set.

Inverting color for the selected characters using the Invert tool. All black dots in
each character are changed to white, and vice versa.
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Resizing Characters
To resize single or multiple font characters:

114

1

Select the required character in the Character Set window.
For resizing multiple characters simultaneously, select multiple characters in the
Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

In the Point Size entry box, enter the required value for the character point size.
The character point size specifies the size of the character.

4

Check Filter Bitmap option to remove un even edges and single bits after resizing
the character(s).

5

In the Horizontal Proportion area, specify the following:
 Increase: increases the character width by the percent specified.
 Decrease: decreases the character width by the percent specified.
 By Amount: sets the character width increase/decrease percentages.

6

In the Vertical Proportion area, specify the following:
 Increase: increases the character height by the percent specified.
 Decrease: decreases the character height by the percent specified.
 By Amount: sets the character height increase/decrease percentages.
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7

Click
in the Toolbox to apply the settings.
The Character Set window updates.

To minimize distortion, resize in one step rather than performing repeated resize
operations.

Resize example: Character “O” is resized with point size set to 6 and the Filter
Bitmap option selected. In this example, the Horizontal proportion increased by 5
percent and the Vertical proportion decreased by 15 percent.
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Rotating Characters
To rotate single or multiple font characters:

1

Select the required character in the Character Set window.
For rotating multiple characters simultaneously, select multiple characters in the
Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

In the Rotate area, select one of the following rotation options:
 90 Clockwise: rotates the character(s) clockwise in 90-degree increments.
 90 Counter Clockwise: rotates the character(s) counter clockwise in 90-degree
increments.

4

Click
to apply the settings.
The Character Set window updates.

90 Clockwise
Rotation

Original
Character

90 Counter
Clockwise Rotation

Rotation examples.
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Flipping Characters
To flip/mirror single or multiple font characters:

1

Select the required character in the Character Set window.
For flipping multiple characters simultaneously, select multiple characters in the
Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

In the Flip area, select one of the following options for character flipping:
 Horizontal: flips the character(s) horizontally.
 Vertical: flips the character(s) vertically.

4

Click
to apply the settings.
The Character Set window updates.
Flip Examples.

Original
Character

Horizontal
Flip
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Vertical
Flip

Horizontal
Vertical Flip

117

Positioning Characters
To shift/position single or multiple font characters:

1

Select the required character(s).

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

In the Pixels entry box, enter the number of pixels for the shift direction. Specify a
value between 1 and 99.

4

In the Direction area, select one of the following shift direction options:
 Left: shifts the pixel(s) to the left.
 Right: shifts the pixel(s) to the right.
 Top: shifts the pixel(s) to the top.
 Bottom: shifts the pixel(s) to the bottom.

5

Click
to apply the settings.
The Character Set window updates.

1. Specify the required
properties in the Position
area in the Toolbox.
2. Click
to apply the
settings and update the
Character Set window.

Positioning example: The selected characters are positioned to the right by 25
pixels.
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Distorting Characters
To slant/distort single or multiple font characters:

1

Select the required character in the Character Set window.
For performing the distort operation on multiple characters simultaneously, select
multiple characters in the Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

In the Pixels entry box, enter the number of pixels for the slant direction. You can
specify a value between 4 and 255.

4

In the Direction area, select one of the following character(s) slant directions:
 Left: slants the pixel(s) to the left.
 Right: slants the pixel(s) to the right.
 Top: slants the pixel(s) to the top.
 Bottom: slants the pixel(s) to the bottom.

5

Click
to apply the settings.
The Character Set window updates.

Click
tool for applying distortion to the
selected characters in the Character Set
window.

Distortion example: The selected characters are distorted to the right by 9 pixels.
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Filtering Characters
Filtering option in the Font Editor cleans rough edges on black and white fonts. The
scanned characters generally have a number of marks and smudges that need to be cleaned
up; they usually show up as extra hanging pixels around the text.
To filter single or multiple font characters:
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1

Select the required character in the Character Set window.
For filtering multiple characters simultaneously, select multiple characters in the
Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

In the Sharp Corners area, select an option for softening the sharp corners:
 Black: smooths the character corners by adding or removing the black bits.
 White: smooths the character corners by adding or removing the white bits.

4

In the Hanging Bits area, select an option to delete pixels hanging off the character:
 Black: filters black hanging bits.
 White: filters white hanging bits.
This option is used to filter ragged bits of the selected character. The hanging bits
represent bits that are part of a character bitmap, but are suspended on the outer
edges of the character bitmap.

5

In the Single Bits area, select an option to delete the pixels added through the
scanning process:
 Black: filters single black bits.
 White: filters single white bits.
This option is used to filter single bits of the selected character area. The single bits
represent independent bits that are scattered within a character bitmap.
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6

Click
to apply the settings.
The Character Set window updates.

To clean rough edges on black and white signatures and logos, select and apply all
six filtering algorithms from the Toolbox.

Single bits
Hanging bits

Character shows hanging and single black bits.

It is recommended that you apply filter to a single character to see the effect of
different filtering options. Repeatedly filtering the font might distort the font.
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Applying Halftone to Characters
Halftone screen option converts grayscale characters to simulated halftone dots. You can
apply different halftone screens to the same characters to achieve different effects.
To apply line or shading patterns to a character:

1

Select the required character in the Character Set window.
For applying halftoning to multiple characters simultaneously, select multiple
characters in the Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

Under Halftone Area, select one of the following options for applying a halftone
pattern:
 Background: applies pattern to the character background.
 Foreground: applies pattern to the character foreground.
 Include Outline: applies outline to the character(s).
 Width: sets character outline width value (in dots).
This option is enabled only when Include Outline is checked.

4

Select the required halftone pattern option from the following:
 Pattern: applies shading pattern to halftone.
 Line: applies line pattern to halftone.

For more information on pattern options, see “Selecting Patterns” on page 123.

5

Set the required halftone line pattern option from the following:


: applies horizontal line pattern.



: applies vertical line pattern.



: applies left diagonal (45°) line pattern.

: applies right diagonal (135°) line pattern.
These options are enabled only when Line is selected from above.
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6

Set the halftone line style option from the following:
 Separation: sets character line frequency, per inch of halftone.
 Width: sets character line width, per inch of halftone.
These options are enabled when Line option is selected.

7

Click
to apply the settings.
The Character Set window updates.
The Preview pane displays the halftoning line effects
applied to the characters in the character set.

Selecting Patterns
Font Editor applies halftone to characters with different patterns. For more information on
halftoning options, see the “Applying Halftone to Characters” on page 122. The Font
Editor features a number of pre-defined shading patterns to meet the requirements.
To select the required pattern:

1

Select the required character in the Character Set window.
For specifying a pattern for multiple characters simultaneously, select multiple
characters in the Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.
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3

Click
on the Toolbox.
The Patterns dialog displays.

4

Select the required fill pattern design from Available Designs.

5

Set the B/W Category specifying the black and white pattern style option from the
following:
 Tristate: uses the tristate pattern style.
 Standard: uses the standard pattern style.
 Screen: uses the screen pattern style.
You can view a sample of the selected pattern in the Preview area.

6

Click OK to save changes and return to the Font Editor workspace.

Halftone examples.

124

DesignPro Tools Font Editor® for Xerox User Guide

Darkening Characters
To darken single or multiple font characters:

1

Select the required character in the Character Set window.
For darkening multiple characters simultaneously, select multiple characters in the
Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

In the Pixels entry box, enter the number of pixels to add for darkening the character.

4

Set the character darkening direction option from the following:
 Left: darkens the character(s) from the left.
 Right: darkens the character(s) from the right.
 Top: darkens the character(s) from the top.
 Bottom: darkens the character(s) from the bottom.

5

Click
to apply the settings.
The Character Set window updates.

Darkening example: Character “A” is darkened from the top with Pixels set to 5.
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Lightening Characters
To lighten single or multiple font characters:

1

Select the required character in the Character Set window.
For lightening multiple characters simultaneously, select multiple characters in the
Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

In the Pixels entry box, enter the number of black pixels to compress (for character
lightening).

4

In the Direction area, set the required character lightening direction option from the
following:
 Left: lightens the character(s) from the left.
 Right: lightens the character(s) from the right.
 Top: lightens the character(s) from the top.
 Bottom: lightens the character(s) from the bottom.

5

Click
to apply the settings.
The Character Set window updates.

You cannot reverse a lighten operation by using
, however, you can use the
undo option using the Standard toolbar to restore pre-lightened character(s).

Lightening example: Character “A” is lightened from the bottom with Pixels set to 4.
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Outlining Characters
To outline single or multiple font characters:

1

Select the required character in the Character Set window.
You can outline multiple characters simultaneously, by selecting multiple characters
in the Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

In the Width entry box, enter the outline width (in points) for the selected
character(s).

4

Click
to apply the settings.
The Character Set window updates.

Outline example: Character “A” is outlined with Width set to 1.
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Slimming Characters
Font Editor provides the slimming feature to narrow the character within its borders. This
feature is available only for black and white fonts.
To narrow single or multiple font characters:

1

Select the required character in the Character Set window.
For performing the slim operation on multiple characters simultaneously, select
multiple characters in the Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

Under the Slimming area, select one of the following options for the direction of
slimming in a character:
 Top Right: reduces dots from the top and the right side of the character(s).
 Bottom Right: reduces dots from the bottom and the right side of the
character(s).
 Right: reduces dots from the right side only.

4

Click
to apply the settings.
The Character Set window updates.

Slimming example: Character “A” is slimmed using the Top Right option.
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Blending Characters
The Font Editor blend tool blends other characters with a specified character in a character
cell. The blend tool is enabled only in the edit mode.
To blend characters:

1

Double-click the required character in the Character Set window.
The Editing pane displays in the Character Set window. The character can be viewed
from the Editing pane.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

Select another character from the Character Set window to blend with the character
open in the Edit mode.
Both characters are blended and can be viewed in the Editing pane.

The example displays blended characters in the Editing pane of Font Editor.
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4

Click

on the Standard toolbar to update changes.

Blended characters after update.

Once the required characters are blended, deselect the blend tool before
selecting any other characters from the Character Set window. With the blend
tool selected, any subsequent character selections would also blend with the
character open in the edit mode.

Underlining Characters
To underline single or multiple font characters:
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1

Select the required character in the Character Set window.
For underlining multiple characters simultaneously, select multiple characters in the
Character Set window.

2

Click
on the Transform toolbar.
The Toolbox displays the associated options.

3

Enter a value in the Baseline entry box. The line is drawn at the specified distance
(value in pixels) above or below the character(s) baseline.

4

Enter a value in the Thickness entry box. The line is drawn with the specified
thickness (value in dots) above or below the character(s) baseline.
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5

In the Position area, select an underline position from one of the following:
 Above: draws line above the character(s).
 Below: draws line below the character(s).

6

In the Width area, select an underline width from one of the following:
 Cell: draws line across the cell(s).
 Character: draws line across the character(s).

7

Click
to apply the settings.
The Character Set window updates.

Underline example: The character “O” is underlined across the Character with
Baseline set to 0 and position option set to Below.

Chapter 6: Transform Tools
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Appendix A:

Workspace Quick
Reference
In this appendix...


Menu bar



Toolbars

This appendix provides information on DesignPro Font Editor workspace environment
menus and toolbars.

Menu bar
Fonts Editor provides a horizontal menu bar located right below the title bar. The menu
bar provides access to standard Windows, as well as Font Editor-specific menu items.
Selecting a menu performs an associated action or displays a submenu or a dialog. You
can perform standard Windows operations to hide or display a menu bar, or you can dock
a menu bar at the edge of the Design Area.
Font Editor provides the following menu items:


File Menu (page 134)



Edit Menu (page 135)



View Menu (page 136)



Transformations Menu (page 137)



Tools Menu (page 138)



Window Menu (page 139)



Help Menu (page 139)
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File Menu
The File menu provides access to the following commands:

Icon

134

Menu Item

Purpose

Access Key

New

Creates a new font. Also
displays a sub-menu with
options to create a new Coded
Font, Character Set and Code
Page.

Control + N

Open

Displays the Open dialog to
open the required font.

Control + O

Open Windows
Font

Displays the Font dialog to
open the required Windows
(True Type) font.

Control + Shift + O

Close

Closes an active font.

Save

Saves an active font.

Save As

Displays the Save As dialog to
save an active font with a new
name.

Save As Coded
Font

Displays the Save As dialog to
save an active font as a Coded
Font.

Exit

Quits the application.

Control + S

Alt + F4
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Edit Menu
The Edit menu provides access to the following commands:

Icon

Menu Item

Purpose

Access Key

Undo

Reverses the last action.

Control + Z

Redo

Cancels the last undo action.

Control + Y

Cut

Cuts the selection.

Control + X

Copy

Copies the selection to the
clipboard.

Control + C

Paste

Pastes the previously copied
selection onto the selected
character(s) in the Character Set
window.

Control + V

Delete

Deletes the selection.

Delete

Select All

Selects all of the characters in
the Character Set window.

Control + A

Invert Selection

Cancels the previous selection.

Control + I

Edit Character

Displays the Editing pane to
edit the selected character.

Control + E

Swap Character

Switches the positions of two
characters in a character set.
Refer to “Formatting Toolbar”
on page 142 for details.

Kill Character

Replaces non-blank characters
with spacing characters in the
character set. For details, refer
to “Formatting Toolbar” on
page 142.

Merge Character

Adds characters from one
character set to another. Refer
to “Formatting Toolbar” on
page 142 for details.
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View Menu
The View menu provides access to the following commands:

Icon
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Menu Item

Purpose

Access Key

Preview

Displays the Preview pane.
Refer to “Preview Toolbar” on
page 143 for details.

Double Byte List

This feature is currently not
functional.

Full Screen

Switches the display of the
workspace from the Normal
view to the Full Screen view.

Zoom

Controls the magnification
level of the characters in the
editing pane. Also displays the
Zoom sub-menu. For more
information on Zoom, refer to
“View Toolbar” on page 146.

Toolbars

Controls the display of the
toolbars; also displays the
Toolbars submenu.

Status bar

Shows or hides the Status bar.

Messages

Shows or hides the Messages
window.

Control + Shift + M

Grid

Shows or hides the grid when
editing characters.

F4

Clear Messages

Clears all of the messages from
the Messages window.

Control + D

F7
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Icon

Menu Item

Purpose

Access Key

Character/Code
Point Properties

Displays Character Properties
dialog to view and specify
individual properties of the
selected character in the
Character Set window. Refer
to “Character Properties” on
page 95 in Chapter 5: “Editing
Fonts” on page 81, for details.

F2

Font Properties

Displays Font Properties
dialog to view and specify
the properties for Xerox
fonts.

Alt Enter

Refer to “Font Properties” on
page 99 in Chapter 5: “Editing
Fonts” on page 81, for details.

Transformations Menu
The Transformations menu provides access to the Transformation commands. For
Transformation commands, see “Transform Toolbar” on page 145.
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Tools Menu
The Tools menu provides access to the following commands. For commands on Drawing
Objects, see “Drawing Toolbar” on page 144.

Icon
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Menu Item

Purpose

Access Key

Import Image

Displays the Open dialog to
import an image into a
character. For details, refer to
“Formatting Toolbar” on page
142.

Control + Shift + I

Profile Editor

Launches the Elixir Profile
Editor application.

Options

Displays the Options dialog.

Profile Selection

Displays the Profile Selection
dialog.

Toolset Selection

Displays a toolset sub-menu
with AFP and Xerox options.

Application
Format Settings

Displays the Application
Format Settings submenu for
setting the application
properties; also enables you to
Load, Clear and Save the Setup
file at the Application level.
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Window Menu
The Window menu provides access to the following commands:

Icon

Menu Item

Purpose

Cascade

Rearranges and resizes all of
the opened fonts in the Font
Editor so that they overlap each
other.

Tile

Rearranges and resizes all of
the opened fonts in the Font
Editor so that they do not
overlap each other.

Arrange Icons

Arranges the minimized fonts
in the design area.

Access Key

Help Menu
The Help menu provides access to the following commands:

Icon

Menu Item

Purpose

Access Key

Contents

Opens the Font Editor online
help file with the Contents tab
selected.

F1

Search

Opens the Font Editor online
help file with the Search tab
selected.

Index

Opens the Font Editor online
help file with the Index tab
selected.

Elixir on Web

Opens the Elixir website.

About Font
Editor

Displays the Product Version,
Copyright, and Licensing
information.
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Toolbars
Font Editor toolbars provide access to the most commonly used application commands.
You can perform standard Windows operations to hide or display a toolbar, dock a toolbar
at the edge of the workspace, or display a toolbar as a palette window.
Font Editor provides the following toolbars:

140



Standard Toolbar (page 141)



Formatting Toolbar (page 142)



Preview Toolbar (page 143)



Drawing Toolbar (page 144)



Transform Toolbar (page 145)



View Toolbar (page 146)
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Standard Toolbar
The Standard toolbar provides one-click access to the basic File and Edit menu commands
such as Opening Fonts (page 50), Creating Fonts (page 57) and Saving Fonts (page 64).

Button

Purpose
Creates a new font.
Opens the selected font.
Saves the active font in a specified format.
Cuts the selection.
Copies the selection to the clipboard.
Pastes the selection onto the selected area in the
Editing pane.
Reverses the last action.
Cancels the last undo action.
Updates the font by applying changes to the
character(s) in the Character Set window.
Opens the DesignPro Font Editor online help file.

Appendix A: Workspace Quick Reference

141

Formatting Toolbar
The Formatting toolbar provides quick access to the basic font editing commands such as
Swapping Characters (page 89) or Replacing Non-Blank Characters with Blank
Characters (page 91). For details, refer to Chapter 5: “Editing Fonts” on page 81.

Button

Purpose
Displays the editing pane to edit the selected
character.

Switches the positions of two characters in a
character set. For details, refer to
“Swapping Characters” on page 89 in
Chapter 5: “Editing Fonts” on page 81.
Replaces non-blank characters with spacing
characters in the character set. Also displays
a sub-menu with Delete, Blank and Null
options.
Refer to “Replacing Non-Blank Characters
with Blank Characters” on page 91 in
Chapter 5: “Editing Fonts” on page 81 for
details.
Displays the Open dialog to import an image in
the selected character, in the Character Set
window.

Refer to “Importing Images in a Font” on page
93 in Chapter 5: “Editing Fonts” on page 81 for
details.
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Button

Purpose
Displays Character Properties dialog to view
and specify individual properties of the selected
character in the Character Set window. Refer to
“Character Properties” on page 95 in Chapter 5:
“Editing Fonts” on page 81, for details.

Displays Font Properties dialog to view
and specify the properties for Xerox fonts.
Refer to “Font Properties” on page 99 in Chapter
5: “Editing Fonts” on page 81, for details.

Preview Toolbar
The Preview toolbar is used for previewing fonts in the Font Editor. For details, refer to
Chapter 5: “Editing Fonts” on page 81.

Button

Purpose
Displays a font-preview pad for viewing
how text created with the current font will
display at print time. For details, refer to
“Using the Preview Tool” on page 110 in
Chapter 5: “Editing Fonts” on page 81.
Underlines single or multiple font characters
selected in the Character Set window.

Enables you to see the kerning effect on
character pairs in the preview pane. For
more information on kerning effect, refer to
“Kerning” on page 46 in Chapter 3: “Font
Structure” on page 39
Clear all of the text entered in the Preview
pane.
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Drawing Toolbar
The Drawing toolbar provides one-click access to the Drawing tools. For details, refer to
“Using Drawing Tools” on page 100 in Chapter 5: “Editing Fonts” on page 81.

Button

Purpose
Defines a straight-edged marquee to move, cut,
copy and paste a rectangular area in the editing
pane.
Paints continuous dots, or a series of horizontal,
vertical, or diagonal lines. Also displays the
Brush Tool options in the Toolbox.
Draws single, connected, and radial lines. Also
displays the Line Tool options in the Toolbox.
Draws hollow or filled squares or rectangles with
squared or rounded corners. Also displays the
Box Tool options in the Toolbox.
Draws hollow or filled circles and ellipses and
displays the Circle Tool options in the Toolbox.

Draw dots in a character cell. Also displays
the Dot tool options in the Toolbox.
Shows or hides the graphical ruler in the design
area.
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Transform Toolbar
The Transform toolbar contains transform tools to apply transformations to a font
character. Refer to Chapter 6: “Transform Tools” on page 111 for more information on
transformations.

Button

Purpose
Inverts the colors of a character.
Resizes a character and displays the Resize
options in the Toolbox.
Rotates a character and displays the Rotate
options in the Toolbox.
Flips a character and displays the Flip options in
the Toolbox.
Shifts an entire character within the specified
borders. Also displays the Position options in the
Toolbox.
Distorts a character by performing arbitrary
bitmap rotations. Also displays the Distort
options in the Toolbox.
Filters the ‘Noise’ or ‘Dust’ from a character.
Also displays the Filter Noise options in the
Toolbox.
Converts a character to halftone dots by applying
different lines or shading patterns to an image.
Also displays the Halftone options in the
Toolbox.
Darkens a character area by adding pixels. Also
displays the Darken options in the Toolbox.
Lightens a character by compressing the number
of black pixels. Also displays the Lighten options
in the Toolbox.
Creates an outlined (hollow) version of the
selected character. Also displays the Outline
options in the Toolbox.
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Button

Purpose
Narrows the selected character within its borders.
Also displays the Slimming options in the
Toolbox.

Blends other characters with a specified
character in a character cell. Also displays
the Blending options in the Toolbox.
Underlines single or multiple font characters
selected in the Character Set window.

View Toolbar
The View toolbar provides one-click access to commands such as using the Grid tools or
zooming the workspace. This toolbar activates when working in the Edit mode.

Button

Purpose
Increases the window object magnification.
Reduces the window object magnification.
Shows or hides the grid when editing characters.
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Appendix B:

Glossary
The following is an alphabetical listing of product-specific or unique terms and
abbreviations used in this guide.
Accent
A mark over, under or through a letter, that indicates the vocal quality or sound value
(inflection, tone, stress, etc.)
Ascender
Distance from the character baseline to the topmost toned-pel.

Ascender and baseline.
A-space
Distance from the character reference point to the near edge of the toned-pel box. See also
B-space and C-space.
AFPDSTree
Windows component displaying AFP (MO:DCA) internal file structure and associated
information.
BCOCA (Bar Code Content Architecture)
Composition of industry-standard bar codes, including draw rule commands and raster
data.
B-space
The width of the toned-pel box of the character. See also A-space and C-space.
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Baseline
An imaginary line which is used to position a character. Characters may rest on the
baseline or extend above or below it. Characters are normally positioned so that their
baselines are aligned. Such characters are said to be base aligned.
Baseline offset
The distance (in dots) from the bottom of the character bitmap to the baseline. The
baseline offset is positive if the character sits above the baseline and negative if it sits
below the baseline.
Bitmap
A two-dimensional array of dots which is used to represent each character in a
computerized font.
Blanks left
The distance (in dots) between the left side of the character cell and the start of the
character bitmap.
Blanks right
The distance (in dots) from the right side of the character bitmap and the edge of the cell.
If the character has right kerning, this value is negative and the character extends over the
right side of the cell.
Bold
A darker version of a font or character formed using heavier strokes. See also Weight.
BCOCA (Bar Code Content Architecture)
Composition of industry-standard bar codes, including draw rule commands and raster
data.
Boxed text
Form text bounded by a column of set height and width.
Blend text mode
Editable, moveable text entry mode displaying text either within box or next to crosshair
pointer. Once the text is placed in the design area, text becomes part of the image and can
only be edited using the drawing tools.
C-space
Distance from the far edge of the toned-pel box to the escapement point. See also A-space
and B-space.
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Character escapement point
Marks the end of the space along the character baseline allocated for the character. When
printing adjacent characters, the reference point of the next character is placed at this
point.
Character header
Record containing character information such as width, height, and descender position
relative to baseline.
Character reference point
The point along the character baseline within the character box that coincides with the
current print position.
Cell
An imaginary rectangular block of pixels that represents the space in which a given
character is drawn on the screen.
Cell height
Height of an imaginary rectangular block of pixels that represents the space in which a
given character is drawn on the screen.
Cell width
The width of a character cell, also called the set width.
Clipping
Operation that removes display elements of a picture falling outside the specified
boundary.
Debolden
Lighten print character by removing bits.
DBCS (Double-Byte Character Set)
Character set containing a maximum of 65536 characters.
Delta - x
The delta-x of a character is the same as the character width or set width.
Descender
Distance from the character baseline to the lowest toned-pel.

Descender.
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DIB (Device Independent Bitmap)
Windows standard file format designed to ensure that bitmapped graphics created using
one application can be opened and displayed in another application exactly the way they
appeared in the originating application.
Dot
See Point.
Embolden
Darkens print character by adding bits. A complete set of characters of a certain size and
orientation (such as portrait or landscape) in one typeface.
Fast keys
See Keyboard shortcut.
FDL (Forms Description Language)
Source language used for designing electronic forms for Xerox Laser printers. See also
FSL and Form.
Fidelity
Degree of required visual exactness required when processing the input data stream for
printing a file. Different levels of fidelity can be specified, which determines how errors
are handled, such as substituting fonts when a font used in the data stream cannot be
found.
Fixed font
Font containing characters with fixed spacing. See also Proportional font.
Fixed-pitch
Font family in which all characters have the same horizontal spacing.
Font
Complete set of print characters of the same family, size, typeface, and orientation.
Font family
A set of fonts with similar design characteristics, usually including many sizes, typefaces,
and orientations.
Font header
A record within the computer which contains information applicable to the entire font
such as the font name, the line spacing, and the orientation.
Form
Single-page document used for background reproduction on each page of other
documents.
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Form template
Form loaded as a visual guide for designing a new form. When the new form is saved, the
form template is not included.
Free text
Form text not bound by a column of set height and width.
FSL
Forms source library. Uncompiled user-created forms containing FDL commands. See
also FDL (Forms Description Language) and Form.
Glyph
Symbol set element representing data; can be letter, digit, punctuation mark, or other
notation.
GOCA (Graphics Object Content Architecture)
Structure for describing a complex picture (e.g., bar chart or pie chart) using graphic
commands.
Grid
Horizontal and vertical lines of pixels used for precise object placement.
Guidelines
Horizontal and/or vertical lines in the design area used to align objects.
Halftoning
Applying line or shading patterns to make images or characters appear either gray or
textured.
IM image
Resolution-dependent migration image object that cannot be compressed or scaled.
Image
Resolution-dependent migration image object that cannot be compressed or scaled.
JDE (Job Descriptor Entry)
Command inside a data set passed to a Xerox laser printer.
JDL (Job Descriptor Library)
Compiled module stored on a Xerox Laser printer controlling print set functions such as
paging and lines per page.
JSL (Job Source Library)
Source file containing uncompiled Xerox Print Description Language statements for job
descriptions. See also JDL (Job Descriptor Library) and JDE (Job Descriptor Entry).
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IOCA (Image Object Content Architecture)
Non-resolution dependent data structure in which image objects can be scaled and
compressed.
Kerning
Process of adjusting the spacing between certain character pairs to enhance readability and
to visually equalize the spacing among all characters within a line. The amount of space
added or subtracted between certain character pairs is dependent upon the font and point
size used.
Keyboard shortcut
Special key or three-key combination for executing an operation without using the mouse;
also called fast key(s).
Leading
The amount of white space placed at the top or bottom of characters to prevent
overlapping between succeeding lines.
Line spacing
Distance between succeeding lines of text when printed on a page. In other words, the line
spacing is the distance from the top of the characters on one line to the top of the
characters on the next line.
Locator box
A rectangular locator box available on the right pane in the design area, where the image
or character can be viewed in its original size.
Messages window
Window displaying informational, error, and warning messages.
Metacode
Code used by a Xerox printer to control imaging system internal functions and provide allpoints-addressability. Functions include character positioning and font and print
orientation selection.
Mirroring
Character or image rotation, such that the top displays bottom or right displays left.
Miter
Joint made by beveling two 45° surfaces to form a 90° corner.
MO:DCA (Mixed Object Document Content Architecture)
Structure of device-independent data stream used for interchanging documents.
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MO:DCA-P
See MO:DCA Presentation.
MO:DCA Presentation
Subset of MO:DCA structure used for defining presentation documents.
Monospace
Form of print and display spacing in which each character occupies the same amount of
horizontal space (character width) on the line, regardless of whether the character is wide
(such as m) or narrow (such as I). See also Pixel and Fixed-pitch.
Nonblank character
Printable font character with a bitmap containing a letter, number, mark, or symbol.
Null character
Non-printable character occupying unused font position.
Orientation
Direction of the type in reference to the upper left corner of a portrait page.
Outline font
Font having graphic character shapes represented in digital form by a series of
mathematical expressions rather than by raster patterns. See also Raster font.
Overstrike
To print characters over each other.
Raster font
Font in which characters are defined by the raster bitmap.
Paper
Physical attributes of a logical page, such as size, orientation, positioning, and
partitioning.
Pel
See Pixel.
Pitch
Distance between corresponding points of two equal characters that are typed immediately
adjacent to one another. For fixed-pitch (or monospaced) fonts; the characteristic of a font
family with the same horizontal spacing (characters printed per inch) assigned to all
characters. For proportional pitched fonts, spacing in proportion to individual character
width variations.
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Pixel
Contraction of “picture element” smallest displayable or printable unit on a physical
medium. A pixel is sometimes referred to as a dot. Character bitmaps are made up of dots
or pixels. The word pixel is a contraction of a picture element. A pixel can contain
additional information, such as color and can be larger than one bit while still representing
one dot.
Point
Size of the characters of a font when they appear on paper is given in points. One point is
1/72 of an inch or 0.352 mm.
Point size
Size of a printed character in points from the top of the ascender to the bottom of the
descender. Thus, if the characters in a font are, on average, 1/2 inch high when printed, the
font is said to have a "point size of 36" or to be a "36 point font."
Print data stream
Data stream created by Print Services Facility for transmission to printer.
Proportional font
A set of characters in a particular style and size in which a variable amount of horizontal
space is allotted to each letter or number. In a proportional font, the letter i, for example, is
allowed less space than the letter m. See also Pitch.
Raster font
Series of pels arranged in scan lines to form font. Raster fonts are specified pixel-by-pixel.
Each character is represented by a double array describing the order in which pixels in a
"character box" need to be in order to produce that character. In other words, each
character is given by a monochrome bitmap.
Raster graphics
Bitmaps wherein an image is defined by a collection of small, independently controlled
dots (pixels) arranged in rows and columns.
Raster pattern
A series of picture elements (pels) arranged in scan lines to form an image.
Resolution
Measure of image sharpness, expressed either as number of lines and columns, or pels per
unit of area.
Resource Map Editor
Product component used to display, define, and edit font input to output format mappings,
and provide instructions for storing information in the Elixir Resource Map.
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Reverse
Switch image or character from black on white background to white on black background,
or vice versa.
SBCS (Single-Byte Character Set)
Character set in which each character is represented by a 1-byte code (256 characters).
Set width
Distance from the start of the character cell to the start of the next character cell. Also
called the character width or delta-x.
SOSI (Shift-Out, Shift-In)
Special EBCDIC data stream codes used to control switch between double- and singlebyte fonts.
Snap to
Product function that causes form elements to automatically align with the nearest
displayed grid point.
Spacing character
A blank or all white character that is used for positioning characters on a line. These
characters do the same thing as a space key on a typewriter.
Style
A modified version of a typeface. Examples of a style are Bold, Italic, etc.
Toned-pel box
Defines the boundaries of a character bitmap. Each character bitmap in a character set
comprises an ordered array of black dots (toned-pels) and non-printing blank dots
(untoned-pels). Toned-pels define the shape of the character; untoned-pels define the
white space in and about the character.
Typeface
All characters of a single type family, each having the same style, weight, and width,
regardless of size.
Typographic font
Font having variable distances between characters.
UDK (User Defined Key)
User-defined escape character for specified print jobs.
Underline
Placement of a line under text, usually for emphasis (also called underscore).
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Uniformly spaced font
See Monospace.
Weight
Thickness of a font which can be changed by emboldening or deboldening characters in a
font.
X-height
Height of lowercase letter x.
Zoom
Product feature used to enlarge a selected portion of a graphical image or document to fill
a window or the screen.
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Index
A
adding
circles 106
dots 108
toolbar buttons 31
Adobe Type 1 fonts 49
ascenders 45
A-space 44
ATM fonts 49

B
baseline
offset 46, 82, 96
positioning 46
baseline offset 96
blanks
left 96
right 96
Blend Tool 129
blending characters 129
BMP
16 Color 93
24-bit Color 93
256 Color 93
Monochrome 93
Box tool 105, 106
boxes, drawing 105
Brush tool 109
B-space 44

C
cascading windows 36
cell width 96
changing
fonts 84
input format properties 72
output format properties 73
character number 96
Character or Code point properties tool 95, 98
Character Set window 18, 19
character sets 41

Index

character transform tools 111
characters
above baseline 82
adding boxes 105
adding circles 106
adding dots 108
adding images 93
adding lines 104
ascenders 45
baseline 41, 46, 82
baseline offset 46, 82, 96
below baseline 82
blanks left 96
blanks right 82, 96
blending 129
B-space 44
cell width 82, 96
character number 96
copying 85
C-space 44
darkening 125
deleting 92
descenders 45
deselecting 84
distorting 119
drawing 100
editing 100
erasing 106
filling with brush 109
filtering 120
flipping 117
font character settings 95
formatting 89
half tonning 122
increment 44
inverting 113
left kerning 47, 96
lightening 126
merging 88
nonblank characters 91
null character properties 97
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orientation 43
outlining 127
paste multiple characters 86
pasting 85
positioning 118
printing adjacent characters 44
properties 95
reference point 44
replacing 91
resizing 114
rotation 42, 116
selecting 84
selecting areas 102
setting properties 95
slimming 128
spacing 98
spacing characters 91
swapping 89
typeface 40
underlining 130
undoing changes 89
uniform increment 44
choosing commands 35
Circle tool 106
circles, drawing 106
Clear tool 110
clearing
EPM files 78
color box
black 108, 109
invert 105, 108
white 108, 109
color brush
invert 109
color coding messages 24
color lines
black 104
invert 104
white 104
commands
redo 35
undo 35
conventions 13
symbolic 14
typographic 13
converters
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properties 74
viewing properties 74
converting
Elixir fonts 47
Copy tool 85, 86
copying
characters 85
creating
ASCII fonts 57
custom profiles 69
Elixir Legacy fonts from Windows fonts 62
fonts 57
spacing characters 91
toolbars 31
user profiles 69
Xerox font from Windows font 63
Xerox fonts 61
C-space 44
customer support 15
Customize dialog 29, 31
cutting
individual characters 86

D
Darken Tool 125
darkening characters 125
deleting characters 92
descenders 45
deselecting characters 84
DesignPro applications 10
DesignPro Font Editor
workspace 17
dialogs
Browse for Folder 71
Customize 29, 31
Font 55
Font Properties 58, 99
GDF/Elixir form 54
New Font 57
Open 51, 52, 53, 54, 134
Open Profile Configuration File 69
Options 22, 76, 138
Profile Selection 138
Properties of Spacing Character 98, 99
Register New Profile 69
Save As 63, 64, 67, 134
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displaying
grid 34
message time 24
Distort Tool 119
distorting characters 119
Dot tool 108
drawing
boxes 105
circles 106
dots 108
lines 104
Drawing toolbar 102, 108, 109, 144

E
Edit tool 100
editing
characters 89, 100
erasing 106
fonts 81, 84
Elixir fonts 50
Elixir Legacy fonts
converting 47
opening 52
EPM files 78
extensions
FLJ 49, 50
FNT 49, 50
HDR 50
INI 69
JPEG 93
JPG 93
PCL 49, 50
PCX 93
PRN 93
registering, new 76
TIFF 93

F
file formats
input properties 72
output properties 73
properties, setting 71
files
Elixir Parameter files (EPM) 78
filling
box color 105

Index

circles 107
hollow box 105
hollow circles 107
Filter Noise Tool 120
filtering characters 120
Flip Tool 117
flipping characters 117
FLJ 49, 50
FNT 49, 50
Font Editor
menus 133
overview 9
toolbars 140
Font Properties dialog 58
font structure
AFP 39
Elixir 39
font type
width 40
fonts
Adobe Type 1 49
ATM fonts 49
changing 84
character set properties 99
character set vs font 48
characteristics 41, 82
copying range of characters 86
creating 57
creating ASCII fonts 57
creating Elixir Legacy fonts from Windows
fonts 62
creating Xerox fonts 61
creating Xerox fonts from Windows font 63
deselecting 84
editing 81, 84, 100
Elixir 50
Elixir font structure 47
Elixir fonts 50
Elixir legacy font structure 47
Elixir Legacy fonts 49, 52
formatting 89
opening 50
opening Elixir Legacy fonts 52
opening PC mapped fonts 53, 54
opening Xerox fonts 51
output formats 50

159

PCL 50
PCL fonts 49, 50
PC-mapped fonts 53
PostScript 49
previewing 110
properties 59, 99, 100
Xerox 100
proportional-spaced 44
sampling 110
saving 64
saving as a PCL font 66
saving as Elixir Legacy fonts 64
saving as Xerox fonts 67
selecting 84
structure 39
style 40
symbol set properties 99
transforming 111
True Type 49
True Type fonts 49
type family 40
type font 40
typeface 40
typographic 44
weight 40
Xerox font properties 99
Xerox fonts 50
formatting fonts 89
Formatting toolbar 89, 92, 95, 99, 100

G
GCID 41
grid 34
displaying/hiding 34

H
half toning characters 122
Halftone Tool 122, 123
HDR 50
Help
context-sensitive 16
customer support 15
opening Online Help 16
hiding
grid 34
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I
image formats
JPEG 93
PCL 93
PCX 93
TIFF 93
images
input formats 49
JPEG 93
output formats 50
PCL 93
PCX 93
TIFF 93
importing images 93
INI 68, 69
input
formats 49
parsers 74
Invert Color Tool 113
inverting
box color 105, 108
brush color 109
line color 104

J
JPEG 93
JPG 93

K
kerning
left 46
right 47
Kerning tool 110
Key, about 70
Kill character tool 91, 92

L
leading 83
left kerning 47, 96
Lighten Tool 126
lightening characters 126
Line tool 104
lines, drawing 104
logging
messages 22
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M
managing fonts 49
menu bar 26
Edit menu 135
File menu 134
Help menu 139
Tools menu 138
Transformations menu 137
View menu 136
Window menu 36, 37, 38, 139
merging
characters 88
Messages window 21, 136
clearing messages 21
color coding messages 24
displaying message time 24
logging messages 22
modifying
resource extensions 77
monospaced fonts 44
moving selected area 103

N
New Character Set dialog 57
non-blank characters 91

O
Open dialog 51, 52, 53, 54, 134
Open Profile Configuration File dialog 69
opening
Elixir Legacy fonts 52
EPM files 79
Font Editor 17
fonts 50
PC-mapped fonts 53, 54
recently used fonts 51
Xerox fonts 51
Options dialog 22, 76, 138
General category 21
Info Server category 74
Messages category 22
orientation 43
Outline Tool 127
outlining characters 127
output

Index

converts 74
data converters 74
overview
Font Editor 9

P
painting objects 109
parsers
viewing properties 74
pasting
characters 85
range of characters 86
selected area 102
patterns
selecting 123
PCL fonts 50
PCL images 93
PCX 93
Position Tool 118
positioning characters 118
PostScript fonts 49
Preview tool 110
Preview toolbar 110
previewing
fonts 110
preview pane 110
Profile Selection dialog 138
profiles
about 68
custom 69
user 68
viewing 68
properties
changing input formats 72
changing output formats 73
Elixir fonts 99, 100
file formats 71
FRM 71
GDF 71
non-AFP character 95
non-AFP fonts 99
null character 97
PCL 71
spacing character 98
Xerox fonts 100
Properties of Spacing Character dialog 98
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proportional-spaced font 44

R
Register New Profile dialog 69
related guides 12
replacing characters 91
Resize tool 114
resizing characters 114
right kerning 47
right-click menu 35
Rotate Tool 116
rotating characters 116

S
sampling fonts 110
Save As dialog 63, 64, 67, 134
saving
as a Xerox font 67
Elixir Legacy fonts 64
EPM files 78
fonts 64
PCL fonts 66
Select tool 102
selecting
areas 102
characters 84
patterns 123
settings
character properties 95
file format properties 71
font properties 59, 99
Setup files 78
clearing 78
opening 79
saving 78
slimming characters 128
Slimming tool 128
spacing characters 91
Standard toolbar 85, 102, 106, 130, 141
Status bar 136
support 15
supported file formats
input 49
output 50
Xerox 49
supported fonts
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ATM 49
Elixir 49
Elixir legacy 49
FNT 49, 50
PCL 49, 50
Swap character tool 89
swapping characters 89
symbols
properties, setting 70
symbol set 99

T
TIFF 93
tiling windows 37
toolbars 26
about 26
adding buttons 31
creating new 31
customizing display 29
Drawing 103, 106, 109, 144
Formatting 27, 89, 98, 99
Preview 27, 110
Standard 26, 35, 85, 102, 130, 141
Transform 28, 111, 145
View 28, 34
Toolbox 20
Blend 129
Box 105, 106
Brush 109
Circle 106
Darken 125
Distort 119
Dot 108
Filter Noise 120
Flip 117
Halftone 122, 123
Lighten 126
Line 104
Outline 127
Pattern 124
Position 118
Resize 114
Rotate 116
Select 102, 103
Slimming 128
Underline 130
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tools

U

Blend 129
Box 105
Brush 109
Brush tool 109
Character or Code point properties 95, 98
Circle 106
Clear 110
Copy 85, 86
Darken 125
Distort 119
Dot 108
drawing tools 100
Edit tool 100
Filter Noise 120
Flip 117
Halftone 122, 123
Import image tool 93
Invert Color 113
Kerning 110
Kill character 91, 92
Lighten 126
Line 104
Outline 127
Position 118
Preview 110
Resize 114
Rotate 116
Select tool 102
Slimming 128
Swap character 89
toolbars 26
Underline 110, 130
Undo 89
Update changes 102, 107, 108, 109, 130
workspace, using 26
training 16
Transform toolbar 111, 145
transforming
fonts 111
True Type fonts 49
type family 40
type font 40
typeface 40
typographic conventions 13
typographic font 44

Underline tool 110, 130
underlining characters 130
Undo tool 89
undoing changes 89
uniform 44
Update changes tool 102, 107, 108, 109, 130
user profiles
about 68
custom 69
default 68
using
brush tool 109
character transform tools 111
drawing tools 100
workspace tools 26

Index

V
Value
about 70
View toolbar 28, 34
viewing
profiles 68

W
Who Should Use this Guide? 12
Window menu 36, 37, 38
windows
arranging workspace windows 38
cascading workspace windows 36
character set 18
Messages 136
tiling workspace windows 37
workspace
arranging windows 36
character set window 18
functions 35
grid 34
menu bar 26
menus 26
Messages window 21
toolbars 26
Toolbox 20
windows,understanding 17
zooming 146
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workspace using, tools 26

X
Xerox fonts
character sets 41

Z
Zoom In tool 146
Zoom Out tool 146
zooming
workspace 146
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