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2 What is Report Editor? 
 

Asset DB Report Editor is a software tool that has been developed to work directly with 

Asset DB Analyst and Architect. Within the Report Editor module, standard Asset DB 

system reports (including Print Assessment Summary, Moves and Changes and Future 

State Proposal) can be generated and edited to meet specific user requirements such as 

data filters, content, and visual styles.  

Users can also create new reports to show text, charts and graphs depicting all aspects 

of the data from their project.  

 

3 Getting Started 
 

The starting point for running, creating or editing reports using Asset DB Report Editor is 

an Asset DB project representing an existing printing environment.  Before continuing 

you should ensure you have read the Asset DB Auditor and Analyst manuals and are 

familiar with their contents. 

 

3.1 Capturing and Understanding the Existing Environment 
 

Before you are able to run or amend reports you must first capture comprehensive data 

for your current fleet and where possible for your solution design.  

For System reports this could also include capturing average monthly volumes, running a 

TCO calculation and running a Green Analysis for the current state, and adding product 

cost data and running a Green Analysis for the future state. 

For reports that you may wish to create or amend, the data you collect should reflect the 

data you wish to appear in your report. 

 

Details of the above mentioned processes can be found in the Asset DB Auditor, Analyst 

and Architect manuals. Therefore the rest of this manual will assume a full understanding 

of this. 

 

3.2 Running a System Report 
 

The processes to run an existing System Report such as the Print Assessment Summary 

Report, Moves and Changes Report or Future State Proposal Report are covered in the 

Asset DB Analyst Manual. The rest of this manual will assume an understanding of that 

process. 
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4 Creating a New Report 
 

To create a new report you should first open the report management window by selecting 

Reports>Design>Manage. Once the window is opened click the New button to create the 

report. This will produce the New Report window shown in Figure 1.  

 

Here you will be able to give your new report a name, a title and select a Report Style 

from the drop-down. The Name of the report will be how the report is identifiable within 

your list of reports. This name will not appear in the final report produced. The Report 

Title is the name that will appear in the Header on each page of your report. The title of 

the report and the report’s name may be different. 

 

 

 

Figure 1. The New Report window 

 

The next stage in creating a report is to select the Report Style. By default this will be set 

to the Asset DB (System) Style but this can be changed to a personalised Style using the 

drop-downs. Styles can be created or edited using the methods explained in Section 6.   

 

The final stage in setting up a new report is to set the Project Data Source in order to 

filter your data and set sorting defaults. This is done by selecting the Data Source tab 

and then following the same method as explained in Section 7.   

 

Once each of these has been set then the report is saved by clicking the OK button. The 

report is then ready to be populated with Paragraphs, Tables, Images and Charts. 

Section 8 will outline the steps used to create each of these objects. 
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5 Editing an Existing Report 
 

As well as being able to generate pre-defined System reports, it is also possible to 

amend these reports to add/remove paragraphs and tables, set additional criteria or 

adjust the style of the report. 

 

In order to edit a System report such as the Print Assessment Summary Report, Moves 

and Changes Report or Future State Proposal report you must first make a duplicate of 

the desired report.  

A report is copied in the report management window which can be opened by selecting 

Reports>Design>Manage. 

 

The report management window will then list all of the available reports. An existing 

report is copied by selecting the report and clicking on the Copy button as shown in 

Figure 2. 

 

 

 

Figure 2. Copying an existing report 

 

Copying a report will then open the Copy report window. Within this window you will be 

able to change the Name of the report (which appears in the report list) and the title of 

the report (which appears on each page of the report). 
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Figure 3. Copying a report 

 

Within the Copy window it is also possible to remove sections of the original report from 

your copy. If your project does not contain a TCO or Green Calculation for example, you 

may wish to remove these sections from the Print Assessment Summary report. 

This is done by unchecking the tick boxes for a particular section of the report that you 

wish to omit in the bottom left corner (shown in Figure 3). Highlighting the section will 

show a preview in the main panel which will then aid with the decision making process 

around which to remove.  

It is also possible to remove sections from the report at a later stage and further details 

on this can be found in Section 8. 

 

Finally, the style of the report (personalised colours, fonts and logos) can be selected at 

this stage using the Style drop down and the Data Source can be set as described in 

Section 7.  

 

Once the above settings have been set, the next step is to click on the OK button to 

create your copied report. You are then able to edit the various Sections and objects 

within your report as explained in Section 8.  
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6 Report Styles 
 

As well as defining the data and text to be included within a report, it is also possible to 

design the style of the reports. Fonts, colours, images and orientation can all be set to 

create custom styles. Multiple Styles can be created and then shared among users.  

 

6.1 Creating a New Style 
 

To create a new report style, we must first open the Report Style management window 

by selecting Reports>Style>Manage. You can then select the New button to create the 

new style. This will then present the Edit Style window shown in Figure 4.  

 

 

 

Figure 4. The Edit Style window 

 

The first features to set for your new style are the style name, page size and page 

orientation. Each of these can be determined in the first General tab.  

 

The style name will allow you to quickly identify the style when selecting it for a given 

report.  
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The page size and orientation will apply to all pages within the report. Because the report 

can be exported in various formats including PDF, Word and PowerPoint, it is important 

to decide upon the format in which you will be exporting the report when you determine 

these parameters. For example a PDF or Word may be best in portrait orientation 

whereas a PowerPoint export may be best in landscape orientation. 

 

6.1.1 Setting Fonts and Text Colours 
 

The next stage in setting a report style is to determine the font and text colours for the 

report. The first font to set is for the paragraph or main body of text within the report. This 

will also determine the default font for the report as a whole. 

 

First select the Paragraph section from the top left panel of the Edit Style Window. You 

can then use the options in the panel below to set the font, size, style and colours for the 

Paragraph. You will then be able to see the change immediately in the right hand panel. 

 

You are then able to amend each individual heading and title style in the same way by 

expanding each title group and setting the font styles as shown in Figure 5.  

 

 

 

Figure 5. Changing the font of headers/titles 

 

Set the new fonts/ 

colours for the title 

Set the title to be 

changed 

Changes can be 

seen 

immediately 
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6.1.2 Setting Chart Colours 
 

Once you have set the fonts and colours for your Style, you can then set the colours for 

charts that appear in the reports.  

 

The first step is to select the Chart Series tab at the top left of the screen. This will then 

display the current colours used in the Style and the order in which they will be used.  

 

To edit a currently used colour, double click on the relevant line item. You will then be 

able to either type in the exact colour numbers, or use the drop-down menu to select a 

pre-defined colour as shown in Figure 6.  

 

 

 

Figure 6. Changing chart colours 

 

Colours can be deleted from the list by selecting the colour and clicking the Delete button 

(shown highlighted in Figure 6).  

 

The order in which the colours are used can also be edited by selecting each line item 

then using the up and down arrow buttons to the right of the list.  

 

Automatically see 

a sample chart 

Manually edit the 

hexadecimal colour 

codes 

Changes can be 
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6.1.3 Setting the Report Header and Footer 
 

The final aspects of the Report Style that can be edited are the Header and Footer. The 

colour of the header is set by changing the colour of the “Title” in the Styles tab as 

explained in Section 6.1.1.  

 

By selecting the Page Header tab, you can then edit the alignment of the header and 

amend the image displayed. The default for the report title displayed in the header is left 

justified and in the middle of the header bar. This can be adjusted to either the top or the 

bottom of the banner using the Title Align drop-down menu. 

 

In addition to the title, the Image shown in the header can also be changed using the 

options shown in Figure 7.  

 

 

 

Figure 7. Editing the Page Header 

 

The options for the image can be set as follows: 

 

 Display: A checkbox to determine whether an image will be displayed. 

 Image: To change the image click the Select Image button and browse to the 

desired image. 

 Width and Height: The size of the image can be adjusted to fit the header. 

 Position: The image can either be positioned at the left or the right of the header. 

 Align: As with the text the image can be at the top, middle or bottom of the 

banner.  

 

The same options can then also be set for the image in the footer by selecting the Page 

Footer tab. Within that tab it is also possible to change the alignment of the page 

numbering to the top or bottom of the banner from the default middle. 
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Once you have made all desired changes to the selected style, simply click OK at the 

bottom right of the window and your changes will be saved.  

 

6.2 Editing an Existing Style 
 

To edit an existing report style, we must first open the Report Style management window 

by selecting Reports>Style>Manage. This will show all currently created report styles. A 

style is deleted by selecting the line item and then clicking the Delete button. 

 

An existing Style is edited by again selecting the line item and then clicking the Edit 

button. The Style can then be edited using the processes explained in Sections 6.1.1, 

6.1.2 and 6.1.3.  

 

 

 

6.3 Exporting and Importing Styles 
 

Once Styles have been created using the above processes, as well as being able to use 

them for future reports within the Asset DB install in which they were created, they can 

also be exported to then be imported into another Asset DB install.  

 

To export a Style navigate to Reports>Style>Export from the menu bar. This will then 

present a list of all available Styles. You should then select the Style you wish to export 

and click the Export button. This will then allow you to save the file into a desired location 

as a .rst file. 

 

To import a Style, navigate to Reports>Style>Import and then navigate to the saved .rst 

file. This style can then be selected for any report within your system. 

 

7 Setting the Project Data Source 
 

Once a report has been copied, it will now appear in the report management window. To 

start making changes to the new report you now need to select the report from the list 

and click the Edit button as shown in Figure 8.  
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Figure 8. Editing a copied report 

 

This will then produce the edit report window. At this stage it is not possible to rename 

your report but the title can still be changed in the Report Title Section in the top left hand 

corner.  

 

The first stage to setting up your report is to determine the data that the report will take 

into consideration. This is done in the Project Data Source tab of the Edit report window 

shown in Figure 9. 
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Figure 9. Project Data Source tab 

 

Asset DB can filter the data in your project for your report based on any field from within 

the project’s icon customisation as well as system set fields such as device type.  

In order to set the criteria for these filters you would use the Criteria panel highlighted in 

Figure 9. For the Print Assessment Summary report, the default is set to include only 

Printers, MFDs, Scanners and Faxes that are In Scope. To change this default, or for 

other reports where you want to set the criteria, click on the Edit button in the Criteria 

Panel. 

 

This will then bring the Edit Criteria window (shown in Figure 10) where you can set the 

distinct criteria for your data. This will allow you to show only a distinct subset of your 

data. For example, you may wish to show only in-scope printers in your report and the 

following steps will allow you to do this. 

 

The first step is to add a criterion using the Add Criteria button ( ). You can then set the 

details of each criterion using the options shown in Figure 10. For each individual 

criterion added you can use multiple filters on the selected data field using the Add 

Additional Path button ( ).  
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Figure 10. The Edit Criteria window 

 

In order to create the criteria in the above mentioned example, you would first select 

Asset Type as the data field and then select the Printer check box (shown in Figure 10). 

You should then create an additional criterion choosing Out of Scope as the data field 

and then ensure the condition is such that the field is uncheck (equals unchecked). 

 

Once you have created the criteria set you wish to use to filter the data in your project, 

this is saved by clicking the OK button. This will then update the Criteria panel to show 

your new settings. 

 

7.1 Creating Custom Fields 
 

In addition to using the standard fields in the project’s Icon Customisation to filter the data 

for the report, it is also possible to create custom fields based on the standard fields. For 

example, you may wish to filter on overall cost including both the TCO cost and Electricity 

Select any field 

in the Icon 

Customisation 

Choice of criteria 

Insert an additional 

criterion 

Set multiple 

filters for one 

field 

Free text and check 

boxes for relevant 

criteria 
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cost. You could then create a custom field which would add these two fields together for 

you. 

To create a custom field you should first click on the Add button in the Custom Fields 

panel shown in Figure 11.  

 

 

 

Figure 11. Creating a custom field 

 

You will then be shown the Field Wizard window where you will determine how to create 

the new custom field.  

The first screen will give three options for the type of field, listed below: 

 

7.1.1 Add two or more fields together 
 

This option would be used for the example above where you wish to filter based on the 

sum of multiple fields. To create such a field, first select the relevant radio button and 

click Next.  

 

You then need to give your new custom field a name in the Display Name box (shown in 

Figure 12). This is the name that will appear in the list of fields within the Criteria 

windows. 

 

The next step is to select the fields you wish to be added together. This is done by 

clicking on the Add button and scrolling through the current project Icon Customisation to 

select the relevant fields. Once you have selected all of the fields you wish to be added 

together they will be displayed in the Fields section as seen in Figure 12. 
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Figure 12. Field Wizard – creating a field by adding multiple existing fields 

 

To finish the process and create the field simply click on the Finish button. Your new field 

will then appear in the Custom Fields panel in the top left corner of the Edit Report 

window. 

 

7.1.2 Multiply a field by a value 
 

This option would allow numeric fields to be multiplied before a filter is applied. An 

example of this would be a monthly value multiplied by 12 to give an annual value. To 

create such a field, first select the relevant radio button and click Next.  

 

You then need to give your new custom field a name in the Display Name box as above. 

The next step is to select the field you wish to be multiplied using the drop down menu. 

 

The Amount field should be populated by the value by which you wish your field to be 

multiplied.  
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Figure 13. Field Wizard – creating a field by multiplying an existing field 

 

To finish the process and create the field simply click on the Finish button. Your new field 

will then appear in the Custom Fields panel in the top left corner of the Edit Report 

window. 

 

7.1.3 Display text based on criteria 
 

This final option could be used to condense a multiple option field such as Connection 

Type or Asset Type. The process to create a field in this way will be to create new 

category options based on set criteria. Each device will then be placed into each of the 

new categories. 

To create such a field, first select the relevant radio button and click Next.  

 

You then need to give your new custom field a name in the Display Name box as above. 

The next step is to define the default category. This will be the category chosen for 

devices which currently do not have a value in the selected field.  

 

The final stage is to create the new categories. For this example we will split the 

Connection Type field into simply Networked and Non-Networked. To create a category, 

first double-click in the first row in the Categories table under the Category heading. You 

can then type the name of the first category to be created. To define the new category 

you then need to double-click in the same row under the Criteria heading. This will then 

bring up an Edit Criteria window. The process to edit the criteria is explained in Section 7 

and Figure 10. This process is then repeated to create all categories that are required.  
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Figure 14. Field Wizard – creating a field by displaying text based on criteria 

 

To finish the process and create the field simply click on the Finish button. Your new field 

will then appear in the Custom Fields panel in the top left corner of the Edit Report 

window. 

 

Once you have created Custom Fields, they can then be used to set the criteria for your 

report as explained in Section 7.The fields will appear in a Custom section within the icon 

customisation. 

 

7.2 Setting Default Sort Orders 
 

The final default option to be defined within the Project Data Source tab is the default 

sorting orders for tables and graphs.  

This will allow you to determine whether a list should be sorted ascending or descending 

for each specific field. The default for all fields will be ascending unless otherwise 

specified within certain tables or graphs.  
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Figure 15. Setting a default sort order 

 

To set a Sort Order, first double click in an available row under the Field heading. You 

will then be able to select a field from the project Icon Customisation. Once a field has 

been selected, you can then use the drop down in the Direction column to determine 

whether the sort should be ascending or descending as a default as shown in Figure 15.  

 

These sort orders will then be used as the default in all tables and graphs throughout the 

selected report unless a specific sort order has been set for a certain item. A Sort Order 

can be deleted by selecting the relevant row in the table and selecting the Delete button. 

 

Once you are happy with the settings of your Project Data Source, they can be saved by 

clicking on the OK button at the bottom right corner of the Edit Report window.  

 

8 Managing the Report Content 
 

Once a new report has been created or an existing report has been copied and the 

Project Data Source has been set, the main body of the report can now be created. This 

will consist of Sections and sub-sections which will then include Paragraphs, Images, 

Tables and Charts.  

 

8.1 Creating Report Sections 
 

The first step in managing the content of a report is to create the sections of the report. 

Sections within the report allow easier navigation through the report and programs such 

as Microsoft Word to identify the titles and create a navigation bar.  

 

To add the first new Section to your report select Add<Section from the bottom of the 

window as shown in Figure 16. 
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Figure 16. Adding a Section to a report 

 

You will then be asked to name the Section in a resulting pop-up window. Once you have 

given the Section a name, click OK to create the section. It will then appear in the Report 

Content section of the Edit Report window. 

 

Once the first Section has been added, to add additional sections you must instead use 

the Insert<Section option. This will allow a new Section to be created instead of a sub-

section (further explained in Section 8.1.1). The inserted section will then appear at the 

top of the Report Content list.  

 

Sections can be moved within the report by selecting them from the list and using the up 

and down arrows to the right of the list. This is explained in more detail in Section 8.9. 
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8.1.1 Creating Sub-Sections 
 

Once you have added sections to the report, it is then possible to add Sub-Sections 

within those Sections. To do this ensure that the Section is selected, then click on 

Add>Section as shown in Figure 17. You will then be able to name the new Sub-Section. 

 

 

 

Figure 17. Creating Sub-Sections 

 

Once the Sub-Section has been created you will see it appear in the Report Content list 

but it will be offset to the right from the Section under which it was created. 

 

To add a new Sub-Section at the same level, you should then reselect the original 

Section and repeat the steps outlined above. To add an additional level you would then 

need to select the Sub-Section before clicking Add>Section. 

 

8.2 Inserting Page Breaks 
 

Adding a page break within a report will allow a new Section or item to appear on a new 

page instead of following directly from the previous object. A page break can be added at 

any point within the report.  

 

There are two ways in which a page break can be added, using the Add menu or the 

Insert menu. Adding a page break using the Add menu (Add>Page Break) will add a new 

break to the bottom of the report. Using the Insert option (Insert>Page Break) will insert 

the break above the currently selected item from the Report Content list.  
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These same two Insert and Add options apply for all other new objects added to the 

report. 

 

8.3 Creating/Editing Paragraphs 
 

A Paragraph within an Asset DB report relates to either a full paragraph of text or a 

Section or Sub-Section title. Just like the Page Breaks, there are two ways in which a 

Paragraph can be added, using the Add menu (Add>Paragraph) or the Insert menu 

(Insert>Paragraph).  

 

Once the Paragraph is created, select it from the Report Content list and click Edit to 

allow changes to be made. A paragraph that has already been created is edited in the 

same way. 

 

 

 

Figure 18. Creating a Paragraph 

 

You are then able to create/edit the text that you would like to appear by typing in the 

white box.  

 

The text will automatically appear in the Paragraph style. To change the appearance of 

the text, first highlight the section to be changed. Then you can use the buttons along the 
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top of the window to either select a predefined style from the drop-down, or manually 

make changes using the individual options. 

 

All changes made to a Paragraph can then be saved and previewed by clicking the Save 

button. This will also update the name of the paragraph in the Report Content list to show 

the first line of the paragraph. 

 

8.3.1 Creating Project Assets Paragraphs 
 

A Project Assets Paragraph is a paragraph of text which can also contain parameters 

based on the data within the project’s current state. This will allow dynamic numeric 

values to be included in a paragraph. 

 

Just like a standard Paragraph, there are two ways in which a Project Assets Paragraph 

can be added, using the Add menu (Add>Project Assets>Paragraph) or the Insert menu 

(Insert>Project Assets>Paragraph).  

 

Once the Paragraph is created, select it from the Report Content list and click Edit to 

allow changes to be made. The text within the Project Assets paragraph is then created 

and amended in the same way as a standard Paragraph. 

 

To enhance your text with a parameter, click the ‘Insert Parameter’ button ( ) which will 

produce the Create Parameter window. The parameter can then be created as explained 

in Section 8.5.1.  

 

Within each system report there are various pieces of text such as section and chart titles 

and paragraphs about the data shown. Each of these is fully editable within the Edit 

Report window. To open the Edit Report window select Reports>Manage>Design. Select 

the chosen copied report from the Reports management window and click Edit. 

 

To edit a piece of text within a report you should first select the item from the Report 

Content list which will appear in the home screen of the Edit Report window. You will 

then be shown a preview of the selected article in the Section of Content panel. 

 

To start editing the chosen section, click on the Edit button at the bottom right corner of 

the Section of Content panel. This will then display the text in an editable format as seen 

in Figure 19.  
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Figure 19. Editing text within a report 

 

The body of the text can then be updated to your desired state. A preview of the new text 

can be seen by clicking on the Save button. 

 

In addition, it is also possible to edit the size and colour of the text within the Section of 

Content panel. Selecting the Edit button again will display the text in an editable format 

and will also show font options at the top, highlighted in Figure 19.  

 

The default colour and size etc. will be determined by the Style that has been chosen for 

the report using the Report Style drop-down. The font will also be determined by the 

Style and cannot be changed at this point. Details of how this can be changed can be 

found in Section 9.  

 

The text appearance can be changed by first selecting the text, then either using the 

drop-down menu to select a pre-determined heading style, or using the individual editing 

options. These include bold, underlined and italic as well as text and highlighting colours.  

 

Any changes that have been made can be saved and a preview shown by selecting the 

Save button. 
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8.3.2 Creating Virtual Assets Paragraphs 
 

If you have also created a Solution for your project, it is then possible to create 

paragraphs containing parameters based on the virtual assets in that solution. 

  

Just like a standard Paragraph, there are two ways in which a Virtual Assets Paragraph 

can be added, using the Add menu (Add>Virtual Assets>Paragraph) or the Insert menu 

(Insert>Virtual Assets>Paragraph).  

 

The content of the paragraph can then be created as per the instructions in Section 8.3.1 

and then saved by clicking Save. 

 

8.4 Creating/Editing Report Tables 
 

There are three types of table that could appear in a report. The first is a standard Table 

which consists predominantly of text with the addition of numeric parameters. The 

second type of table is a Dynamic Table which is made up of lists of data taken from the 

project. The third is a Cross Tab table which allows multiple data calculations to be 

shown for a single field. 

 

8.4.1 Editing a Standard Table 
 

A Standard table can be added or inserted into a report by selecting Add>Table or 

Insert>Table. Once created, a new or existing table can then be selected from the Report 

Content list and edited by clicking the Edit button.  

 

This will then present you with the table in an editable format along with the settings 

available to be changed as shown in Figure 20.  
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Figure 20. Editing a standard table 

 

The first settings to be edited are for the layout of the table. The table can be embedded 

into a standard page along with other pieces of text and charts. Alternatively, by selecting 

the Full Page check-box the table can appear on a page by itself.  

The additional option for the layout of the table is to set the horizontal margin at either 

side of the table on the page. This can be set from 0% such that the table expands to the 

margin of the page, up to 100% such that the size of the text within the table determines 

the width of the table. 

 

The size of the table in terms of rows and columns can then be altered by increasing or 

decreasing the number of each in the Table Size section. Additional rows will be placed 

at the bottom of the table and additional columns will be added to the right as shown in 

Figure 21. Similarly, removed columns will be taken from the right and removed rows will 

be taken from the bottom.  
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Figure 21. Adding rows and columns to an existing table 

 

Once the physical structure of the table has been edited, the text within the table can 

then be added. To enter text into a cell in the table, select the cell and then type the 

desired text. The height of the cell’s row will automatically adjust depending on the 

amount of text entered into the cell. The style of the added text can then be customised 

using the buttons along the top of the preview pane. 

 

Once all desired changes have been made to the table, the changes can be saved and a 

preview shown by clicking the Save button. 

 

8.5 Creating Project Assets Tables 
 

As well as the standard table mentioned above, there are three additional types of 

Project Asset Tables that can be added or inserted into a report, a standard Project 

Assets Table, a Project Assets Dynamic Table and a Project Assets Cross Tab table. 

 

8.5.1 Adding a Parameter to a Standard Project Assets Table 
 

In addition to adding plain text to a standard table, it is also possible to add single 

parameters based on the data within your project. In the example table shown in Figure 

20 from the Print Assessment Summary report, the table consists of text cells stating a 

maximum, minimum and average user:device ratio for a company which would be static 

figures in all reports run. There is then also a parameter which has been created to 

portray the actual user:device ratio for the project. 

 

A Standard Project Assets table can be added or inserted into a report by selecting 

Add>Project Assets>Table>Table or Insert>Project Assets>Table>Table. The table can 

then be edited by selecting the report from the list and clicking Edit. 

 

Number of rows 

and columns 

increased 

Additional rows 

added below 

and column 

added to the 

right 
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To insert a parameter into a cell first select the cell then click the ‘Insert Parameter’ 

button ( ) which will produce the Create Parameter window shown in Figure 22.  

 

 

 

Figure 22. The Create Parameter window 

 

To create a parameter you must first give the parameter a name. This will then appear 

within the parameter brackets in the selected cell. This can be seen for the “Device Ratio” 

parameter used in Figure 20.  

 

The next step is then to determine the type of parameter to be created. There are three 

options which are described as follows: 

 

8.5.2 Calculation 
 

A calculation will produce a single value based on one of the following operations: 

 

Count: The number of values in a data field (i.e. total devices with a finisher) 

Distinct Count: The number of distinct values in a data field (i.e. total distinct 

models) 

Sum: The total of all values in a numeric field 

Average: The average of all values in a numeric field  

Lowest: The lowest value in a numerical field 

Highest: The highest value in a numerical field 

Standard Deviation: The measure of dispersal of your data 

Variance: The variance between the lowest and highest value in a numeric field 

First: The first item in a list of text values such as the first Asset Number 

 

Once the calculation has been selected from the drop-down, you can then use the data 

field drop down to determine to which field the calculation should refer. For certain 

calculations there are restrictions around which fields can be chosen. Count, Distinct 

Count and First can be used for any field whereas all others can only be used for numeric 

fields.  
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An example of using a calculation parameter could be to show the total number of 

different models within a print fleet. For this, the user would give a name of “Different 

Models”, select Distinct Count as the calculation and then Model from the field drop-

down. This would then appear in the table as a single number showing the number of 

models in the fleet. 

 

8.5.3 Percentage 
 

A percentage parameter allows the user to produce a value that represents one 

calculated value as a percentage of another. An example of such a calculation could be 

the percentage of the total volume that is colour volume.  

 

The percentage calculation will be made up of two values, one which will be a 

percentage of the other. Each of these values will be determined by a calculation which 

will be produced using the method described above.  

 

  

 

Figure 23. Creating a percentage parameter 

 

8.5.4 Ratio 
 

A ratio parameter is calculated similarly to a percentage parameter. Again, you would 

need two calculated values but the final calculation would be represented as a ratio (two 

values separated by a colon). These values would once again be calculated using the 

method described above. 

 

An example of the usage of a ratio parameter could be to calculate the ratio of printers 

compared to MFDs or the user:device ratio as mentioned above. 

 

 

For any of the three calculations, as well as using standard fields, it is also possible to 

create custom fields within the Datasource tab of the Section of Content pane. Details on 

how to create custom fields can be found in Section 7.1. 

 

Value 1 will be 

represented as a 

percentage of Value 2 
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8.5.5 Creating a Dynamic Table 
 

A dynamic table, as mentioned above, is made up of lists of data taken from the project. 

The lists created can then be limited to a certain number of values to show the top 10 or 

bottom 5 for example.  

 

A Project Assets Dynamic Table can be added or inserted into a report by selecting 

Add>Project Assets>Table>Dynamic Table or Insert>Project Assets>Table>Dynamic 

Table. The table can then be edited by selecting the report from the list and clicking Edit. 

This will then show the characteristics of the table in an editable format as shown in 

Figure 24. 

 

 

 

Figure 24. Editing a Dynamic Table 

 

The layout of the table is set up the same as for a standard Table as described in Section 

8.4.1. A Dynamic Table is then also given a Title which will appear above the table in the 

finished report.  

 

Once the above features of the report are defined, the columns of the table can then be 

created in the Columns panel. A column is added by double clicking in the first empty cell 

in the Field Column. This will then allow you to select a field of data that you wish to 

display from the project’s icon customisation. 
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You will then have the option to give the new column a custom Heading. If this cell is left 

blank then the heading will match the name of the field. To apply a custom heading 

simply double click in the relevant cell and then type the desired heading. 

 

The final column to be completed is the weight. This will determine how wide the column 

will appear in the table (based on a ratio of 0 up to 1).  The weight is also set by double 

clicking in the cell and typing the required figure.  

 

The final feature of the Dynamic Table that can be edited in the Properties tab is the 

Grouping. Results in the table can be grouped together by location by selecting the 

Group by Location check-box. To group by any other field (Model for example) click on 

the Add button and then select the desired field from the icon customisation.   

 

8.5.6 Editing a Dynamic Table Datasource 
 

In addition to standard data fields, the table can also contain custom fields created using 

the existing fields. The custom fields are created in the Datasource tab (shown in Figure 

25). Additional details on how these custom fields can be created can be found in Section 

7.1.  

 

In addition to the custom fields, a sort order can also be created in the Datasource tab. 

This will show the current field by which the table is sorted. This sort order can be 

changed using the methods described in Section 7.2.  
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Figure 25. Editing a Dynamic Table – the Datasource tab 

 

Criteria can also be set which will filter the data within the project before it appears in the 

report. The process used to set the criteria is explained in Section 7.  

 

The final setting within the Datasource tab is the Limit. This will determine the number of 

results that will display in the report to show a top 10 for example. To edit the limit simply 

type the required limit into the field. 

 

All changes made to a Dynamic Table can then be saved and previewed by clicking the 

Save button. 

 

8.5.7 Creating a Cross Tab Table 
 

A Cross Tab table will allow multiple pieces of information to be shown for a single field. 

For example, for each make of devices, a Cross Tab table could show the number of 

different models there are for that make as well as the number of colour devices and the 

number of mono devices. So compared to a Standard or Dynamic table it is possible to 

portray a lot more information within a Cross Tab table. 
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A Project Assets Cross Tab Table can be added or inserted into a report by selecting 

Add>Project Assets>Table>Cross Tab Table or Insert>Project Assets>Table>Cross Tab 

Table. The table can then be edited by selecting the report from the list and clicking Edit.  

This will then show the characteristics of the table in an editable format as shown in 

Figure 26.  

 

 

 

Figure 26. Editing a Cross Tab Table 

 

The Layout of the table is set up the same as for a standard Table as described in 

Section 8.4.1. A Cross Tab table is then also given a Title which will appear above the 

table in the finished report.  

 

Once the above features of the report are defined, the project Datasource can be 

determined including any custom fields, filter criteria or limits for the table. This is done 

using the methods described in Section 7. 

 

When the Datasource is determined, the columns of the table can then be created. The 

first Column to be created is the left hand title column. This will create a new row for each 

of the values for which the other columns will display information. In the example 

mentioned above, the title column will create a new row for, and show the name of each 

of the makes in the project. This is created using the Group By drop-down.  
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There are then two additional types of Columns that can be added as follows:  

 

8.5.8 Calculation Column 
 

A Calculation Column will show a value associated with each row of the table based on 

the following calculations:  

 

Count: The number of values in a data field (i.e. total devices with a finisher) 

Distinct Count: The number of distinct values in a data field (i.e. total distinct 

models) 

Sum: The total of all values in a numeric field 

Average: The average of all values in a numeric field  

Lowest: The lowest value in a numerical field 

Highest: The highest value in a numerical field 

Standard Deviation: The measure of dispersal of your data 

Variance: The variance between the lowest and highest value in a numeric field 

First: The first item in a list of text values such as the first Asset Number 

 

To edit a column, first double click in the relevant row in the Column Name column. This 

will then allow you to amend the name that will appear in the top title row. The next stage 

is to amend the field of data on which the calculation will be based. This is done by 

double clicking the cell and then choosing the relevant field from the pop-up. 

 

The next stage is to select the calculation from the next column using the drop-down. As 

mentioned before, for certain calculations there are restrictions around which fields can 

be chosen. Count, Distinct Count and First can be used for any field whereas all others 

can only be used for numeric fields. 

 

The final option to select for a Calculation Column is the weight of the column. This is a 

value from 0 to 1 and will determine the width of the column. This is again changed by 

double clicking in the cell and then typing a new value. 

 

8.5.9 Count Column 
 

The second additional type of column that can be produced is a Count Column which will 

produce a count of all devices for each row that satisfy defined criteria. 

 

The first stage in editing a Count Column is to amend the name. This is done by double 

clicking the relevant row in the Column Name column. As for the Calculation Column this 

will change the name that will appear in the title row.  
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The next stage is then to set up the criteria on which the counts will be based. This is 

done by double clicking in the relevant cell in the Criteria column and then following the 

instructions explained in Section 7.  

 

Finally, the weight of the Count Columns is changed by double clicking in the cell and 

then typing a new value from 0 to 1. 

 

Once all of the settings for the Cross Tab table have been edited as desired they can be 

saved and previewed by clicking the Save button. 

 

8.6 Creating Virtual Assets Tables 
 

In addition to the project assets tables mentioned above, each of the three table types 

can be created as Virtual Assets tables to incorporate data from the project’s Solution.  

 

The three Virtual Assets tables are added or inserted into a report by selecting 

Add>Virtual Assets>Table>Table/Dynamic Table/Cross Tab or Insert>Virtual 

Assets>Table>Table/ Dynamic Table/Cross Tab.  

 

Once created, the table can then be selected from the Report Content list and edited by 

clicking the Edit button. The tables can then be created using the processes explained in 

Section 8.5. 

 

8.7 Creating/Editing Report Assets Charts 
 

There are three types of chart that can be created in an Asset DB report, a Pie Chart, a 

Series Pie Chart and a Bar Chart. Each of these chart types will display the data from 

your project in a way set by the user.  

 

8.7.1 Creating a Pie Chart 
 

A Pie Chart in an Asset DB report is a standard pie chart where different outcomes of a 

data field are represented by chunks of a circular “pie” sized in relation to their proportion 

of the total of that data field. 

 

A Pie Chart can be added or inserted into a report by selecting Add>Project 

Assets>Chart>Pie or Insert> Project Assets> Chart>Pie.  

 

Once created, the chart can then be selected from the Report Content list and edited by 

clicking the Edit button.  
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The first aspects of the Pie Chart to be edited are the physical features including the 

layout and title.  

 

Within the Layout panel, the horizontal margins at either side of the chart on the page 

can be set from 0% such that the table expands to the margin of the page, up to 95% 

which will create a very slim chart. This is adjusted using the up and down arrows next to 

the field. 

The chart can then be set to be on its own page within the report by selecting the Full 

Page check-box.  

 

The title of the chart can be edited simply by changing the text in the Title field. 

 

 

 

Figure 27. Editing a Pie Chart 

 

The final physical feature of the Pie Chart to be determined before the data is edited is 

the label format. Within the Label Format drop down there are five options explained as 

follows: 

 

 Group By: The title of the data group (e.g. Printer/MFD/Fax for Asset Type) 

 Value: The value of the data group (e.g. the count or sum of a field) 
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 Percentage: The percentage that each section is of the total chart 

Group By and Value: The title and the value of the data group 

Group By and Percentage: The title and the percentage of the data group 

 

The label format for a chart can be changed by selecting a different option from the drop-

down list. 

 

The next option that can be edited is the data field from the icon customisation by which 

the data in chart will be grouped. This is selected in the Group By drop-down. The title of 

this field will then show on the chart label if one of the Group By options is selected.  

 

The final stage is to set the calculation to determine the Value or Percentage associated 

with each group. A calculation will produce a single value per group based on one of the 

following operations: 

 

Count: The number of values in a data field (i.e. total devices with a finisher) 

Distinct Count: The number of distinct values in a data field (i.e. total distinct 

models) 

Sum: The total of all values in a numeric field 

Average: The average of all values in a numeric field  

Lowest: The lowest value in a numerical field 

Highest: The highest value in a numerical field 

Standard Deviation: The measure of dispersal of your data 

Variance: The variance between the lowest and highest value in a numeric field 

First: The first item in a list of text values such as the first Asset Number 

 

Once the calculation has been selected from the drop-down, you can then use the data 

field drop down to determine to which field the calculation should refer. For certain 

calculations there are restrictions around which fields can be chosen. Count, Distinct 

Count and First can be used for any field whereas all others can only be used for numeric 

fields.  

 

These calculated values will then determine the outcome of the Pie Chart in the final 

report. 

 

In addition to the above amendments that can be made to a Pie Chart, the Datasource 

for the chart can also be edited including filtering the data and creating custom fields. 

This is done using methods explained in Section 8.5.6.  
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8.7.2 Editing a Series Pie Chart 
 

A Series Pie Chart in an Asset DB report allows multiple pieces of information to be 

displayed within the same Pie chart, each represented by its own Chunk of the pie. An 

example of this in the Print Assessment Summary Report is the Cost Summary by 

Mono/Colour. This allows two separate fields, Mono Cost and Colour Cost to be 

displayed as separate slices in the same pie. 

 

A Pie Chart can be added or inserted into a report by selecting Add>Project 

Assets>Chart>Series Pie or Insert> Project Assets> Chart>Series Pie.  

 

To edit the Series Pie, first select it from the Report Content list and click the Edit button. 

The first aspects of the Series Pie Chart to be edited are the physical features including 

the layout and Caption. These aspects are edited as per the method for a Pie Chart in 

Section 8.7.1. The Caption for a Bar chart appears below the chart but is edited just as 

the Title for the Pie Chart. 

 

 

 

Figure 28. Editing a Series Pie Chart 

 

The final physical feature of the Series Pie Chart to be determined before the data is 

edited is the label format. This is again edited as per the standard Pie Chart in Section 

8.7.1. 
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The final stage is to amend each of the slices of the pie chart. Each slice consists of a 

data field from your icon customisation along with a calculation from the list below: 

 

Count: The number of values in a data field (i.e. total devices with a finisher) 

Distinct Count: The number of distinct values in a data field (i.e. total distinct 

models) 

Sum: The total of all values in a numeric field 

Average: The average of all values in a numeric field  

Lowest: The lowest value in a numerical field 

Highest: The highest value in a numerical field 

Standard Deviation: The measure of dispersal of your data 

Variance: The variance between the lowest and highest value in a numeric field 

First: The first item in a list of text values such as the first Asset Number 

 

As with the standard pie chart, certain calculations have restrictions around which fields 

can be chosen. Count, Distinct Count and First can be used for any field whereas all 

others can only be used for fields with numeric values.  

 

First, select the required field for the slice by double clicking on the relevant cell in the 

Field column. You can then choose the desired field from the project’s icon 

customisation. You can then select the calculation required to determine the value of that 

slice. This is done by simply selecting from the drop-down in the Calculation column. 

 

In addition to the above amendments that can be made to a Pie Chart, the Datasource 

for the chart can also be edited including filtering the data and creating custom fields. 

This is done using methods explained in Section 8.5.6.  

 

Once all changes have been made, they can be saved and previewed using the Save 

button. 

 

8.7.3 Editing a Bar Chart  
 

A Bar Chart within an Asset DB report is a standard bar chart where different outcomes 

of a data field are represented by bars in a cross axis chart with heights sized in relation 

to their value. 

 

A Pie Chart can be added or inserted into a report by selecting Add>Project 

Assets>Chart>Bar or Insert> Project Assets> Chart>Bar.  
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The first aspects of the Bar Chart to be edited are the physical features including the 

layout and Caption. These aspects are edited as per the method for a Pie Chart in 

Section 8.7.1. The Caption for a Bar chart appears below the chart but is edited just as 

the Title for the Pie Chart.  

 

 

 

Figure 29. Editing a Bar Chart 

 

The next aspect of the Bar Chart that can be edited is the X-axis of the chart. That is, the 

data field from the icon customisation by which the data in chart will be grouped. This is 

selected in the Category drop-down.  

 

The final stage in editing a Bar Chart is to amend the Series. This will determine how 

many sets of bars the chart will contain and the data that will determine the size of each 

bar. There are two types of Series, Calculation and Expression. Multiple series can be 

created but each must be of the same type. The types of series are edited as follows: 

 

8.7.4 Calculation 
 

A calculation series will produce a single value per group based on one of the following 

operations: 
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Count: The number of values in a data field (i.e. total devices with a finisher) 

Distinct Count: The number of distinct values in a data field (i.e. total distinct 

models) 

Sum: The total of all values in a numeric field 

Average: The average of all values in a numeric field  

Lowest: The lowest value in a numerical field 

Highest: The highest value in a numerical field 

Standard Deviation: The measure of dispersal of your data 

Variance: The variance between the lowest and highest value in a numeric field 

First: The first item in a list of text values such as the first Asset Number 

 

To edit an existing Calculation series or to add an additional series, first double click in 

the cell in the Field column. This will then allow you to choose a new field to which the 

calculation will refer. The type of calculation required from the list above can then be 

selected from the Calculation drop-down. For certain calculations there are restrictions 

around which fields can be chosen. Count, Distinct Count and First can be used for any 

field whereas all others can only be used for numeric fields.  

 

8.7.5 Expression 
 

An expression series allows the data within the project to be filtered further in order to 

create the bars. This will then create customised fields to show in the Bar Chart.  

 

The first stage to edit an Expression Series is to edit the column name. This is done by 

double clicking the relevant cell in the Column Name column. You should then create the 

associated criterion/criteria. This is set using the methods explained in Section 7. 

 

In addition to the above amendments that can be made to a Bar Chart, the Datasource 

for the chart can also be edited including filtering the data and creating custom fields. 

This is done using methods explained in Section 8.5.6.  

 

8.8 Creating Virtual Assets Charts 
 

In addition to the project assets charts mentioned above, each of the three chart types 

can be created as Virtual Assets charts to incorporate data from the project’s Solution.  

 

The three Virtual Assets charts are added or inserted into a report by selecting 

Add>Virtual Assets>Chart>Pie/Series Pie/Bar or Insert>Virtual Assets>Chart/Pie/Series 

Pie/Bar.  
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Once created, the chart can then be selected from the Report Content list and edited by 

clicking the Edit button. The charts can then be created using the processes explained in 

Section 8.7. 

 

8.9 Changing the Report Order 
 

To edit the order of a report, first select Reports>Design>Manage from the menu bar to 

open the report management window. Now select the desired report from the list and 

select Edit.  

 

This will then produce the Edit Report window and the Properties tab (as shown in Figure 

30) where we will make the changes to the report structure.  

 

 

 

Figure 30. The Edit Project window – Properties tab 

 

Within the properties tab you will then see the Report Content panel shown highlighted in 

Figure 30. This will list all of the sections of the selected report, in this case a copy of the 

Print Assessment Summary report. Section and sub-section names are wrapped with 

thick black lines and paragraphs, graphs and tables within that section are listed below.  

 

Move a section or 

object up or down in 

the list 
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A section can be moved to any other area within the report, a sub-section can be moved 

only within its section and an object (an image, paragraph, table or chart) can only be 

moved within its section or sub-section. 

 

To move any item, first select the item in question from the Report content panel. For 

objects this will then show a preview of how that object will appear in the report  and then 

use the up and down arrows to the right of the list to determine the new location of the 

item. 

 

As well as being able to move objects around within the report, the Report Content panel 

will also allow us to remove a section or object from the report. This may be to avoid 

blank charts for missing data or to remove unwanted images or text for example. 

 

To delete a section or object from the report, select the object from the list and then 

select the delete button at the bottom of the list.  

 

Once you are happy with the new structure of your Report, your changes can be saved 

by clicking on the OK button at the bottom right corner of the Edit Report window.  

 

9 Exporting/Importing Report Designs 
 

An edited or created report structure can be exported from the Asset DB install in which it 

was created and hence shared with other Asset DB users. This will allow a single user 

within an organisation to create the report structures and all other users with an 

equivalent licence (full report editing capabilities) to be able to produce the same report 

without the need to re-run the copy/creation process. 

 

A report structure is exported by selecting Reports>Design>Export from the menu bar. 

You should then select the desired report from the subsequent list and select Export 

which will produce a .rpt file.  

 

To import a Report structure, navigate to Reports>Design>Import and then navigate to 

the saved .rpt file. This report can then be run for any project within your system. 


