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1. Introduction 

This chapter describes how to use this guide. 

Note: This documentation is written for Xerox Web Document 
Submission Version 2.0.1. 

Intended Audience 

This manual is intended for use by Xerox personnel who are responsible 
for the installation of the Adobe PDF Transit module on the Xerox Web 
Document Submission Software system.   

Assumptions 

The person installing Adobe PDF Transit software should have 
experience in the following areas: 

• Windows 2000 server administration  
• Applicable workstation operating systems experience 
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Conventions 

This guide uses the following conventions:  

• Menu items and buttons appear in bold text. 
• Screen, text box, and drop-down list titles, are spelled and punctuated 

exactly as they appear on the screen.  
• Document titles appear in italics. 
• Content representative of text that is displayed on a computer monitor 

is displayed in Courier New font and enclosed in a shaded table as 
shown in Table 1-1. 

Table 1-1. Example of text displayed on a computer monitor 

INSERT INTO Field {field_name,custom_name} 

Related Documentation 

The following guides provide further information on the  
Web Document Submission system: 

• Xerox Web Document Submission Software Installation Planning 
Guide – Part Number 701P37977 

• Xerox Web Document Submission Software Installation and 
Configuration Guide – Part Number 701P37978  

• Xerox Web Document Submission Software System Administration 
Guide – Part Number 701P37979 

Note: Operator / Administrator and User instructions are available as 
online help while using the Web Document Submission system. 
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2. Product Overview 

Xerox Web Document Submission Software 

Web Document Submission allows end users to submit print jobs 
electronically using industry standard browsers. Once submitted, 
production personnel efficiently update job status as documents move 
through the production cycle, providing users with information about their 
jobs. Web-based printing generates cost savings and improvements in 
quality, productivity, and turnaround time. 

The system uses several services that can be loaded on one or more 
servers, depending on the print shop configuration. 

Adobe® PDF Transit™ 

Adobe PDF Transit is an optional installable module for the Web 
Document Submission system. On the user workstation, Adobe PDF 
Transit installs like a print driver and converts files to Portable Document 
Format (PDF). Users can open a file in its native application and choose 
the Adobe PDF Transit print driver from the list of installed printers.  

Integrated with Web Document Submission, Adobe PDF Transit supports 
document submission in an almost exact workflow to that of the Xpress 
Print Driver (XPD). Users can submit documents for production by using 
the standard print dialog offered by Adobe PDF Transit for their particular 
supported operating system. Upon confirmation of submission, the Adobe 
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PDF Transit driver converts the file to PDF, initiates a browser session, 
and loads the Web Document Submission log on page. After 
authenticating the user, the system continues to upload the file, attach it 
to a new order, and prompt for instructions using the same workflow as a 
typical web submission. 

The Adobe PDF Transit module for the Web Document Submission 
system is comprised of two portions: 

Adobe PDF Transit Server 

The Adobe PDF Transit Server component is a set of software libraries 
that is integrated into the Web Document Submission software. 

Adobe PDF Transit Client 

Adobe PDF Transit Clients are installed on user workstations. The clients 
allow users to choose PDF Transit to send print-ready files directly from 
Windows to the Web Document Submission system.  
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3. Installation Requirements 

Web Document Submission requires a specific combination of hardware, 
software, and information to ensure a successful installation. These 
requirements are documented in the Web Document Submission — 
Xerox Web Document Submission Software Installation Planning Guide. 
An overview of the hardware and software requirements follow. 

Hardware Requirements 

Server Requirements for Adobe PDF Transit Module 

One Windows 2000 server with Xerox Web Document Submission 
Software Version 2.0.1 or later installed. 

Client Requirements for Adobe PDF Transit Module 

A workstation capable of using a supported client operating system and a 
supported browser. 
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Software Requirements 

Server Requirements 

The server requires the following software in order to install  
Adobe PDF Transit. 

• Microsoft Windows 2000 Server  
• Microsoft Office XP 
• Adobe Acrobat Reader  
• Xerox Web Document Submission Software  
• Internet Explorer 5.5 (or later) or Netscape Navigator 4.75 (or later)  
• WinZip (for full Web Document Submission installation only) 

Client Requirements  

Adobe PDF Transit drivers are available for all of the following operating 
systems:  

• Windows 95 (Service Release 2 / Windows Sockets 2.0) 
• Windows 98 
• Windows ME 
• Windows NT 4.0 
• Windows 2000 
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4. Installing the Software 

The Web Document Submission software is distributed on two CDs. CD 1 
contains the Web Document Submission software. CD 2 contains the 
Adobe PDF Transit software. Which of the CDs are used depends on the 
current state of the Web Document Submission installation. 

Installation Paths 

There are two paths to installing Adobe PDF Transit. The method of 
installation depends on if Adobe PDF Transit is part of a new system 
being installed or on an existing Web Document Submission system, as 
shown in Figure 4-1. 

Figure 4-1. Installation paths for installing Adobe PDF Transit 
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New Installation including Adobe PDF Transit 

This is the path to choose for installation if this is an installation where 
Web Document Submission has not already been installed. The 
procedure to install Web Document Submission and Adobe PDF Transit 
begins on page 4-2.  

Upgrade Web Document Submission to add Adobe PDF Transit 

This is the path to choose if there is already a working Web Document 
Submission system operating and Adobe PDF Transit is to be added to 
the existing installation. The procedure to upgrade Web Document 
Submission begins on page 4-9. 

Installing Web Document Submission including Adobe PDF Transit 

Ensure that the Web Document Submission server is operating properly 
before attempting to install Web Document Submission and the Adobe 
PDF Transit module. Figure 4-2 illustrates the workflow to complete the 
new installation. 
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Figure 4-2. New Web Document Submission installation process  
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Perform the following to install Web Document Submission and add 
Adobe PDF Transit: 

1. Insert CD1 (Web Document Submission) Installation CD into the 
CD-ROM drive of the server. 

2. Starting at page 4-1 and proceeding to the end of the Web Document 
Submission Software Installation and Configuration Guide, install and 
test Web Document Submission. Return to this guide and the next 
step when the software is operating properly. Ensure that the Web 
Document Submission system has been shut down before proceeding 
to the next step. 

3. Insert CD2 (Adobe PDF Transit) Installation CD into the CD-ROM 
drive of the server. 

4. Double-click My Computer. 

5. Go to <CD ROM Drive> and double-click pdftransit_init. 

6. A window opens and requests the path to the Web Document 
Submission software. Select C:\XDX and press the Enter key on the 
keyboard. 

7. Once the files have been transferred to the Web Document 
Submission server an Installation Notice window appears with a 
reminder to change the flag for Adobe PDF Transit Conversion from 
false to true. The steps that follow will perform that task. Click OK. 
Close any open windows. 

8. Restart the Web Document Submission system. On the server, 
double-click My Computer. Go to C:\xdx\scripts and double-click 
xwdss-startup.bat. 
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9. As Web Document Submission services begin, buttons appear on the 
taskbar to show running processes. Processes started are APACHE, 
MYSQL, RMID, and TOMCAT.  

 

10. Almost instantly, the APACHE button disappears from the taskbar. To 
see any system messages delivered to any of these processes, 
simply click the button to view the window for the desired process. 
The window may have to be resized in order to see the system 
messages. 

 

11. Once the Web Document Submission processes have started go to 
C:\xdx\scripts and double-click ControlCenter.bat. 

12. When the XDX Control Center has appeared click  
Tools > Configuration Manager. 
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13. The configuration_control_panel window appears. Using the 
mouse, adjust the vertical bar so that the left side pane can be 
completely seen. 

 

14. Click the + beside xdxConf to open the configuration folder. 

15. Click the + beside properties to open the properties folder. 

16.  Click the + beside Conversion to open the Conversion folder. 

17. Click Adobe PDF Transit Support. 

4-6 ADOBE PDF TRANSIT INSTALLATION AND CONFIGURATION SUPPLEMENT 



XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0.1 STARTING UP AND SHUTTING DOWN  

18. Change the Property Value for Adobe PDF Transit Support from 
false to true. 

 

19. Click File > Save to save the change. 

20. A Login window appears. Enter the Username admin and the 
Password 22222 and click OK. 
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21. Close the configuration_control_panel by clicking X. Close the XDX 
Control Center by clicking X. 

 

22. For the change to take effect, the Web Document Submission system 
must be shut down and restarted.  

23. Once the Web Document Submission system has been restarted,  
log on to the system and ensure that the Adobe logo appears in the 
footer section of the user log on window. The Adobe logo will appear 
on every web page. 

24. From the user home page, click Download Software. Ensure that the 
links for downloading the Adobe PDF Transit software and 
documentation are present.  

Users can now download the Adobe PDF Transit software from the 
Downloads page on the Web Document Submission user home 
page. Instructions for installing this software are available from the 
online help menu, as well as Chapter 5 – Installing the Adobe PDF 
Transit Client Drivers in this guide. 

 

 

 

4-8 ADOBE PDF TRANSIT INSTALLATION AND CONFIGURATION SUPPLEMENT 



XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0.1 STARTING UP AND SHUTTING DOWN  

Upgrading Web Document Submission to Add Adobe PDF Transit 

Ensure that the Web Document Submission 2.0 software is operating 
properly before attempting to perform the upgrade to add Adobe PDF 
Transit. Figure 4-3 illustrates the workflow to complete the upgrade. 
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Figure 4-3. Web Document Submission upgrade process 
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Perform the following to upgrade Web Document Submission to add 
Adobe PDF Transit: 

Shut down Web Document Submission 

1. If open, close the Control Center by clicking X. The corresponding 
command window will close automatically. 

 

2. Go to C:\xdx\scripts and double-click xwdss-shutdown.bat. All 
services will close and their corresponding command windows will 
close automatically. 

Back up the Web Document Submission Server 

To safeguard against the remote possibility of data loss during the 
upgrade, follow the established backup procedure for the Web Document 
Submission server and make a current backup of the server. 

Upgrade the Web Document Submission Server 

The following procedure will install the updated Web Document 
Submission software.  

1. Insert CD2 (Adobe PDF Transit) Installation CD into the CD-ROM 
drive of the server. 

3. Double-click My Computer. 

4. Go to <CD ROM Drive> and double-click pdftransit_init. 

5. A window opens and requests the path to the Web Document 
Submission software. Select C:\XDX and press the Enter key on the 
keyboard. 
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6. Once the files have been transferred to the Web Document 
Submission server an Installation Notice window appears with a 
reminder to change the flag for Adobe PDF Transit Conversion from 
false to true. The steps that follow will perform that task. Click OK. 
Close any open windows. 

7. Restart the Web Document Submission system. On the server, 
double-click My Computer. Go to C:\xdx\scripts and double-click 
xwdss-startup.bat. 

8. As Web Document Submission services begin, buttons appear on the 
taskbar to show running processes. Processes started are APACHE, 
MYSQL, RMID, and TOMCAT.  

 

9. Almost instantly, the APACHE button disappears from the taskbar. To 
see any system messages delivered to any of these processes, 
simply click the button to view the window for the desired process. 
The window may have to be resized in order to see the system 
messages. 

 

10. Once the Web Document Submission processes have go to 
C:\xdx\scripts and double-click ControlCenter.bat. 

11. When the XDX Control Center has appeared click  
Tools > Configuration Manager. 
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12. The configuration_control_panel window appears. Using the 
mouse, adjust the vertical bar so that the left side pane is completely 
visible. 

 

13. Click the + beside xdxConf to open the configuration folder. 

14. Click the + beside properties to open the properties folder. 

15.  Click the + beside Conversion to open the Conversion folder. 

16. Click Adobe PDF Transit Support. 
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17. Change the Property Value for Adobe PDF Transit Support from 
false to true. 

 

18. Click File > Save to save the change. 

19. A Login window appears. Enter the Username admin and the 
Password 22222 and click OK. 
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20. Close the configuration_control_panel by clicking X. Close the XDX 
Control Center by clicking X. 

 

21. For the change to take effect, the Web Document Submission system 
must be shut down and restarted. 

22. Once the Web Document Submission system has been restarted,  
log on to the system and ensure that the Adobe logo appears in the 
footer section of the user log on window. The Adobe logo will appear 
on every web page. 

23. From the user home page, click Download Software. Ensure that the 
links for downloading the Adobe PDF Transit software and 
documentation are present. 

Users can now download the Adobe PDF Transit software from the 
Downloads page on the Web Document Submission user home 
page. Instructions for installing this software are available from the 
online help menu, as well as Chapter 5 – Installing the Adobe PDF 
Transit Client Drivers in this guide. 
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5. Installing the Adobe PDF Transit 
Client Drivers 

The Adobe PDF Transit client drivers are available to users once they 
have log on to the Web Document Submission system. Instructions for 
the supported user workstation operating systems are included here and 
are also available from the online help system.  

Adobe PDF Transit Client Driver Installation 

Perform the following to download and install the Windows version 
of the Adobe PDF Transit client: 

1. On the Web Document Submission User home page, click Download 
Software. The browser refreshes and displays the Drivers and 
Documentation area.  

2. In Drivers and Documentation area, click the link for the appropriate 
operating system. The File Download window appears.  

3. Save the file and note the location where the file is saved. 

4. After the download is complete, locate and double-click the 
appropriate executable file: 

Executable Files for installing Adobe PDF Transit 

Windows 95/98/ME Windows NT Windows 2000 
setup9x.exe setupnt.exe setupw2k.exe 
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The Adobe® PDF Transit™ Client Setup installer appears.  

Note: Close any open software programs before proceeding. 
5. In the Adobe® PDF Transit™ Client Setup installer: 

a) Click Next. 

b) The following window appears:  

 
Modify the text in the window shown above to read as shown below by 
adding /xdx/servlet/pdftransit-upload after the IP address. Substitute 
YourServerName with the Web Document Submission IP address. 
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c) Click Next. 

d) Read the License Agreement and click Yes. The Choose 
Destination Location window appears.  

e) In the Choose Destination Location window, click Next. The Select 
Program Folder window appears.  

f) In the Select Program Folder window, click Next. The Start 
Copying Files window appears.  

g) Click Next. The Installation Complete window appears.  

h) In the Installation Complete window, click Finish. 

6. To confirm that the Adobe PDF Transit print driver has been installed: 

a) On the Windows taskbar, click Start.  

b) On the Start menu, move the pointer over Settings, then click 
Printers. 

c) Verify that Xerox Adobe PDF Transit Printer file icon is present. 
 

To send a job using the Xerox Adobe PDF Transit Printer driver 

1. From within a Windows application, on the File menu, click Print. 
The Print dialog box appears.  
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2. In the Print window: 

a) In the Printer area, on the Name list, click Xerox Adobe PDF 
Transit Printer.  

b) Click OK. The WDSS - Adobe PDF Transit v 1.0.1 window 
appears and the document file uploads, contacts the server, and 
indicates if the upload to the Web Document Submission server 
was successful. Upon a successful upload, a browser window 
launches.  

3. Log on to the system and proceed as if it were a normal print job. 

Removing the Adobe PDF Transit Client Driver 

To remove the Adobe PDF Transit Client driver, execute the following 
procedure: 

Perform the following to remove the Adobe PDF Transit Client 
driver: 

1. Click Start > Settings > Control Panel. Double-click Add/Remove 
Programs. 

2. The Add/Remove Programs Properties window appears. Locate 
and click Adobe PDF Transit 1.01 Client for Xerox Corporation. 

3. Click Add/Remove. The InstallShield window appears followed by 
the Confirm File Deletion window. Click OK. 

4. Files are removed from the workstation and when the process is 
complete, the Uninstallation Complete window appears. Click 
Finish. 

5. Click OK to close the Add/Remove Programs Properties window. 
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6. Close the Control Panel window. The removal of the Adobe PDF 
Transit Driver is now complete. 

Reinstalling the Adobe PDF Transit Client Driver 

To repair or reinstall the Adobe PDF Transit Client driver execute the 
following procedure. 

Perform the following to reinstall or repair the Adobe PDF Transit 
Client driver: 

1. Download the correct version of the driver from the Drivers and 
Documentation section of the Download page. 
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2. After the download is complete, locate and double-click the 
downloaded driver. The Adobe® PDF Transit™ Client Setup installer 
appears. Ensure Repair is selected and click Next. 

 

3. The software will request the Web Document Submission Server URL 
again. It must be the same URL given as before or the installation 
program will not proceed. 

4. The Setup Status window appears and shows the progress of the 
repair.  
 
When the repair is completed, click Finish. Check the driver by 
sending a job to the Web Document Server from a Windows 
application.
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6. Troubleshooting 

This section describes two methods for helping to diagnose problems that 
may occur. For further assistance with troubleshooting problems, consult 
Chapter 7 – Contacts and Escalation Process. 

Installation Problems 

The simplest way to ensure there are no installation problems is to have a 
clean server. Any existing versions of MySQL and any Java must 
removed. 

Ensure Microsoft Internet Information Services (IIS) are not operational. 

If an installation is not working, if the system is not an operational system, 
often it is easier to delete the C:\xdx folder and begin the installation 
again. Shut down Web Document Submission and reboot the server. 
After the server has restarted, remove the C:\xdx folder. Complete 
instructions are given in the Web Document Submission Software Version 
2.0.1 System Administration Guide. 

Debugging Apache and Tomcat 

The Apache server logs are located in C:\xdx\etc\Apache2\logs and the 
Tomcat servlet engine logs are located in C:\xdx\etc\tomcat4.0\logs. 
These logs provide valuable troubleshooting information if the software is 
not operating properly. 
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Note: Each time Apache is started, the previous error log is reopened 
and new information is appended to the end of the file. If there is an 
error in the system, the logs will contain debugging information. 

Debugging Web Document Submission Services 

Debugging output is saved to file by each Web Document Submission 
service. If there is an error with the system, examine these files to 
determine where the error has occurred. Generally, if there is a problem, 
a Java exception will be found in one of the log files. This message can 
be used to determine exactly what errors have occurred in the system. 

The log file messages that appear for Tomcat can modified by starting the 
Configuration Control Panel from the XDX Control Center. These steps 
assume the XDX Control Center is operational and the Documents 
System is running. 

Perform the following to modify the logging messages for Tomcat: 

1. On the XDX Control Center click Tools > Configuration Manager. 

2. The configuration_control_panel window opens. Click the + next to 
the xdxConf folder. 

3. Click the + next to properties. 

4. Click the + next to the Logging folder. 

5. Click Log Status. 

6. Change the Property Value from info to debug. This will increase the 
level of information returned from the system to the log files. 

7. Click File > Save to save all changes. 
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8. If required, enter the Username Admin and the Password 22222. 
Click OK. 

9. Click X to close the configuration_control_panel window.  
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7. Contacts and Escalation Process 

This chapter describes the support process and support contacts 
available for Web Document Submission. 

Web Document Submission Support Process 

At the time of installation, a Customer Solution Administrator (CSA) will 
be identified. The CSA is available to manage all software-related issues. 
The CSA, who has the skills of a system administrator, handles the  
day-to-day service and support operations at the customer site. The CSA 
is the main interface to the Web Document Submission Support Center. 

Note: If a problem relates to a Xerox output device and not the software 
please contact the appropriate Xerox Support Center for that 
product. If a problem relates to the computer server hardware, 
contact the manufacturer of the server. 

Here is the process for initiating support: 

1. When the end user or operator encounters an error with the software, 
they should contact the CSA.  

2. The CSA performs system level isolation and problem resolution for 
Web Document Submission.  

3. If the CSA is not able to resolve the problem, the problem is escalated 
to Web Document Submission Support Center for support. 

Note: Only the CSA can call the hotline for support. 
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Support Contacts 

Web Document Submission has an e-Support website available at 
http://www.xerox.com/webdocumentsubmission/support. The e-Support 
website provides a searchable knowledgebase, Frequently Asked 
Questions (FAQ’s), and the ability to submit a support request via e-mail. 

Contact the designated CSA for support. The CSA will contact the Web 
Document Submission Support Center if they require additional 
assistance. The Support Center can be reached at  
1-888-508-5244, 8:00 a.m. to 5:00 p.m., Monday through Friday, local 
time, continental USA.
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