
Xerox Web Document Submission Software Version 2.0.1
Installation and Configuration Guide

Document version 1.02
September, 2002
Part Number 701P37978



Xerox Corporation
Global Knowledge and Language Services
800 Phillips Road
Building 845, 845-17S
Webster, New York 14580
USA

©2002 XEROX CORPORATION. All rights reserved.

Copyright protection claimed includes all forms and matters of copyrightable
material and information now allowed by statutory or judicial law or hereinafter
granted, including without limitations, material generated from the software
programs which are displayed on the screen such as styles, templates, icons,
screen displays looks, and so on.

XEROX®, The Document Company®, the digital X®, Xerox Canada Ltd.®, Xerox
Europe®, and all identifying numbers used in connection with the Xerox products
mentioned in this publication are trademarks of XEROX CORPORATION.

Adobe, the Adobe logo, Acrobat, the Acrobat logo, Acrobat Reader, Reader,
Distiller, and Adobe PDF Transit are either registered trademarks or trademarks
of Adobe Systems Incorporated in the United States and/or other countries.

All non-Xerox brands and product names are trademarks or registered
trademarks of their respective companies.

This product includes software developed by the Apache Software Foundation
(http://www.apache.org/).

While every care has been taken in the preparation of this material, no liability
will be accepted by Xerox Corporation arising out of any inaccuracies or
omissions.

Changes are periodically made to this document. Changes, technical
inaccuracies, and typographical errors will be corrected in subsequent editions.





Revision History

Reviser Date Revision Resulting
Revision Description

Brian
Laing

06/20/2002 1 .80 Added XGS cover page. Modified all occurrences
of Xerox Documents Xpress to Xerox Web
Document Submission.

Brian
Laing

07/16/2002 2 1.02 1. Added a section to reveal file extensions on
the server.

2. Revised the WinZip portion of installing the
XPD for Windows NT 4.0 and Windows 2000.

3. Modified the License Generation section to
reflect that the license can now be generated
on the server and that a floppy disk is no
longer required. The license is now saved in
the My Documents folder on the server.

4. Revised Installation Workflow diagrams to
reflect the product name change and the
addition of the optional Adobe PDF Transit
software.

5. Added a supplemental step to the installation
procedure so that installers can monitor the
installation progress.

6. Modified all occurrences of the XDX Control
Center to reflect the new method of starting,
stopping, and monitoring the Web Document
Submission system

7. Modified the section on configuring the
Apache Administrator e-mail address for the
new version of Apache.

8. Modified the Troubleshooting chapter to show
the correct locations of the Tomcat log files
and change to modifying the logging
messages.

9. Section added on disabling IIS.

10. Added designation that the document is for
the 2.0.1 release of Web Document
Submission.

Brian
Laing

09/20/2002 3 1.02 1. Corrected version number in Introduction to
read 2.0.1



INSTALLATION AND CONFIGURATION GUIDE III

Table of Contents

Revision History.........................................................................................iv

1. Introduction....................................................................................1-1
Xerox Web Document Submission Software .......................................... 1-1
Intended Audience.................................................................................. 1-1
Assumptions ........................................................................................... 1-2
Conventions............................................................................................ 1-2
Related Documentation .......................................................................... 1-3

2. Product Overview ..........................................................................2-1
Responsibilities....................................................................................... 2-1

System Administrator..............................................................................2-1
Print Shop Administrator.........................................................................2-2
Print Shop Operator................................................................................2-2
User ........................................................................................................2-3

Optional Modules.................................................................................... 2-3

3. Installation Requirements .............................................................3-1
Hardware Requirements ......................................................................... 3-1

Server Requirements..............................................................................3-1
Client Requirements ...............................................................................3-1

Software Requirements .......................................................................... 3-2
Server Requirements..............................................................................3-2
Client Requirements ...............................................................................3-2



TABLE OF CONTENTS XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0.1

IV INSTALLATION AND CONFIGURATION GUIDE

Information Requirements....................................................................... 3-3

4. Installing the Software...................................................................4-1
Display File Extensions........................................................................... 4-2

Displaying File Extensions......................................................................4-2
Third-party Software and Printer Driver Installation ................................ 4-3

Installing Adobe Acrobat Reader ............................................................4-3
Adding the Print Driver............................................................................4-3

Windows NT 4.0 Server....................................................................4-4
Windows 2000 Server.......................................................................4-6

Installing Microsoft Office XP..................................................................4-8
Post Installation Tasks............................................................................4-9

Web Document Submission License Generation.................................... 4-9
Installing Web Document Submission................................................... 4-13

Web Document Submission Software Installation ................................4-14
Exit the Installation Program.................................................................4-18
Configuring the Web Document Submission Core Installation .............4-18
Configure Apache Administrator E-mail Address .................................4-21

5. Starting Up and Shutting Down....................................................5-1
Starting Web Document Submission ...................................................... 5-1

Starting Web Document Submission For the First Time.........................5-1
Testing Web Document Submission....................................................... 5-3

Testing Web Document Submission.......................................................5-3
Shutting Down Web Document Submission ........................................... 5-5

Shutting Down Web Document Submission ...........................................5-5

6. Troubleshooting.............................................................................6-1
Installation Problems............................................................................... 6-1
Debugging Apache and Tomcat ............................................................. 6-1
Debugging Web Document Submission Services................................... 6-2



XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0.1 TABLE OF CONTENTS

INSTALLATION AND CONFIGURATION GUIDE V

7. Contacts and Escalation Process ................................................7-1
Web Document Submission Support Process ........................................ 7-1
Support Contacts .................................................................................... 7-2

A. Install Verification Procedure ...................................................... A-1
Functional Areas Being Verified..............................................................A-1

Administrative Functions........................................................................ A-1
Client Functions..................................................................................... A-2
Operator Functions................................................................................ A-3

Install Verification Procedures ................................................................A-4
1. Administrator Verification Procedures ............................................... A-4

1.1 Logging on as Administrator ...................................................... A-4
1.2 Adding a Printer ......................................................................... A-5
1.3 Editing the User Interface Using Admin Tools ........................... A-5

2. Client Verification Procedures ........................................................... A-7
2.1 Registering a Client Account – Self Registration ....................... A-7
2.2 Logging on as a User................................................................. A-8
2.3 Editing a User Profile ................................................................. A-9
2.4 Submitting a Print Job Request – MS Word Document ............. A-9
2.5 Submitting a Print Job Request – MS Excel Document........... A-10
2.6 Submitting a Print Job Request – Hard Copy Document......... A-11
2.7 Editing the Personal Address Book ......................................... A-12
2.8 Editing the Document Repository ............................................ A-12

3. Operator Verification Procedures .................................................... A-13
3.1 Logging on as Operator ........................................................... A-13
3.2 Editing a Client Job Request – MS Word Document ............... A-14
3.3 Fulfilling a Client Job Request – MS Word Document ............. A-14
3.4 Fulfilling a Client Job Request – MS Excel Document............. A-15
3.5 Fulfilling a Client Job Request – Hard copy Document ........... A-16
3.6 Sending a Job to Each Installed Printer................................... A-17



TABLE OF CONTENTS XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0.1

VI INSTALLATION AND CONFIGURATION GUIDE

Install Verification Record .....................................................................A-18
Results................................................................................................. A-18

Administrative Functions................................................................ A-19
Client Functions ............................................................................. A-19
Operator Functions ........................................................................ A-20

Index ........................................................................................ Index-1



INSTALLATION AND CONFIGURATION GUIDE 1-1

1. Introduction

This chapter describes Xerox Web Document Submission Software
Version 2.0.1 and how to use this guide.

Xerox Web Document Submission Software

Web Document Submission allows end users to submit print jobs
electronically using industry standard browsers. Once submitted,
production personnel efficiently update job status as documents move
through the production cycle, providing users with information about their
jobs. Web-based printing generates cost savings and improvements in
quality, productivity, and turnaround time.

The system uses several services that can be loaded on one or more
servers, depending on the print shop configuration.

Intended Audience

This guide is intended for use by Xerox personnel who are responsible for
the installation of this system.
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Assumptions

The person installing Web Document Submission software should have
experience in the following areas:

•  Windows NT and / or Windows 2000 server administration
•  Applicable workstation operating systems experience
•  Hypertext Markup Language (HTML)
•  Extensible Markup Language (XML)
•  JavaServer Pages (JSP)
•  Structured Query Language (SQL)

Conventions

This guide uses the following conventions:

•  Menu items and buttons appear in bold text.
•  Screen, text box, and drop-down list titles are spelled and punctuated

exactly as they appear on the screen.
•  Document titles appear in italics.
•  Content representative of text that is displayed on a computer monitor

is displayed in Courier New font and enclosed in a shaded table as
shown in Table 1-1.

Table 1-1. Example of text displayed on a computer monitor

INSERT INTO Field {field_name,custom_name}
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Related Documentation

The following guides provide further information on the Web Document
Submission system:

•  Xerox Web Document Submission Software Installation Planning
Guide – Part Number 701P37977

•  Xerox Web Document Submission Software System Administration
Guide – Part Number 701P37979

•  Xerox Web Document Submission Software Adobe PDF Transit
Installation and Configuration Supplement (Optional) – Part Number
701P38642

Note: Operator / Administrator and User instructions are available as
online help while using the Web Document Submission system.
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2. Product Overview

Web Document Submission is a web-based application used to submit
and track jobs.

System users access the software via three web interfaces:

•  A User interface for submitting print jobs
•  An Operator interface for printing jobs
•  A Printer Administrator interface for setting up printers and templates,

customizing the user interface, and establishing pricing

Responsibilities

System Administrator

The System Administrator manages user, operator, and print shop
administrative permissions for a print shop installation. Specific tasks
include:

•  Managing Web Document Submission software
•  Customizing the Web Document Submission user interface
•  Managing user / operator permissions for a single print shop

The System Administrator will have a detailed understanding how the
Web Document Submission software works.
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Print Shop Administrator

The Printer Administrator is a user who manages a print shop. Specific
tasks include:

•  Establishing specific print shop policies
•  Configuring printers
•  Generating reports using Web Document Submission tools
•  Load pricing data into Web Document Submission
•  Creating templates

The Print Shop Administrator must understand how to configure a printer
and how printer communications work.

Print Shop Operator

The Print Shop Operator is a user who manages the printing workflow in
a print shop. Specific tasks include:

•  Printing jobs sent by end users
•  Modifying the job status as jobs move through the workflow
•  Distributing printed materials

The Print Shop Operator must have detailed knowledge of scheduling
and prioritizing print jobs as well as a solid understanding of the
capabilities and capacities of the print shop.
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User

The User submits documents and jobs to Web Document Submission
over the Internet using a web browser, the Xpress Print Driver (XPD), or
in some installations through DocuShare and / or Adobe PDF Transit.
Specific tasks include:

•  Using Web Document Submission as the interface to the print shop
and local printers

•  Uploading documents into Web Document Submission
•  Requesting printing and resubmission services using Web Document

Submission

The User must be knowledgeable about basic web browser use, general
Internet use (downloading, uploading, and navigation), and printer driver
installation.

Optional Modules

There are two optional modules available for installation with Web
Document Submission:

•  DocuShare Link to Web Document Submission
•  Adobe PDF Transit for Web Document Submission
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3. Installation Requirements

Web Document Submission requires a specific combination of hardware,
software, and information to ensure a successful installation. These
requirements are documented in the Xerox Web Document Submission
Software Installation Planning Guide.

These installation instructions assume that the Web Document
Submission server has had the proper operating system installed and has
a working connection to the Internet.

Hardware Requirements

Server Requirements

•  One Windows NT 4.0 or Windows 2000 server
•  8-GB hard disk
•  512-MB random access memory (RAM)
•  One 10 / 100 Megabytes per second (MBps) network interface card

(NIC)
•  One available drop on a 100 MBps network
•  Simple Mail Transfer Protocol (SMTP) server supporting Anonymous

SMTP connections for outgoing mail
•  An uninterruptible power supply (UPS) for the server

Client Requirements

•  Workstation capable of using a supported operating system and a
supported browser
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Software Requirements

Server Requirements

•  Microsoft Windows NT Server 4.0 or Microsoft Windows 2000 Server

CAUTION: Ensure that Microsoft Internet Information Services (IIS) are
disabled on the Web Document Submission server. The Web
Document Submission server uses Apache as the web
server software and will not function with IIS installed.
Consult article Q321141 – HOW TO: Disable or Remove
Unnecessary IIS Services – on the Knowledge Base section
of the Microsoft support site (http://support.microsoft.com) for
instructions on how to stop IIS services.

•  Microsoft TCP / IP Printing service (LPR service) installed
(Windows NT Server 4.0 only)

•  Microsoft Office XP
•  Adobe Acrobat Reader 4.05 (or later)
•  Web Document Submission Software
•  Internet Explorer 5.5 (or later) or Netscape Navigator 4.75 (or later)
•  WinZip

Client Requirements

•  Any one of the following operating systems:
•  Windows NT Workstation 4.0
•  Windows 2000 Professional
•  Windows 95 / 98 / ME

•  Adobe Acrobat Reader 4.05 (or later)

http://support.microsoft.com/


XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0.1 PRODUCT OVERVIEW

INSTALLATION AND CONFIGURATION GUIDE 3-3

•  Internet Explorer 5.5 (or later) or Netscape Navigator 4.75 (or later)
•  WinZip

Information Requirements

See the Xerox Web Document Submission Software Installation Planning
Guide for a complete list of the information requirements.





 

4. Installing the Software 

Obtain the Xerox Web Document Submission Software Version 2.0 – 
Installation Planning Guide before installing the software. The following 
figure, Figure 4-1 gives an overall look at the workflow for the complete 
installation process. 

Figure 4-1. Web Document Submission installation process 

Installation
process

Gather customer
installation information

Schedule installation

Install, configure, and test
software

Customize and test
software as required

Software training as
required
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When performing an installation, the following, including third-party 
software and printer driver, must be present and properly configured on 
the server before installing Web Document Submission software: 

• Adobe Acrobat Reader 
• PDFwriter print driver 
• Microsoft Office XP 

It is recommended that the server be assigned a name and physically 
labeled with the applicable name and machine IP address. An example is 
shown in Figure 4-2. 

Figure 4-2. Example server label 
Example label 

Web Document 
Submission 

Server  
IP: xxx.xxx.xxx.xxx 

Display File Extensions 

In order to simplify product installation it is recommended that file 
extensions be turned on. By default, when Windows 95/98/ME, Windows 
NT 4.0, and Windows 2000 are installed, file extensions are turned off. 

Displaying File Extensions 

Perform the following to display file extensions: 

1. Double-click My Computer. Click View > Folder Options  (or choose 
Options from the View menu in Windows 95 or Windows NT 4.0). 



XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0.1 INSTALLING THE SOFTWARE  

INSTALLATION AND CONFIGURATION GUIDE 4-3 

2. Click the View tab. Locate Hide file extensions for known file 
types. Ensure that the check box is cleared. Click OK.  Close all open 
windows. 

Third-party Software and Printer Driver Installation 

Installing Adobe Acrobat Reader  

The system uses Adobe Acrobat Reader to convert documents to PDF 
format. If Adobe Acrobat Reader is not already installed on the Web 
Document Submission server, it must be downloaded from Adobe and 
then installed. 

Perform the following to install Adobe Acrobat Reader: 

1. Go to http://www.adobe.com and download a copy of Acrobat Reader. 
Choose either the base version, or the version that can search PDF 
files. Either free version will work with Web Document Submission. 

2. Follow the instructions from Adobe to install Adobe Acrobat Reader. 

Note: Restarting the server is not necessary at this time. The server will 
be restarted as part of the final installation procedure. 

Adding the Print Driver 

The Xpress Print Driver (XPD) is used to convert documents to PostScript 
before they are sent to the printer. 

http://www.adobe.com/
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Perform the following to add the XPD: 

Windows NT 4.0 Server 

1. Create a folder named XPD on the C: drive of the server.  

2. To unzip xpd-1.1.3.zip, a Java archive (jar) file on the installation CD, 
into the newly created XPD folder: 

a) Insert the installation CD in the CD drive. 

b) Open WinZip and click File > Open Archive.  

c) The Open Archive window appears. From the Files of type drop-
down menu, select All files (*.*) 

d) Click the Look in drop-down and locate and double-click the 
installer.jar file on the installation CD. This file is located at  
<CD ROM drive> \ installer.jar.  

e) When the file listing appears in WinZip, click the Name header to 
alphabetize the file listing. 

 

f) Locate and double-click webAppServer_dist.zip.  
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g) The webAppServer_dist.zip file is extracted. Click the Name 
header to alphabetize the file listing. 

 

h) Locate and click xpd-1.1.3.ZIP to highlight the file name. 

 

i) On the WinZip toolbar click Extract. 

j) The Extract window opens. Select Selected Files from the File 
area. In the Folders/drives area, browse to C:\XPD. 

k) Click Extract. The Xerox Print Driver files are extracted into the 
XPD folder on the server. 

3. Click Start > Settings > Printers. 

4. Double-click Add Printer. 

5. Ensure My Computer is selected and click Next. 

6. For the port, select LPT1. Click Next. 

7. The list of manufacturers of printers appears. Click Have Disk. 

8. The Install from Disk dialog box appears. Browse to C:\XPD. 

9. When in the XPD folder click webxpd.inf. Click Open. 

10. The Install From Disk dialog box appears. Click OK. 

11. Select Web Document Submission PS Color Plugin. Click Next. 
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Note: Only the color driver needs to be selected for the server since it 
will handle both color and black and white jobs. 

12. Type XDX PDFwriter in the Printer name text box. Click Next. 

Note: This is case and space sensitive. There is a space between the 
letter X and the letter P. 

13. Click Not shared. Click Next. 

14. Click No to bypass printing a test page. Click Finish. 

Windows 2000 Server 

1. Create a folder named XPD on the C: drive of the server.  

2. To unzip Xpdy2k.zip, a Java archive (jar) file on the installation CD, 
into the newly created XPD folder: 

a) Insert the installation CD in the CD drive. 

b) Open WinZip and click File > Open Archive.  

c) The Open Archive window appears. From the Files of type  
drop-down menu, select All files (*.*) 

d) Click the Look in drop-down and locate and double-click the 
installer.jar file on the installation CD. This file is located at  
<CD ROM drive> \ installer.jar.  

e) When the file listing appears in WinZip, click the Name header to 
alphabetize the file listing. 
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f) Locate and double-click webAppServer_dist.zip.  

 

g) The webAppServer_dist.zip file is extracted. Click the Name 
header to alphabetize the file listing. 

 

h) Locate and click Xpdy2k.zip to highlight the file name. 

 

i) On the WinZip toolbar click Extract. 

j) The Extract window opens. Select Selected Files from the File 
area. In the Folders/drives area, browse to C:\XPD. 

k) Click Extract. The Xerox Print Driver files are extracted into the 
XPD folder on the server. 

3. Click Start > Settings > Printers. 

4. Double-click Add Printer. 

5. The Add Printer Wizard appears. Click Next. 

6. The Local or Network Printer window appears. Click Local Printer. 
Clear Automatically detect and install my Plug and Play Printer. 
Click Next. 

7. For the port select LPT1. Click Next. 
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8. The list of manufacturers of printers appears. Click Have Disk. 

9. The Install from Disk dialog box appears. Click Browse and browse 
to C:/XPD. 

10. When in the XPD folder click webxpd.inf. Click Open. 

11. The Install From Disk dialog box reappears. Click OK. 

12. Select Web Document Submission PS Color Plugin. Click Next.  

Note: Only the color driver needs to be selected since it will handle both 
color and black and white jobs. 

13. Type XDX PDFwriter in the Printer name text box. Click Next. 

Note: The print name is case and space sensitive. There is a space 
between the letter X and the letter P. 

14. Click Do not share this printer. Click Next. 

15. To ensure that a test page is not printed click No. Click Next. 

16. The Completing the Add Printer Wizard window appears. Click 
Finish. The Wizard indicates that files are being copied. 

17. A warning that the Digital Signature not found appears. Click Yes. 

18. Close all open windows. The XDX printer driver has been installed. 

Installing Microsoft Office XP 

Microsoft Office XP must be installed in order for print drivers to process 
Office documents. 

Perform the following to install Microsoft Office: 

1. Insert the Microsoft Office XP CD in the CD-ROM drive. 
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Note: If the Microsoft Office installation does not begin after inserting the 
CD, follow the instructions distributed with Microsoft Office on 
manually starting an installation.  

2. Start the installation process and choose Typical installation. 

3. Accept all defaults ensuring that Word, Excel, and PowerPoint are 
installed. 

4. Remove the CD from the CD-ROM drive.  

5. Restart Windows when prompted. 

Post Installation Tasks 

In order for the Web Document Submission system to operate, Adobe 
Acrobat Reader, and Microsoft Office must be started to accept license 
agreements. Failure to do so will keep the system from operating. 

Start both Adobe Acrobat and Microsoft Office. Accept their licensing 
agreements, activate the products, and then close Acrobat and Office 
before installing Web Document Submission. 

Note: Microsoft Office must be activated. Failure to activate the product 
will cause Microsoft Office to reduce features after 30 days 
resulting in a malfunction of Web Document Submission. 

Web Document Submission License Generation 

Generate a license using the XDX License Generation Tool 1.0 before 
installing Web Document Submission.  
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Tip: This procedure saves the license file to the My Documents folder on 
the Web Document Submission server. The standard installation of 
Windows 2000 Server has this folder has this folder as a default. 
Windows NT needs to have this folder created before creating the 
license. Create the My Documents folder at the root directory of the 
C: drive. 

Perform the following to generate a license: 

1. Insert the Web Document Submission installation CD into the 
CD-ROM drive on the Web Document Submission server. 

2. Double-click My Computer.  

3. Double-click the CD-ROM drive where the Web Document 
Submission software appears.  

4. Double-click license_gen.bat.  

5. After a few moments the XDX License Generation Tool 1.00 window 
appears. Type the following information into the appropriate fields: 

• Company Name – Type the full company name 
• Expiration Date – Type the date that is 15 years from the installation 

date 
• Serial Number – Type the serial number 
• Web App Server IP – Type the IP address of the Web Document 

Submission server 
• Database Server IP – Type the IP address of the Web Document 

Submission server 
• License File Location –  Type the name of the license file in the 

following format: 

c:\my documents\<license file name>.lic 

The license file name should be no more than eight characters long.  
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Tip: Saving the license file to the My Documents folder on the server to 
simplifies locating the license file and eliminates the need to recreate 
a license if the system needs to be reinstalled. 

When all the fields are complete click Generate License File. 

 

6. The License Generator window appears. Click OK.   
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Note: If the program indicates an error with the expiration date, exit the 
program and start the licensing process again. The expiration date 
cannot be edited once set.
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Installing Web Document Submission  

This section gives procedures on installing the core Web Document 
Submission software. Once operational, the chapters that follow give 
procedures on testing the installed configuration of the software at a 
customer site. 

CAUTION:  Ensure that the Display Properties for the server monitor is 
set to a minimum of 256 colors. The installation program will 
not appear on the screen if a lower number of colors is 
selected.  

The Web Document Submission server contains the application server 
software, the database server, the web server software and the 
repository. Figure 4-3 illustrates the workflow for installing the core 
product. 

Figure 4-3. Web Document Submission software installation 
workflow 

Install Web Document
Submission 2.0

software

Validate installation
1. Log on as Admin
2. Create User
3. Test UI configuration
4. Submit jobs
5. Test Operator functions

Web Document
Submission Server

Core Installation
Complete

Configure core Web
Documents Submission

1. System e-mail
2. Apache Admin e-mail
3. Load pricing tables

Additional Configuration
and Customization

Consult the System
Administration Guide or the
Adobe PDF Transit
Installation and Configuration
Supplement
1. User management
2. Configure UI
3. Set system parameters
4. Backup strategy
5. Optional DocuShare link
6. Optional Adobe PDF
Transit software

Begin Core
Installation

Manually install and
configure third party

applications
1. Adobe Acrobat Reader
2. PDFwriter
3. Microsoft Office
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Web Document Submission Software Installation 

Perform the following to install Web Document Submission software 
on the server: 

1. Insert the Web Document Submission installation CD into the 
CD-ROM drive of the server. 

2. Double-click My Computer.  

3. Double-click the CD-ROM drive where the Web Document 
Submission software appears.  

4. Double-click runInstaller.bat. 

5. A command window appears followed the WebXpress Installation 
window. Click Full Installation. 

 

Note: The WebXpress Installation window may appear behind the 
Command window when installing on a Windows 2000 server. 
Minimize the Command window to see the Installation window. 
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6. The License File window appears. Click Browse. 

 

7. Browse to C:\My Documents. The filename for the license created 
will appear. Click the file name and then click Select License File. 
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8. The License File window reappears. Click Next. 

 

9. The Installation Location window appears. The default installation 
directory is C:/xdx. Ensure the Server address is the IP address of 
the server where Web Document Submission is being installed. Click 
Install. 
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Tip: The Command Window will disappear behind the Installation 
Window. Move the command window in front of the Installation 
window in order to monitor the status of the installation. The 
message BUILD SUCCESSFUL will appear several times. This 
does not mean the installation is complete. 

10. After several minutes, the Installation Complete window appears. 
Click Done. 
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Exit the Installation Program 

Perform the following to exit the installation program: 

1. The WebXpress Installation window reappears. To exit the 
installation program, click X. 

 

2. Remove the installation CD. 

3. Restart the server. 

If there were problems and the installation did not complete properly, 
consult Chapter 6 – Troubleshooting. 

Configuring the Web Document Submission Core Installation 

The addresses for the e-mail server and administrator must be configured 
for the Web Document Submission system to operate properly.  

CAUTION:  Without these addresses configured, the Web Document 
Submission system will not accept any new users. 

Perform the following to set e-mail server and administrator 
addresses for the system: 

1. On the server, double-click My Computer. Go to C:\xdx\scripts and 
double-click xwdss-startup.bat. 

2. As Web Document Submission services begin, buttons appear on the 
taskbar to show running processes. Processes started are APACHE, 
MYSQL, RMID, and TOMCAT.  
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3. Almost instantly, the APACHE button disappears from the taskbar. To 
see any system messages delivered to any of these processes, 
simply click the button to view the window for the desired process. 
The window may have to be resized in order to see the system 
messages. 

 

4. Once the Web Document Submission processes have started go to 
C:\xdx\scripts and double-click ControlCenter.bat. 

Note: To simplify startup of Web Document Submission, create 
shortcuts to xwdss-startup.bat, xwdss-shutdown.bat, and 
ControlCenter.bat batch files and place them on the desktop. 

 

5. On the XDX Control Center click Tools > Configuration Manager. 
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6. The configuration_control_panel window opens. Click the + next to 
the xdxConf folder. 

7. Click the + next to properties. 

8. Click the + next to the Email folder. 

Note: This next set of configuration items deals with e-mail properties. 
Consult the Web Document Submission Installation Planning 
Guide for the required information for this section. 

9. Click Email Subject. Replace the default subject line with the subject 
line of the e-mail messages sent to warn users that their documents 
will be deleted. 

10. Click Admin Email Address. Type the Web Document Submission 
administrator e-mail address in place of the default property value. 

11. Click Email Enabled. Ensure that the value is set to true if users are 
to be notified by the system about the status of their jobs. 

12. Click Email Footer. Type the text to be appended to the end of every 
outgoing e-mail message. 

13. Click Printshop Name. Type the name of the print shop, used in  
e-mails to users in place of the default property value. 

WARNING! Do not use an ampersand (&) in the Print Shop name. Doing 
so will cause the Web Document Submission system to 
malfunction. 

14. Click Email Server. Type the IP address of the designated e-mail 
server. 

15. Click File > Save to save all changes. 

16. If required, enter the Username Admin and the Password 22222. 
Click OK. 
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17. Click X to close the configuration_control_panel window.  

 

18. Click X to close the XDX Control Center. 

19. Go to C:\xdx\scripts and double-click xwdss-shutdown.bat. 
All processes stop. The core system is now installed.  

Configure Apache Administrator E-mail Address 

The Apache web server software can e-mail the system administrator if 
there are internal problems with the web server. Follow these instructions 
to set the e-mail address: 

Perform the following to configure the Apache Administrator e-mail 
address: 

1. On the server double-click My Computer.  
Go to C:\xdx\etc\Apache2\conf. 

2. Open httpd.conf in a text editor. 

3. Search for the line ServerAdmin user@domain.com and replace 
user@domain.com with the System Administrator e-mail address. 

 

4. Save the file, overwriting the existing httpd.conf. 

5. Close all open windows.





 

5. Starting Up and Shutting Down 

Web Document Submission is started and shut down from the Web 
Document Submission server. 

CAUTION: After starting Web Document Submission services, the 
process windows are minimized. DO NOT close the process 
windows since doing so shuts down Web Document 
Submission. 

Starting Web Document Submission  

Starting Web Document Submission requires activating a batch file on the 
Web Document Submission server. The following procedure starts the 
system for the first time. 

Starting Web Document Submission For the First Time 

Perform the following to start Web Document Submission for the 
first time: 

1. On the server, double-click My Computer. Go to C:\xdx\scripts and 
double-click xwdss-startup.bat. 
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2. As Web Document Submission services begin, buttons appear on the 
taskbar to show running processes. Processes started are APACHE, 
MYSQL, RMID, and TOMCAT.  

 

3. Almost instantly, the APACHE button disappears from the taskbar. To 
see any system messages delivered to any of these processes, 
simply click the button to view the window for the desired process. 
The window may have to be resized in order to see the system 
messages. 

 

The following figure, Figure 5-1, describes the components started. 

Figure 5-1. Description of components started with the Control 
Center 

Component Description 

RMID (Remote Method 
Invocation Daemon) 

A utility that Web Document Submission services 
use for activation 

MySQL (Database Server) The database management system that tracks 
users and jobs in the system 

Tomcat (used by Web 
Server) 

Tomcat is a servlet container with a Java Server 
Pages (JSP) environment. A servlet container is a 
runtime shell that manages and invokes servlets 
on behalf of users. 

Apache (Web Server) The web server for the Web Document 
Submission system 
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4. Once the Web Document Submission processes have started go to 
C:\xdx\scripts and double-click ControlCenter.bat. Double-click 
Admin-LoadPricing.bat. This batch file loads the base pricing tables 
into MySQL. 

CAUTION: Pricing Tables are loaded only this one time. Loading the 
Pricing Tables again will erase any changes made since the 
tables were initialized the first time.  

Testing Web Document Submission  

Once Web Document Submission has been installed, test the software to 
ensure that it is operating correctly. The following steps are only a basic 
test to see if the software is functioning. To test system operations 
completely, consult the Install Verification Procedure chapter in  
Appendix A. 

Testing Web Document Submission  

Perform the following to test the Web Document Submission user 
log on: 

1. Open a browser window on a workstation connected to the network or 
on the Web Document Submission server. 

2. In the address line, type the IP address that will point to the Web 
Document Submission Web server. In most cases, it is the IP address 
of the Web Document Submission server, which hosts the web server 
software. 

http:// <Web Document Submission server IP address>/xdx 
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3. The initial log on screen appears after several moments. Log on with 
the User name admin and the Password 22222. Attempt to submit a 
job.  

Perform the following to test the Web Document Submission 
administrator log on: 

1. Open a browser window on a workstation connected to the network or 
on the Web Document Submission server. 

2. In the address line, type the IP address that will point to the Web 
Document Submission Web server. In most cases, it is the IP address 
of the Web Document Submission server, which hosts the web server 
software. 

http:// <Web Document Submission server IP address>/xdx/admin 

3. The initial log on screen appears after several moments. Log on with 
the User name admin and the Password 22222. Attempt to view the 
job that was submitted in the procedure above. 
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Shutting Down Web Document Submission  

To shut down the system, first close the XDX Control center and then use 
a batch file to shut down Web Document Submission.  

Shutting Down Web Document Submission 

Perform the following to shut down Web Document Submission 
components: 

1. Close the Control Center by clicking X. 

 

2. Go to C:\xdx\scripts and double-click xwdss-shutdown.bat. 
All processes close their corresponding command windows and the 
Web Document Submission system stops. 
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6. Troubleshooting 

This section describes two methods for helping to diagnose problems that 
may occur. For further assistance with troubleshooting problems, consult 
Chapter 7 – Contacts and Escalation Process. 

Installation Problems 

The simplest way to ensure there are no installation problems is to have a 
clean server. Remove old versions of Web Document Submission or 
Documents Xpress. Any existing versions of MySQL and any Java must 
also be removed using their own uninstall programs. 

Ensure that Microsoft Internet Information Services (IIS) is disabled. 

If an installation is not working, often it is easier to delete the C:\xdx 
folder and begin the installation again. Shut down Web Document 
Submission and reboot the server. After the server has restarted, remove 
the C:\xdx folder. Complete instructions are given in the Web Document 
Submission Software Version 2.0 System Administration Guide. 

Debugging Apache and Tomcat 

The Apache server logs are located in C:\xdx\etc\Apache2\logs and the 
Tomcat logs are located in C:\xdx\etc\tomcat4.0\logs. These logs provide 
valuable troubleshooting information if the software is not operating 
properly. 
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Note: Each time Apache is started, the previous error log is reopened 
and new information is appended to the end of the file. If there is an 
error in the system, the logs will contain debugging information. 

Debugging Web Document Submission Services 

Debugging output is saved to file by each Web Document Submission 
service. If there is an error with the system, examine the service window 
of the appropriate service to determine where the error has occurred. 
Generally, if there is a problem, a Java exception will be displayed in the 
window. This message can be used to determine exactly what errors 
have occurred in the system. 

The log file messages that appear for Tomcat can be modified by starting 
the Configuration Control Panel from the XDX Control Center. These 
steps assume the XDX Control Center is operational and the Web 
Document Submission system is running. 

Perform the following to modify the logging messages for Tomcat: 

1. On the XDX Control Center click Tools > Configuration Manager. 

2. The configuration_control_panel window opens. Click the + next to 
the xdxConf folder. 

3. Click the + next to properties. 

4. Click the + next to the Logging folder. 

5. Click Log Status. 

6. Change the Property Value from info to debug. This will increase the 
level of information returned from the system. 

7. Click File > Save to save all changes. 
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8. If required, enter the Username Admin and the Password 22222. 
Click OK. 

9. Click X to close the configuration_control_panel window.  
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7. Contacts and Escalation Process 

This chapter describes the support process and support contacts 
available for Web Document Submission. 

Web Document Submission Support Process 

At the time of installation, a Customer Solution Administrator (CSA) is 
identified. The CSA is available to manage all software-related issues. 
The CSA, who has the skills of a system administrator, handles the  
day-to-day service and support operations at the customer site. The CSA 
is the main interface to the Web Document Submission Support Center. 

Note: If a problem relates to a Xerox output device and not the software 
please contact the appropriate Xerox Support Center for that 
product. If a problem relates to the computer server hardware, 
contact the manufacturer of the server. 

This is the process for initiating support: 

1. When the end user or operator encounters an error with the software, 
they should contact the CSA.  

2. The CSA performs system level isolation and problem resolution for 
Web Document Submission.  

3. If the CSA is not able to resolve the problem, the problem is escalated 
to Web Document Submission Support Center for support. 

Note: Only the CSA can call the hotline for support. 
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Support Contacts 

Web Document Submission has an e-Support website available at 
http://www.xerox.com/webdocumentsubmission/support. The e-Support 
website provides a searchable knowledgebase, Frequently Asked 
Questions (FAQs), and the ability to submit a support request via e-mail. 

Contact the designated CSA for support. The CSA will contact the Web 
Document Submission Support Center if they require additional 
assistance. The Support Center can be reached at  
1-888-508-5244, 8:00 a.m. to 5:00 p.m., Monday through Friday, local 
time, Continental USA.
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A. Install Verification Procedure 

Use this chapter to verify a successful installation of Web Document 
Submission. Record all test results pertinent to a specific install in the 
worksheets provided in this chapter. 

Functional Areas Being Verified 

This section provides an overview of the functional areas verified after 
software installation. 

Administrative Functions 

Administrative functions that will be tested are listed in Table A-1. 

Table A-1. Administrative functions and procedures 
Function Test Procedure 

Log on as Administrator 1.1 

Add Printer (Default and others in print shop) 1.2 

Edit User Interface Using Admin Tools 1.3 
 

INSTALLATION AND CONFIGURATION GUIDE A-1 



INSTALL VERIFICATION PROCEDURE XEROX WEB DOCUMENT SUBMISSION SOFTWARE VERSION 2.0.1 

Client Functions 

Client functions that will be tested are listed in Table A-2. 

Table A-2. Client functions and procedures 
Function Test Procedure 

Register Your Account 2.1 

Log on as End User 2.2 

Edit User Profile 2.3 

Submit Print Job Request – MS Word Document 2.4 

Submit a Print Job Request – MS Excel Document 2.5 

Submit a Print Job Request – Hard copy Document 2.6 

Edit Personal Address Book 2.7 

Edit Document Repository 2.8 
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Operator Functions 

Operator functions that will be tested are listed in Table A-3. 

Table A-3. Operator functions and procedures 
Function Test Procedure 

Log on as Operator 3.1 

Edit a Client Job Request – MS Word Document 3.2 

Fulfill a Client Job Request – MS Word Document 3.3 

Fulfill a Client Job Request – MS Excel Document 3.4 

Fulfill a Client Job Request – Hard copy Document 3.5 

Send a Print Job to Each Installed Printer 3.6 
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Install Verification Procedures 

These install verification procedures test the basic system functionality of 
Web Document Submission. Run the Administrator and Operator 
verification procedures from any workstation on the system network 
except where noted. Test the Client verification procedures from a 
corporate client workstation.  

Record all Pass / Fail results and provide a summary in the Install 
Verification Record at the end of this chapter.  

1. Administrator Verification Procedures 

The Administrator verification procedures test the major functions of a 
System Administrator using Web Document Submission.  

1.1 Logging on as Administrator 

Perform the following to log on as Administrator: 

1. Open a browser window on a workstation connected to the network, 
or one of the Web Document Submission servers. 

2. In the address line, type the IP address for the Web Document 
Submission server: 
 
http:// <Web Document Submission server IP address>/xdx/admin 

3. Type admin in the Username text box, type the admin password 
22222 in the Password text box and click Log On. 
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Verify that the log on was successful. If unsuccessful, please note the 
observed system response. 

__________________________________________________________  

__________________________________________________________  

1.2 Adding a Printer 

Perform the following to add a printer: 

1. While logged on as Administrator, click Printers. From the Manage 
Printers drop-down menu chose Add Printer.  

2. Type the Printer Name, Server Address, Printer Location, and 
Printer Description in the text boxes provided. Select and click Add 
Printer to save the printer data.  

3. On the Manage Printers drop-down menu, click View Printers. 

Verify that the added printer is displayed according to the definition 
just supplied. If unsuccessful, please note the observed system 
response. 

__________________________________________________________  

__________________________________________________________  

1.3 Editing the User Interface Using Admin Tools 

Perform the following to edit the user interface using the Admin 
tools: 

1. Move to the Web Document Submission server and restore the XDX 
Control Center screen. 
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2. Click Tools > UI Config. From the Configure Colors drop-down 
menu, select Main Page Text Color. 

3. In the Current Color text box type:  

#0000ff 

4. Click Commit Changes and type the Admin Username and Password 
if requested.  

5. Open a web browser to verify that, after logging on, the welcome 
message has blue text. 

6. Change the Current Color for the Main Page Text Color back to: 

#000000 

7. Click Commit Changes and type the Admin Username and Password 
if requested. 

8. Click C:\xdx\scripts\xwdss-shutdown.bat. Close the XDX Control 
Center. 

9. Click C:\xdx\scripts\xwdss-startup.bat to restart Web Document 
Submission and return to the Home page. 

Verify that the changes were saved and UI updates are visible on the 
affected web pages. If unsuccessful, please note the observed system 
response. 

__________________________________________________________  

__________________________________________________________  
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2. Client Verification Procedures 

The Client verification procedures exercise the major end user functions 
of Web Document Submission.  

2.1 Registering a Client Account – Self Registration 

Perform the following to register a client account: 

1. Open a browser window on a workstation connected to the network, 
or one of the Web Document Submission servers. 

2. In the address line, type the IP address for the Web Document 
Submission server: 
 
http:// <Web Document Submission server IP address>/xdx 

3. Click Self Registration. 

4. Type a user name and a valid e-mail address. To send the registration 
request click Continue. 

5. In the Temporary Password field, type the temporary password 
provided on the system generated e-mail. 

Note: The temporary password will be e-mailed to the address entered 
in step 4. The password can also be located at the end of the 
Tomcat window in the XDX Control Center. 

6. In the New Password and the Verify Password fields, type a new 
password. 

7. To log on to Web Document Submission click Finish. 
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Verify that a system-generated e-mail was sent to the registering end 
user containing the assigned system password. If unsuccessful, 
please note the observed system response. 

__________________________________________________________  

__________________________________________________________  

2.2 Logging on as a User 

Perform the following to log in as an end user: 

1. Close the browser window from procedure 2.1. Open a new browser 
window. 

2. In the address line, type the IP address for the Web Document 
Submission server: 
 
http:// <Web Document Submission server IP address>/xdx 

3. Type the user name registered in procedure 2.1. 

4. Type the registered password in the Password box. Click Log On. 

Verify that the log on was successful. If unsuccessful, please note 
observed the system response. 

__________________________________________________________  

__________________________________________________________  
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2.3 Editing a User Profile 

Perform the following to edit a user profile: 

1. From the Home page, click User Profile.  

2. Fill in or modify User Profile fields for the user.  

3. Click Update Profile. Click Finish to save the updates. 

Verify that the user profile updates were successful by clicking Log 
Off, logging back on as the same user, and selecting User Profile 
from the menu. If unsuccessful, please note the observed system 
response. 

__________________________________________________________  

__________________________________________________________  

2.4 Submitting a Print Job Request – MS Word Document 

Perform the following to submit an MS Word document print job 
request: 

1. From the User Home page, click Submit.  

2. Click Browse. Select any MS Word document and click Open.  

3. Click Next to upload the MS Word document to the repository on the 
Web Document Submission server. 

4. Type Test description in the Description text box. Click Next. 

5. The recipients for the job appear. Click Next.  
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6. Type These are special instructions in the Special Instructions 
text box. Click Next.  

7. The Verify your order window appears. Review the order and then 
click Submit Order. Wait for the screen to refresh. 

8. Record the Job ID for this job. This Job ID will be required for test 
procedure 3.2. Click Finish 

Verify that the submitted job was successful. If unsuccessful, please 
note the observed system response. 

__________________________________________________________  

__________________________________________________________  

2.5 Submitting a Print Job Request – MS Excel Document 

Perform the following to submit an MS Excel document print job 
request: 

1. From the User Home page, click Submit.  

2. Click Browse. Select any MS Excel document and click Open.  

3. Click Next to upload the MS Excel document to the repository on the 
Web Document Submission server. 

4. Select any print options for this document job. Click Next. 

5. The recipients for the job appear. Click Next.  

6. Type These are special instructions in the Special Instructions 
text box. Click Next.  

7. The Verify your order window appears. Review the order and then 
click Submit Order. Wait for the screen to refresh. 
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Verify that the submitted job was successful. If unsuccessful, please 
note the observed system response. 

__________________________________________________________  

__________________________________________________________  

2.6 Submitting a Print Job Request – Hard Copy Document 

Perform the following to submit a hard copy document print job 
request: 

1. From the User Home page click Submit. 

2. Click Hard Copy. 

3. Select the print options for this document. Click Next. 

4. The Choose recipients for this job window appears. Click Next. 

5. Type These are special instructions in the Special Instructions 
text box. Click Next.  

6. The Verify your order window appears. Review the order. 

7. Click Submit Order to submit the print job order to the print shop. 
Wait for the screen to refresh. 

Verify that the submitted job was successful. If unsuccessful, please 
note the observed system response 

__________________________________________________________  

__________________________________________________________  
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2.7 Editing the Personal Address Book 

Perform the following to edit the Personal Address Book: 

1. From the User Home page, click Personal Address Book. 

2. Click Add User.  

3. Fill in the fields with an imaginary user. When finished click Add User. 

Verify that the new address was successful saved by clicking the 
name link of the user just added. Ensure the edits made were saved. 
If unsuccessful, please note the observed system response. 

__________________________________________________________  

__________________________________________________________  

2.8 Editing the Document Repository 

Perform the following to edit the Document Repository: 

1. From the User Home page, click Repository. 

2. Select a document from the repository. Select Extend. Click Delete 
or Extend Document. 

Verify that the document selected for extension was extended from 
the repository. Typically, since there is just one document in the 
repository from these tests, the number of days remaining should not 
change. If unsuccessful, please note the observed system response. 

__________________________________________________________  

__________________________________________________________  
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3. Operator Verification Procedures 

The Operator verification procedures test the major functions of an 
Operator using Web Document Submission.  

3.1 Logging on as Operator 

Perform the following to log on as Operator: 

1. Open a browser window on a workstation connected to the network. 

2. In the address line, type the IP address for the Web Document 
Submission server: 
 
http:// <Web Document Submission server IP address>/xdx /admin 

3. Type operator in the User Name text box. 

4. Type the operator password 22222 in the Password text box and click 
Log On. 

Verify that the log on was successful. If unsuccessful, please note the 
observed system response. 

__________________________________________________________  

__________________________________________________________  
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3.2 Editing a Client Job Request – MS Word Document 

Perform the following to edit an MS Word document client job 
request: 

1. From the Operator Home page locate the Job ID of the MS Word 
document previously submitted. 

2. From the Options drop-down menu, choose Edit Job. Make some 
type of change to the job. 

3. Click Submit Edits. The screen refreshes. Click Finish. 

4. From the Options drop-down menu, choose Inspect Job. 

Verify that the job properties were updated. If unsuccessful, please 
note the observed system response. 

__________________________________________________________  

__________________________________________________________  

3.3 Fulfilling a Client Job Request – MS Word Document 

A printer must already be added to the Web Document Submission 
system and the installer logged in as Administrator for this test to work. 

Perform the following to fulfill an MS Word document client job 
request: 

1. Using the job just edited in 3.2, from the Options drop-down menu, 
choose Print Job. 

2. Under Print Full Job, select a printer from the drop-down menu. 
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3. Clear the Skip Job Ticket checkbox and click Print. 

4. Click Job Status. Select Succeeded from the Change Status to: 
drop-down menu. 

5. Click Submit to update the job status. 

6. Click Set Page Count to confirm status change and update the page 
count if necessary. 

7. Click Job Status Page. 

Verify that the Job Status is Succeeded. If unsuccessful, please note 
the observed system response.  

Note: If e-mail notification is activated, verify that the end user received 
an e-mail notification of job completion. 

__________________________________________________________  

__________________________________________________________  

3.4 Fulfilling a Client Job Request – MS Excel Document 

Perform the following to fulfill an MS Excel document client job 
request: 

1. Using the job just edited in 3.2, from the Options drop-down menu, 
choose Print Job. 

2. Under Print Full Job, select a printer from the drop-down menu. 

3. Clear the Skip Job Ticket checkbox and click Print. 

4. Click Job Status. Select Succeeded from the Change Status to: 
drop-down menu. 

5. Click Submit to update the job status. 
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6. Click Set Page Count to confirm status change and update the page 
count if necessary. 

7. Click Job Status Page. 

Verify that the Job Status is Succeeded. If unsuccessful, please note 
the observed system response.  

Note: If e-mail notification is activated, verify that the end user received 
an email notification of job completion. 

__________________________________________________________  

__________________________________________________________  

3.5 Fulfilling a Client Job Request – Hard copy Document 

Perform the following to fulfill a hard copy document client job 
request: 

1. From the Operator Home page, locate the Job ID of the hard copy 
document previously submitted. 

2. From the Options drop-down menu, click Inspect Job. 

3. Click Edit job ticket to examine the job options selected for the hard 
copy document. 

4. Print the job according to the client print request. 

5. On the Web Document Submission Operator page click Job Status. 
Select Succeeded from the Change Status to: drop-down menu. 

6. Click Submit to update the job status. 

7. Click Set Page Count to confirm status change and update the page 
count if necessary. 
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8. Click Job Status Page. 

Verify that the Job Status is Succeeded. If unsuccessful, please note 
the observed system response.  

Note: If e-mail notification is activated, verify that the end user received 
an e-mail notification of job completion. 

__________________________________________________________  

__________________________________________________________  

3.6 Sending a Job to Each Installed Printer 

Perform the following to send a job to each installed printer: 

1. From the Operator Home page, locate any Job ID with status of 
Received in Print Shop. 

Note: If there is no job with the status of Received in Print Shop, 
change the status of any job to Received in Print Shop. 

2. From the Options drop-down menu, click Inspect Job to view the job 
properties. 

3. Click Print Job. 

4. Under the heading Print Full Job, select a printer from the  
drop-down menu. 

5. Click Print to send the job to the selected printer.  

6. Repeat steps 4 and 5 for each installed printer. 

7. Click Job Status. Select Succeeded from the Change Status to: 
drop-down menu. 

8. Click Submit to update the job status. 
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9. Click Set Page Count to confirm status change and update the page 
count if necessary. 

10. Click Job Status Page. 

Verify that the job was successful and all printers could print job requests. 
If unsuccessful, please note the observed system response. 

__________________________________________________________  

__________________________________________________________  

Install Verification Record 

Use the following section to record results of the installation verification 
procedures. Comments concerning failure observations are recorded at 
the bottom of each procedure the previous section. 

Results 

Record results using the following tables. Describe what is observed if a 
procedure fails. 
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Administrative Functions 

Test results for Administrative functions are recorded in Table A-4. 

Table A-4. Administrative functions and test procedures 
Function Test 

Procedure 
Results 

P – Pass or F – Fail 

Log on as Administrator 2.1.1  

Add Printers (Default and others in print shop) 2.1.2  

Edit User Interface Using Admin Tools 2.1.3  
 

Client Functions 

Test results for Client functions are recorded in Table A-5. 

Table A-5. Client functions and test procedures 
Function Test 

Procedure 
Results 

P – Pass or F – Fail 

Register Your Account 2.2.1  

Log on as End User 2.2.2  

Edit User Profile 2.2.3  

Submit Print Job Request – MS Word 
Document 

2.2.4  

Submit a Print Job Request – MS Excel 
Document 

2.2.5  

Submit a Print Job Request – Hardcopy 
Document 

2.2.6  

Submit a File Conversion Job Request – PDF 2.2.7  
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Table A-5. Client functions and test procedures (continued) 
Function Test 

Procedure 
Results 

P – Pass or F – Fail 

Submit a File Conversion Job Request – 
PostScript 

2.2.8  

Edit Personal Address Book 2.2.9  

Edit Document Repository 2.2.10  

Operator Functions 

Test results for Operator functions are recorded in Table A-6. 

Table A-6. Operator functions and test procedures 
Function Test 

Procedure 
Results 

P – Pass or F – Fail 

Log on  as Operator 2.3.1  

Edit a Client Job Request – MS Word 
Document 

2.3.2  

Fulfill a Client Job Request – MS Word 
Document 

2.3.3  

Fulfill a Client Job Request – MS Excel 
Document 

2.3.4  

Fulfill a Client Job Request – Hard copy 
Document 

2.3.5  

Send a Job to Each Installed Printer 2.3.6  
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